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Logic Reference
Recent years have seen a revolution in the use of 
personal computers for creating music.

Music projects that until recently would have required an array of professional studio 
equipment can now be completed in a home or project studio, using a personal 
computer and readily available resources. A personal computer with a fast processor 
and enough RAM can now serve as a workstation for recording, arranging, mixing, and 
producing complete music projects, which can be played back on the computer, 
burned on a CD or DVD, or distributed over the Internet.

What Is Logic?
Logic is an integrated system for composing, producing, and scoring music, built 
specifically for Mac OS X. Musicians can create professional sounding original music 
compositions, royalty-free soundtracks for Final Cut Pro video projects, and more.
Logic allows you to build musical arrangements using MIDI and software instruments 
alongside audio recordings of acoustic instruments, vocal performances and 
prerecorded audio files.
You can freely combine and arrange loops plus MIDI and software instrument parts in 
Logic’s Arrange window, add professional-quality effects, mix your music in stereo, and 
export the final mix to a standard audio file or an audio CD that can be played on any 
multimedia-equipped computer, home stereo or imported into Final Cut Pro or other 
applications.

Logic includes the following features, amongst many others:
• Record MIDI information via connected MIDI input devices, such as keyboards, and 

play back this information via any connected MIDI device or Logic’s integrated 
software instruments.

• Create, arrange, and edit MIDI projects, and print out musical notation via a printer 
connected to your computer.

• Digitally record acoustic and electric instruments or vocal performances into your 
projects, and process these audio recordings with Logic’s in-built real-time effects.
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• Make use of the integrated software instruments, including:  ES1 and EXS24 or third-
party Audio Unit instruments.

• Load songs or channel strips from Apple’s GarageBand application, and edit them, 
making use of the additional processing and editing possibilities afforded by Logic.

• Mix your MIDI and audio tracks, including effects and software-based instrument 
settings, via a sophisticated total recall mix automation system. Logic includes high-
quality effects plug-ins that you can use in your projects. You can also install third-
party effects in the Audio Units plug-in format.

• Bounce all audio data, including effects and mix automation settings, to a stereo file 
for mastering or further processing.

• Work in real time:  You can work on Logic projects in real time, adding, and editing 
audio and MIDI parts while the project is playing, and hear the results of your 
changes immediately.

• Use existing loop libraries:  Logic directly supports Apple Loop files, and is 
compatible with a wide variety of existing audio file types, including those created in 
ReCycle.

• Locate and preview files easily:  The Apple Loop Browser, part of the Logic interface, 
provides powerful file browsing and search features, making it easy to locate loops 
by instrument, genre, mood, or other search criteria.

• Mix Apple Loops recorded at different tempos and keys:  Logic automatically 
matches loops to the project tempo and key, allowing you to freely combine loops 
from different sources in a single project.

About This Manual
This book is the final arbiter on all things in Logic, and covers all areas of the program 
in detail.

You will find descriptions of the most essential aspects of Logic’s interface, commands, 
and menus in the Using Logic chapter. These descriptions are often paired with 
instructions or examples for accomplishing specific tasks. 

Chapter 2 discusses the use of Logic’s Transport functions and covers the navigation of 
your Logic projects. 

The following chapters will provide you with an overview and complete description of 
all parameters and functions available in each of Logic’s editing and file handling 
windows. You will learn how to make use of the arranging, recording, and editing 
facilities available—for MIDI and audio data—in these chapters.

Later chapters discuss mixing, automation, and Logic’s preferences, Song settings and 
synchronization options. 
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The Onscreen Help system—accessible from Logic’s Help menu—is fundamentally the 
Reference Manuals in electronic form. It has the advantage of being at your fingertips 
when you need it, and is also searchable.

Even if you’re the type who just doesn’t like reading manuals, we ask that you read the 
next section. It will provide you with essential information on the basic operation of 
Logic’s interface.

Please note that all topics described herein were accurate at the date of printing. For 
up to date information on changes or additions made after printing, please refer to the 
Late Breaking News on the Logic DVD, and/or to the Update Info, included with each 
Logic update. 

Conventions of This Manual…
Before commencing, we’d like to cover the following conventions used in this manual.

Menu Functions
For functions that can be reached via hierarchical menus, the different menu levels are 
described as follows:  Menu > Menu entry > Function.

Important Entries
Some text will be shown as follows:

Important:  Information on function or parameter.

These entries discuss a key concept or technical information that should, or must, be 
followed or taken into account. Please pay special attention to these entries.

Notes
Some sections provide additional information or tips that will assist your use of Logic. 
These are displayed as shown below:

Note:  Information on function or parameter.

Key Commands
Many Logic functions can be activated or accessed with key commands—computer 
keyboard shortcuts. The key commands mentioned in this guide are based on the 
standard Key Command Set, assigned by the Logic Setup Assistant. Where possible, we 
have also included the standard Key Commands for PowerBook users. These are based 
on the PowerBook Key Command Set, assigned in the Logic Setup Assistant.
Preface    Logic Reference 11
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1 Using Logic
The following chapter will guide you through Logic’s basic 
interface elements, file handling options and common input 
techniques.

You will also learn about a number of shortcuts and features that will accelerate your 
workflow, and assist you while learning about Logic.

Using the Mouse
The mouse can be used in the following ways in Logic:  

Clicking
Place the mouse pointer on the object (button, input field and so on) and press the 
mouse button once.

Double-Clicking
The same as clicking on an object, but you press the mouse button twice, in quick 
succession. You can set a suitable interval between clicks in the System Preferences 
(Keyboard and Mouse pane).

Grabbing or Clicking and Holding
The same as clicking on an object, but you keep the mouse button held down.

Moving or Dragging
Grab the object, and move the mouse (keeping the mouse button held down) to the 
desired position.

Mouse Wheel Events
You can use the mouse wheel to scroll vertically in Logic. There are also some modifiers 
supported:
• If you press Command, the mouse wheel can be used to scroll horizontally.
• If you press Option, the mouse wheel can be used to zoom in/out vertically.
• If you press Option-Command, the mouse wheel can be used to zoom in/out 

horizontally.
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• If you press Option-Control, the mouse wheel can be used to zoom in/out in both 
directions.

Note:  Logic also supports mice with two wheels. The second wheel works like the first 
wheel, but with interchanged axes.

Input Options
This section discusses the various methods available for interaction with parameters, 
and data entry tasks.

Mouse Input
Checkboxes

Checkboxes are square boxes that are “checked” when you click them, in order to 
activate an option (or function). Click the checkbox a second time to remove the 
“check”, and deactivate the option.

Pull-Down Menus

Pull-down menus open when you click-hold on certain input fields or buttons. You can 
select a function from within such menus by highlighting the desired item with the 
mouse, and releasing the mouse button. If you wish to select an item that is outside 
the visible section of the menu,
• move the mouse over the top or bottom edge of the menu; the further you move it, 

the faster you will scroll through the menu.
• hold down Shift as you do this. You can then release the mouse button, and use the 

scroll bar to the right of the pull-down menu to browse. When the mouse reaches 
the entry you wish to use, release Shift.

Mouse as Slider
You can set most numerical parameters (even note values or names) by grabbing the 
parameter value, and moving the mouse up or down. If the parameter consists of 
several separate numbers (song position, for example), you can adjust each number 
individually using this method.
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Using the Mouse for In/Decrementing
Nearly all parameter values that can be set using the mouse as a slider (and even some 
of the pull-down menu parameters) may also be increased or decreased in single units 
by clicking on the top or bottom half of the value, while holding down Control.

Numerical Input

Double-clicking on a numerical parameter value opens an input field. The existing 
value is highlighted, and ready to be overwritten by a new entry. You can also use the 
mouse to make a partial selection in an input field, so that only the highlighted part is 
overwritten. As long as the input field is open, the computer keyboard may only be 
used for data entry, and may not be used for key commands (with the exception of the 
main menu functions).

Arithmetical Operations
You can enter numbers at any time by typing in an arithmetical operation:  “+2” or “−5”, 
for example, which changes the current value by/to that amount.

ASCII Code
You can also input numbers as ASCII code:  just place a ` or " in front of the selected 
key, and the ASCII code will be input as a number. As an example:
• "! results in a value of 33
• "a results in a value of 97

This function is particularly useful for entering text in SysEx strings.

Cancel Numerical Input
Direct numerical input can be canceled by entering no text at all and pressing Enter or 
Return.
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Text Input
You can input text names in the same way as numbers, but you only need to click a 
name field once to allow input. You can directly click on an object with the Text tool to 
rename it.

Numbered Names
Any number of selected Objects or Regions can be assigned same name. If the name 
ends with a number, this number will automatically be incremented by 1 for each 
subsequent Object or Region. This allows you to quickly, and uniquely, name all of the 
Regions on a track or all of the Fader Objects in the Environment, as examples.

Note:  To turn off automatic numbering, place a space after the number at the end of 
the Object or Region name. All selected Objects and Region will then end in the same 
number.

Tools and the Toolbox
Logic allows recorded data to be handled graphically. This means that you don’t need 
to input instructions in command lines in order to perform operations, but rather, do so 
by manipulating graphical “objects”. This is done with the help of Tools (see “The Tools” 
on page 18). Each edit window provides different Toolboxes that are suitable for the 
tasks performed in the editor.

The Arrange window Toolbox looks like this:

When editing objects graphically, you always have two tools available at the mouse 
pointer position:  one is already active, the other is activated by holding down 
Command.
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You can change the currently active tool by clicking on another tool in the Toolbox. The 
mouse pointer then adopts the shape of the tool you clicked on, allowing you to 
instantly identify the active tool by looking at the cursor graphic:  the Eraser is used for 
deleting, the Scissors for cutting and the Glue Tool for merging Regions, as examples. 
To assign a tool to Command, click on the desired tool in the Toolbox, with Command 
depressed.

If you have a suitable mouse, you can also assign the right mouse button to a third 
tool, allowing the use of three assignable tools:  
• left-click
• Command- (left) click 
• right-click

Note:  You can also assign the Toolbox to the right mouse button with the Global > 
Editing > Right Mouse Button Opens Toolbox preference. This allows you to open the 
Toolbox at the mouse cursor position by right-clicking anywhere in the working area of 
the open window.

Tools are only effective in the working area of the window in which they were selected. 
You can define individual tools for each opened window.

A tool (the Scissors, for example) basically affects the Objects or Regions that you click 
on. If multiple Objects or Regions are selected, they will all be affected by the tool (the 
Scissors would cut all selected Regions at the same song position, for example).

Note:  The Toolbox can be hidden in the Arrange and Score Editor windows to save 
onscreen space, which can be very helpful if you only have a small monitor. The 
function is accessible via the View > Toolbox menu option.

Selecting Tools
You select the tool you wish to use by clicking on it (with the left or right mouse 
button) in the Toolbox (or clicking while holding down Command for the alternate 
tool).

Note:  You can use the Set next Tool and Set previous Tool key commands to switch to 
the neighboring tool in the top window.

Opening the Toolbox at the Mouse Position
Use the Show Tools key command (default:  Esc) to open a Toolbox at the mouse 
position. When a Toolbox is opened at the mouse position, you can also use one of the 
number keys to select a tool. The tools are always numbered from left to right and top 
to bottom. Press the Show Tools key command a second time to switch to the pointer, 
and close the Toolbox.
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Using Key Commands
Each tool can be selected via a specific key command. Key commands that switch to a 
specific tool toggle between this tool and the previously selected tool.

The Tools
Here are two example Toolboxes, which contain most of the tools available in Logic:

Arrange Toolbox

Score Toolbox

All tools, including a number of tools not displayed in the images, are described below. 
As mentioned earlier, some tools are specific to certain editing windows.

Pointer
The Pointer is the default tool. The mouse also takes on this shape outside the working 
area when making a menu selection or inputting a data value. Within the working area, 
the pointer is used for selecting (by clicking on Objects or Regions), moving (by 
grabbing and dragging), copying (by holding down Option and dragging), and editing 
lengths (by grabbing the bottom right corner and dragging). Grabbing and dragging 
anywhere on the window background activates a “rubber band”, that allows the 
selection of multiple Regions or Objects.

Note:  When changing the lengths of multiple Regions, you can make all lengths equal 
by holding Shift-Option.

Pointer

Mute tool

Solo tool

Pencil

Eraser

Scissors

Text tool

Magnifying Glass (Zoom tool)

Crossfade tool

Glue tool

Pointer

Mute tool

Solo tool

Pencil

Eraser

Voice Splitter

Magnifying Glass

Sizer tool

Quantize tool

Glue tool

Scissors

Layout tool

Camera tool

Text tool

Velocity tool
Chapter 1    Using Logic



    

 

                  
Pencil
The Pencil is used to add new Regions. You can also select, drag, and alter the length of 
Regions while the Pencil tool is active.

Scissors
The Scissors tool is used to split Regions, allowing individual sections to be copied, 
moved or deleted.

Text Tool
The Text tool is used to name Regions, or add text to a musical score.

Layout Tool
The Layout tool is used to graphically move events in the Score Editor, in order to 
optimize the display (bars to lines:  “Local Formatting”, for example), without altering 
the timing of the actual MIDI events.

Size Tool
The Size tool is used to adjust the size of graphic elements in the score. It looks similar 
to the bottom right corner of a Mac window, which is also used for resizing tasks.

Magnifying Glass
The Magnifying Glass allows you to zoom in on a “rubber-banded” section, up to the 
full window size. You can revert to the normal zoom level by clicking on the 
background with the tool. You can also access this function when other tools are 
selected by holding down Control.

Solo Tool
Click-holding on a Region with the Solo tool allows you to listen to the selected 
Regions in isolation during playback. Moving the mouse vertically also outputs any 
events the cursor touches, even when the sequencer is stopped.

Mute Tool
Clicking on a Region with the Mute tool prevents it from playing. A dot is placed in 
front of the Region name (and the Region is shaded if the Preferences > Display > 
Arrange > Muted Regions are textured preference is active), to indicate that it is muted. 
You can unmute the Region by clicking on it again with the Mute tool. If multiple 
Regions are selected, the setting of the clicked Region applies to all selected Regions.

Finger Tool
The Finger is used to alter note lengths in the Matrix Editor. 

Eraser Tool
The Eraser deletes selected Regions and Objects. When you click on an Object or 
Region with the Eraser, all of the currently selected Objects and Regions are deleted (as 
if you had used Backspace). 
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Glue Tool
The Glue tool performs the reverse operation of the Scissors tool. All selected Regions 
are merged into a single Region, which is assigned the name and track position of the 
first Region on the time axis.

Crosshair Tool
The Crosshair is used to input a linear series of MIDI events in the Hyper Editor.

MIDI Thru Tool
Clicking on an instrument in the Environment with the MIDI Thru tool assigns the 
instrument to the selected track in the Arrange window, thereby making it the active 
MIDI Thru instrument.

Voice Splitter Tool
You can separate polyphonic voices onto different staves in the Score Editor by 
drawing a dividing line with the Voice Splitter tool (provided you are using a 
polyphonic score style).

Camera Tool
The Camera tool is used to select, and export, sections of the Score Editor display as 
graphics files.

Quantize Tool
The Quantize tool is used to correct the timing of MIDI note events in the Matrix and 
Score Editors.

Velocity Tool
You can use the Velocity tool to change the velocity of notes in the Matrix and Score 
Editors.

Help Tags
A help tag appears just below the mouse cursor position—for as long as the mouse 
button is held down—when using many of the tools. The help tag provides useful 
feedback about the type of operation you are performing.

Important:  You must enable the Preferences > Display > Show Help Tags option in order 
to view help tags during editing operations. 

During operations involving Regions, the help tag will look something like this:

From left to right (and from top to bottom), the values indicate:  (name of ) operation, 
mouse (or Region) position, Region name, track number, and length of the Region.
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During operations involving events, the help tag looks something like this:

 

From left to right, the values indicate:  (name of ) operation, mouse (or event) position, 
event type, event MIDI channel, first data byte (note pitch, for example), second data 
byte (note velocity, for example), and event length (note length, for example).

Window Functions
The basic functions of the Logic windows are the same as those in other Macintosh 
applications. The display options available in Logic’s windows are far more extensive, 
however, than those of other programs.

In Logic, you can open different combinations of windows (even several of the same 
type) and adjust each one individually. All open windows in a song are constantly 
updated. This means that the windows update to follow the song position, and any 
alterations made in one window immediately update the display of all other windows 
you are working with. It is also easy to save different window arrangements (called 
“Screensets”), and recall them with the push of a button.

Working With Windows
Opening Windows
All Logic windows can be opened from the Windows menu. The corresponding key 
command (Open Arrange, Command-1, for example) is displayed beside each menu 
item, allowing you to open the window without using the mouse. You can open as 
many of the same type of window as you like.

The Toggle … Window key commands allow you to define one key command to:
• bring an open window (of an assigned type) to the front,
• open a window of the assigned type,
• close a window of the assigned type, if it is in front (the active window).

Setting Window Size
You can adjust window size by dragging the lower right-hand corner of the window, as 
with any window in the Finder.
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Window Buttons

The three buttons found at the top left of all windows (except the Transport) perform 
the following operations:
• Left button (black dot):  closes the window.
• Center button (minus sign):  minimizes the window, and places an icon on the Dock. 

The window can be restored by clicking on the icon in the Dock.
• Right button (plus sign); resizes the window to the maximum screen size. A second 

click on the icon will restore the original window size.

Moving Up One Level in the Display Hierarchy
Clicking the button featuring the square graphic (Up One Display Level button—or 
UDL button) in the top left corner of the window takes you to the next (higher) display 
level.

Note:  Double-clicking on the background of the edit area of a window also takes you 
to the next highest display level.

Display Levels in the Editors
Normally, the editors are at the lowest display level, which shows individual events. 
Clicking the UDL button, at the upper left corner of the editor window, allows you to 
move up one level in the hierarchy. As an example, if you are currently looking at the 
events in a MIDI Region inside a folder, the display will switch to a view of the MIDI 
Region in the parent folder.
In the Matrix and Hyper Editors, this step up the display hierarchy means that you will 
then see an Arrange window. In this scenario, a change to the lowest display hierarchy 
level will cause the relevant editor to reappear. At the Arrange level, you will see the 
local menus of the Matrix or Score Editors, which also contain all of the Arrange 
window functions. Double-clicking on a MIDI Region opens the Hyper, Matrix, Score 
Editor, or Event List display of the contents of the MIDI Region. Use of this facility, in 
conjunction with the UDL button allows you to quickly switch to another MIDI Region, 
and edit its contents.
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Clicking the UDL button in the Event List moves you up one level in the hierarchy, just 
like the other editors. In the Event List, however, the form of the display remains the 
same but instead of a listing of individual events, you’ll see a list of Regions—along 
with their position, name, track number, and length. The MIDI Region that you were 
just editing will be selected in the list of Regions.

Once again, double-clicking on a MIDI Region (or using the Go Into Folder or Region key 
command) takes you back to the lowest display level, showing the contents of the MIDI 
Region.

Double-clicking on an Audio Region opens the Region in the Sample Editor. 

In the Score Editor, clicking on the UDL button, or double-clicking on the background 
takes you to the higher display level. Unlike the other editors, individual events can also 
be edited while in higher display levels in the Score Editor. Double-clicking on a staff (at 
an empty point), takes you back to a lower display level.

Selecting the Working Area
The scroll bars are situated at the right and bottom edges of a window, if you can only 
see a portion of the total working area in either the vertical or horizontal dimension.

You can move the visible section by clicking the arrows, or grabbing and dragging the 
scroll slider. There are two points of note:  
• The size relationship of the scroll slider to the entire scroll bar corresponds to the size 

of the visible section of the window, in relation to the overall window size.
• The visible section changes as you move the scroll slider.

The X/Y scroll element is situated at the bottom left corner of the window. By grabbing 
and dragging it, you can move the horizontal and vertical window section, as if you 
were dragging both scroll bars simultaneously. When the cursor hovers over the X/Y 
scroll element, a crosshair icon with four arrowheads is displayed. 

You can also engage the X/Y scroll feature by holding down a third button (the mouse 
wheel button, for example), and moving the mouse. The distance of the mouse pointer 
position from the initial clicked position determines the scrolling speed.

Note:  Touching the background of the Arrange Window while holding Shift-Control 
also allows you to scroll the window both horizontally and vertically.
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Use the Page Up, Page Down, Page Left, and Page Right key commands to scroll one 
page up, down, left, or right, as if you had clicked in the grey region (in the scroll bar) 
above/below the vertical scroll slider, or to the left/right of the horizontal scroll slider. 
The Page Top, Page Bottom, Page Left most and Page Right most key commands move 
the visible section of the working area to the top, bottom, left, or right, just as if you 
had grabbed one of the scrollers, and moved it to one of its extreme positions.

In the Arrange window, Event List, Hyper, and Matrix editors, View > Scroll To Selection 
allows you to move the visible window section to the first set of selected events. This 
function is available as a key command in the Arrange and Various MIDI Region Editors 
area. The key command works in the currently-active window.

Closing Windows
You can close windows by clicking on the close symbol at the top left. If you hold 
down Option as you click, all windows of the active song will be closed. Holding Shift 
while clicking closes all windows of all currently loaded songs.

Zooming
The Zoom sliders are used to zoom in and out of the working area display. Selection of 
different Zoom slider values reduces or increases the size of Objects and Regions in the 
displayed screen section, allowing you to see more Objects and Regions in the same 
space (zoom out) or a detailed display of fewer Objects and Regions (zoom in).

While zooming, the top-left selected Object/Region is kept in the visible area of the 
screen, whenever possible.

The horizontal Zoom slider is located to the bottom-left of the working area of the 
screen—in the Arrange window, it’s just under the Track List. 

The vertical Zoom slider is found at the top right of the active window. 
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Clicking on the more closely spaced bars will reduce the zoom level. Clicking on the 
widely spaced bars will increase the zoom level. You can click-hold and drag the Zoom 
sliders to step through several zoom levels. Any relative size differences between 
tracks/objects will be retained when zooming. Command-clicking in the left/right 
(horizontal) or top/bottom (vertical) half of the Zoom slider decreases/increases the 
zoom factor by one step.

Storing and Recalling Zoom Settings
You can store three different zoom settings for each window via use of the Save as 
Zoom 1–3 key commands. Use Recall Zoom 1–3 to recall your zoomed settings. These 
commands only apply to the top (active) window.

Zooming in on One Section of the Screen
To enlarge a section of the screen to fill the whole window, use the Magnifying Glass 
tool to drag a “rubber band” over the desired area. You can do this more than once.

Auto Track Zoom
The Arrange menu View > Auto Track Zoom function automatically enlarges the 
currently selected track. The track size can be manually set by dragging the lower left 
corner of any track in the Track List (the cursor will change to a “finger” icon).

Reverting to the Previous Zoom Setting
Click on the background with the Magnifying Glass. This will return the zoom level to 
the original setting, by backtracking through the previous steps. You can access the 
Magnifying Glass functions from any other tool (apart from the Pencil) by holding 
down Control. The pointer will display the active tool, until you press the mouse 
button. As long as the button is pressed, it will display the Magnifying Glass tool.

Window Elements
Adjusting the Size of the Window Elements
If you move the mouse over the top left corner of the Arrange area, the mouse pointer 
turns into a crosshair. By dragging it, you can adjust the size of the Bar Ruler, Arrange 
area, Track List, and Transport field buttons. You can also adjust the window elements in 
the Score, Hyper, and Matrix Editors using the same method.

Concealing/Revealing the Transport Functions
Use View > Transportto display or remove the Transport panel from the top left corner 
of the Hyper, Matrix, or Arrange windows. The number of buttons and indicators shown 
is dependent on the amount of available screen space.
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Concealing/Revealing the Parameters
The View > Parameters function allows you to display or remove the entire area (which 
contains the Region parameters, Instrument parameters, and the Toolbox) to the left of 
the Arrange, Environment, and other edit windows. Hiding these parameters provides 
more space for the editing window itself.

In many windows, you can hide and/or reveal further screen elements, such as the 
Toolbox. These display options are always available from the View menu.

Concealing/Revealing the Local Menu Bar and Scroll Bars
Command-Option-click on the window title bar to toggle the display of the local menu 
bar and scroll bars. This allows you configure small floating windows, which can be 
stored as part of a Screenset.

Resizing the Parameters Area
You can alter the size of the entire Parameters area in the Arrange, Score, Hyper, and 
Environment windows by moving your mouse cursor over the resize bars (the gray, 
vertical bar with the two vertical lines) between the Parameters area and the column to 
the right. As an example, the Arrange window’s Track List. The cursor appearance will 
change, allowing you to click and drag horizontally. As you do so, the Parameters area 
is resized, until the mouse button is released. The smallest “unit” of the resizing grid is 
the width of a tool in the toolbox.

This facility makes reading parameter names and labels clearer.

Menu Handling
Given Logic’s extensive range of data manipulation functions, it would be impractical 
to display all of them in the main menu bar. To ensure that only relevant functions are 
available in each editor, a local menu system is employed.
Logic’s menus are accessed in the same way as in other applications:  click-hold on the 
menu title, move the mouse over the desired item, and release the mouse button. In 
hierarchical menus, a right-pointing arrow is shown beside the item. If you highlight 
such an item, a sub-menu will be displayed to the right. To select an item from this sub-
menu, move the mouse to the right, into the sub-menu, and then move vertically over 
the desired item. Release the mouse button to activate the selected function.

Note:  A short click on any of the local menus will result in the menu remaining open, 
even after you have released the mouse button. A long click will result in the behavior 
described above.
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Window Types
There are two different types of windows in Logic:  normal windows and float windows. 
The contents of all windows that belong to the current song are always updated, 
regardless of type.

Normal Windows
You can open as many normal windows as you want, including several of the same 
type. Even though the contents of all windows are constantly updated, only one of the 
windows ever has the status of being the “top”, or “active” window. This is the window 
that is in the foreground when several normal windows overlap.

Topped, or active, windows can be recognized by a title bar that is not dimmed out, 
and black name. 

The illustration above shows the active, non-floating Arrange window

The main distinguishing characteristic of this window is that key commands only affect 
this window, and not any of the others. The Windows > Next Window menu function 
brings the next open window to the top, if it is fully obscured by other windows.

In background windows, you can not only observe changes, but make almost any kind 
of change, without having to bring the window into the foreground. To do so, simply 
long click on it. Background windows are identified by a white title bar (they can be 
positioned next to the top window, or tiled underneath it) and faded name. You can 
bring a window to the foreground by clicking on it, clicking on the title bar, or by 
accessing one of the local menu functions.
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Float Windows
Float windows are so named because they always “float” in the foreground, even above 
the topped normal window (if there are a lot of open float windows, they will 
inevitably cover each other up—just click on one to bring it to the foreground). 

The illustration above shows the Arrange window as float window.

Float windows are recognizable by their narrower, gray title bar. Mouse operations can 
be carried out in the same way as in normal windows.

The most common example of a float window is the Transport window. You can open 
any other window as a float window by holding down Option while selecting the 
desired edit window from the Windows menu.

Note:  Holding down Option while opening a window with a key command does not 
open the window as a float.

Relationships Between Windows
The two buttons at the top left of a window, determine its relationship to the song 
position (Catch), or to other windows (Link, Contents Link, or Contents Catch).

Catch
The Catch function ensures that the visible section of a window follows the song 
position as the song plays. 
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If the button featuring the walking man is lit, the window’s display follows the song 
position as the song plays. If the button is not lit, the display does not update, even 
when the song position line moves past the right edge of the visible portion of the 
window (Catch Clock Position).

Note:  If you move the visible section manually, Catch is automatically switched off, 
ensuring that the newly displayed section doesn’t then disappear.

The Catch when Sequencer starts (Preferences > Global > Catch) option enables Catch 
mode whenever you press Play or Pause.

Link, Contents Link, and Contents Catch
You can define these display options to control how information is displayed when 
working with related editor windows.

Link
When the button featuring the chain link icon is activated in a given window, this 
window always displays the same contents as the topped window. The display is 
adjusted whenever the selection in the topped window is altered. 

Here’s an example:  imagine the topped window is an editor. In Linked mode, the other 
editor windows can display the same data in another form (with the exception of the 
Arrange window, which does not display event data).

Here’s another example, using the Environment window; The top window is the 
Arrange window. In Linked mode, the Environment window will display the instrument 
that corresponds to the selected track in the Arrange window. As you switch tracks in 
the Arrange, the Environment will update to reflect the selection.

Contents Link
Double-clicking on the Link button activates Contents Link mode. This means that the 
window always shows the contents of the Region or Object selected in the top 
window. The display is therefore always one level below that of the top window. 

Here’s an example:  if the top window is an Arrange window, in Contents Link mode 
the editor windows can show the events of a selected MIDI Region. Selecting a 
different MIDI Region in the Arrange window will cause the display of the linked editor 
to switch to the newly-selected MIDI Region.
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You could also use Contents Link mode in an Arrange window, to display the contents 
of the folders in another Arrange window.

Contents Catch
By simultaneously switching on Catch and Contents Link, you activate Contents Catch 
mode. Initially, this is equivalent to Contents Link mode, but when the song position 
reaches the next Region on the same track, the contents of this Region are then 
displayed. 

You could use this mode in an Arrange window, much as you would in Contents Link 
mode. The editors would then show the events of whichever MIDI Region is currently 
being played on a track.

Screensets
Normally, you lay out your windows on the screen in a way that suits your working 
methods. This layout of various windows, including the display size, zoom, position of 
each window and other settings is called a Screenset, and can be stored. Once defined, 
you can freely switch between different Screensets, much as you might swap between 
different computer monitors.

Storing Screensets
Screensets are numbered from 1 to 99 (using only the 1 to 9 computer keys. The 0 key 
is used for the Stop command). You can see the number of the current Screenset 
beside the word Windows in the main menu. You don’t need to save Screensets with an 
explicit command. It happens automatically, as soon as you switch to another 
Screenset. Thus, without any effort, your current working view is always stored in the 
current Screenset.

Switching Screensets
Just input the number of the desired Screenset (1 to 9). For two-digit Screensets hold 
down Control while entering the first digit.

Protecting Screensets
Use the Lock/Unlock Current Screenset key command or Windows > Screensets > Lock 
Screensetmenu option to prevent the current Screenset from being altered. A • appears 
in front of the Screenset number to indicate that it is locked. Reuse the key or menu 
command (the default is Shift-L) to unlock the Screenset.

The File > New command deactivates all Screenset locks.
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Copying Screensets
To copy the current Screenset to a destination Screenset, hold down Shift when you 
switch Screensets. Two digit Screensets are copied by holding Shift-Control 1+1, …, 
9+9.

You can also use menu functions to copy Screensets via the Clipboard:  Switch to the 
Screenset you would like to copy, and select Windows > Screensets > Copy Screenset, 
then type in the Screenset number that you wish to copy to, and select Windows > 
Screensets > Paste Screenset.

You can also copy individual Screensets between different songs using this method. To 
import all Screensets from another song, please make use of the File > Song Settings > 
Import Settings option.

Reverting to a Stored Screenset
The Revert to Current Screenset key command resets your screen to its state prior to 
importing the current Screenset.

Recalling Screensets 1 to 9
Screensets 1 to 9 can be recalled by freely-defined key and MIDI remote commands, 
not only the number keys. This allows you to define the number keys for other 
purposes, such as toggling windows on and off, as described above. The 1 to 9 key 
commands are called Recall Screenset 1 (…9, respectively) in the Key Commands 
window.

Sequencer Controlled Screenset Switching
You can automatically switch Screensets through the use of meta event # 49—just add 
it to a MIDI Regionin the Event Editor.

To switch a Screenset automatically:
1 Set the song position to the point where you’d like the Screenset to change.

2 Hold down Command and click in the Event Editor on the button shown below.

3 The inserted meta event has a default value of 50 (Song Select).

4 Alter the number in the NUM column from 50 to 49. This changes the name to 
Screenset.

5 Input the desired Screenset number in the (VAL) column.

You can stop the switching by muting the MIDI Region that contains the meta 49 
event.
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Window Management Functions
The Windows > Tile Windows function tiles all open windows, and makes them all the 
same size. 

The Windows > Stack Windows function stacks all open windows on top of one another, 
so that at least a part of the title bar is visible for each window, no matter which is the 
foreground window at the time.

The Windows > Tile Windows horizontally function tiles all open windows, using all 
available horizontal space for each individual window (if possible).

Edit Operations
The local edit menus in Logic’s various windows all take the same form. The top two 
items are Undo and Redo. Below Redo are the typical Clipboard functions (see “The 
Clipboard” on page 32), and at the bottom of each are the main selection commands.

Undo
Undo allows you to reverse the previous edit. The default key command for Undo is 
Command-Z.

Multiple Undo and Redo
An unlimited number of editing steps can be undone. This also applies to the Redo 
function. You can determine the number of undo steps in the Preferences menu.

The Clipboard
The Clipboard is an invisible area of memory, into which you can cut or copy selected 
objects, allowing them to be pasted to a different location.

The Clipboard is universal, which means that it can be used to exchange objects 
between songs. 

Cut
All selected objects are removed from their current position, and placed on the 
Clipboard. The previous contents of the Clipboard are overwritten in the process (key 
command is Command-X).

Copy
A copy of all selected objects is placed on the Clipboard. The selected objects are left in 
place. Here too, the previous contents of the Clipboard are overwritten (key command 
is Command-C).

Paste
All objects from the Clipboard are copied into the top window. The Clipboard is not 
erased in the process (key command is Command-V).
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The contents of the Clipboard are added at the current song position (if they are events 
or Regions). The song position is incremented by the length of the pasted Region/
event(s).

In the Arrange window, the contents of the Clipboard are pasted to the selected track. 
If events are pasted into the Arrange window, either a new MIDI Region or Region is 
created, or the events are added to a selected MIDI Region. Any existing Regions 
remain unchanged.

In the Environment window, the Objects are pasted into the layer currently being 
displayed, at their original positions.

Clear
Any selected objects are erased. Clear has no effect on the Clipboard, and is 
functionally identical to pressing the Backspace key.

Selection Techniques
Whenever you want to perform a function on one or more objects, you first need to 
select the objecs. This applies equally to Regions, individual events or Environment 
Objects. Selected objects are either displayed in an inverted color scheme, or will flash 
(in the Score Editor).

An object selected in one window will also be selected in all other windows that 
display that object. Changing the top window doesn’t affect the selection (as long as 
you don’t click on the background, which deselects everything. Be sure to click on the 
window’s title bar).

Goto Selection Start/End
The Goto Selection Start/End key command moves the song position line to the location 
of the first/most recently selected event in the top window.

Selecting Individual Objects
Individual objects may be selected by clicking on them, and deselected by clicking on 
the background or by selecting another object.

You can also use the Select next/previous Region/event key commands (default:  right/left 
arrows, M/I in the Event List). Select first/last selects the first/last object of the currently 
displayed level.

Selecting Alphabetically
The Tab key selects the next alphabetical object. In the Arrange or Environment 
windows, pressing any letter key selects the first object with a name that begins with 
the chosen letter (as in the Mac’s Finder), provided that no key command is assigned to 
this key.
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Selecting Several Objects
To select several non-contiguous objects, hold down Shift as you click them. As 
subsequent objects or events are selected, the previous selections are retained. This 
also works with horizontal or rubber band selection.

Horizontal Selection
To select all Regions on a track, click on the track name in the Track List. In the same 
way, you can select all events (of a specified event definition) in the Hyper Editor, by 
clicking on the event definition name, or all notes of a certain pitch in the Matrix Editor 
by clicking the relevant key on the Matrix Editor’s keyboard.

In Cycle mode, the selection techniques covered above only affect events that fall 
within the Cycle area.

“Rubber-Banding”
To select consecutive objects, click on the background and drag a “rubber band” over 
them. All objects touched, or enclosed, by the rubber band will be selected.

Toggling the Selection Status
When you make any selection (including by rubber band or horizontal selection) while 
holding down Shift, the active selection status of the objects (events) will be reversed.

You can reverse the selection status of all objects (events) by using Edit > Toggle 
Selection. As an example of where this would be useful:  if you want to select all 
Regions in a song, with the exception of a few, first select the Regions that you don’t 
wish to use, and then Toggle Selection.

Selecting Following Regions/Events
To select all Regions/events after the currently selected one (or, if no Region/event is 
currently selected, to select all Regions/events after the song position line), use the Edit 
> Select all Following function.

Selecting Regions/Events Within the Locators (Vertical Selection)
Edit > Select Inside Locatorsselects all Regions/events lying wholly or partly inside the 
locator positions.
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General Functions of the Editors
Logic’s MIDI editors allow the editing of events (MIDI messages). Logic’s MIDI editors 
include the Score, Matrix, and Hyper Editor, Event List and Transform windows. 

Opening Editors
Double-clicking on a MIDI Region opens the Score Editor. There is a pull-down menu 
on the Preferences > Global > Editing page, which lets you select the editor that will be 
opened when you double-click on a MIDI Region. The options are:  the Score, Event, 
Matrix, and Hyper Editor.

Control Output via MIDI
Switching on the MIDI Out button causes MIDI events to be sent when they are added, 
selected, or edited. This allows you to audibly monitor every editing stage, whether you 
are scrolling through the Event List (automatic selection) or transposing a note. 

Deleting Events
The basic techniques are the same as those for deleting Regions:
• Backspace deletes all selected events.
• The Eraser also deletes all selected events, and any events that you click with it 

(whether previously selected or not).

Event and Note Quantization
The Event List and Matrix Editor have a separate quantization function, which can be 
applied to all selected events. Unlike quantization for MIDI Regions, event quantization 
applies to all events, not just notes. It irreversibly alters their positions (only notes can 
be returned to their original recorded positions).

Quantizing Events
Select the events that you want to quantize. Then open the pull-down Quantization 
menu by grabbing the Q button shown in the image (the Q button in the Matrix Editor 
looks slightly different).

This is identical to the pull-down menu found in the Region Parameter box, and 
contains its own quantization grid  (see “Quantization” on page 120). As soon as you 
select an item from the menu, all selected events are quantized.

Note:  You can only reverse note quantization. All other events are permanently shifted.
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To apply the same quantization value to another series of selected events (even in 
other editor windows), select Functions > Quantize Again, or click (quickly) on the Q 
button a second time.

Note Quantization
Normally, all notes in a MIDI Region are quantized in accordance with the Quantization 
parameter value chosen in the Region Parameter box

Reversing Note Quantization
Note events can be returned to their original record positions, or moved manually, by 
selecting the off setting in the Quantization menu. Alternately, you can click on the Q 
button while holding down Option.

You can also achieve the same result by selecting Functions > De-Quantize.

Key Commands
You can activate nearly all Logic functions with key commands or MIDI messages. The 
Key Commands window is used for the assignment of key commands to computer 
keyboard keys or to MIDI messages. 

Note:  A number of Logic functions are only available as key commands.

Whenever this manual mentions a key command, this refers to a function or option 
that can be accessed by either a computer keyboard keystroke (or keystroke 
combination) or a MIDI message. This allows you to completely customize Logic to suit 
your own working style.

Saving Key Commands
Your personal key assignments are stored in a separate Preferences file. You should:
• Make a backup of this file at another hard disk location.
• Make a backup on removable media (a CD-ROM, for example), in case you need to 

use Logic on another computer.

Whenever you install Logic updates, your personal key commands will remain 
unaltered.

Note:  Even the fixed global key commands of older versions are user-definable. Please 
keep in mind that some of these commands such as Undo, Save, Quit, New, Open, Cut, 
Copy, and Paste follow Mac OS X conventions, and probably shouldn’t be altered.
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Special Keys
Some keys have special functions:
• The Shift, Control, Option, and Command modifier keys can only be used in 

conjunction with other keys.
• The Backspace key has the fixed “delete selected objects” function. It can only be 

assigned to another function in conjunction with the modifier keys.
• The key combinations assigned to the options in the main menu bar cannot be 

reassigned. The relevant key commands are displayed after the main menu items.
• The plus and minus keys increase or decrease any selected parameter value in single 

units. They can be assigned different functions which override this behavior.

Key Commands Window
The Key Commands window can be opened by selecting Preferences > Key Commands.

All available key commands are listed on the left side. They are grouped according to 
various categories. The global key commands work regardless of which Logic window 
is currently active; the other commands require the corresponding window(s) to be 
topped. This allows you the assign the same key command to different functions in 
different windows.

A “•” in front of the description of the function indicates that the function is only 
available as a key command or MIDI command. To the right of the key command 
listing, you can see the currently assigned key, and below this, the assigned MIDI 
message (if applicable). 
Chapter 1    Using Logic 37



38

 

Key Commands List
In the list shown to the left of the Key Commands window, the following applies:
• Groups can be extended or collapsed by clicking on the disclosure triangle to the 

left.
• Columns can be changed in width by dragging the separating lines between the 

headers (Command, Key, MIDI, and so on)
• When the list has keyboard focus, physically pressing a key command (or key 

command combination) selects the appropriate function in the list. 
• If the triggered key command is located in a collapsed group, the group will 

automatically be expanded.

Options Menu

The Options menu offers:
• Import and Copy key command functions
• Expand/Collapse and Scroll to Selection functions for the Key Commands List 

window
• Several Initialize options

Importing Key Commands
This function is particularly useful if you need to work temporarily on someone else’s 
system; you might want to use your personal key assignments on it, without altering 
the other system’s settings.

The Options > Import Key Commands function allows you to import the key 
assignments from any Logic Preferences file. When selected, a file selector box allows 
you to browse any internal drive or removable media for the desired Logic Preferences 
file.

The existing Preferences file (on the target system) is automatically saved as a ∗.bak file. 
This file contains the old key commands.

Note:  You don’t need to restart Logic to begin using the new key command set.
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Printing a Key Command List
The Options > Copy Key Commands to Clipboard function copies the key commands into 
the Clipboard as text. From here, it’s a simple matter of pasting the results into any 
word processor, formatting as desired, and printing them out.

The Copy to Clipboard function also takes into account the Show and Find function 
settings (see below). You could, therefore, export a certain group of key commands 
(those containing a particular character string, for example). What you see in the 
window display is exactly what’s exported.

Initializing Key or MIDI Event Assignments
The Options > Initialize all Key Commands menu item initializes all key assignments.

The Options > Initialize all MIDI Commands menu item initializes all MIDI assignments. 
Once initialized, default assignments will be used.

Note:  You will lose your existing key command assignments if you make use of the 
Initialize functions, so ensure that you have created a copy of your Logic Preferences 
file before doing so.

Switching MIDI Remote On/Off

You can use the MIDI Remote checkbox to globally switch on/off responses to all 
defined MIDI messages. The MIDI command for this (Toggle MIDI remote) is always 
active, even when MIDI Remote is disabled, and is therefore always available.

If you have assigned MIDI Remote commands to all of the keys on your master 
keyboard, it’s advisable to use a second foot pedal or a programmable button on your 
keyboard for Toggle MIDI Remote. If no such facility is available, use a key you are 
unlikely to press by accident (the lowest or highest key, for example) during 
recording—but you will no longer be able to use this key to record notes.

The MIDI Remote checkbox also applies to MIDI events that are created with 
Transformer or Fader Objects in the Environment, and are routed to the Physical Input 
Object.

Valid MIDI commands are recognized, and filtered, by the Physical Input Object, 
because it makes no sense to record them.

Show Menu
You can use the Show menu to filter all the used, or unused key commands from the 
window display. All other Key Commands window functions remain available for use.
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Find Function
The Find field is used to find key commands by name or partial name:

• The search is performed as you enter text. There is no need to press the Return key. 
• The Cancel button to the right (that appears as soon as any text is entered) clears any 

entered text, and displays all key commands.
• The Find menu to the left (the magnifying glass) retains a history of recently used 

search terms. The Clear menu item erases the Find history.

Note:  The Find history is limited to searches that were completed with a press of the 
Return key. 

Key Command Properties
The box shown below displays the selected key command’s properties:

• Key:  the key’s name (or a negative number if it’s a scan code). This parameter cannot 
be edited.

• Modifiers:  the modifier keys which need to be held down in order to execute the key 
command function. These can be edited.

• Learn by Key Label:  enables you to teach Logic to use a particular key or key 
combination to perform a function.

• Learn by Key Position:  stores the code from the incoming key. This is different to the 
Learn by Key Label functionality in that a scan code allows you to use the number 
keys and plus/minus keys (above the keyboard and on the numeric keypad) for 
different functions. This also means that the key position remains the same if you 
switch between different operating system language settings or different keyboards. 
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MIDI

• The uppermost box, the Status menu, displays the type of MIDI message that is used 
for the key command.

• Channel:  Indicates the MIDI channel number of the incoming message. This 
parameter is disabled if the Status menu is set to unused.

• Data 1:  This field indicates the first MIDI data byte. As an example:  This field will 
show and allow the entry of a MIDI note value if the Status menu is set to Note.

• Data 2:  This field indicates the second MIDI data byte. It is disabled if the Status 
menu is set to anything other than Control Change or Poly Pressure.

• Learn MIDI button:  Enables you to teach Logic a particular MIDI command to perform 
a key command function. You must enable this button before Logic will accept any 
MIDI data for use as a key command trigger. 

Assignments 

This field displays the control surface assignment associated with the selected key 
command. It is only relevant when a control surface is used with Logic.

Each line displays:
• The name of the control surface, or the MIDI string if the assignment is from an 

unsupported control surface.
• The name of the control. If the name is shown in gray, this indicates that the 

assignment is currently inactive (because it is part of an inactive mode). 
• Zone and Mode that the Assignment belongs to, if applicable.

Note:  The display is updated when a Zone changes its Mode (when holding down a 
modifier button, for example).

Double-clicking on a row will show the assignment in the Controller Assignments 
Editor (see “The Controller Assignments Window” on page 500).
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The Learn New Assignment button allows you to “teach” Logic a new assignment for the 
selected key command. Click on the button, and use the desired control. 

Note:  If you wish to set up assignments for an entire control surface, be it supported or 
unsupported, make use of the Preferences > Control Surfaces > Learn Assignment for xxx 
function. This is discussed in detail in the Control Surfaces chapter of this manual (see 
“Customizing Control Surfaces” on page 498).

Assigning and Deleting Key Commands
This section discusses a number of Learn functions that allow you to assign particular 
computer keys or MIDI commands to Logic functions. Closing the Key Commands 
window automatically disables any active Learn button.

To assign a function to a key:

1 Activate the Learn by Key Label button.

2 Select the desired function with the mouse.

3 Press the desired key, along with the desired modifier keys (Shift, Control, Option, 
Command), if necessary.

4 If you want to make another assignment, repeat steps 2 and 3.

5 Deactivate Learn by Key Label Key

Learn by Key Positionworks in the same way, but differs in that it’s not just a reference to 
an ASCII code that is stored, but the actual code of the key that is pressed.

In practice, this means that you can, for example, assign different commands to the 
number keys on the numeric keypad and the number keys above the keyboard—and 
the same goes for the different plus and minus keys on the numeric keypad and main 
keyboard. 

The only disadvantage is that the key code (a number), rather than the ASCII symbol, is 
displayed in the Key Commands window. The ASCII symbol is more useful for reference 
purposes.

To clarify the difference between these two functions, here’s a short comparison:

If you use the Learn by Key Label function, and define only one key command for the 
key, it will be used, no matter which of the two keys (either plus key, for example) is 
pressed.

If you use the Learn by Key Position function, and define two key commands (one for 
the alphanumeric keyboard, one for the numeric keypad), then the appropriate key 
command will be used (one for each plus key, for example).
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To delete key assignments:
1 Activate the Learn by Key Label or Learn by Key Position button.

2 Use the mouse to select the function/key assignment that you want to delete.

3 Press Backspace.

4 To erase more assignments, repeat the second and third steps.

5 Deactivate the Learn by Key Label button.

To assign a function to a MIDI message:

1 Activate the Learn MIDI button.

2 Select the desired function with the mouse.

3 Send the desired MIDI message from your controller.

4 If you want to make another assignment, repeat steps 2 and 3.

5 Deactivate the Learn MIDI button.

Note:  If you want to assign a Note On message, remember to switch off Learn MIDI 
before you release the key in question (and thereby transmit a Note Off message). The 
assignment used is always the last message received.

To delete a MIDI assignment:
1 Activate the Learn MIDI button.

2 Use the mouse to select the function/assignment that you want to delete.

3 Press Backspace.

4 To erase more assignments, repeat the second and third steps.

5 Deactivate the Learn MIDI button.

To learn a controller assignment:
1 Activate the Learn Assignment button.

2 Select the desired function with the mouse.

3 Send the desired MIDI message from your controller.

Note:  The Learn Assignment button will be deactivated automatically when the entire 
message has been received. This avoids reception of the message sent by the device 
when you release the button. To ensure reliable reception, hold the button for a short 
period before releasing it.
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4 If you want to make another assignment, repeat steps 2 and 3.

Note:  If you wish to set up assignments for an entire Control Surface, be it supported 
or unsupported, make use of the Control Surfaces > Learn Assignment for xxx option. This 
is discussed in detail in the Control Surfaces section of the manual (see “Customizing 
Control Surfaces” on page 498).

Step Input
The Step Input functions allow you to insert MIDI notes when Logic is not in a realtime 
Record mode. This allows you to input notes that may be too fast for you to play, or 
may be useful if replicating sheet music, but you don’t sight read. You can use any of 
the following for step entry:
• a screen keyboard (Step Input Keyboard window)
• the computer keyboard
• MIDI

Notes are inserted in all modes at the current song position. All three methods can, and 
should, be combined to make full use of the features that each option offers. Here is an 
example:  you can set the note length in the Step Input Keyboard Window, insert notes 
via a MIDI keyboard and locate the Song Position Line using key commands.

Note:  It is also possible to enter note data in realtime with the computer keyboard (see 
“Caps Lock Keyboard” on page 49).

Step Input Keyboard Window
The Step Input Keyboard window can be opened via the main menu Windows > Step 
Input Keyboard. It allows you to insert notes in any MIDI editor.
Chapter 1    Using Logic



 

Key Commands
There is a set of key commands for the insertion of notes via the computer keyboard. 
To activate Step Input mode, the In button (see picture below) must be switched on in 
the selected MIDI editor.

This mode (and the In button) is available in the Event, Matrix, and Score Editor. You will 
find the relevant key commands in the Keyboard Input section of the Key Commands 
window.

MIDI Input
When the In button is engaged, you can insert notes via an external MIDI keyboard. 
You can use the Step Input Keyboard window and/or the Input key commands to 
adjust any settings that are not available from the MIDI keyboard itself. These 
include:  the length of the note and location commands. As with Key Commands Input, 
the MIDI Input is available in the following windows:  Event, Matrix, and Score Editor.

Input via Screen Keyboard
You can open the Step Input Keyboard window via Windows > Step Input Keyboard.

If you decide to work in the Score Editor, you need to adjust the display settings for the 
selected MIDI Region accordingly:  Interpretation (see “Interpretation” on page 378) 
should be off, the Display Quantize (Qua) setting (see “Qua—Display Quantization” on 
page 377) should be set to the smallest note value that you intend to insert.

Before starting note entry, set the Song Position Line to the spot where you want to 
insert the first note. This can be done in a number of ways, such as adjusting the song 
position in the Transport window, for example.

Single Notes
We suggest that you use the mouse while familiarizing yourself with step entry. Click 
on the key of the desired pitch in the Step Input Keyboard, and make use of the 
buttons for note length, velocity, and other parameters. This will insert a note of the 
selected pitch (at the current song position, in the selected MIDI Region), with the 
length and velocity that you chose earlier in the Step Input Keyboard window.

The pitch of an inserted note is determined by the key that you click in the Step Input 
Keyboard window. 
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Length and velocity are determined by the corresponding buttons in that window. If the 
buttons look like those shown in the illustrations below, a sixteenth note with a 
velocity setting of 96 would be inserted—this value (96) corresponds to the forte (f ) 
indicator. The eight available velocity values are represented by the traditional volume 
indicators ppp, pp, p, mp, mf, f, ff, and fff, which correspond to velocity values 16, 32, 48, 
64, 80, 96, 112, and 127, respectively. 

The MIDI channel of an inserted note is determined by the Channel setting in the Step 
Input Keyboard window.

Note:  The channel settings of individual notes usually have no effect on the playback 
channel and therefore the sound of the MIDI Region—this is determined by the track 
instrument settings in the Arrange window. The channel settings of individual notes are 
mainly used for polyphonic score display.

Proceeding
After a note is inserted, the Song Position Line will always jump to the end of the 
inserted note. The following note can be inserted immediately, following the same 
principles.

Chords
To insert several notes at the same bar position, Chord mode needs to be activated. To 
do so, click on the button at the far left side of the window or use the Chord Mode key 
command.

Chord mode prevents the Song Position Line from moving after insertion of a note, 
allowing the user to insert as many notes as desired at the same bar position, one after 
the other. Another click on the Chord button (or the key command) will deactivate 
Chord mode (this should be done before inserting the last note into the chord), and the 
Song Position Line will advance as per usual, after note insertion.
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Input via the Computer Keyboard
Note input with the computer keyboard follows the same principles as input via the 
on-screen keyboard (see “Input via Screen Keyboard” on page 45). Where it differs is 
that key commands are used for all functions, rather than choosing pitch, velocity, note 
length, and so on with mouse clicks. It is recommended that the Keyboard window 
should remain open when you first start using these functions, to make the learning 
process easier. Once familiar, you can leave it closed as it is unnecessary to open the 
Keyboard window when using key commands.

All key commands for step input are user definable. They can be found at the very 
bottom of the list, under the header Keyboard Input, in the Preferences > Key Commands.

Note:  It is also possible to enter note data in realtime with the computer keyboard (see 
“Caps Lock Keyboard” on page 49).

Pitch
The twelve Note C to Note B key commands will insert a note (of the selected pitch) 
with the set length and velocity at the current song position in the selected MIDI 
Region. To insert chords, use the Chord Mode key command. You can switch off chord 
mode with the same key command.

Rather than assigning key commands to all twelve pitches, you also have the option to 
only define key commands for the seven pitches of the C major scale, and use these in 
combination with the Next note will be sharp and Next note will be flat key commands to 
insert the other pitches.

When creating a system for these key command assignments, two approaches seem 
obvious:  either to arrange these commands on the computer keyboard similarly to a 
piano keyboard (C D E F G A B in one row, next to each other, and C# D# F# G# A# 
above these at corresponding positions), or to assign keys to pitches of the C major 
scale according to their note names—especially when the second approach mentioned 
above is used.

Octave Ranges
The octave of an inserted note depends on the current position of the insert range bar. 
This can be seen in the Keyboard Window:  There is a small horizontal bar above the 
piano key image that spans one octave exactly. The chosen note will always be inserted 
inside the range marked by that bar.

This bar continuously changes its position in accordance with the last inserted 
note:  The center of the insert range bar will always be aligned to the last inserted note. 
The next note will be inserted in that range unless the range bar is moved via key 
commands or the mouse.
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An example:  If a G is inserted immediately after inserting a C, the G will be placed 
below the C. Inserting the C places the range beam between G (left end) and F# (right 
end), with the C in the center. Regardless of which note is chosen next, it will always be 
inserted inside this range. The range beam will, however, move as further notes are 
inserted, with the (range beam) center always aligned to the most recently inserted 
note.

Further key commands allow you to place the range bar in different octaves:  Octave 0 
to Octave 6, and also Octave +1/−1/+2/−2, which move the range bar up or down one 
or two octaves. The range bar can also be moved with the mouse.

Note Length and Velocity
Note Length and Velocity are determined before a pitch command is used to actually 
insert a note. The currently selected values can be seen in the Keyboard Window.

Rests, Correction, Moving Forward and Back
The Rest key command moves the Song Position Line forward (in accordance with the 
currently set note value) without inserting a note, thereby creating a rest. 

The Step backwards and Step forward key commands also move the Song Position Line 
forward or back by the length of the selected note value.

The Erase key command will delete the most recently inserted note, and move the 
Song Position Line back to the position where the note (previously) began. This allows 
quick corrections—another note can be inserted immediately, replacing the erased 
one.

Triplets, Dotted Note Groups
The Next three notes are triplets key command is self-explanatory. The rhythmic value of 
the triplets corresponds to the currently selected note value in the Keyboard Window. If 
an eighth note is selected, an eighth note triplet will be created. After three notes have 
been inserted, binary values will be inserted, unless the command is reused.

Next two notes are a dotted group works in a similar way. The special thing about this 
key command is that a pair of notes that complement each other will be inserted. A 
dotted eighth and a sixteenth note, for example.

Interaction with Other Key Commands
If the input mode is activated in an editor window (Score, Matrix, or Event List), these 
key commands have priority over all other key commands.

This means that you may also assign keys or key combinations to these functions 
which are already assigned to other functions. As long as the input mode is active, 
these key assignments will apply; if the input mode is switched off, any other 
assignments (for the same keys) will have priority.
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Note:  As you can use key assignments that are already in use for other functions, you 
should take care to avoid using keys that are assigned to functions that you might also 
want to use when working in step input mode.

Input via MIDI
Note input via MIDI works as per input via the on-screen keyboard (see “Input via 
Screen Keyboard” on page 45). Obviously, you press keys on your real-world MIDI 
keyboard, rather than clicking notes on the on-screen keyboard. Incoming MIDI note 
Velocity information is stored when using MIDI Step Input. It is recommended that the 
Keyboard window should remain open when you first start using these functions, to 
make the learning process easier. Once familiar, you can leave it closed as it is 
unnecessary to open the Keyboard window when using key commands.
It is also recommended that you make use of the Input key commands (see “Input via 
the Computer Keyboard” on page 47) to quickly switch values such as the note length, 
or to determine the insert position. 

Chords can be inserted by playing the chord on the MIDI keyboard. You don’t need to 
switch on Chord Mode in order to do so.

Caps Lock Keyboard
This feature allows you to use the computer keyboard as a realtime MIDI keyboard. This 
is ideal for situations where no external MIDI or USB keyboard is available, such as 
when travelling with your PowerBook. 

The Caps Lock Keyboard supports more than ten octaves, and even includes support of 
Sustain and Velocity information.

The Caps Lock Keyboard is enabled/disabled by pressing the Caps Lock key on your 
computer keyboard. As long as the Caps Lock LED is lit, your Caps Lock Keyboard is 
active.

Needless to say, while in this mode, many keys have different functions and their usual 
key command assignments are not active.

This is the English version of the CapsLock Keyboard—German, Spanish, or French 
versions will appear, dependent on your Mac OS X Keyboard setting.
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The Escape key sends an All Notes Off command, should you encounter hanging notes.

The numeric keys (above the QWERTY keyboard) are used to define the octave for the 
MIDI keyboard.

The two rows below the numeric keys function as the actual MIDI keyboard keys, 
starting with the note C, assigned to the alphabetical A key (or Q, as would be the case 
if using a French keyboard, for example). 

See the black and white keys in the picture above for details.

The lowest row of letter keys sets the velocity for MIDI notes. There are preset values 
ranging from pianissimo to forte fortissimo. Each value can be finely adjusted via the 
two keys to the right of this row (these are assigned to the comma and period keys on 
an English QWERTY type keyboard). This keyboard configuration allows you to send 
any MIDI velocity value from 1 to 127.

The Space bar provides a Sustain function—played with your thumbs rather than your 
feet. You can freely trigger new notes or switch between octave or velocity values while 
notes are sustained.

The current octave and velocity values for the MIDI notes are displayed at the upper 
edge of the Caps Lock Keyboard window. A Transparency fader is also available for this 
window, making visualization clearer or allowing the window to be “ghosted” over the 
background.

Caps Lock Keyboard Preferences
The Enable Caps Lock Keys option allows you to completely enable or disable the Caps 
Lock Keyboard functionality.

After familiarizing yourself with the operation of the Caps Lock Keyboard for a while, 
you may wish to prevent the window from appearing when using it. To do so, disable 
the Show Window when Active option in the Preferences > Global > Caps Lock Keys menu.

Should you wish to use the Space bar key command (usually Start/Stop), rather than as 
the Sustain function for the Caps Lock Keyboard (when active), you can disable the 
Preferences > Global > Caps Lock Keys > Space bar acts as Sustain Pedal option.

Additional Caps Lock Keyboard Info
Due to technical limitations of computer keyboards, there is a maximum number of six 
notes that can be played simultaneously. There are further limitations regarding timing 
precision, and when trying to play certain note clusters (which are musically unusual, at 
any rate). 

Please keep in mind the original intention of this facility—as a useful aid when 
composing on a train or plane—not as a full-on replacement for a real MIDI keyboard.
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Song Administration
All events, other objects and settings (apart from the preferences and key commands) 
are components of a song. Songs are handled in the main File menu.

Projects

The illustration above shows a typical Project folder file structure in Logic’s Open 
dialog.

Creating a Project
The File > New entry launches the following dialog:

If the Create Project Folder checkbox remains unchecked and no template is selected in 
the Templates menu, functionality is as follows:  
• The Autoload Song will be opened. The search for the Autoload Song is conducted in 

the following order:
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• Preset Templates folder (/Library/Application Support/Logic/Song Templates/
Autoload or Autoload.lso)

• User Templates folder (~/Library/Application Support/Logic/Song Templates/
Autoload or Autoload.lso)

• the Application folder (Logic 6 series/Autoload or Autoload.lso).
• If no Autoload Song exists in any of the aforementioned locations, or the Option key 

is pressed, the empty default song (besed on the .plist created by the Logic Setup 
Assistant) will be launched.

Note:  The search for the Autoload Song, as you’ll note from the above, takes place in 
the Templates folders before searching the Application folder. In earlier Logic versions, 
the Autoload Song needed to be placed inside the Logic program folder. While this can 
still be done, we encourage you to move your existing Autoload Song into the User 
Templates folder (see “About Templates” on page 56).

If the Create Project Folder box is selected, followed by a click on the OK button, a 
project will be opened, rather than a song or template. This occurs in the following 
fashion:
• A folder is created in the chosen location, with the desired name—as typed in by 

you.
• A song is opened (either the empty default song if no template was chosen, or the 

chosen template song).
• This song is saved into the newly-created folder.
• An Audio Files folder is created within the new folder.
• The audio recording path is automatically routed to the new Project > Audio Files 

folder.

The checkboxes below the Set button represent the Project settings (these can be 
changed at any time). The project settings determine how files imported from external 
locations (locations outside the project folder) should be handled. They either:  
• stay where they are (if the checkbox is unchecked) 
• or are copied into the project folder (if the checkbox is checked). 

Audio files are automatically moved as soon as they are imported into the Audio 
window (resulting in a sample rate conversion, if necessary).

Note:  The Convert Audio File Sample Rate When Importing option is designed to allow 
the automatic sample rate conversion of imported audio files.

EXS instruments and samples are only moved into the project folder when the song is 
saved. 
If you disable the Copy EXS Samples to Project Folder option, only the EXS instrument 
files will be automatically copied to the project folder when saving, not the samples 
associated with the EXS instrument files.
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Project settings can be changed via the File > Project > Settings menu entry, which 
launches the following dialog:

If Copy (or Move, see “Saving as Project” section below) is set for audio files, sampler 
instruments/samples the “copy” flag will be associated with that file type in the Project 
settings.

Warning:  If a new project is closed without saving it, you will be asked if the created 
files and folders should be deleted. Clicking on Delete will result in all files (including 
any newly-recorded audio files) being moved to the trash—so take care!

Saving as Project

You can use the File > Save as Project function to save a song or project. If the open 
song isn’t already a project, the saved song file is assigned “project” status. This allows 
you to set the Project settings (File > Project > Settings) which determine how imported 
files are handled. This also makes the project “safe”, allowing you to move or copy the 
project folder without losing any file references that point to items within the folder.

In the Save As Project dialog you can choose, if the project files should be copied or 
moved into the project folder. 

The Sampler Instruments and Samples pull-down menu in the Save as Project dialog 
features a Copy Instruments Only option which leaves the samples in their existing 
location.

The Copy All button presets all pull-down menus to the Copy state.

The Move All button presets all pull-down menus to the Move state.
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Copying or Moving the Project Folder
If the project folder is moved or copied to another location, the files in the resulting 
folder will still be found correctly, provided that they are all in (or are in subfolders of ) 
the appropriate project subfolder—audio files are found in the Audio Files sub-folder, 
samples in the Samples sub-folder, sampler instruments in Sampler Instruments sub-
folder and so on.

Project Clean Up
Should there be any unused audio files or EXS instruments in your project folder, make 
use of the File > Project > Clean up menu option. If any unused audio or EXS instrument 
files are found, the following dialog will be displayed:

The checkboxes in the first column can be used to remove/add items to/from the 
deletion list. The name and path of the file to be deleted is shown in the last two 
columns. 

Only files with active checkboxes in the first column will be deleted. All unchecked 
entries will remain untouched.

If multiple rows are selected, a click on any checkbox will switch all selected rows to 
the new state.

Note:  Clean up will only delete unused audio files (WAVE, SDII, AIFF) and EXS 
instrument files. All other files will be ignored.

Note:  Clean up takes into account the project currently loaded, and all other Logic 
songs in the project folder—only files that are not used by any of these songs will be 
displayed in the “Clean up” list.
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Consolidate Project Settings
The File > Project > Consolidate function launches the following dialog:

As you can see, it is basically the same as the Save As Project dialog, but with the Song 
File pull-down menu missing.

How Consolidate Works
• If Consolidate is used on a saved song, the song will be moved into a newly created 

folder (named after the song). Following the consolidation, the usual Save As Project 
functions (copying or moving files) can be performed. 
The newly saved song is assigned “project” status (see page 53), allowing you to 
change the Project settings after the fact, and making the song folder safe to move 
or copy.

• If Consolidate is used on a song which is already a project, all referenced files that are 
not yet in the correct location within the project folder are automatically moved or 
copied (dependent on the specified options) to the appropriate sub-folders.

Project Preferences
The dialog options for all of the abovementioned operations are saved into the 
preferences file.

The default settings for these dialogs are as follows:
• Move Song
• Copy Audio
• Copy EXS Instruments
• Delete Empty Directories
• Unused Audio like Used

Once any changes have been made to these options, and the dialog was closed by 
pressing the OK button, the default values are overwritten, and the new settings will be 
used.

ReCycle Import Handling in Projects
EXS instruments created via a ReCycle import are placed in a Sampler Instruments/
ReCycle sub-folder of the project folder. All audio data generated by a ReCycle import 
are placed in the ReCycle Audio folder, alongside the song file.
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About Templates
A template is a song file that is stored in either of two specific locations (see below). 
Any song file may act as a template. You can view templates much like having multiple 
Autoload Songs.

The advantage of using templates is that not all projects have the same needs, so 
customizing several songs to meet these needs offers an ideal “starting point” for 
different jobs. As examples:
• A template that is software instrument-focussed, for Dance projects. This would 

feature 32 Audio Instrument tracks, and say eight audio tracks.
• An audio track-centric template, featuring say 64 audio tracks, would be ideal for live 

recording.
• A specific live performance template that makes the job of quickly switching 

between parts faster, or perhaps makes heavy use of Environment Objects such as 
Arpeggiators or Touch Tracks.

• Several scoring templates for:  choirs, a rock band, symphony orchestra, string 
quartet, jazz combo, and so on.

• A template for video work. This would typically contain a Video track plus specific 
dialog, foley, and music tracks. 

• Screensets can be customized for each template, or you can make use of the Import 
functions to copy them between templates.

To use Templates:
m Choose File > New and select a template in the Template pop-up menu, that shows all 

songs in the /Library/Application Support/Logic/Song Templates (system volume) folder 
and the ~/Library/Application Support/Logic/Song Templates (user) folder. 

To save Templates:
m Simply select the File > Save as Template menu option, and type in the desired name.

Loading a Song
You use File > Open (Command-O) to launch a typical file selection box. If there is 
already a song loaded, you will be asked if the currently-loaded song should be closed 
(select Close) or not (select Don’t Close). You can disable this prompt by selecting 
Preferences > Global > Song Handling > When Opening a song, ask to ‘Close current 
song(s)?’.

File > Open 
The Open dialog offers an Open File Type menu, where you can activate the following 
options:
• All Logic document types—Displays all song file types supported by Logic.
• Logic Songs—Songs created with current or earlier Logic versions.
• GarageBand songs—Songs created in Apple’s GarageBand application.
• Notator SL songs—Songs created in C-Lab/Emagic Notator or Creator SL.
• MIDI Files—Standard MIDI Files in either format 0 or 1 can be loaded.
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Direct Access to Your Current Songs
You can open any of your most recently opened songs directly without the usual file 
selection dialog by selecting File > Open Recent.

Different Songs Open at the Same Time
If you have several songs open at once, you can switch the currently active song from 
the Windows menu—the active song is the one marked with a tick. Provided that the 
Preferences > Global > Hide Windows of Inactive Songs option is switched off, you can 
also switch the active song by clicking on one of the other song windows.

Song and MIDI File Import by Drag and Drop
Songs and Standard MIDI files can be dragged from the Finder, and dropped into the 
Logic Arrange window. The mouse position—when the mouse button is released—
determines the clock position (rounded by bar) and destination of the first track for 
placement of the imported file.

Opening Pre Version 7 Songs
When loading a song created in a pre-version 7 Logic, the song format will be 
converted to the version 7 format. When saving this song for the first time, a file 
selector dialog will be opened, so that the old song file will not be overwritten 
automatically. 

Note:  Once saved in version 7 format, a song can no longer be opened with versions 
prior to version 7 (exception:  Logic versions 6.4.3 and higher can open the song, but at 
the expense of all Logic 7 specific features). A song can be exported (see “Saving 
Songs” on page 58) as a version 4.8 song.

Special Functions
Checking/Repairing Songs
If you double-click on the remaining number of free events display (see “Tempo/Free 
Memory” on page 77) on the Transport Bar, the memory will be reconfigured. At the 
same time, the current song will be checked for any signs of damage, structural 
problems, and unused blocks.

If any unused blocks are found—which normally shouldn’t happen—you will be able 
to remove these, and repair the song.
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Song Information Window
The Song Information window can be opened via Options > Song Information. 

It contains information about various aspects of your song. This information might not 
be directly useful for you, but you may be asked to provide this information (in case 
there is problem with a specific song) by the Support Team.

Saving Songs
When you select File > Save (or Command-S), the current song will be saved—with its 
current name intact.

If you don’t wish to overwrite the last version of the song saved with this name (which 
is what will happen if you use File > Save or Command-S), make use of the File > Save As 
or File > Save a Copy As options. In the ensuing file selector dialog, you can enter a new 
name for the song (and select a new directory or even create a new folder).
• File > Save as—The next time you save using the straight Save (Command-S) 

function, the new file name and path will be used.
• File > Save a Copy As—The next time you save with the straight Save (Command-S) 

function, the existing file name and path will continue to be used. The “copy” is a 
replica of the existing song, stored in a different location. It does not update the file 
save path. Save a Copy as is ideal for archiving and moving data.

Important:  Songs saved in version 7 of Logic cannot be opened in older versions.

Export Song as Logic 4.8 Song
Choose File > Export > Song as Logic 4.8 Song to save your song in Logic 4.8 format. This 
allows versions prior to version 5 to open a song file. Please note that not all song 
information can be stored in the older format, including any track automation data  
(see “Automation—Introduction” on page 225). You may wish to convert track 
automation data into Region data first, should you need to export in 4.8 Song format.
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Automatic Backup Files
When you save a song, Logic will first make a safety copy of the previous file. You can 
switch off this function in the Global preferences (Preferences > Global), and also set the 
number of backup files that will be made—up to 100.

This function allows you to store up to 100 earlier versions of your song, thereby 
retaining a complete record of your song’s development. 

Backup files are saved in a backup folder within the Project folder, and are named after 
the song/project, but feature the “.bak” file name extension. The backup files 
themselves are also named after the song, but are sequentially numbered. As an 
example:  if the song is called “My Song”, the backup folder will be “My Song.bak”, and 
the backup files within the folder will be called “My Song00”, “My Song01”, and so on.

Note:  If you want to know what the latest version is, take a look at the contents of the 
Project > Backup folder in the Finder, making sure you sort the contents of the window 
by date (select “By Date” in the Finder’s View menu with the backup folder open, and 
selected). The Finder cannot distinguish between files if they were saved during the 
same minute.

Reverting to the Saved Version
Any time you make a mistake, you can undo it by selecting Edit > Undo (Command Z).

If you have made some really serious blunders (as unlikely as that may be), or you 
decide that in the 15 minutes since you last saved, your creative efforts have resulted in 
material too unpleasant to describe here politely, you may find the File > Revert to Saved 
function very helpful. This replaces the current song with the previously saved version.

Closing and Quitting
Closing a Song
File > Close (Command-Option-W) closes the currently active song. If you have made 
any changes since the last save operation, Logic will ask you if the song should be re-
saved before closing, to preserve any changes you have made.

Quitting the Program 
Choose File > Quit (Command-Q) to leave the program. If you’ve made changes, but 
haven’t saved them, you will be asked if you want to do so before quitting (press Enter 
to save).
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Standard MIDI Files
Standard MIDI files are not specific to a particular sequencer program, or type of 
computer. They contain the following information:
• MIDI events, including time positions and channel assignments
• Names of the individual tracks
• Tempo changes
• Copyright marks

Logic supports the importing and exporting of Standard MIDI file formats 0 and 1:
• Format 0 can contain one track.
• Format 1 can contain multiple tracks.

Neither format recognizes any division of a track (into several MIDI Regions, for 
example).

Loading Standard MIDI Files
To load a Standard MIDI file, select File > Import. 

Note:  If you select the MIDI files option in the Open file type menu, only MIDI files will 
be displayed in the File Selector. 

If a song is loaded, you will be asked to “Create new environment or copy current 
environment for MIDI File? New/Copy”.

If you click Copy, the existing environment is copied. The tracks of the Standard MIDI file 
are automatically assigned to suitable instruments.

If no song is loaded, or you answer the question by clicking New, the default 
environment (the default song) is used.

Bank Select
When you open Standard MIDI files, program change and controller events occurring at 
the same position are moved by one tick, so that they will remain in their intended 
order. This prevents Logic from reversing the transmission order of events. The reason 
for this is that certain MIDI devices will not respond properly to program change and 
bank select events that do not occur in the correct order.

This also guarantees that there will be no timing problems, because the transmission of 
a MIDI event always lasts longer than one tick.
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Saving Standard MIDI Files
If you want to play a Logic song on another sequencer, you can do so by saving it as a 
Standard MIDI File. Consult the other sequencer’s instruction manual to see what 
Standard MIDI File formats it can read. Any sequencer should be able to interpret at 
least the type 0 file format.

Preparing the Song
Due to limitations of the Standard MIDI File format, you should prepare your Logic 
song in the following way:
• Neutralize all playback parameters with the normalize function (select them all by 

pressing Command-A, then select MIDI > Region Parameters > Normalize Region 
Parameters) 

• Convert all playback quantization with the Apply Quantization Settings Destructively 
function (Command-A, MIDI > Region Parameters > Apply Quantization Settings 
Destructively)

• Convert all aliases into real copies (Command-A, MIDI > Alias > Turn to Real Copy)
• Convert all loops into real copies (Command-A, MIDI > Region Parameters > Turn 

Loops to Real Copies)
• Convert all MIDI Regions on each track into a continuous MIDI Region (Command-A, 

Region > Merge > Regions per Tracks
• MIDI > Insert Instrument MIDI settings as Events

Additional Preparations for File Format 0
As Standard MIDI file type 0 format files can only save one MIDI Region, you must also 
merge all MIDI Regions into one (Command-A, Region > Merge > Regions).

Saving a Song as a Standard MIDI File
Select all of the required MIDI Regions, and select File > Export > Export Selection as MIDI 
File. You can now enter the destination directory. Remember that most hardware 
sequencers can only read MS-DOS formatted disks, so limit your file name to an 8.3 
character name. As an example:  “song0001.MID”.

In File Format 0
Ensure that the Preferences > Global > ‘Export MIDI File…’ saves single MIDI Regions as File 
Format 0 parameter is checked. If it is, selecting File > Export > Export Selection as MIDI 
File when only one MIDI Region is selected means that file format 0 will automatically 
be used.
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Apple Loops
Logic ships with a number of Apple Loops. Apple Loops are musical phrases that can 
be repeated seamlessly. In comparison to “normal” audio loops, Apple Loops have a 
significant advantage:  they can be transposed and (automatically) time stretched. 
Logic allows you to import Apple Loops, using the Loop Browser. You can also create 
your own Apple Loops with the Apple Loops Utility. 

The Loop Browser
The Loop Browser allows the import of Apple Loops. When you add an Apple Loop to a 
Logic song, it will automatically be matched with the tempo and key of the song. This 
function allows you to use several Apple Loops simultaneously, even if they are of 
different speeds and keys.

The Audio menu contains a Loop Browser option that launches the following window, 
when selected.

The new Apple Loops file format adds tags that allows you to quickly locate files by 
Instrument, Genre, or Mood. Further search refinements can be made by Scale and 
Signature.

The View buttons at the top left switch between a matrix display and a traditional 
Mac OS X file menu that is hierarchically separated into All, By Genre, By Instruments, By 
Moods, and Favorites search criteria.
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The Scale pull-down menu offers Minor, Major, Neither, and Good For Both options. Use 
of these options limits the search for Apple Loops to the selected Scale type, within the 
chosen category. As an example, if Country, Acoustic, and Relaxed categories were 
selected, you would be presented with twenty files that matched your choices. 
Selection of the Minor Scale option would reduce this list to ten possible Apple Loops, 
making the task of auditioning and selecting the most appropriate material faster.

The Signature pull-down menu performs a similar task to the Scale menu, but limits 
searches to Apple Loops that match the selected time signature.

The Search field is used to find Apple Loops by name or partial name:
• Type in the desired search term, and press the Return key. Any files that match your 

search term will be displayed in the file browser at the bottom of the window.
• The Cancel button to the right (which appears as soon as any text was entered) clears 

any entered text. It also clears the search history. 
• The Find menu to the left (the magnifying glass) retains a history of recently used 

search terms. 

The categories matrix shows categories by instrument, genre, or mood. Simply click on 
the desired boxes in the matrix to narrow your search for appropriate Apple Loops. 
Selected boxes are highlighted. Multiple categories can be selected, either in 
conjunction with the Scale and Signature pull-down options, or without.

Note:  You can switch a displayed category via the pop-up menu that opens when you 
Control-click the category box.

The Key pull-down menu determines the playback key of the selected Apple Loop. 

The Volume fader adjusts the playback level of the selected file in the Loop Browser 
window.

The list at the bottom of the window displays all Apple Loops that match the criteria 
set with the parameters discussed above. 
• Clicking on any of the column titles will sort the list of results by Name, Tempo, Key, 

and so on. 
• Clicking on the arrow in any selected column title will sort the list in ascending or 

descending alphabetical, tempo, key, beat, or favorite order.
• Columns can be resized by dragging the vertical lines between column titles.
• Selection of any entry in the list of files will automatically begin playback. You can 

stop playback by clicking on the speaker icon in the left-hand column.

There are two types of Apple Loops:  those featuring a blue sound wave icon and 
others with a green note icon. The Apple Loops that feature the blue icon can be 
added to audio tracks, and can be edited like other Audio Regions. These files have the 
major advantage of automatic tempo and key matching to that of the song tempo and 
key. 
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The Apple Loops that feature the green icon can also be added to audio tracks, where 
they behave exactly like their blue icon counterparts. They may further be added to all 
Audio Instrument and MIDI tracks. On such tracks, these files they can be edited like 
other MIDI Regions, including individual note editing. 

Another interesting thing about the green Apple Loops is that if dragged onto a 
“blank” Audio Instrument track (one with an empty channel strip), the corresponding 
instrument, effect, and input setting are automatically inserted.

Note:  The Transpose Global track will only transpose Apple Loops used on audio tracks 
by ±36 semitones. This is a designed limitation in Logic, as Apple Loops don’t sound 
that great when transposed further. This is also true for the Transpose parameter of the 
Region Parameter box.

To add an Apple Loop to your song:
m Simply drag the desired loop to the appropriate track and desired position. 

Apple Loops Utility
The Apple Loops Utility allows you to create your own Apple Loops. Apple Loops are 
simply audio loops that include metadata “tags” with your loops. These tags provide 
information about the audio recorded in a file. 

Logic uses tags in one of two ways:
• to help locate files when using the Search features of Logic’s Loop Browser.
• to provide information that Logic uses when matching the file’s tempo and key to 

the project tempo and key, this ensuring the best possible playback quality.

Tagged audio files can also contain information about transients. Transients indicate 
where beats occur in the file, and Logic uses these transients to play back audio files at 
the highest level of quality. The Apple Loops Utility can detect transients present in an 
audio file, and you can use the utility to add markers for additional transients, and 
move them to new locations.

If you select a Region in Logic’s Arrange window and choose Audio > Open in Apple 
Loops Utility the following window opens:

The Apple Loops Utility window consists of the Tags and Transients panes. The bottom 
of the window includes a set of playback controls and file management buttons. The 
Apple Loops Utility also includes an Assets drawer, located to the right of the main 
window, where you manage open files.

Tags Pane
The Tags pane includes areas for different types of tags. It also includes a set of 
playback controls that you can use to listen to an open file. 
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Property Tags
• Number of Beats field:  Displays the number of beats in the file.
• File Type button:  sets the file type, which can be One-shot (One-shots are audio files 

not suitable for repetition) or Looped.
• Key pop-up menu:  Sets the key of the file.
• Scale Type pop-up menu:  Sets the file’s scale type. The choices are Major, Minor, 

Good for Both, and Neither.
• Time Signature pop-up menu:  Sets the file’s time signature. The choices are 4/4, 3/4, 

5/4, 6/8, and 7/8.
• Author field:  Displays the name of the file’s author. 
• Copyright field:  Displays the file’s copyright date, if one exists. 
• Comment field:  Displays any comments about the file. 

Search Tags
These tags are used by the Search feature in Logic’s Loop Browser when you search for 
files matching specific criteria.
• Genre pop-up menu:  Displays choices for the musical genre of the file.
• Instrumentation list:  Displays choices for the musical instrument or instrument 

category recorded in the file. Selecting an instrument category in the left column 
displays the list of instruments in that category in the right column.

File Info
This area of the Tags pane includes rows with Kind, Length, Date Modified, Sample 
Rate, Channels, Tempo, and File Location information. This information is for viewing 
only, and cannot be edited in the Tags pane.

Descriptors
Descriptors are complementary pairs of keywords that describe the mood or character 
of the music recorded in the file. Each pair of keywords offers a row of buttons, 
allowing you to choose either one keyword from the pair, or neither keyword.

Transients Pane
The Transients pane contains a large waveform display, with a Beat ruler and a 
horizontal scroll bar. Markers indicate the position of transients in the file. Typically, 
transients correspond to the widest parts of a sound’s waveform. The Transients pane 
includes controls for the beat division and transient detection sensitivity. You can also 
listen to the file (using the playback controls) to determine where transients occur.

The Transients pane includes the following controls:
• Transient Division pop-up menu:  Sets the beat value used for transient detection by 

the Apple Loops Utility. Choosing a larger beat value results in fewer transients being 
detected. Choosing a smaller beat value can also result in fewer transients being 
detected, if they are present in the audio recorded in the file.
Chapter 1    Using Logic 65



66

 

• Sensitivity slider:  Sets the degree of sensitivity for transient detection. When you 
increase the sensitivity of transient detection, the Apple Loops Utility considers 
points of higher amplitude in the waveform as transients, regardless of whether or 
not they occur at a beat value.

When you open a file in the Apple Loops Utility, it looks for transients at every 16th 
note position, based on the file’s tempo and number of beats tags. You can change the 
beat value used for transient detection via the Transient Division pop-up menu.

To display a file in the Transients pane:
m Select the file in the Assets drawer, then click the Transients tab.

Note:  The Transients window can only display one file at a time. If multiple files are 
selected, no waveform is displayed in the window. 

The waveform display in the Transients pane displays both the transients detected by 
the Apple Loops Utility and transients you add to the file. You can add transients and 
move existing transients in the Transients pane.

To add a new transient:
m Click in the darker area above the Beat ruler in the waveform display.

To move a transient marker:
m Drag the marker by its handle in the area above the Beat ruler.

To remove a transient, do one of the following:
m Click the transient’s handle in the area above the Beat ruler, then press the Delete key.
m Drag the transient out of the area above the Beat ruler.

Assets Drawer
The Assets drawer lists the files open in the Apple Loops Utility. The drawer contains a 
Name column that lists the name of each open file, and a Changes column, which 
indicates any files that you have altered.

Playback and File Management Controls
The bottom of the Apple Loops Utility window contains a set of playback controls, 
allowing you to audition the selected file. These controls do not affect the file’s tags.
• Go to Beginning button:  Starts playback from the beginning of the selected file.
• Play button:  Plays back the selected file.
• Stop button:  Stops playback of the selected file.
• Key pop-up menu:  Transposes the selected file to a new key for playback.
• Tempo slider:  Sets the playback tempo of the selected file. 
• Volume slider:  Sets the playback volume of the selected file. 

Note:  When multiple files are selected, the playback controls are not available. You 
cannot play more than one file at a time.
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There are two additional buttons at the bottom of the window, the Assets button and 
the Save button.
• Assets button:  Shows and hides the Assets drawer.
• Save button:  Saves your changes to the currently selected files in the Assets drawer.

GarageBand File Import
Logic supports the importing of GarageBand files via the File > Open menu option. 

On opening the file:
• Logic will automatically create the required number, and type, of tracks to mirror 

those used in the GarageBand song.
• Apple Loops audio data should import without issues.
• The tempo of the GarageBand song will be used.
• Software Instrument parts will be played by GarageBand Instruments in Logic. 

Further to this, any mixing data and effects (plus their Settings) used by Software 
Instruments or Apple Loops-based tracks in GarageBand will also be imported into 
Logic.

Once the GarageBand song is loaded into Logic, you may freely change parts, mixing 
levels, instrument, and effect parameters as in any Logic project.

GarageBand Instruments are automatically installed with Logic. 

You can insert them exactly as you would with other software instruments:
1 Click-hold on an Audio Object’s Instrument slot.

2 The Instrument menu appears, showing all of Logic’s available instruments. Move the 
mouse through the different levels to Mono/Stereo > Logic > GarageBand Instruments 
and choose an Instrument by releasing the mouse. 

The Channel Strip settings of GarageBand translate 1:1 into Logic—with the nice 
exception that you can now access the individual plug-ins that are inserted into a 
GarageBand channel strip. The GarageBand Channel Strip setting files are visible in 
Logic’s Channel Strip menu in a subfolder called GarageBand. Logic’s Channel Strip 
menu is accessible via a long click on the word Inserts on each channel strip.

GarageBand’s two bus effects (Reverb and Echo) are also translated when opened in 
Logic. They are replaced by the Platinum Verb and Tape Delay on Busses 1 and 2.

Note:  GarageBand projects will only open in Logic Express 7 and Logic Pro 7—not in 
older Logic versions. It is not possible to open Logic songs in GarageBand.

More information about GarageBand file support in Logic can be found in the 
“Introduction to Logic for GarageBand Users” tutorial.
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ReCycle Import
ReCycle is the name of a software application by manufacturer Propellerhead, which 
mainly serves as an editing and production tool for loops (repeatedly looped audio 
samples). ReCycle uses specific file formats that can be imported by Logic.

Recognized ReCycle File Formats
Logic can import the following file formats:

Old ReCycle File
• File Suffix:  .rcy 
• Abbreviation:  RCSO

Old ReCycle export file
• File Suffix:  .rex 
• Abbreviation:  REX

ReCycle 2.0 file
• File Suffix:  .rx2
• Abbreviation:  REX2

Importing ReCycle Files Into the Arrange Window
To import a ReCycle file to an audio track use the same options as for normal audio 
files:
• Select Audio > Import Audio File and select a ReCycle file instead of a regular audio 

file, or
• Command-Shift-click on an audio track and select a ReCycle file, or
• Drag a ReCycle file from the Macintosh Finder onto an audio track.

As a result, Logic will create a folder containing one audio track (using the same Audio 
Mixer Object as the track it is created on) which in turn contains the slices of the 
ReCycle file at the appropriate positions. Each of these slices will reference the same 
audio file, which can be found in the Audio Window, as usual.

Important:  If you move the created folder to another audio track, the Audio Mixer 
Object references will not change accordingly! You will need to open the folder and 
change it manually if that is what you want to do.

Copying Audio Data Into the Clipboard 
You can copy audio data into the Clipboard for further use in ReCycle by selecting local 
window Audio > Copy ReCycle Loop. This option will only be active if you have selected 
one audio part in the Arrange window, and will copy the selected region of the 
referenced audio file into the Clipboard. You can then use the Paste as new document 
function in ReCycle to create a new ReCycle document using this audio data. In 
conjunction with the Paste ReCycle Loop function (see below), you can perform a 
complete data transfer from Logic to ReCycle, and back, without using any file selector 
dialogs!
Chapter 1    Using Logic



 

The size of the transferred audio region is limited to 10 MB, due to the fact that the 
Clipboard resides in the computer’s RAM. 10 MB, however, should be sufficient for most 
ReCycle loops (an eight bar stereo loop in 4/4 at 70 bpm uses approximately 5 MB, for 
example).

Pasting ReCycle Loops Into the Arrange Window 
If you use the “Copy Loop” option in ReCycle to copy the loop currently being edited 
into your computers Clipboard, you can paste this loop into the Arrange window by 
selecting Audio > Paste ReCycle Loop. The result will be the same as if a ReCycle file had 
been imported.

ReCycle File Import Overlap Function
On occasion, you may encounter a dialog regarding overlaps, when importing ReCycle 
files.

The launching of this window results from:
• The tempo used in Logic being higher than that of the imported Recycle file.
• Use of the Stretch function in ReCycle.

You may handle the imported file in the following ways:
• Don’t Fix—imports the file as is. All “slices” of the file will overlap, to match Logic’s 

tempo.
• Add tracks—will distribute the slices across multiple audio tracks, allowing you to 

adjust the position or delete slices freely. The Number of additional Audio tracks panel 
in the window determines how many tracks are used for the distribution of the slices. 
These tracks are in addition to the original audio track, on which the Recycle file was 
imported.

• Crossfade—All slices of the file are imported to the same track and automatically 
crossfaded. The crossfade is equal powered. The length of the crossfade is 
determined by the value (shown in milliseconds) displayed in the Crossfade length 
panel. 

• Render into single file—When importing Rex files this function writes all ReCycle slices 
into a single audio file using the current Logic song tempo for the rendering process.

The adjustment of the numerical values is via use of the mouse as a slider, or double-
clicking on the panel(s), and direct numerical entry. 
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OPEN TL Import
Logic has the ability to import song contents using theOpenTL (Open Track List) file 
format.
The OpenTL format is mainly used for data exchange with Tascam hard disk recorders, 
such as the MX2424. It only supports the exchange of audio data (audio media and the 
use of this audio media in a song)—MIDI and automation data will be ignored when 
using the export functions. 
To import an OpenTL file, choose File > Import. A file selector opens, which allows you 
to choose OpenTL files. Note that if you choose the Open TL files option in the Open File 
Type menu, only files with the “.TL” extension will be shown in the file selector. If the 
first event in the imported song starts at a time greater than 1 hour, the following 
dialog appears:  

Set SMPTE start time of song so that events start at the same SMPTE time as they do in the 
imported project?

Confirm it by pressing Set if you want the SMPTE start time of the song to be changed 
accordingly, or Don’t set if the song’s SMPTE start time should not be changed.

Should the first audio part found by OpenTL import have a start time greater than zero 
(less than zero is impossible), Logic will ask if you wish to:  Set the start time of first 
imported event to start of song? If you answer with Set, the first audio part imported will 
be placed precisely at the song start position. 

This solves the problem of the song on the Tascam machine starting at a large time 
value, but less than 1 hour (such as 59 minutes). In this situation, the user can’t 
immediately see the imported audio parts because they are usually imported beyond 
the song’s end point (possibly even beyond the largest possible song end point, 
depending on the song tempo).

Bouncing and POW-r Dithering
Logic provides you with the leading professional POW-r dither algorithm, designed for 
the conversion of 24 bit recordings to 16 bit files—as required for CD burning, for 
example. POW-r (Psychoacoustically Optimized Wordlength Reduction) is licensed from 
the development team of the POW-r Consortium LLC.

POW-r dithering is applied when:
• bouncing audio files to disk

Bouncing can be performed directly in the Arrange (and other) windows by selecting 
the File > Bounce menu option, which will launch the Bounce dialog. Bouncing can also 
be initiated by clicking on the Bounce button found on Audio Output Objects (see 
“Bounce” on page 204).
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POW-r offers three distinct dithering modes. 
• No Dithering:  No dithering is applied.
• POW-r #1:  uses a special dithering curve to minimize quantization noise.
• POW-r #2:  (Noise Shaping):  uses additional noise shaping over a wide frequency 

range, which can extend the dynamic range by 5 to 10 dB.
• POW-r #3:  (Noise Shaping):  uses additional, optimized noise shaping which can 

extend the dynamic range by 20 dB within the 2 to 4 kHz range—the range the 
human ear is most sensitive to.

Note:  Noise Shaping minimizes side effects caused by bit reduction through spectral 
displacement of quantization noise above 10 kHz—the range the human ear is least 
sensitive to.

The mode which will sound the best to you is primarily dependent on the program 
material and on your personal taste. The “right” setting is best determined by 
auditioning the audio material with each of the dithering modes.

Important:  Dithering the same audio signal multiple times should be avoided.
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2 Transport
In this section, you will learn how to move to different 
parts of the song, start and limit passages, and to isolate 
and audition specific portions and components within 
the song.

In short, you’ll learn all about Logic’s Transport window. This also includes a brief 
introduction to Logic’s recording functions. 

The Transport Window
The Transport window is used to control and display Logic’s recording and playback 
functions.

These are the different sections of the transport window:

Transport buttons (see “Transport Buttons” on page 79)

Mode buttons (see “Mode Buttons” on page 81)
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Position display, Locators (see “Position Display” on page 76)

Tempo and Time Signature display (see “Tempo/Free Memory” on page 77)

MIDI Input—Output/Song End (see “MIDI Monitor/Song End” on page 78)

Note:  As a floating window, the Transport window is always in the foreground, and can 
not be covered by other (non-floating) windows. 

All display fields in the Transport window (apart from the song name) can be used for 
data input. You can either:  double-click on the desired display field and input the 
numbers with the keyboard, or adjust the individual numbers by using the mouse as a 
slider.

Note:  All Transport functions are also available as preset (but also user-definable) 
keyboard commands, even if the Transport window is not open.

To open the Transport window:
m Select Windows > Transport, or press Command-7.

Note:  Logic allows an unlimited number of Transport windows to be simultaneously 
opened. Additional Transport windows can be used as giant displays for the Bar or 
SMPTE position, as examples.

To close the Transport window
m Click the close button at the top left of the Transport window. 

Note:  The bar that contains the close/open and minimize buttons is normally found at 
the top of most windows. In the Transport window, this bar is located to the left.

To reposition the Transport window onscreen:
m Grab anywhere in the gray area of the Transport window (not on a function or field), 

and drag it to the desired position. 
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The Transport Bar in Other Windows
You can also configure a fixed Transport window in the Arrange and Matrix windows. 
Select View > Transport and a Transport field appears in the top left corner of the 
window. The number of visible buttons and displays is dependent on the size of the 
area available. You can adjust this area by click-holding on the intersection of the Track 
List, Arrange area and Bar Ruler (the cursor will change to a four-headed arrow), and 
dragging.

Altering the Display
The Transport window pull-down menu opens when you click on the arrow at the 
bottom right. This menu is used to reconfigure the Transport window’s appearance.

Smaller/Larger
You can adjust the size of the Transport bar to nine different size settings. This is 
achieved by dragging the bottom right corner of the Transport window.

Legend

This display option conceals/reveals a description of all window elements, and is very 
helpful if you are still getting to know the program.

Position Slider

This hides/shows a bar along the bottom edge of the window. The size of the bar is 
directly related to the current portion of the song shown in the Arrange area, and this 
portion’s relationship to the overall song length (see “MIDI Monitor/Song End” on 
page 78). You can click-hold on the bar and drag left or right to quickly move to a 
different song position.

Use SMPTE View Offset
This alters the display of the SMPTE time shown at the song startpoint, regardless of 
the true SMPTE start time being read from an external time code source. More 
information on this can be found in the SMPTE View Offset section  (see “General” on 
page 453).
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SMPTE View Offset
This menu option launches the Song Settings > Synchronization > General tab, allowing 
you to define the Bar Position and/or SMPTE time for both the actual song position and 
the SMPTE view offset.

Position Display
The current song position is shown in two formats:

Above: SMPTE time
Hours:  Minutes:  Seconds:  Frames/Subframes.

Below: bar position
Bar—Beat—Division—Ticks.

A beat corresponds to the denominator in the time signature, a division is a freely-
definable part of a beat. A tick is the smallest possible bar sub-division or system 
quantization—of just 1/3840 note.

Locators

You can define two sets of locator points:  one for the Cycle (see “Cycle Mode” on 
page 84), and the other for the Autodrop (see “Autodrop” on page 88) zone. The left-
hand side locators on the Transport window define the Cycle—a passage that is 
constantly repeated. 

The locators shown at the bottom/to the right on the Transport window define the 
Autodrop range (see Autodrop)

Note:  Both sets of locators are only displayed when the Cycle and Autodrop functions 
(buttons on the Transport) are switched on.

Note:  Any mention of the “left or right locators” refers to the Cycle locators, rather than 
the Autodrop locators. The top value denotes the left locator position, and the bottom 
one, the right locator position.

Adjusting Locators to Fit Selected Regions
Set Locators by Regionsmatches the locator positions with the start and end points of 
one (or more) selected Region(s). The Set Rounded Locators by Regions key command 
rounds the locator positions to whole bars.
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Tempo/Free Memory

Tempo
Tempo is displayed as quarter notes per minute, or beats per minute (bpm). It ranges 
from 5 to 9999 bpm, and is adjustable to four decimal places after the whole value.

Programming Tempo Changes
This functionality is described in the Tempo chapter (see “Display and Functions” on 
page 447).

Free Memory
Below the Tempo display, you will see the amount of free memory (events) available in 
the record buffer. You can increase the amount of free memory by reconfiguring the 
memory. 

To reconfigure the memory:
1 Double-click on the free memory display. 

2 A “Reorganize Memory?” dialog will appear. 

3 Confirm by clicking the Reorganize button. 

This reorganization is also carried out automatically after saving or loading a song. A 
common (and good) use of this feature is to free up memory after closing a song, if 
two or more songs were open at the same time. 

Time Signature and Division

This is where you can see, and set the time signature of the song. The format is:

Bar numerator—Bar denominator—Division

The division defines the third format value in all position displays (such as in the Event 
Edit window), and forms the grid for various length and placement operations. The 
division is normally set to 1/16 notes, but has a value range of 1/4 to 1/192 note. If the 
note value of the division is equal to or greater than the bar denominator, the third 
value of the position display is automatically removed.

Apart from the features described below, you can also use the Global Signature track to 
edit time signatures.
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Time Signature Changes
If you alter the bar numerator or denominator in the Transport window, a time 
signature is created at the start of the bar occupied by the current song position. This is 
shown in the Bar Ruler, to the left of the bar number and in the Global Signature track, 
if visible. A time signature change does not affect the absolute positions of any existing 
time signature events that are already inserted.

Note:  You can also add time signature changes directly in the Score Editor  (see “Time 
Signatures” on page 362) by double-clicking on any MIDI Region that spans the 
signature change.

To edit time signature changes:
m Move the Song Position Line to the target bar, and set the new time signature in the 

Transport window. Alternately, you can activate the Signature track via the View > 
Global Tracks menu option, and manually insert them (see “Signature Track” on 
page 244).

You can also edit the time signature in the Score Editor.

To erase time signature changes:
m Simply change the time signature to match the value of the preceding/previously used 

time signature.

Note:  You can also erase time signatures in the Score Editor by selecting them, and 
hitting Backspace. To erase all time signature events, select Edit > Select Similar 
Objectsbefore doing so.

MIDI Monitor/Song End

MIDI Monitor and Panic Function
MIDI Monitor
The top line shows the last MIDI message received, and the bottom line the last MIDI 
message transmitted. The monitor is mainly used for checking MIDI connections.

Automatic Chord Interpretation
The MIDI activity panel of the Transport window shows chord symbols when Logic 
receives more than one MIDI note simultaneously. The respective, held intervals 
(between notes) are interpreted and displayed as chords.
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Panic Function
Click on the MIDI monitor to silence any hanging notes. If this doesn’t work, double-
clicking on it will initiate a Full Panic reset, which should do the trick (see “Reset 
Functions” on page 132).

Song Title
The title of the active song is shown below the MIDI monitor.

Song End
Below the song title, you’ll see a numerical field that indicates the song end position. 
As soon as Logic reaches this position, it will stop automatically, except when 
recording. In this situation, the song end point is automatically moved to the end of 
the recording.

The maximum length of a Logic song is 8550 quarter notes, or about 2158 bars in 4/4 
time.

A song can therefore last a maximum of around 70 minutes at a tempo of 120 bpm. At 
95 bpm, the maximum length is over an hour and a half.

If you need to increase this length, for film synchronization as an example, just halve 
the tempo. You can achieve the same result by using 4/8 time instead of 4/4 time, and 
treating quarter notes as eighth notes. A 4/8 song at a tempo of 60 bpm (equivalent to 
4/4 at a tempo of 120) has a maximum length of more than 4273 bars, or over 2 hours 
and 22 minutes.

Transport Buttons
Record
Recording normally starts after the count-in, at the start of the current bar. In Cycle 
mode, it starts at the left locator. You can also choose to have one beat constantly 
repeated, until a MIDI message is received, at which point recording begins.

Pause
Pauses recording or playback, until you press pause or play again. During paused 
recording, you can add individual events which will be recorded.
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Play
Starts playback at the current position, or from the left locator position when in Cycle 
mode.

You can use the Play from beginning key command to start playback at the beginning 
of the song.

Stop
Ends recording or playback—the sequencer stops. If the sequencer is already stopped, 
pressing stop moves the song position line to the song start point, or to the left locator 
position if Cycle mode is active. 

Rewind/Forward 
If the sequencer is stopped, these buttons work as you would expect. If the sequencer 
is running, you can monitor as you go (cueing/scrubbing), with MIDI events being 
output at a faster rate. This also occurs when rewinding.

A click on either button will jump one bar forward or backward. Click-holding on either 
button will rewind or forward. Moving the mouse left or right will increase or decrease 
the rewind/forward speed.

Note:  Both normal (Rewind/Forward) and fast (Fast Rewind/Fast Forward) winding are 
available from the keyboard.

Shuttle—Winding Like a Reel-to-Reel Tape Recorder
There are two key commands for “winding the reels”—moving the Song Position 
Line—called Shuttle Rewind and Shuttle Forward. You will find them in the Key 
Commands window (see “Key Commands” on page 36) by searching for the Shuttle 
character string. Repeated hits of the key will increase the winding speed. Repeated 
hits of the opposing “shuttle” key will slow down the shuttle speed, and eventually 
change the winding direction. Shuttle disables Cycle mode. Shuttling is halted by the 
Stop command.
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Mode Buttons
The mode buttons do not immediately trigger an action. Rather, they switch operating 
states. The relevant button will illuminate to indicate that the mode is activated.

Cycle, Autodrop, and Replace

More information about the Cycle switch can be found in the Cycle Mode section (see 
“Cycle Mode” on page 84). For more details about Autodrop (see “Autodrop” on 
page 88), and the Replace switch (see “Options” on page 87).

Solo and Solo Lock
In Solo mode, only the selected Regions are played. The data output from all other 
Regions is muted. This is known as:  “soloing the Regions”. You can of course, change 
the Solo mode of Regions by changing your selection (default key command:  S). 

If you want to carry out specific functions on individual Regions, regardless of the solo 
status of other Regions, you need to be able to select these Regions without affecting 
the Solo status of others.

This is what the Solo Lock function is for. After soloing the desired Regions, double-click 
on the solo button, and a padlock symbol will appear on it to indicate “solo lock” status. 
You can now alter the selection without affecting the solo status of other Regions.

Sync
This button allows you to synchronize Logic with an external source (make Logic the 
synchronization “slave” to another device). If Logic is running by itself, or acting as the 
synchronization source (it is the synchronization “master”), this button should not be 
activated. When you first boot Logic, manual Sync mode is automatically switched off. 

Click-holding the Sync button opens a pull-down menu, where you can define the 
following:
• the type of external synchronization.

Cycle Replace

Autodrop
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• direct access to the tempo editors  (see “Display and Functions” on page 447).
• direct access to the Synchronization settings.

Metronome
This button (default:  C) is used to turn the metronome on and off. Logic remembers 
the Metronome status for recording and playback. 

Click-holding the Metronome button offers pull-down menu access to the Recording 
and Metronome Settings.

The Bar Ruler
There is a Bar Ruler at the top of the Arrange, Matrix, Hyper, and Score windows.

This ruler is used to display, and set, the:
• song position.
• start and end of the song or folder.
• cycle and autodrop locators.

Color and Display
The Bar Ruler changes color depending on the transport mode:
• Red—Record
• Yellow—Solo
• Blue—External Synchronization.

Dependent on the zoom settings (see “Zooming” on page 24), the bars are shown at 
the top edge in units of 1, 4, 8, or 16. Changes in time signature are also shown here.

In the bottom third, there is a vertical line for each bar. The shorter lines represent one 
beat, but are not always visible (depending on the zoom setting).
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Start and End Markers

The song start point is normally at position 1 1 1 1. You can move the song start point 
to an earlier position for playing upbeats or program change commands, by grabbing 
and dragging it with the mouse. The position display in the top left of the window will 
indicate where it is. The song end (default:  bar 201) can be set using the same method, 
or with the numerical Song End display (see “MIDI Monitor/Song End” on page 78).

In folders, the start and end markers refer to the folder rather than the song. The length 
of a folder can also be adjusted from within the folder itself.

Song Position Line
The Song Position Line (SPL) is a vertical line which indicates the current song position 
in all horizontal, time-based windows. You can grab the line with the mouse, and drag 
it to the desired position (but only if there is no Region or event at the mouse position 
when you drag it). Selecting Wide Song Position Line in the Preferences > Display > 
General page switches to a thicker SPL.

Direct Placement
As it can be difficult to grab the SPL in the window itself, you can also directly position 
it by using the bottom third of the Bar Ruler. Just click at the desired position in the 
lower third of the Bar Ruler to make the SPL jump to the point you’ve clicked.

Double-clicking on the bottom third of the Bar Ruler repositions the SPL, and also 
toggles between playback (or record) and stop modes.
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Numerically

Selecting Goto Position opens the dialog box shown above, allowing you to input the 
song position numerically. The last division used (bar position or SMPTE time) is 
automatically selected, with the last input value as a default. As the numbers are 
registered from the left, it is enough just to enter the bar number.

In the Score Window, you can set the SPL position directly by clicking into a staff at the 
desired point while pressing Option. This function is only available when the sequencer 
is stopped. The selected position is displayed in the help tag for as long as the mouse 
key is pressed. This method is especially handy when working in page view mode, as 
no Bar Ruler is visible in this mode.

Scrubbing
Start playback, and grab the bottom third of the Bar Ruler. By moving the mouse to the 
left or right, you can now scrub through the song, moving the SPL to hear all “cued” 
events. As soon as you stop moving the mouse, normal playback is resumed. 

Cycle Mode
In Cycle mode, a selected passage of the current song is constantly repeated. This is 
useful for:
• composing a song section.
• practicing a recording.
• recording individual tracks consecutively.
• editing events.

The Cycle area is shown as a green stripe in the top part of the Bar Ruler.

There are four ways of switching Cycle mode on and off:
• clicking on the Cycle button.
• using the Cycle key command.
• clicking on the top part of the Bar Ruler.
• inputting a Cycle area graphically in the Bar Ruler.
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How Logic behaves in Cycle mode:
• The Song Position Line jumps from the end of the Cycle to the beginning.
• When this happens, the playback from Environment Objects that are generating 

notes is interrupted.
• The Play command starts playback from the beginning of the Cycle.
• To start playback from another position, hit Pause twice, or Pauseand then Play.
• At the cycle jump point, you can use the Chase Events (see “Chase Events” on 

page 89) function—File > Song Settings > MIDI > Chase > Chase on Cycle Jump.
• You can determine the way recording works in Cycle mode, by using the various 

options on the File > Song Settings > Recording page.

Defining the Cycle
There are a number of different ways to define a Cycle. 

Defining the Cycle graphically in the Bar Ruler:
m Click-hold in the top third of the Bar Ruler, and define the desired Cycle area by 

dragging the mouse from left to right. Dragging from right to left generates a Skip 
Cycle (see “Skip Cycle” on page 86).

Grab the Cycle “bar” in the middle to reposition it. 

Grab the bottom corners to move the start or end points of the Cycle (you can even do 
this while the sequencer is still running.). If you set the start and end points to the 
same position, Cycle mode is switched off.

Note:  You can reset the nearest edge of the Cycle beam by clicking on it while holding 
down Shift, even if the beam is outside the visible range, or Cycle mode is switched off.

When you set the size of a Cycle graphically in the Bar Ruler, its size is quantized to the 
nearest bar. Locator positions can only be changed by division at high zoom 
resolutions, or if you hold down Control as you drag (the Cycle). If you hold down Shift 
and Control, at a really high zoom resolution, you can drag and change the size of the 
Cycle in ticks.

To set locator positions that do not lie on whole bar lines, regardless of the zoom 
resolution, enter your locator positions numerically in the Transport window.

Numerical Entry
The positions of the left and right locators (start and end points of the Cycle) are shown 
in the Transport window, where they can also be altered.

By Regions
You can use the Set Locators by Regions (default:  B) and Set Locators & Play key 
commands to set the locators at the start and end of selected Regions; the latter 
command also starts playback.
• Set rounded Locators by Regions rounds the position of the locators to the nearest bar.
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• The Set rounded Locators & Play key command achieves the same result, but also 
starts playback.

Skip Cycle
You can skip a passage in play mode, which is useful for trying out the musical effect of 
various transitions.

To set up Skip Cycle:
m Drag the Skip Cycle area from right to left in the Bar Ruler. If a (normal) Cycle area 

already exists, just move the left locator to the right of the right locator.

The Skip Cycle area is shown as a very thin strip at the top edge of the Bar Ruler.

Features of Skip Cycle Mode
When the SPL reaches the right locator position, it skips to the left locator (the “right” 
and “left” locators swap positions).

You can use Skip Cycle mode when editing, to leave out parts of the song that you 
don’t want to be affected by the edit.

Recording
Selecting a Track
To select the desired recording track, simply click on it.

Only one MIDI track can be record enabled in Logic Express, which may be on another 
folder level.

During recording, incoming events are stored in a Region on the selected track.

Note:  Audio tracks must be record enabled, and a recording path (a hard disk drive) 
defined before audio files can be recorded.

Changing MIDI Tracks
If you record MIDI information, you can change the record track, without stopping 
recording—just select a new track, using the Select previous/next track key commands 
(default keys:  Up or Down Arrow).
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Count-In
The Count-in and Record Pre-roll values can be defined in File > Song Settings > 
Recording (see “Metronome Settings” on page 466).

This is often useful if the section of the song (just before the part you’re recording) 
lacks the sort of rhythmic information necessary to play new parts in time, but there’s 
plenty of rhythmic material, once the section you’re recording to gets going.

Options
Record Toggle—Record Repeat
The Record Toggle key command switches between playback and record mode. Record 
Repeat repeats the recording from the previous drop-in point.

Record into Selected MIDI Region
Normally, a new MIDI Region is created during every recording. In the Recording 
Options (see “Recording Settings” on page 468) of the Song Settings you can activate 
Merge New Recording With Selected Region, so that any new data is incorporated into an 
existing (and selected) MIDI Region.

Replace Mode
To activate Replace mode, press the Replace button. In replace mode, any newly 
recorded data is always stored in a new Region. In addition, any existing Region on the 
destination track are cut at the punch in/out points of the recording, and any data 
between these points is deleted.

Destructive MIDI Recording
If you select File > Song Settings > Recording > Merge New Recording With Selected Region 
(r), and switch on Replace mode, newly recorded events will replace those in existing 
MIDI Regions.

The Merge/Replace combination can itself be coupled with the Autodrop and/or Cycle 
functions.

Recording in Cycle Mode
All settings for recording in Cycle mode can be made in the Song Settings > Recording 
Options (see “Recording Settings” on page 468). You can either use several cycle passes 
to record a single Region (Merge only New Regions in Cycle Record (checked), or you can 
create a new Region for every cycle pass (unchecked). 

A new track can be automatically created for each of these Regions (Auto Create Tracks 
in Cycle Record). The Regions you create can also be automatically muted (Auto Mute in 
Cycle Record). This mode is very well suited to recording several consecutive versions of 
a solo, and then picking the best one.
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Cycle and Replace
During a cycle recording in Replace mode, existing Regions are deleted during the first 
cycle pass—from the punch-in point to either; a punch-out point or the end of the 
Cycle. When the second cycle pass begins, recording continues, but no further Regions 
are deleted. If you want to replace the end of an existing Region, you don’t need to 
stop recording before the second cycle pass begins:  the start of the existing Region 
remains intact.

Recording With Skip Cycle
If Skip Cycle is switched on, the Cycle area is bypassed during recording.

Autodrop
The term Autodrop means the automatic activation and deactivation of record mode at 
predefined positions. Autodrop mode is most commonly used to re-record a badly 
played section of an otherwise flawless recording. The advantage of Autodrop mode is 
that you can concentrate on your playing, rather than starting and stopping record 
mode.

If Cycle mode is inactive, the left and right locators serve as drop-in and drop-out 
points. Autodrop is activated by clicking on the Autodrop button.

Defining the Autodrop Area

If both Cycle and Autodrop modes are active, you will see an independent pair of 
locators available for the Autodrop range. There are two stripes in the Bar Ruler, the top 
one representing the Cycle area, and the bottom one the Autodrop range. The 
Autodrop range can be graphically altered in the Bar Ruler, just as you would with a 
Cycle area. 

Note:  If the Bar Ruler display is narrow, hold down Option to ensure that any 
alterations made to the Cycle only affect the Autodrop range.

The grid scale—for graphic operations in the Bar Ruler—can be reduced to division 
resolution by holding down Control, and to tick resolution by holding down Shift-
Control.
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Setting Autodrop Numerically
The positions of the Autodrop locators are displayed numerically, to the right of the 
Cycle locators on the Transport window. These positions can be altered by using the 
mouse as a slider, or by direct numerical entry in this display window.

Recording in Autodrop Mode
To make an autodrop recording, place Logic in Record mode at any position before the 
drop-in point. Any events played before the drop-in or after the drop-out points are 
channelled through the sequencer as usual, but are not recorded.

If the SPL is positioned after the right locator when you start recording, recording 
automatically begins at the drop-in point, following the count-in.

If Autodrop is enabled during recording, the Record button will flash while the song 
position is outside the drop locators. This indicates that no recording takes place.

Combining Cycle and Autodrop
If you want to improve a difficult part of a certain passage, you can use a combination 
of the cycle and autodrop functions. Cycle mode allows you to practice as many times 
as you like before the “final take”. On each cycle pass, only events that fall within the 
autodrop range are recorded. This allows you to make use of the preceding song 
section to “get into the groove”.

Chase Events
Chase Events searches all MIDI Regions playing at a specified “jump-in” point. The 
function examines what all MIDI Regions are doing before the jump-in point, to 
determine which events would have affected playback at the jump-in point, if reached 
by playing through the song, rather than by just jumping there.

This is a difficult concept to grasp, so here’s another explanation:

If you start playback in the middle of a song by jumping straight to that point (via Cycle 
mode looping or by direct SPL placement), you might expect a problem or two with 
note playback. If an important note started playing just before the playback start point, 
you would expect Logic to overlook it, and the note wouldn’t be heard. Notes, however, 
are not the only potential problem. If there were a maximum pitch-bend message just 
before the playback start point, you would miss out on this too. Fortunately, Logic is 
smarter than your average MIDI sequencer, to misquote Yogi Bear…

Open the File > Song Settings > MIDI > Chase page, to set up the Chase Events function.
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The Chase Events function searches all MIDI Regions at the playback start point. It looks 
for a selection of the following before the playback start point:
• any notes due to start playing at the playback start point.
• any notes that are still playing at playback start point—held-down sustain pedal 

(Chase sustained Notes).
• program changes.
• pitch-bend information.
• continuous controllers 0 to 15.
• continuous “switch” controllers 64 to 71.
• all other controllers (all other Controls).
• monophonic (channel) aftertouch.

There is a potential problem when chasing notes that are used to trigger a drum loop 
in a sampler. Unless you are lucky enough to start the MIDI Region precisely at the 
beginning of the sample loop, the sample will be triggered at the wrong time and will, 
therefore, be played out of sync with the rest of the MIDI Region (at least until the next 
trigger note). The problem is that most samplers can only play samples from the 
beginning, and cannot synchronize them to the beat when started in the middle.

To solve this potential issue:

Activate the No Transposeparameter of your drum loop instrument, in the instrument’s 
Object Parameter box, and switch off the In ‘No Transpose’ instruments option in the 
MIDI > Chase page of the Song Settings. The result of this selection is that whenever the 
song jumps to a new position, your drum loops will not play until they reach the next 
“trigger note”.

The No Transpose parameter actually prevents transposition by the Region playback 
parameters, which is also not desirable for drum sounds or loops.
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3 Arrange Window
The Arrange window is the heart of Logic. It is the view 
that you will see most often when working with the 
program.

You will learn all about the different interface elements, functions, and features of the 
Arrange window in this section. You will also discover how to handle both MIDI and 
audio tracks plus a number of other important techniques.

Overview

The Arrange area is where all MIDI and audio information is recorded, on horizontal 
tracks. Individual MIDI recordings are called MIDI Regions, audio recordings are called 
Audio Regions. Both Region types are displayed as horizontal “beams”. Above the 
Arrange area is the Bar Ruler, which displays position information.
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To the left of the Arrange area is the Track List (see “Tracks” on page 92). This is where 
you determine which (Audio) Object should play the MIDI or audio information on 
each track. You can make various settings for these Objects in the Object Parameter box 
in the lower left corner.

As the Regions are arranged graphically, you can also use specialized mouse tools from 
the Toolbox to help you perform different operations.

The Region Parameter box (see “MIDI Region Playback Parameters” on page 116) is used 
to set playback parameters, such as transposition and quantization (see “Quantization” 
on page 120), for individual Regions.

The channel strip at the bottom left corner of the Arrange window always shows the 
mixer channel strip of the currently selected track.

Opening the Arrange Window
The Arrange window can be opened by selecting Windows > Arrange in the main 
menu, or by pressing Command-1.

If preferred, you may define an alternate key command for Open Arrange Window in the 
Key Commands window (see “Key Commands” on page 36).

Note:  Many Arrange window features apply to MIDI and Audio Regions, but some are 
only relevant to one or the other. This chapter describes general and MIDI features. 
Specific audio features are dealt with in Chapter 4, “Audio in the Arrange Window,” on 
page 133.

Tracks
A track is where audio signals and MIDI events are recorded (into Regions and MIDI 
Regions, respectively). They are stacked vertically and extend horizontally across the 
Arrange area. Most of the functions described in this section are identical for MIDI and 
audio tracks.
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Overview
There are basically three types of tracks:
• Audio tracks:  for playback, recording, and automation of audio signals.
• Audio Instrument tracks:  for playback, recording, and automation of MIDI data sent 

to software instruments.
• MIDI tracks:  for playback, recording, and automation of MIDI data sent to external 

MIDI devices.

In addition to these tracks, there are also tracks with very specific functions, such as the 
Global tracks (see “Global Tracks” on page 239). The descriptions in this section don’t 
deal with these special tracks.

Each track is numbered from top to bottom in the Track List. During playback, a small 
level meter appears next to the track number.

For MIDI or Audio Instrument tracks:
This indicates the velocity of the recording, and turns red to denote a maximum 
velocity value. MIDI tracks also indicate MIDI controller data playback via a small c that 
appears temporarily over the track number. 

For audio tracks:
The level meter denotes the output level.

Note:  The level indicator is only displayed if selected via the Arrange window View > 
Track Numbers/Level Meters menu option.

To the right of the track number (and possibly, the Mute, Record, Solo, and Freeze 
buttons—dependent on track type and View menu settings) is an icon and a name. 
Click-holding on the track name allows you to assign a destination for the track—
regardless of track type.

If you wish to route a track (containing MIDI events in a MIDI Region) to a MIDI sound 
generator or software instrument, select a suitable instrument as the track destination.

If you wish to route a track (containing audio data in an Audio Region) to a specific 
audio channel number, select the desired audio channel as the track destination.
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Note:  Strictly speaking, tracks don’t need to be routed to an instrument or audio 
channel, as you can assign any Environment Object to the output of a track. The track 
data could conceivably be sent to a folder, or directly to a MIDI port (a MIDI Region). 
Obviously, audio data would not be understood by a MIDI sound module, so there is no 
point in routing a track that contains audio data (in a Region) to an instrument. 
Similarly, there is no point in routing a track that contains MIDI data (in a MIDI Region) 
to an audio channel.

To aid understanding, we will use the term “instrument” rather than “audio channel” (or 
the correct, but long-winded, “track data destination object”) in this section.

A MIDI track is automatically record enabled when selected. The Record Enable button 
turns red to indicate this “armed” state. During recording, a MIDI Region (containing the 
recorded MIDI events) is created on the selected (and armed) track.

An audio track is not automatically record enabled when selected. You must press the 
Record Enable button on the desired track, which will turn red to indicate an “armed” 
state. During recording, an Audio Region (a pointer to the recorded audio file) is 
created on the selected (and armed) track.

Track Icons
Logic offers high resolution, scalable (from 128 × 128 pixels downwards), and user-
definable icons.

User-Definable Icons
You can create your own icons for tracks. These icons must be of 128 × 128 pixels in size, 
must have an alpha channel for transparency and must be saved in the portable 
network graphics format (with the “.png” suffix). The filename must also start with a 
three-digit number. If this number is below 325, the corresponding built-in Logic icon 
will be replaced with your new graphic (you can check the number of existing Logic 
icons by clicking on them in the Object Parameter box).

There are two possible locations for user icons:

The ~/Library/Application Support/Logic/Logic Resources/Icons folder can contain icons 
which are only valid for the particular user (~ is the user name). If you save your icons 
in the root directory—/Library/Application Support/Logic/Logic Resources/Icons—the 
icons are valid for all users. If icons with identical numbers exist in both folders, the 
icons found in the user folder have priority.
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Icon Color
The small, monochromatic icons adopt the color of their “parent” Audio Object or MIDI 
Instrument Object—which is also used for newly recorded Regions in the Arrange 
window.

The high resolution Arrange icons have their own color and, therefore, cannot adopt 
the color of the “parent” Object. 

Selecting a Track
You can select a track by clicking on its name or icon in the Track List. This also selects 
all Regions on the track (or if the Cycle function is switched on, it only selects the 
Regions that fall within the defined Cycle area).

Use the Select Next/Previous Track key commands to select the track above/below the 
selected track in the track list (default key assignments:  Up Arrow/Down Arrow).

Changing Tracks While Retaining Your Selections
If you click on a new track while holding down Option, the track will be selected 
without changing the existing selection of Regions. 

Sorting Tracks
To change the position of a track in the Track List, grab the track number, and drag it 
up or down. The cursor will turn into a hand graphic, to indicate that the track can be 
repositioned vertically.

Creating Tracks
To create a track, use the Track > Create command. The new track is created at the 
currently selected track position, and all ensuing tracks (below it) are moved down the 
Track List.

To create a track at the bottom of the Track List, double-click below the lowest track in 
the track list.

Creating a Track with the Next Instrument
The Track > Create with next Instrument function, creates a new track below the selected 
track, and assigns the next instrument to it (from the instrument selection list). Under 
most circumstances, this would be the next MIDI channel in the same sound module.

You can also hold down Option while double-clicking under the Track List when you 
create a new track.

Copying a Track
If you hold down Option when moving a track, a copy of the track is created at the 
destination position. All selected Regions on the old track are also moved to the new 
track. 
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Note:  If you hold down Option before grabbing the track number, no extra Regions on 
the track will be selected. If no Regions were selected in the first place, an empty track 
with the same track instrument is created at the destination position. 

If the Cycle function is switched on, all Regions in the Cycle area are moved from the 
old track to the new track. The musical result is not any different, because the new track 
is played by the same track instrument.

Moving Regions onto a Track
The function Region > Move Selected Regions to Current Track moves all selected Regions 
from different tracks onto the selected track. The time position of all Regions is 
retained.

Deleting Tracks
To delete the selected track, use the Track > Delete function. If there are any Regions on 
the track, a warning message appears first.

If there is no Region selected in the Arrange area, you can perform the same function 
by pressing Backspace.

A third method is to grab the track as if to reposition it (see above), and remove it from 
the Track List by dragging it to the left.

Deleting Unused Tracks
Use the Track > Delete Unused function to delete any tracks that don’t contain any 
Regions.

Naming Tracks
To name a track independently of its assigned instrument, select Track > Create Track 
Name.

You can also change the name of an existing track by double-clicking on the 
instrument name in the Track List, while holding down Command, and typing in the 
text input field that appears.

The track name is then displayed in place of the instrument name in the Track List, and 
will be used as the default name for recorded Regions.

If there is enough room vertically (achieved by zooming in vertically), both the track 
and instrument name will be displayed.

You can see the instrument name in the Object Parameter box, or check it by clicking 
on the track name and holding down the mouse button.
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Name While Creating a Track
When you create a track (by double-clicking below the bottom track in the Track List) 
you can hold down Command at the same time to open the input box for the track 
name.

Deleting Track Names
To delete a track name, select Track > Delete Track Name.

You can also double-click on the track name while holding down Command. This opens 
the text input field for the track name. The name can be deleted using Backspace. The 
instrument name will then appear in the Track List again.

Muting Tracks
Both MIDI and audio tracks have Mute buttons to the left side of the Track List, 
between the track number and the icon. Muting a track stops it from playing. To show 
or hide the blue Mute buttons, select View > Track Mute Buttons.

Muting When the Mute Buttons Are Hidden
If the Mute buttons are hidden—to save space—you can still mute a track to the left of 
the track number.

If you move the mouse to the left edge of the Track List by the track number, the 
mouse pointer turns into a hand; clicking the mouse shortly now mutes the track (or if 
the track is already muted, it cancels the mute). Muted tracks are then indicated by a •.

You can also use the Mute Track key command to mute a track.

Muting All Tracks
If you hold Command while clicking on a Mute button in the Track List, all tracks in the 
currently-selected display level (or folder) are muted. If they were already muted, they 
will be unmuted.

Mute Instrument
If you mute a track while holding down Command-Option, all tracks in the current 
song with the same track instrument (including those in all folders) are muted.
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Soloing Tracks
Both MIDI and audio tracks (and folders) offer Track Solo buttons to the left side of the 
Track List, between the track number and the icon. Soloing a track isolates it while 
playing—and mutes all other tracks. To show or hide the yellow Track Solo buttons, 
select View > Track Solo Buttons.

Activating any Track Solo button enables Solo Lock mode (see “Solo and Solo Lock” on 
page 81), if necessary, and adds all Regions on that track to the Solo Lock Group. The 
button turns yellow when active. Deactivating a Track Solo button removes all Regions 
on the track from the Solo Lock group and—in cases where no other Track’s Solo 
button is active—disables Solo Lock. Disabling the global Solo (Lock), sets all individual 
Track Solo buttons to the Off position.

Soloing When the Track Solo Buttons Are Hidden
If the Track Solo buttons are hidden—to save space—you can still solo a track with the 
Solo button on the Transport bar.

Simply press the Transport Solo button, and click on the desired track. Soloed tracks are 
indicated by a yellow outline.

Soloing Multiple Tracks
If you hold down Shift while the Transport Solo button is active, and click on the 
desired track names, you will solo them (when the track Solo buttons are hidden).

If you hold any modifier while clicking on a Solo button in the Track List, all tracks in 
the currently-selected display level (or folder) are soloed. If they were already soloed, 
they will be unsoloed.

Note:  You can make use of the Track Button Slide Activation feature for both the Track 
Solo and Mute button functions (see “Track Button Slide Activation” on page 98).

Track Button Slide Activation
Buttons on Arrange tracks (Solo, Mute, Record Enable, Freeze) support “slide activation”, 
which is similar to running your finger across several channel strip buttons on good 
hardware mixing consoles. 

As a usage example of slide activation in Logic, click-hold on the Mute button of one 
track, and drag the mouse up or down. The Mute buttons of all “swiped” tracks will 
switch to the same state. 

Simply drag over the Mute buttons of the same tracks to undo the Mute.
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Selecting an Instrument
Click-holding on an Instrument’s name (or icon) in the Track List opens a hierarchical 
pull-down menu. The sub menus of this pull-down menu correspond to the 
Environment layers  (see “Layers” on page 154) of your song. This is where you select 
and assign Instruments to a track.

Changing an Instrument Assignment Globally
If you hold down Option while selecting an Instrument, the previously selected 
Instrument will be replaced in every track in the current song by the new Instrument 
(even in tracks in folders).

Selecting Track Instruments by Drag and Drop
You can select any of the Objects in the Environment window to be the current track 
Instrument, by simply dragging one out of the Environment window, and dropping it 
onto the Track List.

If you move a Multi Instrument into the Track List, the selected sub-channel is set as the 
track Instrument. If no sub-channel is selected, all initialized (the sub-channels that are 
not crossed out) sub-channels are set for the destination track, and the tracks below 
that. If there are no tracks below the destination track, new tracks will be created.

In all cases, the Environment Objects involved are completely unaltered.

Special Types of Instruments
In addition to the normal instruments which are described in the Instruments section 
(see “MIDI Instruments” on page 101), there are two other possible track settings for 
which there is no corresponding Environment Object:

No Output
Tracks assigned as No Output send no data. This can be useful in situations where you 
wish to store data (such as SysEx) that you don’t wish to send.

Folder
This setting is used when you want the track to play a folder (see “Overview” on 
page 122). Normal Regions will not play on a track set to the Folder instrument.

Protecting Tracks
Tracks can be protected, preventing any alterations:
• Existing Regions and their contents cannot be altered.
• No recording is possible on protected tracks.
• New Regions cannot be created.
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If the Track Protect button is not visible in the Track List, you can switch it on via the 
Arrange menu View > Track Protect Buttons. Clicking on the Lock button(s) toggles 
between locked and unlocked mode.

If you hold Command while clicking on a Track Protect button in the Track List, all 
tracks in the currently-selected display level (or folder) are protected. If they were 
already protected, they will be unprotected.

Arrange Channel Strip
The channel strip of the currently selected Arrange track will appear in the Parameters 
area of the Arrange window, provided that there is sufficient space to display it. 

If there is not enough vertical room, click the upper left triangles in the Region 
Parameter and/or Object Parameter boxes and/or hide the Toolbox (View > Toolbox). 

Note:  The Channel Strip Only option in the View menu (and key command) allows you 
to hide all elements of the Parameters area — except the Arrange channel strip. 
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The Arrange channel strip allows you to access all of the mixer channel functions 
(volume, pan, sends, inserts, and so on) directly from the Arrange window. Any 
adjustments you make to a track’s Arrange channel strip will be reflected in the 
corresponding Track Mixer and Environment channel strip as well.

Resizing the Arrange Channel Strip
You can alter the size of the Arrange channel strip (and the entire Parameters area), by 
moving your mouse cursor over the “resize bars” (two vertical lines) between the 
Parameters area and the Track List. The cursor appearance will change, allowing you to 
click and drag horizontally. As you do so, the Parameters area is resized, and both it and 
the Track List will move left or right, until the mouse button is released.

This facility makes reading parameter names and labels clearer.

MIDI Instruments
In order to know where specific MIDI messages are to be sent, Logic needs to have 
some idea of how the MIDI devices in your setup are connected. This is portrayed 
graphically in the Environment, which shows the sequencer’s connection with many 
other Objects, which we will refer to as “Instruments” in this section. Each instrument is 
an Environment Object, which represents a physical MIDI device. You can think of the 
Instrument Object as being a virtual instrument, or a representation of a real 
instrument.

To learn how to configure the Environment, refer to the Environment section (see 
“Environment—Introduction” on page 153).

To make an instrument visible:
m Double-click on the instrument name in the Track List. This directly opens the 

Environment window, with the Object selected.

Creating a New Instrument
It is best to create Instruments directly in the Environment, but you can also do so from 
the Arrange window, by using the Create New Instrument key command. The selected 
track will then contain a new Instrument, whose parameters can be adjusted in the 
instrument’s Object Parameter box. The new Instrument will also be present in the 
Environment. All Instruments in the Arrange window exist in the Environment, no 
matter where they were created originally. 
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The Instrument Parameters
The Instrument’s Object Parameter box is located at the bottom left corner of the 
Arrange window.

The Instrument parameters belong to the Instrument Object, not to the track per se, so 
if you alter the parameters here, it will affect all tracks playing (addressing) the 
Instrument.

Note:  The Instrument’s Object Parameter box in the Arrange window is identical to the 
corresponding Object Parameter box for the same Instrument in the Environment. 

To open/close the Instrument’s Parameter box:
m Click the small triangle at the top left to open or close the Instrument’s Parameter box.

Name
The top line shows the instrument name, which can be edited by clicking on it.

Object Type
The Object type is shown in brackets, and cannot be altered. Normally this will 
be:  (Instrument) or, if you’re using Multi Instruments:  (Sub Channel).

Selecting an Icon
Grabbing the icon opens a pop-up menu, where you can assign a new icon to 
represent the Instrument. 

Note:  If you have closed the Object Parameter box, or it is hidden from view, you can 
select an icon directly from the Track List by clicking on the icon while holding down 
Option-Command.

Color of the Instrument Icon
If you selected a single-colored icon, you can change its color, using the usual color 
palette with:  View > Colors, as long as no Region is selected. The color of the 
instrument icon serves as the default color for all Regions recorded on this track.
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Hiding an Instrument
The small box to the left of the icon determines whether the instrument appears in the 
instrument selection pop-up menu of the track list. You will generally always have this 
checked for Instrument Objects.

Note:  This option is primarily used to reduce the size of the instrument pop-up menu, 
by hiding other Environment Objects, such as faders or MIDI ports.

MIDI Channel and Port Connection
The Port parameter, found in the Instrument’s Object Parameter box (see “Global 
Preferences” on page 476), defines the MIDI Output that the instrument’s data is sent 
to. Your MIDI sound module is connected to this output jack. 

Note:  If the instrument has not been connected with cables in the Environment, this 
line can be used to set the Instrument’s output port via a pop-up menu (containing the 
names of all installed MIDI drivers). This means that the instrument is directly 
connected to one of your MIDI interface’s MIDI Out ports. As such, this line represents 
an unseen direct connection, as there is no visible cable connection for the instrument 
in the Environment window. 

The purpose of a hidden direct connection is to enable you to address the individual 
MIDI ports directly from the Arrange window without needing to access the 
Environment window. For most situations, this is the best way to assign instruments to 
ports, as it eliminates the need for cabling.

Keep in mind that if you directly assign a port, and also connect the instrument to a 
MIDI Out Object with a cable, all MIDI data sent via that instrument will be doubled. If 
you attempt to do this, Logic displays a dialog box asking whether or not you should 
“Keep or Remove?” the direct connection. You will generally select Remove in this 
situation.

The MIDI channel is set with the Channel parameter. This defines the channel used for 
MIDI data output by the instrument, allowing your “real” instrument to receive the data.

Setting the MIDI Channel: Multi Instruments
In the Instrument’s Object Parameter box, you can also alter the MIDI channel of an 
instryment part (a “sub-channel” or “part” of a Multi Instrument). This does not reassign 
the channel for the current part, but rather selects another sub-channel from the 
current Multi Instrument.

You can’t actually change the receive channel of a part in the multitimbral synthesizer. 
This is only possible in a few models (and is not particularly useful when using a 
multitrack sequencer, at any rate). The Channel parameter is really an alternative way of 
changing the track instrument, allowing the track to be played by a different part (sub-
channel) in the multitimbral synthesizer.
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If the MIDI channel is set to All, you can edit the parameters of the whole multi 
instrument. A useful facility for globally changing the MIDI port, for example.

Adjusting the Sound of a Track
The Program, Volume, and Pan parameters transmit program changes, volume 
controllers (#7) and pan controllers (#10) respectively. 

If the respective box is unchecked, the default value of the MIDI device itself is used. 
The corresponding value is only transmitted if you place a check in the box, by clicking 
in it. If the box is already checked, any value changes are transmitted immediately.

A program change may be selected on the right, via a pull-down menu. Volume and 
panorama are set by using the mouse as a slider. Control-clicking just above or below 
any current value increases or decreases it.

To the left of the program number, there is an extra parameter which is used for Bank 
Select. If your sound source can receive Bank Select messages (MIDI controller #0 or 
#32—check your synth manual for format details), you can switch between different 
banks, each containing a maximum of 128 sounds. 

As many devices cannot receive these messages, you can deactivate this parameter by 
making the setting shown here.

For more on the other instrument parameters, take a look at the descriptions in the 
Standard Instrument section (see “Standard Instrument” on page 163).

Recording Program Changes, Volume, or Pan Controllers
Any of the listed event types available in the Instrument’s Object Parameter box can 
also be stored when in Record mode. 

As an example, in Record-Pause mode, you can store program changes at 
specific positions in the following way:

1 Deactivate the Program (or Volume/Pan) checkbox.

2 Click on the Pause button in the Transport bar.
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3 Activate the Record button in the Transport bar.

4 Move the Song Position Line to the desired song position.

5 Select the desired sound (program) and/or the volume/pan setting you want to use.

6 Activate the Program (or Volume and Pan) checkbox(es). Each selected event will be 
sent and recorded.

7 Click the Stop button in the Transport bar to exit recording mode. 

The values of the Program, Volume, and Pan parameters will not be updated every time 
such control change events are played back. These parameters are initial values, when 
you load a song, or use the MIDI > Insert Instrument MIDI Settings as Events command—
before you begin to record mixer automation data. 

Further Parameters
You also find the following parameters in the Instrument’s Parameter Box:

Transpose
The Transpose parameter allows you to define the number of semitones that all note 
events will be transposed by on output. Negative values transpose downwards.

Velocity
The Velocity parameter allows you to increase or decrease the “note on” velocities of all 
note events by an amount adjustable between −99 and 99.

Key Limit
The two note values of the Key Limit parameter define a pitch range. All notes outside 
this range will be ignored by the instrument when it plays a MIDI Region.

Vel Limit
The two values of the Vel Limit parameter define a velocity range. All notes whose 
velocity is outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late by from −99 to 99 
ticks. This allows you to adjust for any differences in reaction time between your 
various MIDI devices. For delay effects use the Region parameter of the same name, as 
this allows longer delay times.

No Transpose
If the box next to the No Transpose parameter is checked, all Regions on any tracks 
played by this instrument are protected from transposition. In other words, the 
Transpose Region parameter is ignored. This is very useful for instruments assigned to 
drum or other multi-timbral samples, as transposition will cause the sounds rather than 
the pitches to change for these instruments.
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No Reset
If the box next to the No Reset parameter is checked, no reset messages will be sent to 
this instrument. This can be useful if controllers are being used for non-musical 
purposes, for example when an Instrument is used for mixer automation. The 
Preferences > MIDI > Reset Messages window controls what reset messages are normally 
sent, but these messages are not sent to “No Reset” instruments.

Style 
The Style parameter is located at the bottom of the Parameter box. It displays Auto by 
default but can be changed to any of the available score styles. Whenever a Region is 
created on one of the Instrument’s tracks it will be assigned the score style displayed 
here. In the case of Auto, Logic will pick an appropriate style based on the pitch range 
of the notes in the Region.

Don’t forget:  you can change a MIDI Region’s Score Style at any time in the Display 
Parameter box in the Score window. 

You can change the score styles of all MIDI Regions on an Instrument’s tracks by 
holding down Option when selecting the Instrument’s default score style.

Additional Audio Instrument Object Parameters
All of the abovementioned parameters are available for Audio Instrument Objects, 
which also share the following additional checkboxes with Audio tracks/Objects. There 
is one exception, however:  Audio Instrument Objects have a Device parameter instead 
of a Port parameter, which allows you to specify the audio device, rather than a MIDI 
port.
• Show EQs:  Hides/shows the Track EQ button at the top of the channel strip.
• Show Inserts:  Hides/shows Insert slots on the channel strip.
• Show Sends:  Hides/shows Sends on the channel strip.
• Show I/O:  Hides/shows the Input and Output slots on the channel strip.

A further Value as pull-down menu is available, which allows you to display parameters 
numerically (Num) or in decibels (dB). 
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MIDI Regions
MIDI Regions are containers for the MIDI events within them. Containers for audio data 
are referred to as Audio Regions (or simply Regions). Audio Regions can be compared 
(see “MIDI and Audio Regions Compared” on page 140) to MIDI Regions as far as how 
they are used and edited. The purpose of MIDI Regions is to make things clearer and 
easier to deal with. They also correspond to the musical convention of treating a phrase 
or a riff as a single unit. It’s often better to perform operations (such as quantization) on 
these units, rather than on individual notes.

Note:  MIDI Regions can overlap one another, partly or completely, within a track. This 
should generally be avoided, for clarity’s sake.

Remember that all operations described in this section with a plural in the heading 
(MIDI Regions, for example), apply to one or more selected MIDI Region(s).

Creating a MIDI Region
Normally a MIDI Region is created automatically when you record on the selected track. 
It begins at the start of the bar in which the first event was recorded, and stops at the 
end of the bar in which the last event was recorded.

Note:  MIDI Regions can also be created by directly inserting events (see “Special 
Functions” on page 115) from the Clipboard into the Arrange window.

Creating an Empty MIDI Region
Click at the desired position in the Arrange area with the Pencil tool to insert the empty 
MIDI Region. You can now manually enter events into this new MIDI Region in one of 
the editors.
Chapter 3    Arrange Window 107



108

 

Deleting MIDI Regions
You can delete all selected MIDI Regions by clicking on them with the Eraser tool, or by 
pressing Backspace. You can also delete any non-selected MIDI Region by clicking on it 
with the Eraser.

Retrieving Deleted MIDI Regions
Should you accidentally delete a MIDI Region, you can restore it by selecting Edit > 
Undo (Command-Z) immediately after making the error.

Drag Menu
Before looking at moving and editing Regions in the following sections, we’d like to 
cover the Drag pull-down menu. It allows you to set preferences for edits that you may 
perform on Regions within the Arrange window. 

The Drag pull-down menu provides:  No Overlap, Overlap and X-Fade modes. These are 
all audio editing modes that alter the behavior of Audio Regions when different 
operations are performed:
• X-Fade mode will automatically crossfade two Regions when they are moved to an 

overlapping position.
• No Overlap is used in situations where you don’t want Regions to overlap. In this 

mode, the first Region (the one positioned earlier on the track) will be “clipped” 
(shortened) so that no overlap occurs. 

• Overlap mode will preserve the original Region borders, even when you move 
Regions to overlapping positions. This was the standard mode of earlier Logic 
versions.

Note:  The Drag menuis also available in several other editors.
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Moving Regions
Regions may be moved by grabbing and dragging them with the mouse pointer. You 
can move Regions along the timeline and from one track to another. You can also move 
them between two Arrange windows.

Note:  If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area 
in order to move it.

Tying Regions by Length Change
The Region > Tie Regions by Length Change option lengthens the selected Region(s), 
making them end exactly at the startpoint of the next Region on the track.

Tie Regions within Locators
Region > Tie Regions within Locators makes all selected Regions within the Locators 
longer, closing the gaps between them. The last Region on each track (within the 
locator boundaries) won’t be affected.

Editing the Start Position Numerically
You can edit the start point of a MIDI Region (and its length) numerically. This can be 
done from an Event List set to view objects at the same level (see “… on Arrange Level” 
on page 304) as the Arrange window or in a floating event window (see “Event Float 
Window” on page 310).

Copying Regions
To copy Regions to another point in the song, or to other tracks, hold down Option 
while moving the Region. 

Note:  Holding Option-Shift while moving a MIDI Region allows you to create an Alias 
(see “Aliases” on page 124) of it.

If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area in 
order to copy it.

Note:  Copy/paste and Option-drag create a independent copy of the Region. This copy 
will not reflect changes made in the original Region. If you want this type of behavior, 
make use of the Loop parameter.

Making Multiple Copies of Regions
The Region > Repeat Regions menu allows you to repeat one or more selected Regions. 
The repetition always starts at the end of the Region itself, or at the end of the last 
(along the time line) Region.

Number of Copies
This is where you enter the number of copies (excluding the original).
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Adjustment
Used to determine whether you want a copy to begin exactly at the end of the original 
or the previous copy (setting:  None), or whether you want the startpoint to be 
“quantized”. In most cases, the Auto setting will be suitable.

“as”
This parameter determines whether the repeats are copies or aliases of the original.

Altering the Length of Regions
Grab the Region at the bottom right corner, with the pointer or pencil tool, to move 
the endpoint of the Region to the desired position. The data in Regions is never 
deleted, even when they’re shortened; playback simply stops at the end of the Region. 
Restore the length of the Region in the same fashion to hear the playback of events/
audio data at the end of the Region.

If Hyper Draw is enabled for the Region, you’ll need to grab above the blue area, in 
order to adjust the endpoint.

Multiple Selection
You can change the length of multiple Regions in the same way. The length will be 
changed by the same absolute amount.

Same Absolute Length
If you want to make all selected MIDI Regions the same absolute length—even if they 
had different original lengths—simply hold Option-Shift while changing the length 
(just as in the Matrix Editor or the Event List).

Adjusting the Region Startpoint
You can also adjust the length of the MIDI Region by grabbing it at the bottom left 
corner. It should be noted that you can never move the left corner beyond the first 
event in the MIDI Region—you can never “hide” events from the beginning of the MIDI 
Region. If you want to remove the start of a MIDI Region you need to cut it, and mute 
or delete the new start segment (new MIDI Region).

Rounded to Whole Bars
The MIDI > Snap Region Start to Bar function rounds the Region startpoint to the 
nearest whole bar.

The position of events within MIDI Regions is not affected by changes to the Region 
length. 

If you wish to alter the position of the events:
m Hold down Option while altering the length of a MIDI Region to alter the timing of 

events. The events will be stretched or compressed, proportionately, by the amount 
that the MIDI Region was altered in length.
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Note:  You can make a rhythmic MIDI Region play in “half-time” by stretching it to twice 
the original length, or in “double-time” by shortening the length to half the original 
length.

… to Adjust It to Fit Its Contents
The MIDI > Set Optimal Region Sizes function reduces or increases the length of a 
Region, making it just large enough to contain the events (or Regions, if a Folder) 
within it. The Region borders are rounded to the nearest bar.

Holding down Option when using this function rounds the borders to the nearest beat.

… to Adjust It to Fit Other Regions
The Region > Remove Overlaps function searches all selected Regions in a track for 
overlaps. If an overlap is found, the earlier Region is reduced in length, thus removing 
the overlap.

Using a Finer Grid
All of these operations (moving/copying, lengthening/shortening) snap to the bar or 
beat grid, depending on the current resolution of the Bar Ruler, and the setting of the 
zoom function. There are two ways to override the grid, allowing finer adjustments. All 
you need to do is hold these keys during the particular operation:
• Display Format values as grid scale:  Press Control during operation.
• No grid (ticks as grid scale):  Press Control-Shift during operation.

Let’s say you want to shorten a Region in a 4/4 bar so that the “4” is played but not the 
“4 and” of the last bar. 

This can be done by following these steps:
1 Zoom the screen display until you can see quarter notes in the Bar Ruler. 

2 Grab the bottom right corner of the Region, and move the mouse to the left, until the 
Region is shortened by one quarter note. 

3 Press (and hold) Control, and move the mouse carefully to the right, until the Region 
has become one division longer. While you’re doing this, the help tag shows the Region 
start position, track number, and the current length of the Region in bars, beats, 
divisions, and ticks. The three right-hand numbers should be “3 1 0”.
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Dividing MIDI Regions
Click on the Scissors (see “The Tools” on page 18) in the Toolbox. Now click-hold on the 
desired MIDI Region(s). The help tag shows the current mouse position. When you 
release the mouse button, all selected MIDI Regions are cut at the position shown in 
the help tag. The grid is based on the Display Format value. This value is displayed and 
is adjustable in the Transport window, just below the Time Signature indicator.

If any notes overlap other notes by more than a 1/16 note, the following dialog will 
appear on-screen:

Overlapping Notes found! Do you want to keep, to shorten or to split those?

Keep (default) leaves all notes unaltered. The MIDI Region is cut as usual, but when you 
do this, you can end up with notes in the left-hand half that are much longer than the 
MIDI Region containing them. Such notes will play normally, unless “Clip Length” is set 
to On, which cuts off all sustaining notes at the end of a MIDI Region.

Shorten truncates all overlapping notes, so that they end at the point where the MIDI 
Region was divided.

Split divides overlapping notes across the two MIDI Regions created when a cut is 
made; two notes are created, with the same pitch and velocity as the original, and with 
the same total length as the original note.

Multiple Divisions With the Scissors
If you hold down Option while cutting a Region with the Scissors tool, the selected 
Region will be cut into multiple pieces of the same length as the first segment.

As an example:  To divide a 16-bar Region into eight 2-bar Regions, cut the Region at 
the start of bar 3, while holding down Option.

Graphically
You can achieve the same effect by defining a cycle area with the mouse in the Bar 
Ruler, while holding down Command. 
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Merging MIDI Regions
You can merge two or more selected MIDI Regions into a single MIDI Region, by 
clicking on one of them with the Glue tool (see “The Tools” on page 18).

The function of the Glue tool is the same as Region > Merge > Regions. This merges all 
selected MIDI Regions—even those on different tracks—into a single MIDI Region. All 
events from each individual MIDI Region retain their original time positions. Be aware 
that the individual MIDI channels are replaced by the MIDI channel of the current 
track’s Instrument. The new (merged) MIDI Region adopts the name and track of the 
first (along the time line) of the merged MIDI Regions (see “Fixing/Neutralizing MIDI 
Region Parameters” on page 120).

The Region > Merge > Regions per Tracks function has the same effect as Merge Regions, 
but if the selected Regions are on several different tracks they are combined into one 
Region per track.

The Region > Merge > Regions, the Region > Merge > Regions per Tracks and the Glue tool 
functions handle the Transpose, Velocity, and Dynamics Region parameters intelligently. 
If these parameters are not identical in all selected Regions, the Regions are normalized 
before the merge. If one of the Region parameters (the Transpose value, for example) is 
set identically in all selected Regions, that value is preserved, and the events remain 
unchanged.

Demixing Regions
The Region > Split/Demix > Demix by Event Channel function searches the selected 
Region for events with different MIDI channels. A separate Region, containing all 
matching events, is created for every MIDI channel that is found. Each of these Regions 
is created on a track with an Instrument that matches the MIDI channel. If no such 
tracks exist, new tracks are created, using the original Instrument’s track.

This function is useful for the import of Standard MIDI Files (Format 0), when all note 
events are placed in a single MIDI Region.

The Region > Split/Demix > Demix by Note Pitch function searches the selected MIDI 
Region for notes with different note numbers. A different MIDI Region of the same 
length is created for every note number found. The tracks created for these MIDI 
Regions is assigned to the same Instrument as the original MIDI Region. This feature is 
especially useful for separating drum parts that have been recorded into Logic from a 
drum machine.
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Muting Regions
Often, when arranging, you’ll want to test musical ideas by muting certain Regions. This 
is what the Mute tool (see “The Tools” on page 18) is designed for.

You can mute individual or selected Regions by clicking on them with the mute tool. 
Clicking a muted Region reverses this state (unmuting). Muted Regions are indicated 
by a dot that precedes the Region name, and are shaded (dependent on the 
Preferences > Display > Arrange > Muted Regions are textured setting).

Note:  You can perform the same function with the Mute Folders/Regions key command.

Soloing Regions
You can solo any selected Regions by using the Solo button in the Transport window, 
or the key command of the same name. 

Double-clicking on the Solo button “locks” the soloed status, so that changing the 
selection doesn’t affect what is being soloed. This is especially useful when you want to 
make changes to the playback parameters of a Region, while listening to a specific solo 
group. 

Another click (or reusing the key command) exits solo mode. For more on this, read the 
Solo and Solo Lock sections (see “Mode Buttons” on page 81).

When the Solo function is activated, the Bar Ruler will change from gray to yellow, 
making it easy to see that Solo is engaged.

The Solo tool (see “Selecting Tools” on page 17) enables you to solo individual or 
selected Regions, by click-holding on them. You can also scrub the Region by moving 
the mouse horizontally. If Logic is in play mode, solo playback starts as soon as you 
stop scrubbing. Release the mouse button to end solo auditioning.
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Naming a Region
Click the Region with the Text tool (see “The Tools” on page 18), and a text input box 
will appear. Enter the desired name and press Enter, or click another Region or the 
Arrange area background to exit text input mode.

The same applies if entering a name in the Region Parameter box.

Multiple Naming
Select a group of Regions (with the rubber band, for example), and click one of them 
with the Text tool. A text input box will appear, allowing you to name the Region. All 
Regions are assigned same name.

With Incrementing Numbers
If you end the name of the Region with a number, all selected Regions are assigned the 
same name, but are incrementally numbered (region 1, region 2, region 3, and so on). 
They are numbered in accordance with their temporal (time) positions. If you want all 
Regions to end with the same number, just add a space after the number.

The above also applies if you enter the name in the top line of the Region Parameter 
box, rather than use the text tool.

Special Functions
Inserting Events
MIDI events can be added directly to the selected track in the Arrange window, at the 
current song position, via the Clipboard. Events can be copied from one of the edit 
windows (even from another song).

This function allows you to insert MIDI events—from the Matrix Editor, for example—
directly into the Arrange window. Logic checks for a selected MIDI Region (for use as a 
destination), and adds the data to it. If no MIDI Regions are selected, Logic will create a 
new MIDI Region on the selected track.

Deleting Duplicate Events
The Erase Duplicates key command searches all selected MIDI Regions and all MIDI 
Regions in selected folders, for identical events with the same time position. Any events 
occurring twice or more at the same position are deleted (allowing one to remain).
• The search looks for notes, controllers, monophonic aftertouch and program change 

data.
• Events of the same type, but on different channels, are not viewed as being identical.
• The “same time position” includes two notes which are output simultaneously 

because of the current quantization setting.
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MIDI Region Playback Parameters
The Region Parameter box is located to the left of the track list, above the Toolbox. 

Displaying Region Parameters
When you select a Region, its parameters are automatically displayed in the Region 
Parameter box. If the Region Parameter box isn’t visible, select View > Parameters. 

None of these parameters alter the original data of the Region, they only affect 
playback.

Note:  The Region parameters also apply to folders, affecting all Regions within them. 

Opening and Closing
Clicking on the small triangle to the left of the name shows or hides the contents of the 
box, just as with folders in the Finder (if you are viewing the contents By Name). 
Closing the box provides room for the elements below.

Name
The top line in the Region Parameter box simply shows the name of the selected 
Region.

Quantize
Covered in the Quantization section (see “Quantization” on page 120).

Defaults and MIDI Thru
Default Region Parameters
If no Region is selected, the upper line of the Region Parameter box will display MIDI 
Thru. Any live MIDI input (in stop mode, as well as during recording or playback) will be 
played with the instrument and settings chosen here. When you record a new Region, 
the settings in the MIDI Thru Parameter box are carried across to the new MIDI Region’s 
Parameter box. The MIDI Thru Parameter box can be viewed as an adjustable “default” 
Parameter box. 

Realtime Processing
An important concept to understand is that incoming MIDI data is always relayed 
“through” the instrument assigned to the currently selected track. This data is also 
processed through the MIDI Thru Parameter box, described above. The MIDI Thru 
parameters are always displayed, and are adjustable when no Regions are selected. 
Click on the window background to deselect all Regions.
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Editing Several Regions Simultaneously
If several Regions are selected, the number of selected Regions is displayed, in place of 
a Region name. If you alter any Region parameter, all selected Regions will be affected. 
If a given parameter (Transpose, for example) is set differently in the individual Regions, 
a “*” appears in the Parameter field. You can alter this parameter for all selected 
Regions, and the value differential will be retained (relative alteration). If you want to 
set all selected Regions to the same value, hold down Option while changing the value 
(absolute alteration).

Loop
Value range:  On or Off. Normal value:  Off

When switched On, the Region is repeated until it encounters another Region on the 
same track. A loop will also terminate at the end marker of a folder (if the looped 
Region is inside a folder), or the song end marker. These loop repeats are displayed as 
grey beams, named after the parent Region. The length of each loop is identical to that 
of the parent Region, so if you want to create polyrhythmic structures, try 
experimenting with the length of the original Region.

One way of ending a loop early is to create an empty Region (on the same track) with 
the Pencil. Perhaps a better method is to place the looped Region in a folder. You can 
then control the total number of loops by simply altering the length of the folder.

Looped Regions can be selected by clicking on the light-gray bar at the top of the 
loop-repetitions. A short click will select the looped Region. Click-holding behaves like 
a click on the background. All Regions are deselected and rubber-band selection 
becomes active, allowing multiple Regions to be selected.

The Toggle Loop key command may be used to switch the Loop parameter on and off 
for selected Regions.

Region > Parameters > Turn Loops to Real Copies transforms the loops into real copies of 
the original Region, and simultaneously switches the Loop parameter Off for the 
resulting Region(s).

Region > Parameters > Turn Loops to Aliases changes MIDI Region loops to aliases. This 
function is also available as a key command.

Transpose
Value range:  ±96 semitones. Normal value:  0

All note events contained in the MIDI Region are transposed up or down by the 
selected amount during playback. Even complete folders can be instantly transposed in 
this way. If several individual MIDI Regions within the folder have already been 
transposed, the relative differences between them are retained.
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If you want to transpose by octaves, click on the arrows to the right of the Transpose 
parameter. This opens a pull-down menu that allows direct octave transpositions.

To guard against drum notes, and so on being transposed, the MIDI Instrument’s 
Object Parameter box contains a No Transpose checkbox. If you place a check in this 
box, the transpose parameter is ignored in all MIDI Regions played by this Instrument.

Velocity, Dynamics, and Gate Time
Velocity
Value range:  ±99. Normal value:  0

All notes in the relevant Region are offset by the selected value. Positive values add to 
the originally recorded velocity, and negative ones subtract from it, although naturally 
it is impossible to go outside the limits defined by the MIDI Standard (0–127). If you 
select a velocity offset that exceeds the maximum or minimum possible value for a 
particular note, that note will play at the extreme possible range. As an example, a 
setting of +20 will cause a note with a velocity of 120 to play at 127.

Dynamics
Value range:  in percent. Normal value:  100%

This parameter also affects the velocity values of notes, but instead of adding or 
subtracting a fixed amount, the differences between “soft” and “loud” notes (the 
dynamics) are increased or decreased. This works in a similar way to a compressor or 
expander. Values above 100% expand the dynamics, thereby increasing the difference 
between “loud” and “soft”, while values below 100% compress the dynamics, reducing 
the differences between “loud” and “soft”.

The Fix setting causes all notes to be transmitted at a velocity value of 64. When used 
in conjunction with the Velocity parameter (see above), it is possible to set any fixed 
velocity value.

Gate Time
Value range:  in percent. Normal value:  100%

The term “gate time” stems from the technology used in analog synthesizers, and refers 
to the time between pressing and releasing a key. This parameter affects the absolute 
note duration or length. This should not be confused with the musical note value, 
which normally refers to the amount of time until the next note. The practical effect is 
to make the notes in the Region more staccato or legato. The parameter range is 
related to the original note lengths. “Fix” produces extreme staccato. Values below 
100% shorten the note lengths. Values above 100% lengthen the notes. The “leg.” 
setting produces a completely legato effect for all notes, no matter what their original 
lengths, eliminating all space between notes in the affected Region. If this is used on a 
folder, all notes in all MIDI Regions in the folder will be affected.
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Delay
Value range:  −999 to 9999 ticks. Normal value:  0

This parameter alters the time position of selected Regions. Positive values correspond 
to a delay (laid-back playing style or dragging), negative values cause a pre-delay 
(driving or rushing).

The units are ticks. A tick is the smallest time resolution in a sequencer, which is 1/
3840th note in Logic. On the right side of the delay value field you can use the mouse 
as slider to input the value.

If you on the arrows to the right of the Delay value, the pop-up menu allows you to set 
the delay in note values (1/16, 1/8 and so on).

Select View > Delay in ms to switch the display to milliseconds. 

This can also be used to calculate delay times for different note values at 
various tempos:

1 Set the desired note value by clicking on the Delay value.

2 Go to the View menu and switch on Delay in ms.

3 Set the desired tempo in the Transport panel.

4 The delay parameter will now show the delay time.

The delay parameter is mainly used for musical purposes. It is also a way of fixing 
timing problems that may occur for a variety of reasons. Some examples of these are:
• The attack phase of the sound is too slow. A good musician will automatically 

compensate for this by playing the notes slightly early. With very slow sounds, you 
may need a pre-delay of over 100 ms to even them out.

• The sound generator is reacting too slowly to the incoming note-on messages. Older 
multitimbral sound generators often take tens of milliseconds before outputting a 
voice. This effect may be better compensated for with the Instrument’s Parameter 
box Delay parameter, as this will affect all Regions on all tracks that are transmitted to 
the slow-reacting device.
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• The delay in outputting the voice is not constant as it is dependent on the order of 
notes arriving serially at the sound generator. You should therefore try pre-delaying 
rhythmically important tracks by as little as one tick—it can work wonders!

Fixing/Neutralizing MIDI Region Parameters
You can normalize the MIDI Region parameter settings of all selected MIDI Regions and 
Folders with the MIDI > Region Parameters > Normalize Region Parameters command. 

This means that all settings are actually written as data, and playback parameters revert 
to normal values. The audible result remains the same. The Loop parameter is not 
affected. Use of this function is effectively like saying “make these MIDI Region/
instrument parameter values permanent”. In most circumstances, it is better not to do 
this, as leaving the original data untouched provides more flexibility. This includes 
unlimited opportunities to change your mind about MIDI Region edits.

Merge/Normalize and MIDI Channels
As per the Merge function or the Glue tool, the Normalize function is intelligent in the 
way it handles stored MIDI channel numbers. If all stored events have the same MIDI 
channel number, the channel will be changed to that of the Instrument assigned to the 
current track. If the events are on different channels, Logic will ask whether or not you 
would like to convert the event channels.

Quantization
Quantization is the rhythmic correction of notes to a specific time grid. Any 
inaccurately played notes are moved to the nearest position on this grid.

As an example, if the smallest notes in a passage are 1/16th notes, you should use 1/
16th quantization to move all recorded notes to their ideal rhythmic value. This will 
only work if no note was played more than 1/32nd from the ideal position, otherwise 
the note will be moved 1/16th later or earlier than the desired position.

How It Works
Quantization settings are made in the Region Parameter box. They are non-destructive 
playback parameters, so they can be replaced by another setting at any time. This also 
means that you can always revert to the unquantized, original recording by setting the 
Qua parameter to Off. Unlike other playback parameters, quantization affects the way 
notes are displayed in the editor windows, thus allowing you to see what effect the 
quantization parameters are having by looking at the position of the notes. Region 
quantization only affects notes, not other types of events (controllers, for example).

For every note event, two positions are stored internally:  the original recorded 
position, and the playback position (also shown in the editor windows). For 
unquantized MIDI Regions, both positions are the same. Each time you quantize, a new 
playback position is calculated in relation to the original position.
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The Apply Quantization Settings Destructively (see “Applying the Quantization Settings” 
on page 122”) command overwrites the original position with the playback position. 
The same thing happens if you manually change a note in one of the editors.

Which Events Can Be Quantized?
Region parameter quantization only works on notes, not on other types of events like 
controllers. Apart from notes, all events have just one position parameter, which can be 
left alone or permanently changed by Event Quantize, or dragging with the mouse.

Essentially, quantization works on the whole MIDI Region. To quantize individiual notes 
or other event types, use Event quantization (see “Event and Note Quantization” on 
page 35) in one of the Editor windows. You should note that this overwrites the original 
record position of the quantized note.

If you want to quantize various parts of a MIDI Region differently, you can divide the 
MIDI Region, and use different quantization settings on each part of the MIDI Region. 
You can then recombine the parts of the original MIDI Region without affecting the 
way the parts are played. 

The quantization grid always begins at the start of a MIDI Region. If the MIDI Region 
does not start at the beginning of the bar, neither does the quantization grid.

Quantization
The quantization grid is accessed from a pull-down menu beside the Quantization 
parameter in the Region Parameter box.

This function sets the quantization value for all selected MIDI Regions.

Quantization Off
The Off setting plays the notes at the finest possible timing resolution:  1/3840 note, 
which is unquantized playback, in practical terms.

Normal Quantization
The 1/1, 1/2, 1/4, 1/8, 1/16, 1/32 and 1/64 note settings quantize the MIDI Region to the 
equivalent note value.

Triplet Quantization
The 1/3, 1/6, 1/12, 1/24, 1/48 and 1/96 note settings quantize the MIDI Region to triplet 
note values. A 1/6 note is equivalent to a quarter triplet, 1/12 note to an eighth triplet, 
1/24 note to a sixteenth triplet and 1/48 note to a thirty-second triplet.

Mixed Quantization
The 8 & 12 setting corresponds to eighths and eighth triplets, 16 & 12 to sixteenths and 
eighth triplets and 16 & 24 to sixteenths and sixteenth triplets. Mixed quantization 
always applies to both note values, and requires greater playing precision when 
recording.
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Odd Quantization
The 9-Tuplet setting means novetuplets (1 bar = 9 beats), 7-Tuplet is septuplets (1 bar = 
7 beats), 5-Tuplet/4 is quarter quintuplets (1 bar = 5 beats), and 5-Tuplet/8 is eighth 
quintuplets (1 bar = 10 beats). 

Applying the Quantization Settings
In the same way that other Region parameters can be normalized, the quantization 
settings can also be applied permanently to stored data.

To do this, use the Apply Quantization Settings Destructively key command.

Of course, once this is done, it is impossible to revert to the original recording, unless 
you use Undo immediately after performing the operation.

Pre-Quantization
The Apply Quantization Settings Destructively function is especially well suited to pre-
quantization. As an example, if a recorded MIDI Region cannot be quantized to a 1/16 
swing without producing a few incorrectly timed notes, quantize it to 1/16th notes and 
then use Apply Quantization Settings Destructively. You can now apply any swing 
quantization to this cleaned-up version of the MIDI Region.

If you are recording a hi-hat pattern consisting of 1/16 notes and one single 1/32 note, 
first play the rhythm (quantized to 1/16 notes) without the 1/32 note and choose Apply 
Quantization Settings Destructively. You can now raise the quantization to 1/32 notes, 
and add the extra note without incorrectly quantizing any badly-played 1/16 notes.

Folders
Overview
A folder is a Region that can contain other Regions, much like a folder in the Finder 
that can contain other folders or files.

One way to imagine a folder is as a song within a song. A folder can have as many 
tracks, featuring Regions, as required. When opened, folders look just like the Arrange 
area and track list in a song.

Within a track of the song, a folder looks like a MIDI Region, but has a dotted surface.

This could contain tracks like trumpet, saxophone, and trombone arranged into a brass 
section, or 14 tracks of drum instruments, which you may want to treat as a single drum 
pattern Region.
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In the same way, your entire song, including all tracks and Regions, could itself be a 
folder, appearing as a grey beam in another song. In this way, you could arrange several 
songs for a concert.

This is not all that folders can do. You could use folders to represent the parts of a song 
(choruses and verses). As in the Finder, you can place as many folders as you like within 
other folders, and within yet more folders (for the instrument groups within the 
different parts of the song, as an example), with no limit to the number of levels you 
can create.

Another possible use might be to store different arrangements of a song in different 
folders, allowing you to switch between them rapidly… That’s enough for you to be 
thinking about for the moment. We’ll leave the rest up to your imagination…

The “Folder” as a Track Instrument
A folder is normally placed on a track assigned to a Folder in the Track List, rather than 
an Instrument.

All Regions in the folder are played by the instruments set in the folder’s track list. All 
instruments within the folder will play back as they normally would on the top level of 
the Arrange window.

If you place a folder on a track that is set to a normal instrument, its entire contents are 
played by this instrument. This usually only makes sense if the folder contains tracks for 
just this instrument. This could be a quick way of listening to a string arrangement, if 
some of the intended sound sources are unavailable, for example.

Working With Folders
Creating Folders
The Region > Folder > Pack Folder function places all selected Regions into a folder. The 
folder is created on an existing folder track. If no track with a folder instrument is 
available, Logic creates one.

In a similar way, if no Region is selected, Logic creates a track with a folder on it. This 
contains no Regions—just tracks assigned to all instruments from the current level.

Changing Display Levels
Entering a Folder
To change to a lower level (go into a folder) of the Arrange window, double-click the 
folder itself.

Double-clicking on a track assigned as folder in the track list, opens the Track Mixer (see 
“Track Mixer” on page 218).
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Exiting a Folder
To change to a higher display level of the Arrange window, double-click on the 
background. 

Moving Regions Into Folders
…is as easy as drag-and-drop. Drag the Region(s) from the original track onto the 
folder at the desired position and release the mouse. If the folder does not already 
contain a track with the same instrument as the original track, Logic creates one. When 
you look inside the folder, you will see the Region at the drop position.

Folder Editing: Just Like Regions
In principle, you can do anything with folders that you can do with Regions (see “MIDI 
Regions” on page 107).

Unpacking Folders
Unpacking Individual Regions
If you want to move individual Regions from a folder to a higher level, there are two 
ways of doing so:
• Go to the display level that you want to add the Region to. Now, open a second 

Arrange window by pressing Command-1 (default). Go into the folder that you want 
to remove the Region from, and drag it from one Arrange window into the other.

• Go to the display level that you want to remove the Region from. Select the Region 
and transfer it to the Clipboard by pressing Command-X. Change to the display level 
that you want to add the Region to. Select the desired track, and set the song 
position line to the desired position, then add the Region by pressing Command-V.

Unpacking Folders
Use the Region > Folder > Unpack Folder command to dismantle the selected folder. 
Logic will create new tracks on the same level that the folder was located on (below 
the former folder track). 

Aliases
An alias in Logic is the same as an alias in the Finder. It looks like a Region, but contains 
no actual data. It is just a reference to the data of the original Region—a virtual 
“reflection” of the original. You can always recognize an alias, because its name is 
written in italics.

Note:  Aliases can be created for MIDI Regions and Folders. Only cloned Audio Regions 
can be created for Audio Regions (see the “Making Multiple Copies of Regions” section 
on page 109). When the term Region is used in the following section about aliases, it 
only refers to MIDI Regions and Folders.
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If the data in the original Region is altered, this immediately affects all aliases of the 
Region.

In fact, this is the whole point of aliases. As an example, if a riff or phrase keeps 
recurring throughout a song, it makes sense to use aliases, rather than have full copies 
of the original eat up your storage space. 

Furthermore, when using aliases, if you feel something is not quite right, you only need 
to alter the original, and the correction will automatically take effect throughout the 
whole song. If you just want to alter a detail at one point in the song, you can turn that 
particular alias into an independent Region.

Creating an Alias
To create an alias, just hold down Shift when copying the Region as per usual (hold 
down Option-Shift and drag).

There is also the Alias > Make command in the MIDI menu. The alias appears on the 
selected track, beginning at the current song position.

If several Regions are selected, their relative time and track positions are retained. The 
selected track is the destination track for the first Region along the time line.

When you use the Region > Repeat Regions (see “Copying Regions” on page 109) 
function, you have the “as Alias” option.

Playback Parameters
Although an alias is a “slave” of the original, it has its own playback parameters. The 
exception is the original’s quantization parameters, which have a special status and 
always apply to aliases too.

Alias and Real Regions
Search Functions for an Original or Alias
Finding the Original of an Alias
If you have forgotten where the original is for a certain alias, select the alias, and 
choose the MIDI > Alias > Select Original function, which will find and select the original 
Region. 

Finding the Alias of an Original
Conversely, you can select the original of a particular Region, and find any aliases 
you’ve made from it. Select MIDI > Alias > Select All Aliases of Region. All existing aliases 
will then be found and selected.

“Orphan” Aliases
If you erase a Region that one or more aliases were created from, Logic will display the 
following warning message:

One or more Aliases are made from Regions to be cleared! Do you still want to clear these?
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“Don’t Clear” cancels the erase procedure, while “Clear” deletes the Region. If you do 
this, it makes no sense to keep the aliases after you’ve deleted the original. As Logic 
doesn’t do this for you, you could end up with “orphan” aliases—aliases without an 
original. Although such Regions serve no useful purpose, Logic doesn’t automatically 
delete them, as you might decide to assign them to new originals at a later stage.

Selecting All Orphan Aliases
MIDI > Alias > Select All Orphan Aliases selects all aliases that reference original Regions 
that no longer exist.

Deleting Orphan Aliases
MIDI > Alias > Delete All Orphan Aliases deletes all aliases that no longer have originals. 
You can use this function to tidy up after deleting a number of Regions, as this may 
possibly leave several unnecessary aliases in your song file.

Turning the Alias Into a Real Region
You can use MIDI > Alias > Turn to Real Copy to make a real Region from an alias; its 
contents will be identical to those of the original Region referenced by the alias.

Editing the Events in an Alias
It is not possible to edit aliases of MIDI Regions. If you double-click on an alias, Logic 
assumes that you either want to edit the original, or turn the alias into a real Region. A 
dialog box appears, asking whether you want to create and edit a real copy, or to edit 
the original instead.

Click on the desired button; Enter opens the editor window for the original MIDI 
Region.

Merging Two or More Regions
If you edit an original Region by merging it with others, any existing aliases are 
automatically updated to reflect the changes.
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Time and Key Signature Editor
The Time and Key Signature Editor window allows you to copy, move, and delete time 
signature changes, key signature changes and global score symbols (repeat signs, 
special barlines and so on).

Choose Signature/Key Change List Editor from the Options menu to open this window. 
This editor is very similar in use to the Event List editor, except that new list entries can 
only be created by copying existing ones.

The following score symbols are displayed in this window as list entries, if they are 
present in the score of the song (note:  the initial time and key signature of the song is 
always displayed here, without bar position indications at the top of the list):
• Time signature changes
• Key signatures/key changes, as displayed in the Score Edit window
• Repeat signs (repeat start, repeat end, repeat end and start, brackets for first and 

second endings)
• Special barlines:  double barlines, final double barlines (“end of score”), half/short 

barlines, hidden barlines (displayed as dotted lines on the screen) and manually 
inserted regular barlines.

Note:  None of these symbols affects Logic’s MIDI and audio playback. Time signatures 
do, however, affect both the score display and the bar position display in all windows. 
All functions reliant on the chosen time signature and bar positions (such as MIDI 
metronome click or Transform window functions) are affected, if bar positions are used 
to restrict a function to a certain part of the song.

Functions
Copying Time and Key Signatures
Time signatures, key changes, repeat signs, and special barlines can be copied in this 
window, exactly as in the Event List:
• Select all list entries that you want to copy by clicking on them (Shift-click for 

multiple selections) and use Edit > Copy (Command-C) to copy them to the 
Clipboard.

• Insert copied entries by choosing Edit > Paste (Command-V).
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• Copied list entries are inserted into the list, and an entry box for the bar position of 
the first inserted list event will open. Type in the desired bar position and close the 
box by pressing Return. Subsequent list entries are inserted at bar positions that 
correspond to their original distance from the first copied list entry.

Moving and Deleting List Entries
All list entries in this window (except the initial time signature and key indication at the 
top of the list) can be moved or deleted. Again, this works like the Event Edit window:
• To delete a list entry, select it and press Backspace.
• To move an entry, you can either; click on its bar position with the mouse, keep the 

mouse button pressed and move the mouse up or down, or double-click on the bar 
position of the list entry, and type the desired bar position into the box that appears.

Changing Time and Key Signatures in the List Editor
Existing time signatures and key changes can be altered directly in this list:
• Their position can be changed as described in the previous section.
• Time signatures can be changed by click-holding on the nominator or denominator 

in the list, and dragging the mouse up or down to increase or decrease the value.
• To alter a key signature, either; click on the word major or minor to switch between 

parallel major and minor keys, or click and hold on the root of the key:  This opens a 
pop-up menu of root notes for all available keys. Select the desired key by 
highlighting the corresponding note in the pop-up menu.

Altering the Display
For information on basic window functions, please refer to the section on Window 
Functions (see “Window Functions” on page 21).

If you want to maximize the room available for the Arrange area, please refer to the 
section on Relationships between Windows (see “Relationships Between Windows” on 
page 28).

Display Options for the Track List 
You can use the View menu to show or hide various parts of the track list:  

Track Numbers/Level Meters
Allows you to show or hide the track numbers and level meters.

Mute Button
Every track has its own Mute button. If the Mute buttons are hidden, you can still mute 
any track by clicking to the left of the track number. 

Track Solo Button
Every track has its own Solo button. 
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Record Enable Button
Allows you to show/hide the Record Enable buttons.

Track Protect Button
Shows/hides the Track Protect Buttons.

Track Freeze Button
Shows/hides the Track Freeze Buttons.

Track Instrument Channel
When on, this option displays an abbreviated Track Instrument label.

Instrument Icon
Selecting Instrument Icon shows/hides the track instrument icons.

Instrument Icon (Large)
Selecting Instrument Icon (Large) allows the display of large track instrument icons.

Track Instrument Color
Selecting this option uses the track instrument color for all newly-created Regions.

Instrument Name
Shows/hides the Instrument Name (see “Instrument Name and Track Name” on 
page 129).

Track Name
Shows/hides the Track Name (see “Instrument Name and Track Name” on page 129).

Instrument Name and Track Name
Hiding one of the names makes more horizontal space available. To distinguish 
between them, the instrument name is always shown in bold type. 

Horizontal Layout
If both the instrument and track names are shown, the names are divided by a line. You 
can move this dividing line by dragging the mark at the top of the track list with the 
mouse.
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Instrument and Track Name Stacked on Each Other
If you zoom in far enough vertically, you will be shown both names, one above the 
other:  the instrument name (in bold) on top, and the track name below. This even 
occurs if one of the names is hidden. 

Sorting the Tracks
You can sort tracks by grabbing the desired track number and moving it vertically. You 
can use the right edge of the track list for sorting as well. 

Here are the rest of the track list functions involving names:

Selecting a Track Instrument
You can assign an instrument to a track by click-holding the left half of the name or the 
icon.

Opening the Environment Window for an Instrument
You can open an Environment window (with the relevant instrument highlighted), by 
double-clicking the instrument name.

Editing Instrument Names
You can edit the Instrument/Audio Object name by Option–double-clicking directly in 
the track list. You can also use the Instrument Parameter box.

Editing Track Names
You can edit track names by Command–double-clicking directly into the track list—
even if it’s only the instrument name that is shown.
Chapter 3    Arrange Window



 

Region Display
Contents Visible in MIDI Regions
If you vertically zoom the display, you will be able to see the actual events contained 
within MIDI Regions.

MIDI Regions show notes or controller events, folders show the Regions they contain, 
and aliases show the name and position of the original.

The View > Region Content option allows you to see a display of contents, at large 
enough zoom settings. If you uncheck this option, the contents will not be displayed, 
no matter what the zoom setting.

Region Colors
Newly recorded Regions initially adopt the color of the track instrument. You can 
change the color of a Region via the local View > Colors menu, which opens a color 
palette. A double-click on a color field opens the system color palette, allowing you to 
create custom colors. Color edits are stored in the Preferences file and are available for 
all songs.

After copying Regions between tracks, you could find the Arrange area will start to 
resemble a patchwork quilt. In this situation, the Region > Instrument Colors To 
Regionsfunction replaces the colors of all selected Regions with the colors of the 
Instruments playing these Regions. Instrument colors can be set in the Environment.

Altering the Background of the Arrange
Use the View > Grid function to switch on/off a track/bar number grid in the arrange 
area’s background. 

Plain Background toggles the background between a plain background and a high 
resolution pattern. You can choose both a background color for the plain background 
and a high resolution pattern via Preferences > Display > Arrange.

Show/Hide Channel Strip Only
A View menu option (and key command) allows you to hide all elements of the 
Parameters area — except the Arrange channel strip. 

This is extremely handy in cases where a high number of active Inserts and Sends are 
used, and displayed, on small screens (such as that of a 12" PowerBook).

The same command can be reused to toggle back to the full view of the Parameters 
area.
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Reset Functions
To switch off stuck notes, click on the MIDI monitor in the Transport window, or hit 
Stop twice in rapid succession. In both cases, reset messages are sent, as defined in 
Preferences > MIDI > Reset Messages  (see “Interface Language” on page 484).

For Hanging Notes—Panic Function
If the notes continue to sound, then your sound sources may not be able to respond to 
“All Notes Off” messages. If this happens, try the following:

Double-click on the MIDI Monitor in the Transport window (or use the Send discrete 
Note Offs key command). Separate Note Off messages will then be sent for every note, 
on all channels of every MIDI port. 

This should do the trick!

Unwanted Modulation—Controller Reset
Options > Send to MIDI > Reset Controllers transmits a control change message #121, 
with a value of 0 (reset all controllers), on all MIDI channels and outputs used by 
defined instruments. This neutralizes all MIDI controllers, such as modulation or pitch 
bends.

If Some Sounds Are Suddenly Too Quiet—Volume Reset
The Options > Send to MIDI > Maximum Volume function transmits a control change 
message #7 (main volume), with a value of 127, on all MIDI channels and outputs used 
by defined instruments. This sets all channels to their maximum volume, providing the 
optimum signal/noise ratio for your sound sources.

If You Suddenly Hear the Wrong Sounds—Send Instrument Settings
The Options > Send to MIDI > Used Instrument MIDI Settings function sends all Prg, Vol, 
and Pan settings from all Instrument’s Object Parameter boxes used in the current 
song. This could help to reset your sound sources for the current song, if your synths 
suddenly change patches mid-performance.

You can set this function to operate automatically after loading any song by activating 
the After loading Song, send:  Used Instrument MIDI Setting option, in the Song Settings > 
MIDI page.
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4 Audio in the Arrange Window
This chapter discusses the importing, creation, editing, 
and handling of Audio Regions in the Arrange window.

You will also learn a number of automated recording techniques, discover crossfading, 
looping, and tempo matching. Further to this, you’ll find out about the Freeze facility, 
which allows you to create projects that are beyond the real time capabilities of your 
computer.

Regions
Creating Regions
MIDI Regions are containers for MIDI events in the Arrange window. Containers for 
audio data are referred to as Audio Regions, or simply Regions. 

Audio Regions can be compared to MIDI Regions in the ways that they are used and 
edited. When you record audio in real time, Logic not only creates an audio file on the 
hard disk, but also automatically creates a Region, which represents the recorded audio 
file. Regions can be seen in both the Arrange window (on tracks), and in the Audio 
window (see “Audio Window—Introduction” on page 249), which lists all audio files and 
Regions used in the song.

Drag and Drop Into the Arrange Window
You can import existing audio files into a song by dragging and dropping them directly 
into the Arrange window from either; the Audio window, or directly from any folder on 
your hard disks. A Region, encompassing the entire audio file, will automatically be 
created at the “drop” point.

Note:  You can only drag Regions onto Audio tracks.
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Multiple File Dragging
You can drag multiple audio files from the Audio window or a Finder window into the 
Arrange window. To do so, simply rubber band contiguous files, or command-click non-
contiguous audio files in the Finder or Audio window, and drag them to the desired 
Arrange window position. The following dialog will be launched:

• Create new tracks—creates new tracks for each dragged file, using the next available 
Audio Object. As an example, if three audio files are dragged into the Arrange 
window onto Track/Audio Object 4, three new audio tracks (Track/Objects 5, 6, and 7) 
will be created, and the audio files will be placed onto these tracks (as Regions) at 
the selected song position.

• Use existing tracks—will sequentially place the dragged files (as Regions) onto 
existing tracks, starting with the currently selected track. As an example, if three 
audio files are dragged into the Arrange window (where track 4 is selected), the first 
file will be placed on track 4 and the following two files will be placed on tracks 5 
and 6.

• Place all files on selected track—does just this, with all files being placed sequentially 
on the desired track.

• Copy audio file names to track names—uses the file names to rename tracks, and is 
only available for use with the Create new tracks and Use existing tracks functions.

• Create new audio regions—will add the desired files to the Arrange window, and will 
create a new audio Region for each. A numeric value will be appended to each audio 
Region in the Arrange window, and a new Region will be created for each file in the 
Audio window. As an example, a Region called “folk-04” will become a new Region 
called “folk-04.1”. The original Region will be retained in the Audio window (and 
Arrange, if used).

Inserting Audio Files Using the Pencil Tool
Audio files can be inserted on Audio tracks by Shift-clicking at the desired Arrange 
window position with the Pencil tool. A file selector appears, allowing you to select the 
file that you wish to insert. The length of new Regions inserted in this way defaults to 
the complete file length, which can be freely edited later.

Inserting Apple Loops
Apple Loops are special types of audio files. The insertion method for Apple Loops is 
different to that of other audio file types. Further information can be found in the 
Apple Loops section (see “Apple Loops” on page 62).
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Editing Regions
Dividing Regions
When you divide a Region using the Scissors tool, you create two new Regions. The 
newly created segments of the Region are named after the original, with a sequential 
number appended to the end of the name.

Region Display
The Arrange window displays the actual waveform of an audio file, all the way down to 
single sample resolution (at higher zoom levels). The Waveform vertical zoom key 
commands make this feature even more useful; for precise Arrange edit operations, 
and for operations on audio Regions with low signal levels.

Resolution
When selecting a cut point with the Scissors tool, you can move backwards and 
forwards in steps of one division. If you need a finer resolution, press Control after you 
have selected the Region with the Scissors. To obtain the maximum resolution (ticks) 
press Shift, as well.

On Zero Crossings
If Edit > Search Zero Crossings is switched on in the Audio window, the division-point is 
moved to the nearest position that the waveform crosses the zero amplitude axis. 
When enabled, this also applies to all other methods of altering the start or endpoint of 
a Region in the Arrange window.

Note:  This can cause the precise startpoint and length of a Region to differ slightly 
from the selected value. In most cases, this will be inaudible.

Erasing Regions
Regions can be erased by either; selecting them and pressing Backspace, or by clicking 
on them with the Eraser tool.

Erasing Recordings
When you erase a Region that you have just recorded (since opening the song), Logic 
will ask if you also want to erase the corresponding audio file. This is a good way to 
avoid wasting hard drive space unnecessarily by retaining bad takes and unwanted 
recordings.

If the recording was made before the song was loaded for the current session, this 
dialog box will not appear. This prevents you from accidentally deleting valuable 
recordings. Pressing Backspace will only remove the Region from the Arrange area. If 
you want to delete the corresponding audio file from the hard disk, you can do so by 
selecting Audio File > Delete File(s) in the Audio window.
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Copying Regions
Creating New Regions
Copies of Audio Regions are made in exactly the same way as MIDI Regions—by 
dragging them while holding down Option. This automatically creates a new Region in 
the Audio window. The new Region will retain the name of the original, with a 
sequential number added.

This allows you to alter the start and endpoints of the copied Region independently of 
the original. It is comparable to a genuine copy of a MIDI Region, which is created in 
the same way.

Using an Existing Region More Than Once
You can also create another version of the same Region in the Arrange window—a 
cloned Region, if you will. To do this, hold down the Option and Shift keys as you are 
copying. This is comparable to an alias of a MIDI Region, which is created in the same 
way.

Whenever you adjust the start or endpoints of any of these Regions, all other cloned 
Regions will also be adjusted. 

Making Cloned Regions Independent
To make several cloned Regions independent of each other, select Audio > Convert 
Regions to New Regionsin the Arrange window. This converts all selected clones into 
individual Regions.

Making Multiple Copies of Regions
You can make multiple copies  (see “Copying Regions” on page 109) of both Audio and 
MIDI Regions with Region > Repeat Regions. This function creates clones of the Region 
(the Regions are not independent).

Another way to make Regions repeat is through use of the Loop parameter in the 
Region Parameter box  (see “Loop” on page 117).

The MIDI > Region Parameters > Turn Loops to Real Copies command will change loops of 
selected Regions into “real” copies. The Regions that are created, however, represent 
the same Region. As such, any alterations to the length of the Region or audio material 
affects all “real looped” Regions (as with cloned Regions).
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Moving Audio Regions
You can grab Audio Regions in the Arrange window with the mouse, and move them 
around, just like MIDI Regions. 

If you hold down Control while moving Regions, you can move them in steps of one 
division (in sixteenths, for example).

If you hold down Control and Shift while moving Regions, you can move them by 
single ticks (maximum resolution).

You can also use the Delay parameter in the Region Parameter box to shift the 
playback position of Regions.

In practice, a resolution of one tick will usually be fine enough.

To move a Region by a finer resolution than ticks (such as a resolution of one sample 
word), please use the Anchor point in the Audio window or Sample Editor.

Note:  All cloned Regions in the Arrange window are affected as well.

You can also move Regions by adjusting their positions in the Event List:
1 Select the Region that you wish to edit.

2 Choose Windows > Event List. 

3 Click on the button (featuring the square graphic) in the Event List’s top left corner to 
move up one level in the hierarchy. 

4 Move Regions as desired, by changing the value in the Position column.

Moving Regions Back to Record Position
You can move any selected Region in the Arrange window back to it’s original recorded 
position by selecting Audio > Move Region to Original Record Position.

This function only works if the corresponding audio file was recorded in the current 
song. Audio files imported via Add Audio File have no original record position.

This command is also available as a key command:  Set Region(s) to original Recording 
Position.

Changing Start and End Points
You can shorten or lengthen any Region by grabbing it’s lower right hand corner with 
the mouse and dragging it—if track based automation is displayed, grab the corners 
above the automation layer. You cannot make a Region longer than its original audio 
file. This means that all other Regions derived from this Region will be lengthened by 
the same amount (cloned regions—see the “Copying Regions” section on page 136).

Of course, the same goes for any changes you make to the startpoint of a Region. Such 
changes can be made by grabbing, and dragging, the lower left edge of the Region.
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You can edit a Region’s start and endpoints far more accurately with the Sample Editor, 
which can be opened by double-clicking on the Region. Simply slide the “S” and “E” 
markers to change the Start and End points of the region. While moving the Start 
point, use the Option-key, to ensure that the Anchor (and therefore the timing of the 
audio, relative to the rest of the arrangement), remains unchanged. The Anchor must 
be positioned inside the Region. 

If you wish to move the start point to the right, first move it to the approximate target 
position while in the Arrange window. Then open the Sample Editor, and use the 
Option-key to precisely move the start point to the desired location.

Adjusting the Grid to Zero Crossings
If Edit > Search Zero Crossings is switched on in the Audio window, the adjustment will 
snap to the nearest zero crossing point of the waveform every time you alter the start 
or endpoint of a Region in the Arrange window. The Anchor is not affected.

The disadvantage of this option is that altered start or endpoints never land exactly on 
the selected musical grid, and will always be a few ticks out. Normally, this won’t 
matter, because the Anchor reference point is unaffected. Should this ever cause a 
problem, you can simply switch off the Search Zero Crossings option. The primary 
reason for activation of the zero crossings option, is that it prevents clicks and pops at 
region start and endpoints.

Region Parameter Box
Name
As with MIDI Regions, the top line of the Region Parameter box displays, and allows 
you to edit, the name of the Audio Region. You can name several selected Audio 
Regions simultaneously; the Regions are assigned the same name, with sequential 
numbers added to the end of the name. Logic inserts these numbers automatically, 
unless you deliberately leave a space at the end of the name.

When you change the name of a Region in the Arrange, the corresponding Region is 
also renamed in the Audio window.

Loop
As with MIDI Regions, you can use the Loop parameter to make a Region repeat 
automatically. The loop repeats until it reaches the next Region on the track, the end of 
the song, or the end of the folder that contains the Region.

Don’t forget that these loops are based on the Region’s sample grid. This means that 
even if the Region is precisely matched to the song tempo, loop repeats may start to 
go out of sync after a while. You can avoid this problem by setting the endpoint of the 
Region to an exact measure boundary. In these cases, it may be better to use the 
Region > Repeat Regions function (see “Copying Regions” on page 109).
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Delay
Just as with MIDI Regions, you can advance or delay the playback of Audio Regions, the 
smallest available units being ticks.

The Region Anchor
The Anchor is an Audio Region’s temporal reference point. When you move an Audio 
Region, it’s not the start point that is displayed in the help tag (as with MIDI Regions)—
it’s the Anchor point.

As an example, to guarantee perfect synchronization between a one-bar drum loop 
and your MIDI Regions, the Anchor must be assigned to a well-defined musical point. If 
the loop begins with a significant level peak (say a kick drum beat), set the Anchor to 
the point where the volume of that beat is at its precise peak.

Any changes made to the position of the Anchor in the Audio window will directly 
affect the corresponding Region in the Arrange window. The position of the audio will 
shift in relation to Logic’s time axis, while the Anchor remains tied to the same bar 
value, and is marked by a dotted line.
Chapter 4    Audio in the Arrange Window 139



140

 

MIDI and Audio Regions Compared
The following overview sums up the main differences between Audio and MIDI 
Regions. There are some notes at the bottom of the table to clarify the most important 
points.

Naturally, some of the parameters that can be applied to MIDI events have no effect on 
audio signals. Equivalent operations for most of these are available as destructive edit 
operations in the Sample Edit window.

Feature
MIDI 
Regions Audio Regions

Composed of discrete data Yes No, because Regions are just references to 
parts of audio files

Can be given names Yes Yes

Loop Region parameter available Yes Yes

Quantize Region parameter available Yes No, but but the position of Regions themselves 
can be quantized, using the Event List display 
on the Arrange level. 

Transpose Region parameter available Yes No, but you can use the Time Machine and 
Pitch Shifting functions. Apple Loops can be 
transposed.

Velocity Region parameter available Yes No

Dynamics Region parameter available Yes No

Gate Time Region parameter available Yes No

Delay Region parameter available Yes Yes

Can be freely positioned Yes Yes

Left or right corner edit Yes Yes, and this affects the Audio Region, but not 
the position of the audio waveforms relative to 
the time axis of the sequencer

Can be cut with the Scissors tool Yes Yes, creates a new Audio Region.

Can have aliases made of them Yes Yes

Left corner may be dragged to 
conceal data at beginning

No Yes

Have a variable musical reference 
point

No Yes, a variable Anchor. This affects all Regions 
derived from a given Region, and can change 
the position of the audio, relative to the time 
axis of the sequencer

Can be turned off with the Mute 
function

Yes Yes

Can be grouped into folders Yes Yes

Can be soloed Yes Yes
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Only Audio Regions have the flexible reference point provided by the Anchor.

The fundamental functions (such as a freely determinable position and length, the 
ability to create complex arrangements with the aid of folders, and the ability to name, 
mute, and solo) are generally available to all types of Regions (MIDI Regions, Audio 
Regions, Folders, and Aliases).

Audio Recording
For details on preparations for audio recording, please refer to the relevant sections in 
the Audio Driver section (see “Audio Drivers” on page 271).

Creating Audio Tracks
To create an audio track, you must first assign an Audio Object as a track instrument. 
Click on a track name in the Arrange window, while holding down the mouse button. 
This opens the hierarchical Instrument list pull-down menu, where you may select an 
Audio Object via Audio > Audio Track > Audio X. To help things along, Audio Objects 
“Audio 1” to “Audio X” are preset for your hardware by the Logic Setup Assistant.

If you want to make adjustments to Audio Objects, you can do it directly from the 
Arrange window. The Object Parameter box is located below the Toolbox.

Arming Tracks
First Method:
• Click the button marked with an R, on the desired track in the track list. To show/hide 

these switches, select View > Track Record Button.

If you have checked View > Track Record Button but the switch is still not visible, you 
should switch on the driver for the relevant audio hardware in the Audio > Audio 
Hardware & Drivers window.

Second Method:
• Open the Environment Layer containing your Audio Objects (by selecting Audio > 

Audio Mixer).

• Click on the REC button of all Audio Objects that you wish to record to. Click the 
Audio Object REC button a second time to disarm the track. You can also arm the 
current track by clicking the Record Enable button on the Arrange channel strip.

You can only make audio recordings on armed tracks, no matter what track is 
highlighted in the Arrange window.
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• If you select a MIDI track, you’ll record MIDI events.
• If you select an Audio Instrument track, you’ll also record MIDI events.
• If you select an Audio track, you’ll record on all tracks that have been armed (record 

enabled).
• Space is reserved on the hard disk for armed tracks, and will no longer be available 

for Undo files. For this reason, Logic will automatically disarm audio tracks when 
editing in the Sample Editor, or if the hard disk is nearly full.

• You can record simultaneously on one MIDI trackand several audio tracks, by clicking 
the Record Enable button on the MIDI track and the audio tracks you want to record 
to. 

Note:  Shift-clicking arms additional audio tracks, following the selection of a MIDI track 
for recording.

If several Arrange window tracks are assigned to the same Audio Object (“Audio 1”, for 
example), the new audio file (Region) will be recorded to the selected track.

“Disarming” All Tracks
If several tracks are record-enabled, you can instantly disable them all by Option-
clicking on any of the flashing REC buttons.

Standard Recording With Count-in
You can start recording at any point in a song by setting the Song Position Line to the 
desired location. If the target audio recording tracks are correctly set, and the necessary 
inputs (and audio signals) are connected and properly adjusted, just hit the Record 
switch on the Transport, or press “∗”.

A “count-in” is heard. Signals will be recorded during this time. Depending on the 
number of tracks required, Logic will pause for a short interval between the time you 
press the Record button, and the start of recording.

During recording, the Recording float window opens. This displays the remaining 
recording time.

Logic will automatically create a Region in the Arrange window after recording (press 
Stop on the Transport to end recording), and will create an overview of the audio file. 
This is a graphic file that is used to display the waveform in the Arrange window. You 
can listen to the new recording in the Arrange window while the overview is created.

Record and Pause Mode
If Logic is in pause mode, you can start audio recording by clicking “Record Toggle”, 
“Pause” or “Play”. Recording begins at the current song position.
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Punch-In Recording
You can actually engage recording while in playback mode—“on the fly”. To do this, 
start playback and press Shift-asterisk (the key command for Record Toggle) at the point 
where you want to start recording. Audio recording will start immediately. Recording 
can be stopped at any time, by pressing Stop in the usual way, or by pressing Shift-
asterisk again. If you use this second option, recording ceases, but the sequencer will 
continue to play.

Pre-Programmed Drop-Record
Logic’s autodrop function can be used on audio tracks, just as it can with MIDI Regions. 
Autodrop is enabled by clicking on the autodrop switch on the Transport window. Here 
is a step by step breakdown of the procedure:

• The Autodrop button must be turned on.

• You can set the autodrop locators numerically in the Transport window.
• The autodrop recording zone is indicated by a thick bar in the middle third of the Bar 

Ruler.
• Recording only takes place within the autodrop zone, with the exception of a short 

“lead-in” just before recording is due to start.
• The autodrop zone start and end points can be set from either; the Bar Ruler, or by 

using the locators in the Transport bar. Please note that if the Cycle function is 
switched on, you can set the Autodrop Locators in the window to the right of the 
Cycle Locators (under tempo in the Transport bar).

• Start recording. Logic will begin recording about one bar before the drop-in locator. 
Press Stop to end recording, and a Region that corresponds exactly to the length of 
the autodrop zone will be created. This method allows the startpoint of the Region to 
be adjusted later, allowing the lead-in to become audible. This way, the beginning 
can be easily recovered if the performer anticipates the autodrop zone slightly. 
Adjustments to the lead-in portion of the Region does not change the position of 
the recording, relative to the time axis.

Tip:  You can even define a small autodrop zone within a larger Cycle Zone (see below), 
if desired. This can be handy if a player needs to re-record a difficult passage in the 
middle of a song, and requires several attempts to get it right.
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Audio Cycle Recording
You can make audio recordings even when “Cycle” is switched on. A new track is 
created for every cycle repeat. All newly-created tracks are played by the same Audio 
Object. This prevents the different “takes” from being played simultaneously.

If you stop recording just after a full cycle has ended, no new Region is created for the 
cycle that has just begun. The audio material is not lost, but is recorded after the last 
Region in the audio file.

The whole recording (all cycle repeats) is stored as a single audio file. This audio file is 
split into Regions, each as long as the Cycle length. The Region of the preceding cycle 
is automatically muted when playback of the ensuing cycle/Region begins.

Audio cycle recording also works when you’re simultaneously recording two channels.

After Recording, Please Note…
After you’ve made your first audio recording in a song, you should not make any 
further adjustments to the tempo of the song. Decide on a tempo, and any changes in 
tempo, well before the first audio recording, and stick to it. Audio recordings have a 
fixed playback rate, and can only be matched to new tempos if you’re prepared to go 
through a great deal of hassle. 

The time compression/expansion algorithms available in Logic only permit you to 
match audio to new tempos when the tempo differences involved are relatively small; 
if you try and use them to significantly change the tempo of your recordings, audio 
quality may be significantly compromised.

Note:  You can, of course, change your audio recordings into Apple Loop format files. 
This file type makes transpositions and time stretching tasks much easier (see “Apple 
Loops” on page 62).

If you’ve made your audio recordings in real time, playing them over the top of an 
existing MIDI arrangement, it is not particularly recommended that you move the 
Anchor of any of your Regions. You can make slight adjustments to the timing of your 
Regions using the Delay parameter.
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Stereo Recordings
For information on creating stereo recordings, please read the appropriate Mixers, 
Effects, and Audio Objects sections; Stereo Objects (see “Stereo Objects” on page 203) 
and Channel Strips (see “Logic’s Mixing Facilities” on page 191) and the section on 
Faders and Level Adjustment (see “Level” on page 200).

Stereo recordings will normally be saved as Interleaved Stereo files. A stereo symbol, 
consisting of two overlapping circles (see left image below), is shown beside the names 
of Interleaved Stereo files (that appear as Regions) in the Arrange window.

Split Stereo Regions are indicated by a stereo symbol consisting of two adjoining 
circles (see right image above).

You can freely mix both formats, even on the same track. We recommend that you use 
the Interleaved Stereo format if your audio hardware supports it.

Split Stereo files require around twice the hard disk I/O performance of mono files. 
Interleaved Stereo files, by comparison, only require about one and a half times the 
throughput of Mono files.

Functions
Automatic Tempo Matching
Logic offers an automatic function that matches the length of a free-form musical 
passage with the length of an audio Region. The length of the Region remains 
constant, but the sequencer tempo is varied automatically, with the Region and 
musical passage ending up exactly the same length.

To illustrate the use of this function, we’ll use a one-bar drum loop as an example:

Imagine you’ve recorded a drum loop live, or imported it from a sampling CD. You’ve 
used the Audio window and Sample Editor to adjust the start and endpoints of the 
audio Region, ensuring that the loop cycles perfectly, without any glitches.

Now, drag the drum loop into the Arrange window, where it appears as a Region. Make 
sure that you place the front (left) edge of the Region at the start of a bar.
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Construct a Cycle in the Arrange window Bar Ruler. Set the length to match the 
intended musical length of the Region. The drum loop is one bar long, so you should 
set a Cycle length of one bar, to match.

Once the Cycle is set to the desired musical length in the Bar Ruler, you’ll note that the 
current length of the Region will be different to that of the Cycle. 

Select Options > Tempo > Adjust Tempo using Region Length and Locators. The default 
key command is “T”.

The tempo is recalculated, making the Region exactly one bar long, and fitting the 
length of the Cycle perfectly. This does not change the playback tempo of the audio, 
but rather, makes the song tempo conform to the audio.

Digital Mixdown
Logic allows you to digitally mix down audio data from within the Arrange window. 
This is done with the Glue tool. This function is non-destructive, as Logic always creates 
a new file for the mixed-down material. This new audio file is stored on your hard drive.

To carry out a mixdown, select the Glue tool from the Toolbox, and use it to select the 
required Regions for mixdown (if necessary, using Shift as well).

The mixdown process can be aborted by pressing Command-period. All audio files will 
remain unchanged.

No Mixdown Situation
• If there are several Regions (mono or stereo) in a row on the same track, which have 

been cut out of one Region using the scissors tool, no mixdown is carried out. In this 
situation, a single Region is simply created over the entire area. This delivers the 
desired result, without using any additional disk space.

• Logic can recognize associated Regions, even if there are gaps between them. The 
determining factor is that the relative position of the Regions in the Arrange window 
corresponds to the relative position of the Regions in the underlying audio file.

• No mixdown occurs when you try to mix two Regions on tracks that are panned to 
opposite sides.
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• The two resulting mixdown files would be identical to the original audio files (in the 
areas used for the Regions). If you don’t need the unused areas of the audio files, 
select “Optimize Files”.

“Mixdown” of Regions in a Track
If several Regions that overlap each other are selected on a single track, no mixdown 
occurs. You are asked to create a new audio file, which is named after the first Region 
on the track. The selected Regions are then mixed together, with no changes to 
volume, and without clip scanning.

If there are empty sections between two Regions, these are added into the new audio 
fileas silent passages.

Genuine Mixdown With Clipscan
If you combine audio data from two or more tracks, the current pan and volume values 
for the individual tracks will define the pan and volume settings in the new audio file. If 
you want to combine both sides of a stereo audio file (a mono channel on each of two 
tracks), first set the pan controls of the component mono sides to hard left and hard 
right, respectively.

You can perform a mixdown while the sequencer is playing.

Following the digital clipping scan (Clipscan) and completion of the mixdown, Logic 
replaces the previously selected Regions with one Region that contains the new, 
mixed-down audio file in it’s entirety. You can use the undo function to restore the 
original audio Regions, if desired. If you do so, you’ll be asked if you’d like to keep, or 
delete, the newly created mixed audio file. If you decide to keep it, it will remain in the 
Audio window, and can be further processed.

During a mixdown, the 32-Bit resolution Clipscan function ensures that the highest 
possible level is maintained, without clipping.

Audio Crossfades in Digital Mixdown
The Digital Mixdown function (Glue tool, menu, or key command) in the Arrange 
window supports audio crossfades of selected Regions.

The parameters are defined in the General Audio preferences pane, which can be 
opened either via the Audio Crossfade options for Merge key command or by 
selecting:  Preferences > Audio > General.
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There are two parameters:

Crossfade Time [ms]:  This is the length of the entire crossfade. To switch off the 
crossfade, set this value to zero.

Crossfade Curve:  To obtain a linear crossfade, set this value to zero. Other values 
(positive or negative), produce various exponential fades. The fade-outs and fade-ins 
are always symmetrical, to avoid deviations in level. The preset values are:  Time = 
20 ms, Curve = 0 (linear).

The graph shows the actual shape of the crossfade; the original algorithms are also 
used to calculate the curve display. Values over about 250 ms are scaled in the graph, 
to ensure that the entire crossfade is visible.

Freeze
The Freeze function saves almost 100% of the CPU power used for software 
instruments and effect plug-ins. You can apply it, individually, to audio or Audio 
Instrument tracks. 

Concept
Internally, Freeze performs individual offline bounce processes for each “frozen” track. 
All plug-ins of a track (including software instrument plug-ins, if applicable, along with 
all related automation data) are rendered into a “Freeze file”.

As long as a track is frozen—following the freeze process—the freeze file will play back 
in place of the original track (and its CPU-hungry plug-ins). The original track and plug-
ins are temporarily deactivated, and use no CPU resources.

Due to technical reasons, the Freeze function is not available for the tracks of DSP-
based audio hardware systems (such as ProTools), tracks that use plug-ins calculated on 
DSP cards (Powercore, UAD-1, Pulsar, and so on) or tracks that use external signal 
processing devices via the I/O plug-in. You can, however, freeze tracks that use Sends to 
Busses—with DSP-based or I/O plug-ins used on the busses.

The Freeze function always bounces the complete channel signal. If you are using more 
than one track for the same audio or instrument channel in the Arrange, then all 
(sub)tracks of this channel will be frozen, and cannot be edited independently.

When to Freeze a Track
In real-life situations, Freeze allows you to:
• use additional plug-ins or software instruments in further audio or instrument tracks, 

which would normally not be possible as it would exceed the CPU processing limits 
of your computer.

• Play back songs created on computers with greater CPU power.
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Freeze was made for very CPU-intensive processes, which are generally (from higher to 
lower demand) outlined as follows:
• Software synthesizers with a complex voice architecture
• Plug-ins with a complex structure (reverbs, filter banks or FFT-based effects)
• Software synthesizers with a simple voice architecture
• Software sampler with active filter
• Software sampler with deactivated filter
• Plug-ins with a simple structure

As long as your computer is able to calculate all active processes in real time, it’s 
unnecessary to freeze tracks.

Freeze is recommended whenever your system’s power runs short and one, or multiple, 
existing tracks with CPU-intensive instrument and/or effect plug-ins are in a finalized 
state, or at least seem to require no further changes for the meantime—in other words, 
a “close to final” mix.

As long as a track is frozen, its CPU usage is reduced to that of a high resolution audio 
track, without any effect plug-ins inserted—regardless of the number, or processing 
demands, of the plug-ins that were used originally.

How to Freeze a Track
It’s extremely easy to freeze a track:  simply activate the Freeze button—the button 
that features a small ice crystal icon (light gray when active). If the Freeze buttons are 
not visible, activate the View > Track Freeze Buttons menu option in the Arrange 
window.

If you hold Command while clicking on a Freeze button in the Track List, all tracks that 
contain data in the currently-selected display level (or folder) will be frozen. If the 
Freeze buttons were already enabled, they will be disabled.

You can also use track button slide activation to enable Freeze on multiple tracks.

Logic will create freeze files after receiving the next “Play” command. This allows you to 
activate the Freeze buttons of multiple tracks, and render their freeze files in one go.

During the Freeze process, the SPL will follow the currently rendered position. A 
floating progress bar window is also displayed.
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Freeze files are always rendered between the song start and end marks—it is 
recommended that you check the song end mark in the Bar Ruler before starting a 
Freeze process. Please note that the end mark should be adjusted to include feedback-
dependent delay repetitions or reverb tails. Empty areas (digital zero) at the end of 
freeze files will automatically be removed after the Freeze process.

You can abort freeze processes by pressing Command-Period—in this scenario, the 
portion of the frozen tracks that has already been rendered will remain in the freeze 
files, and will be used for playback. Frozen tracks will remain silent beyond this point.

The freeze process uses 100% of available CPU power. If, for example, a track uses 40% 
of the CPU for real time plug-in calculations, its freeze file will be created in two and a 
half times (faster than) the realtime speed. If the original track uses 100% of the CPU 
power, the freeze process will happen in (approximately) realtime—even if offline 
bouncing is used.

Working With Frozen Tracks
Once a track is frozen, you cannot edit any instrument or plug-in parameters (or related 
automation data). You can, however, still edit the:
• effect send levels and destinations,
• panorama parameters,
• volume, mute, and solo

of frozen tracks—including their automation data.

Whenever you try to edit “forbidden” parameters of frozen tracks, (such as plug-in 
parameters that were rendered into the freeze file), Logic will display an error 
message:  

“Current track is frozen. Do you want to unfreeze it?”

In this situation:
• Unfreeze will deactivate the Freeze button of the track.
• The freeze file will be deleted.

Please note that the track will now use the amount of CPU processing power that it 
originally required, if you enter “Play” mode.

Now,
• perform your edits,
• activate the Freeze button again, if required.

It is not possible to cut and re-arrange the freeze files in any way, nor is it possible to 
mix the freeze files with their originals on a single track—you can use one or the other, 
not both!
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It is also not possible to record audio on frozen tracks. In fact, the Record button will be 
hidden when a track is frozen.

Freeze Files
The temporary freeze files are saved in a folder named “Freeze Files” which is created in 
the root directory of your project folder. Usually, you won’t need to access these freeze 
files directly.

Logic manages these freeze files automatically in the background:  They are created 
during the Freeze process, will play back in place of the original tracks (as long as these 
tracks are frozen), and will be deleted as soon as the Freeze button of the 
corresponding track is deactivated.

In some cases, however, it might be handy to use freeze files directly:  One example 
would be if you wanted to freeze all of your tracks, and use the freeze files for a remix 
in another studio (on DSP-based systems, for example). 

Refresh Freeze Files
The Audio > Refresh Freeze Files menu function (and key command of the same name) 
allow you to refresh the current freeze files. This may become necessary when global 
changes are made that also affect the playback of the frozen tracks (tempo changes, for 
example).
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5
5 The Environment
The Environment is Logic’s “brain”. It allows you to control 
all MIDI input and output.

Beyond basic input and output handling, the Environment can be used to process MIDI 
data in real time, and can even be used to create processing “machines”, such as virtual 
rhythm generators and step sequencers, or complex synthesizer editors.

Environment—Introduction
The Environment refers to Logic’s “virtual” environment inside your computer. It was 
developed to allow you complete control over your MIDI setup from within Logic.

Imagine that the Environment window provides a virtual view of your MIDI studio, 
including port objects which represent the MIDI inputs and outputs of your MIDI 
interface, instruments which are virtual representations of each device in your MIDI 
setup, and various objects for modifying the MIDI signal flow.

In order for this to work properly, you need to connect the different Objects in the 
Environment via virtual MIDI cables. This allows you to control the overall MIDI signal 
flow.

You can also create virtual faders that generate MIDI events when you move them. The 
movements of these Fader Objects can be remotely-controlled by other MIDI events, 
and recorded by Logic. In addition, there are specialized Objects which can split a MIDI 
signal into different channels, make pre-programmed alterations, or even re-route the 
signal path. 

Layers
As you can probably imagine, the Environment can quickly fill up with a large number 
of Objects. To keep things organized, you can assign Objects to different display levels, 
referred to as “layers”. Think of these layers as being different, partial views of the overall 
Environment. Naturally, you can easily connect Objects between different layers.
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Opening the Environment Window
To open an Environment window, select Windows > Environment (default key 
command:  Command-8). Double-clicking on an instrument in the track list of the 
Arrange window also opens an Environment window, to the layer containing the 
corresponding Instrument Object. When the Environment window opens, the Object 
that represents the track Instrument you double-clicked will be highlighted.

Basic Operation
Layers

Layers are “display levels” of the Environment window. They allow you to configure the 
Environment’s display, allowing you to view and work with specific groups of related 
Objects (Audio Instruments, for example), rather than dealing with all Environment 
Objects at the same time. The name of the current layer is displayed in the Layer box.

The distribution of Objects on different layers has no affect on their function—it’s 
simply a system of organization. There are some exceptions:  Objects in the Global 
Objects layer also appear on all other layers; and the All Objects layer shows all 
Environment Objects in a list.

Switching Between Layers
Click-holding the Layer box opens the layer pull-down menu, used to switch between 
layers.

Select Options > Goto previous Layer to switch back to the most recently active layer. 
This allows you to toggle between two layers.

Remember that you can assign key commands to this and many other Environment 
menu functions, for faster navigation and greater ease of use.
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Creating Layers
Selecting **Create!** from the layer pull-down menu creates a new, empty layer called 
“(unnamed)”, at the end of the list. You can add a new layer above the current position 
in the list by selecting Options > Layer > Insert.

Naming Layers
Double-clicking on the layer box opens a text field, allowing you to enter a name for 
the current layer.

Deleting Layers
You can remove the current layer from the list by selecting Options > Layer > Delete. As 
all Objects contained in the layer are also deleted, an alert box appears, to warn against 
the unwitting deletion of Objects. You must click Delete to complete the operation. 
Cancel or Enter cancels the operation.

Special Layers
The position (and existence) of the first two layers is protected, and they cannot be 
deleted:

All Objects
The top layer in the pull-down menu always displays all Objects in the Environment. 
The Objects in this layer are normally shown as a list. (You can change this in the 
Environment’s View menu, but doing so is not recommended.)

If you turn off the Preferences > Display > Other > Allow ‘All Objects’ Layer option, the All 
Objects layer will be removed from the layer pull-down menu.

The Options > Goto Layer of Object function switches to the selected Object’s layer.

Global Objects
You can place Objects (output ports, for example) that you want to be visible in all 
layers in the second layer from the top. These will appear at the same position, in all 
layers. We recommend that you place as few Objects as possible on this layer, due to 
the on-screen clutter that global Objects can create.

Hiding/Showing Parameters
As in other windows, you can hide the column containing the buttons, Toolbox, layer 
menu, and Object Parameter box by selecting View > Parameters. This will create more 
room onscreen for the Environment workspace display.

Hiding/Showing the Cables
Choosing View > Cables toggles the display of cables. This also hides/shows the 
positioning bar to the right of the individual Objects (used for moving and sizing of 
several Environment Objects).
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Protecting Cabling and Object Positions
You can prevent the accidental alteration of the position, size, and cable connections of 
all Objects by selecting View > Protect Cabling/Positions.

Background
If the cabling and Object positions are protected, and the cables are hidden, the 
background color changes. This usually looks better for virtual mixing desks and fader 
setups.

List Display
Selecting View > by Text switches the graphic display of the layers to a list display. The 
cables are not shown in the list display. This type of display is most useful in the All 
Objects layer.

Objects
Creating Objects
When you select an Object type from the New menu, an Object of this type is created 
in the current layer. Clicking on a layer background with the pencil tool creates a new 
“Standard Instrument” Object.

You can copy existing Objects by dragging an Object while holding down Option. 
Cabling is preserved; so groups of Objects copied in this way will be connected in the 
same way as the originals. (When you copy a single Object, only its output cables are 
preserved).

Deleting Objects
Click with the Eraser tool, or press Backspace, to delete all selected Objects.

Adjusting the Size of Objects
You can adjust the size of fader, keyboard, and monitor Objects by grabbing and 
dragging the bottom right corner (just as with windows). Changing sizes when 
multiple Objects are selected (by “rubber-banding” or Shift-clicking) will alter each 
Object’s size, while preserving their sizes, relative to each other.

Selecting Options > Clean up > Size by Default sets the size of each selected Object to its 
default value.

Moving Objects
You can move Objects by grabbing their icon or name, and dragging them to the 
desired position. The surface of Keyboard and Fader Objects is used for their operation. 
You must therefore either grab the name (if available), or the positioning bar to the 
right of the Object in order to move them.

If you hold down Shift, you can also grab Keyboard or Fader Objects by their surface. 
Remember to first deselect any other selected Objects by clicking on the layer 
background, to avoid moving them as well.
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Snapping Objects to a Grid
Select View > Snap Positions to align the Objects to an invisible grid. It’s a good idea to 
leave snap positions switched on. You only need to switch it off if you want to manually 
move an Object by a few pixels.

Aligning Objects …
… in a row or column
To align several selected Objects horizontally or vertically, select the Options > Clean up 
> Align Objects function. The top left Object stays where it is. The position of the next 
Object determines whether the Objects are aligned in a column or a row. If it is to the 
right of the top left Object, all Objects are aligned horizontally (row). If it is below the 
top left Object, all Objects are aligned vertically (column).

…to grid positions
If you choose Options > Clean up > Positions by Grid, all selected Objects are aligned to 
the invisible grid.

Moving Objects Between Layers
…with the layer selection box
To alter the layer assignment of a group of Environment Objects, first select the 
Objects, and then select the desired layer, while holding down Option. This moves the 
selected Objects to the chosen layer.

… with a second Environment window
Another way of moving Objects to a different layer is to open a second Environment 
window. Select the target layer and drag the relevant Objects from one window to the 
other. You can also use this method to copy Objects between layers (by holding 
Option).

… via the Clipboard
Another option is to move Objects via the Clipboard (Edit menu or the usual key 
commands):
• Select the Objects that you want to move and choose Edit > Cut (default key 

Command-X).
• Switch to the destination layer.
• Make sure that no Objects are selected (by clicking on the layer background).
• Select Edit > Paste (default key Command-V).

Replacing Objects
If any Objects are selected when attempting to add Objects to the current layer via Edit 
> Paste, a dialog box asks if you want to “Replace current selection? No/Replace”. If you 
press Enter or click Replace, the selected Objects will be replaced by the Objects in the 
Clipboard. The existing cabling remains intact.
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Assigning an Object to the Selected Track
You can assign any Environment Object to the selected Arrange window track by 
clicking on the Object with the MIDI Thru tool.

Remember:  Logic’s MIDI Thru function diverts all incoming MIDI events to the 
Environment Object assigned to the selected track.

Special Selection Commands
Selecting All Used Instruments
The Edit > Select Used Instruments function selects all Objects that are assigned to tracks 
in the Arrange window, or are connected to such Objects via cables.

Selecting All Unused Instruments
The Edit > Select Unused Instruments function selects all Objects that are neither; used in 
the Arrange window, nor connected to any such Objects via cables.

Selecting Cable Destination Objects
The Edit > Select Cable Destination option highlights the destination Object of a selected 
cable connection. This is particularly useful in two cases:
• The destination Object is in a different layer. You can use the function to select and 

display the destination Object in its layer;
• From the list display (View > By Text), you can locate the destination Object of a 

source Object, because selecting the source Object also selects its cable connections.

This function allows you to follow the cabling from one serially-cabled Object to the 
next. If several Objects are connected, or several cable connections are selected, the 
path of the top cable is followed.

Toggling Your Selection
Just as in the Arrange and editor windows, you can change the status of any selected 
Objects in the current layer by choosing Edit > Toggle Selection.
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The MIDI Signal Path
Before any MIDI events received at your computer’s MIDI inputs can be recorded by 
Logic, there must be a connection between two Environment Objects, namely:  the 
physical input and the sequencer input.

In the sequencer, the events are always directed to the selected track, where they can 
be recorded. The events played by the track are mixed with any incoming events and 
sent to the Environment Object assigned to the track in the Arrange window’s track list. 
From here, the events are directed to a MIDI output (see “Direct Output Assignment” on 
page 159).

You can insert Objects into the signal path between the physical input and the 
sequencer input, as well as between the instrument and the MIDI Out port, to 
accomplish other Environment processing. This is done by using cables (see “Cabling” 
on page 160).

Direct Output Assignment
You can create a direct output connection from any Instrument Object to a physical 
MIDI output by setting the desired output in the Port parameter line, just above the 
Channel parameter.

If you click and hold in this line, a pull-down menu will list all individual ports, an off 
setting and one general setting (All) for each output connection. The off setting 
completely disables the connection to the MIDI interface port. The All option routes the 
Object’s output to all available MIDI ports. This may be useful if the device is sending a 
pulse, for example. 

Note:  If you have a MIDI interface with more than one output port (or even several 
interfaces which can be stacked, like products belonging to the Unitor family), you can 
set up a direct connection to one of the individual ports (1 to 63) of that, or those, 
interface/s (for example “Port 1 (Unitor 8)” or “Port 14 (Motu)”). 

Any Object with a directly assigned output is indicated by a shaded triangle on its 
right-hand side. The triangle is hollow when there is no direct assignment.
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Breaking the Direct Output Assignment
To break the direct output assignment, set the Port parameter to off, the top entry in 
the pull-down menu.

Cabling
The cabling between Environment Objects provides control over the entire MIDI signal 
path. A cable is normally shown as a gray line between a source and destination 
Object.

Objects always have an input on the left, and an output on the right-hand side. The 
output of an Object is shown as a small triangle, pointing to the right.

If you grab the triangle, the mouse pointer turns into a patch cord that represents a 
cable connection coming from the Object’s output. Move the mouse over the 
destination Object to connect it to the source Object with a cable. Once you have 
selected the destination Object (this happens automatically when you touch it), release 
the mouse button.

If the source Object has already been directly assigned to an output, a dialog box will 
appear, asking whether or not you want to replace the direct assignment. You have 
three options:
• Cancel:  the connection is not made, and the direct output assignment remains 

intact.
• No:  your cabling is carried out, but the direct output assignment remains intact. This 

means that the Object is connected in two places—one via the visible cable and one 
via the direct output assignment.

• Remove (or Enter):  your cabling is carried out, and the direct output assignment is 
removed. (This is the default selection, because you generally won’t want an Object 
connected to two different destinations).

Cabling Between Layers
If the destination Object of the cable is on a different layer, you can connect it by using 
the Instrument List. To do this, hold Option as you grab the output triangle and scroll 
to the desired destination Object when the Instrument List (see “Object Parameters” on 
page 162) appears.

You can also open a second Environment window showing the destination layer, and 
connect the Objects graphically between the windows.
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A cable connection to another layer looks like this:

Deleting Cables
To remove a cable connection, click the cable with the eraser, or select the cable and 
press Backspace. You can also remove a cable by grabbing it and plugging it back into 
the input of its source Object.

You can use Edit > Clear Cables only to remove all selected cables, without also clearing 
any Objects that happen to be selected. This is handy if you want to clear all cables 
leading to (or from) one or more Objects, given that selecting Objects also selects all 
associated cable connections.

Cable Color
Cables are assigned the same color as the source Object. You can switch off cable 
coloring, and render them all in gray with the View > Colored Cables function.

Multiple Cabling
Multiple Inputs
There is no limit to the number of cables that you can “plug” into a target Object. All 
MIDI signals are then mixed at its input.

Multiple Outputs
Once an output from an Object is used (cabled to another Object), another output 
triangle automatically appears. You can thus cable outputs from the Object to as many 
other destination Objects as desired.

Note:  Some Objects have special outputs, and are exceptions to this rule.

Special Outputs
Some Objects, such as the Channel Splitter (see “Channel Splitter Object” on page 173), 
feature several—functionally different—outputs. In these Objects, each output is only 
available once. If you want to route the signal to several destinations from these 
outputs, you must first create a monitor (see “Monitor Object” on page 173) (New > 
Monitor), plug the cable into it, then connect it to as many other destinations as you 
like. The monitor Object also allows you to view the MIDI events flowing through it.
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To select a common destination for several existing cables, first select the cables. (If the 
cables are already leading to a common destination, the simplest way of doing this is 
to select the destination Object.) Next, grab one of the cables and plug it into the new 
destination Object. A dialog box will appear, asking “Do you want to connect all 
selected cables with new Destination? No/Connect”. Click Connect, or press Enter.

Cabling Serially
To cable a group of Objects serially, first select all Objects and then choose Options > 
Cable serially. The Objects will be cabled in series, starting with the top-left Object. This 
is handy for quickly connecting groups of faders in a mixing console, for example.

Environment Objects
Object Parameters
Each Environment Object has several parameters that control its operation. These 
parameters can be viewed and changed in the Object Parameter box. The Parameter 
box also appears in the Arrange window when you select a track assigned to the 
Object. It also appears in the Environment window when you select the Object. These 
are the same parameters—changes in one location will be reflected in the other.

Opening/Closing the Object Parameter Box
By clicking the triangle at the top left, you can hide all parameters except the Object 
name and type. This reduces the box to its minimum vertical size.

Common Parameters
The following parameters are shared by all Object types:

Name
The name of the Object is shown next to the triangle, and can be selected for editing 
by clicking on it. You can also edit the name by clicking on the Object with the text 
tool.

Object Type
The Object type is shown in brackets, and cannot be edited.

Icon/Display Filter for the Instrument List
Click-holding on the icon in the Parameter box opens a pull-down menu, where you 
can choose an icon to represent the Object in the Environment and Arrange window 
track list.

Placing a check in the box next to the icon means that the Object will appear in the 
Instrument List, and can therefore be assigned to a track via this menu. Objects not on 
the track list can still be assigned to tracks by dragging them from the Environment 
window to the track list, or by using the Environment’s MIDI Thru tool.
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If the box is not checked, the Object will not appear in the Instrument List, and a 
diagonal line through the icon is shown. This will not hide the Object or its icon in the 
Environment.

You should only check the icon box if the Object will be used as a track instrument, or 
you need to connect cables to its outputs by using the instrument selection menu.

Color
You can change the color of an Object via the View > Colors local menu, which opens a 
palette of various colors. A double-click on a color field opens the system color palette, 
allowing you create customized colors. These color edits are stored in the Preferences 
file, and are available for all songs. The color of an Environment Object is used as the 
default color for any newly created Region in the Arrange window.

Standard Instrument
This is the simplest track playback Object. It provides a direct connection to a single 
MIDI port and channel, which can be set in its Parameter box.

You can also set a number of other playback parameters, including program bank and 
number, initial volume and pan, transpose, velocity scaling, and MIDI delay.

To create a new standard instrument, select New > Instrument, or click on the layer 
background with the pencil tool. Instruments serve as the interface between Logic’s 
tracks and your MIDI sound sources.

The Standard Instrument Object Parameter box will be familiar to you from the Arrange 
window. Here are the details of the individual parameters.

Channel
Use the Channel parameter to set the MIDI channel for the instrument’s output. All 
events at the output of the standard instrument Object are sent via the channel set 
here. Exception:  If you set this parameter to All, all events will be sent with their 
original channel settings—as they appear in the Event List window.

Port
Below the channel parameter, a direct connection to one of the MIDI output ports can 
be set. Remember that you can also directly cable the standard instrument Object to 
other Environment Objects for MIDI processing. If no MIDI output port is defined in the 
Object Parameter box for the instrument, the Port parameter will display “off”.
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Prg, Vol, and Pan 
The Prg, Vol, and Pan parameters transmit program changes, volume controller (#7) and 
pan controller (#10) data.

You can edit the values of any of these parameters, but no data will be sent until you 
check the corresponding box (by clicking on it). If the box is already checked, any value 
alterations will be sent immediately, and the values will also be sent whenever the track 
is selected. 

To the left of the program number, directly to the right of the checkbox, you’ll see the 
bank select parameter. If your MIDI sound sources recognize Bank Select messages 
(check their manuals), you will be able to switch between sound banks. If your sound 
sources respond to the standard Bank Select message (Controller #32), you will be able 
to use this parameter directly. If not, you may define your own Bank Select commands 
(see “Defining Custom Bank Selects” on page 169).

Transpose
The Transpose parameter defines the number of semitones that all note events will be 
transposed by, on output. Negative values transpose downwards.

Velocity
The Velocity parameter allows you to increase or decrease the “note on” velocities of all 
note events, by an amount adjustable between −99 and 99.

Key Limit
The two note values of the Lim parameter define a pitch range. All notes outside this 
range will be ignored by the instrument when it plays a MIDI Region.

Vel Limit
The two values of the VLim parameter define a velocity range. All notes with a velocity 
that falls outside this range will not be played by the instrument.

Delay
The Delay parameter causes all MIDI events to be sent early or late. This “delay” ranges 
from −99 to 99 ticks. This allows you to adjust for any differences in reaction time 
between your various MIDI devices. Use the Region parameter of the same name to 
create delay effects, as this allows longer delay times.
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No Transpose
If the box next to the No Transpose parameter is checked, all Regions on any tracks 
played by this instrument are protected from transposition. In other words, the 
“transpose” Region parameter is ignored. This is very useful for instruments assigned to 
drum or other multi-timbral samples, as transposition will cause the sounds (rather 
than the pitches) to change in these instruments.

No Reset
If the box next to the No Reset parameter is checked, no reset messages will be sent to 
the instrument. This can be useful if controllers are being used for non-musical 
purposes, such as when using an Instrument for mixer automation. The Preferences > 
MIDI > Reset Messages window controls what reset messages are normally sent. These 
messages are not sent to “No Reset” instruments.

Style 
The Style parameter is located at the bottom of the Parameter Box. It displays Auto by 
default, but can be changed to any of the available score styles. Whenever a Region is 
created on one of the instrument’s tracks, it will be assigned the score style displayed 
here. In the Auto style’s case, Logic will pick an appropriate style based on the pitch 
range of the notes in the Region.

Don’t forget:  you can change a MIDI Region’s Score Style at any time in the Display 
Parameter box of the Score window. 

You can change the score styles of all MIDI Regions on an instrument’s tracks by 
holding down Option when selecting the instrument’s default score style.

Multi Instrument
A multi-instrument is like a collection of 16 standard instruments (see “Standard 
Instrument” on page 163) in one package. There is a “sub-channel” for each of the 16 
MIDI channels—as indicated by the numbered squares on the multi-instrument icon. 
Clicking on any of these numbered squares selects the corresponding sub-instrument, 
and displays its parameters in the Parameter box.

All sub-channels of a multi-instrument use the same output port.
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Multi-instruments have 15 name banks—each of which will hold 128 preset names. If 
the multi-instrument’s program parameter is checked, selecting names in the name 
bank will send MIDI program change messages to the corresponding port and channel. 

You will generally use multi-instruments to address multi-timbral synths or samplers in 
your studio. A multi-timbral synth is one that can receive on several MIDI channels at 
once—playing back a different sound on each channel. As most modern MIDI devices 
are multi-timbral, the multi instrument will probably be the most commonly used 
instrument Object in your Environment.

To create a new multi-instrument, choose New > Multi Instrument.

A multi-instrument is intended for use with multi-channel MIDI sound devices. It 
combines 16 separate sub-instruments (one for each MIDI channel) with 15 name 
banks, and a number of common bank select options.

A multi-instrument consists of 16 sub-channels, each of which has a complete set of 
instrument parameters. The name, MIDI channel and output of each sub-channel is 
determined by the multi-instrument. All sub-channels share the 15 banks of program 
names, and use the same format for their bank select message.

Multi-Instrument Parameter Box
Once you have created a multi-instrument, you will see the multi-instrument Parameter 
box.

You should already be familiar with the meaning and operation of the individual 
parameters (as they’re identical to those of the standard instrument Object). The 
settings made here apply to all sub-channels and should be left at their neutral, default 
values, with the exception of the output port setting. Set the output port in the line 
below the “Cha” parameter line (Port parameter). For more information on this subject, 
please read the Direct Output Assignment section (see “Direct Output Assignment” on 
page 159). Direct output assignment can also be replaced by manual cabling to other 
Environment Objects—so keep it in mind.
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Activating and Selecting Sub-Channels
To select a sub-channel for a specific MIDI channel number, click the appropriately 
numbered button on the multi-instrument Object. The first time you click it, the sub-
channel is activated, making it available from the Instrument List. To avoid menu 
clutter, you should only activate as many sub-channels as you actually need.

As with any other Environment Objects, you can remove sub-channels from the 
Instrument List, by unchecking the icon box. The button for that sub-channel will then 
be shown with a diagonal line through it. If you want to select the entire multi-
instrument rather than a particular sub-channel, click on the top edge of the multi-
instrument Object, or next to the icon.

In the above diagram, sub-channel 1 is selected, sub-channels 1 to 8 are activated, and 
9 to 16 have been removed from the Instrument List.

The Sub-Channel Parameter Box
The sub-channel parameters are the same as those of standard instrument Objects (see 
“Standard Instrument” on page 163). The only parameter you can not change is the 
MIDI channel. (If you change the output port, this will affect the entire multi-instrument 
and all other sub-channels.) If you try to change the channel from the Parameter box in 
the Environment window you’ll see the following warning:  “Channel protected! Please 
select a sub-channel from the Instrument pull-down menu.” You can, however, change 
the channel in the Arrange window’s Parameter box to a sub-channel shown in the 
Instrument List (one without a slash through it on the multi-instrument), and the track’s 
instrument will change to the selected sub-channel.

Cabling
To connect the output of an Environment Object directly to the input of a sub-channel, 
hold down Option, and connect it the via the Instrument List (see “Cabling” on 
page 160).
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Multi Instrument Window
Double-clicking on a multi-instrument opens the multi-instrument window:

Name and Short Name
At the top left, under Device Name, you can enter the full name of the multi-instrument. 
To the top right, under Short Device Name, you can also enter a short name. This short 
name is used in the Arrange window track list, when the program name is displayed. 
The short name is shown directly beside the icon, so leave a space in front of it, if you 
want uniform (name) spacing in the track list.

Depending on whether or not you have checked the sub-channel’s Prg box, the 
following information will appear in the Arrange window track list:
• the name of the multi-instrument and channel number (if the box is not checked) or
• the short name, channel number and program name (if the box is checked).

Program Names
There are 128 program names in the multi-instrument window. A total of 15 banks of 
128 program names are available. There are several ways of entering the program 
names:
• by double-clicking on the name (via the text input field),
• by copying (via the Clipboard) from a different multi-instrument, or from a word 

processing program. The Clipboard functions for a whole sound bank are available in 
the text import pull-down menu (downwards arrow at the top right). First, copy the 
program numbers or General MIDI names to the Clipboard, and add them to a word 
processor document. You can then edit the names and copy the whole section back 
again.

• if you want to use program numbers instead of names, select Init Names as Numbers 
from the text import menu.

• if you want to use General MIDI program names, select Init General MIDI Names.

If the Use GM Drum Names for Channel 10 box at the very bottom is checked, the 
standard GM drum set names will be shown in the Prg pull-down menu of the 
Parameter box for sub-channel 10.
Chapter 5    The Environment



 

If the Prg box in the selected sub-channel’s Parameter box is checked, you can send a 
program change message by selecting a program name in the multi-instrument 
window (either by clicking, or using your computer’s arrow keys).

Banks
On the left, above the program names, you can choose one of 15 available sound banks 
(0 to 14) via a pull-down menu. The top item (“No Bank specified. Names of Bank 0 
used.”) can be used if that particular sound generator does not understand bank select 
messages, or only has 128 sound programs. Bank 0 is always initialized. The first time 
you choose one of the banks numbered 1 to 14, you will be asked whether or not you 
want to initialize this bank. Press Enter or Cancel if you don’t want to initialize the bank. 
Non-initialized banks do not have their own program names, but use the names of the 
equivalent program numbers from bank 0. You should only initialize additional banks if 
you want to enter program names for those banks, because each initialized bank uses 
more memory.

In the pull-down menu to the right, labeled Bank Message, you can define the MIDI 
events that are sent when you switch between the banks of the multi-instrument. 
Different bank select formats are used by different MIDI instrument manufacturers—
please consult your instrument’s manual to see whether it supports bank select 
messages and if so, what format it uses. With modern synths, there’s a good chance the 
format will be one of the top items in the pull-down menu:  either controller# 32 or 
controller# 0. There are also presets to accommodate several of the more common 
types of synth. If your synth doesn’t use one of the formats listed, check out the section 
on defining your own bank select commands (see “Defining Custom Bank Selects” on 
page 169).

Defining Custom Bank Selects
Logic provides 63 bank numbers (0 to 62) for each single standard instrument, multi-
instrument sub-channel, or mapped instrument. You can create custom lists, consisting 
of as many events (of any kind, even SysEx) as you wish—for each of these banks. 
Whenever you change the bank manually or send a standard bank change message 
from Logic, the entire list for that bank will be transmitted to your synth.

If you need more than 63 banks for a particular MIDI device, use several instrument 
Objects. 

To set up custom bank select messages, first select the instrument, then choose 
Options > Define Custom Bank Messages. A window similar to the Event List will open, 
with a single, default, bank select message for banks 0 to 15. (The default used is a MIDI 
controller #0 message, with a value equal to the bank number).

You can create MIDI events here in exactly the same way as in the Event Editor, by 
cutting, copying, inserting, and editing. The only difference is that you enter the desired 
bank number, rather than a time position.
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The letter in parentheses next to the bank number allows you to control the order of 
transmission, when a bank select requires more than one message.

As an example:

Here, the Bank Select command “Bank 1” was set up to send three events:  first, (a) a 
controller #32 message with a value of 1, then (b) a controller #0 message with a value 
of 0 and finally, (c) a SysEx message.

If there are no events defined for a particular bank, a standard Bank Select message will 
be sent for that bank.

The custom bank select information becomes part of the instrument, and will be 
automatically copied with it, should you replicate the instrument Object.

For bank messages that need a channel (MIDI controller messages, for example), the 
channel of the instrument is used. This feature is especially useful for multi-instruments, 
as you only need to create one set of bank messages for all 16 sub-channels. If an 
instrument’s channel is set to All, channel 1 is used. 

On multi-instruments, the bank select message (whether it’s a standard controller or a 
string of events you’ve configured) is also used by SoundDiver, if Autolink is switched 
on. This enables it to request the program names in the current bank.

Mapped Instrument
This instrument is particularly useful for drum instruments or any drum-mode MIDI 
device.

A drum-mode device is one which assigns different sounds to different MIDI notes on 
the same MIDI channel. Any input note may be routed to a different output note and 
assigned its own velocity setting, notation, name, and output cable. You can also 
protect mapped instruments from being accidentally transposed.

To create a new mapped instrument, select New > Mapped Instrument.
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A mapped instrument is useful for drum programming. It is used just like a standard 
instrument, but has the following special features:

Each individual input note can be:
• named (snare, hi hat and so on);
• mapped to an output note (F# and G# for the same hi-hat sound, allowing you to 

play rapid repeats);
• given a velocity offset;
• assigned its own MIDI channel;
• sent to one of up to 16 output cables (this allows you to create a single instrument 

that addresses multiple sound sources);

Object Parameter Box
The mapped instrument’s parameters are a subset of the standard instrument (see 
“Standard Instrument” on page 163) parameters. The missing settings are available on a 
note-by-note basis in the mapped instrument window.

GM Mixer Object
The GM Mixer is a collection of 16 fader “modules”, configured to emulate a virtual 
mixing desk for 16 MIDI channels. Each module has controls for volume, mute, preset, 
bank, and four assignable knobs (one of which is typically used for pan). There are 
optional controls for standard XG and GS effects. 

The GM Mixer can be directly connected to an output port, via its Parameter box. 

To create a new GM Mixer, select New > GM Mixer. 

The GM Mixer is intended for controlling the 16 channels of a MIDI device which 
conforms to the GM, XG, or GS standard. This includes the GM set of 128 program 
names (with variation banks for XG or GS), MSB/LSB bank select messages, and 
standard controller names (#1 for mod wheel, #2 for breath, #7 for volume, #10 for pan, 
#11 for expression, and so on).
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Most of the GM Mixer’s set up is done in the mixer itself, but there are also a few 
parameters in its Parameter box. 

Cha/Port
Like other instrument Objects, the GM Mixer can also have a direct MIDI output 
connection. This is set in the line below the channel in the Parameter box. The Channel 
parameter determines the channel number of the lowest GM Mixer module. You can 
use this, together with resizing the GM Mixer window, to create sub-mixers for any 
continuous string of channels (3 to 7, for example). 

Legend
The Legend checkbox toggles the display of the legend along the left edge of the GM 
Mixer. The Legend not only indicates what the rows of controls do, it is used to set the 
function of the top four rows of knobs. After the GM Mixer is set up, you can hide the 
legend to save space.

Bank
The Bank checkbox toggles bank MSB/LSB display below the program name display, at 
the bottom of the GM Mixer. You can save space by hiding bank display, unless you 
need to select program banks numerically.

Keyboard Object
The keyboard Object is used for creating notes with the mouse. It will also display all 
notes passing through it. In this sense, you can think of it as a realtime, note-on 
monitor.

You can create a virtual keyboard by selecting New > Keyboard.

The keyboard Object generates MIDI note events when clicked with the mouse. It also 
displays note events passing through it—when a note is being held, the corresponding 
key is reversed in color. Although you can record the output of the keyboard in Logic, 
its main purpose is for testing and monitoring in the Environment.

Apart from the standard parameters, you can also set the MIDI channel, a fixed velocity 
for all notes and the octave of the lowest note on the keyboard (which is always a C). 
You can re-size the keyboard to control its range above the lowest note. Shift-click the 
keyboard to select, and move it.
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Monitor Object
The monitor Object displays all MIDI events passing through it, and retains the last 32 
such events. You will need to resize it to see more than 5 events at a time. 

To create a monitor Object, select New > Monitor. The monitor shows all events (MIDI 
and meta) passing through it. It remembers the last 32 events, with the newest events 
shown at the bottom of the list. You can resize it to show from 1 to 32 events. (You can 
make it even bigger, if desired).

Monitors are very handy as both testing, and branching devices. When coupled with 
Objects that have functionally different outputs (the channel splitter and mapped 
instrument, for example), monitor Objects can be used to attach more than one output 
cable to the same function.

Click in the body of the monitor to clear it.

Channel Splitter Object

The channel splitter routes MIDI events by channel. It offers an output for each of the 
16 MIDI channels, and an additional “SUM” output. If a particular channel output is not 
connected to anything, events for that channel will appear at the SUM output. 

To create a new channel splitter Object, select New > Channel Splitter. You can use the 
channel splitter to reroute MIDI events to different cables, in accordance with their MIDI 
channels. Every MIDI event received at the channel splitter input is automatically 
routed to the output that corresponds to its MIDI channel. If no cable is connected to 
the corresponding output channel, the event is rerouted to the SUM output (at the 
top). The SUM output is used for the events of channels with no individual output 
connections.
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Arpeggiator Object
The arpeggiator turns chords into arpeggios. It plays the currently held notes—
individuallyin a selectable pattern (up, down, random, and so on), and at a selectable 
speed that ranges between whole-notes and 768th-notes.

The arpeggiator features a number of useful parameters including; note-length, repeat 
on/off and octave doubling. All of its parameters can be changed in real time through 
the use of MIDI controller messages.

Important:  Logic must be in play (or record) mode for the arpeggiator to work.

To create a new arpeggiator, select New > Arpeggiator. 

The arpeggiator cycles through all held notes (arpeggiates chords) within its range. You 
can set the range to be as wide or narrow as you wish. There are parameters for 
direction, velocity, speed, note length, start quantize (snap), repeats, octaves, and 
velocity offset. All of the arpeggiator’s parameters can be MIDI controlled in real time, 
which adds immensely to its versatility.

To use the arpeggiator, you must place it in the MIDI signal path, and Logic’s Transport 
must be running. (For technical reasons, the arpeggiator resets on cycle jumps). 
Typically, you would assign the arpeggiator to an Arrange track, and cable its output to 
an instrument or port Object. You can, of course, insert it anywhere else in the MIDI 
signal path. 

Once set up, you can use the arpeggiator with live MIDI input, or for MIDI Region 
playback. You can also record the output of the arpeggiator by cabling it into the 
sequencer input Object. If you do this, be sure you either record to a no output track, 
or break the arpeggiator’s connection to the MIDI output. 

Arpeggiator Parameters
The arpeggiator features the following parameters (the numbers in parentheses are 
Control Base offsets—see below):

Direction (+0)
The direction of the arpeggiated chord:
• Up:  Lowest note to highest note
• Down:  Highest note to lowest note
• UpDn:  Up and down—highest and lowest notes repeat
• Auto:  Up or down depending on whether the second chord note arrived before or 

after the first chord note
• UpD2:  Up and down—highest and lowest notes don’t repeat
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• Rand:  Notes play in random order
• All:  All notes play at once (useful when repeat is on)

Vel (+1)
Velocity values of the arpeggiated notes.
• 1 to 127:  Fixed velocities,
• Orig:  the velocities of the recorded notes are retained,
• Rand:  random velocities between 1 and the original value.

Lim (Low: +2, High: +3)
This is where you can define the pitch range (between C-2 and G8) for the chord 
arpeggiation. Any chord notes outside this range are passed directly to the output. This 
is useful when you want to solo above, or play a bass line below an arpeggiated chord.

Res (+4)
This is where you set the rhythmic note value (the speed in note divisions) of the 
arpeggio via a pull-down menu. None = arpeggiator switched off.

Len (+5)
This is where you define the length of the arpeggiated notes. The Orig setting retains 
the lengths of recorded notes.

Snap to (+6)
Unless this value is set to None, the arpeggiator will wait for Logic’s transport to reach 
the next indicated note division before starting the arpeggio. This is useful for 
rhythmically synchronizing the arpeggio with other MIDI data.

Repeat (+7)
On continues the arpeggio for as long as the chord is held down. Off finishes the 
arpeggio after one run.

Octaves (+8)
The arpeggio can be repeated over 1 to 10 octaves.

Crescendo (+9)
The velocity value set here (−99 to +99) is added every time the arpeggio is repeated 
(provided Repeat is set to On, of course).

Control Base
All 10 parameters of the arpeggiator can be remote-controlled by controller events. The 
Control Base parameter determines the controller number for the first parameter 
(Direction). The other parameters will be controlled by subsequent controller numbers. 
To figure out which controller number will be used for a certain parameter, add the 
number shown in brackets (behind the parameter names in this document) to the 
Control Base value. When Control Base is set to Off, MIDI control of the arpeggiator is 
disabled.
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Delay Line Object
The delay line echoes MIDI events passing through it—at intervals ranging from one 
tick to 256 whole notes.

There are parameters for the number of echoes, (echo) transposition and velocity 
offset. 

The echoes of each incoming event are cycled through each cabled output of the delay 
line.

Important:  Logic’s transport must be running for the delay line to work.

To create a new Delay Object, select New > Delay Line.

This Object repeats any MIDI events, much like a delay line effect. Pitch and velocity 
offsets can be added to note events. As with the arpeggiator, you will need to place the 
delay line in the MIDI signal path, and will need to start Logic’s Transport for it to work.

The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 
whole notes. You can suppress the original note. Repeats leaving the delay line will 
cycle through all cabled outlets, allowing you to play each repeat with a different 
sound.

Delay Line Parameters
The Delay Object has the following parameters:

Thru Original
If this box is checked, the original signal is passed thru. If unchecked, the original signal 
is suppressed.

Repeats
Number of event repeats (1 to 99). Setting 0 = delay switched off.

Del
The delay time between the individual repeats. The left value is in divisions, and the 
right value in ticks.

Trp
The transposition of note events per repeat (±99 semitones).

Vel
The change in the velocity values of note events per repeat (±99).
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Physical Input/Sequencer Input Objects
The physical input Object represents the physical inputs of your MIDI interface; the 
sequencer input represents Logic’s MIDI input. You can only have one of each of these 
Objects in the Environment. The default sequencer input Object is named “to 
Recording & Thru”.

To create either type of input Object, select New > Physical Input or New > Sequencer 
Input. To make use of an existing Object, drag it onto the relevant layer. This will not 
affect its cabling.

Physical Input Object
The physical input represents the MIDI inputs of your MIDI interface. Each song can 
have only one physical input Object. You only need to create a physical input Object if 
you have deleted the one that existed when the song was created. Do so by selecting 
New > Physical Input.

The physical input Object receives MIDI signals from the inputs of the MIDI interface(s) 
connected to your computer. 

Sequencer Input Object
MIDI events arrive at Arrange window tracks thru the sequencer input Object. If 
nothing is cabled into the sequencer input Object, nothing can be recorded in Logic. 
Typically, the physical input Object is cabled directly to the sequencer input Object but 
other Objects can be inserted between them. Typical candidates are; a monitor, 
keyboard, or cable switcher Object—feeding various processors such as an arpeggiator, 
a delay line, and so on (See the Clicks & Ports layer of the Logic default Song.) You can 
also cable the output of complex Environment processes into the sequencer input 
Object, in order to record the processed signal.

Each song can have only one sequencer input Object. You only need to create a 
sequencer input Object if you have deleted the one that existed when the song was 
created. If you do need to create one, select New > Sequencer Input.
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MIDI Metronome Click
The MIDI metronome click Object is used to create note events at bar, beat, and 
division intervals. These can be sent to either; a MIDI port or the internal speaker.

There is a button on the Transport that turns the MIDI metronome click on and off.

A long click on this button will allow you to open the File > Song Settings > Metronome  
(see “Metronome Settings” on page 466). In this pane, you can also set the MIDI 
metronome click to play during recording and/or playback. This dialog mirrors the 
settings in the Parameter box of the MIDI metronome click Object:  Checkboxes for Bar, 
Beat, and Division allow you to generate note events separately for bars, beats, and 
divisions. The Cha, Note, and Vel parameters define the MIDI channel, note number and 
velocity of generated notes. The MIDI port parameter allows you to set a direct output 
port for the metronome.

Each song can have only one MIDI metronome click Object. You only need to create a 
MIDI Metronome Click Object if the one that existed when the song was created has 
been deleted. If you do need to create one, select New > MIDI Metronome Click.

Internal Objects
“Internal” Objects include instruments located inside your Macintosh (such as a PCI 
card and/or software synthesizers). Although communication with sound sources 
inside the computer does not actually use MIDI, it still conforms to the MIDI 
communication protocol. Internal Objects have an input, but no output. They therefore 
act like extra output ports, which are hard-wired to the relevant sound generator.

Using Internal Objects
If you want to address internal sound sources, you must first create an equivalent 
internal Object (see below). Then create a standard instrument, multi-instrument or 
mapped instrument for the device. Next, connect the output of the instrument to the 
internal Object. Then use the instrument as you normally would.

Apple QuickTime
The QuickTime system extension offers a software-based GM sound generator. The 
“QuickTime Musical Instruments” file must be present on your System.

To create a virtual representation of the QuickTime synth, choose New > Internal > 
Apple QuickTime.
Chapter 5    The Environment



 

This software synth is 16-part multi-timbral. As usual, you can switch sounds via 
program changes; these are arranged according the GM table. Channel 10 is always set 
to drum sounds, with GM key assignments. The QuickTime synthesizer reacts to notes 
and program change commands, as well as to pitch bend (±2 semitones) and the main 
volume controller (#7).

The first note is used to initialize the relevant MIDI channel of the QuickTime 
synthesizer, and is not played.

Internal—ReWire
New > Internal > ReWire allows you to send MIDI data to ReWire2 compatible 
applications and their software instruments.

Starting/Stopping the ReWire Connection
To connect to a ReWire compatible software instrument, first launch Logic and then the 
ReWire application. When shutting down, first quit the ReWire application, then Logic.

Settings
Apart from common parameters, the Rewire Object offers three settings:

Device:  This setting refers to the ReWire application(s) that Logic can connect to. If one 
or more ReWire applications are running, it will display the names of these applications. 

Bus:  Lets you choose the ReWire Bus from all available ReWire busses. If a ReWire 
application provides bus names, they will be shown. If using Reason, the names of the 
instruments available in the Reason Rack will be shown from Bus 6 upwards, in place of 
numbers.

Cha:  Sets the MIDI channel of the ReWire Object.

Reason Settings
When using Reason, the Bus numbers translate as follows:
• Bus 1:  addresses the instrument chosen as the Live Track in Reason.
• Busses 2 to 5:  address Busses A-D of Reason’s MIDI In device.
• Busses 6 and higher:  addresses the instruments of the Reason Rack.

ReWire Behavior
In Preferences > Audio > Driver, you can set the ReWire behavior for each ReWire 
compatible audio driver type. When sending MIDI data to a ReWire compatible 
software instrument, you can choose between these modes:
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• Playback mode:  use this mode when playing back MIDI tracks via ReWire. This setting 
requires less CPU power.

• Live mode:  use this mode when playing a ReWire instrument live. This setting 
requires more CPU power.

MIDI Outs
Port Objects represent the MIDI output(s) of your MIDI interface(s). You can also use 
them to address the internal synth on your soundcard (if applicable).

To create a port Object choose New > MIDI Out Port.

The lowest line in the Parameter box sets the MIDI output driver for the port Object. 
The signals from all MIDI cables plugged into this Object will then be sent via the 
selected MIDI output.

Remember that you can also address any MIDI output port directly from instrument 
Objects (and the GM Mixer Object).

Faders
Faders (see “Faders—Overview” on page 181) are used to send MIDI events by clicking 
or click-dragging on them. Faders come in different forms (knobs, sliders, numerical, 
and buttons). Fader Objects respond to incoming MIDI events.

Audio Objects
The Environment’s audio Object (see “Audio Objects in the Audio and Track Mixer” on 
page 194) is the “building block” of the Environment Audio Mixer. They are also used to 
create audio tracks in the Arrange window—audio tracks are simply tracks with Audio 
Objects assigned to them.

Although audio Objects are not part of the MIDI signal flow, they still allow MIDI 
controller messages to control aspects of Logic’s audio playback. Any MIDI Object can 
be cabled into an audio Object, thereby feeding control data into the audio Object.
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Faders
Faders—Overview
To create a new fader, select New > Fader > … A sub-menu appears, where you may 
select the style of fader you want. 

The style of a fader determines it’s onscreen appearance (slider, knob, menu, numerical) 
and how it responds to the mouse (click and drag, double-click and type a number, 
click, and select from a menu). The Auto style fader—the default style if you create a 
fader with a key command—changes styles as you alter its shape and size. 

The type of fader determines what events the fader sends out and responds to. 

In general, a fader’s style is completely independent of its type. A cable switcher can 
look like a button, a knob can send out MIDI events, and so on. Don’t worry about 
selecting the wrong fader style or type from the New menu—you have complete 
control of a fader’s style and type from its Parameter box.

Some of the styles have numerical displays. When there is a numerical display, you can 
double-click it, and type in the desired values. When you drag on any of the sliders or 
knobs, the series of values that are sent out depends on the fader size and scrolling 
speed—not every consecutive value is sent out at smaller sizes. If you drag slowly on 
the numerical field, however, you will send all consecutive values.
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The text-style fader behaves like a pop-up menu. If double-clicked, a window will open, 
allowing you to enter text for each of the menu positions. A checkbox enables the 
names to be scrolled, rather than chosen from a menu.

Fader Operation
Normally, you’ll grab the surface of a fader, and drag it vertically or horizontally, 
depending on it’s style. 

Knobs can be dragged either vertically or horizontally.

When the fader features a numerical display, you can grab this number and use the 
mouse as a slider. The advantage is that if you drag slowly, the fader output will move 
in increments of 1 value unit, regardless of the size of the Object. When using the fader 
itself as a slider, values may jump in larger increments, depending on the size of the 
fader and dragging speed. You can also change values in single steps by dragging on 
the slider or knob while holding down Control.

Buttons only send two values, the lowest and highest of their range set in the 
Parameter box. You change a button’s state by clicking on it.

Names with Numbers
If you name one Object in a selected group of Objects with a name that ends in a 
numeral, the remaining Objects will be renamed with this name, but with sequentially 
increasing numerals. As an example:  Selecting several Objects and naming one of 
them “Object 1” will result in the ensuing Objects being renamed as “Object 1”, “Object 
2”, “Object 3” and so on.
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Special Functions
Grouping Faders
If you select several faders and move one of them, all selected faders will move 
proportionately. As long as all faders remain selected, their relative positions will be 
retained (even after one or more of the faders has reached its minimum or maximum 
position).

Moving the fader group with Option pressed changes all values in a linear fashion (the 
absolute value differences are maintained).

Moving the fader group with Shift-Option pressed changes all faders to the same value.

Sending Fader Values
You can use the Options > Send All Fader Values and … > Send Selected Fader Values 
functions to make all fader Objects or all selected fader Objects send their current 
values. Use of this function in conjunction with Logic’s Record/Pause mode allows you 
to record a “snapshot” of all current fader positions. This is especially useful for virtual 
mixing desks, or synthesizer panels. (Send All Fader Values only sends values for faders 
that are cabled to other Objects.) The Song Settings > MIDI Options > Send All Fader 
Values after loading option automatically sends all fader values after a song is loaded.

Resetting Fader Values
Options > Reset Selected Faders sets all selected faders to zero, and transmits this data.

Recording and Playback of Fader Movements
Recording Fader Movements
You don’t need any special cabling to record the data generated by a fader. All data 
generated by faders is recorded on the selected track when Logic is in record or record/
pause mode. The recorded events correspond to the out definitions of the faders.

Playing Back Fader Movements
Any fader will react to incoming events that match its In definition. The fader must, of 
course, be in the MIDI signal path. Typically, you accomplish this by cabling the track 
instrument into the fader. For automated mixing tasks, it is useful to create a new 
(standard) instrument for the sole purpose of fader automation. Ensure that the 
instrument (which might be named “playback”) has no direct MIDI output, that its 
channel setting is All, and that it is connected to the first fader in any chain of serially-
cabled faders.
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Fader Styles
The fader’s style is shown in the line under the icon. It can be changed by clicking on 
the current style name, and selecting the new style from the pop-up menu.

Remember that a fader’s style does not usually affect its function—you can select the 
most convenient style for the desired use of the Object.

The following section provides notes on some of the fader styles:

Vertical/Mute
This is exactly like the Vertical 4 fader style, with an added mute switch. When you 
press the mute switch, the fader sends an event matching its Out definition with a 
value of 0. The fader’s movements are not sent while the mute switch is on (down). The 
current fader value is sent when you turn the mute switch off (up). 

Numerical
You can double-click the numerical field of a numerical fader, and type in a new value. 
If you click and drag slowly on the numerical field, fader values will change in single 
step increments.

Buttons
Button style faders send only two possible values, corresponding to the minimum and 
maximum values of their range. When on (hollow or Xed in the illustration), the 
maximum value is sent. When off (filled or not Xed in the illustration) the minimum 
value is sent. If the minimum and maximum range parameters are set to the same 
value, the button sends this value each time it is clicked. 
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Text
Text faders function like Numerical faders, but can display text for each of the 128 
possible MIDI values (0 to 127). Double-clicking on the surface of a text fader opens the 
text fader window.

Clicking on a position in this window will cause the corresponding fader value to be 
sent. (This is similar to selecting programs by name in the multi-instrument window). 
Double-click on a position in this window to type in the desired text. By default (when 
you create a text style fader), the text positions contain numerical values. You can use 
this feature to create numerical style faders with colored backgrounds.

Clipboard Functions
The pull-down menu located at the top right of the text fader window provides cut, 
copy, and paste Clipboard functions. You can use these facilities to transfer the entire 
list of names to a text editor, for more convenient editing. Note that empty lines (and 
lines that only contain spaces) are ignored. If you want to insert blank positions in the 
list, use Option–Space bar.

Behave as Menu
Check the Behave as menu box to make the text fader act like a pull-down menu. When 
this box is unchecked, the text fader acts like a scrolling menu.

Text Fader Range
A text fader only allows the entry of as many names defined by its range. To clarify, if 
you set a text style fader’s range to 0, 1 you can only enter two values. You should 
always set the minimum necessary range for a text fader, as this saves memory. In any 
case, remember that the first name corresponds to the lowest value in the range (not 
necessarily 0) and the last name corresponds to the highest value (not necessarily 127).

If you force a text fader to a value outside its range (with MIDI input) it will display “---” 
for values below its range and “+++” for values above. The one exception is when the 
fader’s range is 0, 1 in which case all values above 1 will display the name for value 1.
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Fader Functions:  MIDI Events
Each fader has an In and an Out definition. The In definition determines the types of 
MIDI events that can remote control the fader (the event types it reacts to). The Out 
definition determines the types of MIDI events the fader sends out. (A fader can, 
therefore, convert one type of MIDI event to another).

Most MIDI events consist of three bytes. The first byte indicates the type and channel of 
the MIDI event (a note on channel 3, for example). The second byte indicates the first 
data value (the pitch of a note event, for example) and the third byte indicates the 
second data value (the velocity of a note event, for example). A few MIDI events only 
use two bytes (program change and aftertouch). Some, such as faders (and 
transformers) always provide for 3 bytes, with the second byte being discarded for 
these special, 2-byte messages. 

Fader parameters are provided for setting the message type, MIDI channel and the first 
data value. Note that the message type and MIDI channel are actually combined in the 
resulting MIDI event. The second data value is determined by the fader setting, or in 
the case of remote control, by the incoming MIDI event.

Here are the In and Out definition parameters:

Out (or In):  defines the event type (use the pull-down menu shown in the diagram).

Channel (1 to 16):  defines the MIDI channel of the event.

-1- (0 to 127):  defines the first data byte of the event. In some cases, such as pitch bend, 
this is an actual data value. In other cases (MIDI controllers), this indicates the controller 
type (volume, pan, and so on, as examples). In other cases, such as aftertouch, this byte 
is unused.

Here is the meaning of the -1- parameter and fader position for each of the In and Out 
definition choices:
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Note On
The -1- parameter sets the pitch, and the fader position sets the velocity. This is most 
useful as an In definition—for trapping specific notes and converting them to other 
MIDI events, or simply monitoring their velocity. If you move a fader with an Out 
definition set to Note On, a note-off MIDI event will immediately follow the note-on. 
This might be useful for creating onscreen drum pads from button style faders, for 
example. 

P-Press
The -1- parameter sets the pitch, and the fader position sets the amount of Poly 
Pressure (key pressure or polyphonic aftertouch). 

Control
The -1- parameter sets the MIDI controller number (the controller type), and the fader 
position sets the controller value. The controller type can actually be selected by name, 
via the pull-down menu that appears when you click-hold on the -1- parameter.

Program Change
The -1- parameter is ignored. (In earlier versions of Logic, this sets the program bank.) 
The fader position determines the program number.

C-Press
The -1- parameter is ignored. The fader position sets the channel pressure 
(monophonic aftertouch) amount.

PitchBd
The -1- parameter sets the pitch bend LSB, and the fader position sets the MSB. 
Typically, you would set the -1- parameter to 0, and use the fader to control the “coarse” 
pitch bend amount. A -1- setting of 0, and a fader position of 64 results in no pitch 
bend.

Fader Functions:  Range, Val as
Range
The range parameter contains two numbers—the left one sets the lowest possible 
fader value, and the right one sets the highest. Note that these limits can be exceeded 
by MIDI remote control. When the fader style is a button, the range determines the in 
and out position values of the button. 

For text style faders, the first name always corresponds to the low end of the range, 
and subsequent names correspond to incremental range values, up to the top range. 
The number of names that can be entered into the window is limited by the range.

Val as
This parameter determines the way that numerical values are displayed by the fader:
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Num
The fader value is displayed directly as a number (0 to 127).

Pan
Fader value 64 is displayed as “0”; smaller values appear as negative numbers and larger 
values as positive numbers (−64 to 63).

Hz, Oct, dB, ms 
These display formats are tailored to various DSP functions.

bpm
An offset of 50 is added to the fader value. This displays the correct tempo settings for 
the special tempo control fader.

If none of the above formats is suitable, consider using a text style fader, and entering 
the desired display values as text. Examples include percentages, note names and 
program names.

Fader Functions:  Filter
This parameter provides various filter options for MIDI events:

off
All incoming MIDI events are allowed to pass through. All events that match the input 
definition are converted, in accordance with the output definition.

Other
All MIDI events that do not correspond to the input definition are filtered. All events 
that match the input definition are converted in accordance with the output definition, 
and allowed to pass through.

Match
All MIDI events that match the input definition are filtered, all others are allowed to 
pass.

All
All incoming MIDI events are filtered.

Thru
All MIDI events coming from the physical input Object are filtered. This is the same as 
turning off all events coming from Logic (from Regions or the Environment).

Use this filter mode to prevent MIDI feedback, by blocking incoming MIDI events from 
being sent back out.

Shot
When the fader is moved with the mouse, only the final value (the value when the 
mouse button is released) is sent.
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14 Bit
Used in conjunction with pitch bend, this allows 2-byte (fine tuning) pitch bend events. 
Used with controller messages, this causes the fader to send two MIDI controller 
messages—one for the MSB and one for the LSB.

For the 14 Bit setting to work, the fader’s In and Out definitions must be the same. For 
controllers, the MSB uses the In definition controller number, and the LSB uses the 
controller number 32 higher. This conforms to the MIDI standard for sending 14-bit 
controller data.

Note that with this filter setting, the fader’s range maximum can be set to 16,383, and a 
fader value of 8192 represents no pitch bend.

Feedback
When the Feedback parameter is unchecked, the fader will automatically prevent 
feedback loops resulting from circular cabling (the fader remembers when a specific 
MIDI event has passed through it and will not allow it to pass through again). Checking 
the Feedback checkbox will allow this.

Environment Exchange
One of the main reasons for the Environment is to customize Logic to your MIDI studio. 
As each Logic song has its own Environment, you may occasionally need to move 
Environment patches from one song to another.

Whenever you want to exchange Environments between songs, there is a source song 
containing the desired Environment and a destination song with an Environment that 
you want to change. The destination Environment must be the song in memory (the 
song that is currently open). The source song will be a file on your hard drive (or any 
other media such as a CD, Zip, and so on). Logic will present an Open dialog, allowing 
you to select the source song when importing an Environment.

The Environment Objects you wish to import should be contained on a single 
Environment layer, especially if you are importing a complete Environment patch—
several Objects that are cabled to each another. If these Objects are not on one layer, 
you should first open the source song and rearrange the Environment patch by moving 
all desired Objects to the same layer.

To import an Environment layer, select Options > Import Environment > Layer, select the 
source song in the resulting file selector box, and then choose the desired layer in the 
dialog that appears. This layer, and all of its Objects will be inserted in the destination 
song, at the same layer position (the same place on the Layer’s pop-up menu) that it 
occupied in the source song. Note that this inserts a new layer into the destination 
song—its original layers will be shifted as needed. This process can also be repeated, to 
import other layers from the same source song.
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6
6 Logic’s Mixing Facilities 
Logic provides you with different Mixer windows, 
designed to make mixing a painless and intuitive process.

Logic’s two major Mixer windows—the Audio Mixer and the Track Mixer—are the topic 
of this chapter. We will first have a close look at the specific characteristics of the Audio 
Mixer. Before we move on to the Track Mixer, we will provide you with detailed 
information on Audio Objects, which are the building blocks of the Audio and Track 
Mixers. Finally, you’ll get in touch with all of the Track Mixer’s special features. We’ll also 
have a look at MIDI channel strips, which are displayed right alongside audio tracks in 
the Track Mixer. 

If you compare both Mixer windows, you can see that they look quite similar. There are, 
however, some differences in the Parameters area:  The Audio Mixer is a layer of the 
Environment and therefore offers not only the Layers menu, but also the appropriate 
Object Parameter box. In the Parameters area of the Track Mixer, you can see several 
Filter buttons, labeled Global, MIDI, Input, Track, Inst, Aux, Bus, and Output. These Filter 
buttons make the Track Mixer a very convenient tool for mixing, as they allow you to 
limit the display to the tracks you’re interested in. 

Another obvious difference between the two Mixer windows is that the Audio Mixer 
consists solely of Audio Objects; you will not find any MIDI channel strips in it. The Track 
Mixer displays MIDI tracks beside audio tracks, allowing you to mix all song tracks in 
one window. 
     191
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Audio Mixer
The Audio Mixer is one of the Environment layers in the default song (the template 
loaded by Logic after launching). To open it, select Audio > Audio Mixer, or go to the 
Environment (Windows > Environment or Command-8), and choose Audio from the 
Layer menu.

Note:  If you press Option while opening a Mixer window, the Mixers will appear as float 
windows.

The specification and size of the Audio Mixer depends on the hardware used; it 
configures itself when you start Logic, or create a new song. The Environment’s Audio 
Object is the “building block” of the Audio Mixer. All Audio Objects used in your current 
song are shown in the Audio Mixer. If plug-ins and auxiliary sends are included, the size 
of the Mixer increases automatically. 

Setting Up Your Audio Mixer
The Audio Mixer provides you with various functions that allow you to build your 
virtual Audio Mixer with all required components. The following Audio Object types 
can be used for this purpose:
• Track—Recording and Playback
• Input—Controls the Input Signal
• Instrument—Virtual Software Instruments
• Output—Controls the Output Signal
• Bus—Routing and Effects
• Aux—Auxiliary Object

To create an Audio Object:
1 Select New > Audio Object in the Environment’s local menu. 

2 Double-click the newly-created Audio Object icon, to make the channel strip appear. 

3 Now go to the Audio Object’s Parameter box, and set its Channel parameter to the 
desired Audio Object type. 

To delete an Audio Object:
1 Select the Audio Object by clicking on its upper edge, or on its name. 

2 Press Backspace. This sets the level of the track controlled by this Object to zero. If a 
duplicate of the Object being erased exists, it will remain in place, and its level will not 
be set to zero.
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Connections
The signal within the various Audio Objects requires no cabling, or any kind of manual 
connection. The signal is routed via the corresponding slots in the Audio Object. As an 
example:  the Send slots connect a Track or Instrument Object to the Bus Object; the 
Output slot connects the various Objects to an Output Object. Logic’s virtual audio 
mixer resembles the routing and connection options of traditional mixing consoles.

Object Parameter Box
If the Parameter column is visible (select View > Parameters if it’s not), a box will display 
the parameters of the selected Audio Object. Clicking on the triangle at the top of this 
box (next to the name) conceals/reveals its contents. 

The name in the uppermost line of this box can be changed by clicking on it. This will 
also change the name displayed below the Object itself, and in the Arrange window (if 
no Track Name is specified). The check box to the left of the icon indicates whether or 
not the Audio Object will appear in the instrument selection menu of the Arrange 
window track list. You can change the icon via a pull-down menu if you wish, although 
the default icon is usually suitable.

Device
The Device parameter selects the hard disk recording system that the Audio Object is 
connected to. The default setting will be for the hard disk recording hardware installed 
on your system; entries referring to hardware not connected to your system are “grayed 
out” (see “Audio Drivers” on page 271).

Channel
The Channel parameter determines the type and channel of the signal controlled by an 
Audio Object.

The various options are:
• Track (see “Track Object” on page 211)
• Input (see “Input Object” on page 212)
• Instrument (see “Audio Instrument Object” on page 213)
• Bus (see “Bus Objects” on page 216)
• Output (see “Output Objects” on page 215)
• Aux (see “Auxiliary Object” on page 217) 

Note:  Stereo Inputs and Outputs are available as separate menu items.
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When you select Audio Object types, you’ll notice the following text styles are used:
• Outline:  This indicates that the Object is not available. This happens when a song 

was produced on a system with more tracks than yours (track 9 on an 8-track system, 
for example).

• Normal:  This is used for Objects that haven’t been defined in the Environment, and 
are therefore not in use.

• Bold:  Objects in bold have been defined in the Environment, and are in use.
• “*”:  The Object is unavailable as it already exists in its stereo form.

MIDI Channel
The MIDI Channel parameter determines the MIDI channel that the Audio Object will 
respond to. You can control the Audio Object remotely, using MIDI controller 
information.

This also works the other way around. Once a MIDI channel number is set, you can 
generate controller information on this MIDI channel, by moving the sliders and knobs 
of the Audio Object itself.

When the Channel parameter is set, the MIDI channel is automatically set to the same 
number, as this usually makes things easier to remember. For channels above 16, 16 is 
subtracted from the track number, so that a Channel setting of 17 will default to MIDI 
channel 1, Channel 18 to MIDI channel 2, and so forth.

Audio Objects in the Audio and Track Mixer
Audio Objects are the building blocks of the Audio Mixer, and an important part of the 
Track Mixer. In the following section, you will learn about the differences between 
Audio Object types and how you can use them. 

Multiple Selection of Audio Objects
Logic allows multiple Audio Object faders to be selected (by Shift-clicking) in the Track 
Mixer and Audio Mixer. The class (Instrument, Audio, Bus, Aux, and so on) of the 
channel doesn’t matter.

To deselect multiple channels, click on any unselected channel. You can also select a 
previously unselected track in the Arrange window.

Once selected, all channels behave as a temporary “group”, allowing you to quickly 
adjust a number of settings on all selected faders by performing an operation on one 
of the grouped faders. To adjust the listed parameters on all selected channels, follow 
these instructions:
• Volume:  Simply drag the Volume slider on any selected channel. All volume changes 

are relative and logarithmic.
• Pan:  Drag the Pan knob on any selected channel. All pan changes are relative.
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• Mute:  Click the Mute button on any selected channel. The Mute buttons of all 
selected channels will switch to the new mode.

• Solo:  Click the Solo button on any selected channel. The Solo buttons of all selected 
channels will switch to the new mode.

• Record Enable:  Click the Record enable button on any selected channel. The Record 
Enable buttons of all selected channels will switch to the new mode (note that only 
channels with different input sources can be record enabled simultaneously).

• Send Level:  Drag the Send level knob on any selected channel. All Send level knobs 
of the corresponding Send slots change accordingly (relative changes).

• Send Destination:  Click-hold on any of the selected channel’s Send slot(s), and make 
your selection from the list. The corresponding Send slots of all selected channels will 
be routed to the chosen destination.

• Inserts:  Click-hold on any of the selected channel’s Insert slot(s), and make your 
selection from the list. The selected effect will be inserted into the corresponding 
Insert slot on all selected channels.

• Input:  Click-hold on any selected channel’s Input slot, and make your selection from 
the list. All selected channels will receive their signal from the chosen input(s).

• Output:  Click-hold on any selected channel’s Output slot, and make your selection 
from the list. All selected channels will be routed to the chosen output (pair).

• Automation Mode:  Click-hold any selected channel’s Automation mode pop-up 
menu, and make your selection from the list. All selected channels will be switched 
to the chosen Automation mode.

• Group Assignment:  Click-hold any selected channel’s Group display, and make your 
selection from the list. All selected channels will be assigned to the chosen Group.

Important:  You can only perform the multi-channel Send and Insert options if no active 
Send or Insert is in the same slot on any selected channel. In other words, ensure that 
all selected channels have an unused Send 3, or Insert slot 4, for example, before using 
this facility.

Note:  Clicking a fader or knob while holding Option resets the value to a neutral 
value:  Option-clicking a volume fader sets it to 0 dB (90, if the Value As menu in the 
Object Parameter box is set to the Num option), Option-clicking a pan pot sets it to the 
center position, Option-clicking a send pot sets it to 0 dB (90).
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Elements of the Audio Object
Here is an overview of all Audio Object elements. The list shows what elements are 
available in the different types of Audio Objects.

Channel EQ
The Channel EQ is inserted into the first available Insert slot by double-clicking the EQ 
area on the upper portion of mixer channel strips. This area will change to a thumbnail 
view of the Channel EQ display. The thumbnails provide an overview of the EQ settings 
used in each individual channel.

Option–double-clicking will insert the EQ as the first plug-in, and move all existing 
plug-ins of this channel one slot down (and redirecting their automation data 
accordingly, if necessary).

Alternately, you can insert the Channel EQ in any desired slot as per other plug-ins. 
You’ll find it in the EQ section of the plug-in list. This is the only way to insert multiple 
Channel EQs. It should be noted that only the first (topmost) Channel EQ can be 
displayed as a thumbnail.

Element Audio Object

Channel EQ Track, Instrument, Input, Bus, Aux, Output

Inserts Track, Instrument, Output, Bus, Aux

Sends Track, Input, Instrument, Aux

Input Track, Instrument, Aux

Output Track, Instrument, Bus, Aux

Automation Track, Input, Instrument, Output, Bus, Aux

Pan/Balance Control Track, Instrument, Output, Bus, Aux

Levelmeter Track, Instrument, Output, Bus, Aux

Headroom/Clip Indicator Track, Instrument, Output, Bus, Aux

Volume Control Track, Instrument, Output, Bus, Master, Aux

Mute Track, Instrument, Output, Bus, Aux

Solo Track, Instrument, Aux, Bus

Mono-Stereo Track, Output, Aux, Bus

Track Arm Track

Bounce Output
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More information about the parameters of the Channel EQ can be found in the Logic 
Pro 7 Plug-In Reference. 

Inserts
If you have enough processing capacity, you can use up to 4 Inserts per Audio Object. 
An extra blank Insert is created, as soon as all of the currently displayed insert slots are 
used, up to the maximum allowed.

The Insert pull-down menu displays all available Logic plug-ins, as well as all correctly 
installed Audio Units plug-ins.

Note:  Shift–double-clicking on a used (active) Insert slot will open the Plug-in window 
as a non-float window. Clicking on the minimize button at the top left of the window 
will place the Plug-in window on the Dock. It can be restored by clicking on the Dock 
icon.

Channel Strip Settings Menu
If you click on the word Insert on any channel strip, the Channel Strip Settings menu 
opens. This menu allows you to load and save the entire routing configuration of a 
single channel strip, including all loaded plug-ins and settings.

The ability to save an entire routing configuration can be used in a number of ways, 
such as:
• Setting up and storing complex multi-effect configurations—on any type of channel.
• Similarly, the configuration of a particular routing configuration for use with multi-

output software instruments.
• Copying a routing or effect configuration between Projects.
• The rapid creation of new Templates.

The Channel Strip menu offers the following items:
• Next/Previous Channel Strip Setting:  Loads the next or previous Channel Strip 

setting in the list.
• Copy/Paste Channel Strip Setting:  Allows to you to copy and paste Channel Strip 

settings between channels or projects.
• Save Channel Strip Setting as:  Saves the Channel Strip setting, and allows you to 

name it.
• Once you have created one or more Channel Strip settings, a list of settings will be 

shown below the menu functions. The active Channel Strip setting is denoted by a 
bullet.
Chapter 6    Logic’s Mixing Facilities 197



198

 

As there are obviously different classes of Audio Objects, a number of sub-folders 
(Audio, Instrument, Aux, and so on) are automatically created in the /Applications/
Logic/Channel Strip Settings folder when you first save a Channel Strip setting. Channel 
Strip settings are identified by the “cst” file extension.

Important:  Please do not attempt to change the Channel Strip Settings folder 
structure.

Note:  Further information about Inserts and the use of plug-ins can be found in the 
first part of the Plug-In Reference.

Sends
The Sends allow you to send a portion of the Audio Object signal into an internal Bus 
or Auxiliary Object. The Sends connect the Track Object with a Bus Object or Auxiliary 
Object. No cabling is required for this or any other connection within the Audio Mixer.

Note:  The Send routing options available vary, depending on the hardware you are 
using. 

To create a Send:
1 Click on an empty Send slot and select one of the possible send destinations, using the 

pull-down menu that appears. 

2 When you have selected the Send destination, you can regulate the amount of signal 
supplied by using the Send Amount control knob. As you are adjusting the level, the 
relevant value appears in the Send slot. You may assign up to 8 sends per track. 

To remove a Send:
m Open the pull-down menu of an active Send slot, and select No Send.

To normalize the Send level:
m You can reset a Send to 0 dB (90) by Option-clicking on its Send Amount knob.

To bypass a Send:
m You can switch a Send to Bypass mode by Option-clicking on its Send slot. If a Send is 

active, its name will be blue. If a Send is switched off, its name is gray (bypass mode).
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Post and Pre Fader Aux Sends
Sends in analog mixers are positioned either before (“pre”) or after (“post”) the fader. To 
select one of these options in Logic, click-hold the Send slot. The Bus menu opens, and 
you may select either Post or Pre at the top of the list.

A post fader signal level, routed to the Send, changes along with volume fader 
movements. If you are using the Send to route a signal from the channel to a reverb, 
this means that the relationship between the original signal and the effect signal 
remains constant. When you pull the channel’s volume fader all the way down, the 
reverb disappears as well. This setting is generally the most useful, and is the default in 
Logic.

If a Send is set to be pre fader, the level of the signal routed to the Send remains 
constant, regardless of any volume fader movements on the source channel. The signal 
is still fed to the selected bus—even if the channel’s volume fader is completely pulled 
down. Pre fader sends are mainly used for monitoring tasks; headphone monitoring in 
the studio, or foldback monitoring on stage. Pre fader sends are also useful when you 
want to hear the effect signal in isolation (without the original signal). The equalizer still 
affects the sends in “pre fader” mode (pre fader, post EQ).

Stereo Sends
Logic allows you to assign the sends of mono tracks to stereo busses (or stereo 
outputs). It’s unnecessary to assign two sends to address a true stereo reverb plug-in.

Double-Click on Send
Double-clicking on a Send slot of any audio channel will “jump” to the allocated Bus 
channel fader, making navigation easier in the Mixer windows. 

In/Output
Input Selection
The Input field allows you to select the desired audio input of your audio hardware. 
This input (or input pair) supplies an audio signal to the track when recording. If 
Monitoring is switched on, the signal of this audio input will be routed to the output 
(or bus) selected in the Output field, when the track is record enabled. The number of 
available inputs is determined by the audio hardware in use.

Note:  The Input slot is used for the insertion of software instruments on Audio 
Instrument Objects, and is known as the “Instrument Slot” on these channels. Further 
information can be found in the first section of the Plug-In Reference manual. 
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Output Routing
The slot directly below the Input slot determines where the signal of the Audio Object 
(mixer channel) will be sent. The number of outputs that are available is determined by 
the audio hardware in use.

Hold Option while selecting the inputs or outputs of a single channel to change all 
selected Audio Objects simultaneously. (See also “Multiple Selection of Audio Objects” 
on page 194.) Please note that inputs are only changed on (selected) Audio Objects of 
the same status:  mono or stereo. This facility allows you to easily select a single input 
for all audio tracks.

Double-click on Output slot
Double-clicking on the Output slot on any audio channel will “jump” to the allocated 
Output channel fader, accelerating navigation in the Mixers. 

Pan/Balance
Mono Objects feature a Pan control, which determines the position of a signal in the 
stereo image.

Stereo Objects, on the other hand, possess Balance controls. The Balance control differs 
from the Pan control in that the former controls the relative levels of two signals (L/R) 
at their outputs. The latter merely apportions one signal between two outputs.

Note:  You can reset the Pan control to it’s centered (0) position with an Option-click.

Level
Audio Objects feature level meters that display the playback or input monitor level.

When you arm a track, in preparation for recording, the meter displays the input level.
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The playback level is also displayed to the left of the track number in the Arrange 
window, if View > Track Numbers/Level Meters is selected. 

Peak Hold
As with conventional mixing desk meters, peak values are “held” on the display for a 
few seconds, making them easier to read. The most recent maximum level is always 
reliably displayed, even if your CPU power is insufficient for a smooth real time display 
of levels.

Clip Detector
The clip detector above the level meter shows you the headroom of a track in dB.

When a signal clips, the clip detector will turn red; the value indicates the amount that 
the signal needs to be reduced, in order to prevent clipping.

Up to + 6 dB will be shown. If a track clips now and then, it doesn’t really matter—as 
long as the master doesn’t clip. Clicking on any clip detector will reset all clip detectors. 
The Clear Overload Flag in Audio Channel Display key command has the same effect.

Pre Fader Metering
Activation of Audio > Pre-Fader Metering ensures that the level displayed by the level 
meters is measured pre fader (pre pan/balance), but post Equalizer and inserts. This 
guarantees the display of track levels, even if the fader is dragged all the way down.

Adjusting the Level
The fader on each Track Object sets its playback level. The recording level is not set in 
Logic. It is set at the source (the device supplying the input signal). You cannot adjust 
the level on the digital input. Logic’s fader is only used to control the monitoring level.

The level meter of the Audio Objects and aux sends can be shown in decibels (dB) 
(default), or MIDI controller values. To change the scale, select the appropriate Object, 
and alter the “Val as” parameter. A MIDI volume of 90 is equivalent to 0 dB.

The maximum boost is + 6 dB. You can reset the volume fader to 0 dB (90) by Option-
clicking on it.
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When multiple Audio Objects are selected, changing their level by moving one fader is 
dB-proportional. The mixing ratio of the selected channels remains constant.

An independent monitoring level is available when a Track Object is record enabled. 
After arming the track, set the fader to the desired level. The original level will be 
restored when the Object is disarmed. The global Toggle (Mute) Audio Tracks key 
command switches the levels of all Audio Objects between two different values. Each 
Object may be set to any value for both toggle positions, allowing you to quickly 
switch between two basic mixes.

You can switch other Object types in the same way, using the global Toggle (Mute) 
Audio Inputs, Toggle (Mute) Audio Bus and Toggle (Mute) Audio Outputs key commands.

Solo/Mute
Solo
All Audio Objects have a Solo button. This mutes all other Audio Objects.

Muted Objects are indicated by a flashing M in the Mute button. Please note that this 
does not mute MIDI tracks.

You can also solo several Objects at once.

Option-clicking a previously unsoloed Object releases other active Solo buttons, 
allowing the selected channel to be heard in isolation (“Interlocking Solo” or “Solo 
Toggle”).

Option-clicking any activated Solo button disables the solo status of all Audio Objects.

Solo Safe
If you want to hear the signal of a soloed channel with any bussed effects, the effect 
return channels obviously shouldn’t be muted. Unlike conventional mixing desks, Logic 
can scan the entire signal path, and leave the effect return channels open.

The same applies when you solo an effect return signal. The channels fed into the 
effect are muted, but their effect sends remain open, ensuring that the effect continues 
to receive a signal.

This automatic mute-suppression only applies to the internal effect returns. If you are 
using external effect units via Bus Objects, the scan will keep the effect master sends 
open. Logic cannot, however, know which of the Input Objects you are using as effect 
returns for external effect units. You need to manually switch these Input Objects to 
“solo safe”—just like on a conventional mixing desk.
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Control-clicking an inactive solo switch makes an Audio Object “solo safe”. This prevents 
it from being muted when you solo another channel. “Solo safe” status is indicated by 
an X on the solo button. A second Control-click defeats the solo safe status.

Mute Button
You can mute any Audio Object by pressing the button marked with an M. Pressing the 
button a second time restores the previous level.

Stereo Objects
All Audio Object types (Track, Input, and Output) may be configured as stereo. Logic 
uses true stereo tracks, provided that Preferences > Audio > Drivers > Universal Track 
Mode (UTM) is activated. This means that Track 2 is unaffected when you configure 
Track 1 as stereo. Audio Regions on the tracks of stereo Objects are always dealt with 
together, no matter what type of operation being performed. If you open the Sample 
Editor, both sides of the stereo pair are shown, and are processed together.

Creating Stereo Objects
To do this, select the desired Object (we’ll use the one named “Audio 1” as an 
example—click on its name, at the bottom). Click on the Mono symbol, at the bottom 
left of the Object, next to the REC button. 

The button will now show two interlinked circles, indicating that it’s a stereo Object. 

If you click-hold on this button, you will see a pop-up menu that offers four choices:

Mono:  Sets the track to play mono files.

Stereo:  Sets the track to play stereo files. These may be either “interleaved” or “split” 
stereo files.

Left:  If a stereo region is assigned to the track, only the left side will be played. If a 
mono file is assigned to the track, it will play normally. In either case, the output of the 
track will be mono.

Right:  If a stereo region is assigned to the track, only the right side will be played. If a 
mono file is assigned to the track, it will play normally. In either case, the output of the 
track will be mono.
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Any combination of stereo and mono recordings is permitted. As an example, you can 
set both tracks 1 and 2 to stereo, and use tracks 3 and 4 for mono recordings, if you 
wish.

Whatever parameters you adjust for stereo Objects, the changes affect both sides 
equally. The pan control becomes a balance control.

Track Arming
The Record Enable button (see below) “arms” a track, making it ready for recording. 
Once armed, the Record Enable button flashes red. It remains constantly lit during the 
actual recording.

If the control flashes between gray-red, this indicates that no audio track is selected in 
the Arrange window, and no recording can take place. Please select the corresponding 
Audio track in the Arrange.

Rec controls only exist for Track Objects. Please note that the number of Track Objects 
that can be simultaneously armed is limited to the number of tracks that your audio 
hardware can record to concurrently. This would typically be the number of inputs 
offered by the audio hardware.

You can select the input that the Track Object will record from, via the input selector 
slot, found in the I/O section of the Track Object. Click-holding on the slot will reveal a 
pull-down menu, showing all available inputs for your hardware. If the record track is 
stereo, the inputs will be displayed in pairs (Input 1–2, Input 3–4, and so on). They will 
be displayed individually for mono tracks. Arming a track set to a specific input will 
automatically disarm any other track that is currently using the same input.

Bounce
Output Objects feature Bounce buttons. Bounces for Output Objects 1 and 2 can also 
be initiated by choosing File > Bounce from any Logic window (although the Arrange 
would be the most appropriate).

The Bounce process allows you to create an audio file based on all audio Objects 
routed to the selected Output Object. All parameters, including volume, pan, and 
effects are recorded as part of the “bounced” file. Bouncing takes place in either 
realtime or faster than real time (“offline” bounce).

To create a bounce file:
1 Press the Bounce button on the Output Object or choose the File > Bounce menu 

option.
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2 Set the parameters in the Bounce dialog window (see below).

3 Press the Bounce button in the Bounce dialog window.

4 The ensuing file selector allows you to enter a destination folder and name for the 
bounced file.

Note:  Mono bouncing is possible when the Output Object is set to mono. In this 
situation, a mono audio file is generated.

Global Options in the Bounce Dialog Window
Several global options are available in the Bounce Dialog window, regardless of the file 
type(s) being bounced.

Destination
You can select between a PCM file (in SDII, AIFF, or Wave format) or MP3, AAC, and Burn 
CD (to a Red Book compliant Audio CD) options by simply clicking the desired radio 
buttons.

PCM, MP3, and AAC files can be individually bounced and added to the iTunes library if 
the Add to iTunes library checkbox is enabled in each sub-pane.

PCM files in SDII, AIFF, or Wave format—can be added to the Audio window if the Add 
to Audio window checkbox is enabled in the PCM sub-pane.

Start and End Position
These fields define the boundaries of the song segment that you want to write to the 
bounced file. The defaults for these fields is the whole song, from the beginning of the 
first Audio Region to the end of the last. Note that the defaults will be the locator 
positions, if the Cycle function is engaged. In any case, you can adjust the start and end 
positions manually. As an example, should you want to take into account a MIDI sound 
module (mixed via an Input Object) that falls outside the preset Region.

It’s often a good idea to set the End position of the bounce a little bit past the end of 
the last Region, ensuring that reverb tails and echoes from delay plug-ins are not 
chopped off. The amount of extra time needed will, of course, depend on the effect 
settings used.

As you adjust the Start and End position parameters, you are shown the hard disk 
space requirements for the bounced file above the Cancel and Bounce button.

Bounce Mode
• Realtime:  Creates the bounce file in real time. Use it whenever you wish to bounce 

audio and Audio Instrument tracks, plus external MIDI sound sources that are routed 
into the Logic Mixer via (Live) Input Objects.
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• Offline:  Accelerates the bounce process—depending on the complexity of your 
arrangement and available CPU processing power. It also allows the bouncing of 
complex arrangements that would normally exceed the power of your CPU, if trying 
to play them in real time. Offline bouncing, however, is limited to internal sources 
(audio or Audio Instrument tracks). The MIDI tracks and Input Objects of Logic’s Mixer 
are deactivated during offline bouncing.

Please note that the Offline Bounce mode is only available to the Output Objects of 
mixers that belong to native audio driver systems. DSP-based audio hardware can not 
make use of offline bouncing due to the nature of its stream-oriented technology. 
Other software applications that are fed into your Logic Mixer via ReWire technology 
are available for offline bounce processes.

PCM Options in the Bounce Dialog Window
File Format
You can select between a PCM file (in SDII, AIFF, or Wave format) or MP3, AAC, and burn 
to an Audio CD in one go.

PCM, MP3, and AAC files can be individually bounced and added to the iTunes library.

PCM files in SDII, AIFF, or Wave format can be added to the Audio window.

Resolution
This is where you define the resolution of the bounced file. The options are 16 Bit, 8 Bit 
(for multimedia productions) or 24 Bit (for mastering to DVD).

Sample Rate
This pull-down menu allows you to define the desired sample rate for your bounced 
audio file(s). Options range from 11,025 to 96,000 Hz, and include the three most 
commonly used sample rates:  44,100 (CD-DA), 48,000 (DAT) and 96,000 (DVD).

Stereo File Type
You can select between split stereo (for use in ProTools), or interleaved stereo (for 
further use in Logic or for CD writing software) here.

Setting Stereo File Type to Split Stereo disables Burn (following a warning message).

Dithering
Dithering  (see “Bouncing and POW-r Dithering” on page 70) is recommended when 
bouncing 24 bit recordings into 16 bit files.

“Add to” Options
The Add to Audio window option adds the bounced PCM file(s) to the Audio window

The Add to iTunes library option adds the bounced PCM file to the iTunes library. Note 
that iTunes does not support SDII. Should the file be in SDII format, this switch will be 
disabled.
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MP3 Options in the Bounce Dialog Window
Logic allows the bouncing of MP3 (MPEG-2-Layer-3) format files. This well-known data 
reduction format for digital audio signals was developed by the Fraunhofer Institute, 
and allows high compression rates while maintaining quite good audio quality 
(depending on the compression rate). MP3 is the current standard for audio file 
exchange via the Internet.

Due to the fact that encoding an MP3 file equates to a loss of audio quality, you should 
not use MP3 files during production if you have access to the same audio data in linear 
formats such as:  AIFF, WAV, or SDII.

Bounced PCM file(s) is/are also used for encoding to MP3/AAC or burning a CD. It 
should be noted that this occurs before dithering takes place. 

Note:  Should the selected sample rate be higher than 48 kHz, a temporary copy of the 
bounced PCM file is created—with an automatic sample rate conversion to 48 kHz 
before encoding. This conversion takes place because the MP3 format does not support 
sampling rates higher than 48 kHz.

If the PCM option is disabled in the Destination menu, a temporary PCM file is bounced 
as a source for encoding to MP3/AAC and/or burning to a CD—in accordance with the 
options selected in the PCM page.

Bit Rate (Mono/Stereo)
MP3 bit rates are selectable between 8 kbps and 320 kbps, but default to 80 kbps 
mono, and 160 kbps stereo. These rates offer acceptable quality and good file 
compression. If you can afford the extra file size, we recommend selecting 96 kbps for 
mono and 192 kbps for stereo streams, as this provides better audio quality. You can, of 
course, choose even higher rates, but the quality improvement afforded by bit rates 
above 96/192 kbps is nominal.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than passages 
that are (more) harmonically rich, generally resulting in better quality MP3s. 
Unfortunately, not all MP3 players can accurately decode VBR-encoded MP3s, which is 
why this option is turned off by default. If you know that your target listener/s can 
decode VBR-encoded MP3s, you can switch this option on.

Quality
Keep this set to Highest whenever possible. Reducing the quality accelerates the 
conversion process, but at the expense of audio quality.

Use Best Encoding
Again, like the Quality parameter, if you uncheck this option, you will gain encoding 
speed at the price of audio quality. This should always be kept on, unless conversion 
time is an issue.
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Filter Frequencies Below 10 Hz
When this option is checked, frequencies below 10 Hz (which are usually not 
reproduced by speakers, and are not audible to human ears at any rate) will be 
removed, leaving slightly more data bandwidth for the frequencies that we can hear, 
resulting in an improvement of the perceived “quality”. Only uncheck this if you’re 
experimenting with subsonic test tones, or exporting MP3s for whales!

Stereo Mode
You can select joint stereo or normal stereo mode. Depending on the original file, these 
settings may (or may not) offer any audible difference. Experiment with both settings 
to determine your preference.

Write ID 3 Tags/ID3 Settings

When the Write ID3 Tags option is enabled, ID3 tags are written to the file. These tags 
can be edited/configured in the dialog launched via a click on the ID3 Settings button. 
All entries are made by double-clicking on the desired Content field(s) to the right of 
the corresponding ID 3 Frame entry, and typing in your text.

Add to iTunes Library
The Add to iTunes library option adds the encoded MP3 file to the iTunes library.

AAC Format Options
The AAC options are not directly available in the Bounce Dialog window (due to a 
limitation in QuickTime), with the exception of the Add to iTunes library option which 
adds the encoded AAC file to the iTunes library. 

You first need to type in a file name, and press the Bounce button before you can 
access the AAC (Sound Settings and Options > MPEG-4 Audio Compressor) options.

Should the selected sample rate be higher than 48 kHz, a copy of the bounced PCM file 
is created—with an automatic sample rate conversion to 48 kHz before encoding. This 
conversion takes place because the AAC format does not support sampling rates 
higher than 48 kHz.
Chapter 6    Logic’s Mixing Facilities



 

AAC Sound Settings
Compressor
Selects the compression algorithm used for AAC encoding. By default, this is MPEG-4 
Audio.

Rate
A number of predefined sample rates are available in this pop-up menu, ranging from 
8000 kHz to 48,000 kHz.

Size
These radio buttons allow you to select either an 8 or 16 bit output file.

Use
These radio buttons allow you to select either a mono or stereo output file.

Options
The Options switch launches the MPEG-4 Audio Compressor window, discussed below.

MPEG-4 Audio Compressor Window

Compressor
Selects the compression encoder. By default, this is AAC (Low Complexity).

Bit Rate
A number of predefined bit rates are available in this pop-up menu, ranging from 16 
kbits/second to 320 kbits/second.

Output Sample Rate
A number of predefined sample rates are available in this pop-up menu, ranging from 
8000 kHz to 48,000 kHz. The Recommended option selects a default option, based on 
other encoder choices you have made.

Encoder Quality
Keep this set to Best whenever possible. Reducing the quality will speed up the 
conversion process, but at the expense of audio quality.
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Burn Options
Logic can directly burn Red Book audio to blank CDs.

Should the selected sample rate be higher than 44.1 kHz, a copy of the bounced PCM 
file is created—with an automatic sample rate conversion to 44.1 kHz before encoding. 
This conversion takes place because the CD Audio format (Red Book) does not support 
sampling rates higher than 48 kHz.

Note:  Should your system contain multiple CD burners, the first one detected is used.

Important:  Some of the options listed below will only become active when blank CD 
media is physically placed in the CD recording mechanism.

Simulate write only
The Simulate write only option requires that a blank CD be inserted into the SuperDrive 
or ComboDrive. As the name suggests, this will simulate a CD burn, but will write no 
data to the blank media. This can be used either alone, or in conjunction with, the Write 
as multi session option.

Write as multi session
The Write as multi session option allows you to add a data session to the same CD at a 
later date—to add the Project folder, for example.

Speed
The first time you use the Speed pull-down menu, a request is made to the CD burning 
mechanism, which may take a while. Once the scan is complete, you may freely select 
from the available speeds.

Dithering
Use of the Dithering parameter is recommended when bouncing 24 bit recordings into 
16 bit files.

Burn
Clicking the Burn button initiates the Bounce and burns the audio to CD.

Note:  Following confirmation of the file location(s), you may encounter further dialogs 
that will ask if you want to overwrite existing files. Use these as required.
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Audio Object Types
The following section introduces you to Logic’s different Audio Object types.

Track Object
The Track Object is used for playing back and recording audio signals in the Arrange 
window. You also control the signal of recorded tracks via the different elements of the 
Track Object.

The number of tracks available depends on the CPU power of your computer. 

You can limit the number of tracks via the Audio > Audio Driver > Max. Number of Audio 
tracks setting for thedriver/hardware, thereby limiting the amount of memory and 
processing power required.

The Track Object features the following elements (see “Elements of the Audio Object” 
on page 196):  EQs, Inserts, Bus Sends, Input/Output, Automation, Pan, Level, and Level 
meter, Mute/Solo, Mono/Stereo, Track Arming.

Monitoring With Effect Plug-ins
Record-enabled (armed) audio tracks—with assigned audio inputs—can be monitored 
with effects plug-ins inserted into the armed audio channel. In this type of setup, the 
effect plug-ins are monitored but not recorded. This can be useful during an overdub 
session, for example. If you’d like to record the audio track with effects, insert the effect 
plug-ins into the corresponding input channel (see below), rather than the audio track 
channel. 

Example:  During vocal recording, many artists prefer to monitor their performance 
with a little reverb, while the track is actually recorded dry. To do so, insert a reverb 
plug-in into the audio channel, arm the track and start recording. The reverb will be 
part of the monitor mix, but will not be recorded. 
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It is possible to combine pre-processing and monitoring with effects. You can, for 
example, destructively record a signal with compression by inserting a compressor into 
the respective input channel, while simultaneously monitoring the compressed input 
signal with a reverb (inserted on the track channel) that is not recorded.

The Audio > Audio Hardware & Drivers > Software Monitoring preference must be 
enabled if you wish to monitor/record with effects.

Input Object
The Input Object allows you to directly route and control signals from your audio 
hardware’s input. Once an Audio Input Object is assigned to an audio channel, it can be 
monitored and recorded directly into Logic, along with its effect plug-ins.

The signal is processed—inclusive of plug-inseven while Logic is stopped. In other 
words:  Input Objects behave just like external hardware processors. Bus sends can be 
used pre or post-fader.

The Audio Input Objects can effectively replace your old mixing desk, or at least save 
time while bouncing:

Audio Input Objects make the bouncing procedure much easier, as there’s no longer 
any need to record the audio signal of your MIDI devices before bouncing (mixing 
down) their output with the audio recordings. The live Audio Input Objects allow you 
to mix down the audio signal from your external hardware MIDI synthesizers and 
sound modules into a stereo mix (by bouncing an Output Object).

The Input Object features the following elements:  Inserts, Bus Sends, Output, 
Grouping, Automation, Pan, Level, and Level meter, Mute/Solo, Mono/Stereo.

Pre-Processing of Input Signals
Audio Input channels now process an incoming audio signal destructively:  The input 
signal is processed by plug-ins inserted into the input channel. This means that once an 
Audio Input Object is assigned to an audio track, it can be recorded, and monitored, 
with its effect plug-ins.

Example:  To avoid large jumps in level, it is often useful to record a vocal track with 
light compression. To do so; insert a compressor plug-in into the input channel and 
assign the Input Object as the input source of an audio track. During recording, the 
effect of the compressor is recorded with the track.

Note:  To use the Audio Input Object as a “live input”, ensure that the Input Object has 
an assigned Output. This allows monitoring of the Input Object (with all effects) 
directly, without the need to assign it to a record-enabled audio channel.
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Audio Instrument Object
The Instrument Object allows you to use virtual Software Instruments within Logic. 
Currently, the following are supported:  Logic’s own suite of software instruments and 
AU compatible instruments. Logic supports up to 64 discrete Audio Instrument 
channels, dependent on available CPU resources and system RAM. The advantage of 
the integration of sampling and synthesis within Logic is that all tools necessary for 
audio recording, sample playback and synthesis plus effects and mixing can occur 
within your computer.

The Input Slot of the instrument Object serves as an insert slot for the software 
instrument.

After inserting an instrument, the Audio Instrument Object can be used just like a MIDI 
track in the Arrange window. The Audio Instrument Object can also receive MIDI notes 
via Environment cables from other MIDI instrument Objects. This is useful for creating 
sound layers of hardware MIDI instruments and virtual instruments. 

Please note that the Preferences > MIDI > General > Use Unified Virtual and Classic MIDI 
Engine setting must be switched on to make use of these features.

When an Audio Instrument track is selected, it is ready to be played in real-time and 
consequently produces some system load. Normally, Logic releases system resources 
used by the Audio Engine when the sequencer is stopped. This is not true, however, if 
an Audio Instrument track is selected in the Arrange and is therefore available for real-
time playing. Selecting a MIDI track or a normal audio track exits this “stand by” mode 
and releases reserved system resources the next time the sequencer is stopped. 

Note:  Muting an Audio Instrument track in the Arrange does not reduce system load.
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The Audio Instrument Object features the following elements (see “Elements of the 
Audio Object” on page 196):  Inserts, Bus Sends, Input, Output, Automation, Pan, Level, 
and Level meter, Mute/Solo. 

Accessing Multiple Outputs
Logic supports the EXS24, UltraBeat, and AU-compatible instruments that are capable 
of addressing multiple outputs. In addition to the “Mono” and “Stereo” submenus of the 
Audio Instrument menu, a “Multi Channel” submenu lists all Instruments that offer 
multiple outputs. A plug-in needs to be inserted from the “Multi Channel” submenu, in 
order to access its individual outputs.

Please note that not all plug-ins (Logic and third-party) are multi-output capable. If the 
Instrument does not appear in the Multi Channel submenu, it is not equipped with 
multiple output facilities. Please make sure that the instrument you wish to use is 
properly installed and authorized.

The first two outputs of a multiple output instrument are always played back as a 
stereo pair by the Instrument channel that the plug-in is inserted into. Additional 
outputs (3 and 4, 5 and 6, and so on) are accessed via Auxiliary Objects (see “Auxiliary 
Object” on page 217).

Software Instrument Pitch
The Song Settings > Tuning > Software Instrument Pitch parameter remotely controls the 
main tuning parameter for all software instruments by ±50 Cents. Some instruments 
created by other manufacturers may not recognize this remote command.

ReWire
Logic supports the ReWire software interface from Propellerhead, a software 
manufacturer. ReWire is an interface between sequencer and audio applications. 
ReWire works with hardware supported by Logic’s native audio engine  (see “The Audio 
Hardware and Drivers Dialog” on page 271).

Please start Logic first, and then start your ReWire application(s). ReWire scans for 
ReWire-compatible applications or system extensions; Propellerhead’s Reason, for 
example.

Logic will display the audio returns of ReWire-connected applications as Audio 
Objects:  You’re able to insert plug-ins and create sends to busses on these returns, as 
per a normal audio track. 

In order to use the audio returns of ReWire-connected applications, select an Audio 
Object and choose the desired ReWire audio-return in the Channel pull-down menu of 
the Audio Object. You will find ReWire channels listed by name, along with the audio 
tracks, inputs, busses, and outputs in this menu. ReWire (or the application that the 
connection belongs to) generates the names for these channels. The name of a ReWire 
channel is irrelevant to Logic.
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As an example, if a channel is called “Mix”, it has no specific function related to that 
name as far as Logic is concerned. It’s up to you to decide what to do with whatever 
channel. If there is no Audio Object for a ReWire return created in the Environment, no 
audio is transferred between a ReWired application and Logic. How does this work in 
practice with ReBirth, for example? In this scenario, you will find two channels called 
“Mix L” and “Mix R” within Logic. The two Mix channels return the summed mix of 
ReBirth’s outputs. You will also find channels for every individual instrument. When 
creating an Audio Object for another channel such as the bass drum, for example, you 
will only hear the bass drum through that channel, and it is removed from the mix 
returns. 

Logic is always Synchronization master. As Logic is also the Cycle master, Skip Cycle 
works, too. 

The following functions are shared between the applications:
• start/stop,
• repositioning,
• cycle start and end,
• tempo change

Output Objects
Output Objects represent Logic’s audio outputs. This is where level and stereo balance 
are adjusted; mastering plug-ins can also be inserted here, such as multi-band 
compressors or the Fat EQ. The number of available Outputs is determined by the 
audio hardware in use.
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Output Objects also provide the Bounce (see “Bounce” on page 204) function, which 
can be used for either; recording all audio into one stereo audio file (comparable to a 
master tape), or to merge several tracks (including all plug-ins and so on) into one 
stereo or mono track (depending on whether the Output Object is set to mono or 
stereo).

The Output Object features the following elements (see “Elements of the Audio Object” 
on page 196):  Inserts, Automation, Pan, Level, and Level meter, Mute, Stereo/Mono, 
Bounce. 

Bus Objects
The Bus Objects can be used in several ways:

They can be used to route audio signals to external devices via the individual outputs 
of the audio hardware, allowing you to change their level and pan settings, and apply 
plug-ins, if you wish.

They can be used as subgroup channels, which control the level of several audio 
channels at once. As an example, all drum tracks or all different vocal takes could be 
routed to one stereo bus for control of their overall level—while still retaining the 
relative differences between the individual channels.

To record the signal of a particular subgroup (for later use as a stereo track in the 
arrangement), route it to an unused Output Object, and use the Bounce function (see 
“Bounce” on page 204).

The Bus Objects can be used as effect returns:  in this case the plug-ins serve as internal 
effect processors. 
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Effects such as reverb and delay are generally used as bus inserts. These Bus Objects 
are usually addressed with the send knobs of the audio channels, and act as effect 
returns. 

These busses are routed to an Output Object.

In the default song, the pre-set Bus Objects have been named “Returns”.

The Bus Object features the following elements (see “Elements of the Audio Object” on 
page 196):  Inserts, Automation, Pan, Level, and Level meter, Mute, Stereo/Mono.

Auxiliary Object
The native Aux Object can be either mono or stereo. Aux input sources will appear as 
either stereo pairs, or single mono channels, dependent on the mono/stereo status of 
the Aux channel. It is possible to use the same input source for several Aux channels. 
Aux channels process audio signals non-destructively, in real time. Two Aux channels 
are pre-configured in a new song, by default. As with all other Audio Objects, 
additional Aux Objects can be created, and accessed, via the Audio layer of the 
Environment. Aux Objects are automatically made available as needed, in the Cha pull-
down menu of the Object parameter box. When four Aux Objects are in use, a fifth is 
offered in the pull-down menu, when using six Auxes, a seventh is added and so on. 
This makes it possible to create up to 8 Aux channels in the Environment.

The input source of an Aux channel is selected with the input assignment pop-up 
menu. Possible input sources are:  All software instrument outputs provided by 
Instrument plug-ins (Logic or AU). These additional outputs are only available to plug-
ins inserted into an instrument channel via the “Multi Channel” sub menu. Aux channel 
Input sources—sent from suitable Instrument plug-ins—start from output 3.
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Aux channels can also be displayed in the Track Mixer. Note:  If the Aux channels are 
used as tracks in the Arrange window, ensure that the view filter of the Track Mixer is 
set to show Aux channels by activating the Aux button (track view). Activate the Aux 
and Global button (global view) if the Aux Objects are only used as Environment 
Objects (in other words, they’re not used as Arrange window tracks). 

The Aux Object features the following elements (see “Bus Objects” on 
page 216):  Inserts, Sends, Input, Output, Automation, Pan, Level, and Level meter, Mute, 
Stereo/Mono.

Aux Objects and Software Instruments With Multiple Outputs
By default, all outputs of a Multi Channel (see “Audio Instrument Object” on page 213) 
Instrument plug-in are routed to the main output pair of the respective Audio 
Instrument Object. Subsequent Multi Channel Instrument outputs are sent to Aux 
Objects.

Track Mixer
To open, select Windows > Track Mixer.

Note:  If you press Option while opening a Mixer window, it will appear as a float 
window.

Unlike the Audio Mixer, the Track Mixer deals with both audio and MIDI tracks. Each 
channel represents an Object in the Environment:  the audio channels are Audio 
Objects, the MIDI channels are instruments or parts (sub-channels) of multi 
instruments.

Tracks that don’t have their own mixer parameters are not visible in the Track Mixer. 
These include Delay Objects  (see “Delay Line Object” on page 176), Arpeggiators  (see 
“Arpeggiator Object” on page 174), and so on. If several tracks in the Arrange window 
address the same track instrument Object, the instrument is represented by a single 
channel in the Track Mixer.

Note:  You can adjust the vertical and horizontal display of the Track Mixer with the 
Zoom controls.
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Display Modes
The Track Mixer has two display modes:  Global and Track view.

In Global view, all MIDI instruments and all Audio Objects that exist in the Environment 
are displayed as mixer channels.

In Track view, Logic creates a mixer based on all tracks currently assigned in the Arrange 
window track list. It contains as many channels as there are tracks. The channels are laid 
out in the same order as in the Arrange window. Redundant tracks are suppressed, 
where multiple tracks represent the same output (Object). This could be two MIDI 
instruments with the same port and channel setting, or two Audio Objects with the 
same device and audio channel/track setting.

If you miss an Object you need for mixing (an Audio Output Object, for example), open 
Global view and double-click on the Object in question. It will then be added to the 
Arrange track list, and will appear in the Track Mixer when in Track view mode.

Track Filter
The Track menu is used to define the types of tracks displayed in the Track Mixer.

Track Filter Switching Techniques
You can set Global and Track views separately with the Filter buttons. 

• Command-click doesn’t change the Track Filter setting when switching Global view 
on and off.

• Clicking without a modifier on a disabled track type will enable the view of this type, 
and disable all other types.

• Clicking without a modifier on a currently enabled track type will enable all types. A 
second click will cause the display to revert to a single enabled type. 

• Shift-clicking allows you to individually enable and disable types, in any combination.
• Command-clicking if Global view is disabled enables Global view, and also enables 

the display of the current track type.
• Command-clicking if Global view is enabled simply disables Global view. 
• Option-clicking moves the window position to the first track of the current type. 

Filter and Global view modes are not changed—with one exception:  If the clicked 
type is currently disabled, it will be enabled.
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The Global view can display tracks that don’t exist in the current arrangement or 
recording folder. In this situation, it’s impossible to select such tracks for recording. If 
you double-click on one of these tracks, it will automatically be created (and selected) 
in the current recording folder.

View Options
The View menu is used to customize the display to suit your requirements. You can 
individually switch off the display of; instrument names, program numbers, bank 
numbers, the user-defined knobs on the MIDI mixer channels (Assign), pan pots (Pan), 
faders (Volume) and track names and numbers to create more onscreen space. If you 
choose to remove the instrument and program names from the display, the channel 
retains its rectangular shape—without the tabs needed for long names. If you switch 
off the display of the instrument name alone, the track name is shown in it’s place.

If you enable the Same Instrument Tracks option, identical Arrange window tracks are 
also displayed in the Track Mixer. These tracks have redundant settings for volume, pan, 
and so on, so it’s usually unnecessary to display more than one. The mute settings, 
however, may be different for each track.

Like the other editors, the Track Mixer can be stored as part of any Screenset  (see 
“Screensets” on page 30).

Folders and the Track Mixer
The Track Mixer can not only display the contents of the highest level of the Arrange 
window, but also the contents of folders. The Track Mixer automatically registers any 
change in the folder structure, or instruments assigned to tracks. 

If a folder is selected, or if the top window is an Arrange display of a folder when you 
open the Mixer, it will only show the tracks within the folder. If you click the directory 
close-box (the square button below the window close-box at the top left), you will 
switch the Track Mixer to the next-highest level; in this case, the level containing the 
folder. Double-clicking the folder channel restores the display of the folder. The display 
of Folder Tracks must be switched on in the Tracks menu for this to work.

General Tips for Using the Track Mixer
The following tips might help you make the most of the Track Mixer. 

To create an arrange track using the Track Mixer:
m In Global view, a double-click on the background of a channel will insert a new 

(corresponding) track into the current Arrange window, provided that no 
corresponding track already exists.

To mute arrange tracks using the Track Mixer
m Option-clicking on the Mute button of an Audio Object will mute the corresponding 

Arrange window track, but will not mute the Audio Object. A second Option-click will 
un-mute the track.
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Note:  If the current Track Mixer view does not contain the Output or Bus Object, Global 
view will automatically be enabled. The appropriate view filter (Output/Bus) will also be 
enabled, ensuring that the selected Object type is visible.

The MIDI channel strips have little “LEDs”, which turn green for Note On events, and 
yellow for all other MIDI information.

Send All Mixer Data
The selection of Options > Send All Mixer Data transmits all currently visible mixer knobs 
and fader settings to MIDI.

Track Selection When Playing or Recording
You can prevent the track selection from changing when making an adjustment to a 
channel, while Logic is in recording or playback mode. There’s an independent 
parameter for each situation; Options > Change Track in Record Mode and Options > 
Change Track in Play Mode.

MIDI Channel Strips
Operation
This section deals with the MIDI channel strips of the Track Mixer, as well as those of 
the GM Mixer (see “GM Mixer Object” on page 171).

The MIDI channel strips work as a remote control for the mixing parameters of your 
sound modules and synthesizers (volume and pan, for example). This is the nature of a 
sequencer. The controls send MIDI Control Change Messages. They do not control any 
audio signal flow within Logic. Switch on all options in the View menu of the Track 
Mixer, so you can see all of the parameters described below.

Saving the Mixer Settings
The Mixer settings directly affect the Object Parameter box at the bottom left of the 
Arrange window. The current settings are saved with the song. If the memory of your 
sound module is not maintained by battery every time you switch it off, it will forget 
any settings made in Logic. To restore these settings after reloading the song, select 
Options > Send to MIDI > Used Instruments MIDI Settings from the main menu. 
Chapter 6    Logic’s Mixing Facilities 221



222

 

Extended GM, GS, and XG Functions
In addition to the GM Standard, there are extended standards created by Roland (GS) 
and Yamaha (XG).

GS and XG mode allow you to select different effect programs, and to control 
the level of the reverb and chorus effects.

1 Click-hold the GM field on the right side of the Mixer window. A pull-down menu 
appears.

2 Select the extended standard (GS or XG). Depending on your selection, the controllers 
for the extended effects will appear.

3 Select the desired reverb or chorus effect from the pull-down menu. 

4 Program the desired reverb or delay time (Time parameter), by using the mouse as a 
slider.

Reset Button
The Reset button transmits a GS On or XG On command, and resets all controllers to 
neutral positions. This allows you to reset all connected sound modules to their 
standard settings, and begin a mix from scratch. The Reset button is only available in 
the Environment GM Mixer.

Controls
The Track Mixer > View > MIDI Track Components menu allows you to switch the display 
of the different MIDI Channel Strip controls on or off.

Bank
If your sound source “understands” bank select events, you can choose the bank 
number for each of the 16 MIDI channels. Please remember that not all synthesizers 
support bank select events. You can use several different bank select formats (see 
“Defining Custom Bank Selects” on page 169).

Program
The Program pull-down menu is used to select a sound by name. Each channel has its 
own pull-down menu. The top row selects programs for odd-numbered MIDI channels 
(1, 3, 5 … 15), and the bottom row is used for even-numbered channels (2, 4 … 16).

To select the sound for a MIDI channel:
1 Click-hold the sound name.

2 A pull-down menu opens, containing all GM sound names.

3 Select a sound from the menu, and release the mouse button. Logic selects the sound 
in the sound module.

Volume
You can use the volume fader to control the level of each individual channel. Controller 
7 is sent.
Chapter 6    Logic’s Mixing Facilities



 

Mute
The Mute button switches the volume of the channel between zero and the current 
fader position. In practice, this means that if the button is “down”, the channel is muted. 
If you switch the Mute button off, the current fader position (and value) is used.

If you want to mute a channel:
1 Click the Mute button of the desired channel.

2 Click the button again to reactivate the channel.

Pan
The Pan knob allows you to directly control the pan position of the sound.

To control the pan position of a sound:
1 Click-hold the Pan knob.

2 Move the mouse up and down. The knob moves according to the mouse position.

Note:  Clicking a fader or knob while holding Option resets the value to a neutral value. 
The neutral value is zero for all controls except Volume (#7) = 100, Panorama (#10), 
Balance (#8), Resonance (#71), Release Time (#72), Attack Time (#73) and Cutoff 
Frequency (#74)—all of which have a default value of 64 (center position).

Other Controllers
You can send any controller data—to control different parameters of your sound 
source—with each of the upper rows of knobs. 

Selecting Other Controllers
In the Track Mixer, you can simply click on the label above the knob to choose a 
different controller. In the View > MIDI Track components menu you can determine the 
number of controller knobs by choosing Assign 1–5. The default is set to two knobs.

In the Environment GM Mixer, use the text boxes on the left to choose different 
controllers.

Here’s a description of the predefined General MIDI functions. Not all MIDI instruments 
will understand these Controllers:

Reverb (Controller Number 91)
This knob controls the reverb level. The further right you turn the knob, the louder the 
effect signal becomes (in other words, more signal from the channel is fed into the 
effect processor).

Chorus Depth (Controller Number 93)
This knob controls the depth of the chorus effect. The further right you turn the knob, 
the stronger the effect becomes.
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LPF Frequency (Controller Number 74)
This knob controls the overtone content of the sound. Higher values make the sound 
brighter.
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7 Automation
Logic features a very sophisticated, yet simple to use, 
track-based automation system that allows you to create 
and play back fully automated mixes.

In addition, Logic offers a range of automation features that complement the track-
based automation system. These can be used in isolation, or in conjunction.

Automation—Introduction
“Automation” is the ability of a mixing desk to record, edit, and play back the 
movements of its volume faders. Fully automated consoles not only record the motion 
of the volume faders, but the motion of all knobs and switches, including pan, EQ, and 
aux send controls.

All of Logic’s mix functions can be automated, without restriction. This applies to all 
plug-ins—the parameters of all effects and software instruments, plus all third-party 
plug-ins can be totally automated.

Logic offers two types of automation:  Track based and Region based.

Track Based Automation
The Track Based Automation system (see “Display” on page 227) is independent of MIDI 
and Audio Regions and takes place, as the name suggests, on the tracks themselves. 
Track Automation is also independent of Play or Record status.
     225



226

 

There are three ways of writing and editing automation data in a track:
• Moving the on-screen faders and controls using different automation modes.
• Drawing automation data with Hyper Draw (see “Hyper Draw Functions” on 

page 234).
• Using Logic Control or another control surface.

Track Based Automation is the recommended method for all automation tasks. It is 
sample accurate, and therefore, very precise. As sample accurate automation is 
processor-intensive, Logic provides options to partially or completely switch off the 
sample accurate mode via Audio > Audio Settings.

Moving Automation Data When Moving Regions
It’s possible to move Regions with, or independent from, Track Automation data. Switch 
the modes by selecting Options > Track Automation > Track Automation Settings > Move 
Automation with Regions. You can choose between Never, Always, and Ask, which should 
be self-explanatory. Ask is the default setting.

Region Based Automation
Region Based Automation (see “Region Based Automation” on page 232) writes 
automation data directly into Regions as MIDI controller data.

There are three ways of writing and editing this data:
• Moving the on-screen faders and controls in Record Mode.
• Drawing automation data with Hyper Draw (see “Hyper Draw Functions” on 

page 234); this is possible for both MIDI and Audio Regions; furthermore, the Score 
and Matrix Editors both allow the insertion of controller data via Hyper Draw.

• Drawing controller and other data in the Hyper Editor (see “Hyper Editor—
Introduction” on page 311). You can also insert and edit controller data in the Event 
List (see “Using the Event List” on page 297).
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Track Based Automation
Display
Select View > Track Automation to display Track Based Automation data in the Arrange 
window. This is also available as a key command. As long as this function is unchecked, 
Regions appear as per usual. The gray shaded Track Automation area is only displayed 
when the vertical zoom is set to a sufficient height, as is the case with Region Based 
Automation (Hyper Draw). As opposed to Hyper Draw, engaging the Track Automation 
data display will automatically set a sufficient zoom level. Track Automation data is 
displayed on a transparent gray shaded area, allowing you to see the audio waveform 
in Audio Regions, and notes in MIDI Regions, at a reduced contrast level.

You can edit Track Automation data directly in this display.

Zooming of Individual Tracks
Each track can be displayed at an individual vertical zoom level:  Click-hold on the very 
left lower edge (to the left of the track number) of the desired track in the track list, and 
drag downwards. Zooming of all tracks is performed with the Zoom Bars. Alternatively, 
you can use the magnifying glass of the Toolbox. The View > Auto Track Zoom function 
automatically enlarges the currently selected track.

Choosing the Parameter to be Displayed
You can select the parameter that you wish to display and edit in the pull-down menu 
of the panel which appears in the Arrange window track list. This can be the volume 
fader, pan pot, or any other parameter of the corresponding Mixer channel strip. The 
parameters are represented by different preset colors when displayed as a curve in the 
automation track. The most recently edited parameter will be displayed whenever you 
edit a parameter in the Track Mixer, a plug-in-window, or via a Logic Control unit.

Context Sensitive Display
In order to reduce the number of displayed parameters, the display is context sensitive, 
which greatly simplifies operation. This means that only parameters which actually 
control something in the selected Mixer channel strip (or its plug-ins) are displayed. The 
display of parameter names is also context sensitive:  this is a major plus, because 
rather than seeing a meaningless number, you can see the name of the function you’re 
dealing with in plain text. Parameters that already exist in the track (as automation 
data) are displayed in bold lettering in the context-sensitive menu.
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Viewing Multiple Parameters
Background Display of Other Parameters
The background of the automation track shows all other automation data (not the 
currently selected parameter) at a lower contrast level—when the track is at a sufficient 
zoom level. Volume is beige (dark yellow), Pan is dark green, everything else is dark 
blue.

Automation Modes
You can independently select the automation mode of every channel strip in the Track 
Mixer or Audio Mixer. The automation mode parameter is also visible in the Arrange 
track list, at higher vertical zoom levels. The automation mode can also be set via key 
commands. Given that Track Automation data can be recorded during playback mode, 
the default setting is Off, as any mix automation recording may prove disconcerting 
while arranging. You can choose between the following automation modes in any MIDI 
or audio (including Audio Instrument, bus, and output) Region:

Off
Off will disable the current Track Automation data without deleting it. No automation 
data will be written, read, or played back. If the current automation mode is Off, any 
edits to Track Automation data in the Arrange window will automatically switch the 
automation mode to Read. This ensures that the data, as currently edited, will be 
played.

Read
Read will automate the current track, using the existing automation data.

The data cannot be changed in realtime by touching/moving the fader.

Touch
Touch will automate the current track in the same fashion as Read.

Should the fader be touched, the existing Track Automation data of the current fader 
type will be replaced by any new fader movements—while the fader is pressed/
touched. Touch is the most appropriate, “standard” mode, used for creating the mix. It 
allows you to correct and improve the mix at any time, when automation is active. The 
time required by a parameter to return to its previously recorded setting, is set via 
Options > Track Automation > Track Automation Settings > Ramp Time (ms).
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Latch
Latch basically works like Touch, but the current value will replace any existing 
automation data, after releasing the fader—when Logic is in playback (or record) 
mode.

To finish, or to end parameter editing, stop playback (or recording).

Write
In Write Mode, existing Track Automation data is erased as the Song Position Line 
passes it.

If you move any of the Mixer’s controls, this movement will be recorded—if you don’t, 
existing data passed by the SPL is simply deleted. Use Options > Track Automation > 
Track Automation Settings to determine the type of data that should be erased. The 
Write Mode changes to setting determines the mode that Logic switches to after a Write 
operation has been executed.

Be careful with the Write mode (and its settings), to ensure that you don’t erase your 
pan, bus, and EQ automation data by mistake, if your intention was only to erase 
volume fader information!

The Write mode of traditional mix automation systems will rarely be needed when 
working with Logic’s advanced Track Automation features. It’s mainly there to complete 
the selection of automation modes. It’s easier to erase automation data by selecting 
Options > Track Automation > Delete All Automation Data of Current Track (or All Tracks, 
respectively). In earlier analog mix automation systems, the Write mode was the only 
way to erase automation data from tape when beginning a new project. The Options > 
Track Automation > Write to End and Write to Right Locator commands are self 
explanatory. One writes Track automation data to the end of the song, and the other to 
the right locator position.

MIDI
MIDI disconnects the Mixer controls from the Track Automation system, and switches to 
Region Based Automation (see “Region Based Automation” on page 232).

The fader will act like a standard external MIDI source, and will be recorded and played 
back as normal MIDI data in MIDI Regions.
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Switching Automation Modes for All Channels Simultaneously
Hold Command when switching the mode of a channel strip, and all channel strips that 
were previously set to the same automation mode will switch to the selected mode.

Writing Track Automation Data
You have the following write options for Track Automation data:
• Move any fader or control of the selected channel strip—in the Track Mixer or 

Environment Mixer—with the automation mode (see “Automation Modes” on 
page 228) set to Touch, Latch, or Write. In real world usage, you’ll rarely (if ever) use 
the destructive Write mode, which erases all automation data. The standard write 
modes are Touch and Latch.

• Choose a parameter in the Arrange track list, and move the value slider to the right 
of the track list, with one of the write modes engaged.

• Move the external faders (and other controllers) of your Logic Control or another 
suitable hardware controller that has been set up on your system, with one of the 
write modes engaged.

• Use Hyper Draw (see “Hyper Draw” on page 233) to manually draw in automation 
data

Important:  The recording of Track Automation data takes place if Logic is in record or 
playback mode! The Arrange window track selection or audio record ready status is 
irrelevant. Whatever you touch/move will be recorded, when a channel strip is set to 
one of the write modes. The movement of Mixer controls (when in a write mode) can 
be used to overwrite and/or edit existing automation data, in real time.

Behavior in Stop Mode
In Stop mode, the Automation write modes are ignored, and no data is written if the 
fader is moved. There is, however, one exception:  if there are no dynamic changes (no 
automation data), the current fader setting becomes valid for the whole song. This is 
the default behavior for all mix parameters, when you start a fresh song.

Deleting Track Automation Data
The following, self-explanatory, automation data erasure options are available. 
Choose Options > Track Automation >
• Delete currently visible Automation Data of Current Track
• Delete All Automation Data of Current Track
• Delete Orphan Automation Data of Current Track
• Delete All Automation Data of All Tracks

Shift-Option–double-click opens a dialog that allows all automation data of the current 
type to be deleted. This is as per the Delete All Automation Data of Current Track option.

It is also possible to delete a selection of Hyper Draw nodes with Backspace. If no 
Region is selected, the selected nodes will be deleted when pressing Backspace. Use 
this function with care, to avoid the accidental deletion of Regions.
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Editing of Track Automation Data in an Event List
Logic allows Track Automation data to be edited in a dedicated event editor. You can 
also open the folder which contains the (normally invisible) Track Automation data. As 
a core element of the program, Logic will always display every event as plain text in an 
Event Edit window. Please note, however, that this functionality won’t be needed in 
normal music production situations, and is a real “expert” function. You can open the 
Track Automation event editor via the Automation Event Edit key command.

Track Automation Folder
Track Automation data is represented by a new class of “meta” events. These are an 
internal Logic event type that control processes that are not output via MIDI—
although their data structure is somewhat similar to MIDI events. These meta events 
reside, like every event, in MIDI Regions, on tracks. The tracks, in which Track 
Automation data resides, are found in a dedicated folder which is normally hidden. You 
can display it via the Automation Folder key command. You will find a single MIDI 
Region that only contains Track Automation data on each track within this folder. This 
MIDI Region ends with the last Track Automation meta event. (Only tracks that contain 
automation data are shown in the Automation folder window).

You can edit these events with Region Hyper Draw (View > Hyper Draw) and Track 
Hyper Draw (View > Track Automation).

The display of the contents of the automation folder makes it easier to edit the 
automation data independently from Regions. In normal circumstances, however, it’s 
usually quite useful to see the Regions while designing the mix. As such, you’ll 
probably find that you rarely open this folder view.
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Automation Quick Access
This feature makes Track Automation extremely fast and simple if you only have one 
hardware MIDI controller available (one fader on your MIDI keyboard, or maybe just the 
Modulation wheel). You can use this single hardware controller to access (and 
automate) the currently visible Automation parameter of the selected Track in the 
Arrange window.

Setting Up Automation Quick Access
Open the Automation Settings dialog:  Options > Track Automation > Track Automation 
Settings.

There is a section called Automation Quick Access, which can be enabled or disabled via 
On and Off radio buttons. Once enabled, a dialog will prompt you to move the desired 
controller. Move the hardware controller that you’d like to use for Automation Quick 
Access. Click the Done/Learn Message button below. The other parameters shown (via a 
click on the Edit button) here will immediately identify and indicate the type of control 
element you are using (even quite exotic formats are supported). Disable the Learn 
Message button, by clicking on it a second time (the Done button), or close the 
Automation Quick Access dialog.

Once set up, you will have hardware control over any currently visible Automation 
parameter that is selected in the current Arrange track.

Enable/Disable Automation Quick Access
Should you choose the Modulation Wheel for Automation Quick Access (AQA), you 
might want to switch between it’s use for AQA and “normal” Modulation Wheel 
duties—as MIDI controller #1.

This is most efficiently done with the global Toggle Automation Quick Access key 
command. 

Region Based Automation
Region Based Automation writes automation data directly into Regions as MIDI 
controller (or other) data.

Recording of MIDI Automation Data
Region Automation data is recorded just like regular MIDI events. Logic must be in 
Record Mode to capture this type of automation.

You have the following options for MIDI automation data recording:
• Set the automation mode of a Track Mixer channel strip to “MIDI”. The movement of 

any channel strip fader or control will be recorded on the corresponding track as 
MIDI controller data. In the case of audio channels, the track must not be in record 
enabled mode.
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• Moving any Environment Fader (see “Recording and Playback of Fader Movements” 
on page 183) records the fader’s MIDI events to the currently selected track.

• External MIDI controllers can also be used to create and record events. (Please note 
that it is currently not possible to use Logic Control for this purpose, due to it’s high 
fader resolution).

In audio channel strips, all settings (including plug-in parameters) can be recorded as 
MIDI controller data. Record different parameters to find out which controllers are used 
for what parameters. It’s also possible to cable other Environment Objects, such as 
Instruments, Channel Splitters or MIDI Faders into Audio Objects. You may use these 
Environment Objects as track instruments in the Arrange, for the automation of the 
Audio Object they are connected to.

Drawing MIDI Automation Data
Controller data can be directly inserted with Hyper Draw (see “Hyper Draw” on 
page 233) in the Arrange, Matrix, and Score Windows. The Hyper Editor (see “Hyper 
Editor—Introduction” on page 311) serves a similar purpose, in a dedicated window.

Editing MIDI Automation Data
As MIDI automation data consists solely of MIDI events, it can be edited just like any 
other MIDI events, using the Event List (see “Using the Event List” on page 297), Hyper 
Editor (see “Hyper Editor—Introduction” on page 311) or the Transform window (see 
“Transform Window—Introduction” on page 437).

Hyper Draw
Hyper Draw is the easiest way to create and edit Automation data in the Arrange 
window. Changes to automation data are made by graphically inserting points, which 
represent fixed controller values. The points are then interpolated automatically by 
Logic, which creates a series of events that smoothly connect the first event with the 
last. These automatically generated events are recalculated every time you edit the 
curve points.

Hyper Draw is available for both the Track Based (see “Display” on page 227) and 
Region Based Automation (see “Region Based Automation” on page 232) systems. The 
use of Hyper Draw is almost identical for both automation systems.

Hyper Draw for Tracks
Track Hyper Draw is automatically activated when Track Automation is enabled in the 
Arrange Window (View > Track Automation). 
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Hyper Draw for Regions
Region Automation is switched on for the selected Region by choosing a certain event 
type via View > Hyper Draw > … This type of Hyper Draw is also available in the Matrix 
window  (see “Hyper Draw in the Matrix Window” on page 327)and the Score window 
(see “Hyper Draw in the Score Edit Window” on page 347), where a blue Hyper Draw 
section is added below the editing area. You must set a large enough vertical zoom 
resolution in order to see the Hyper Draw curves.

Hyper Draw Functions
Hyper Draw makes use of various tools, maximizing efficiency when drawing and 
editing automation data. In principle, the following applies to both Track Hyper Draw 
and Region Hyper Draw.

Arrow Tool
This tool can be used for a variety of actions within the Hyper Draw area.
• A short click into the empty Hyper Draw area will add a new node.
• The very first click into an empty Hyper Draw track creates a new node at that 

position, and another node at the beginning of the (Hyper Draw) track. This ensures 
that you can’t create parameter controls with “gaps” in the middle of a MIDI Region, 
but have full control over the parameter from the beginning of the automation track.

• A short click on a node will delete it.
• A short click on, or just outside, a line (not a node) will add a new node on the line.
• A long click on a line allows you to move the line, along with its two endpoints—the 

nodes that encompass the line.
• A short and a long click outside a line will create and select a new node, allowing 

you to move the newly-created node immediately.
• Option-long clicking on a selection allows you to copy the selection.
• Option-clicking, without a selection will select all automation data behind (following) 

the current mouse position, allowing you to drag the selection.
• An Option–double-click, without a selection will select all data.

Rubber Band Selection
Shift-click and dragging allows you to make a rubber band selection. There are three 
options:
• Without further modifier keys, no new nodes will be created.
• With Option held, a new node will be created on each side of the rubber band area.
• With Option-Control held, two new nodes will be created on each side.

Multiple Selection of Nodes
• A short Shift-click on a node will toggle the selection of the node.
• A short Shift-click on a line will toggle the selection of the line.
• A short click on the background will deselect all.
• A click outside of the Track Automation data in the Arrange will deselect all.
• A long click in a selected area allows all selected nodes to be moved.
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• A long Shift-click allows a rubber-band selection. The selected area will toggle.
• Moved automation data will automatically erase any data which exists in the 

destination area.

Relative and Absolute Value Changes of Selections
There are two choices available when changing the values of a selection of nodes:
• Clicking on a line or node enables you to change all values by the same absolute 

amount.
• Clicking outside a line, within the selected area (a node or outside a node), changes 

all values proportionately, by a percentage value.

Track Automation: Select All, Scaling
Command-clicking on either; the numerical or graphical value displays in the Arrange 
track list allows the following:
• A short Command-click selects all (current parameter) automation data of the track.
• A long Command-click scales all (current parameter) automation data of the track.

Pen Tool
The Pen Tool allows you to freely draw automation events.

Eraser Tool
The Eraser Tool allows you to erase automation events.

Value Display in Hyper Draw
Numerical values are automatically displayed at Hyper Draw nodes, if there is sufficient 
space onscreen. Numerical values are context-sensitive—the centered pan position is 
displayed as 0 (not 64), and volume is displayed in dB, as examples.

If no events exist for volume and pan, Logic draws a horizontal line of the current value 
(if available). If clicked, a single event of that value will appear on the Hyper Draw track/
area. Further clicks work as per usual.

Activating Region Hyper Draw
To activate Hyper Draw for the currently-selected Region(s), select View > Hyper Draw… 
You can select different Hyper Draw modes for different Regions.

Event Type
You can select the following types of events directly from the Hyper Draw menu:
• Volume
• Panning

The chosen event type is displayed as a controller number, or by name, in the upper 
left corner of the Hyper Draw area.
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MIDI Channel
The View > Hyper Draw > Channel … menu item allows you to define the MIDI channel 
used for event display and editing. The chosen channel number will also displayed 
alongside the event type.

Hyper Draw—Note Velocity
Once active—by selecting View > Hyper Draw > Note Velocity—click-holding at any 
point in a Hyper Draw window will activate the note velocity line tool, much like that 
found in the HyperEdit window. Releasing the mouse button change the tool icon to a 
line, which can be visually placed onscreen. The end of the line is inserted by clicking a 
second time. This will automatically scale all note velocities, aligned to the inserted line. 
Please note that use of this option only makes sense when the Region area actually 
contains notes.

The Note Velocity Line Tool works in different modes:
• Absolute:  With no modifier key pressed, the velocity of notes will be changed to 

match the values of the line.
• Relative:  Command-click, the original and new note velocity will be analyzed. The 

resulting velocity is the average of both.
• Just Selected:  with Option pressed, only previously selected notes will be affected.

Both Relative and Just Selected modes can be combined.

Deactivating Hyper Draw
To switch off Hyper Draw for selected Region(s), select View > Hyper Draw > Disable.

Conversion of Automation Data
Track Automation data can be converted into MIDI data for Region Based automation, 
and vice versa. These commands are found in the Options > Track Automation menu. 
These functions allow you to move data (Volume, Pan, plug-in parameters, and so on) 
from Regions in the Arrange window to the Track Based Automation system, and vice 
versa—moving data from the Track Based Automation to Region Based (last two 
functions). Ensure that at least one Region is selected when using these functions. 

Converting Automation Data 
In the automation view:
• Command-clicking on an automated parameter will activate the parameter pop-up 

menu.
• Select a destination parameter in the menu.
• A dialog will ask you to “convert” or “copy & convert” the original parameter’s 

automation data into automation data for the destination parameter. A “copy & 
convert” of the original parameter data is kept, in addition to the destination 
parameter.
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Moving from Region Data to Track Automation
Move Current Region Data To Track Automation
Moves the currently visible Region data (Volume, for example) to the Track Based 
Automation system.

Move All Region Control Data To Track Automation
Moves all Region Based automation data to the Track Based Automation system.

Moving from Track Automation to Region Data
This option only moves Track Based Automation data that falls within the boundaries of 
the selected Region.

Move Current Track Automation Data To Region
Moves the currently visible Track Based Automation data to a selected Region.

Move All Track Automation Data To Region
Moves all Track Automation data to a selected Region.
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8 Global Tracks
Global Tracks provide a perfect way to view and edit 
global events, such as Tempo, which affect all tracks in 
the arrangement.

Global tracks can be displayed in the following windows, just below the Bar Ruler:
• Arrange window 
• Matrix Editor
• Score Editor (in linear view)
• Hyper Editor

There are several types of Global tracks:
• Tempo track:  contains all tempo changes of a song.
• Signature track:  contains the basic key of the song and all time and key signatures, 

as they are displayed in the Score Editor.
• Transposition track:  shows global transposition events. 
• Video track:  displays frames of a QuickTime movie as “thumbnails” that are perfectly 

synchronized with the music, making it ideal for film scoring. Cuts in the movie can 
be automatically detected and marked. 
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Display Options for Global Tracks
Global tracks are displayed or hidden by repeated use of the View > Global Tracks menu 
option. The View > Global Track Components submenu lists the individual Global track 
types. You may use these submenu items to toggle the display of each track type, one 
by one, or all at once with the Show All/Hide All options. Following the use of any of the 
Components commands, the View > Global Tracks command will only toggle the display 
of components previously chosen in the submenu.

Please note that there are also key commands for all of the following options:
• Toggle Global Tracks
• Toggle Transposition Track
• Toggle Signature Track
• Toggle Tempo Track
• Toggle Video Track
• Hide All Global Tracks
• Show All Global Tracks

In the upper left corner of each Global Track name column, there is a small disclosure 
triangle pointing to the right. If clicked, the track height is expanded and additional 
controls become visible. A further click on the triangle reduces the track height. You 
can freely adjust the horizontal borders between tracks by dragging them up or down 
with the mouse.

The order of Global tracks can be reconfigured by grabbing any of them with the 
mouse in the track list (anywhere except the control elements), and dragging them up 
or down. The display order of Global tracks is saved independently for each window. 

If the Track Protect buttons are visible (Menu View > Track Protect Buttons), any of the 
Global tracks can be protected by clicking on its Protect button, which will turn blue. 
This will prevent the track from being edited unintentionally. 

How to Create, Move, Copy, and Delete Global Events
The data on most Global tracks are called global events (except on the Video track, to 
which the following descriptions do not apply).

Creating Global Events
To create a global event (a tempo change, for example), use the Pencil tool and click at 
the desired position in the track. (If you haven’t changed the default tool assignments, 
this is done by clicking while holding the Command key). Watch the help tag while 
holding down the mouse button:  It displays the exact position and value (if applicable) 
of the event to be inserted, until the mouse button is released.
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Selecting and Moving Global Events
Global events are selected with a simple click, and are moved and/or changed by 
dragging them with the mouse. We recommend that you keep an eye on the help tag 
while doing so. Multiple selection is achieved by Shift-clicking on the desired events. 
This can even be done in combination with the selection of Regions on Arrange tracks.

To select several subsequent events on the same Global track, you can use the rubber 
band selection method, while holding the Control key.

To select all events on a particular Global track, click in the desired Track List.

If menu or key commands for multiple selections are made in the Arrange window 
(such as Select All, Toggle Selection, Select Inside Locators), they will also apply to global 
events on all visible Global tracks. This can be useful for copying or moving an entire 
song section, inclusive of all signature and tempo changes, for example. 

Note:  Events on protected tracks will not be selected and—if currently selected—will 
be deselected by these commands. Consequently, there are several choices available 
should you wish to avoid having global events selected by any of these selection 
commands:  Either you activate the Track Protect buttons of the desired tracks; or you 
choose Edit > Deselect Global Tracks after the use of any of these commands; or you 
simply turn off the Global track display temporarily, using the View > Global Tracks 
menu option or the corresponding key command.

Copying Global Events
You can use the same copy methods used for Regions and MIDI events on global 
events:  Drag an event while holding the Option key (watch the help tag) or use the 
standard menu or key commands for Copy and Paste. The copied global event will be 
pasted at the current Song Position Line (SPL) location. If multiple events are copied, 
the first one will be pasted at the SPL, the others will retain their relative distance to 
the first copied event.

Deleting Global Events 
To delete one or several global events, select the desired event/s and press Backspace 
or Delete, or just use the Eraser tool.
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Tempo Track
The Tempo track displays tempo changes as nodes:  dots connected by lines. By 
default, these dots are followed by horizontal lines that (at the bar position of the next 
tempo change) form right angles with vertical lines, connected to the node of the 
ensuing tempo change.

Note:  If there is enough space in the Tempo track, the tempo will be indicated 
numerically (in bpm) alongside each node.

Insertion of Tempo Changes
Tempo events are inserted by a double-click (with the Pointer) or by using the Pencil 
tool. Watch the help tag and don’t release the mouse button until the intended tempo 
and position are indicated exactly.

Note:  If you hold Control-Option-Command while clicking in the Tempo track, a text 
field opens. You can type the desired bpm value into this field. Press Return or Enter, 
and a tempo event (of the typed bpm value) will be created at the clicked position.

Deleting Tempo Changes
To delete a tempo change, select it by either clicking the node itself or the line which 
leads away from it, then press Backspace or Delete. Alternately, you can double-click on 
the node or use the Eraser tool. 

Continuous Transition Between Different Tempi
To create a continuous transition between two tempi, grab the dot at the tip of the 
right angle (above or below) the second node, and drag it inside. A curve or diagonal 
line will be the result. You’ll find that this is quite similar to drawing track automation 
curves with the mouse.

The Tempo Resolution menu in the Tempo track defines the number of tempo changes 
that are actually performed when using curves:  When it is set to 1/16, there will be four 
tempo changes per quarter note, 1/1 will only generate one tempo change per bar, 
which will result in a less smooth transition. This setting can be defined differently for 
each node.
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To delete a tempo curve:
m Click the handling node (at the tip of the right angle) with the Eraser tool, or double-

click on it.

Moving and Copying Tempo Changes
To move a tempo change, grab its node (or the line leading away from it) and drag it 
left or right. To copy it, do the same while holding Option. To prevent unintentional 
changes, moving a node is restricted to either vertical or horizontal movement. Put 
another way, you can either change the tempo value or its position, but not both at 
once. To alter the tempo in very small steps, press Shift while dragging the desired 
node up or down.

Tempo events can also be copied by using the standard Copy and Paste procedure. The 
SPL will determine the position for the first pasted event. 

It is also possible to copy or move multiple tempo events at once:  Use Shift-click or the 
rubberband selection method (while pressing Control) for multiple selection.

More About the Tempo Track
• Shift–double-clicking in the Tempo track will open the Tempo List.
• The display range for tempo events is adjusted automatically. The upper and lower 

boundaries of the Tempo track are labeled in the Track List. Dragging a node beyond 
the current maximum or minimum scale boundaries will result in an automatic 
adjustment of the range. You can also define the maximum and minimum ranges of 
the tempo display manually. To do so:  Grab the maximum and minimum values in 
the tempo scale and drag them vertically, or double-click on either (or both) range(s) 
and type the desired numerical value into the text field(s). These user-defined values 
are displayed in yellow. If you want to reset to the automatic adjustment values, use 
the procedure described above, and leave the text fields empty.
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Signature Track
The Signature track shows all time and key signatures of a song. These can be created 
in either the Score Editor or directly in the Signature track:  Click at the desired position 
using the Pencil tool. A dialog window will open, allowing you to set the time or key 
signature. Insertion of the event occurs after closing the dialog with the OK button. If 
you perform this procedure when the track height is reduced, a time signature change 
will be created. If the track height is expanded, you will see separate lines for time and 
key signatures, which can be independently clicked with the Pencil tool to create 
events.

The global playback key for Apple Loops and MIDI Regions is determined by the very 
first key signature (default:  C major). 

Apple Loops can contain information about the key they are in, and can be transposed 
automatically. They will be played back in the song key by default, which is defined by 
the first key signature event. No distinction is made between major and minor keys for 
these global transposition functions; in fact, only the root of the initial key signature is 
relevant for playback of Apple Loops and MIDI Regions.

Note:  If a GarageBand song file is imported into Logic, the initial key signature will 
automatically be set in accordance with the “project key” of the GarageBand song. Any 
existing Apple Loops will be played back in this key, or rather, with the key’s root note.

Key signature changes after the initial key signature only affect the display of MIDI 
notes in the Score Editor—they do not have any effect on playback. 

Similarly, even time signature changes don’t affect playback, but only the display of the 
Score Editor. You will not hear anything different when you change the time signature 
or insert a time signature change in this window.
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Handling Signature Changes
Events on the Signature track can be selected, moved, deleted, and copied (drag them 
while pressing Option or use the standard Copy and Paste commands). Multiple 
selections are possible, even in conjunction with Regions, which is very useful when 
complete parts of a song, containing signature changes, are to be copied. In this 
situation, the Edit > Select Inside Locators option can be helpful. Note that the Signature 
track must be visible and must not be protected, in order to select and copy signatures.

If you double-click a signature in this track, a dialog box opens, allowing you to edit the 
signature.

Shift–double-clicking in the Signature track opens the Signature/Key Change List, where 
time and key signatures are shown in a list style editor, along with other global Score 
symbols such as repeat signs, double bar lines and so on.

Cutting Bars
You can use the Scissors tool in the Signature track to cut bars. As an example; to divide 
one 5/4 measure into a 3/4 and a 2/4 measure by cutting at the fourth beat of the 5/4 
bar. 

If you make a cut in the middle of a bar in a section where the time signature doesn’t 
change, two corresponding shorter measures will be inserted, with the original time 
signature resuming after the cut.

Likewise, it is also possible to merge two subsequent measures into one longer 
measure by using the Glue tool in the Signature track.

Transposition Track

The Transposition track shows global transposition events, which affect the 
transposition of both Audio and MIDI Regions. In MIDI regions, it changes the actual 
MIDI events themselves. Despite this data change to events, the Transposition track 
works “non-destructively”, as the global transposition of MIDI Regions can be changed 
multiple times, without actually altering any information. If the Transposition track is 
set to zero, Regions (and the events they contain) are played back as originally 
recorded. 
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Note:  All Apple Loops and MIDI Regions will be pitch-shifted accordingly. MIDI Regions 
will only be transposed if the No Transpose checkbox is deactivated in their respective 
Object Parameter boxes. The “zero position” of the Transposition track is determined by 
the current key signature in the Signature track. If the key signature changes during a 
song, the “zero position” of the Transposition track changes accordingly. “Regular” 
Audio Regions (Audio Regions that are not Apple Loops) will not be affected. Nor will 
Apple Loops that do not have a key definition (drum loops, for example). 

Handling Events in the Transposition Track
The Transposition track contains nodes that are connected by vertical and horizontal 
lines. Each node represents a global transposition event, which determines the global 
transposition value until the song position reaches the next transposition event during 
playback.

Handling of transposition events works in a similar fashion to Tempo track events:  They 
are created with the Pencil tool, and can be moved horizontally (along the timeline) or 
vertically (changing their transposition value) by dragging them with the mouse. Watch 
the help tag during these procedures to see the exact transposition value and bar 
position of that particular event.

If you hold Control-Option-Command while clicking in the Transposition track, a text 
field will open, allowing direct entry of the desired transposition value. After pressing 
Return, a transposition event of the typed value will be created at the clicked position.

To delete a transposition event, select it by clicking on the node itself (or the line to its 
right) and press Backspace, or use the Eraser tool.

Transposition events can be copied using the standard Copy and Paste procedure or by 
dragging them with the mouse while holding Option. 

It is also possible to copy or move multiple transposition events simultaneously, which 
can be useful for repeated song sections:  Use Shift-click or the rubberband selection 
method (while pressing Control) to make the multiple selection, then drag the first 
selected event to the desired position (while holding Option for copying), or perform 
the Copy and Paste commands. Again, watch the help tag while dragging the events.
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The scale range for the display of transposition events is adjusted automatically:  The 
upper and lower boundaries of the Transposition track are labeled in the Track List. 
Dragging a node or line beyond the current maximum or minimum values will result in 
an automatic adjustment of the range. You can also define the maximum and 
minimum of the transposition scale manually:  Grab the maximum and minimum 
values and drag them vertically, or double-click on them and type the desired 
numerical value into the text field that appears. These user-defined values are displayed 
in yellow. If you want to reset to the automatic adjustment mode, repeat the procedure 
and leave the text fields blank.

Video Track
The Video track does not contain any global events, but serves as the “thumbnail track” 
(an overview containing single frames) for QuickTime video when creating film music.

Note:  This global Video track replaces the Video Thumbnail track of previous Logic 
versions. If a song file (created with an older Logic version) which contained a Video 
Thumbnail track in the Arrange window is opened, the Video will be displayed in the 
original Video Thumbnail track view. 

Note:  You can easily insert a movie at the current mouse position by clicking in the 
Video track with the Pencil tool. 

The number of frames displayed in the Video track depend on the track height and the 
zoom level of the window. All frames are aligned left, with only the very last frame 
aligned to the right. This guarantees that you can always see at least the first and last 
frames of a video, independent of the current zoom level. Given the left alignment of 
frames, the left margin of a frame will always be displayed at the exact position of that 
particular frame (except the very last frame).

Note:  Some settings for the thumbnail display can be found in Logic’s Video 
preferences (see “Video Preferences” on page 485).
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9
9 Audio Window
The Audio window provides an overview of all audio files 
used in the current song. It also offers a number of 
simple editing and conversion facilities that simplify 
audio file handling.

While many of the Audio window’s tasks can be performed elsewhere in Logic, it offers 
a number of unique features that are discussed in this chapter.

Audio Window—Introduction

Logic allows you to access any digitally stored audio recordings (audio files) on your 
hard drives, in the most common Macintosh formats:  AIFF (Audio Interchange File 
Format) and SDII (Sound Designer II format), and also Wave (.WAV) format files. Several 
other audio file formats are also supported, including; MP3, AAC and ReCycle.
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By default, recordings made in Logic are stored in the Sound Designer II format. You 
can change the recording format to AIFF or WAV via Audio > Audio Preferences… > 
Recording File Type. Sound Designer I files can also be imported, played back and edited 
destructively in the Sample Editor, but Logic will neither record nor bounce this file 
type.

Audio files imported into a Logic song can be at any supported bit depth and sample 
rate. Logic supports bit depths of 16, 20, and 24 bits, and sample rates of 44.1, 48, 88.2, 
96, and 192 kHz. Logic performs a real time, native sample rate conversion (see “Further 
Options” on page 268).

The Audio window is used to organize all audio files that are used in a Logic song. It 
doesn’t matter whether these audio files have just been recorded, or whether they 
were copied weeks ago from a CD-ROM onto the hard disk. The Audio window gives a 
Logic song access to any compatible data on the hard disks.

The Audio window contains no positioning information about the files it lists. In fact, 
files that are not yet in use in the arrangement may be added to the Audio window. 
Files are assigned to the sequencer’s time axis by arranging sections of the audio files, 
known as “Audio Regions”, in the Arrange window, much like MIDI Regions.

The Audio window can be thought of as an audio file catalog for the song. It also 
provides an overview of Regions that have been defined from each audio file.

You can define new audio files and Regions and edit, delete, or rename existing ones in 
the Audio window. When edited here, the accuracy is limited to units of 256 sample 
words. To make more precise edits, use the Sample Edit window.

These audio files and Regions can then be dragged directly into the Arrange window, 
where they may be arranged as Audio Regions.

The menus of the Audio window contain all operations related to the administration of 
audio files and Regions.

Opening the Audio Window
Select Audio > Audio Window (or Command-9) to open the Audio window. You can 
open several Audio windows at once (even within one Screenset)—to use different 
zoom factors, for example.

If you add an audio file to the Audio window, Logic automatically creates a Region that 
encompasses the entire length of the file.

You can create as many Regions as desired from the same audio file. There are no 
length limitations to Regions, as long as they don’t exceed the length of the source 
audio file.
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Regions can be moved with the mouse into the Arrange window. The portion of the 
audio file represented by the Region is then played at the desired song position.

Layout
Overview
On the left side of the Audio window, you’ll see a thin column. At the top, you’ll see the 
mode buttons (see “The Mode Buttons” on page 251), and at the bottom, the tools.

The column to the right lists the audio files, and their Regions, by name.

Further to the right, Region waveforms are displayed graphically, in the large white area 
of the window. A Region is shown as a boxed, black, or colored area, while the rest of 
the audio file is shown in light gray, indicating that this part of the audio file is not used 
for the Region.

Zoom Functions
The Zoom Bar at the top right can be used to enlarge or reduce the vertical display.

The Zoom Bar at the lower left is for enlarging or reducing the horizontal display size—
altering the time display of the Regions.

The Mode Buttons
The mode buttons allow you to select different operating modes. These affect both the 
display and the playback of Regions in the Audio window.

Link
Link mode in the Audio window means that whenever you select an audio Region in 
the Arrange window, the same Region is automatically selected and displayed in the 
Audio window.

You can switch link mode on or off by clicking the button featuring the chain link icon.

Hidden Regions (see “The Audio List” on page 253) cannot be displayed in link mode. If 
you want to display them, you need to Show (see “The Audio List” on page 253) the 
Regions.

Monitoring
You can play Regions directly in the Audio window. This monitoring is not related to 
the time axis of the sequencer. There are several ways to play a Region:
Chapter 9    Audio Window 251



252

 

Playing From a Specific Position
Click-hold the desired Region in the waveform display with the mouse. Playback starts 
at the click point. This allows you to play specific sections.

Playback stops as soon as you release the button.

Playing the Whole Region
If you want to play an entire Region, highlight its name in the list. Now click the button 
featuring the speaker symbol to start playback. Click the button again to stop playback.

You can also start or stop this type of playback with the Play/Stop Region key 
command.

Stereo Playback
If a Region of a stereo file is selected, clicking the speaker icon plays both sides of the 
stereo file. If you click the icon while holding down Command or Shift, only the 
selected Region (mono) is played. If you subsequently select a Region from another 
stereo file, Logic returns to stereo playback.

Region Cycle
Regions may be looped continuously during monitoring. To switch “Region cycle” on or 
off, click the button featuring the circular arrow symbols. This mode applies to all 
Regions in the Audio window.

This cycle setting only affects monitoring in the Audio window, and has no effect on 
song playback. It should not be confused with the Arrange window Cycle function.

You can adjust the start and endpoints of the Region in real time, while the Region is 
being cycled. This is useful for setting precise Region lengths—when “polishing” drum 
loops, for example.

Selecting the Audio Output for Monitoring
The actual routing of audio signals to different outputs is done in the Arrange window 
(using the Audio Object in the track list).

You can, however, choose a specific audio hardware channel—for monitoring duties—
in the Audio window. Set the desired output by click-dragging on the Channel button, 
just below the speaker icon.
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Display
The Audio List
The list provides an overview of all audio files used in the current song, and the 
Regions derived from them. This is where audio files can be added, removed, deleted, 
or renamed. Regions can also be created, deleted, and renamed.

Hiding and Showing Regions
Following the addition of an audio file, you will see the file name in the Audio window, 
in large print. This takes up minimal screen space, and shows as many currently used 
files as your zoom setting and monitor size will allow. There is a small triangular arrow 
directly beside the file name.

Click the small triangle to reveal an audio file’s Regions. Much like the list display of 
folders in the Finder, this shows you the “contents” of the audio files—the Regions 
derived from the files. The arrow points downwards, showing the Region names in 
small print. Click the triangle a second time to hide the Regions.

You can also press Command while clicking on any audio file’s triangle to quickly Hide/
Show all Regions.

Activating the Display of All Regions
Selecting View > Show All Regions instantly displays all Regions—of all audio files in the 
Audio window.

Hiding the Display of All Regions
The View > Hide all Regions option instantly hides the Regions of all audio files. Click the 
small triangle to the left of the file name to view individual Regions.

Displaying the Lengths of the Regions
The lengths of Regions can be displayed in various units.

Select View > Show Length as; at the lowest level of this hierarchical menu, you can 
choose the display units for Region lengths.

Show Length as… > None
No length display.

Show Length as… > Min:Sec:Ms
Absolute time length of the Region in hours, minutes, seconds, and milliseconds.

Show Length as… > Samples
Number of sample words in the Region.

Show Length as… > SMPTE Time
SMPTE length, which unlike absolute time, uses frames and bits in place of 
milliseconds.
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Show Length as… > Bars/Beats…
The Region is displayed in musical units:  bars:beats:divisions:ticks.

If the tempo, time signature or division settings are altered, the display is automatically 
recalculated.

Displaying Information About Audio Files
Information on every currently loaded audio file can be displayed, from left to right, in 
the Region waveform display, as follows:

Sample rate (Hz), Bit Depth (Bit), Mono, or Stereo status (Cha), file size (kByte) and file 
path or folder (Location). Mono files are identified by a single circle symbol, and stereo 
files by a double circle symbol.

You can switch this display on or off by selecting View > Show File Info.

Sorting Audio Files and Regions
Sorting Audio Files
Audio files in the list can be sorted according to various criteria by selecting View > Files 
sorted by…:

Files sorted by… > None
The audio files are listed in the order in which they were loaded or recorded.

Files sorted by… > Name
The audio files are listed in alphabetical order.

Files sorted by… > Size
The audio files are listed according to size, in decreasing order.

Files sorted by… > Drive
The audio files are sorted according to the drive on which they are stored (hard disk, 
removable drive, partition).

Sorting Regions
The display of Regions can be sorted (within an audio file) according to various criteria 
by choosing View > Sort Regions by…

Sort Regions by… > Start
The Regions are sorted according to their time position in the audio file. This is the 
default setting.

Sort Regions by… > Length
The Regions are sorted according to their lengths.

Sort Regions by… > Name
The Regions are sorted alphabetically.
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The Waveform Display Outside the Region
Logic defaults to showing the waveforms outside the defined Region area in light gray.

You can alter the display by Option–click-holding inside the Region. A pull-down menu 
will appear, containing the following options:

None
No waveform display outside the Regions.

Bright
Waveform display outside the Regions colored light gray.

Middle
Waveform display outside the Regions colored mid gray.

Dark
Waveform display outside the Regions colored dark gray.

Overview Calculation
In addition to the actual audio data, an audio file also contains data required for 
graphical display of the waveform in the Audio window and Sample Editor (“Overview” 
data).

Automatic Overview Calculation
If the Audio > Audio Setting > General > Create Overview after Recording option is 
switched on, graphic overviews are automatically calculated immediately after audio 
recording.

If you switch off this option, overviews are not calculated automatically, but can be 
started manually.

Starting Overview Calculation Manually 
Occasionally, when loading/importing audio files, you may need to perform a manual 
overview calculation (if the audio files don’t contain overview data). You can start the 
overview calculation of selected files with Audio File > Refresh Overviews.

Controlling the Overview Calculation
The calculation of audio file overview data is shown in a float window. This calculation 
occurs in the background, allowing you to continue working with Logic.

You can position this float window anywhere. The most recently used position is saved 
in the Preferences.
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Double-clicking this window opens a dialog box that offers the following options:
• If you stop the calculation by clicking Abort, you can still play the audio file—but it 

will not be easy to edit without an overview!
• Continue performs the overview calculation in the background, as per usual.
• Clicking Finish transfers the calculation to the foreground, speeding it up 

considerably. The disadvantage is that you can’t use your Mac for anything else, until 
the overview calculation is finished.

Operation
Selection Techniques
There are several different ways of selecting audio files and Regions in the Audio 
window.

To select a single item, either click its name in the list, or on the waveform display.

Shift-clicking allows the selection of several items, even if they aren’t adjacent to one 
another. You can also “rubber band” select multiple adjacent files in the list.

To select all items, use Edit > Select All (Command-A).

You can also use the up/down cursor keys to select the upper/lower audio file or group, 
and the left/right cursor keys to show/hide the waveform display.

Audio Files
Selecting the Next Audio File
The Select Next Audio File key command selects the next audio file in the list.

Selecting the Previous Audio File
The Select Previous Audio File key command selects the previous audio file in the list.

Audio Files and Regions

Selecting Used Regions
Choosing Edit > Select used will select all audio files and Regions used in the song 
arrangement.

Selecting Unused Regions
Edit > Select unused selects all audio files and Regions that are not used in the current 
song arrangement. You can use this function at the end of a session or production, to 
delete any items that are not required (press Backspace to delete).
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Edit Commands
All standard edit commands are available in the Audio window. As usual, they only 
apply to the currently selected items (audio files or Regions).

The Cut, Copy, and Paste commands only apply to the exchange of items between two 
different songs. An audio file can only appear once in a song’s list of audio files, and 
therefore, cannot be copied within a song.

Cut
The selected audio files or Regions are cut, and moved to the Clipboard. They are 
removed from the Audio window. (key command:  Command-X).

Copy
The selected audio files (and their associated Regions) are copied to the Clipboard. 
They remain in the Audio window. (key command:  Command-C).

Paste
The contents of the Clipboard are added (provided it contains audio files and 
associated Regions from another song). (key command:  Command-V).

Clear
Any selected audio files or Regions are deleted. You can achieve the same effect by 
pressing Backspace.

Note:  The Cut or Clear functions do not delete audio files from the hard disk, they 
simply remove them from the Audio window of the current song. If (whole, or portions 
of ) audio files are being used as Audio Regions in the Arrange, they will be deleted 
from the Arrange window as well.

If you actually want to delete the selected audio files from the hard disk, select Audio 
File > Delete File(s).

Undo
Reverses the previous command (key command:  Command-Z). 

Not all actions can be reversed with Undo. Any function that cannot be undone will 
warn you of this before executing the function.

Regions
Creating a Region
Select the desired audio file, and choose Audio File > Add Region. The new Region will 
appear after the existing Regions in the list.

Copying a Region
If you select an existing Region, and use the Add Region function, a cloned Region is 
created.
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Deleting a Region
You can use the Eraser tool to delete one or more Regions. If any of these Regions exist 
in the Arrange window, they will be removed as well. You should, therefore, be careful 
when using this tool. The Undo function is always available, however, should you 
inadvertently remove a required Region.

You can also delete any selected Regions by pressing Backspace.

Altering the Boundaries of a Region
You can directly alter the boundaries of a Region in the graphic display with the Region 
Edit (finger) tool. You can also use the normal mouse pointer. Just make sure that you 
grab the lower third of the Region when performing the following actions:

Moving the Start Point
To adjust the start point of a Region, grab the left border. The tool turns into a small 
hand pointing to the right. You can now adjust the start point.

Moving the End Point of a Region
To adjust the end point of a Region, grab the right border. The tool turns into a small 
hand pointing to the left. You can now adjust the end point.

Moving the Whole Region
You can also move an entire Region within an audio file, by grabbing it in the middle. 
The tool turns into two arrows pointing left and right. If the Region is very small, use 
the zoom function to enlarge the section. Make sure you can see the two arrows before 
making any alterations.

If you want to adjust the boundaries of the Region without moving the Anchor, hold 
down Option during the operation. This applies to moving the start or end points, as 
well as moving the whole Region.

Moving the Anchor
To move the Anchor, grab the small Anchor triangle below the Region. The tool turns 
into the Region Edit tool. A vertical guide line appears above the Anchor triangle. 

Snapping to Zero Crossings
If Edit > Search Zero Crossings is switched on, adjustments to the start or end positions 
of a Region are snapped to the nearest point where the wave form crosses the zero 
axis. This ensures “glitch-free” playback. When adjusting the startpoint, the area 
preceding the selected point is searched. When adjusting the end point, the area that 
follows the Region is searched. This option is useful when defining Regions in the 
Audio window.

Search Zero Crossings also applies to all operations in the Arrange window.
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Making Fine Adjustments
The graphic display in the Audio window is optimized for quick and simple 
organization of audio files and Regions. This involves displaying as many things as 
possible simultaneously in the window. Given this, the finest resolution for positioning 
the start and end pointers, or the Anchor, is limited to units of 256 samples. This is 
usually adequate, particularly if search zero crossings is switched on.

On occasion, however, you need to make precise adjustments—down to individual 
sample word level. Drum loops are a good example. The Sample Edit window is better 
suited to these situations. To open the Sample Edit window for a Region, double-click 
on it!

Protecting the Region Parameters
Regions can be “locked”, to protect against accidental alterations to the start and end 
points, or the Anchor position. The small lock symbol beside every Region can be 
opened and closed with a click. If locked, you can play the Region, but can’t edit it. This 
function should not be confused with delete protection:  A protected Region can still 
be deleted.

Renaming Audio Files and Regions
To rename audio files and Regions in the Audio window, just double-click the name in 
the audio list. A text input box will appear, allowing you to type in a new name.

The following warning appears when renaming files:  

Keep in mind other songs may use the same file! Do you still want to rename the file?

You should check if the audio file that you want to rename is used by another song. If it 
is, don’t rename the file, or it won’t be found or played by the other song.

Logic helps you in these situations:
• Logic alters the name of an audio file in all currently opened songs that use this file.
• If the file is half of a “split” stereo pair, Logic automatically assigns the new name to 

the other half of the (SDII) stereo pair.
• Logic also renames any backup files on the same drive.

If you rename a stereo file, Logic automatically assigns the new name to up to five files 
(both the mono files used in Logic, their backups and the stereo file). In this situation, 
it’s a good idea to store all files in the same location.

You can rename Regions whenever you like.

As long as Regions are named after their “parent” audio files, any renaming of the audio 
files is automatically carried over to their associated Regions.
Chapter 9    Audio Window 259



260

 

File Administration
Record File
Defining the Record Path
Every recording in the Arrange window creates a new audio file. To keep track of your 
recordings, you should tell Logic where the data is to be written before you start 
recording.

You can also define a file name for the audio files that are recorded—a kind of working 
title—which Logic will automatically keep using, by appending a series of numbers to 
the file name for each subsequent recording.

The path (folder) for audio recordings can be set individually for each song. 

Select Audio > Set Audio Record Path or open the Record menu (click-hold the Record 
button) to access these settings.

Use Audio Object Name for File Name
If this option selected, the name of the Audio Object is used as the file name for the 
recording.

Pre-allocate Recording Files
If this option is selected, Logic creates the audio file for the next recording when you 
record-enable the track. In addition, the audio file (buffer) for the next recording is 
immediately created at the end of every recording. This allows you to start audio 
recording more quickly.

Unused recording files are deleted when you quit Logic.
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Maximum Recording Time (Recommended): xxx Minutes
This parameter defines the maximum recording time for new audio files, in minutes; 
this determines the size of the temporary recording file. Before any recording can take 
place, a file large enough to hold it must be created on the hard disk.

You can switch this option off, which will create a record file with the size of all 
available free space on the currently selected hard disk.

Disadvantage:
• the audio file may be heavily fragmented, if the actual recorded file is much shorter 

than the pre-created recording file.

It is strongly recommended that you switch on this option, and set a maximum 
recording time.

If there’s not enough storage space available to accommodate the time you have set, 
the maximum length of the recording is temporarily reduced. During recording, the 
Record float window (the one with the red bar) will display the remaining time.

Global Record Path/Song Record Path
The Global Record Path was available in earlier versions. It is stored in Preferences, and 
applies to all songs. The advantage is that you don’t need to define a record path in 
every new song before you can record, provided that you don’t mind recording files for 
every song into the same folder.

The Song Record Path allows you to organize the audio recordings for each song into 
its own folder. The advantage is that when you switch from one song to another, any 
new recordings are automatically stored in the current song’s folder, without having to 
switch the path manually.

Set
This button can be used to define the path and the file name of the recording file. An 
incremental number is added to the name of every new recording. You can create a 
new folder (if required) in the dialog box.

To the right, you will see the current volume, and the remaining capacity (if the volume 
is registered). If you click-hold the volume, the entire path is displayed. This way you 
can see exactly which folder you are recording into.

You can change the path and name whenever you want, via the Set Record Path 
function.

When You Choose the Path Remember …
• If the hard disk used by the path leads is not connected or is switched off, the path 

will be deleted.
• If you rename the volume, Logic will not be able to find it.
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When You Enter the Recording Time Remember…
The display of the remaining memory and the maximum recording time depends on 
the following factors:
• the number of tracks that you want to record simultaneously.
• the sample rate.

If you are starting Logic for the first time, this display refers to recording a single mono 
track. After every recording, Logic makes any unused memory available for more 
recording.

It is always advisable to choose a much smaller value than the maximum possible 
recording time. If you don’t, there will not be enough space for further recordings, 
following the first recording. It’s good practice to set this value one minute higher than 
the longest single take you expect to record.

If you set a long recording time, and then increase the number of tracks, or change the 
sample rate, and there’s insufficient hard disk space, Logic will warn you via an alert.

Adding Audio Files
If you want to use an audio file in the current song, select Audio File > Add Audio File. An 
extended file selector box appears, allowing you to select one or more audio files.

Audio File Selector
Logic’s add audio files selector box offers the following features:
• Adding several files at once.
• Adding or removing all files in the folder.
• The cursor stays at the last position after you have added a file—subsequent files can 

therefore be added by pressing Return.
• Any files that have already been added are filtered from the view.

Auditioning audio files:
• Channel 1 of your audio hardware is used for playback.
• Playback can be stopped at any time.
• Playback is not stopped if you change the folder or volume.
• A short standby pause (a delay before the file can be auditioned) ensures that you 

can scroll quickly through folders.

Done adds all selected audio files to the song and closes the file selector box.

Drag & Drop Using Audio Files
The Drag and Drop functionality of Mac OS X is supported:  you can drag any selection 
of audio files directly from the Finder into an open Audio window.

The end result is exactly the same as using the Add Audio File function. It can save you 
time, especially with large multiple selections.
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You can also drag and drop audio files from the Finder directly into the Arrange. A 
corresponding entry will automatically appear in the Audio window.

Removing Audio Files
To remove an audio file from the current song, select its name in the Audio window 
and press Backspace. This does not delete the file from the hard disk.

MP3 Import
MP3 files may be imported into Logic by using the same methods employed when 
adding AIFF, SDII, or WAV files:  namely by Shift-clicking with the pencil tool in the 
Arrange, using the Audio > Add Audio File command, via the Audio File local menu of 
the Audio window, or by dragging MP3 files from the Finder into the Audio window or 
Arrange.

When you import an MP3 file, Logic converts it into an AIFF file, and it is the AIFF file 
that is used in Logic. Logic does this because many functions, such as waveform 
display, sample accurate editing, and so on, would overtax the CPU if Logic had to 
constantly decode and re-encode the MP3 files in real time for each change or edit. 
Logic ensures the most efficient use of resources by converting the MP3s to AIFF on 
import.

Deleting Audio Files
In theory, audio files are displayed and organized by the operating system in exactly 
the same way as all other Macintosh files. You can therefore delete or copy them in the 
Finder. This has the following disadvantages, however:
• If you delete an audio file, you may not know if it is needed in a song.
• If you accidentally delete audio files, Logic warns you of this when you load the song. 

In addition, there will still be items in the Audio window and Audio Regions in the 
Arrange window which originally referred to the missing audio file, and have 
therefore been “orphaned”. This detracts from a clear overview of the song.

For this reason, it is safer to delete redundant audio files in the Audio window. First, 
select the audio files that you want to delete. Be careful, because once files have been 
deleted, they are gone for good. You cannot use the Undo function to recover deleted 
audio files.

Select Audio File > Delete File(s). An alert message, informing you of the number of 
audio files about to be deleted, will appear.

Click Cancel to abandon the deletion process, or click Delete to permanently delete the 
files.

You should make sure that the files selected for deletion are not used in other songs.
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Further File Functions
Saving a Region as an Individual Audio File
If you want to create one (or more) independent audio files from selected Regions, use 
the Audio File > Save Region(s) as function. Use the file selector to choose the target 
folder for the new audio files. If you’re only editing one Region (or two paired Regions 
from a stereo recording), you can also enter a name for the new audio file. If you are 
editing several Regions simultaneously, it’s a good idea to name the Regions in 
advance, as the existing Region names will apply to the audio files derived from them.

A dialog box appears onscreen:

Add Audio Files to List of Audio Window? No/Add

If you want to add the new audio files immediately, confirm with Enter or Add. If not, 
click No.

There is a very similar function that allows you to convert selected Regions into 
individual audio files, accessible directly from the Arrange window.

Making Backups
The Audio File > Backup File(s) function stores duplicates of files in the same storage 
location as the original(s), with the extension “dup”.

Don’t forget the backup options that are available in the Sample Edit window.

Copying Audio Files
The Audio File > Copy/Convert File(s) function copies files to a different location on your 
hard disk (or other storage medium). When you copy a file, you can enter a new name 
in the file selector box (similar to the Save A Copy As command).

Logic checks if there’s enough space to copy the selected file(s) to the target location. If 
a file of the same name exists at the target, Logic asks whether or not you want to 
replace it. Logic also provides the opportunity to replace the audio file used in the song 
with the file that you just copied.

Moving Audio Files
The Audio File > Move File(s) function enables you to move audio files on your hard disk. 
Unlike the copy function, the source file disappears after the operation.

If the source drive/partition is the same as the target drive/partition, the files are simply 
moved to the other folder. This is a very quick and convenient way of organizing the 
drive and the song.

Example
Choose “Select Used” from the Edit menu of the Audio window (this refers to the files 
being used in the Arrange window), and move them to a new folder. This folder will 
only contain the audio files used by this song.
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Be very careful when using this function. A different song may use the same audio files. 
The next time you start the other song, you will need to locate the files that you have 
moved.

Logic updates the path information for all open songs that use a given audio file. This 
makes it easier to move (and reopen) audio files. Following the move of files to the new 
location, save all open songs to transfer/update all storage reference(s).

File Conversion and Exchange
Audio File Format Conversion
You can define the format of the destination file when you copy files using the Audio 
File > Copy/Convert Files(s) function.

All selected audio files can be copied into any of the following formats:
• …Original File Type:  The original format is used.
• …SDII File:  The copies are in the Sound Designer II format.
• …AIFF File:  The copies are in the Audio Interchange File Format.
• …Wave File:  The copies are in the “.WAV” format.

Convert to AAC or MP3:
There are also the two separate Audio File > Convert to MP3 and Audio File > Convert to 
AAC functions, which allow you to convert audio files to the AAC (MPEG Layer 4) or MP3 
format. A dialog will launch when either option is selected, allowing you to set the 
desired preferences. These conversions can be performed on one, or multiple, files.

When activated, a dialog will allow you to save a single file with any name. In cases 
where multiple files are being converted and saved, the existing file name will be used, 
with the appropriate file extension added—“partyman.aiff” will be converted to 
“partyman.mp3”. 

The default folder location for all saved files is the parent directory—the folder that 
contains the original files. This can be freely changed in the Save As dialog, prior to 
saving the files.

Exchanging Audio Files Between Mac and PC
When converting audio files to the Wave format on the Macintosh, or when converting 
AIFF files on the PC, you can use long file names.

Wave files can be directly played on the Macintosh, without problems, in Logic’s native 
Audio Engine. SDII Files can also be played on the PC, as long as the files are recorded 
at 16 Bit 44.1 kHz. It is generally recommended, when transferring files from Mac to PC, 
that you convert the files to Wave format (while still on the Mac), as the Resource Fork 
is lost in SDII files. (The Resource Fork contains detailed information about format, 
Sample rate and Bit definition).
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The use of DOS-formatted hard disks with your Mac OS computer is not recommended, 
as its audio performance is significantly worse than the performance of an HFS+ drive.

To transfer an entire Logic song from Logic Mac to Logic Windows, open the Audio 
window and copy all audio files onto the MS-DOS drive (or the PC network drive, if 
available) as .WAV files. The song file (exported as a Logic 4.8 song) itself can be read 
directly on both platforms.

Logic Windows will recognize a song created on a Macintosh, and looks for 
“FileName.WAV” instead of the original files.

Likewise, to transfer from Logic Windows to Logic Mac, you need to export the audio 
files onto the Mac/HFS+ drive. Logic Mac will first look for “FileName.AIF” files, and then 
for “FileName.WAV” files, which are used on the PC.

Store the Logic song file in the same folder as the audio files. This will allow Logic to 
find the audio files immediately after loading.

Split and Interleaved Stereo Formats
The internal structure of multi-track hard disk recording systems is such that each 
individual audio track can be dealt with independently. Accordingly, a separate audio 
file is created for each track.

Logic creates single files containing both channels of a stereo recording. This is called 
the “interleaved stereo format”. These are composed of a Region consisting of small 
alternate data packets from both tracks. Logic can record files directly in the interleaved 
format, giving stereo files recorded in Logic instant compatibility with other mastering 
or CD recording applications. Please note that not all hardware and driver models are 
compatible with this format, so all files recorded on these systems will be in the split 
stereo format. Please read more about this topic in the Universal Track Mode section.

Special Features of “Split” Stereo Files
There are a few special features for dealing with “split stereo” sound files:
• In the file selector box, “split stereo” audio files are treated as a single file, even 

though strictly speaking, they are two independent files.
• In the audio list you can see both files. They have the same name—apart from the 

channel markings (L and R). If you rename one channel of a stereo audio file, the file 
for the other channel is automatically renamed as well. 

• Their Regions can also be renamed.
• If you use the Add Region command to create a new Region, Logic does this for both 

audio files.
• Any alteration made to either Region is automatically transferred to the other Region. 

This applies to the start point, end point, and position of the Anchor.
• If either of these Regions is moved into the Arrange window, the other Region is also 

moved.
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Converting Different Split Stereo Formats
Logic treats audio files with a name that ends in “.L” or “.R” as stereo files. These “name 
extensions” are used by ProTools, Session, or SoundDesigner II to identify “split stereo” 
files. Logic’s file management functions, such as Rename, Create, or Revert to Backup can 
also identify these name extensions.

Manual Stereo Conversion
Convert to SDII Stereo
This command converts two (split-stereo) audio files into a single stereo file—in the 
SDII format. This is useful if you want to edit a “split stereo” file using a different 
program, such as CD mastering software.

Select the audio files and choose Audio File > Convert to SDII Stereo. Keep in mind that 
this only works for split stereo files. You can’t use Convert to SDII Stereo to combine 
two mono files into a stereo file.

Logic automatically stores converted SDII files in the same location as the original split 
files (provided that there’s enough room on the drive).

Convert to AIFF Stereo
Split stereo files can be converted into an interleaved stereo file—in the AIFF format—
by using the File > Convert to AIFF Stereo command.

Other Functions Involving Audio Files
Reassigning Audio Files (Update File Information)
If Logic cannot find one or more audio files—when opening a song, for example—the 
Regions are shown as “blank” gray areas in the Audio window.

If the files are available under a different name, or you want to assign a “replacement” 
file, you can do so as follows:
• Double-click the relevant Region, or select Audio File > Update File Information.
• Select Locate in the dialog, and a file selector box opens, allowing you to load the 

desired audio file. 

What to Do if Logic Cannot Find an Audio File
Sometimes, Logic can’t find a file which was previously used in the song. This could be 
due to one of the following:
• You have not connected the relevant hard disk, or you have renamed the volume.
• You have stored the files in a different volume, or moved them to another volume.
• You have renamed the files in the Finder, or renamed them in the Audio window of 

another song.
• You have deleted the files.

In these situations, Logic launches a dialog box. You can respond in any of the 
following ways:
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Search
The current volume is searched for filenames. If the search is unsuccessful, Logic asks 
you if you want to search other volumes for these files. This enables you to assemble 
songs, even if you have copied or moved the relevant files onto other media.

Skip
(Don’t search for this file). Use this function if you know that this audio file no longer 
exists, or was renamed. This button changes to “Skip All” if further audio files aren’t 
found.

Skip All (for Several Files)
(Don’t search for any more files). Use this function if you know that all audio files in this 
song no longer exist, or have been renamed.

Manually
You can manually define where to search for the file. A file selector, containing the 
names of the audio files being searched for, appears onscreen.

If more than one file with a matching name is found, you can select the correct file in a 
dialog box.

Further Options
Setting the Sample Rate
Logic performs a real time, native sample rate conversion. Any sample rate available in 
Logic (via Audio > Sample Rate) can be used for the conversion—even if your audio 
hardware does not support the selected sample rate.

The native software sample rate conversion facility matches the sample rate of any 
audio hardware, thereby allowing the playback of projects on virtually any audio 
system—even if the hardware is—in sample rate terms—not compatible. Nothing is 
lost in the process. Any internal processing and bouncing is always performed at the 
original sample rate, and at the highest quality, even in cases where the hardware does 
not support a particular sample rate. This facility allows you to work on projects 
originally created on high-end audio systems, with smaller setups.

Example:

A song was created with an audio hardware/setup at 96 kHz. Moving this project to a 
laptop, or setup that does not support the original project’s sample rate, will commonly 
result in the wrong playback speed. The native realtime sample rate conversion facility 
will counteract this effect, allowing correct playback of the project on the laptop, at any 
sample rate.

High sample rates not only eat drive space, but also result in more CPU load, because 
everything has to be handled in half the time.
Chapter 9    Audio Window



 

Varipitch/Varispeed Synchronization
The real time sample rate conversion facility allows Logic’s audio engine to follow an 
external MTC signal (“MTC continuous”), while maintaining the correct playback pitch 
and speed. This even works when recording in MTC-slave mode.
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10 Audio Drivers
To use particular audio hardware with Logic, the 
hardware’s driver needs to be activated and configured 
correctly. This chapter explains how this is done.

Drivers are software programs used to enable various pieces of hardware and software. 
This allows them to be recognized by other computer programs, and to have the 
appropriate data routed to and from them, in a format they can understand.

Selecting, activating, and configuring a particular audio driver in Logic is achieved via 
the Audio > Audio Hardware and Drivers dialogs. 

The Audio Hardware and Drivers Dialog

In Mac OS X, all audio devices are accessed via Core Audio, an integral part of the 
operating system. Core Audio is a flexible, high-performance, low-latency audio system, 
which allows access to multiple audio hardware devices from several audio applications 
at the same time. Logic is compatible with any audio hardware which has a Core Audio 
driver. All information about using Logic with Core Audio hardware can be found in the 
following section. 

Core Audio
Logic automatically recognizes any installed Core Audio hardware, and will use the 
default settings—defined in Mac OS X’s Audio MIDI Setup utility (Applications > 
Utilities > Audio MIDI Setup). It can, however, be advantageous to optimize the settings 
for your individual hardware setup, particularly if you use several sound cards or a multi 
I/O card. This can be done in Logic’s Core Audio pane, which offers the following 
options:
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Enable
Click this box to enable the Core Audio driver. 

Note:  In situations where the preferred hardware is unavailable, such as when opening 
a song created in the studio on your PowerBook, or your audio interface is not 
connected or turned off, Logic will automatically select the built-in audio hardware of 
your Macintosh.

Driver
Allows you to choose between any Core Audio Driver installed in your system, 
including the internal sound output.

I/O Buffer Size
This parameter determines the size of the buffer used by the audio hardware—for both 
input and output. Options range from 1024 down to 32 samples. The smaller the buffer 
size, the less “latency” you will encounter when monitoring while recording, or using 
software instruments. 

Note:  There may be a point where the selected I/O Buffer Size is too small for your 
system, and begins to affect playback. This usually takes the form of clicks, pops, and 
crackles. You should therefore aim for the lowest possible I/O Buffer Size value that 
doesn’t introduce these types of artefacts.

As this parameter value is reduced, it places a higher strain on the CPU(s) of the system. 
On current model Macs, you should be able to reduce this value down to its minimum 
value. As a word of advice, if you find a higher (larger) I/O Buffer Size setting provides 
suitably low latency during record monitoring and software instrument playback, you 
should use it. This will minimize the impact on the CPU(s) of your system.

Recording Delay
This parameter is measured in samples. It allows the recording of Audio Regions to be 
delayed by a certain fixed value. It helps advanced users to compensate for any 
incorrect delay information that might be caused by the audio driver. You should not 
normally need to touch this parameter.

Max. Number of Audiotracks
The Audio Engine requires free system memory, which is not assigned to Logic or any 
other application. The amount of memory required depends on the maximum number 
of tracks to be played, and on the number of I/O channels supplied by the driver. This 
setting allows you to reduce the amount of memory required by the driver, by reducing 
the number of tracks. This may be useful when you want to run other applications or 
drivers simultaneously.
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Universal Track Mode
Universal Track Mode allows you to play back adjacent stereo and mono Regions on a 
single track. Even-numbered Audio Objects won’t be regarded as the right channels of 
the odd-numbered stereo Audio Objects to their left, and every Audio Object has its 
own mono/stereo switch. Dependent on whether a mono or stereo Region is played 
back, the pan knob will behave as a Balance or Pan control. If you play back a mono 
Region and the pan is set to the center position, both channels of the Audio Object will 
output the same signal level. Universal Track mode is not switchable in Logic Express.

Larger Disc Buffer
This option influences the amount of audio data that is read from the disk in advance. 
This option is switched off by default, matching the demands of fast hard drives and 
powerful computers. If you encounter frequent error messages while running Logic in 
this mode, you should switch this setting on. This will allow you to play back more tracks, 
achieving higher reliability. Please note that RAM requirements are increased if this 
option is active.

24 Bit Recording
When this setting is active, Logic can record 24 bit files. Please note that this only 
makes sense if you are actually using a 20 or 24 bit interface. As long as your audio 
hardware is capable of this bit resolution, you can select this option in the Audio > 
Audio Hardware & Drivers window. 20 or 24 bit recordings offer a significant 
improvement in the available dynamic range, but require high quality peripheral 
components such as microphones, preamps, and high quality AD/DA converters. 24 bit 
files use one and a half times the disk space of comparable 16 bit files.

Software Monitoring
This option allows you to switch Software Monitoring (listening to the actual input 
signal) on or off. Please note that with Software Monitoring active, the audio signal is 
processed via software—a certain amount of audible delay (commonly referred to as 
“latency”) is inevitable. If you are listening to the recorded signal through your mixing 
desk, or your audio hardware supports hardware monitoring, you should switch this 
option off.

Process Buffer Range
This parameter determines the size of the native buffer used to compute mixes and 
effects. Choose between Small, Medium, and Large buffer sizes. 

Note:  Larger buffer sizes will increase latency. Dependent on CPU speed, buffer sizes 
that are too small might compromise real time audio processing.
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ReWire Behavior
When sending MIDI data to a ReWire compatible software instrument, you can choose 
between four modes:
• Playback mode:  use when playing back MIDI tracks via ReWire. This setting requires 

less CPU power.
• Live mode:  use when playing a ReWire instrument live. This settings requires more 

CPU power.

Audio Engine
The Audio Engine is the part of Logic that processes and controls all audio data for 
playback, recording, mixing, and effects.

All descriptions of the audio functionality in this manual are based on the Native Audio 
Engine. Settings for different Audio Driver Models are nearly identical. This engine 
performs a realtime, native Sample Rate Conversion.

Realtime Sample Rate Conversion
Any Sample Rate (Audio > Sample Rate) available in Logic can be used in the Native 
Audio Engine—even if your audio hardware does not support the selected sample rate. 
Nothing is lost in the process. All internal processing in Logic, including bouncing, is 
performed at the original song sample rate (Audio > Sample Rate), and will be 
performed independently of the sample rates supported by the audio hardware. Logic 
automatically uses the best matching sample rate supported by your hardware for 
playback. 

This facility allows you to work on projects originally created on high-end audio 
systems, with smaller setups.

Example:
A song was created on an audio hardware/setup at 96 kHz. Moving this project to a 
laptop, or setup that does not support the original project’s sample rate, will commonly 
result in the wrong playback speed of the audio files. The real time software sample 
rate conversion facility will counteract this effect, allowing correct playback of the 
project on the laptop, at any sample rate. You can start a Logic project in the studio, 
continue on your laptop, and return to the studio with the new material.

Note:  The set sample rate also applies for recording. As an example, if your audio 
hardware supports sample rates up to 48 kHz, but the song is set to 96 kHz, Logic will 
generate audio files at 96 kHz. You should be aware that the audio quality is not 
improved in the process. The quality of audio is still at 48 kHz, as determined by the 
recording hardware, despite the fact that the information is stored in a large 96 kHz file. 

Important:  Using higher audio sample rates often increases CPU load significantly.
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11 Sample Editor
The Sample Editor is used to perform extremely precise 
destructive edits on audio files.

The Sample Editor features a number of useful processing tools—collectively known as 
the Digital Factory. These allow you to time stretch and pitch shift audio and change 
sample rates.

Sample Editor—Introduction

The Sample Edit window offers an enormous number of data-editing functions, which 
are used to process individual audio files. You can edit mono, as well as stereo files.

You can set the lengths of Audio Regions with extreme precision (down to single-
sample resolution), by making use of the window’s adjustable zoom resolution. The 
Anchor points can also be positioned here, with the same degree of accuracy.
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Opening the Sample Edit Window
There are various ways of opening a Sample Edit window:
• Select Audio > Sample Editor.
• Press Command-0.
• Double-click on any audio Region in the Arrange window; this opens the selected 

Region in the Sample Editor.
• Double-click on any Region in the Audio window.

If no Region is selected, Logic will ask if you’d like to load a new file into the Sample 
Edit window.

If you’re dealing with an interleaved, or half of a “split stereo” file or Audio Region, both 
channels/audio files will be displayed in the Sample Edit window, with the left side on 
top, and the right side below.

If you open the Sample Edit window from the Arrange window, as opposed to the 
Audio window, the Bar Ruler is able to reference the Region’s position in the song. You 
can tell all of this from the position marker lines in the Bar Ruler. A dotted line indicates 
no time connection (Audio window), while a broken line indicates a time connection 
for the Region being used in the Arrange window.

Elements of the Sample Edit Window
• The small waveform display at the top is the overview; the entire audio file is 

depicted here.
• The dotted frame in the overview shows the extent of the section visible in the 

display area.
• The Parameter box in the upper left corner below the overview shows the start point 

and length of the selected area.
• When the Catch (“walking man” symbol) button is activated, it ensures that the 

playback position is always visible in the window. The other controls operate as in 
the Audio window.

• In the center, you’ll see the main contents of the Sample Edit window:  the detailed 
waveform display.

• Left of the detailed waveform display is the Amplitude Scale (as a percentage, or 16-
bit decimal values). 

• The dotted line in the waveform and overview display is the Playback position line.
• The zoom bars are used to set the magnification of the detailed waveform display.
• The horizontal time ruler above the detailed waveform shows the name of the edited 

Region at the top left. 
• Beneath that is the time position of the Region in the audio file, in various formats.
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Display
Waveform Overview

Between the Sample Edit window’s title strip and Bar Ruler, you’ll see the overview. This 
display always shows the full length of the currently selected audio file, regardless of 
the zoom resolution. Please note that the overview is not scaled; a kick drum sample 
lasting 0.3 seconds could take up the same space as a choral passage lasting 15 
minutes.

During playback, the current position is indicated by a vertical line that moves in real 
time. This is visible in both the overview and the detailed waveform display.

The current selection is also displayed in the overview.

The section visible in the detailed waveform display is shown as a dotted rectangle in 
the overview.

Functions in the Overview
• A short mouse click on the overview displays the clicked area in the detailed 

waveform display.
• A long click resumes playback from this position. Releasing the mouse button stops 

playback.
• Double-clicking lets you listen to the sample from the clicked position.

Window Functions
The Catch and Link functions work in pretty much the same way as in the other edit 
windows.

Catch Mode
Catch mode ensures that the Sample Edit window always displays the area around the 
current playback position (whether you are playing the song, or monitoring the 
sample). Catch is turned on and off by either clicking the “walking man” button, or with 
a key command.
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Link Mode
Link mode ensures that any Audio Regions selected in the Arrange window are 
displayed in the Sample Edit window. Link mode is turned off and on by clicking the 
“linked chain” switch, or the corresponding key command.

If you often work in Link mode, give this a try:  open a Sample Edit window and switch 
on Link mode. Now close the window, and Logic will retain this status.

Double-click on the Region you wish to view, and you’ll see that the display in both 
windows is linked.

The Detailed Waveform Display
Display Scale
Zoom Bars
The Zoom Bars work as they do in all other windows.

The Zoom Tool
Just as in the other windows, there is a zoom tool in the Sample Edit window’s Toolbox 
(the magnifying glass). If you use this tool to draw a rectangle, the selected area of the 
window will be magnified so that it fills the whole display area. Clicking once (with the 
tool) returns you to the previous zoom resolution.

If you hold down Command as you click the Bar symbols with the mouse, you can alter 
the vertical and horizontal zoom simultaneously.

X and Y Axis Scales
The Y axis vertical scale shows the waveform amplitude in percentage units (View > 
Amplitude Percentage). If you select View > Amplitude Sample Value, the scale will be 
displayed in sample units.

The X axis (the time ruler) shows the course of the audio file over time. You can select 
various scaling units in the View menu.

Don’t forget that this display format also affects the figures shown in the help tag, and 
the selection parameter field:

View > Samples
Displays the sample word number from the beginning of the song or audio file.

View > Min:Sec:Ms
Shows the scale in Hours:Minutes:Seconds:Milliseconds, from the beginning of the 
song or audio file.
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View > SMPTE Time
Shows the scale in SMPTE time (in Hours:Minutes:Seconds:  Frames). The time scale 
begins at the song start point (with the SMPTE offset, if applicable). When you use this 
scale, the absolute SMPTE value of the source clock is shown on the X axis.

View > Bars/Beats…
Shows the scale in Bars, Beats, Divisions, and Ticks, just like the Bar Ruler in the other 
time-related windows. The “zero point” is represented by “1 1 1 1”, but lengths are 
measured from “0 0 0 0”.

Absolute and Relative Time
The different axis scales in the Sample Edit window can be displayed relative to two 
different reference values:
• by reference to the time axis of the song (absolute position)
• by reference to the beginning of the audio file (relative position).

Relative Position
The units in the time axis (between the overview and the waveform display) are 
displayed with dotted lines when viewing the relative position. You will be in this mode 
if you open the Sample Editor from the Audio window, or if the Sample Editor is in Link 
mode, and you select a Region in the Audio window.

The beginning the section is automatically assigned the to the zero value, or in Bar/
Beat terms, “1 1 1 1”.

This does not necessarily match the actual song position. The calculation of all 
remaining musical sections uses the current song tempo.

Absolute Position
You can recognize this format by the broken line below the units in the time axis. You 
will be in this mode if you open the Sample Editor from the Arrange window, or if the 
Sample Editor is in Link mode, and you select a Region in the Arrange window.

Time is measured from the start of the song, which is assigned a value of zero (or 1 1 1 
1 in Bar/Beat terms). In this instance, the time axis shows the absolute (song) time, and 
the figures do not refer to the audio file.
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Display Waveform as Sample Bits
You can switch from the usual representation of the waveform, to one that shows the 
structure of the recorded digital data, at high magnification levels on the detailed 
waveform display. You do this by selecting View > Show as Sample & Hold. This can be 
useful when eliminating clicks and pops from your recordings, for example.

Thanks to the clever use of oversampling techniques and lowpass filters at the D/A 
conversion stage, the stored sample bits (on the right) are ultimately converted into a 
signal waveform, more like the one shown to the left.

The Sample Edit Window in Use
Monitoring Sample Playback
Monitoring Sample Playback

There are various ways to play back the audio sections visible in the Sample Edit 
window, allowing you to hear audio during edits. Playback occurs independently of the 
song position. If you’d like to hear the selected audio passage in the context of the 
song, just use the Transport controls, as usual.

Selecting the Audio Output
The small boxes below the loudspeaker symbol allow you to select the output channel 
that you want to use for monitoring.

Set the number of the desired output in the Channel box under the loudspeaker 
symbol. 

Playback From the Overview
Monitoring playback from the overview display is performed in exactly the same way 
as Regions in the Audio window. Simply click-hold at the point you want playback to 
begin. Releasing the mouse causes playback to stop. You can also start monitoring 
from any position by double-clicking on the overview.

Playing the Current Selection
To play back the current selection, click on the loudspeaker switch. You can also 
perform this function with the Play/Stop Selection key command.
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Playback From a Certain Position
If you double-click at any position on the time axis, the audio file will play back from 
this point, to the end of the current selection. If you double-click on a point beyond the 
selected area, the audio file will play until its endpoint is reached.

Checking the Position of the Anchor
The Play/Stop Region to Anchor and Play/Stop Region from Anchor key commands allow 
you to check the Region Anchor position, by listening to the parts just before and after 
the Anchor.

Cycle Playback Mode
You’ll find the Cycle button on the left-hand side of the Sample Edit window, just above 
the Loudspeaker button. If you turn this on, the currently selected audio section will 
cycle continually when playback is engaged.

You can change the start and end points of the selected area while monitoring it in 
cycle playback mode. This makes it easy to edit the start and end points of (say) a drum 
loop, until it loops perfectly. When you’re satisfied, you can turn the selection into a 
new Region with the Edit > Selection > Region function.

Playing Regions
In general, you can only play currently selected parts of files from within the Sample 
Edit window. There is, however, a key command that toggles between playback of the 
whole Region and stop—regardless of the selection. This key command is called Start/
Stop Region.

When you open the Sample Editor by double-clicking on a Region, it will automatically 
be selected in the Sample Editor. The same thing happens when you click on a Region, 
while the Sample Editor is in Link mode.
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GoTo Commands
The scroll bars along the bottom and right edges of the Sample Edit window scroll 
through the detailed waveform display in the usual way. 

If you’re trying to reach a specific point in the audio file, some of the keyboard short-
cuts listed below may be of use to you. You can define your own keystrokes for these 
commands in the Key Commands window (see “Key Commands” on page 36).

These commands move the corresponding point to the center of the waveform display.
• Goto Selection Start
• Goto Selection End
• Goto Region Start
• Goto Region End
• Goto Region Anchor

Making Selections
Selecting the Whole Audio File
You can select the entire audio file with the Edit > Select All function, or Command-A.

Manual Selection
To select a particular section of an audio file, click-hold on the start or end of the area 
you want to select, and move the mouse to the right or left.

To Change the Boundaries of a Selection
Shift-clicking on a selection changes its existing start and end points. The proximity of 
your click to the beginning/end of the selection determines whether you change the 
start point or end point boundary. The closest one wins…

Changing the Farthest Selection Limit
If you hold down Option-Shift, the more distant selection boundary is changed (rather 
than the nearer). 

Moving a Selection
Option-click, and dragging shifts the whole selection, without changing its length.

The Selection Parameter Box
The start point and length of the current selection are shown in the Selection 
Parameter box. The format depends on the display setting in the View menu.
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The start point and length are displayed in a separate help tag while making a 
selection. The format is sample words.

The Relationship Between Selections and Regions
When you open the Sample Edit window by double-clicking on a Region, the Sample 
Edit waveform display will open with the entire Region selected. Changing the 
selection has no direct effect on the borders of the actual audio Region. The playback 
monitor only plays back the current selection.

Logic offers two functions that govern the interaction between selections and audio 
Regions. These will allow you to create and edit Regions with the minimum of fuss.

Selecting the Region
The Edit > Region→ Selection function selects the entire Region, currently shown in the 
Sample Edit window. The current Region is the one selected in the Audio window (or 
the Audio Region selected in the Arrange window).

This function is useful if you want to reselect the entire Region for cycled playback, 
after performing a number of edits, for example.

Turning a Selection Into a Region
If you want to turn your current selection into an audio Region, use Edit > Selection → 
Region. This enables you to define an audio passage as a selection, and then convert it 
to a Region, in place of the originally selected Region.

Creating New Regions
To define a new Region from an area you’ve just selected, select Edit > Create New 
Region. You can define this function as a key command.
Chapter 11    Sample Editor 283



284

 

Editing Regions in the Sample Editor
If accuracy is what you need, you should edit the start and end points of Regions in the 
Sample Edit window, not the Audio window.

The same goes for any adjustments you make to the Anchor, which in many cases 
should really be placed on the amplitude peaks, rather than at the start of the attack 
phase of the sound. A good example would be recordings of brass instruments, which 
may take some time to build to a peak. Moving the Anchor to these peaks forces the 
Region to snap to the grid of your arrangement, using the Anchor as the pivot point. 
The flexible zoom settings allow you to be as precise as you like, going right down to 
the level of single bits, at the highest magnification factor.

Important:  Be careful! Any changes to the Anchor point will change the relative 
position of the audio Region in the song. Given that the front of a Region is the default 
position for the Anchor, you must also take care when changing a Region’s start point.

The small markers on the lower edge of the waveform display provide direct access to 
the boundaries of the Region and the Anchor. As usual, you can just grab them, and 
pull.

• S = Region Start
• E = Region End
• Triangle = Anchor

Protecting the Anchor Point
If you move the start or end points of a Region past the Anchor point, the Anchor point 
will also move. This is often not what you want to happen.

Hold down Option while moving the start or end markers to prevent the Anchor from 
moving. Keep in mind though, that the Anchor can never be to the left of the Region 
start point, so it will move if you drag the start of the Region past the Anchor (to the 
right), even with Option pressed.

Search Zero Crossings
If this editing option is switched on, Logic will search for the nearest point where the 
waveform crosses the zero amplitude axis whenever the start or end points of a 
selection are changed. This avoids glitches in playback. The program looks for zero 
crossing points just before the start point, and beyond the end point.
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Editing Commands
The Sample Edit window features the usual Cut, Copy, Paste, Clear, and Undo commands 
in the Edit menu (or from the keyboard).

All of these commands (except Copy) actually change the data of the audio file itself; in 
other words, they behave destructively. 

Cut
Cuts a selected passage out of an audio file, and copies it to the Clipboard. All following 
audio sections move forward to fill the gap.

Copy
Copies a selected passage to the Clipboard, leaving the selected area in its original 
location.

Paste
Inserts the contents of the Clipboard at the cursor position, or start point of the 
selection. If there is no selection available, the cursor acts as the paste point (it is 
shown as a thin dotted line). If audio data is present behind the paste point, it is moved 
back to make room for the Clipboard contents. If anything is selected at the time of the 
paste, it is deleted and replaced by the Clipboard contents.

Clear
Erases the selection, without placing it in the Clipboard. All data beyond the deleted 
passage is pulled forward to fill the gap.

Undo
Cancels any edit commands used, and reverses its effect. This also works with the 
destructive editing commands (see “Functions” on page 288).

The Undo function in the Sample Editor operates separately from the rest of the 
program (see next section). This allows you to try out the edit in the Arrangement. If 
you don’t like it, you can return to the Sample Editor, and reverse the edit with the 
Undo function.

Space is reserved on the hard disk for armed tracks, which is not available for undo 
files. Logic therefore automatically switches off record-ready status for audio tracks if 
the disk is nearly full, thereby making edits possible in the Sample Editor.

Sample Editor Undo Preferences
Several options that accompany the Sample Editor’s multiple undo functionality can be 
found in the Audio preferences:
• Record “Normalize” in Undo History—disable this parameter if you don’ want to create 

any undo files once the Normalize function is invoked. 
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Note:  As normalization is generally the last step in sample editing, this parameter (if 
active) can destroy the undo history. As a safety feature, a warning pops up if an undo 
history exists (and the switch is on), providing you with the opportunity to create an 
undo file.

• Number of Undo Steps—limits the maximum number of recorded undo steps. Use the 
mouse as a slider to adjust the step value.

• Store undo files in Song Folder—switch this parameter on if you would like the undo 
history to be stored in a sub-folder alongside the song.

Note:  This is switched on by default if the song is part of a project (see “Projects” on 
page 51).

• Global undo file path—all undo history files are saved into a “global” location (a user-
defined folder) if the Store undo files in Song Folder option is not switched on.

Backup Copies
Automatic Backups
Logic will ask you if you wish to make a backup copy of the file you’re working on 
(unless one already exists), before you perform a destructive edit in the Sample Editor.

Activate the No Dialog button to avoid this question being asked again, while editing in 
the current window.

You can even turn off the dialog altogether in the Audio > Audio Preferences. In this 
situation, you’ll only be asked when the program is first loaded, and when you make 
your first edit. You can reply as follows:

Process
No backup is made and the edit is performed. You won’t be asked the question until 
the next program launch.

Cancel
Stops the edit.

Preferences
Opens the Audio Preferences window, allowing you to reactivate the Backup dialog 
box, so that it appears every time you attempt a destructive edit.

Manual Backups
You can make manual backups of the file you’re editing, or replace it with a backup 
version at any time—using a variety of functions:

Audio File > Create Backup
Creates a duplicate of the audio file you’re working on (with the extension “.dup”), and 
places it on the same level, in the same folder.
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Audio File > Revert to Backup
This function completely replaces the current audio file with the backup (provided one 
exists, of course). A warning message informs you of the creation date of the backup 
file, before the current file is replaced.

You cannot reverse this function with Undo.

Audio File > Save A Copy As
Copies the current audio file to the location of your choice.

Audio File > Save Selection As
Saves the current selection as an independent audio file. You can choose whether you 
wish to bring the file into the Audio window, following the save.

An interleaved stereo file is created when the source file is an interleaved stereo file.

Update Arrange Position
Edit > Update Arrange Position, when engaged, means that altering the Region start 
point (or, more specifically, the Anchor position) in the Sample Editor also affects the 
position of the Region in the Arrange window. This ensures that the position of a given 
audio Region stays at the same place in the arrangement. When moving the Region 
start point back, the remaining portion of the Region will start playback at a later 
position.

Such edits have always been possible with Logic—but you needed to alter the start 
point of the Region in the Arrange window. The Update Arrange Position option allows 
you to make these edits more precisely in the Sample Editor, without changing the 
position of audio in the Arrange. This is dependent on the Region start and Anchor 
points being set to the beginning of the audio file (so that dragging the Region 
startpoint also drags the Anchor). 

This is the most common scenario:  Anchor and Region start are always at the 
beginning of the audio file, whenever you record audio or add an audio file. Moving 
the Region start also moves the Anchor, as the Anchor can not precede the Region’s 
start position.
• If Update Arrange Position is engaged, moving the Anchor won’t change the audible 

result. The movement of the Anchor in the Sample Editor and the new position in the 
Arrange are automatically compensated for. Moving the Region start in the Sample 
Editor will lead to the same result as dragging the Region startpoint in the Arrange 
window. This is the default setting.

• If Update Arrange Position is disabled, moving the Anchor changes the position of 
audio Regions in the Arrange window. 
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Functions
This section describes various Sample Edit window functions that are ideal for polishing 
audio recordings. You can use these to add the finishing touches to your work.

Each of the commands only affects the currently selected portion of audio. If you want 
to use them to alter the whole audio file, use the Select All function beforehand.

All of the functions described in this section are destructive, and change the files stored 
on your hard drive. You can, of course, use the Undo function.

As the Undo function in the Sample Editor works independently of the rest of the 
program, you can try out an edit in the Arrangement and make changes there. As soon 
as you open the Sample Editor again (or bring it into the foreground), the Undo 
function is available for the last destructive sample edit.

You are asked to confirm these functions as a safety measure. This confirmation dialog 
box can be turned off by selecting Audio > Audio Preferences > Warning before process 
Function in Sample Edit (Menu).

Data altering processes can be cancelled while underway by pressing Command-
period. The audio file will be retained in its original state, even if it appears that a 
portion of the editing function has occurred.

Normalize
Normalization is a process that raises the maximum level of a digital signal to a certain 
amount—typically to its highest possible level, without introducing distortion. 
Normalizing is activated by selecting Functions > Normalize.

This is done in the following way; Logic finds the point with the highest volume (−x dB) 
in the currently selected audio, and determines how far this is from the maximum 
possible level. The level of the whole selection is then raised by this amount. The 
dynamic balance of the audio passage remains unaltered—it merely gets louder.

The start and end points for the section being normalized should generally not fall 
within a continuous section of audio, as this will result in abrupt increases in volume 
after normalization. The start and end points should therefore be located in sections 
that also contain pauses. Occasionally, you should remove any unwanted, audible 
noises that fall in musical gaps with the aid of the “Silence” function.

Change Gain
You can use Functions > Change Gain to raise or lower the level of an audio passage by 
a specific amount.

A dialog box appears onscreen, allowing you to set the required level change in 
percent (Change relative:) or decibels.
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If you click on Search Maximum, the highest peak level is determined, and a value is 
then calculated for use when normalizing the audio file.

results in absolute:  displays the maximum level that will be achieved by changing the 
gain (by the amount shown in the Change relative:  box).

You should never make a gain change that results in a value over 100%, as this will 
result in digital clipping.

Click Change (or press Return) to perform the gain change.

Fade In/Out
Fade In
Functions > Fade In creates a fade in. You can set up the fade-in time period directly in 
the currently selected audio. Volume is set to zero at the left start point of the selection, 
and the fade-in occurs over the length of the selection.

Fade Out
Functions > Fade Out works in the same way as fade in, except that the fade works in 
the opposite direction. This lets you fade passages out automatically. This function is 
destructive.

If you use the Silence (see “Silence” on page 289) function to remove unwanted 
background noise from silent passages, small jumps in volume can sometimes appear 
at the start and end points of selections, as well as on the edges of the audio signal. In 
this situation, zoom in, and select a small area surrounding (just before and after) the 
startpoint of the signal, then use the fade-in function.

Silence
You can use Functions > Silence to remove all data from a selected area. The waveform 
material contained in the selected audio passage and the corresponding amplitude 
values are all set to zero. You can use this function to silence unwanted background 
noise in quiet passages.

Invert/Reverse
Invert
Functions > Invert completely reverses the phase of all currently-selected audio material. 
All negative amplitude values become positive, and vice versa. While this doesn’t 
audibly change the file, if heard in isolation, you can use Invert to correct phase 
cancellation errors, particularly if you’re mixing down to mono. This is extremely useful 
when several out of tune signals (or several signals processed through chorus effects), 
are to be mixed down to mono. The process depends heavily on the audio material.

You can also use the Invert function to decode MS recordings, but it’s far easier to use 
the DirMixer plug-in for this task.
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Reverse
Functions > Reverse reverses the selected audio passage.

Trim
Functions > Trim erases all Regions that aren’t selected. Use it to remove unimportant 
passages from the start and end of your audio files.

Make sure that the areas you are about to delete do not contain any Regions that you 
may need. Regions outside the selection will be lost, and Regions that fall partly 
outside will be shortened. If any such Regions are being used in the Arrange, an alert 
box appears, giving you the option to cancel the trim function.

Remove DC Offset
Poorly constructed audio hardware can result in direct current (DC) being layered over 
the audio signal. This results in a vertical shift in the waveform position, which can be 
clearly seen in the Sample Editor. 

During playback, this can cause crackling sounds at the start and end of the audio 
Region.

Functions > Remove DC Offset centers the waveform around the zero amplitude line, to 
avoid crackling at cut points.

Search Peak/Silence
Search Peak
Functions > Search Peak scans the currently selected Region for the sample bit with the 
greatest amplitude value. The cursor in the waveform display is then placed on this bit.

Search Silence
Functions > Search Silence scans the selected audio for sections containing silence 
(“digital zero”). The cursor is then placed at the start of the first section found, that fits 
this description.

Adjust Tempo…
Just like Automatic Tempo Matching in the Arrange, the Adjust Tempo by Selection & 
Locators function adjusts the song tempo, according to the current locator positions 
and Sample Edit window selection.

The operation is similar to the Arrange function; it only refers to the selection in the 
Sample Edit window, rather than the overall Region length.
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Digital Factory
Operation
The Digital Factory functions are accessed via the Sample Edit window’s Factory menu.
• Open the Sample Editor by double-clicking a Region in the Arrange, or the Audio 

window.

This selects the whole Region.
• Or:  select the area to be edited.
• Or:  press Command-A, to edit the whole audio file.

The Digital Factory functions always affect the selected area.
• Select Factory > …
• Make the desired settings in the float window that appears.
• You can start playback if you wish. Even though the functions alter the data in the 

audio file, they can still be performed while the file is playing.
• Click the edit button at the bottom (Process & Paste). The label on the edit button 

varies, depending on the function.

The top line of the Sample Edit window keeps you informed about the function’s 
progress.

The selected area of the audio file is replaced by the edited audio material.

Options
• Selecting Edit > Undo (or Command-Z) allows you to compare the edit with the 

original, at any time. You can continue to work in the Arrange window, as the Undo 
function of the Sample Edit window operates independently of the rest of the 
program.

• You can repeat the edit with other Regions or audio files, without needing to close 
and reopen the chosen Factory window. The function is only performed on the 
selected material.

• You can also use the pull-down menu at the top edge of the window to switch 
directly between the individual functions of every Digital Factory process. The two 
sides of the Factory menu (separated by a horizontal line) divide the Digital Factory 
into “Machines” (large float window) and “Functions” (small float window).

If you are playing your song (containing MIDI and audio data) while editing audio 
material, owners of slower computers may experience slightly “jerky” playback of the 
audio material. MIDI playback will continue to function correctly. The editing time also 
increases slightly while the song is playing.
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Time and Pitch Machine
The Time Machine allows you to radically alter the time structure of audio files, 
including time compression/expansion, and pitch transposition. When changing the 
pitch, you can also correct any alteration of the formants. Pitch shifting without 
formant correction causes a phenomenon commonly known as the “Mickey Mouse” 
effect.

Overview of the Time and Pitch Machine features:
• Time compression or expansion without transposition,
• Pitch transposition with or without altering the length and tempo,
• Correction or alteration of the timbre (sonic character),
• any combination of these functions.
• Consider the Time Machine to be a universal tool for control of the pitch, tempo, and 

sonic character of digital recordings. Each of these parameters can be addressed 
independently. The current settings are visually represented by the position of a ball 
in a 3-dimensional graphic display, where the axes are time, pitch, and timbre (sonic 
character).

Opening the Time and Pitch Machine
To open the Time Machine, select Factory > Time and Pitch Machine. 

Parameters
Most of the parameters are mutually dependent; you don’t need to enter them all to 
get a good result. We suggest that you don’t adjust a parameter unless you know what 
the value should be.

The left “column” (Original) displays the present value, and the right column 
(Destination) is used for entry of the desired target value for the edit.

Tempo Change (%)
Tempo alteration in percent. (There is no original value shown).
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Tempo
Tempo in bpm (beats per minute). Make sure you set the right length in bars, or the 
correct original tempo will not be shown on the left!

Length (Samples)
Length in samples.

Length (SMPTE)
Length in SMPTE time.

Length (Bars)
Length in bars. If you have already adjusted the song tempo to the Region that you’re 
about to edit, the original value will automatically be set correctly. If not, you need to 
manually enter the original length here.

Transpose (Cent)
Transposition of the sound material in 1/100 semitone units (cents).

Free Transposition
You will see the Free pull-down menu next to the Transposition parameter.

This is the most common setting when using the Time Machine. It means that the 
program performs “free” compression/expansion or transposition. In this situation, the 
pitch and tempo of the audio material are completely independent of one another.

Classic (Correlated) Transposition
Switch the pull-down menu from Free to Classic. The Classic mode is for situations 
where you want to transpose a selected Region, and also affect its tempo. This 
produces an effect that you’re probably familiar with, as it simulates the sound of 
changing tape speed. In this scenario, the pitch, sonic character, and playback speed all 
change.

Audio Algorithms
Version 5 algorithm
This is the well-known algorithm of Logic 5 and earlier versions.

Any material
This is the most universal algorithm, which should be able to handle any kind of 
material—it is the new default setting when using the Time Machine. 

Using the Graphic Display
To the left of the Time Machine window, you can see a graphic representation of the 
current settings. You can grab the ball within the graphic, and freely move it to adjust 
the compression/expansion, and pitch shift. The further the ball deviates from the 
center position, the harder the algorithm has to work, and the lower the expected 
sound quality will be.
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Also remember that the quality of the result depends greatly on the source material.

Don’t let this keep you from experimenting. Feel free to try extreme settings for 
compression/expansion or transposition. In such cases, the result may not always be 
what you expect, but it might be just the “effect” you’re looking for.

You can move the ball in the 3-dimensional display with the mouse. Naturally, only two 
dimensions can be accessed at once; use Shift to switch between two different 2-
dimensional planes (enabling you to reach every point of the 3D graph). Holding 
Control, Option, or Command limits ball movement to one axis, allowing independent 
timbre, transposition, or length changes.

You can also grab and move the shadows of the ball. These are its projections on the 
timbre axis, and the transposition/time plane, respectively

The position of the ball directly effects the numerical values, and vice versa.

You can reset the ball and all numerical values to centered (neutral) positions by simply 
double-clicking in the graphic display.

Time Machine—Technical Background
The Technology of the Time Machine
The Time Machine analyzes the spectral components and dynamics of the digital audio 
material, and processes the result. The high-grade algorithm endeavors to retain as 
much spectral and dynamic information as possible, and minimizes phase variations. In 
stereo files, the phase relationship between the left and right channels is fixed, and not 
altered. Doubled sound events are kept to a minimum. This approach produces a high 
quality result, which is smoother than what you’re probably used to hearing from other 
products, despite the speed of the process.

You should, however, bear in mind that apart from resampling (transposition), the Time 
Machine has to achieve the “physically impossible”:  when a sample is lengthened, 
information needs to be “invented.” This should be as realistic as possible. Conversely, 
when a sample is shortened, information has to be cut out. This cut information should 
be as unimportant to the overall character of the sound as possible. Lengthening is 
more difficult than shortening, and if you have a choice, it’s better to speed up a drum 
loop than it is to slow it down.

There’s always a small deviation between the set stretch or compression factor, and the 
actual result. This is because the algorithm needs some freedom to optimize the 
spectral and dynamic integrity (the sound quality). The deviation from the set value is 
only a few milliseconds (or fractions of a bpm). This shouldn’t present a problem, as the 
absolute deviation is independent of the length of the processed section. Put another 
way, this means the deviation is no greater in longer files.
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Audio Energizer

The purpose of the Audio Energizer is to increase the perceived volume of audio 
material, while altering the sound as little as possible, and without causing clipping. 
Digital distortion (which would be the inevitable result of simply increasing the level, 
and which sounds very unpleasant) is avoided by using this algorithm.

You could compare the effect to that of an analog tape which is saturated by a high 
recording level. The distortion factor and effect on the audio material is much lower, 
however.

Here’s an example of the effect. If a normalized audio file (audio data which is already 
at the maximum dynamic range) is edited, the effect is as follows:  a VU meter will 
show a higher level, indicating increased average energy in the signal. A peak display 
will show the same level as before, as the maximum signal level has not been 
exceeded.

Opening the Audio Energizer
Select Factory > Audio Energizer in the Sample Editor. The function is executed by 
clicking the Energize button.

Parameters
The main parameter is Factor. This is where you select the amount of average level 
boost. 0% means no alteration, while higher values produce an increase in energy. The 
setting you make here will depend on the audio material, situation, and personal taste. 
Begin by trying values in the 40 to 100% range. Values below 10% will have little effect, 
values over 100% can lead to undesirable alterations in the sound, depending on the 
material. Values over 200% are not recommended with normalized files, because they 
will have detrimental effects on the sound and it’s dynamics. They can also greatly 
increase the required computation time. On non-normalized audio data, even high 
values can be effective because the overall level is initially increased to it’s maximum, 
without affecting the dynamic range.
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The Attack and Release parameters control the steepness of the algorithm’s filter. You 
can try increasing these values to double or four times the default, if the result sounds 
too “digital” or “raw”. This can happen if small elements among the main events in the 
original signal are boosted. As an example, the reverb portion of a sound can become 
louder.

The perceived loudness of the overall audio material is increased. If the material 
contains anomalies such as noise, these will also be increased, and sometimes become 
audible. If necessary, you can edit the result with the noise reduction function (Silencer) 
on a low setting, or make use of Logic’s effect processing capabilities.

Sample Rate Converter
The Sample Rate Converter is used for sample frequency conversions.

Opening the Sample Rate Converter
Normally, you’ll want to convert the sample rate of an entire audio file. To do this, select 
the whole audio file in the Sample Editor (Command-A).

Select Factory > Sample Rate Convert, and click the Convert button.

Parameters
Source (Hz)
This shows the previous sample rate of the audio file. To enable changes to incorrectly 
stored sample rate formats (after editing in other programs, for example)—or for 
effects—you can enter any value you like here. You should only change this parameter 
if you know what you’re doing.

Destination (Hz)
Enter the desired sample rate that you want the selected area converted to.
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12 Event List
The Event List displays MIDI data in the form of an 
alphanumerical “list”, combining all of the data editing 
functions of the other editors.

The Event List, while not as “pretty” as other Logic editing windows, is extremely 
powerful. This chapter discusses the many specific uses where the Event List is your 
best choice for data handling and editing.

Using the Event List
The Event List is used whenever you need to make precise alterations to recorded data, 
and where the graphic display of the other editors is not as well suited to the task. It is 
the only editor that provides access to all recorded event data. You can also restrict 
what you see, allowing you to only edit specific event types.

Opening the Event List

To open the Event List and view the contents of the selected Region, select Windows > 
Event List, or use a user-defined key command for Open Event Editor.
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You can also open it by double-clicking on a Region if you have selected Double-
clicking a MIDI Region opens Event List in Preferences > Global > Editing.

Structure
The standard buttons are supplemented by two scroll arrows, that help you move 
through the list. 

The event type buttons allow you to filter specific event types from the display, and 
access or add them (by Command-clicking on them).

Beneath the Toolbox is the quantization grid selection field for the event quantize 
function. There is also a field for defining the Division value, which corresponds to the 
Division value as set in the Transport window. 

If the Catch function is switched on, the arrow-shaped position marker always points to 
the current event. 

The main area shows the actual list of events or Regions.
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Display
The event type buttons allow you to “filter” the display, removing individual event types 
from the Event List, limiting the view to the specific types of events you’re interested in. 
Click the desired button with any tool (except the pencil).

If a button is grayed out, that event type will not be displayed.

All functions only affect the displayed events, thus protecting any non-displayed events 
from any alterations you may make.

Here is a short overview of the filter buttons.

The note symbol denotes note events. The symbol with the dual-digit, seven-segment 
display denotes program change events. 

The hand wheel symbol with a marker in the middle (pitch bend wheel) denotes pitch 
bend events. The hand wheel symbol with a marker at the bottom (modulation wheel) 
denotes control change events. 

The single weight symbol denotes aftertouch events (channel pressure). The multiple 
weights symbol denotes polyphonic key pressure events (polyphonic aftertouch). 

The SysEx symbol denotes SysEx events. The symbol with a row of zeros and ones is 
called the full message button. This does not filter out any type of event, but affects the 
amount of detail displayed for all event types. 

The Event List display is normally restricted to one line per event. When the full 
message display is active, all information stored along with the event is also shown. 
This is particularly important for editing SysEx messages. When examining note events 
in the Event List, you will also notice Logic’s internal score layout information included 
in the list. You can edit this in the Event List if you wish, but it serves little purpose.
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Operation
Scrolling
Clicking either of the scroll arrows moves the display up or down by one event. The 
event at the position marker is always selected (the existing selection changes as you 
scroll). The scrolling speed can be varied by vertically moving the mouse. The Scroll to 
Next/Previous Event key command is also available from the Event window, and has the 
same end result.

If the MIDI Out button is switched on, every newly selected event will be played. This 
allows you to scroll through the list and audibly monitor the events as you go.

If you want to keep the selected event where it is, use the usual scroll bar functions.

Selection
Selection Techniques
When selecting events with the mouse, you should click near the status column, to 
avoid any unintentional parameter alterations.

You can use any of the standard selection techniques here:  individual selection by 
clicking on objects, multiple selection using the rubber band, or both of these (without 
altering the previous selection), in conjunction with Shift. Don’t forget you can also 
make selections according to specific criteria with the Edit menu.

Any events hidden from the display by clicking on the event type buttons, are 
immediately deselected. This ensures that all functions only affect the displayed (and 
selected) events.

Special Selection Functions
Some selection commands (which can be accessed from the Edit menus of all Editor 
windows) can also be utilized by selecting an item with the mouse, while holding 
down additional modifier keys.
• If you click on an event while holding down Option, you select all events between 

the last event that was selected, and the current one.
• If you hold down Control and select an event, all similar events will also be selected.
• If you select an event while holding down Control-Option, all identical events will be 

selected.
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Event Editing
Adding Events
To add an event, click on the desired event type button with the pencil (or any other 
tool, while holding down Command). The event is then added at the current song 
position, and is automatically selected.

Duplicating Events
To duplicate an existing event (to alter the parameter value of the copy, for example) 
click on the original event with the pencil. An input box appears—use it to enter the 
position for the newly-duplicated event. If you press Return, the duplicate will appear 
at the same position as the original.

Pasting from the Clipboard
When adding events using the Clipboard’s Paste function, a position input box will 
appear, allowing you to type in the position of the first event. Once again, if you 
confirm by pressing Return, the original position of the event is retained. The relative 
positions of other copied events are also always maintained.

This means that the events are not added at the song position, as in the graphical 
editors. 

Moving Events
To move an event in time, alter its position indicator. As soon as you alter its position, 
the list is automatically sorted, even though the currently selected event remains the 
same.

Altering Values
Event positions or parameter values can be altered in the usual way by using the 
mouse as a slider (grabbing and dragging), or with text input (double-click on the 
parameter value and type in a new value).

You cannot alter the type of events using this method, however. To alter the event type, 
you must either; open a Transform window, or add an event of the desired type and 
then delete the original event.

Altering the Values of Several Events
If a parameter of a selected event is altered, it will affect the same parameter in all 
selected events.

Relative Value Alteration
When you alter parameter values in a group of selected events, the relative differences 
between parameter values remain unchanged. This means that parameter values can 
only be altered until the (same) parameter value of one of the selected events has 
reached its maximum or minimum value.
Chapter 12    Event List 301



302

 

Flexible Relative Value Alteration
If you want to continue altering a parameter value in a multiple selection (even if one 
of the values in the selection has reached its maximum or minimum value), hold down 
Option while moving the mouse, or press Return to confirm a numerical input.

Absolute Value Alteration
If you want to set a parameter to the same value for all selected events, hold down 
Shift-Option, while using the mouse as a slider, or press Return to confirm a numerical 
input.

Numerical Value Input
If you want to directly input a number, double-click the relevant parameter.

There are a few special points concerning numerical editing of events in the Event List:
• When entering event time positions and lengths, press Tab to jump from part to part 

within the value you’re entering.
• New events can be created by using the ASCII keyboard. When you’re numerically 

editing events, you can duplicate them by simply pressing Esc.
• The Duplicate Event and Numerical Edit key command also allows you to create new 

events.

Event List Structure
… on the Event Level

The individual columns in the list have the following meanings:

Position
The position of events in the song; for note events this means the beginning of the 
note. The units represent bars, beats, divisions, and ticks (see “Position Display” on 
page 76).

Counting begins at 1 for each unit (first bar, first beat, first division, first tick:  1 1 1 1), 
and continues until it is carried over to the next largest unit.

Numerical input starts from the left (which means you can simply enter the bar 
number if you want). The units can be separated by either spaces, dots, or commas.

Position Within the MIDI Region
If you select View > Local Position, the event positions don’t refer to their absolute 
location within the song, but to their relative positions within the MIDI Region.
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Status
This is where you can see the event type, as specified by the status byte of a MIDI 
message. You cannot directly edit this parameter.

Cha
The MIDI channel used to record an event.

Remember that this MIDI channel will be replaced by the Channel parameter of the 
playback instrument, during playback. The event is only output to the recorded MIDI 
channel when the Channel parameter is set to All.

You should also note that the recorded MIDI channel is used to assign a polyphonic 
voice to the note in Score Styles.

Num, Val
These columns contain event data bytes. Their meaning depends on the event type:

Length/Info
With controller events, this column shows the controller name. 

With SysEx events, the manufacturer’s name.

With pitch bend events, a 14-bit value is displayed here; comprised of the first (Num) 
and second (Val) Data bytes, combined. This value can be edited directly here.

With notes or Regions, the length is displayed here.

Here too, the units are bars, beats, divisions, and ticks. For the sake of clarity, when the 
length begins with one or more zeros, the “_” symbol is used. The minimum length is 1 
tick (_ _ _ 1) not 0 ticks, as simultaneously switching a note on and off wouldn’t make 
sense!

Numerical input starts on the right, working to the left—you can enter ticks if desired. 
The units can be separated by either spaces, dots, or commas.

End Instead of Length
If you select View > Length as absolute Position, you can make the length display show 
the absolute position of the note off event, rather than it’s length from the note on.

Status Num Val

Note Pitch Velocity

Control Controller number Value

Pitch LSB MSB

C-Press (not used) Value

P-Press Pitch Value

Program Bank Select Program number
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… on Arrange Level
When you click on the UDL button, or double-click the background area above or 
below the list entries (if visible), you move up one level in the Folder/Region hierarchy.

This allows you to see all Regions in the current song (or folder). On the Arrange level, 
the list has the following columns:

Position
The start of the Region.

Name
Name of the Region. Double-clicking on the Folder name switches you to the display of 
its contents. Double-clicking on an audio Region opens the Region in the Sample 
Editor. A click on a MIDI Region returns you to event-level editing.

You can edit the name with the Text tool.

Track
Displays the track number. You cannot edit this value here (you could totally destroy 
your arrangement if you did). If you want to move Regions to other tracks, do it 
graphically in the Arrange window.

Length
The length of the Region.
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Event Type Structure
Note Events

Num
MIDI note number (note #). The range is from C-2 (note #:  0) to G8 (note #:  127). 
Middle C is note # 60. It’s known as C3 in MIDI terminology.

On some keyboards/synth modules (notably those made by Korg and Roland), the note 
range is C-1 (#0) to G9 (#127). In these cases middle C is called C4.

In the Preferences > Display Preferences page, you can reference the display to the 
description that is most frequently used by your devices (Display middle C as…).

Val
Velocity of a note from 1 to 127. The zero value (0) carries the note off message, and 
cannot be used here.

Length/Info
Length of the note. Although MIDI can only transfer note on or note off messages, Logic 
actually stores the position and length of all notes, which makes them easier to access 
musically. The note off message is generated automatically during playback.

Mapped Instrument Notes
If the edited MIDI Region is played through a mapped instrument, the defined names 
of the individual notes appear in the Status line. For the sake of clarity, there is a small 
note symbol to the left of each name.
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Program Change Events

Program change events can be transmitted to connected MIDI devices for patch 
selection. These may be sounds in a synthesizer, programs in an effects unit, or 
snapshots in an automated mixing desk.

Val
A program number between 0 and 127.

Some manufacturers (such as Yamaha) number the programs in their devices from 1 to 
128, not 0 to 127. In this situation, you need to subtract 1 from the program number 
shown on the device itself.

Other manufacturers use various methods of dividing internal memory locations into 
groups (or banks) and sounds. The most common is divisions into 8 groups of 8 
sounds, each numbered 1 to 8. These devices respond to program numbers 0 to 63 by 
addressing storage locations 11 to 88. The instruction manuals for these devices should 
contain conversion tables to assist you.

Num
Bank select. Normally you will see this symbol (−), which means no bank select will be 
sent. If you assign a number between 0 and 126, a bank select event is sent before the 
program change event. This allows you to address different sound banks (preset, 
internal, card, and so on) inside your synthesizer. The synthesizer must be able to 
recognize controller 32 as bank select, but unfortunately this standard is not used by all 
manufacturers. If you have any problems with bank select, check your synthesizer’s 
manual to see whether, and how, it responds to bank select commands. You can 
change the type of bank select message Logic sends for each Multi Instrument in your 
setup (see “Defining Custom Bank Selects” on page 169).
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Pitchbend Events

Pitch bend events are used to continuously vary the pitch. They are usually generated 
by a centered pitchbend wheel or joystick on your keyboard.

Num
Fine pitch bend division (LSB). Many keyboards transmit a value of 0. If the pitch bend 
wheel has an 8-bit resolution, you will see values of 0 or 64 here.

Val
The effective pitch value (MSB) of 0 to 127. A value of 64 corresponds to the mid-way 
setting of the wheel.

Length/Info
The 14-bit value is displayed in this column as a decimal figure ranging from −8192 to 
8191. The value in this column may be edited in the usual way.

Control Change Events

These event types are used to transfer MIDI controllers (modulation, sustain, volume, 
and pan, as examples).

Num
The number of the controller. All of the various MIDI controllers (such as the 
modulation wheel or sustain pedal) are assigned their own numbers (#1 or #64 
respectively). Some other controllers are also defined, such as volume (#7) or pan (#10).

Controllers that are defined in the MIDI Standard are described in the Length/Info field.
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Val
Value of the controller. Continuous controllers have a range of 0 to 127. Switch 
controllers (#64—#90), transfer only two states; off (val=0) and on (val anything 
between 1 and 127).

Aftertouch Events

Aftertouch (or channel pressure) events are generated by a mechanical pressure sensor 
beneath the keyboard. The resulting sound modulation affects all notes on that 
particular MIDI channel.

Num
This column is empty for aftertouch events, as they only have one data byte.

Val
Strength of the pressure on the keyboard (0 to 127).

Poly Pressure Events

Poly pressure events are generated by mechanical pressure sensors beneath each 
individual key. The resulting sound modulation only affects that particular note. Only a 
few keyboards offer this capability.

Num
MIDI note.

Val
Strength of the pressure on the key.
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SysEx Events

System Exclusive Data (SysEx) is exclusive to individual MIDI devices. You can record 
these events using the dump utilities of your synthesizers, allowing you to save patch 
information outside the MIDI device. The arrows in front and behind the word EOX are 
used to add or remove bytes.

Editing SysEx Events requires a thorough understanding of the data format used by the 
MIDI device in question. Incorrect edits can lead to the corruption or loss of sound 
data.

SysEx Data in Hex Format
You can select whether SysEx data is displayed in hexadecimal or decimal, in the Event 
List or the SysEx fader editors, with the View > SysEx in Hex Format command.

Hexadecimal digits are preceded by a $ symbol in Logic.

Tips for Numerical Input
Numerical input (by double-clicking) is always independent of the current display 
mode or event type, and can be used in many other areas of the program. Here are 
some of the possible methods. You can type in:
• Decimals:  1, 01, 2, 3, 4, 127, …
• Hexadecimals:  $1, $01, $2, $3, $A, $0A, $7F
• Notes:  “C3”, “C#3”, “Cb3”, “C##2” (equivalent to D2), “Dbb2” (equivalent to C2)

If you double-click on the note “E3”, you can enter a decimal value such as “64” or a hex 
value of “$40” instead of the note itself.

In many parts of Logic, mathematical operations can also be used to change values. As 
examples:
• adding two existing values:  “+5”, “+$10”
• subtracting from the existing value:  “−5”
• summing two values:  “38+17”
• subtracting two values:  “38−17”
• multiplying two values:  “7∗8”
• dividing two values:  “80/5”
Chapter 12    Event List 309



310

 

Event Float Window

The event float window can be accessed from most other windows.

Select Options > Event Float (or the Open Event Float key command) to open an Event 
Float window. This provides information on the currently-selected object, and can be 
compared to a single line of the Event List. You can edit all parameters in this window.

The following parameters are displayed:
• the start point of the selected object in bars, beats, divisions, and ticks,
• the type or name of the selected object,
• the recorded MIDI channel and first data byte (if the selected object is an event), the 

name of notes, and the second data byte (if it exists);
• length of the selected object in bars, beats, divisions, and ticks.
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13 Hyper Editor
The Hyper Editor is a graphical editor that can be used to 
create or edit MIDI note and controller data.

This editor is unique in that it makes some editing tasks—such as data scaling—much 
faster. The Hyper Editor is also ideal for “drawing” in drum and other parts.

Hyper Editor—Introduction

Usage
The Hyper Editor has many uses. The main ones are creating and editing drum MIDI 
Regions, and graphically editing controller data. Despite some similarities, don’t 
confuse the Hyper Editor with the Hyper Draw function.

Opening the Hyper Editor
To open a Hyper Editor window, select Windows > Hyper Edit (default Command-5). You 
will then be able to see the contents of the MIDI Region selected in the Arrange 
window.
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Structure
The structure of the Hyper Editor window resembles that of the Arrange 
window:  there is the horizontal Bar Ruler at the top, and the optional transport panel 
in the top left corner. On the left is the optional parameter area and the event name 
column, and to the right of that, the editing area, which can be likened to the 
arrangement area of the Arrange window.

The individual lines in the Hyper Editor are functionally similar to tracks in the Arrange 
window, in that each line has an event definition, which determines the event type 
displayed in this line (much as tracks in the Arrange window contain an instrument). 
When you select a line in the name column, its event definition is shown in the 
Parameter box.

The display of events takes the form of a horizontal row of vertical beams. The height of 
the beams indicates the value of the event. You can directly alter the value by grabbing 
the beam and moving the mouse up and down. It is possible to store a combination of 
simultaneously displayed event definitions as a hyper set.

Hyper Sets
A hyper set is a way of saving a combination of event definitions. When a hyper set is 
saved, the vertical zoom setting of the Hyper Editor is stored (this determines the 
number of event definitions that can be displayed simultaneously). You can save as 
many hyper sets as you need in each song.

Selecting a Hyper Set
Directly above the event definition parameter field is the hyper set selection field. 
Grabbing it opens a pull-down menu, which allows you to select from among the 
available hyper sets.

Creating a Hyper Set
To create a new hyper set, select Hyper > Create Hyper Set. The preset event definition in 
the new hyper set is the volume controller (#7). Any alterations that you make, such as 
adding or redefining event definitions, or adjusting the vertical zoom setting, are 
automatically stored in the current hyper set (as with screen sets).
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Hyper > Create Hyper Set For Current Events creates a new hyper set, consisting of the the 
currently selected event types. This is especially nice if you want to create a hyper set 
for all event types that you have created in a conventional Region Hyper Draw. You can 
open the Event Editor, select everything, deselect the note events, open the Hyper 
Editor and use Hyper > Create Hyper Set For Current Events. All used event types can then 
be edited in the Hyper Editor.

Create GM Drum Set
General MIDI has an established keyboard assignment pattern for drum and percussion 
sounds. This is often even the case with sound modules, samplers, and professional 
synthesizers that don’t carry a GM, GS, or XG emblem. As the Hyper Editor is ideally 
suited for drum track editing, you may wish to create a hyper set that is specifically 
tailored for GM Drum Sets, including the correct names and hi hat modes. Select Hyper 
> Create GM Drum Set to do so.

Naming the Hyper Set
To name the current hyper set, double-click on the hyper set selection button.

Clearing a Hyper Set
To clear the current hyper set (to delete its contents), select Hyper > Clear Hyper Set.

Event Definitions
The event definition of a hyper edit line determines the events it displays. This selection 
usually affects the status byte and the first data byte of the event. The second data byte 
then contains the adjustable value, which is represented by the height of the beam. As 
an example, the value of a controller or the velocity value of a note is shown as a beam 
in an event definition line. Don’t worry if this seems a bit confusing at first:  when 
setting up the hyper definition parameters, Logic helps you by providing pull-down 
menus containing written definitions of the status byte and (as far as possible) the first 
data byte. There is an even simpler way to set up hyper definitions:  you can 
automatically create event definitions for selected events—see below.

There are many ways of altering the way the beams are displayed, and adjusting them 
to the particular event types. You can also use a grid to align the display of existing 
events, and add new events. This grid can be set separately for each event definition in 
a hyper set. The height of the lines in the hyper set is adjusted with the Hyper Edit 
window’s vertical zoom function.

Selecting the Event Definition
As with tracks in the Arrange window, you can select an event definition by clicking on 
the name column. This allows you to view its parameters in the Event Definition 
Parameter box. You can also make multiple selections.
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Creating Event Definitions
Creating an Event Definition
When you select Hyper > Create Event Definition, a new event definition is added, at the 
position of the currently selected event definition. Initially, it has the same parameters 
as the original. The event definitions beneath it are moved downwards.

Automatically Creating Event Definitions
If you select an event in another opened editor window, you can automatically create 
an equivalent event definition by checking the Auto Define checkbox.

If the current hyper set already contains an event definition that corresponds to the 
type of the selected event, Logic does not create a superfluous double definition. The 
existing event definition is moved into the visible area in this situation.

Don’t forget to switch off Auto Define immediately after completing your input.

Creating Several Event Definitions Automatically
You can also automatically create several event definitions. Just select the events that 
you want to base the event definitions on. You can use the same function to create 
event definitions for all event types in the selected MIDI Region.

It’s a good idea to create a new hyper set before creating a group of new definitions.

Hyper > Create Hyper Set For Current Events creates a new hyper set with event types 
that match those of the selected events. This is especially nice if you want to quickly 
create a hyper set for all event types created in the conventional Region Hyper Draw. 
You can open the Event Editor, select all, deselect the note events, open the Hyper 
Editor and use Hyper > Create Hyper Set For Current Events. All used event types can then 
be edited in the Hyper Editor.

If you select Hyper > Multi Create Event Definition a dialog box asks whether you want to 
create event definitions for all event types (select All or press Return), or just the 
selected events (Selected). Press Cancel to abort.

Deleting an Event Definition
Select Hyper > Delete Event Definition to remove the selected event definition.

Sorting Event Definitions
To change the vertical order of the various event definitions, just grab the event 
definition you want to move by its name column, and drag it to the desired position.
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Copy/Convert Event Definitions
Hyper Sets: Copying Event Definitions
Select the event definition that you want to copy, and select Hyper > Copy Event 
Definition. Switch to the destination hyper set, and select Hyper > Paste Event Definition.

Converting Event Definitions
You can redefine an event definition (along with all events). The values of the events 
are retained, but the event type is changed to the new event definition. Select Hyper > 
Convert Event Definition, or double-click on the name column of the event definition 
that you want to convert.

The box shown below appears. On the left (convert), you can see the parameters of the 
selected event definition, and on the right you can define the parameters of the 
destination event type. The current settings are used as default values.

If you place an “x” in the Quantize Events checkbox, the event positions are quantized 
according to the Grid setting shown in the right-hand parameter field. If you make no 
further alterations, this allows you to quantize the positions of the events. If any Delay 
value is shown on the right, this is taken into account by the quantization.
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Event Definition Parameter Box
The Event Definition Parameter box is where you make the settings for the currently 
selected event definition line. The most important parameters are Status and -1-.

Opening the Event Definition Parameter Box
You can show (or hide) the entire left parameter area by checking (or unchecking) View 
> Parameters. You can close or open the Parameter box by clicking the triangle in the 
top left corner. 

Name of the Event Definition
Clicking the name next to the triangle determines what appears in the name column. If 
you define a named MIDI controller, or a note from a mapped instrument in the Status 
and -1- parameters, the relevant name will be offered as a preset. Altering a note name 
in the event definition also alters the corresponding note name in the mapped 
instrument.

You can also display, add, and edit Meta Events in the Hyper Editor’s event definition.

Display and Editing Grid
The Grid parameter is set with the typical pull-down quantization menu. New events 
can then be added at the set grid positions. The positions of existing events are not 
affected.

If you want to quantize the positions of existing events, you can do so using event 
quantization, or more simply with event definition conversion.

The same quantization templates available for playback parameters, including Groove 
Templates you have defined, are accessible.

When editing complex drum rhythms, it can be useful to create several hyper 
definitions for one drum note, each with a different quantization grid. As an example, if 
there are two lines for a snare drum, one with a 1/16 and the other with a 1/96 grid, 
you can use the pencil to add individual hits in the coarser grid, and rolls in the finer 
grid.
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Beam Width
You can set the width of the event beams from 1 to 16, using the Pen-width parameter. 
Regardless of the beam width, the exact event position is always marked by the left 
edge of the beam.

When set to the maximum value (Penwidth = 16), note events are displayed with their 
actual length.

Beam Display
The Style parameter allows you to select from four different color display variations, for 
the beams. Styles 5 to 8 are the same as 1 to 4, but the selected events flash when you 
highlight them.

Delay
The Delay parameter can be used to delay (with positive values), or advance (negative 
values) all of the events in an event definition line by an adjustable number of ticks. 
The change in position is visible immediately. Even new events are offset from the grid 
positions by the Delay value. If you click between the word Delay and the parameter 
value, you can use a pull-down menu to enter note values (1/16 and so on) directly.

Unlike the Region playback parameters’ Delay option, this only affects individual event 
types or note numbers, which is very useful for drum programming (flams, for 
example).

In general, it is useful to transmit controller data slightly before or after the exact grid 
positions, to improve the timing of the notes lying on the grid positions.

Length of Notes to Be Added
You can use the Length parameter to set the length of notes to be added, measured in 
divisions (the left number), and ticks (the right number).

To guarantee optimum timing when drum programming, you should ensure that note 
off events are never transmitted at the same time as note on events. Use note lengths 
that aren’t close to straight note values, such as 100 ticks (1/48 note = 80 ticks, 1/32 
note = 120 ticks). Very small tick values are also unsuitable, because note off events may 
sometimes be transmitted at the same time as note on events, at the same position.

Event Status
If you grab the right side of the Status line, a pull-down menu opens, enabling you to 
set the status for this event definition line.

MIDI Channel
Next to Cha, you’ll see a checkbox, and to the right of this you can set a MIDI channel 
number. If you check this box, the display is restricted to events on the set channel. If 
the box is unchecked, the channel parameter is ignored, and matching events on all 
channels are displayed.
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First Data Byte
The bottom line shows the -1- parameter, where you can determine the first data byte 
of the displayed event.

As an example, if Note is set as the event status, you can determine the pitch (note #) 
that should be displayed in this event definition line. If the edited MIDI Region is played 
by a mapped instrument, a pull-down menu that features the names of the input notes 
(drum sound names) appears here.

As with the MIDI channel, the checkbox determines whether (if checked) only events 
with the defined first data byte should be displayed, or whether (if unchecked) the 
setting should be ignored. In the case of note events, the velocity values of all notes 
(regardless of pitch) would be displayed in the relevant event definition line.

If Control is set as the event status, you can use a pull-down menu to determine the 
controller type (controller #).

With channel aftertouch (status C-Press), or program change events (status Program) 
the setting of the -1- parameter is always ignored, and the first data byte is displayed as 
a beam height. With pitch bend data (status PitchBd), the setting is also ignored, 
because both data bytes are used to display the beam height.

Making Different Definitions Simultaneously
Just as you can adjust the parameters for several MIDI Regions at once, you can set the 
parameters of several event definitions simultaneously. Select several event definitions 
in the name column, by holding down Shift and clicking on them. You can also use 
Hyper > Select All Event Definitions to select all event definitions, and then deselect some 
of them by Shift-clicking on them.

Any alterations made in the Event Definition Parameter box affect all selected event 
definitions.
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Hi Hat Mode
In hi hat mode, event definitions can be grouped together. Only one event from each 
group can be played at any time position. A typical use is for preventing different hi hat 
notes (open, closed, pedal) from being inserted at the same position.

To define a hi hat group, click in any of the lines at the left edge of the name column. 
Click here once again to switch hi hat mode off for the line. All lines in a hi hat group 
must be vertically adjacent to each other.

If you add an event within a hi hat group, all existing events at this time position are 
deleted. 

You can create as many hi hat groups as you want in a hyper set, but they must all be 
separated by at least one line in which hi hat mode is switched off.

Operation
Grid
The grid defined by the Grid parameter in the Event Definition Parameter box is very 
important:
• During selection, all events within a grid section are selected
• When you change the values of existing events, all events within a grid section are 

altered, and
• New events are added at the grid positions, in accordance with the value set as the 

Delay parameter.

Selection Techniques
You can use any of the usual selection techniques (see “Selection Techniques” on 
page 33), with the following differences:
• To select individual events, hold down Shift, as you would when selecting several 

events that are scattered across the screen, and;
• When making a rubber band selection, hold down Shift (be careful not to click on 

any events).
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Moving and Copying Events
When moving selected events, you also need to hold down Shift.

To copy events, use Option as per usual.

Both operations allow you to move events to other event definition lines. The events 
will be converted automatically.

Altering Event Values
You can alter individual values by grabbing the event beam (with the pointer or pencil). 
As you change the event value, the current value is shown in a help tag.

Altering Several Events
If several events are selected, you can alter all of their values relatively, by grabbing one 
of the event beams. The absolute differences between the event values remain 
constant. If one of the beams reaches the top or bottom value, you will not be able to 
go any further in that direction.

If you hold down Option while doing so, you can keep raising or lowering the values of 
the selected event group, until the grabbed event beam reaches the top or bottom.

Setting Up a Manual Series
Existing Events
Draw the events with the mouse pointer, while holding down the mouse button.

Creating New Events
Draw the events with the pencil, while holding down the mouse button. The pencil is 
preset as the second tool (Command key).

Setting Up a Linear Series
• Select the crosshair tool.
• Click anywhere in the beam display area, and hold down the mouse button.
• Keep an eye on the help tag (showing the exact position and event value in the top 

line). Move the mouse to the start point of the line you want.
• Release the mouse button.
• Move the mouse to the desired end point of the line (to the right or left). You can 

also keep an eye on the position and event value in the help tag.
• Click at the desired end point to align the event beams along the line.

If events existed in the area between the start and end points, they are aligned along 
the line.

If there were no events in the region, new events are created at the grid positions (in 
accordance with the Grid parameter), aligned along the line.

If you definitely want to create new events, hold down Option when you click for the 
last time.
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This creates one event at every grid value. With very flat slopes, or very fine grids, the 
individual grid positions remain unoccupied if the value to be added is the same as the 
value of the previous event. This reduces the data-flow along the MIDI bus, without 
reducing the resolution of the controller.

When defining the Grid parameter to add a succession of controllers use the motto, “as 
coarse as possible and as fine as necessary” to minimize data output. Logic can deal 
with very large amounts of data, but unfortunately the same cannot be said of MIDI 
itself.

Linear Series in Sections
If you also hold down Shift, you can immediately draw another line from the end point 
of the original line.

Adding Individual Events
Use the pencil to add individual events. You can alter the value before you release the 
mouse button. The pencil is preset as the second tool (Command key).

Fix Value
If you place a check in the Fix Value checkbox, you can prevent the height of any event 
beam being altered with the mouse pointer or pencil.

When adding events with the pencil, all added events are assigned the value of the 
previously-selected event. This allows you to draw a succession of events with the same 
value.

You can adopt the value of an event (with a fixed value) as a preset, by selecting it with 
the pencil. In fix value mode, it is impossible to alter the value by clicking on it.

When adding events with the crosshair tool, the preset value is always used as the start 
point of the line.
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14 Matrix Editor
The Matrix Editor allows MIDI note events to be handled 
in much the same fashion as Regions in the Arrange 
window.

This editor is often called the “piano roll” editor as it represents note events as beams 
that resemble the holes cut in the paper of pianola piano rolls. It is an exceptionally 
easy to use tool for the creation and editing of MIDI note data.

Matrix Editor—Introduction

The Matrix Editor is used to graphically edit note events. Its advantage over the other 
editors is its ability to provide a more precise display of the length, position, and 
velocity of the notes. The Matrix Editor is designed for fine-tuning the positions and 
lengths of notes.
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Opening the Matrix Editor
To open a Matrix Editor window that shows the contents of the selected MIDI Region, 
select Windows > Open Matrix Edit (Command-6) or a user-defined key command (Open 
Matrix Editor).

The optional parameter field to the left contains the standard buttons and the Toolbox. 
A Bar Ruler is shown at the top edge, much like the Arrange window (and the Hyper 
and Score Editors). Below the Toolbox, you’ll find a field that allows you to define the 
sub-division of the grid. The vertical screen keyboard indicates the pitch of notes, 
which are displayed as horizontal beams. In the upper left corner, a display panel shows 
various types of information, depending on the situation.

Display
Notes are the only events shown in the Matrix Editor. The beams (and the way they can 
be edited) are very similar to the MIDI Regions in the Arrange window.

Pitch/Note Names
The pitch is indicated by the vertical keyboard on the left side. To help you with 
positioning, there are horizontal lines running across the screen between notes B and 
C, and notes E and F.

If a mapped instrument MIDI Region is being displayed, the names of the notes being 
played will appear on the vertical keyboard, in place of notes “C” and “F”.

When a mapped instrument note is being moved, its name is displayed in the help tag.

Position
You can read the position of a note in the Bar Ruler. The background is marked by 
vertical lines to assist with positioning—the default values are:
• A black line at every bar,
• A lighter gray line at every beat, and
• A very light gray line at every division (you can alter the division value in the 

Transport window, or in the parameter area).

Velocity
The velocity of a note is portrayed by a horizontal line in the note. The length of the 
line in relation to the total length of the note corresponds to the velocity value of the 
note (in relation to the maximum value of 127).

The Matrix Editor displays the velocity of note events by color, too.

This makes it very easy to see at a glance what range of velocities are contained in a 
MIDI Region.
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If you change the velocity of MIDI notes with the V tool, you will notice that the color of 
selected notes changes in real time.

Chord Recognition
When selecting multiple overlapping notes in the Matrix editor, the information section 
in the upper left corner displays the chord name.

Editing Notes
You can use the same intuitive editing functions available for Regions in the Arrange 
window.

There are also some editing options (see “Edit Operations” on page 32) that are 
available in all editor windows.

Selection Techniques
In addition to the usual selection options, you can select all notes of the same pitch in 
the MIDI Region by clicking the corresponding onscreen keyboard key.

You can also rubber band select a pitch range of the onscreen keyboard, and select all 
notes within it.

Quick Opening of Event or Score Editor
A double-click on any event (without any modifier) opens the Event editor. An Option–
double-click opens the Score editor.

Creating Notes
To create a note, click at the desired point on the background with the pencil tool.

Duplicating Notes
To copy an existing note to another position or pitch, first click the original note with 
the pencil (near the middle).

Any notes now created by clicking the background will have exactly the same length 
and velocity as the original note.

Deleting Notes
You can delete selected notes by pressing Backspace, or clicking on them with the 
eraser.
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Moving Notes
You can move selected notes by grabbing them (near the middle) and dragging them. 
If you move notes vertically, they will be transposed, and if you move them horizontally, 
they will be moved in time. The target position and pitch are shown in the help tag 
while the mouse button is held down.

When you move notes horizontally, they snap to the resolution of the Bar Ruler, and the 
setting of the zoom function.

You can limit movement to one direction, to avoid accidentally transposing notes when 
moving them vertically (and vice versa). (Options > Settings > Global Preferences:  Limit 
Dragging to one direction in Matrix and Score).

Setting a Finer Grid
When moving notes in the Matrix window, you can make fine adjustments at a high 
resolution, by holding down Control as you drag. The exact resolution will depend on 
the current resolution of the Bar Ruler, and the setting of the zoom function.

If you hold down Control-Shift, you can move the notes in tick steps, completely 
independently of the resolution of the Bar Ruler, and the setting of the zoom function.

Copying Notes
Hold down Option as you move the notes.

This allows you to copy or move notes between two Matrix Editor windows.

You can, of course, also copy (Edit > Copy or Command-C) or move (Edit > Cut or 
Command-X) the notes onto the Clipboard, and then paste them at the current song 
position, at their original pitch (choose Edit > Paste or Command-V).

Altering Length
To alter the length of a note, grab it by its bottom right-hand corner, and drag it to the 
required length. While you are altering the length, the help tag will keep you informed 
about the precise length of the note. 

Note Start Edit
The head of a note (startpoint) can be changed, while retaining the original endpoint. 
This is done by grabbing and dragging a note at the bottom left corner. This function is 
similar to adjusting the startpoint of a MIDI Region in the Arrange Window.

Altering the Lengths of Several Notes Simultaneously
You can adjust the lengths of several selected notes at once (a chord, for example), by 
simply altering the length of one of them. The relative differences between the 
(selected) note lengths will be maintained.
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Making Notes the Same Length
If you want to make several selected notes the same length, hold down Option-Shift 
(as in the Event List, when making several parameters the same value).

What Tools to Use
You can use either the mouse pointer or the pencil when altering note lengths. It’s 
advisable to use the pointer, as this avoids the accidental creation of new notes, 
possible with the pencil.

It can sometimes be difficult to grab the bottom right corner of very short notes. In this 
situation, you should use the index finger tool, which allows you to grab notes 
anywhere, in order to alter their length.

Altering Velocity
To alter the velocity value, click-hold, and vertically drag on the note with the V tool. 
The help tag will indicate the velocity value of the note you have clicked on.

If the MIDI Out function is switched on, the note will be output when you alter the 
velocity.

Altering the Velocity of Several Notes
All selected notes can be altered simultaneously; the differences in their respective 
velocity values will be retained. If the velocity value of one of the selected notes 
reaches an extreme value (0 or 127), none of the selected notes can be adjusted further.

You can override this behavior by holding Option while doing so. This allows you to 
continue altering the velocity values until the selected (clicked) note reaches an 
extreme value.

Hold down Option-Shift while dragging, to assign the same velocity value to all notes.

Hyper Draw in the Matrix Window
In both the Matrix and Score Editors you can use the View > Hyper Draw command to 
open a Hyper Draw (see “Hyper Draw” on page 233) display. This allows quick and easy 
editing of controller data while viewing note data.

Once you have opened the Hyper Draw display, you can select the type of event you 
want to view by using the arrow menu to the left.

You can adjust the size of the Hyper Draw display by grabbing, and vertically moving 
the dividing line that separates it from the main Matrix editing window.
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15 Score Editor
The Score Editor offers extensive score layout and 
printing facilities, allowing the transcription of everything 
from simple melody lines to full symphonic scores.

This chapter outlines all of the tools and features available for Score and Lyric entry, 
editing, layout, and printing.

Score Editor—Introduction

Logic’s Score Edit window basically serves two purposes:
     329



330

 

• As a MIDI editor for users who prefer to use traditional music notation as an interface 
for MIDI sequencing. Input, editing, copying, or deleting of MIDI events and changing 
their musical position can be done directly in the Score window. You can also change 
between different display levels (view single or multiple parts at once).

• To prepare and produce printed music. The number of staves in a score is only 
limited by the paper size. Each staff can contain up to 16 independent (“polyphonic”) 
voices.

In addition to notes (which always represent MIDI events), numerous musical symbols 
can be inserted. Text (or any symbol which is part of a text font) can also be integrated 
into the music.

Single pages, or parts of them, can be exported to graphic or text based programs with 
the camera tool. The selected area can be saved as a graphic file, or copied to the 
Clipboard, and then imported or pasted as a picture in another program. This is 
especially useful when preparing teaching material.

MIDI sequencing and notation layout for printing are closely related in Logic. Recorded 
MIDI notes are immediately displayed in the score. On the flipside, notes inserted with 
the mouse onscreen, or changes to existing notes, are immediately reflected in the 
MIDI playback.

Opening the Score Edit Window
There are several ways to open the Score window:
• Main Windows > Open Score menu option.
• The Open Score Window key command (Default:  Command-3).
• Double-click on a MIDI Region in the Arrange window, if Double-clicking a MIDI 

Region Opens Score Editor is selected in Logic > Preferences > Global > Editing.
• To recall an open window (which is hidden by other windows), select the window’s 

name in the main Windows menu, where all currently opened windows are listed.

Several Score windows can be open at once. This allows the display of different groups 
of instruments, by using different Instrument Sets, for example.
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Elements of the Score Edit Window
Here’s an overview of the Score Edit window’s elements.

Along the Left-Hand Side:

Along the Top Margin:
• Bar Ruler (linear view only)
• Zoom symbols
• Menus

The Main Working Area:

Optionally shows:
• Instrument name display column on the left side.
• Hyper Draw area at the bottom (only possible in single MIDI Region view and with 

linear display).
• Page Rulers (only in page view).

The various options for changing the display of these elements are described in the 
General Appearance of the Score Edit window section (see “View Menu” on page 336).

Instrument Set Box

Buttons for Catch, Link, MIDI In, MIDI Out, and Page Edit view

Display Parameter box

Part box (groups and individual)

Toolbox

Event Parameter box
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Positioning the SPL Directly in the Score
The Song Position Line can be set directly in the Score window by Option-clicking a 
staff at the desired position. This function is only available when the sequencer is 
stopped. It is especially helpful in Page view, where no Bar Ruler is displayed. The 
selected position is displayed in the Help Tag while the mouse button is pressed.

Notation Concept
MIDI sequencing and score display are closely related in Logic. Every note in the score 
represents a MIDI note event. MIDI Regions are interpreted for display by Logic, using 
methods that can be influenced by the user to a great extent. The goal is to retain the 
feel of real time recordings, while still rendering a readable score.

If notes are entered into the score with the mouse or step input, they are also played 
back via MIDI, as they represent MIDI events.

Basics
Recorded MIDI Regions are automatically displayed in the Score window. If you like the 
sound of playback, but not the score display, you can usually obtain the desired results 
by changing settings in; the Display Parameter box, the various Song Settings dialog 
windows, or the Note Attributes. You can further control the display by selecting or 
creating Score Styles, Instrument Sets, and Text Styles that best fit your music.

If you generally prefer mouse input, you first need to create one or more empty MIDI 
Regions in the Arrange window with the pencil tool. These will be displayed as empty 
staves in the Score window. Rests are usually displayed automatically in Logic, and 
don’t need to be manually inserted.

If you want to use the mouse to insert new notes into a previously recorded MIDI 
Region, you can select a rhythmic note value from the Part box, and drag it to the 
desired bar and pitch position, in any of the visible staves. 

No matter which input method you decide to use, the selected display settings always 
apply to the inserted MIDI events. This means that a thirty-second note can only be 
displayed if the Qua parameter in the Display Parameter box of the corresponding MIDI 
Region is set to 1/32, or shorter. If the value is set to 1/8, an inserted 32nd note will be 
displayed as an eighth note (but will still play back as a 32nd). The display is also 
affected by the Interpretation setting in the MIDI Region’s Display Parameter box. These 
settings can be different for each MIDI Region—even for MIDI Regions on the same 
track! Simply cut the MIDI Region with the scissors tool to use different display 
parameter settings in the same staff. Once cut, you can assign different display settings 
to the resulting shorter MIDI Regions, although they will still be displayed as one, 
uninterrupted staff. MIDI playback is not affected by this procedure.
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The Part Box contains a number of symbols that can be inserted into the score by 
dragging them into position with the mouse.

The printed result always corresponds to what you see in the selected Score window 
(Page Edit view must be activated). Layout work should be done in page and print 
view, after all of the notes (and most of the symbols) have been recorded or inserted.

Staff Display…
…in Relation to the Position and Length of MIDI Regions in the Arrange 
Window
MIDI Regions in the Arrange (see “MIDI Regions” on page 107) window represent parts 
played by certain instruments (on tracks), and are displayed as staves in the Score 
window. Depending on the selected Score Style (see “Basics” on page 380), an 
instrument’s notation can be displayed in a staff system containing two or more staves 
(such as a two staff system for a piano part). 

Each of these staves or (Arrange window) tracks, can contain an (almost) unlimited 
number of MIDI Regions. If the MIDI Regions on one track directly follow one another 
in the Arrange window (with no gaps between them), they are displayed as one 
continuous staff in the score, unless you have limited the view to a single MIDI Region, 
by engaging content linked mode. In linear view, you will still see clefs, time and key 
signatures at the beginning of each MIDI Region, but these disappear as soon as you 
change to Page Edit view.

The Display Parameters (see “The Display Parameter Box” on page 374) for each of these 
MIDI Regions can be set independently. This allows you to influence the visual display 
of (the notation contained in) MIDI Regions very flexibly—especially the display of 
rhythmic values. If necessary, MIDI Regions can be divided into several smaller Regions 
with the scissors tool (available directly in the Score window), allowing you to assign 
different display parameters to each resulting part.

Selected MIDI Regions are displayed with blue stave lines (unless this option is 
deactivated in the Score Preferences (see “Score Preferences” on page 423), making it 
very easy to identify the currently selected part.

Aliases in the Score Display
Alias (see “Aliases” on page 124) is a term used for MIDI Regions and Folders in the 
Arrange window that are not independent. Alias objects “mirror” other MIDI Regions 
and Folders at different positions and/or tracks. Wherever an alias exists, its parent 
(original) MIDI Region or Folder is played back.

Aliases are also displayed in the Score Edit Window, and can be printed. The display of 
Alias objects can be switched on or off via Layout > Global Format > Show Alias.
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An alias can be assigned a different Score Style than its parent Region. As an example, a 
melody played in unison by several instruments can be handled as a regular MIDI 
Region, and several aliases. Different Score Styles can be used for the different 
instruments, including transposing Score Styles. If you decide to change something in 
the melody, you don’t need to edit all copies of it. Just make the change in the parent 
MIDI Region, which will automatically be reflected in all of it’s aliases.

Alias Editing
You can directly edit the notes and symbols in the displayed alias if Layout > Global 
Format > Allow Alias Editing is switched on. Please be aware that this alters the data of 
the original MIDI Region and all aliases created from it, because only the original MIDI 
Region can actually contain MIDI data.

If Allow Alias Editing is switched off and you try to edit an alias, a dialog that will offer 
the following options:
• Cancel:  the aliases and the original MIDI Region remain untouched.
• Enable Alias Editing:  Alias Editing is enabled; remember that this actually edits the 

original MIDI Region.
• Copy Region:  A copy of the original MIDI Region is created. You can now edit the 

notes independently of the original MIDI Region, as the alias is also a real Region.

Basic Elements for Score Display
The following elements and parameters form the basis of Logic’s score display. 

Instrument Sets

Instrument Sets (see “Instrument Sets and Score Display Levels” on page 401) allow you 
to control which instruments are displayed (and printed) in a score. You can include as 
many (or few) of the existing track instruments into a score as you wish. The order of 
the instruments can be arranged independently of their order in the Arrange window. 
You can assign names and abbreviated names to each track instrument, independent 
of the actual track instrument names in the Arrange window. These names are 
displayed in the score. You can also define which staves are connected with brackets 
and bar lines, to form groups of instruments in the score.

Any single instrument can be quickly extracted from the score, by selecting it from the 
pull-down menu that appears when you Option-click on the Instrument Set Box. This 
way, you don’t need to create an Instrument Set for every instrument, in order to 
produce parts. The automatic line breaks and individual stave margins can be 
independently changed for each Instrument Set. Please see the Instrument Sets section 
for details.
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When you open a new Score window with several MIDI Regions selected in the 
Arrange window, an Instrument Set will automatically be created and displayed in the 
Score window. This Instrument Set only contains the instruments of the selected MIDI 
Regions.

Score Styles
Each Score Style (see “Basics” on page 380) contains a collection of score settings. Their 
function could be compared to that of text formats in word processors and layout 
programs. In place of text settings, Score Styles contain the staff size, display 
transposition, stave distance, number of independent voices and so on. Obviously, 
defining all of these settings each time a new MIDI Region is created or recorded would 
be painful. Fortunately, you can assign any desired Score Style to any MIDI Region. In 
fact, any number of Score Styles may be created and assigned to individual MIDI 
Regions. There are a number of Score Styles included in the template files that come 
with Logic, and in Logic’s default song. Please see the Score Styles section for details.

Text Styles
These are user-definable text formats for all types of displayed text.

Display Parameter box
The parameters of the Display Parameter box (see “The Display Parameter Box” on 
page 374) mainly affect the rhythmic display of selected MIDI Regions. They can be 
different for each Region. Some of these parameters can be overridden for individual 
notes, by using Note Attributes.

Song Settings
You can set general display options that affect the whole song in the Song Settings 
(see “Song Settings for Score Display” on page 410) window. These include; spacing 
between notes, page margins, line thickness, display of instrument names, bar and 
page numbers, and a lot more.

Note Attributes
The Note Attributes (see “Note Attributes” on page 398) affect single notes or—when 
assigning them to a group of notes—all selected notes. The following parameters can 
be defined individually for each note:
• Enharmonic changes.
• Settings for Interpretation and Syncopation, independent of the settings in the 

Display Parameter box.
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• Stem direction, tie direction, and beaming, independent of the settings in the Score 
Style being used.

• Display as an Independent Note, which excludes the note from the measure’s overall 
rhythmic calculation.

• Horizontal graphic offset from the default position.
• Change of accidental distance.
• Change of note size, and form of the note head.

General Appearance
View Menu
You can activate and deactivate the following display options by selecting the 
corresponding menu entries. Activation is indicated by a check mark:

Colors
The entries in this menu set the color mode for the active score window. These settings 
have priority over all other color settings.
• Normal or Individual means that colors are assigned according to the color settings in 

Score Styles and Note Attributes. As long as these settings haven’t been changed in 
new songs, this will result in a regular black and white printout—and black notes on 
a yellow background onscreen.

• Show Pitch applies colors in accordance with note pitches. The colors of notes can be 
edited in the Layout > Colors window. You can also determine whether notes with 
accidentals have the same color as those without accidentals, or if each note in the 
chromatic scale will have its own color, in this window.

• Show Velocity applies eight different colors in accordance with MIDI velocity. These 
colors can also be edited in Layout > Colors.

• Show Voice Assignment assigns different colors to different Voices. This only makes 
sense in Score Styles that contain more than one Voice. This mode employs the 
colors of the user palette, which can also be found and edited in Layout > Colors.

• Force Black & White does exactly that. This mode is useful when color options have 
been used in Score Styles or have been assigned to notes using Note Attributes, but 
you want to print a regular black and white score, and return to the colored display.

Page Edit
Note:  A quicker way of changing between Linear and Page Edit view is to click on the 
button in the upper left corner, or use the corresponding key command.

You should use linear view for editing, as screen redraws are much faster, especially on 
slower computers. Page view should only be used for layout work, in preparation for 
printout.
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You can jump directly to any page, using the Go to Page key command, when working 
in Page view mode. The Song Position Line is automatically set to the beginning of the 
selected page, unless the sequencer is running when you execute the command. In this 
situation, Catch mode will be turned off.

In Page View mode, Logic will automatically display as many pages next to each other 
as possible, according to the size of the Score Edit window and current zoom level.

Print View
Print view will also show the page margins onscreen (if Page view is activated). 
Note:  the yellow area on the screen represents the printable area (which also depends 
on the printer being used), not the actual sheet of paper.

Explode Folders 
Displays the contents (MIDI Regions) of all lower display levels (folders), along with the 
MIDI Regions of the current level. 

If this option is not activated, folders are displayed as gray beams in linear view. In Page 
view, they are not visible at all. As with the other windows, the contents of a folder will 
appear when you double-click the gray beam that represents it.

Explode Polyphony 
Displays every voice of a polyphonic Score Style on a separate staff. In general, this is 
not intended for printout, but for convenient editing of polyphonic voices. 

Scroll in Play
Changes Logic’s scrolling behavior when Catch is activated:  the current song position 
is always shown in the middle of the window, making the score display itself move 
around the SPL, which stays in the center of the screen.

Part Box 
• Show All Groups:  If deactivated, only the Part box Group that is currently selected in 

the top section of the Part box, appears below it.
• Lock Group Positions:  This allows you to lock the order of Part box Groups. If 

unlocked, the group of the most recently selected object is always moved up to the 
top (of the lower section) of the Part box.

Toolbox 
Hides/Shows the Toolbox on the left side of the Score window. As in all Logic windows, 
the Toolbox is displayed at the current cursor position when you use the Esc key 
command. Select a tool, or press Esc again to close the Toolbox.

SMPTE Time Ruler 
Displays SMPTE timecode positions in the Bar Ruler (only in linear view). If there’s 
enough vertical space, it will show both bar and timecode positions.
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Parameters 
Hides/Shows the left column of the Score window (Display Parameter box, Event 
Parameter box, Part box, and so on).

Instrument Names 
Hides/Shows the names of (used) track instruments, to the left of the score display.

Page Rulers 
Hides/Shows rulers in Page Edit view. Measurement units can be centimeters or inches.

White Background 
Switches between a white and colored background.

Hyper Draw 
If you activate one of these options, a Hyper Draw area appears at the bottom of the 
main working area, allowing you to easily insert control data. You can change the area 
height, by dragging the borderline vertically with the mouse. Note that Score Hyper 
Draw is only available when single MIDI Regions are displayed in linear view.

Other Options
Adjusting the Borders Between the Different Areas
You can move the left and upper borders of the main working area by positioning the 
cursor on one of the border lines, and click-dragging it. During these operations, the 
cursor features two or four arrows. There are three possibilities:
• On the left side, you can alter the width of the columns containing the parameters, 

(mainly changing the appearance of the Part box Groups), and the instrument 
names.

• Along the upper border, you can create vertical headroom. This is useful for working 
on parts containing very high notes, or symbols above high notes (such as slurs), 
which might not be otherwise visible, and therefore can’t be edited.

• In the upper left corner of the main working area, you can change the width of the 
parameter column, and the height of the bar or page ruler. If View > Instrument 
Names is activated, the width of the instrument name column can also be changed.

Parameter Boxes
Both the Display and Event Parameter boxes can be reduced/restored, by clicking on 
the triangle in the upper left corner of each parameter box.

The Main Working Area
The appearance of the score display depends on:
• The settings of the Link and Catch buttons (see “Display Levels” on page 401)
• The selected Instrument Set (see “Instrument Sets and Score Display Levels” on 

page 401)
• Page or Linear view (View menu, and/or button to the right of the MIDI Out button)
• Zoom level 
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• Explode Folders (see “View Menu” on page 336) on or off
• Explode Polyphony (see “View Menu” on page 336) on or off
• Hyper Draw (see “Hyper Draw in the Score Edit Window” on page 347) on or off

Input Methods in the Score Window
There are several ways to input notes and symbols in the Score window:
• Real time MIDI recording (notes and sustain pedal markings only)
• MIDI step input (notes only)
• Mouse input from the Part box (notes, text, and all symbols)
• Insertion of copied events (all, except global events)
• Fast input of symbols by assignment to selected notes with key commands. These 

are available for some symbols which are attached to notes (accents, Jazz symbols, 
and so on) and slurs or crescendi.

• Hyper Draw (see “Hyper Draw in the Score Edit Window” on page 347) allows you to 
insert and edit MIDI events that aren’t normally displayed in the Score window, such 
as continuous controller data (volume, pitchbend, and so on).

The various input and insertion methods can be combined. With all input methods, 
however, you should always remember that MIDI playback is also influenced by the 
settings in the Region Parameter box (see “MIDI Region Playback Parameters” on 
page 116) and Instrument Parameter box (see “The Instrument Parameters” on 
page 102) in the Arrange window. Settings in the Environment may also affect MIDI 
playback, if configured to do so.

Score Display Options—a Survey
With a few exceptions, a printed score (see “Printout” on page 341) is always identical to 
the Page Edit view display in the currently active Score window.

The display depends not only on what was recorded or inserted, but also on the 
chosen display settings. As there are a quite a few, each affecting certain aspects of a 
song’s display, here is an overview of the various settings. These are organized into 
groups, ordered in accordance with their influence on the overall display. Detailed 
explanations of the following terms are provided on the indicated pages.

Settings that affect all song files:
• The Score Preferences (see “Score Preferences” on page 423)

Settings that affect the score display of one song file:
• Page format, and printer driver

Song Settings (see “Song Settings for Score Display” on page 410) (menu Layout):
• Global Format
• Clefs & Signatures
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• Extended Layout Parameters
• Numbers & Names
• Guitar Tablature…
• Text Styles…
• Score Styles… (see “Basics” on page 380)

Settings that can be assigned differently for each Score window, allowing 
different score displays within the same song file:
• Display levels:  Content Linked, Linked, or Not Linked
• Explode Folders
• Instrument Set (see “Instrument Sets and Score Display Levels” on 

page 401):  selection and order of the displayed instruments
• Explode Polyphony
• Linear view or Page Edit view (printout can only be started from Page Edit view)
• Zoom levels (does not affect the printout)

Settings that affect the score display of a particular MIDI Region:
The parameters in the Display Parameter box:
• Score Styles…
• Display quantization (“Qua”)
• Interpretation
• Syncopation
• No Overlap
• Max. Dots

Special case:
• Score Off in the Extended Region Parameters 

Settings that can be changed for each note individually, regardless of the 
default settings:
• Accidentals:  Enharmonic Shift
• Accidental Position (distance to note)
• Beaming of notes
• Stem Direction
• Interpretation
• Syncopation
• Tie Direction
• Note head appearance (Head)
• Treating a note as Independent Note or Independent Grace Note
• Note size (Size)
• Horizontal Position:  Graphic positioning
• N-Tuplet settings (Tuplets)
Chapter 15    Score Editor



 

Printout
It is important that you first choose the appropriate paper size and format in the File > 
Page Setup menu. The Score window (containing the intended print view) must be the 
active window. Start printing by selecting File > Print, or use the corresponding key 
command (default:  Command-P). A dialog box, which will vary slightly from printer to 
printer, is shown. Depending on the printer, there may be some additional options, 
such as which page numbers you would like to print, or the number of copies. Make 
your selections, and click the Print or OK button.

The printout is always identical to the Page Edit view display in the Score window. The 
following items are not printed, however, but are visible on the screen:
• The dashed lines that represent page and header margins, and borders between staff 

systems
• Cursor, Song Position Line
• Colors (page margins, stave lines of selected MIDI Regions)
• Hidden time signature changes
• Hidden note heads (displayed in gray onscreen), and their ties
• Hidden bar lines (displayed as dashed lines on the screen)
• Hidden N-Tuplet numbers

Printers work at higher resolutions than monitors. As such, you should work at high 
zoom levels when doing layout work that requires precision, such as positioning 
symbols and text elements.

It’s very easy to switch back and forth between a normal and enlarged view of the 
display, by using the magnifying glass tool (shortcut:  rubber band selection while 
holding down Control, to enlarge the selected area). 

Using External Symbol Fonts for Display and Printout of Notes and Symbols
You can use the Sonata font from Adobe™, the Jazzfont (http://www.jazzfont.com/) 
and the Swingfont (not included with Logic), instead of Logic’s internal score font, for 
display and printout of notes and symbols. The external font must be properly installed 
on your system. Activate Options > Score Preferences > Use external Symbol Font (if 
available) and choose the font you wish to use in the corresponding pull-down menu.

The onscreen display of some of these fonts can be hard to read (especially at smaller 
zoom levels), so there’s also an option to only use the external font for the printout. 
Select only for Printout is the Score Preferences option.
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Graphic Export
There are two ways to export Logic’s notation into other programs, as graphic images:

PICT Export Using the Camera Tool
You can save a part of a Logic score page (or a whole page) as an image (PICT format), 
and paste it into documents created with other programs (word processing and DTP 
software). Use the Camera tool to select the desired score section, using the “rubber 
band” selection technique. As soon as you release the mouse button, Logic creates a 
PICT file (or copies the selection to the Clipboard—see option below), encompassing 
the area you dragged the Camera tool over. This function is only available in Page Edit 
view. 

There are some related settings in Logic > Preferences > Score Preferences:

Graphic Export Resolution
Determines the resolution of the exported image file. This can be set between 72 and 
600 dpi.
• If the image is only intended for use on a computer screen, use low resolution 

(72 dpi).
• If the image is intended for a document that will be printed, select your printer’s 

resolution.

Graphic Export to (pull-down menu)…
• Clipboard:  The image is copied to the Clipboard and can be pasted directly into 

other documents, without saving it as a separate file.
• PICT File:  The image will be saved as a PICT file. A file selector box allows you to 

assign a file name and path.

PICT File Creator ID
This allows you to determine which program will be used to open the file when you 
double-click it in the Finder. The default setting is ttxt. This setting, however, has no 
influence on the file format itself.
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Realtime MIDI Recording
Although real time MIDI recording is usually done in the Arrange window, you can also 
start recording directly from the Score window. You must first select the destination 
track in the Arrange window’s track column. This can be done directly from the Score 
window, by clicking on a staff that belongs to the desired track. If no MIDI Regions exist 
on the track, you will need to switch to the Arrange window for recording, because the 
track won’t be displayed in the Score (the Score window only shows Regions and 
folders).

If you want your recording to become part of an existing MIDI Region (because you use 
score template files), select the global Song Settings > Recording Options menu item, 
and activate Merge New Recording With Selected Regions, before starting to record. Also 
make sure that the destination MIDI Region is selected, or Logic will create a new MIDI 
Region on the same track, which will probably overlap the existing one. 

The display of recorded notes depends on:
• The score display settings, especially those in the Display Parameter box (see “The 

Display Parameter Box” on page 374) and the Note Attributes (see “Note Attributes” 
on page 398). Please read the corresponding sections in this chapter.

• The Quantize and Transpose settings in the Arrange window’s Region Parameter box 
(see “MIDI Region Playback Parameters” on page 116):

Logic creates a score display based on the MIDI data, including any changes caused by 
these two playback parameters.

An example:  if Transpose is set to +2 in the Region Parameter box, a note that was 
initially a C (when recorded) will be played back and displayed as a D. The same applies 
to playback quantization, with the exception of notes that were “unquantized” with the 
Quantize tool, or the corresponding key command. 

Step Input
Step input (see “Step Input” on page 44) in the Score window works in the same way as 
other editor windows.

The Score Edit window, however, is the only editor (apart from the Matrix editor) where 
the content of several Regions can be displayed and edited at once. This ability results 
in some differences relating to step input in the Score window:
• The MIDI Region that you want to insert notes into must be selected (click on the 

staff ). If no staff is visible, you must first create an empty MIDI Region in the Arrange 
window.
Chapter 15    Score Editor 343



344

 

• Simultaneous step input into several Regions is not possible. If more than one MIDI 
Region is selected, the notes will be inserted into only one of them.

• If several Regions follow one another on the same Arrange track (even those with 
gaps in-between them), you can step input notes from one MIDI Region to the next. 
As soon as the SPL reaches the beginning of the next MIDI Region, Logic will 
automatically insert the notes into it.

Mouse Input
A staff must exist before notes, symbols, and text elements (called objects in the 
following sections) can be inserted. Each staff (even an empty one) is the direct 
representation of one or more Regions. Empty Regions can be created with the pencil 
tool in the Arrange window, where their length and position can also be changed.

These empty Regions are displayed in the Score window as empty staves. Rests are 
automatically displayed (unless the automatic rest display is deactivated in the 
assigned Score Style).

Input
Prior to any mouse input, you first need to select an object in the Part box, and drag it 
to the desired position in the main working area. As a positioning aid, you will see a 
Help Tag while you’re “holding” the object with the mouse. Drag the mouse until the 
desired position is shown in the Help Tag, and release the mouse button. The Help Tag 
is especially important for positioning when working at smaller zoom levels.

When working in full score view, and inserting objects between the staves (such as 
dynamic symbols), you should make sure that these symbols have been inserted into 
the desired MIDI Region/staff. Immediately after inserting an object, the target MIDI 
Region will be selected, and displayed with blue stave lines. You can also see its name 
in the top line of the Display Parameter box.

It’s generally better to change to single staff display (double-click on the staff ) when 
inserting objects that are positioned between staves (especially lyrics). Although it 
doesn’t matter which MIDI Region an object belongs to in full score mode (as they stay 
where they are placed), such objects can be displayed with the wrong instrument, 
when single instrument parts are later displayed and printed.

All Part box objects and features are described in detail in the Part box section (see 
“The Part Box” on page 348).

In the Event List, notes and sustain pedal markings are listed as MIDI events, and most 
other symbols and text objects as Meta events. Global symbols, global text elements, 
time, and key signature changes are not listed in the Event List. Symbols attached to 
notes (accents, note heads, and so on), are not listed as events in the Event List, but are 
saved with their “parent” notes (the notes they belong to/are associated with).
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MIDI Channel and Velocity of Inserted Objects
The MIDI channel and velocity of objects inserted with the mouse are determined by 
the Insert Defaults settings in the Event Parameter box. These are visible (and can be 
edited), when no object is selected. Click anywhere in the background of the working 
area to display the Insert Defaults settings.

Ensure that “Insert Defaults” is displayed in the top line of the Event Parameter box. 

When inserting events into a staff which uses a Polyphonic Score Style (see “Editing 
Single-Staff Polyphonic Styles” on page 392), only MIDI channels that correspond to 
those of the voices can be used.

Many symbols, apart from notes (all Meta Events), display a MIDI channel in the Event 
List. Some of them even have a velocity parameter. These parameters vary in the Event 
Parameter box:  for most objects, the MIDI channel indicates a Staff parameter, which 
determines the staff (theoretically, up to 16) that the symbol belongs to, in Polyphonic 
Score Styles. BE CAREFUL:  if this parameter is set to a value that exceeds the number of 
staves in the Score Style, the symbol will disappear.

Insert Quantization
To make positioning of notes and symbols easier, objects can only be inserted at 
certain bar positions:
• There is an invisible note positioning grid. You can imagine its resolution as if the 

whole bar—beginning at beat one—were filled with notes of the chosen value. An 
example:  in an empty 4/4 measure, half notes can only be inserted on beats one and 
three, eighth note triplets only on the first, second, or third eighth note triplet of 
every beat.

• All binary and dotted values can be inserted at any position of an automatically 
displayed rest. This means that if there is an eighth note on one, you can insert a 
quarter or a dotted quarter note at the second eighth’s position. (In this situation, 
Interpretation must be turned off in the Display Parameter box, to allow the display of 
the eighth note rest on the “and” of beat one). The Syncopation setting determines 
how the inserted note is displayed, in this example.

• Symbols (except those directly attached to notes) can be inserted at any position 
that corresponds to the grid defined by the Qua parameter. For hybrid quantizations 
(such as 8,12), the insert quantization is determined by the binary value (1/8 in this 
example).
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You can move any note, and most symbols, to any desired position, by editing its 
numeric bar position in the Event List, or the Event Float Window (see “Event Float 
Window” on page 310). As an example, if you want to insert a half note on “two” in 4/4 
time, place it on “one” or “three”, and change the position to “two” in the Event Float.

Simultaneous Input of Objects Into Several Regions
If you hold down Shift while inserting an object from the Part box, the object is 
inserted at the same position into all currently selected Regions. The help tag will 
display Insert Multi during this process. This technique allows you to insert notes, 
symbols, and even text elements into several Regions at once. (Text elements will not 
appear until you have finished the text input procedure).

You may make the multiple MIDI Region selection in either the Arrange or the Score 
window. Shift-click all desired Regions/staves, or use the rubber band selection 
method. You don’t need to select events in the Score window—just drag the cursor 
vertically across the staves that you want to select.

Following selection, the top line of the Display Parameter box will indicate the number 
of staves (Regions) that have been chosen.

Key changes, signature changes, and global signs are automatically inserted into all 
staves of a song, and cannot be inserted into individual, selected staves.

Exact Graphic Position of Symbols
When inserting a symbol that isn’t automatically attached to a note, you should pay 
attention to the following details:

All symbols are inserted at the bar position indicated in the Help Tag, when you release 
the mouse button. This position corresponds to the symbol’s Event List line. Apart from 
the bar position, further parameters that affect the graphic offset (from the inserted bar 
position) are available.

These are shown, and can be edited, in the Event Parameter box (vert. pos, hor. pos). The 
measurement unit of these two parameters is one sixteenth of the distance between 
two lines in a staff. These distances are scaled accordingly when the Size of the staff 
(defined in the selected Score Style) is changed.
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Make sure that the bar position really is identical to the graphic display position when 
inserting symbols. As an example:  If you work with small Spacing parameters (in Layout 
> Global Format), a “Forte” symbol placed under a note on one may be interpreted as 
being on two, with a negative hor. pos value because you placed it a little bit too far to 
the right. This won’t make any difference as long as you stay on that particular display 
level. 

If you switch to a different display level (to extract the parts of single instruments), this 
can result in an undesired display, as these graphic position values represent an 
absolute distance (defined by the vertical staff size). If you later change the Score Style, 
the line breaks or some other layout parameter, a different number of bars may be 
displayed in one line. Given that the horizontal offset (hor.pos) is calculated as an 
absolute distance from the new (relative) graphic display of the bar position, the Forte 
symbol may then be displayed at a position closer to the second beat than to the first.

The following key commands move any score symbol that can be positioned 
independently of notes or staves. They also apply to text events and chord symbols:
• Nudge Position Up
• Nudge Position Down
• Nudge Position Left
• Nudge Position Right

These functions alter the hor.pos. and vert.pos. parameters by ±1, rather than the bar 
position of the affected symbols and text events. 

Hyper Draw in the Score Edit Window
If you activate View > Hyper Draw, you can insert and edit MIDI events which aren’t 
normally displayed in the Score window (volume, pitchbend, and so on). The type and 
channel of the MIDI data displayed in the Hyper Draw area can be selected and 
changed from the View menu.

Hyper Draw (see “Hyper Draw” on page 233) in the Score window operates in the same 
way as in the Arrange window.
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Hyper Draw can only be activated in Linear view, and when a single MIDI Region is 
displayed. If you switch to another mode (Page Edit view, or full score), the Hyper Draw 
area disappears. The view settings are stored, however, so when you return to single 
MIDI Region and Linear view, the previous Hyper Draw setting is recalled.

The Hyper Draw display is horizontally scaled, in relation to the score display above it. 
Its height can be changed, by dragging the horizontal borderline with the mouse. A 
corresponding value scale is displayed in the instrument name column if View > 
Instrument Names is activated. As in the Arrange window, you may select and/or 
change the event type and MIDI channel displayed in the Hyper Draw area, via the View 
> Hyper Draw menu option.

Hint:  Set Hyper Draw to Note Velocity to graphically display and edit velocities.

The Part Box

The objects available in the Part box (notes, symbols, text objects) are organized in 
groups. The top section contains small squares, with each representing a group. All 
groups (with all available symbols) are shown in a panel below. The arrangement of 
groups can change. If you click on one of the squares in the top section, the 
corresponding group moves to the top of the panel below, for easy access to its 
symbols.

Any symbol can be selected and inserted, directly from the group panel, at any time. 
The function described above makes it easier to work with the Part box, especially on 
smaller screens, or when using small Score windows.

Selecting and Inserting Part Box Objects
There are various ways to select and insert objects:

m Selecting an object with the mouse from one of the object groups, and dragging it to 
the desired position in the Score display. If a particular object group isn’t visible, click 
on its symbol in the top section of the Part box. This places the selected object group 
at the top of the group panel.
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Note:  To select an object, you can also click-hold on one of the squares that represent 
the Part box groups:  a pull-down menu containing all of that group’s symbols will 
appear. 

m Direct Insertion of a selected symbol:  if the desired symbol is already selected 
(indicated by its inverted display in the Part box), click the desired position in the staff 
with the pencil tool. If you click-hold the mouse button, you will be holding the 
previously selected symbol. Drag it to the destination position, while keeping an eye 
on the Help Tag for positioning information.

Using Floating Palettes 
A double-click on one of the squares in the top section of the Part box opens a small 
floating window, containing all objects of the corresponding group. This palette can be 
moved to any onscreen position. Objects can be dragged directly from these palettes 
into any position in the Score. 

Note:  Unlike the regular Part box, the object selection is not visible in the palettes.

The palettes can have different shapes, depending on the modifier pressed while 
opening a floating palette with a double-click:
• Normal (Control)
• Vertical (Option)
• Horizontal (Command)

If you don’t wish to use a modifier key when you open a palette, the shape can be 
predefined in the Score Preferences > Open Floating Palettes pull-down menu.

As many palettes as required can be simultaneously opened, and positioned around 
the screen.

Object Selection by Key Commands
The following (user definable) key commands (see “Key Commands” on page 36) 
selects the corresponding note values in the Part box. These can then be quickly 
inserted with the pencil tool:
• Part box 1/1 Note
• Part box 1/2 Note
• Part box 1/4 Note
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• Part box 1/8 Note
• Part box 1/16 Note
• Part box 1/32 Note

If you execute any of these twice in succession, the corresponding triplet value is 
selected, three times selects the dotted value, and four times returns to the original 
value. 

Further key commands can also change the selection inside the Part box:

• Next Part box Symbol
• Previous Part box Symbol

Next moves the selection (similar to a text cursor) to the right, Previous to the left. After 
reaching a group’s last object, the selection cycles back to the beginning of the group.

• Next Part box Group
• Previous Part box Group

Next moves the selection to the object group below the current (selected) one. Previous 
moves one group up, as determined by the current order of the groups. When 
changing between groups, the most recently selected object within each group is 
retained.

Display Size of Inserted Objects
The size of inserted objects (except text and chord symbols) always corresponds to the 
size of the staff they are inserted into, and changes if the staff is resized via the Score 
Style (see “Basics” on page 380).

Most objects can be made larger or smaller after insertion with the Sizing tool (as can 
text elements, except chord symbols). Just grab the object with the tool and move the 
mouse up or down. Changes are immediately visible.
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Notes

The square that represents notes, in the top section of the Part box, is divided into 
three parts. This is because note values are organized into three sub-groups. Each can 
be brought to the top of the group panel by clicking on the corresponding symbol 
within the note square (note, dot, or 3).

Inserting any of these symbols creates a MIDI note event, of the exact note length 
value. For display purposes, however, all of these MIDI notes are interpreted by Logic as 
if they were recorded in real time. Therefore, the Display Parameter box settings need 
to be set in a way that allows inserted notes to be displayed correctly.

If you only want to enter notes with the mouse, without using real time recording at all, 
switch off Interpretation (see “Interpretation” on page 378) and No Overlap (see “No 
Overlap” on page 379) in the Display Parameter box, and choose a very high Qua value 
(128, 384). Syncopation (see “Syncopation” on page 379) can be set according to style, 
and personal preference.

Allowing Diatonic Input Only
Select Options > Diatonic Insert to limit input to notes that are diatonically correct for 
the current key. Notes can be altered chromatically, once they have been inserted.

Note:  If you protect (lock) your screensets (see “Screensets” on page 30), this function’s 
setting will also be “locked”.

Ties
Notes which are displayed as several graphical notes, connected with ties, only 
represent one MIDI note. To create such notes, you first insert a shorter note value, then 
change its length in the Event Parameter box (see “Other Options” on page 338), the 
Event List (see “Using the Event List” on page 297), or the Event Float (see “Event Float 
Window” on page 310) window.

Ties cannot be inserted directly into Logic, but are created and displayed automatically, 
according to the length of the MIDI note. The up/down direction of each tie can be set 
with Attributes > Ties.
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Changing the Way Notes With Ties Are Displayed
If you don’t like the way particular tied notes are displayed, you can change the display 
by inserting a user rest at the position you want to see a graphic note. The rest’s length 
is not important, but you should preferably use a shorter one (an eighth note rest). 
Watch the Help Tag, for exact positioning. As soon as the rest is inserted, it will no 
longer be visible in the score display, but the note display will change accordingly. If 
you want to change the position of a rest, or delete it, you may do so in the Event List.

N-Tuplets
The symbol for N-tuplets is found in the triplet group.

Depending on the selected display quantization, and the particular situation, Logic 
usually recognizes and notates regular triplets correctly. This requires a corresponding 
Qua (see “Qua—Display Quantization” on page 377) value in the Display Parameter 
box). You need to use the N-tuplet object for the display of other N-tuplets.

Definition of Previously Recorded Notes As N-Tuplets
For notes that already exist (as part of a MIDI recording), but are not displayed correctly, 
the N-tuplet symbol needs to be dragged on top of the first note. This note must be 
indicated in the Help Tag, before you release the mouse button. A dialog box will open, 
allowing you to define the N-tuplet’s attributes:

In the score, the above would correspond to:

The dialog box is best explained with the example above:  five tuplet eighth notes 
should be displayed, in place of four regular eighth notes. The following options are 
also available:

Hide Bracket:  the bracket is not displayed.
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Hide Numbers:  the N-tuplet’s number will not be printed. It will be displayed in 
parentheses onscreen. This is necessary for further edits to the N-tuplet.

Show Denominator:  the N-tuplet display also contains the denominator (the second 
number in the dialog box). This would be 5:4 in the example above.

Direction:  the direction of bracket and number. Auto refers to the setting in the Score 
Style being used.

Allow Double Values:  if this option is activated (which is the default setting), N-tuplets 
can contain note values that are twice as long as the “regular” tuplet value. 

N-Tuplet Input With the Mouse
If you want to insert a tuplet, including all of its notes, with the mouse, insert the first 
note at the desired position, then drag the N-tuplet symbol on top of it. Define the 
required settings in the dialog box that automatically opens. 

The display will initially display a series of rests, the number of which corresponds to 
the N-tuplet value. You can insert other notes at these rest positions. Select a note 
value which approximately matches the length of the desired N-tuplet notes. In this 
example, this would be dotted sixteenth notes.

If you want to hear these notes played back with legato phrasing, and the notes are still 
too long or too short, you will need to change their (MIDI) lengths. The fastest way to 
do this is to select all notes, and then use Functions > Note Events > Note Force Legato 
(Selected/Any), or the corresponding key command.

The method described above also allows you to create N-tuplets which contain rests or 
syncopated note values (double length).

If you want an N-tuplet to begin with a rest, you first need to insert a user rest from the 
Part box, then drag the N-tuplet symbol on top of the rest. Automatically displayed 
rests cannot function as starting points for N-tuplets.

Changing or Deleting Existing Tuplets
A double-click on the N-tuplet number opens its configuration box, allowing you to 
make changes, or use the Delete button to erase the tuplet. N-tuplets also can be 
deleted by clicking on the tuplet number with the eraser tool. 

Fast Input of Several Identical N-Tuplets
If you hold down Option as you insert the N-tuplet symbol, the most-recently inserted 
N-tuplet’s settings will be used, without the dialog.
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Editing Automatically Displayed Triplets
Triplets are usually displayed automatically (depending on the Qua parameter in the 
Display Parameter box). If you want to change the way triplets are displayed, you can 
simply double-click the “3”, which opens the N-tuplet dialog box (allowing you to 
change the settings), and converts the automatic triplet to an N-tuplet. This also useful 
for hiding the numbers and brackets of “normal” triplets.

“Artificial” N-Tuplets to Bypass Display Quantization
You can bypass the display quantization value (Qua) by using hidden, “artificial” N-
tuplets. As an example, if there is a single 32nd note run in a MIDI Region that 
otherwise only contains eighth notes or longer values, you can set Qua to 1/8, and drag 
the N-tuplet symbol onto the first note of the 32nd figure. In the resulting dialog box, 
use the 8:8/32 setting, with Hide Brackets and Hide Numbers checked. The number (8) 
will be visible on screen, but not in the printout.

Although this is not the way that tuplets are normally used, it can be a handy tool for 
forcing the display of runs of shorter notes in a MIDI Region (1/32nd notes in this case), 
with a display quantize value set for longer note values (1/8 notes, in this example).

Grace Notes, Independent Notes
Independent Notes are notes that aren’t included in the automatic rhythmic and graphic 
display calculation of a measure, but are still played back via MIDI at their insert 
position. There are two types:

• Independent:  these are displayed at their original length, as long as they are binary or 
dotted note values which can be displayed as a single (not tied) note. After insertion, 
you can change the stem direction, enharmonic interpretation, accidental distance, 
and note head, using the Note Attributes (see “Note Attributes” on page 398) 
functions.

• Independent Grace:  these are always displayed as miniature eighth notes, with a slash 
across the stem, and a tie. The tie direction, stem direction, enharmonic 
interpretation, accidental distance, and note head can be changed.

Both types of Independent Notes can only appear as single notes, without beams to 
other notes.

Creating Independent Notes:
• Existing regular notes can be converted to Independent Notes via Attributes > 

Independent > Independent or Independent Grace, or corresponding key commands. 
Attributes > Independent > Not Independent converts notes back into regular notes.
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• If you want to insert an Independent Note directly, Option-select a note with the 
mouse from the Part box, and drag it to the desired position. Independent Grace Notes 
cannot be inserted directly. They need to be created by converting regular or 
Independent notes.

In most situations, you will need to create additional graphic distance between the 
Grace Note and the note it is associated with. The best way is by using the Layout tool 
(see “Editing With Tools” on page 371) to move the main note away from the grace 
note. 

Hint:  if you want to create beamed grace notes, try using a polyphonic Score Style (see 
“Editing Single-Staff Polyphonic Styles” on page 392) with no rests displayed for the 
second voice. Assign the desired grace notes to the second voice, and resize them with 
the Sizing tool.

Sustain Pedal Symbols

These two symbols are the only score symbols—excepting the notes themselves—that 
directly represent MIDI events (MIDI controller #64, sustain pedal on and off ), and thus 
affect MIDI playback. Logic intelligently inserts the On or Off version of the symbol, 
depending on the status of the type that preceded it (a Sustain Off always follows a 
Sustain On and vice versa).

Clefs

The clefs in the Part box are generally intended for clef changes in the middle of a part, 
for a short section of the music. An example would be cello or bassoon parts, when the 
part changes to a higher register. Inserted clefs change the score display, starting at the 
precise insert position (which can even be in the middle of a bar).

You shouldn’t use the Part box clefs to change the clef of a whole MIDI Region. In this 
situation, choose an appropriate Score Style (see “Basics” on page 380) for the Region.
Chapter 15    Score Editor 355



356

 

When you insert a “C-clef”, please watch the Help Tag carefully, as this clef can be 
positioned at five different heights, depending on the register (alto, tenor clef, and so 
on).

If you want to change an existing clef, double-click on it. This opens the following 
selection box. (The same applies to the “basic” clef of a MIDI Region, but changing this 
clef affects the Score Style itself, as well as all Regions that use the same Score Style).

The Smaller Clef Changes in Layout > Clefs & Signatures option also affects clef changes. 
All clefs, except the first one in every staff, will be reduced in size, depending on the 
value set here. This will happen, whether the clef changes are the result of a different 
Score Style in the same staff, or clefs have been inserted from the Part box.

Octave Settings
The four symbols on the right hand side do exactly what you expect them to:  they 
mark a section to be played either one or two octaves higher (or lower). The length of 
the section can be edited after insertion, by grabbing the end of the line and moving it 
horizontally.

Dynamic Symbols

These symbols can be inserted at any position in the score. They are graphic symbols 
only, and have no effect on the playback of Regions they are placed in.
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Note Heads

If you drag one of these symbols onto a note (watch the Help Tag:  the destination note 
must be indicated), the note head changes to that of the selected symbol. If multiple 
notes are selected, dragging the note head onto any one of the notes will attach it to 
all notes in the selection. Altered note heads do not affect MIDI playback.

If you want to return an altered note head to a standard display, use the same method, 
with the black, round note head selected.

Invisible Note Heads
Use of the gray note head will make a note’s head and associated ties invisible. This 
note is displayed with a gray notehead onscreen, allowing further edits. Nothing but 
the stem will be visible in the printout. 

If you combine this feature with Attributes > Stem > Hide, you can completely hide 
notes in the printout.

Symbols Attached to Notes

(Fermatas, accents, phrasing symbols, mute, and bow markings, and so on)

This group contains symbols which usually only refer to one note at a time (Trills, 
however, are in a separate group). These symbols are positioned automatically, as soon 
as they are assigned to a note. You do this by dragging the symbol onto the note head 
(watch the Help Tag to ensure accurate placement). These symbols always move with 
their parent notes, whether they are transposed or otherwise graphically altered.

MIDI Meaning
The symbols in this Part box group can affect the MIDI playback of notes they are 
assigned to. The effect can be on velocity and playback length. If you want these 
symbols to affect playback, you need to define the effect of each symbol, separately, in 
the MIDI Meaning dialog. This can be opened via Layout > MIDI Meaning (see “MIDI 
Meaning” on page 422).
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Quick Assignment With Key Commands 
Some symbols feature user-definable key commands (see “Key Commands” on 
page 36), which automatically assign the corresponding symbol to all currently 
selected notes:

Hint:  working with these key commands can be even faster when you also use the 
Select Next Event/Select Previous Event, and Toggle next/previous Object (Event) key 
commands. The two latter commands include the following or previous event in the 
current selection, or reverse that inclusion.

Inserting Independent Symbols 
If you want to insert a symbol that remains independent of any note, you can do so by 
holding Option during insertion. This allows you to place a fermata above an 
automatically created rest, for example.

Jazz Symbols

Jazz Symbol input is similar to the input of accents and so on:  if you drag a Jazz 
Symbol onto a note head, it will be assigned to the note, and positioned accordingly. 
Additional space will be created automatically, to avoid overlaps with other notes or 
symbols. These symbols always move with their parent notes, whether they are 
transposed or otherwise graphically altered.

Jazz Symbols can also be inserted with the Attach Symbol:  Jazz 1–6 key commands. The 
numbers 1 to 6 indicate the positions of the symbols in the Part box. Black dots are 
used to indicate the position of each symbol, in relation to the note head (compare the 
two illustrations above).

Jazz symbols may also be inserted independently from notes—as graphic objects—by 
inserting them while holding Option. These unattached symbols can be moved freely; 
and unlike normally inserted Jazz Symbols, do not affect the spacing of notes.
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Slurs, Crescendi

Input
Insert these objects at the intended (left) starting point. They can then be edited to 
their desired shape. After insertion, the object remains selected, and small black square 
“handles” are visible at its end points (or along its length, in the case of slurs). You can 
drag these “handles” with the mouse, to change the object’s shape.

Fast Slur and Crescendo Input With Key Commands
User definable key commands (see “Key Commands” on page 36) allow the fast input of 
slurs, crescendo, and decrescendo symbols:
• Insert Slur Up
• Insert Slur Down
• Insert Crescendo
• Insert Decrescendo

These commands place the corresponding object below or above (Slur Up) the 
currently selected note(s). The start point is determined by the first selected note, and 
the length of the object by the most recently selected note. The shape and vertical 
position of each object is determined by the settings of the last edited object of the 
same type.

Altering the Shape
To edit the shape of these symbols, grab and drag the black square handles—even if 
they’re not visible. To make them visible, select the object by clicking on one of its 
ends, or by rubber band selection.

Changing the Position
All but the last six objects can be moved by simply click-dragging the mouse from the 
object’s left hand starting point. The last six objects in the group are moved by click-
dragging each of their corners (handles) separately.
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Change of Length
All of these symbols can be as long as desired, and can be displayed across line and 
page breaks, in several parts.
• As an example; if you want to extend a slur to a position which is not visible in the 

Score window (in Linear view), you can grab its right end, and pull the cursor to the 
right border of the Score window:  the score will automatically scroll. As soon as the 
desired end position for the slur appears in the window, move the mouse a little to 
the left, to stop the scrolling. Now position the end of the slur. It is important that 
you do not release the mouse button during the entire process.

• In Page Edit view, you can simply drag the right end to its destination in one of the 
lower staves. The slur will be displayed in several sections. The same principle applies 
to the other symbols in this group.

• The length of these objects can also be changed in the Event List or Event Float, by 
changing the numerical length parameter. The end point is moved horizontally by 
this procedure. Slanted objects, such as arrows, will be displayed at a 
correspondingly varied angle.

• The length can exceed the end of the MIDI Region—it’s possible to drag the right 
end of a crescendo to a position in the next MIDI Region on the same track.

Particular Attributes of Certain Symbols
Crescendo:  the tip determines the general position. At the upper right end, length and 
opening angle can be adjusted. At the lower right, length and overall angle can be 
altered.

Decrescendo:  at the upper left end you can alter the bar position, and opening angle. 
At the lower left end, bar position, and overall angle can be set. At the tip (right end), 
vertical position and length are adjusted.

Lines and arrows can be moved (in their entirety) by dragging their starting point. At 
the other end, length and overall angle can be altered. The slanted line symbol denotes 
a line that can be altered freely. The other two line objects (vertical and horizontal) can 
only be extended in the corresponding direction.

Slurs:  slurs have five editing points (the black square handles are visible when the 
object is selected) for changing their shape. The last two slur symbols in the slur group 
are mainly intended for slurs across staves (in piano parts).

Reminder:  these are Slurs, not Ties (see “Ties” on page 351). Ties cannot be inserted 
manually, but are displayed automatically if a MIDI note’s length requires it.

These symbols are graphic only, and have no impact on MIDI playback. 
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Precise Positioning
It’s advisable to work at high zoom levels when positioning slurs. You can quickly 
switch to an extremely zoomed display by holding down Control while rubber band 
selecting an area of the score. This activates the magnifying glass tool, and the selected 
area is displayed at maximum zoom level. Do all your positioning and layout work at 
this zoom level, and return to the regular view by Control-clicking on any free spot.

Key Signatures

Key signature changes can be inserted at any point in a song, by dragging one of the 
key symbols from the Part box, as shown above, onto any staff. Watch the Help Tag, to 
ensure accurate placement. Remember that key signatures and key signature changes 
are effective globally, for all instruments, on all display levels.

Natural symbols are automatically displayed with a new key signature, when necessary 
(when changing from A flat major to F major or A major, for example).

Display transposition of the key signature (for notation of non C instrument parts) is 
achieved by selecting an appropriate Score Style (see “Basics” on page 380). For atonal 
music, there is the option to deactivate Automatic Key Transposition for transposing 
Score Styles, in Layout > Clefs & Signatures (see “Clefs & Signatures” on page 416). This is 
effective for the whole song. If it is deactivated, all sharps and flats are displayed 
directly with their notes. There is a similar option in the Score Style window (Key) which 
allows you to switch off the key signature for a particular Score Style, or even for 
individual staves in multi-staff Score Styles.

The basic key signature of a piece should, however, be set by double-clicking on the 
first staff, between the clef and time signature. This opens a dialog box that allows you 
to set any major or minor key. This window also lets you disable the use of double flats 
and sharps.

This method applies not only to the first staff, but for all staves. If the piece already 
contains other key signature changes, however, any newly inserted key signature only 
changes the key from the insertion point until the next key signature change. As with 
the starting key signature, inserted key signatures affect all Regions, on all levels.
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Deleting a Key Signature Change
This is done by either clicking directly on the key signature change with the eraser tool, 
or by selecting it and pressing Backspace. 

Moving and Copying Key Signature Changes
As key signatures are global symbols, they cannot be moved or copied as easily as 
other objects. 

Further editing of time signatures is possible with the help of the Time/Key Change List 
Editor (see “Time and Key Signature Editor” on page 127).

It is also possible to copy all time and key signatures from one song to another. This is 
described in the Copying Time Signatures between Songs section (see “Time Signature 
and Division” on page 77).

The display of key signatures and key signature changes also depends on the settings 
in Layout > Clefs & Signatures (see “Clefs & Signatures” on page 416), and on the Key 
parameter in the Score Style window (for each Score Style).

Time Signatures

Time signature changes can be inserted at the beginning of any bar, either by inserting 
signatures from the Part box, or by changing the time signature setting in the 
Transport window. In the latter case, the signature change will be inserted at the 
beginning of the measure containing the current song position.

Time signatures and time signature changes are effective globally for all instruments, 
on all display levels. It is not possible to insert different time signatures for different 
instruments, or tracks. Time signature changes only affect the display, not playback. The 
tempo indicator in the Transport window always relates to quarter notes, even if eighth 
notes are chosen as the denominator for the time signature. You can find more 
information about this in the Time Signature and Division section (see “Time Signature 
and Division” on page 77).
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Compound Time Signatures

Apart from 2/4, 3/4, 4/4, 6/8 and the alternative display options for 4/4 and 2/2, there 
are also Part box objects for freely definable time signatures (A/B), and compound time 
signatures (A+B/C). When you insert one of these, a dialog box opens:
• The Nominator can be anything between 1 and 32, the Denominator can be 1, 2, 4, 8, 

16, or 32.
• The Beat Grouping entry field will open when you select A+B/C, allowing you to 

determine the grouping of beats in compound time signatures. It is sufficient to just 
enter the numbers—223, for example. As soon as the entry field is closed, this 
becomes “2+2+3” automatically. The total number of beats in the bar is calculated 
automatically by the sum in this field.

• Print Compound Signature actually displays the defined grouping as the nominator. If 
this is not activated, only the total sum will be displayed as the nominator. Beat 
Grouping, however, affects the way the notes are beamed together—in both cases.

You can also change the automatic beaming in “normal” time signatures. In 4/4-time 
“1+1+1+1” produces four beamed groups (one for every beat), instead of the two 
groups displayed as a default.

Invisible Time Signatures
Hide Signature hides the corresponding time signature change in the printout. The 
signature will still be displayed onscreen, but it will be “crossed out”, and won’t be 
included in the calculation of the spacing between notes and symbols. As a result, 
signatures may overlap notes on the screen, but not in the printout.

This function can be used for notating cadenza-like passages, that contain more notes 
than would normally fit the time signature.

Editing Time Signatures
All time signatures can be edited by double-clicking on them. The dialog box 
mentioned above opens, allowing you to insert the desired changes. There is also a 
Delete option that erases the corresponding time signature change. Alternately, you 
can use the eraser tool, or select them, and press Backspace.

Further editing of time signatures is possible in the Time/Key Change List Editor (see 
“Time and Key Signature Editor” on page 127).
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The display of time signatures and time signature changes is also dependent on the 
Layout > Clefs & Signatures settings (see “Clefs & Signatures” on page 416).

All time and key signatures of a song can be copied into another song (see “Time 
Signature and Division” on page 77).

Repeat Signs and Bar Lines

These objects can be inserted at any “visible” bar position (at the position of any 
graphically displayed note or rest). Usually, however, these objects are used at the 
beginning or end of bars. In this situation, they replace the regular bar line (except first 
and second ending symbols). They are global symbols, and are always displayed in all 
staves, on all display levels. 

Moving, Deleting
Repeat signs and bar lines cannot be moved with the mouse. You need to use the 
eraser tool to delete them. These symbols can be moved, along with time and key 
signatures to a certain extent, in the Arrange window (see the two preceding sections).

The “double repeat sign” is automatically displayed as two “back to back” repeat signs, if 
it is positioned at a line break.

Invisible Bar Lines
The dotted bar line is invisible in the printout. In conjunction with hidden time 
signature changes, this enables you to create bars and musical passages which don’t 
seem to have a fixed meter. Another use for the invisible bar line is to force a graphic 
split of a note into two notes connected with ties—in all staves of a score 
simultaneously—if it is inserted in the middle of a bar.

To hide all automatically displayed barlines, use the Hide All Barlines in Layout > Clefs & 
Signatures option. Note that manually inserted barlines, double barlines, and so on will 
still be displayed and printed.
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1st and 2nd Endings
Following the insertion of one of the repeat endings, text entry mode is automatically 
activated. The default text is “1.” and “2.”. If suitable, confirm with Return. If unsuitable, 
you can freely enter any text into these brackets. The bracket which defaults to “2.” is 
open—without a vertical end line, like the “1.” ending. As the text can be changed, you 
also can create a 2nd ending with a vertical line, for example. The font, text size and 
style of these numbers or text elements is set in the Text Style window (see “Text 
Styles” on page 425) (Text Style Repeat Endings). To edit the text, double-click directly 
on it, which activates text entry mode, indicated by a flashing text cursor.

A 1st or 2nd ending can be moved by dragging its upper left corner. The length can be 
changed by dragging the right end. If a repeat ending is selected, it can be deleted 
with Backspace.

Between the staves in scores, or multi-staff Score Styles—repeat signs and the various 
special bar lines are connected across the staves in accordance with the Instrument Set 
and/or Score Style window settings. First and second endings are only displayed on 
staves with bar lines that aren’t connected to the staff above.

The Alternate Repeat Symbols (for the whole song) option in Layout > Global Settings 
activates a “Real Book” style display of repeat signs.

Note:  These symbols have no impact on MIDI playback.

Trills, Tremolo, and so on

The symbols in this group can be positioned anywhere, and are not attached to notes. 
The trill line and arpeggio lines can be set to any length, by dragging their end points. 
The trill line can also span line breaks. The accidental symbols in this Part box group are 
purely graphic, and do not affect the MIDI playback of notes. They are mainly intended 
as a supplement to trill symbols.
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Rests, Bar Repeat Signs

Automatic Rest Display
Rests are displayed automatically in Logic. This is done in a way whereby existing notes 
and automatic rests always add up to complete bars, that match the given time 
signature. The only exception to this is when a Score Style with a deactivated rest 
display (hide Rest) or with Beat Slashes (instead of rests) is used.

Manually Inserted Rests
In certain situations, you might want to insert rests manually. These replace automatic 
rests, but unlike automatic rests, are listed as events in the Event List. These events have 
a MIDI channel and a velocity value.

The velocity value determines their vertical position in the staff (normal middle 
position is 64).

Manually inserted rests, unlike automatic rests, can be moved higher or lower. Their size 
can also be changed with the Sizing tool.

You can use manually inserted rests (also called “User Rests”) if you don’t like the way a 
particular “automatic” rest is displayed. As examples; to avoid dotted rests, or for the 
syncopated display of rests, despite a Syncopation off (see “Syncopation” on page 379) 
setting. In rhythmic display terms, user rests behave like notes, with Syncopation On 
and Interpretation off (see “Interpretation” on page 378) settings. User rests are 
interpreted in accordance with the display quantize setting (see “Qua—Display 
Quantization” on page 377), just as notes are.

Multi Bar Rests
Rests with a duration of several bars can be indicated by these two symbols. These are 
most suitable for single instrument parts. In the full score, they are only visible when all 
staves contain multi bar rests at the same position. 
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“Church rests” (the older form of display) default to a length value of 2 bars. The default 
length of “normal” multi bar rests is Auto (a value of 0 in the Event List). This means that 
the rest’s duration is calculated automatically, according to the position of the next 
note, user rest, or global symbol (repeat signs, double bar lines and so on). 

Changes can be made in the dialog box, which opens when you double-click on the 
symbol:  you can select the shape (modern or church), activate or deactivate the 
automatic length function, and determine the length, if Auto length is switched off.

Note:  Church rests cannot be longer than nine bars. If this length is exceeded, the 
modern symbol is used automatically.

Moving Multi Bar Rests
These rests cannot be moved with the mouse. You can, however, change their bar 
position in the Event List or Event Float window. You can also alter the length of the 
rest (VAL) in this manner.

Bar Repeat Signs
The symbols for one or two bar repeats replace all notes and rests in the corresponding 
measures. All other symbols remain visible. This does not affect MIDI playback, so 
hidden notes can still be heard. These signs can only be moved in the Event List or 
Event Float window.

Text Objects, Chord Symbols

You will find descriptions of the extensive range of text objects and chord symbols in 
the Text:  Input and Display (see “Text Input” on page 427) and Chord Symbols (see 
“Inserting Chord Symbols” on page 432) sections.
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D.S., D.C., Segno, Coda Signs

These symbols can be inserted at any position in the score. They are graphic symbols, 
and do not affect MIDI playback. Their size can be changed with the Sizing tool.

Tempo and Swing Symbols

These symbols can be inserted at any position. The font, size, and style of the tempo 
indicator itself is determined in the Text Style (see “Text Styles” on page 425) window 
(Text Style Tempo Symbols). The tempo indicator is derived automatically from the 
playback tempo at the corresponding bar position. Note that the tempo indicators in 
the Transport window (see “The Transport Window” on page 73) and the Tempo List 
(see “Tempo List Editor” on page 448) always refer to quarter notes, even if a time 
signature with another denominator is used. As such, the displayed tempo differs, 
depending on the symbol being used.
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Move, Copy, and Paste
Moving or copying of complete Regions (or major parts of a MIDI Region) should 
generally be done in the Arrange window.

Despite this advice, most of the following Score window functions work similarly to 
Logic’s other editors. It is not possible to copy, or move the following symbols:
• Global symbols, such as repeat signs, time, and key signature changes—except in the 

Arrange window (see “Key Signatures” on page 361)—and global text elements 
(headers and so on)

• Symbols directly attached to notes, such as accents, fermatas, note heads, and so on

Moving/Copying With the Mouse
You can move/copy by dragging the selected objects (hold Option to copy). This allows 
you to move or copy any number of notes and symbols to other bar positions and/or 
pitches. If you want to restrict the movement to one direction (vertical or horizontal), 
hold down Shift during this process. There is also a general preference for this: 
Preferences > Global > Limit Dragging to one direction in Matrix and Score.

It is important to watch the Help Tag during this process. It shows the status (Drag or 
Copy), the current difference from the original position (Transpose and Time Shift), and 
the current cursor position (bar position and—for notes—pitch).

Positioning Grid
Movement along the time axis occurs along a quantization grid that corresponds to the 
MIDI Region’s display quantization (Qua) setting. If a hybrid quantize value is selected 
(16,24 for example), the grid corresponds to the binary value (16, in this example). If 
note positions are not aligned with this time grid (because they were recorded in real 
time), their relative offset is retained when they are moved or copied. This allows you to 
move or copy unquantized passages within the Score Editor, without losing the original 
feel of the performance.

Please note:  copying and moving notes (with the mouse) is only possible within the 
same MIDI Region.

Moving and Copying Several Objects at Once
To move or copy (hold Option) several objects at once (notes and symbols), just select 
all desired objects and drag one of them (preferably the first one, or one positioned at 
the exact start point of a measure) to its destination position. Again, watch the Help 
Tag for exact positioning information. All selected objects will be moved or copied, 
while retaining their positional relationship to the first object.

It’s also possible to simultaneously move or copy objects which are in different 
Regions/staves. Each event will be moved/copied to its new position, within its original 
MIDI Region.
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Via the Clipboard
These functions work the same way as in many other software programs, and in other 
Logic windows.

Paste inserts the Clipboard’s contents (a note) into the selected MIDI Region at the 
current song position, as indicated in the Transport Window (see “The Transport 
Window” on page 73). You need to set the Song Position Line to the desired 
destination position before pasting.

When you simultaneously copy and paste several objects, the first object is pasted at 
the indicated bar position, and the others, in relation to it. 

Note:  If you copy the contents of a whole bar which starts with a rest on the first beat, 
the first object is not on one (because automatically displayed rests are not objects), 
and therefore cannot be copied. In this situation, you need to set the paste position 
accordingly. (The exception is when an object, such as a dynamic symbol, is at the 
beginning of the selection, say at beat one, which is also copied).

Paste Multiple
The Clipboard’s contents can be pasted into several Regions at once, at the original 
position. Select all desired Regions, and use either Edit > Paste Multiple, or the Paste 
Multiple key command. 

The multiple selection of Regions can be done either in the Arrange, or directly in the 
Score window:  Shift-click all desired staves, or “rubber band” the adjacent Regions. 

Note:  The Display Parameter box (see “The Display Parameter Box” on page 374) title 
line always indicates the number of Regions that are currently selected.

Automatic Insert Quantization
When you Paste (or Paste Multiple) objects from the Clipboard, the position of the first 
inserted event is automatically quantized, in accordance with the current global display 
format (in the Transport window). As an example, if the current bar position is 4.1.1.37, 
and the global display format is set to 1/16, the pasted object will be inserted at 
position 4.1.1.1, whether it’s a note or a symbol. When the Clipboard contains more than 
one object, the other objects’ positions are not quantized. Rather, their exact relative 
positions from the first object are retained.

If you don’t want this behavior (because you want to preserve the unquantized timing 
of the original), you are better served by other copy methods.

Paste at Original Position/Paste Multiple at Original Position
These two commands (Edit menu, or key commands (see “Key Commands” on 
page 36)) allow you to quickly copy passages from one MIDI Region to another, at the 
same time position. No insert position is required, and no automatic insert quantization 
takes place.
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This is the ideal method for copying an entire musical phrase, including all symbols, to 
the staves of other instruments. All destination staves need to be selected for Paste 
Multiple to work.

These commands can be very useful when used in combination with Select Similar, 
while copying all dynamic symbols from one staff into other staves/instruments, for 
example.

Repeat Objects
This dialog box (see “Copying Regions” on page 109) can be opened from the local Edit 
menu, or with a key command. It is especially useful for copying complete bars (or 
multiple copies), without setting any bar positions. As an example, in a bar that begins 
with a rest on one, select all notes and symbols (rubber band selection), open Repeat 
Objects, insert the number of desired copies, set Adjustment to Bar, and press Enter.

Editing or Deleting Notes and Symbols
Editing With Tools
Velocity Tool 
If you grab one or several notes with the Velocity tool, and move the mouse up or 
down, you change the notes’ velocity values.

The value change can be seen in the Help Tag, and can also be heard if the MIDI Out 
button is activated. 

Grabbing a note while holding down Option-Control, activates the Velocity tool, saving 
you a trip to the Toolbox. Once you release these modifier keys, the cursor returns to its 
previous shape and function.

Quantize Tool
Used for quantizing and de-quantizing (see “Event and Note Quantization” on page 35) 
the MIDI playback of selected notes. 

Layout Tool
The Layout tool changes the horizontal graphic position of a note, in relation to its bar 
position.
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Pulling the note to the right or left changes the displayed distance from the adjacent 
notes or rests. The bar position (and playback) are unaltered. This is used to create 
space for a grace note, or for an arpeggio line, as examples. Symbols, when moved with 
the Layout tool, retain their bar position, but the hor.pos and vert.pos parameters are 
changed, as indicated in the Help Tag during the process.

There is a shortcut for this tool:  press Control while grabbing the note to activate the 
Layout tool.

Sizing Tool
The Sizing tool allows you to change the size of any note, and most symbols.

If you want to reset an object to its original size, double-click on it with the Sizing tool. 
A dialog will ask if you want to reset the size of the object.

Changes in the Event Parameter Box
You can edit the following parameters in the Event Parameter box:

Notes
MIDI channel, pitch, velocity, and note length.

Note:  Several key commands are available for pitch, length, and MIDI channel changes 
of selected notes:

• Event Transpose +1/−1:  half step up/down
• Nudge Event length by Format +1/−1:  lengthens/shortens the note by the current 

global display format value 
• Nudge Event Channel +1/−1:  changes the note’s MIDI channel, accordingly

Symbols
Staff:
Staff number:  this parameter is only important when you are using a polyphonic Score 
Style with multiple staves (for Piano). It determines which staff a symbol belongs to. 
Note:  if this value is higher than the number of staves in the Score Style, the symbol 
disappears!

Symbol
The internal number of a symbol in its Part box Group:  once you know these numbers, 
you can edit the symbol by changing this number, rather than deleting a symbol and 
inserting a new one. This is especially useful for dynamic symbols:  0 = ppp, 1 = pp, 2 = 
p, 3 = mp, 4 = mf, 5 = f, 6 = ff, 7 = fff and so on.
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Vert.pos/hor.pos 
• vert.pos determines the height/vertical position. Zero means a position exactly on 

the top line of the staff, in most cases. Positive values are above, negative values 
below it.

• hor.pos determines the horizontal graphical offset of the object’s bar position. A 
value of zero corresponds to the left edge of a note, at that particular position.

Additional Parameters for Text Objects
• Text Style (see “Text Styles” on page 425)
• Size of the font being used
• Align:  horizontal alignment

Most parameters in the Event Parameter box can be edited by using the mouse as a 
fader (hold down the mouse button while moving it up or down). Alternately, you can 
double-click on a parameter (except Text Styles and alignment), which opens an entry 
field. Simply insert the desired value as a number, or as a pitch, if dealing with notes 
(example:  “D#4”). You can also insert relative changes, such as +4, into this field, to 
raise all selected note pitches by 4 half steps, or to increase a numerical value of 
another parameter by 4.

Changing Several Selected Objects Simultaneously
If several objects are selected, this is indicated in the Event Parameter box’ title line by 
X Notes/Symbols/Events/Texts/Chords selected. “X” indicates the number of selected 
objects. The terms Notes, Texts, and Chords are only used if the current selection is 
limited to objects of that particular type.

If—as in most cases—parameter fields are visible while multiple events are selected, all 
corresponding values can be edited simultaneously. “*” as a value means that the 
selected objects have different values for that particular parameter. There are different 
options for changing these values:

Relative Change (Preserving Differences)
Grab the “*” with the mouse, and use the mouse as a slider. The value shown during 
this process belongs to the first of the selected objects. The other objects are altered by 
the same amount (while retaining their relative values). You can also double-click the 
value and insert the desired change (a number with a plus or minus in front of it) into 
the resulting entry field (see above).

Absolute Change (All Values Set Equal) 
Press Option during the procedure described above:  as soon as you move the mouse, 
the parameter is set to the same value for all selected objects. This enables you to set 
all notes of a chord to the same length or velocity, or set all selected objects to the 
same height (vert.pos).
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There are also key commands that set the vert.pos and hor.pos parameters of all 
selected objects to the same value:
• Align Object Positions Vertically
• Align Object Positions Horizontally
• Align Object Positions (affects both parameters)

These key commands set all objects to the value of the first selected object.

If only one object is selected when you use one of these key commands, a dialog 
appears, allowing you to decide if the parameters of all similar objects should be set to 
the same value. (Note:  this affects all displayed Regions and instruments.) 

Hint:  This is very useful for aligning lyrics and chord symbols.

Deleting Objects in the Score Editor
Here is a short overview of the methods available for object deletion in the Score 
Editor:
• With the eraser tool (works for all objects)

• With Backspace or Edit > Clear, while the corresponding objects are selected 
(flashing). Exception:  repeat signs and special barlines cannot be selected. They can 
only be deleted with the eraser tool.

You can only delete events that are actually displayed in the Score Editor. As an 
example, if you erase notes from a real time recording in the Score window, MIDI 
controller events or pitchbend data that was recorded with these notes will not be 
deleted.

The Display Parameter Box
The settings in the Display Parameter box (with the exception of Style) form the basis 
for the rhythmic interpretation and display of notes. These settings can be different for 
every MIDI Region. The displayed settings always refer to the currently selected MIDI 
Region(s). These settings only affect the score display, not the MIDI playback of notes.

Please keep the following in mind for all settings:
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The Display Parameter box settings not only affect the display of notes recorded in real 
time, but also that of notes inserted with the mouse, or via step input. If you insert a 
short note, such as a 32nd note, it can only be displayed at its original length if Qua is 
set to 32 or shorter. If Qua is set to 8, the 32nd note will be displayed as an eighth note 
(although it will still be played back as a 32nd note). A note inserted with the mouse 
may also display as a longer value if Interpretation is on for that MIDI Region

Settings
Different Settings Within the Same Staff
If you can’t seem to find the appropriate display parameters for a particular MIDI 
Region, remember that you can divide a MIDI Region with the scissors tool (directly in 
the Score window). This will leave MIDI playback unaltered, but provides the option to 
assign different display parameters (display quantization) for the resulting shorter 
Regions. As these divided Regions are still connected to each other, they will be 
displayed as a continuous staff.

Default Settings for New Sequences
If a new MIDI Region is created with the pencil tool in the Arrange window, or through 
MIDI recording, Logic always applies the Default parameters (see “MIDI Region Playback 
Parameters” on page 116) to the MIDI Region. These can be seen and edited in the 
Display Parameter box, when no MIDI Region is selected (The title line shows Insert 
Defaults to indicate this status). These settings will remain as set, until you quit Logic, 
but can be changed any time. 

Click on any empty spot in the main working area (below or above the score) to display 
the Insert Defaults. Edit any of the parameters as desired. (set Qua to the display 
quantize setting that you will use for most Regions in the song, for example) From this 
point on, all new Regions will use these settings as soon as they are created. If Qua is 
set to default, the Qua setting of newly recorded or created Regions will be dependent 
on the Global Format Value in the Transport window.

The default setting for Score Styles (Style) is not defined here. This is separate for each 
Track Instrument, and is set in the bottom line of the Arrange window’s Instrument 
Parameter box.

Simultaneously Changing the Settings of Several Sequences 
This is possible, if all desired Regions are selected. The top line of the Display Parameter 
box indicates the number of Regions or objects (if the selection includes folders) 
currently selected (3 Sequences sel.), instead of the MIDI Region name. If these Regions 
have differing values for any of the parameters, a “*” will be displayed in the 
corresponding line. If you change this value, all selected Regions will be set to the same 
value for that particular parameter.

There are two special functions for the selection of multiple Regions in the Score 
window:
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• Clicking on the title line in the Event Parameter box selects all Regions that are visible 
in the current display.

• Clicking an instrument name, in the column between the parameters and score, 
selects all Regions for that particular Track Instrument (even Regions spread across 
different tracks assigned to the instrument), at the current display level. Remember, 
the instrument name column is only displayed if View > Instrument Names is 
activated.

Rhythmic Interpretation of Sequences
Traditional music notation is only an approximate description of the musical content in 
a piece. The actual performance depends heavily on the interpretation of notes by 
musicians. Quarter notes, for example, are hardly ever held for the exact duration of 
one beat.

The rhythmic interpretation of MIDI Regions (recorded in real time, to a click) presents a 
similar problem, especially if one considers that Logic records MIDI events with a 
resolution of 960 ticks per quarter note. Nobody will play a downbeat at the exact time 
of the click. 

As such, it’s important that you have some idea of what your printed music should look 
like. This will be help you to determine the Display Parameter box settings that will best 
fit your music. The Display Quantization (see “Qua—Display Quantization” on page 377), 
Interpretation (see “Interpretation” on page 378), Syncopation (see “Syncopation” on 
page 379), and No Overlaps (see “No Overlap” on page 379) settings all affect the way 
that recorded music is displayed.

Name and Style
Title Line: Name of the Sequence
The name displayed here is identical to that of the same MIDI Region in the Arrange 
window. It can also be edited here. A double-click on the name opens a text entry field. 
If more than one MIDI Region is selected, this line reads X Sequences selected and Insert 
Defaults (the default settings for new Regions), if nothing is selected.

Style 
The Score Style (see “Basics” on page 380) used for the score display of the MIDI Region. 
This is selected from a pull-down menu, which contains all available Score Styles for the 
current song.
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Qua—Display Quantization
This parameter determines the shortest note value that can be displayed in the 
currently selected MIDI Region (exception:  “artificial” N-tuplets, see the “Artificial” N-
Tuplets to Bypass Display Quantization section (see “N-Tuplets” on page 352)).

The Qua value is selected from a pull-down menu, which contains all available display 
quantization options. Among these there are binary quantizations (displayed as one 
binary value—16 or 128), and hybrid quantizations (two values combined, a binary and 
a ternary value—16,24 or 32,96).

Binary values always correspond to the note value with the same denominator—32 = 
thirty-second note, and so on. Ternary values refer to triplets. Here is a list of the ternary 
values, and their corresponding triplet values:

“Qua” Setting and corresponding Note Length:

Automatic Display of Triplets
When binary display quantizations are used, automatic triplets are not displayed at all 
(except for triplets inserted with the mouse, using an N-tuplet object). Therefore, a 
“hybrid” quantization value must be assigned to the Qua parameter, to enable the 
automatic display of triplets.

Default Setting
The Qua parameter cannot be set to it’s default in existing Regions, as it could in older 
versions of Logic. The default option can only be set with the Insert Defaults, which 
determine the default settings for newly recorded or created Regions. If default is 
chosen, the Qua setting of any new MIDI Region will be dependent on the Global 
Display Value in the Transport window. In this situation, the Qua value will always be a 
hybrid value:  the global display value currently set in the Transport window plus—in 
the case of a binary global value—the next highest ternary value, or—in the case of a 
ternary global value—the binary value which is divisible by that particular ternary 
value.

3 1/2-note triplets

6 1/4-note triplets

12 1/8-note triplets

24 1/16-note triplets

48 1/32-note triplets

96 1/64-note triplets

192 1/128-note triplets

384 1/256-note triplets
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A few examples:  a global value of 1/8 will result in an 8,12 Qua setting for new Regions, 
a global value of 1/12 will become Qua = 4,12, a global value of 1/16 will result in Qua = 
16,24, 1/24 in 8,24 and so on.

Note, however, if a particular Qua value has already been set in the Insert Defaults 
(shown in the Display Parameter box whenever no MIDI Region is selected), all new 
Regions will be assigned this value, regardless of the Global Display Value in the 
Transport window. You may, of course, change any of these values at any time.

Swing Notation
For regular swing notation, 8,12 should be used as the display quantize parameter. This 
enables the display of eighth-note triplets, and also displays two uneven notes on one 
beat (dotted eighth and sixteenth), as regular eighth notes. For double-time passages 
containing sixteenth notes, you either need to cut the MIDI Region in the Arrange 
window, and assign a higher quantize value to the new MIDI Region that contains the 
double-time figure, or use hidden “artificial” N-tuplets for the sixteenth notes (see the 
“Artificial” N-Tuplets to Bypass Display Quantization section (see “N-Tuplets” on 
page 352)).

For swinging sixteenth notes (shuffle funk, hip hop, and so on), the same principle 
applies. In this case, Qua would be set to 16,24.

Interpretation
If Interpretation is on, notes are generally displayed with longer length values than 
their actual length, in order to avoid short rests. Short notes on a downbeat in 4/4 time, 
for example, are displayed as quarter notes. The score becomes less precise, but easier 
to read.

If Interpretation is off, note lengths are displayed as close as possible to their “real” 
values, as determined by the Qua value. In the following example, the same MIDI 
Region is shown twice, the first with Interpretation off, the second on:

The Interpretation function is intended to produce an easy-to-read score display of real 
time recordings. You should generally switch it off when using step or mouse input. 

Interpretation can actually be switched on and off for every single note, independent 
from the Display Parameter box setting. This can be done via a menu option, a key 
command, or by using the Note Attributes (see “Note Attributes” on page 398) box.
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Syncopation
If Syncopation is switched on, each (MIDI) note will be notated as one graphic note 
(not displayed as several tied notes), regardless of its position—if this is possible. (This 
also depends on the Max. Dots setting, see below) If this isn’t possible, the note is 
(graphically) divided into the minimum possible number of notes, connected by ties.

This facility is usually used for the display of syncopated notes. The following example 
shows the same two bars displayed differently, the first with Syncopation off, then on:

Syncopation can also be switched on and off for every single note, independent from 
the Display Parameter box setting. This can be done with a menu option, key 
command, or in the Note Attributes box (see “Note Attributes” on page 398).

If an unwanted display of ties and notes results from the Syncopation function, it is 
possible to change the graphic display of notes connected with ties. Take a User Rest 
from the Part box (preferably a short one, but the length isn’t important), and insert it 
at the bar position where you want the tie “subdivided”. Once the rest is inserted, it will 
disappear, but the note display will change. The inserted rest can only be seen and 
edited in the Event List.

This trick works for all notes, not just syncopated ones (see the Changing the Way 
Notes with Ties Are Displayed section (see “Ties” on page 351)). In polyphonic Score 
Styles, the MIDI channel of the rest and the corresponding note must be the same.

No Overlap
No Overlap on prevents the overlapped display of notes in melodies that are played 
with an exaggerated legato. The effect can be seen in the following example, which 
shows the same MIDI Region, first without, then with Overlap correction:
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No Overlap should only be deactivated in rare cases. If, for example, a piano player 
arpeggiates a chord and holds the notes, the score displays the following result with No 
Overlap on:

Although you can’t see that all notes continue to sound here, the result looks like this if 
No Overlap is deactivated:

The solution typically involves switching No Overlap on, and using sustain pedal 
markings. Logic will automatically display pedal markings if notes are recorded in real 
time with a MIDI keyboard, and sustain pedal.

Max. Dots
This parameter determines the maximum number of dots that Logic will allow for the 
display of single notes. Unwanted dotted notes or rests can be changed by inserting 
User Rests (which remain invisible, if notes). See the Changing the Way Notes with Ties 
Are Displayed section (see “Ties” on page 351).

Score Styles
Basics

The Concept of Score Styles
Score Styles could be compared to text formats in word processing and desktop 
publishing software. In this case, however, it’s score attributes that are stored, not font 
settings. This makes it very easy to assign multiple attributes; such as clef, staff size, 
vertical distance between staves, instrument transposition, and so on, to any existing or 
newly created MIDI Region. A Score Style includes the following parameters:
• Number of staves (for the display of one MIDI Region)
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• For polyphonic, multi-staff Score Styles:  configuration of brackets and bar lines that 
connect the staves.

For every staff:
• Staff size
• Distance to the next (higher and lower) staves
• Number of independent (polyphonic) voices in the staff
• Clef
• Display transposition
• Key signature on/off

For every independent (polyphonic) voice:
• Automatic rest display on/off
• Stem direction of notes
• Tie direction
• Direction of N-tuplet brackets and numbers
• Beaming
• MIDI channel assignment for the voice and/or definition of a split point pitch—for 

separation of the different voices.
• Note Color

Logic contains a number pre-defined Score Styles.

Score Styles do not affect the rhythmic display, unlike the parameters in the Display 
Parameter box. Neither do they affect the horizontal distance (spacing) of notes (apart 
from changes caused by different stave sizes). This is determined in Layout > Global 
Format.

Score Styles are saved with the song file, allowing different Score Styles in different 
songs. Hint:  create some empty template songs with (among other things) the Score 
Styles, and other score settings, that you would normally use as a basis for your work.

Assigning Score Styles
Each individual MIDI Region can be assigned a different Score Style in the Display 
Parameter box. This enables you to quickly;
• create parts for transposing instruments.
• display the same MIDI Region at different sizes, for example—for printout of a full 

score, and individual parts for the different instruments.
• change between different display forms in one staff. This would be done by cutting a 

MIDI Region, and assigning different Score Styles to the resulting shorter Regions. 
(This might be used to alternate between passages that are completely written out, 
and improvised passages using only Beat Slashes and chord symbols, for example).
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Predefined Styles
Here is a complete list of Logic’s preset Score Styles, and their parameters:

Working With Score Styles
Assigning Score Styles to Sequences
The default song that appears when you start Logic contains several Score Styles (see 
“Predefined Styles” on page 382). You can assign a Score Style to a MIDI Region by 
selecting the MIDI Region, then choosing the desired Score Style from the Style 
parameter pull-down menu in the Display Parameter box.

You can also assign a Score Style to several selected Regions at once—see the section 
on Changing the Settings of Several Sequences Simultaneously (see “Settings” on 
page 375).

Score Style assignments can be changed at any time.

Score Style Clef Type Transposition

Bass1 Stave(s) Bass Clef —

Piano 2 Stave(s) Treble/Bass Clef —

Treble 1 Stave(s) Treble Clef —

Treble +8 1 Stave(s) Treble (+8) Clef −1 octave

Treble −8 1 Stave(s) Treble (−8) Clef +1 octave

Alto Sax 1 Stave(s) Treble Clef Eb (+9) 

Guitar Tablature Display

Guitar Mix Tablature Display and 1 Stave Treble (−8) Clef

Baritone Sax 1 Stave(s) Bass Clef Eb (+21)

Contrabass 1 Stave(s) Bass (−8) Clef +1 octave

Horn in Eb 1 Stave(s) Treble Clef Eb (−3)

Horn in F 1 Stave(s) Treble Clef F (+7)

Organ 1/1/5 3 Stave(s) Treble/Bass/Bass Clef —

Organ 1/3/5 3 Stave(s) Treble/Bass/Bass Clef —

Piano 1/3 2 Stave(s) Treble/Bass Clef —

Piccolo 1 Stave(s) Treble Clef −1 octave

Soprano Sax 1 Stave(s) Treble Clef Bb (+2)

Tenor Sax 1 Stave(s) Treble Clef Bb (+14)

Trumpet in A 1 Stave(s) Treble Clef A (+3)

Trumpet in Bb 1 Stave(s) Treble Clef Bb (+2)

Viola 1 Stave(s) Alto Clef —

Violoncello 1 Stave(s) Bass Clef —

# Drums 1 Stave(s) Percussion Clef “mapped”
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Reminder:  Regions that directly follow each other (without gaps) on the same Arrange 
window track, are displayed as one continuous staff in Page Edit view, but can still use 
different Score Styles.

Automatic Score Style Assignment for New Sequences
When you create a new MIDI Region, either by making a real time recording or with the 
pencil tool in the Arrange window, the MIDI Region will be assigned the Score Style 
selected in the bottom line of the Instrument Parameter box of the active track 
instrument. 

When you create template songs, or begin work on a new song, you may wish to 
change these settings for instruments that are likely to use a specific Score Style. This 
ensures that these instruments will immediately be displayed with the correct Score 
Style.

Auto Style 
If Auto Style is chosen in the bottom line of the Instrument Parameter box, every new 
MIDI Region will be automatically assigned a Score Style that fits the register of the 
recorded notes. Auto Style can only be chosen in the Instrument Parameter box, and 
does not appear in the list of Score Styles in the Score window’s Display Parameter box.

The Score Style Window
There are several ways to open the Score Style window:
• double-click on the Style parameter in the Display Parameter box
• Layout > Score Styles
• Open Score Style Window key command
• Double-click in the bottom line (Default Style) of the Instrument Parameter box in the 

Arrange or Environment window.

The following elements (also seen in other Logic windows) can be found along the left 
side of the Score Style window:

Link Button
If the Link button is activated while the Score Style window is open, you will always see 
the parameters of the currently selected MIDI Region’s Score Style. If you switch to a 
different MIDI Region, the Score Style window will reflect the new selection.

Toolbox
This Toolbox contains the pointer tool (same as the regular mouse cursor), the pencil 
tool (for creating new staves and Voices) and the eraser tool (for deleting Score Styles, 
staves, or Voices).
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Name Box/Style Selector
The field below the Toolbox shows the name of the currently selected Score Style. 
Click-hold it to open a pull-down menu that lists all Styles available in the current song. 
Switch to another Score Style by selecting the desired entry, and releasing the mouse 
button.

Parameter Groups
The Score Style Parameters are grouped horizontally in three main sections (top 
line):  Staff, Voice, and Assign.

Staff:
The Parameters for staves. Each line below the word Staff represents one staff in the 
score display.

Voice:
The Parameters for independent Voices. Each line below the word Voice represents one 
independent voice. The term “Voice” only relates to the simultaneous display of 
rhythmically independent, polyphonic passages in the music, not the number of notes 
that can be displayed simultaneously. One Voice can consist of as many simultaneous 
notes (chords) as desired. Only notes which should be displayed as rhythmically 
independent from the other notes in the same staff need to be assigned to separate 
Voices.

Assign:
The parameters for the assignment of notes to the different Voices. For details, see 
below.

Every Staff can contain several independent Voices (up to 16), but one Voice can not be 
displayed across different staves. Therefore, a Score Style must contain at least as many 
Voices as Staves. 

List View
The Score Style window features the single Score Style view shown above, and a list 
view option. The list view is mainly intended for copying Score Styles between songs 
(see below), or for deleting styles.

Double-click in the empty space below the parameters to switch to the list view. 
Another double-click on one of the Score Styles in the list switches to the display of 
that particular Style. Another way to change between single and list views is by clicking 
on the small button to the left of the menu line.
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Handling Score Styles
Copying Score Styles Between Songs
At some point, you’ll probably want to use Score Styles that exist in another song. 
There are two methods for copying Score Styles between songs:

Importing All Score Styles from Another Song
Select Options > Import Settings in the Score window. In the resulting dialog box, 
activate Score Styles only, and click on Import. This imports all Score Styles from another 
song into the current one.

If another song file is already open during this procedure, that song’s Score Styles will 
be imported. If no other song is open, a file selector box will appear, allowing you to 
select the song that contains the desired Score Styles.

Copying Only Particular Score Styles from Other Songs
One or several Score Styles can be selected in the Score Style window’s list view, and 
copied between songs with the usual copy/paste commands (Edit menu or key 
commands). To do this, the Score Style windows of both songs must be opened.

Automatic Score Style Copying
If you copy a MIDI Region from one song to another, and the Score Style used by the 
original MIDI Region doesn’t exist in the target song file, it is automatically copied, 
along with the MIDI Region.

Deleting Score Styles 
Score Styles can be deleted in both the single view (New > Delete Style), and list view 
(with Backspace or Edit > Clear). In list view, you can also select several Score Styles at 
once for this purpose. As an example, select Edit > Select Unused in list view, and press 
Backspace to delete all Score Styles that are currently not assigned to any Regions or 
Track Instruments in the song.

Creating New Score Styles
In single view, you can create new Score Styles by using New > Single Staff Style or New 
> Dual Stave Style. The parameters of Styles created this way are very basic, and need to 
be edited, according to your individual requirements (see below), in most cases.

The default name of Styles created in this fashion is “*New Style”. A double-click on the 
name box opens a text entry field, where any name can be typed in.

Creating New Score Styles Based on Existing Ones
You’ll often need a new Score Style that is almost identical to an existing one. In this 
situation, just make a copy of a Style and edit the copy. Copying can be done:
• in the Score Style window (single view) with New > Duplicate Style.
• with the Score Style window’s pull-down menu (name box), by selecting the bottom 

entry (“****DUPLICATE!****”) in the list.
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• directly in the Score window, by using the Style pull-down menu in the Display 
Parameter box, again selecting “***DUPLICATE!****” at the bottom of the list. This is 
the fastest method, as the new Score Style is automatically assigned to the currently 
selected MIDI Region.

Any of these methods will result in a new Style named after the Score Style it is derived 
from, with “*copied” appended to its name. This text can be edited in the name box of 
the Score Style window.

If the only difference from the original Style is the staff distance or the Style’s clef, 
creating a variation of the currently assigned Score Style can be done very quickly from 
inside the Score window:  (with the desired MIDI Region selected), select the 
“****DUPLICATE!****” command in the Score Style pull-down menu. This copies the 
current Score Style, and assigns the copy to the selected MIDI Region. Now, change the 
staff distance by dragging the clef with the mouse (as in the illustration), or double-
click on the clef to select a different clef from the resulting box.

Editing Single Staff Score Styles
These are the relevant parameters for single Staff Score Styles. The other parameters 
are only relevant if the Score Style consists of more than one Voice, which does not 
refer to the display of chords and so on, but to rhythmically independent, polyphonic 
voices.

Name
The Name of a Score Style can be edited by double-clicking on the name box, which 
opens an entry field.

Space
These values determine the distance to the next (higher and lower) staves, or the page 
margins, for the top and bottom staves of a full score.

This also creates additional space (that belongs to the staff ) above and below the 
actual staff. If, for example, symbols are inserted between staves in full score mode, it is 
important which staff an inserted symbol is assigned to. When parts are extracted from 
the full score, symbols will follow the staff they were inserted in.

The vertical distance above the staff can also be changed directly in the score, by 
dragging the staff up or down (at the clef ).

The distance below the staff can also be edited in the score, but only for the bottom 
staff in the score display, or if only one staff is displayed. The bottom line of the score 
display area is dragged with the mouse, as shown in the illustration.
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These editing procedures change the settings of the corresponding Score Style. This 
means that all Regions which use the same Score Style will be affected, which is not 
always what you might want. To prevent this, use the fast creation method for new 
Styles, based on existing ones.

Size
The size of the staff, and the notes and symbols it contains. There are 16 sizes available 
(0–15). Here are some size recommendations:  for regular instrument parts and lead 
sheets, use size 7 or 8. The staff size you should use in full scores depends on the 
number of staves in the score, and the size and format of the paper being used. When 
using A4 or US letter paper:  full orchestra:  2, big band:  3, wind quintet:  4.

You should note that the size of all staves in an Instrument Set can also be affected by 
the Scale parameter (see “Full Score and Part Layout” on page 407) in the Instrument 
Set window. This makes it possible to use the same sizes for both the whole score and 
parts of a piece.

Clef
You can select the clef to be used in the Score Style from a pull-down menu. This menu 
offers some special options, in addition to the usual clefs:
• Drum.0 to Drum.8:  staves with 0 to 8 lines and a “neutral” percussion clef. The 

relationship of MIDI note pitches to the top line of all staves, corresponds to the top 
line in a regular bass clef (A2). No accidentals will be displayed in these drum staffs. 
Drum.0 also omits any ledger lines. These clefs are often used in Mapped Drum Styles 
(see “Drum Notation With Mapped Score Styles” on page 396), where the height of a 
note does not correspond to pitch, but is determined by different Drum Map 
parameters.

• no clef.0 to no clef.8:  is like the Drum.0–8 staves, but without a clef.
• TAB Guitar… and TAB Bass…:  12 different options for displaying notes as guitar or 

bass tablature. Tablature Tuning Sets are defined and edited in the Tablature window 
(Layout > Guitar Tablature…).

Trans
The display transposition, measured in half steps up or down. This parameter does not 
affect MIDI playback. If a staff contains chord symbols, these will also be transposed 
accordingly. If Automatic Key Transposition in Layout > Clefs & Signatures is activated 
(which is the default setting), key signatures will also be transposed (with one 
exception see next paragraph).

Key
If this parameter is set to Hide, the corresponding staff is displayed without a key 
signature. Instead, all sharps and flats are indicated directly beside the notes. This 
parameter will usually be set to Show the key signature. Hide is an option mainly used 
for transposed french horn parts, which are sometimes written without a key signature.
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Note:  The abovementioned Automatic Key Transposition option has a similar effect on 
the whole song. At a song level, however, the non-transposed basic key signature is still 
indicated, and Hide Key suppresses any key signature display. 

Rest
The automatic rest display can be switched off (HIDE), or set to display Beat Slashes 
instead of rests. This is useful for rhythm section parts, and improvised solos. In this 
situation, the number of slashes per bar are determined by the nominator in the time 
signature (4 slashes in 4/4-time, 6 slashes in 6/8-time and so on). Inserted notes and 
symbols are still displayed, but automatic rests are only shown if shorter than one beat. 
You can insert User Rests manually, to replace individual Beat Slashes.

Stem
This controls the direction of stems. The default setting is Auto. Up or Down forces all 
stems, regardless of pitch, in the corresponding direction. Hide makes all stems (and 
beams and flags) invisible.

Tie
The vertical direction of automatically displayed ties. The default setting is Auto. Up or 
Down forces all ties in the corresponding direction.

Tupl
Controls the direction of N-tuplet brackets and numbers. The default setting is Auto. Up 
or Down forces all N-tuplet brackets and numbers in the corresponding direction. Hide 
prevents the automatic display of triplet brackets and numbers. In this situation, the 
numbers are still displayed in brackets on the screen, to allow edits to these triplets. 
These bracketed numbers will not appear, however, on the printout.

If you set this parameter to Hide, you can still make particular triplets visible:  double-
click on the bracketed number (3) to open a tuplet dialog box. If you close this box 
with OK, you will convert the automatically displayed triplet into a “forced” triplet, 
which will be displayed in accordance with the parameters set in the dialog box.

Beam
Controls the appearance of beams. The default Slant setting allows slanted beams. 
Horiz only allows horizontal beams. Vocal prevents the display of beams, as is typical in 
“classical” vocal parts, where notes are only displayed with flags.

Color
Sets the color of the voice’s notes. The color options are:  Black (“---”), Pitch, Velocity, 
and the 16 colors of the user palette (see “Color” on page 423).

These settings only affect Regions that use an appropriate Score Style. In addition, the 
active color mode in the Score Edit Window must be set to Normal (Individual), which 
is the default setting.
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Editing Two-Stave Score Styles
(2 staves, with one Voice in each)

The most obvious example of a multi-staff Score Style is a two-staff piano system.

When working with multiple staves and/or Voices in a Score Style, the following 
parameters also become relevant:

Number of Staves
Each staff is represented by a number in the first column. These numbers are assigned 
automatically, and cannot be changed. An additional staff can be created in two ways:
• New > Insert Staff. The new line is inserted at the insert mark (>) position, which can 

be determined with a click in the narrow column to the left of the staff numbers.
• Click on the lower left portion of the empty space below the parameters (under the 

Staff parameters) with the pencil tool.

Brackets and Bar Line Connections
In the second to fifth columns of the Score Style window, you can determine which 
staves are bracketed (two bracket types available) and/or connected by bar lines (only 
at the beginning of each staff line, or at every bar line). Simply click-drag in the 
corresponding column until you see the appropriate display, for any of these 
connections. If a Score Style consists of more than two staves, the brackets and bar 
lines can be set to only connect certain parts of the whole system—they can be 
interrupted in-between staves. If you want to delete any connections, grab the symbol 
at its end, and drag it up to the beginning, until it disappears.

Bar line connections can also be edited directly in the score. Just click on the upper end 
of a bar line to connect it to the next (higher) staff. To disconnect bar lines, simply click 
on the same spot again.

The Voice parameters in the middle of the window (Space, Size, Clef, Rest, Stem, and so 
on) can be set individually for each Voice (identical to the staff, in this case). In a simple 
two-stave system, however, you’ll probably select two different clefs and adjust the 
staff distances as needed. The Space parameters also refer to the staff distances inside 
the Score Style itself.
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Voice Separation Method
Additional staves are always treated as additional Voices. There are two different 
methods for assigning notes to voices. The appropriate parameters are found to the far 
right of the Score Style window, below the Assign header:
• A fixed split point (between two lines in the Split column). This is a defined pitch, 

which determines the absolute border between two Voices. Notes above it, or at the 
same pitch, are assigned to the upper Voice. Notes below it are assigned to the lower 
Voice. This method is very simple, but has the disadvantage that none of the Voices, 
even briefly, can ever cross the border. Quite often, in “real life” situations, the border 
between voices needs to be flexible. A piano piece’s right hand part may dip below 
middle “C”, or the left hand may go above. It’s not possible to notate this properly 
using a fixed split point.

• Voice assignment according to the notes’ MIDI channels (Chan):  for each Voice, a 
different MIDI channel can be set in the Chan column.

Every note is now assigned to a Voice according to its MIDI channel. (The note’s MIDI 
channel can be seen and edited in the Event List, Event Float, or in the Score window’s 
Event Parameter box, when the note is selected). The different MIDI channels have no 
impact on MIDI playback, as the playback channel is determined by the Instrument 
Parameter box setting (Arrange window).

Given the use of MIDI channels for voice assignment, notes that aren’t assigned to 
channels will not be displayed at all. This can, however, be used to your advantage, as it 
allows you to exclude certain notes from the display (improvised parts, trill notes, and 
so on).

There are two useful functions that can speed up the process of changing the MIDI 
channel settings of notes, in order to assign them to the desired Voices:
• In the Score Preferences (Options > Score Preferences), there is a parameter called Auto 

Split Notes at … If this is activated, and the default Score Style in the selected 
Instrument Parameter box is a polyphonic Style, all played notes are automatically 
assigned MIDI channels that match the Score Style’s Voice assignments. Notes at, and 
above, the split point are assigned the channel of the first Voice. Notes below are 
assigned the second Voice’s channel (this feature only works for two Voices at a time). 
This creates a usable rough Voice assignment, which can be edited later.

• For Regions that have already been recorded, use Functions > Note Events > Split to 
Channels, or the Split to Channels key command, to assign notes to Voices in the 
Score Style—according to the Auto Split pitch in the Score Preferences.

In most cases, it will still be necessary to change the Voice assignment (the MIDI 
channel) for particular notes, or groups of notes. There are several methods for doing 
this:
• Editing the MIDI channel in the Event Parameter box or the Event List (also works 

with multiple selections).
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• Changing the MIDI channel using the Nudge Event Channel +1 and Nudge Event 
Channel −1 key commands. 
Hint:  these can be especially useful when used in combination with the Select Next/
Previous Event key commands, which allow you to move the selection from note to 
note.

• Using the Voice Separation tool:  this tool allows you to draw a separation line 
between the notes, thereby assigning them to the MIDI channels of the Voices. Place 
the tool between the staves, and draw a line where you want to separate the Voices, 
while holding down the mouse button. The following example shows the resulting 
separation line. If you make a mistake, just move the mouse back slightly to the left 
(with the button still pressed). This erases the separation line to the right of the tool. 
Then try again.

The result of the procedure will look like this:

Note:  The Voice Separation tool can only be used if MIDI channels are pre-defined for 
each of the Voices that you want to separate. This is because Logic needs to know 
which MIDI channels to assign to the notes.

Voice Assignment When Using Mouse Input
If you insert notes with the mouse into a multiple stave Score Style, these are 
automatically assigned to the staff/Voice/channel in which they are placed. If the staff 
contains several Voices (see below), the MIDI channel will correspond to the Insert 
Defaults channel setting (but only if that particular channel is used by one of the Voices 
in the staff ).

There is a Staff parameter in the Event Parameter box for most Symbols inserted into 
multiple stave Score Styles. This parameter determines which staff the symbol belongs 
to. This is also relevant for the vert.pos setting of the symbol.
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Editing Single-Staff Polyphonic Styles 
(With Several Independent Voices)

Polyphonic Score Styles are required when rhythmically different melodic lines need to 
be displayed in the same staff. Theoretically, up to 16 independent Voices are possible. 

There are two possible ways to add another Voice to a staff in the Score Style window:
• Menu New > Insert Voice. The new Voice will be inserted at the insert mark (>) 

position, set with a click in the narrow column to the left of the staff numbers (this is 
important if you want to insert a new Voice between existing Voices).

• By clicking in the (empty) lower right portion of the Score Style window with the 
pencil tool. In this situation, the new Voice is simply added at the bottom.

In both cases, the newly inserted Voice will have the same parameters as the Voice 
above it. These can be freely edited.

A new line appears in the Score Style window for every new Voice. For additional Voices 
within the same staff, it is important that the staff field in the first column remains 
empty. If a number is displayed here, click on it. This will cause the number to 
disappear, and the corresponding staff to disappear from the Score display. 

If there are two independent Voices throughout the piece, the parameters might be set 
as follows:  Stem, Tie, and N-tuplet direction are set to up for the top Voice and down 
for the bottom Voice. Note that even with these general parameters, Note Attributes 
(see “Note Attributes” on page 398) can be changed for each note. Both Voices are 
displayed with automatically displayed rests (Parameter Rest:  Show). 

For Voice Separation (see “Voice Separation Method” on page 390), the same methods 
used in two-stave systems can also be applied. Either draw a line between the notes 
with the Separation tool, or edit the MIDI channels of the notes directly, according to 
the Voice assignment in the Score Style window. 

While the Voice Separation tool is being used, the Help Tag indicates which of the 
Voices are being separated by the current process. This is indicated by two horizontal 
arrows between the numbers of the Voices, and is only relevant if there are more than 
two Voices. To switch to the lower Voices, Shift-drag to move the arrows.

Input and Recording of Polyphonic Voices
Via MIDI
If you record polyphonic voices as separate passes in real time, you should set your 
keyboard or MIDI controller to the appropriate MIDI channel for each Voice. This saves 
you from editing the channels after the fact. The same applies to step input.

Note:  The original MIDI channel will not be recorded properly if the Sequencer Input 
Object’s (see “Physical Input/Sequencer Input Objects” on page 177) Channelize 
function is activated in the Environment window.
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Reminder:  if you want to record an additional Voice into an existing MIDI Region, select 
the Region, and activate the Merge New Recording With Selected Sequence option in the 
Song Settings > Recording Options. You could also record two separate Regions, using 
different MIDI channels, and merge them later.

Mouse Input
Mouse input into polyphonic Score Styles is very easy, if you activate View > Explode 
Polyphony (also available as a key command). This forces all Voices to be displayed in 
separate staves, regardless of Score Style Staff settings (the other Voice parameters 
remain valid). If you insert a note into one of these staves, it is automatically assigned 
the corresponding MIDI channel. Following input, turn off the Explode Polyphony 
option. This will display all voices correctly in one staff, as per the Score Style settings. 
This mode is generally useful for all editing operations in polyphonic staves. 

You can, of course, also insert notes directly into polyphonic staves without activating 
the Explode Polyphony option. In this situation, inserted notes are assigned the MIDI 
channel set in the Insert Defaults of the Event Parameter box  (see “MIDI Channel and 
Velocity of Inserted Objects” on page 345).

Single-Staff Score Style With Optional Polyphony
Sometimes you need to add a second Voice to a staff that usually only requires one 
Voice, in order to properly notate a short, rhythmically-independent passage. This is not 
uncommon with orchestral scores, where the unison part for a group of instruments 
will temporarily separate from the other parts. 

One solution is to use a Score Style with a “Main Voice” and a “Secondary Voice”. The 
parameters for the Main Voice should be set as per a non-polyphonic Style. The 
Secondary Voice is set to Channel 16, and is displayed without automatic rests:
• The stem, tie, and tuplet directions for the Main Voice are set to Auto, which is 

necessary for the proper notation of unison parts. No MIDI channel is defined for the 
Main Voice, so all notes with a channel other than 16 will be assigned to the Main 
Voice. As long as no notes or rests with MIDI channel 16 are used, the score display 
looks the same as with a simple, non-polyphonic Score Style.

• For the second Voice, the stem, tie, and tuplet direction parameters are set to down, 
and the automatic rest display is deactivated (Hide). Only notes with channel 16 will 
be assigned to this Voice. 

The following additional steps are necessary to improve the score’s appearance:
• Rests in the second Voice need to be inserted manually where needed. In the 

example, this was done on the fourth beat of the second measure. The rest’s MIDI 
channel must match the second Voice’s channel (16, in this case). This can be edited 
in the Event List (see “Using the Event List” on page 297).

• In the polyphonic passages, the stems of the Main Voice need to be forced upwards 
by selecting the corresponding notes, and changing their individual stem parameters 
(see “Note Attributes” on page 398).
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An advantage of this approach is that you don’t need to worry about MIDI channels 
during recording or input, and notes won’t disappear unintentionally. There is, however, 
the disadvantage that the Voice Separation tool cannot be used to assign notes to 
Voices. 

Other applications for this method would include; the display of beamed grace notes, 
occasional polyphony in a guitar part, or the indication of rhythmic accents above or 
below beat slashes in rhythm section parts.

Don’t forget that you can add further Voices to a staff, to display more complex parts 
(up to 16).

Multi-Stave Polyphonic Score Styles
(With more Voices than staves)

These Score Styles are mainly used for notating keyboard music. If you start Logic 
without using an Autoload or Template song file, an empty song appears. It contains 
polyphonic Score Styles (see “Predefined Styles” on page 382) for piano (Piano 1+2/3+4) 
and church organ (Organ 1+2/3+4/5, with three staves).

These Score Styles are simply a combination of the Score Style types covered in this 
section. To insert an additional Voice or staff, place the Insert Mark (>) at the desired 
position with the mouse (see illustration), and select New > Insert Voice or New > Insert 
Staff. 

In these complex types of Score Styles, it’s often best to use the Explode Polyphony 
(see “Input and Recording of Polyphonic Voices” on page 392) mode when editing.

Cross Staff Beaming
Music for keyboard instruments or harp (which is notated in two staves) sometimes 
contains passages where notes in the upper and lower staff (played by the left and 
right hand) are connected with a beam, to emphasize the continuing musical phrase.

Required Settings
Cross-staff beaming is only possible between staves that belong to the same Score 
Style, and therefore to the same MIDI Region. The Voices in this Score Style also require 
different MIDI channel assignments—it is not possible to achieve cross-staff beaming 
with a Score Style that only uses a split point pitch for Voice separation.

The Procedure in Detail
As notes can only be connected with beams if they belong to the same Voice, it’s not 
possible to simply select notes in both staves, and apply the usual beaming attribute 
functions to them. As an example, let’s imagine a two-staff Score Style with one Voice 
per staff. Before beaming the notes, you need to assign all notes that you want 
connected by a beam to the same Voice. Let’s choose the Voice of the upper staff for 
this purpose.
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To change the Voice assignments for the notes in the lower staff, you can either; use 
the Voice Separation Tool to draw a line below these notes or, select all notes, and 
change their MIDI channel to match that of the upper Voice (in the Event Parameter 
box).

Following this, all notes will be displayed in the upper staff, probably accompanied by a 
lot of ledger lines. The next step is to define the beaming connections, as desired. This 
can be done with the regular note attribute functions (Attributes > Beaming > Beam 
selected or the corresponding key command).

Now select the notes that you want displayed in the bottom staff, and choose the 
Attributes > Voice/Staff Assignment > staff below Voice menu function (or the 
corresponding key command). This moves all selected notes down to the lower staff, 
although they still remain part of the upper Voice.

You could also choose the opposite approach—first assigning all notes to the lower 
Voice, then moving some notes to the upper staff with Attributes > Voice/Staff 
Assignment > staff above Voice. To display all selected notes in their original staff, use 
Attributes > Voice/Staff Assignment > default staff. 

Stem Direction
The default stem direction for notes beamed across staves is towards the center—the 
beam is displayed between the two staves, stems in the lower staff point up, stems in 
the upper staff point down.

The vertical position and inclination of the beam can be altered by use of the stem 
length change functions described above:  To move the whole beam in parallel motion, 
select all beamed notes, and choose Attributes > Stems > Up or Down to change the 
inclination of the beam. Alternately, select the first or last note of the group and apply 
the functions.

You can also define the stem direction for all notes with the regular note attribute 
functions, thereby placing the beam above the top staff or below the bottom staff. If 
you decide that you like the in-between beam better, you’ll need to select all notes, 
and choose attributes > Stems > Default.

Rest Display
As always, rests are displayed automatically in Logic, as per the Rest settings in the 
Score Style. Given the cross-staff beaming situation described above, however, most (or 
all) notes belong to the Voice of the top staff, and the lower staff will contain rests—
some even at positions occupied by notes. To avoid this potential issue, you should use 
a Score Style where the automatic rest display is deactivated for the bottom staff’s 
Voice. Wherever rest display is desired, insert it/them from the Part box, with the 
mouse.
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Copying Voices or Staves
Copying Voices or Staves Into Other Score Styles
The Copy and Paste commands (Edit menu or key commands) allow you to transfer one 
(or several) voices and/or staves, inclusive of their parameters, into other Score Styles. 
Select the Voices you want to copy, by dragging the mouse vertically in the margin 
column to the left of the stave numbers. The selection will be indicated by a dark grey 
vertical beam. Now, select Edit > Copy (X). Switch to the target Score Style that you 
want to paste these voices into (this also works between different songs). Finally, set 
the Insert mark (>) and select Edit > Paste (X). Note that if a Voice is selected in the 
destination Score Style (indicated by a black beam in the left column), it will be 
replaced by the pasted voices.

Deleting Voices in a Score Style
To delete Voices or staves from a Score Style, select them (dark grey beam, see above) 
and press Backspace, or select Edit > Clear.

Drum Notation With Mapped Score Styles
Nowadays, most MIDI instruments contain a variety of drum and percussion sounds. 
Each MIDI note usually triggers a different sound. If a MIDI Region containing a drum 
part is displayed with a regular Score Style, you’ll see notes with no apparent 
relationships (except MIDI notes triggering the corresponding sounds) to the sounds 
represented by them.

If you want to notate these musically meaningless pitches as a readable drum part—
which uses special percussion note heads—you should use Mapped Instruments and 
Mapped Score Styles. 

The Basics of Drum Notation With Logic
You need to use both a Mapped Instrument as a Track Instrument, and a Mapped Score 
Style, for drum notation to be displayed properly. We’ll start with the Mapped 
Instrument. 

Open an Environment window, create a new Mapped Instrument (see “Mapped 
Instrument” on page 170), and double-click its icon.

You will see the Drum Map Editor for the instrument. The default settings correspond to 
the General MIDI drum note assignments, but they can be edited.

In the column to the far right, there are three parameters relevant to notation:

Head
Determines the shape of the note head for notes triggered by this particular pitch. You 
can choose the shape from the pull-down menu, by click-holding on any of the note 
heads displayed here.
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Group
Each MIDI note can be assigned to a Drum Group via a pull-down menu. A number of 
groups are pre-defined for the most commonly used drum sounds (Kick, Snare, Hi hat, 
Toms, Cymbals, and so on). If you want to define a new Drum Group for another 
instrument sound (such as Tambourine), select one of the New Groups in the pull-down 
menu, and double-click on it. This opens an entry field, allowing you to determine a 
name for the new Drum Group.

Drum Groups play an essential role in “Mapped Score Styles”:  a note must be assigned 
to a Drum Group to be displayed in a Mapped Score Style. If it’s not, it won’t be visible.

Rel. Pos. 
This parameter assigns the note to a line in the staff. It defines the note’s position, in 
relation to the top line of the staff. Integer values make the note fall on a line, fractional 
values result in a note position between two lines (the measurement unit of this 
parameter is the distance of one staff line to the next).

This position parameter can be set individually for each MIDI note. Positions can also be 
influenced in the Score Style window, but this affects all notes of a particular Drum 
Group.

These options allow you to have two different MIDI notes (different bass drum sounds, 
for example) displayed in the same way in the score, or on the same line, but with 
different note heads.

Different Drum Maps Within the Same Song
If you are using various MIDI instruments with different drum assignments, you can 
create a separate Drum Map (in the Drum Map Editor) for each instrument. The list of 
Drum Groups, however, is the same for all instruments in a song. This enables you to 
display different drum tracks with the same Mapped Score Style. All Snare Drums, for 
example, will be displayed in the same way. If you don’t want this behavior, create 
additional drum groups (Kick2, Snare2, and so on), and also create a second Mapped 
Score Style for the display of these Drum Groups.

Mapped Score Styles
Take a look at the default Mapped Score Style in the Score Style window:  You can 
select the default via the pull-down menu to the left.
• To the left side (Staff ), everything is identical to non-mapped Score Styles (with the 

exception of the missing Transpose and Key parameters, which wouldn’t make sense 
here). Choose a drum clef in the Clef column.

• Below Voice (in the top header line), you’ll see a separate Voice column, where the 
different Voices are numbered automatically. The Score Style, in the example above, 
contains one staff with two independent Voices. 
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• The Staves-Voices-Drum Groups hierarchy runs from left to right, and is shown by 
horizontal lines, which indicate the borders between these elements:  each Drum 
Group belongs to the Voice at the same horizontal position. The Pos. parameter 
affects the vertical positioning of all notes of the corresponding Drum Group. The 
value shown here is an offset, which is added/subtracted to the relative positions 
defined for the individual notes in the Drum Map Editor.

Creating and Editing Your Own Mapped Score Styles
This is very similar to creating non-mapped polyphonic Score Styles. Select New > 
Mapped Score Style in the Score Style window, and insert all desired staves, Voices, and 
Drum Groups—with menu functions (New) or the pencil tool.

The copy, insert, and paste functions for single staves, Voices, and Drum Groups also 
work as described in the Copying Voices or Staves into other Score Styles section (see 
“Copying Voices or Staves” on page 396). 

Prior to defining the details of a Mapped Score Style, you should set up all Drum 
Groups, note head shapes, and relative note position parameters in the Drum Map 
Editor. 

The best method is to use an existing drum MIDI Region, and open the Score window 
(to display the MIDI Region), the Drum Map Editor, and the Score Style window. This 
way, you can directly see how parameter changes affect the score display. 

Using Mapped Score Styles for Non-Mapped Instruments
If you use a Mapped Score Style for the display of a regular (non-mapped) instrument, 
Logic will simply use the default settings for Mapped Instruments (which correspond to 
the General MIDI drum sound assignments), to determine the mapping of notes to 
Drum Groups. This is not recommended, however, as this method is less flexible (there 
will only be default Drum Groups available, for example).

Note Attributes
The term “Note Attributes” is used for all display parameters that can be set individually 
per note, regardless of the settings in other windows and boxes.

The Note Attributes window opens when you double-click on a notehead (presuming 
that Preferences > Score Preferences > Double Click Note To Open:  Note Attributes is 
selected). The settings shown in this window correspond to the double-clicked 
note(head).

Different settings are assigned to a note by selecting the corresponding Attributes 
submenu, with the note selected. This attribute assignment can also be made for a 
group of selected notes. The same applies to the assignment of Note Attributes when 
using key commands.
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Reset Note Attributes
This command (Attributes menu or key command) resets all Note Attributes to their 
default settings. Note that this also affects symbols directly attached to notes (accents, 
fermatas, Jazz symbols, and so on), which will be erased by a Note Attributes reset.

List of All Note Attributes
The following list shows all Note Attributes and provides information on accessing and 
altering various attribute options.

Special Note Heads (Default setting “normal” = round and black):
• Insertion from the Part box with the mouse
• In the Note Attributes window (Head)

Altering Note Size (Default:  Size in the Score Style window)
• With the Sizing tool
• In the Note Attributes window (Size)

Horizontal Position Change (Default:  as defined by the note’s bar position)
• With the Layout tool 
• In the Note Attributes window (Horizontal Position)

Accidental Distance from the Note (Deviation from the default setting in the Extended 
Layout Parameters window)
• In the Note Attributes window (Accidental Position)

Display of Accidentals (Default:  display according to key signature)
• In the Note Attributes window (Enharmonic Shift/Accidental Type)
• Menu Attributes > Accidentals
• With key commands

Options:
• Default Accidentals:  according to the default setting
• Enharmonic Shift:  #:  converts G flat to F sharp, or F to E sharp, for example
• Enharmonic Shift:  b:  converts D sharp to E flat, or B to C flat, for example
• Flats To Sharps:  similar to Enharmonic Shift #, but leaves notes without flats unaltered 

(useful for multiple selection)
• Sharps To Flats:  similar to Enharmonic Shift b, but leaves notes without sharps 

unaltered (useful for multiple selection)
• Force Accidental:  forces the display of accidentals (and naturals)
• Hide Accidental:  displays the note without accidentals (MIDI playback is not affected)
• Guide Accidental:  forces the display of the accidental (and naturals) in parentheses.

Stem Direction and Length (Default setting in the Score Style window)
• In the Note Attributes window (Stem Direction only)
• Menu Attributes > Stems
• With key commands
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Options:
• Stems:  default:  according to the default setting
• Stems:  up
• Stems:  down
• Stems:  hide:  hides a note’s stem, and the corresponding beam or flag
• Stem End:  Default Length:  default setting
• Stem End:  Move Up:  moves the stem end upwards; depending on the direction. Also 

shortens or lengthens the stem
• Stem End:  Move Down:  moves the stem end downwards

Beaming of Notes (Default depends on the chosen time signature, the “Beat Grouping” 
setting in the time signature dialog box, and on the “Beam” Score Style parameter)
• Menu Attributes > Beaming
• With key commands

Options:
• Beam Selected Notes:  forces a beam to the following note
• Unbeam Selected Notes:  interrupts the beam to the following note
• Default Beams:  uses the default setting

Voice/Staff Assignment:  for Cross Staff Beaming (see “Cross Staff Beaming” on page 394)
• Menu Attributes > Ties

Options (requires a polyphonic multi staff style):
• Default Staff:  according to voice assignment
• Staff Above Voice:  moves the selected note(s) to the staff above the assigned voice
• Staff Below Voice:  moves the selected note(s) to the staff below the assigned voice

Tie Direction (Default setting in the Score Style window)
• In the Note Attributes window (Tie Direction)
• Menu Attributes > Ties
• With key commands

Options:
• Ties:  default:  according to the default setting
• Ties:  up
• Ties:  down

Syncopation (Default setting in the Display Parameter box)
• In the Note Attributes window (Syncopation)
• Menu Attributes > Syncopation
• With key commands

Options:
• Default Syncopation:  according to the default setting
• Force Syncopation:  forces syncopated display
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• Defeat Syncopation:  defeats syncopated display

Interpretation (Default setting in the Display Parameter box)
• In the Note Attributes window (Interpretation)
• Menu Attributes > Interpretation
• With key commands

Options:
• Default Interpretation:  according to the default setting
• Force Interpretation:  forces Interpretation mode
• Defeat Interpretation:  defeats Interpretation mode

Independent:  Display as Independent Note or Single Grace Note (Default setting “Not 
Independent”)
• Menu Attributes > Independent
• With key commands

Options:
• Not Independent:  the note is displayed in the regular rhythmic context
• Independent:  the note is displayed, independent of the rhythmic context
• Independent Grace:  the note is displayed as a single (independent) grace note

Color
Single notes can also be assigned colors individually, in accordance with the three color 
palettes. The note must be selected, then menu Attributes > Colors > is used to assign 
the desired color (user palette 1 to 16) or color mode (pitch or velocity).

As Note Attributes, these settings have priority over the Score Style settings, but they 
only apply if the color mode is set to Normal (Individual) in the Score Edit window.

Instrument Sets and Score Display Levels
There are basically two parallel systems that determine which Regions are displayed, 
and which aren’t in Logic’s Score Edit window (linear view versus page edit view does 
not play a role here). The hierarchical system which controls Display Levels is basically 
the same in all Logic windows, but has a few special aspects in the Score Edit window.

Display Levels
You can work with the following Display Level settings in the Score Edit window:

Content Linked:  activated by a double-click on the Link symbol. In this mode, only the 
object currently selected in another window (which is a single MIDI Region most of the 
time, but can also be a folder) is displayed in the Score window. 
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Content Catch:  similar to Content Linked, but Catch is also activated. Only one MIDI 
Region is displayed at a time, but the display changes to the next MIDI Region on the 
same track, according to the current bar position, during playback. 

Linked:  (single click on the Link symbol) The Score window shows the same display 
(folder) level as the Arrange window. This is most relevant if you work with Folders. 

Not Linked (Link button deactivated):  in this mode, Logic simply stays at the currently 
visible Display Level, and doesn’t react to MIDI Region selection in other windows. As 
an example, if you always want to see the full score in a particular Score window, 
choose this mode once the full score is displayed in the window. 

Explode Folders
If the current Display Level allows more than one MIDI Region to be viewed 
simultaneously (Linked or Not Linked), the View > Explode Folders option will affect how 
things are shown:  unlike the other editor windows, the Score window can display (or 
even print) the contents of different display (folder) levels at once. If the current Display 
Level contains folders, their contents are also displayed in the score (if this option is not 
activated, Folders will appear as grey beams in linear view, and won’t be shown at all in 
page edit view).

Changing Between Single Sequence and Full Score Display
At all Display Levels, a double-click on a MIDI Region or folder will take you to the next 
lower level (into the Folder or the display of that particular MIDI Region). A double-click 
in the empty space below or above the staves will take you up to the next higher level 
(the next higher Folder, or to the full score display of all Regions in the song). Basically, 
the same principle applies, even if you don’t use Folders at all:  the highest of all levels 
(the complete song) could also be regarded as a folder, which contains all MIDI 
Regions.
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Special Cases Concerning Score Display
In some situations, certain MIDI Regions will not be displayed in the Score window, no 
matter what the Display Level or Instrument Set settings are. These cases include:
• Muted MIDI Regions, if Hide Muted Sequences is activated in Layout > Global Format.
• MIDI Regions on muted tracks, if Hide Muted Tracks is activated in Layout > Global 

Format.
• MIDI Regions with Score set to “off” in their Extended Sequence Parameters (global 

menu Options > Extended Sequence Parameters or key command).

Instrument Sets
Apart from the system of display and folder levels, the Score window also features the 
Instrument Sets system. This determines which (track) instruments should be included 
in the score display of a particular Instrument Set. Each song can contain as many 
Instrument Sets as required. Instrument Sets allow you to:
• arrange the (vertical) order of instruments in the score, independently from the order 

of tracks in the Arrange window.
• assign a name and an abbreviated name to each track instrument, which will then be 

displayed and printed as instrument names in the score.
• determine which of the staves will be connected by brackets and/or bar lines.
• display or print a certain part of the score, such as a particular group of instruments. 

This also allows faster editing in very large files, as screen redraws are much faster 
when fewer instruments are displayed.

• exclude the display of tracks that are only relevant for playback, but not for the score 
(tracks that only contain MIDI controller data, for example).

• simultaneously reduce or enlarge all staves which are part of an Instrument Set, by 
using the Scale parameter. This allows you to use the same Score Styles for printout 
of full scores and parts.

• select from two different parameter sets (Score or Part) for page margins, header 
space height, vertical distance between stave systems, and the maximum number of 
bars per line.

An Instrument Set is selected in the Instrument Set Box, below the Catch and Link 
buttons. If Instrument Sets already exist in the current song, a pull-down menu 
showing all available Instrument Sets will appear when you click-hold on the box. New 
songs will only show the ALL INSTS. entry which—depending on the display level—will 
display all instruments. Double-click this box to open the Instrument Set window.
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The Instrument Set Window

The Instrument Set window can be opened with:
• Double-click on the Instrument Set Box
• Menu Layout > Instrument Sets…
• Key command Open Instrument Set Window

If you have opened the Instrument Set window while the default “ALL INSTS.” set was 
displayed, a warning indicates that the “ALL INSTS.” Instrument Set cannot be edited. In 
the Instrument Set window, select New > New Complete Set. This will create an 
Instrument Set that contains all track instruments currently used in the Arrange 
window. Although this results in the same display as “ALL INSTS.”, you can edit this 
Instrument Set (you cannot define instrument names or change the order of 
instruments; and the bar lines are always connected throughout the whole score, in the 
“ALL INSTS.” Set). You will see columns with the following parameters (from left to 
right) in the window:

Instrument
This column is used to determine which (track) instruments are included in the 
Instrument Set, and their vertical order of appearance in the score. As in the Score Style 
window, there is a narrow column to the left that allows you to set an insert mark (>) 
with a mouse click, or make multiple selection marks by dragging the mouse vertically. 
These selection marks denote selected instrument entries. The usual cut/copy/paste 
commands (Edit menu or key commands) allow you to; move entries to reorder them, 
delete, or copy them into other Instrument Sets. If pasted, they will be placed at the 
insert mark position, which must be set beforehand.

A double-click below the instrument list results in a new instrument entry at the 
bottom. If you want to add an instrument to the middle of the list, set the insert mark 
accordingly, and select New > Add Instrument Entry.

Click-hold on the name of this new entry (Instrument column). A pull-down menu, 
containing all available track instruments, will appear, allowing your selection.
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In most cases, it’s more convenient to create a new Instrument Set with New > New 
Complete Set, as all instruments currently used in the Arrange window are automatically 
included. You can, however, also select New > New Empty Set, into which you can insert 
the desired instruments, one-by-one. Other options in this menu are:  Duplicate Set; 
which creates a copy of the currently visible Instrument Set, for use as a basis for 
another set, and New Set of Selected Insts., which creates a new Instrument Set that 
contains all currently selected instruments.

Track Instrument icons are also displayed in this column, at the highest zoom level.

Please note:  you will not see a new Instrument Set in the Score window until it is 
chosen from the Instrument Set box pull-down menu.

Full Name
A click on any line in this column opens an entry field that contains the default 
“@(reference)”. If you don’t change this, the Track Instrument name will be used as the 
name for the instrument in the score. As the Track Instrument name is often identical to 
the corresponding synthesizer patch (Solostrings high, for example), you’ll probably 
want to assign another name here. This name is automatically displayed in the score as 
the full name:  “Violin 1”, for example. Display parameters for instrument names are set 
in Layout > Numbers & Names (see “Numbers & Names” on page 414).

Short Name
You can also define an abbreviated name for each instrument, which is used if short 
names is selected for the instrument name display in the Layout > Numbers & Names 
dialog window.

Brackets and Bar Lines
You can define which staves in the Instrument Set are connected by brackets (two 
bracket types are available), and/or connected by bar lines (either at the beginning of 
each staff, or throughout), in the last four columns. Any of these connections can be set 
by dragging vertically in the column, until you see the appropriate display.

Brackets and bar lines can also be interrupted between staves, enabling you to form 
groups of connected instruments in a score. If you want to delete a line or bracket, 
grab the corresponding symbol at its end point, and drag it upwards, until it 
disappears. You can use the same method to shorten lines.

Bar line connections can also be edited directly in the score. Just click on the upper end 
of a bar line to connect it to the next (higher) staff. Repeating the procedure 
disconnects the bar lines.
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Name of Instrument Set
The name of an Instrument Set can be edited by double-clicking on the name in the 
left column of the Instrument Set window, which opens a text entry field. Click-holding 
on the name box allows you to switch to another Instrument Set, by selecting it from 
the resulting pull-down menu.

Scaling, Format
These two parameters (below the Instrument Set name) make it possible to create both 
a full score and parts (see “Full Score and Part Layout” on page 407), for all instruments 
in a song file, without changing any settings.

Importing Instrument Sets From Other Songs
Select Options > Import Settings. In the resulting dialog box, activate Instrument Sets 
only, and click on Import. This imports all Instrument Sets from another song into the 
current song.

If another song file is already open during this procedure, it’s Instrument Sets will be 
imported. If no other song is open, a file selector box will appear, allowing you to select 
the song that contains the Instrument Sets you want to import.

Additional Information on Instrument Sets
Relationship to Display Levels
An Instrument Set will only be displayed as defined if an appropriate Display Level (see 
“Display Levels” on page 401) is chosen. Content Linked and Content Catch only allow 
the display of one MIDI Region at a time, so they are not suitable for work with 
Instrument Sets. It’s usually best to deactivate Link, once the desired Instrument Set is 
fully displayed. If only one MIDI Region is displayed, double-click below the staff, which 
will display the full score, then deactivate Link.

Note:  It is possible to work with several open Score windows; each showing different 
Display Levels and/or different Instrument Sets.

New Instrument Sets for Selected Instruments
The Score window Layout > Create Instrument Set from Selection (or key command) 
option immediately creates and displays a new Instrument Set, which consists of all 
instruments used by the currently selected MIDI Regions. Selection of MIDI Regions can 
be made in either the Score or Arrange windows. As screen redraws are faster if fewer 
instruments are displayed, this is a good way to speed up editing. Instrument Sets 
created this way are automatically named after the instruments they contain. If you 
want to delete the set after editing, select New > Delete Set in the Instrument Set 
window (while the Instrument Set that you want to delete is displayed).
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Automatic Display of Selected Instruments when Opening the Score Window
Opening a new Score window, while several Regions are selected in the Arrange 
window, automatically creates and displays an Instrument Set that only contains the 
instruments of the selected Regions. In other words, the Create Instrument Set From 
Selection function is automatically performed whenever a Score window is opened, and 
Regions on more than one track are selected in the Arrange window.

Instrument Sets created in this way are saved with the song file, and are also available 
for later use.

Different Instruments Using the Same Sound
If several instruments or staves use the same MIDI sound for playback (with the same 
MIDI channel on the same MIDI instrument), and you want to display these staves with 
different instrument names in the score, you need to create a separate track instrument 
for each staff, in the Arrange or Environment window.

Full Score and Part Layout
Some functions in the Instrument Set window, and some settings in the Layout > 
Global Format window make it possible to produce both the full score and individual 
parts (for all instruments) from the same Logic song file, without having to adjust any 
settings.

Part Extraction (“Instrument Filter”)
Option-click-hold on the Instrument Set box in the Score window. A pull-down menu, 
containing all Track Instruments currently used in the Arrange window, will appear. If 
one is chosen, only this particular instrument will be displayed. This method allows you 
to quickly display (and print) instrument parts. You should note, however, that only the 
track instrument names will be used as instrument names in the score. So, if you use 
this method for printout of your parts, you need to be careful to use the “real” 
instrument names for the Arrange window Track Instruments.

Scaling Parameter for Instrument Sets
There is a Scaling parameter below the name of the Instrument Set in the Instrument 
Set window, which can be set to any desired size between 50 and 200 percent of the 
original size. This scaling will affect all staves, the distance between staves, all symbols 
associated with staves (all notes, rests, and other symbols), and all local text, including 
lyrics. All of these elements will be resized in accordance with the Scaling parameter 
value of the currently displayed Instrument Set.

The Scaling parameter does not affect Global Text objects (header text, text inserted 
outside the margins) and text such as page numbers, and so on
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Scaling doesn’t happen to parts extracted using the Instrument Filter function 
described above. As such, you can use the same Score Styles for full scores and 
parts:  in extracted parts, the staves will appear at their original size, in the full score, 
their size is defined by the Scaling parameter.

Separate Layout Options for Parts and Score
In the Global Format dialog window (Layout menu) there are separate page layout 
parameters for score and parts. Left, right, top, and bottom margins, the (vertical) size of 
the Header Space, the Line Distance (additional vertical distance between stave 
systems), and the maximum number of bars per system (Max.Bars/Line) can be set 
separately for Score and Parts.

The parameters used for the display and printout of a particular Instrument Set 
depends on the setting of the Format parameter in the Instrument Set window (below 
the Scaling parameter). You can switch this setting by clicking on it.

Part settings are applied automatically when you use the Instrument Filter method (see 
above) to extract and print the parts for single instruments.

For the default ALL INSTS set, the Score settings will always be used, except when a 
single MIDI Region is displayed. In this situation, the Part settings will be used. Please 
note:  the ALL INSTS set cannot be edited (and therefore, can not be scaled), so you’ll 
need to create a dedicated Instrument Set for the full score, in most cases.

The margin and header values can also be changed directly with the mouse by 
dragging the margin (green) and header lines (blue) in page view mode. This only 
affects the Format setting which is currently in use for (Score or Part) display.

Line Breaks
Line breaks and individual stave margins can be determined individually for each 
Instrument Set, and also for each of the extracted parts.

In Page Edit view, you can use the Layout tool to edit line breaks. The automatic line 
break calculations are based on the Layout > Global Format (Spacing and Max.bars/line) 
settings, but can be changed with the following procedure.

To move the last bar of a stave system down into the next staff, grab it with the Layout 
tool, and drag it down until the symbol changes to a hand with a down-pointing 
thumb, then release the mouse button. The bar is moved to the next stave system, and 
the remaining bars in the line are distributed evenly over the entire width of the page. 
The same method works for several bars at once. If you grab the third to last bar of a 
staff, and drag it down, three bars will be moved to the next staff. You also can move 
the first bar(s) of a staff upwards into the preceding staff, by dragging them upwards 
(symbol:  hand with thumb pointing up).
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Logic stores the line breaks for each Instrument Set individually. This also applies to all 
parts created with the Instrument Filter function. These are all stored with the song file.

Restriction to Local Movement
When you move a bar with the Layout tool as described, all manually edited line breaks 
in subsequent lines are deleted, and the (automatic) line breaks are automatically 
recalculated from that line downwards. If you want to prevent this, perhaps because 
you only want to change one detail and keep the other staves as they were, hold 
Control while moving the bars with the Layout tool. Line breaks edited in this way will 
only affect the two (directly concerned) stave systems. All other stave systems are 
unchanged.

Combining Max.Bars/Line and Line Breaks
The Layout > Global Format > Max.Bars/Line parameter determines the maximum 
number of bars Logic will allow in one staff or stave system. The Layout tool can 
override this setting. As an example, you can set Max.Bars to 6, and still move 
additional bars into a line with the Layout tool. Any subsequent lines will contain no 
more than six bars. The full number of bars set here will only be displayed if the 
spacing settings are low enough to allow the proper display of that many bars.

Note:  If you drag more bars into a line than would be displayed when employing the 
automatic line break function, this can result in overlapping notes and symbols!

Local Margins
The left and right margin of each individual stave system can be moved with the 
Layout tool (see “Editing With Tools” on page 371), so that they do not align horizontally 
with the page margins:  click-hold (with the Layout tool) a little bit inside the beginning 
or end of the staff, and drag to the left or right side (see illustration). During this 
process, “Left/Right Stave Margin” will appear in the Help Tag.

In this situation, Logic also adapts the number of bars per line automatically (unless the 
line breaks have been manually adjusted beforehand):  if the line is shortened, bars 
may be moved down to the next line, depending on the Spacing parameters in the 
Global Format window (see “Global Format” on page 410).

To realign a changed staff margin with the other staves, double-click at its end (or 
beginning). A dialog will ask if you want to Reset Local Margin? Confirming this dialog 
will reset the margin.

Hint:  like manual line breaks, these local margins are also saved as part of the current 
Instrument Set, allowing different settings for every Instrument Set.

Deleting All Line Breaks and Local Margins
To delete all line breaks and all locally changed margins in the current Instrument Set, 
select Layout > Reset Line Layout.
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Song Settings for Score Display
There are six pages of score settings in the Song Settings dialog box. You can switch 
between these and the other Song Settings dialog box pages directly, by using the 
pop-up menu on the page. In addition to the methods mentioned below, you can also 
select these pages in the global Options > Settings > menu.

These settings affect the whole song (in all Instrument Sets). They are saved with the 
song file, allowing each song to have different settings.

Note:  In most cases, values of “zero” are not displayed in these settings. Zero values are 
denoted by an empty parameter box.

Importing All Score Settings
Select Options > Import Settings in the Score window. In the resulting dialog box, 
activate Score Settings only, and click on Import. This imports all Score Settings relevant 
to the score display (the settings of these six pages) of another song, into the current 
song.

If another song file is already open during this procedure, it’s Song Settings (score only) 
will be imported. If no other song is open, a file selector box will appear, allowing you 
to select the song that contains the Score Settings you want to import.

Global Format
Global Format settings define page margins, spacing between notes, slanting of beams 
and format settings.

This window can be opened by:
• Layout > Global Format…
• Key command Settings:  Global Format
• Double-click on the page margins in Page Edit view

Note:  Distance values can be displayed in inches or centimeters. To switch between 
these options, just click on one of the unit depictions.

Settings that affect the general page layout (margins, for example) can be set 
independently for a part or the full score. This is indicated by the two input boxes. This 
allows you to print out single voices with a page layout that differs from the full score.

The settings in detail:

Top/Bottom/Left/Right Margin
These values show the margin distances to the outer border of the printable area on 
the page. A “Top Margin 0.0 inches” value means that printing will start as close to the 
top of the paper as the selected printer driver will allow. This means that the size of the 
printable area can be different with various printers, although the difference should be 
minimal.
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Margins are only visible in Page Edit view, where they are displayed as green lines on 
the screen. These lines are not printed. It is also possible to change them directly, by 
dragging them with the mouse in the score.

Like the global page margins, the left and right borders of stave systems can also be 
edited individually. To change the left/right border of a staff system, simply use the 
Layout tool to click and drag the border to the desired position. The local margin (see 
“Local Margins” on page 409) can be reset by double-clicking the same position with 
the Layout tool.

Add Bracket Space
Creates additional space between the left margin line and the beginning of staves, for 
braces and brackets. If this option is deactivated, staves will be aligned directly along 
the left margin line.

Alternating Margins
If activated, the left and right page margin settings will be swapped on every second 
page. This can be useful if a score is going to be bound as a book:  the inner margin 
usually needs to be a little bigger than the outer one. It’s possible that the opposite 
might be preferable, in cases where extra space is needed for remarks that may be 
added to the score at a later date.

Header Space
Defines the height reserved for headers, between the first page’s top margin, and the 
first staff’s top margin (as per the assigned Score Style).

Note:  Text elements inserted directly into this area automatically become Global Text 
(see “Global Text” on page 429), and are displayed as headers in all Instrument Sets 
(scores and parts).

This value can also be changed directly in the score, by dragging the dotted line above 
the first staff.

Line Distance
Defines additional vertical distance between stave systems on the same page. It applies 
to full scores, as well as single staff parts.

Max. Bars/Line
This parameter can be useful when using small spacing values (see below), to prevent 
too many bars from being displayed in one line. The number set here limits the 
number of bars that can be displayed per line.

Note:  This setting can be overridden when using the Layout tool to change line breaks 
(see “Line Breaks” on page 408).
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Constant/Proportional Spacing: Note Distance
These parameters determine the amount of horizontal distance between notes. 
Constant Spacing affects the distance from note to note, regardless of rhythmic value. 
Proportional Spacing also takes the note durations into consideration. If you only use 
Proportional Spacing (and set Constant to 0), every bar receives (more or less) the same 
amount of (horizontal) space. A whole note uses as much space as four quarter notes. 
In the opposite situation (high constant value, proportional value = 0), the distance 
from one note to the next is always the same, regardless of note duration. A half note 
takes the same amount of space as an eighth note. Other factors, such as accidentals, 
ties, and so on are also considered for note distance calculations.

The settings you should use depends on both your personal preference, and the style 
of the piece. Certainly, one should aim for a good balance between these two 
parameters. For best results, try different combinations when working on the final score 
layout.

Slash Spacing: Spacing of Beat Slashes
This is the distance parameter for slashes (used in Score Styles that display Beat Slashes 
instead of automatic rests). This is especially important if notes are inserted into staves 
displayed with slashes. As an example, musical styles such as funk use a lot of sixteenth 
notes, so you are likely to choose a higher slash distance than for music that doesn’t go 
beyond eighth notes. This way, the proper relationships between notes and passages 
(containing only slashes and chord symbols) can be maintained.

Default Pedal Position
This determines the vertical position of pedal symbols (which are created and 
displayed automatically when you use the MIDI sustain pedal during a real time 
recording). If this parameter is set to zero, recorded MIDI sustain pedal controller events 
are hidden in the score. Pedal marks inserted from the Part box are not affected by this 
parameter.

Beaming Slant Factor/Min. Slant/Max. Slant
These three parameters affect the slant angle of beams. As with the Spacing 
parameters, these parameters work together. Appropriate settings need to be found by 
trying different combinations. The final settings will vary, depending on the style of the 
music, and on personal preference.

Beaming Slant Factor:  determines the general amount of beam slanting, in relation to 
the intervals of the notes connected by beams.

Min. Slant:  determines the minimum interval of notes that causes beams to be slanted.

Max. Slant:  determines the maximum beaming slant angle.
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These parameters work relatively to a particular scoring situation, which is why no 
explicit instructions on settings can be given. Again, it is essential to try different 
combinations when working on the final layout of a piece.

“Open” Single Staves
Displays single staves without vertical lines at their start point (left side of the clef ).

Justify Last Staff
Lengthens the last line (the last staff system, in full scores) to the right page margin.

Hide Muted Sequences/Tracks
Excludes muted Regions, or Regions on muted tracks, from the score display. If these 
options are not activated, muted tracks and Regions will be displayed in the score, even 
though they won’t be heard during MIDI playback.

Show Alias
Switches the display of alias objects (see “Aliases in the Score Display” on page 333) in 
the score on or off.

Allow Alias Editing
Switches Alias Editing (see “Aliases in the Score Display” on page 333) on or off.

Alternate Repeat Symbols
If this option is activated, all repeat signs in the song will be displayed with “Real Book 
Style” brackets.

Chord Symbol Language
This pull-down menu allows you to choose between
• International:  default
• German1:  B → “H”, Bb → “B” 
• German2:  B → “H”, Bb → “Bb”
• German3:  C# → “Cis”, Eb → “Es” etc… 
• Roman:  CDEFGAB → Do Re Mi Fa So La Ti

In all Chord Symbol Language formats, the current format is also accepted for the input 
of new chords. The “#”, “b”, “x” and “bb” characters are also active in the German3 mode, 
allowing for quick entry. In the Roman format, the second root string character can be 
omitted (typing “D7” or “Do7” in Roman mode will both result in “Do 7”). Changing the 
Chord Language automatically affects all chord symbols in the song. It is not possible 
to mix chord languages.
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Numbers & Names
These settings affect the automatic display of page numbers, bar numbers, and 
instrument names in the score. 

To open this window, select:
• Layout > Numbers & Names…
• Key command Settings:  Numbers & Names
• Double-click on any bar or page number

Automatic page and bar number display, and automatic display of instrument names 
can be switched on and off for the whole song, by activating/deactivating the 
corresponding check boxes in this window.

For each of these, you can set Font, Size, and Face, (bold, underlined, italic, outlined, 
and circled. Each is activated by clicking on the appropriate symbol. The “circled” 
attribute is similar to “boxed”, but a circle is used instead of a rectangle. An ellipse is 
used for wide text.

The corresponding Text Styles in the Text Style Window (see “Text Styles” on page 425) 
are automatically updated if you edit these settings. 

Page Numbers
Hor. Position
The horizontal alignment on the page

alternating:  alternating, beginning on the right side
left/right/centered
rev. alternating:  alternating, beginning on the left side

Vert. Position
The vertical alignment on the page

top/bottom

Page Offset
This value is added to each actual page number, for display purposes. This can be 
useful when writing a piece consisting of several parts, which are saved as separate 
song files. To retain continuous page numbers throughout the score, you can set this 
parameter to the number of pages contained in all preceding parts (song files).

Hor. Distance
The horizontal distance from the outermost possible printing position on the page. This 
is only relevant for page numbers with the Hor.Position parameter set to alternating or 
rev. alternating.
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Vert. Distance
The vertical distance to the highest or lowest possible printing position on the page 
(dependent on whether Vert.Position is set to top or bottom).

Hide 1st Page Number
Prevents display and printout of the page number on the first page (all others are 
displayed and printed).

Prefix
Allows you to enter text which will be displayed with every page number.

Example:  if you use the prefix “Page”, the word “Page”, followed by a space and the 
actual page number will be displayed on each page. This means that page three will 
display “Page 3”. If you want the page number in the middle of the prefix, you need to 
use the “#” symbol as a variable for the page number. An example:  “- pg.# -” on the 
second page prints as “- pg.2 -”.

You can also use the following text symbols to include automatically generated text in 
the prefix:

“\ i” for the Instrument Set name 
“\ n” for the song (file) name
“\ s” for the name of the currently shown Display Level, which can be the MIDI Region 
or folder name (or even the song name, on the highest level)
“\ d” for the current date (at the time of printout)

Bar Numbers
Bar numbers are placed above or below the barlines, and at the beginning of the line, 
above or below the clef (they are automatically moved to a position where they won’t 
overlap the clef ).

Vert. Position
The height above the staff. If a negative value is set here, the bar numbers are placed 
below the staff.

Step
This value controls the interval (in bars) between the display of bar numbers. A value of 
4, for example, results in bar numbers at the first, fifth, ninth bar, and so on. If you only 
want bar numbers to be displayed at the beginning of each staff line, set this 
parameter to line (which appears instead of zero).

Bar Offset
This value is added to all actual bar numbers, for display.

Start with
Automatic numbering begins at the bar indicated here.
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Hide Bar Numbers in Linear View
Does exactly what it says. Linear View refers to non-Page View.

Top/Bottom Staff only
In full scores, the bar number is only displayed above the top staff, if this option is 
activated (a negative Vert.Pos. value results in the number below the bottom staff ).

Count Mult. Rests
Displays the first and last bar number below multiple rests. This makes sense if a 
negative Vert.Position value is chosen, causing the bar numbers to be shown below the 
staves.

Show at Double Bars
Displays bar numbers at every double bar line and repeat sign, independent of the 
chosen Step setting. As an example, Step = “line” and Double Bars activated will display 
bar numbers at the beginning of each staff line, and above or below all double bar 
lines and repeat signs.

Instrument Names
This determines the appearance of the names defined for the Track Instruments in the 
Instrument Set (see “Instrument Sets and Score Display Levels” on page 401) window, in 
the full name and short name columns. If nothing is defined here, or if ALL INSTR. is 
used as the current Instrument Set, the names of the Track Instruments (as displayed in 
the Arrange window) will be used in the score. (Short names don’t exist in this case)

Position
above/beside staves

Align
left:  at the left margin

right at the right margin (refers to the space preceding staves)

1st Staff
no names/short names/full names

Other Staves
no names/short names/full names

Clefs & Signatures
These are general display options for clefs, key signatures, and time signatures. Please 
read the sections on Clefs (see “Clefs” on page 355), Key Signatures (see “Key 
Signatures” on page 361), and Time Signatures (see “Time Signatures” on page 362).

You can open this window by:
• Layout > Clefs & Signatures…
• Option–double-clicking on any clef or time signature in the score.
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The following display options are available for Clefs, Key Signatures, and Time 
Signatures:
• Every Staff
• First Staff on Every Page
• First Staff on Page 1
• Hide All
• Display Warnings at Line Breaks:  this causes “warning” clefs, time signatures, or key 

signature changes to be displayed at the end a staff or stave system, if the actual 
change is at the beginning of the subsequent staff or stave system.

The following options are also available:

For Clefs:
Smaller Clef Changes (pull-down menu):  clef changes (whether caused by a change of 
Score Style, or by a new clef inserted from the Part box) can be displayed at a smaller 
size than the clefs at the beginning of staves, depending on this setting.

For Key Signatures:
Automatic Key Transposition
This enables the automatic transposition of key signatures in transposing Score Styles. 
This will usually be activated. An exception would be for the notation of atonal music. If 
deactivated, all sharps and flats are displayed directly with the notes. Note that there is 
a similar option in the Score Style window (Key parameter), which allows you to switch 
off the key signature for individual Score Styles, or even for individual staves in multi-
stave Score Styles.

Minimize Transposed Accidentals
This enables the use of enharmonically changed key signatures, if this results in a 
signature with fewer accidentals. As an example, if a piece is written in B major (5 
sharps), the Bb instruments are notated in Db major (5 flats) instead of C# major (7 
sharps). 

Please note that Logic does not display key signatures with more than seven flats or 
sharps, whether this option is activated or not.

Show Naturals
This displays naturals at key signature changes, where preceding accidentals are no 
longer valid (when changing from E major to G major, or to C minor, for example).

Show Grace Accidentals
If this option is activated, courtesy accidentals are automatically displayed. This 
means:  wherever a diatonic note is altered by an accidental, another accidental (a 
natural symbol, in many cases) will be displayed when that note appears (unaltered) in 
a subsequent bar. 
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For Time Signatures/Barlines
Hide Barlines
This option allows you to hide all barlines, which can be useful for educational material, 
gregorian plain chant notation, and other special situations.

Only automatically displayed barlines are hidden, so it’s still possible to insert barlines 
from the Part box, including the “regular” bar line, which will be displayed and printed.

Octave Symbols
These settings enable you to edit the text string and text format of the different octave 
symbols.

Extended Layout Parameters
This is where you define a number of display settings for the whole song, such as; staff 
line thickness, stem length, distance between notes and ties, or notes and dots, and so 
on.

To open this window, select Layout > Extended Layout Parameters.

The first eight parameters determine the line thickness of the following objects:  stave 
lines, stems, ledger lines, bar lines, repeat and end lines, tuplet brackets, text boxes (for 
boxed Text Styles), and crescendi/decrescendi (this last parameter also affects line 
objects and arrows).

Bar Start Spacing/Bar End Spacing changes the relative distance between the first and 
last note of a bar, and the preceding or subsequent bar line. Please note:  Changing the 
default settings of these parameters only makes sense if rather extreme settings have 
been chosen for the general Spacing parameters in the Global Format window.

Dot/Note Distance determines the distance between the note heads and dots, for 
dotted notes. Dot/Dot Distance refers to double dotted notes.

Acc./Note Distance allows you to globally alter the horizontal distance of accidentals 
from the corresponding note heads. The default setting should only be changed if very 
small values are used for the spacing parameters, which results in a tiny distance 
between notes. This global setting can also be combined with the local Accidental 
Distance parameter of individual notes, in the Note Attributes (see “Note Attributes” on 
page 398) window.

Acc./Acc. Distance allows you to globally alter the horizontal distance between several 
accidentals, in chords.

Stem length is the default setting for stem length.

Hor. Tie Position and Vert. Tie Position determine the distances between note heads and 
related ties (which are displayed automatically). There is also a parameter for Tie 
Thickness as well as Slur Thickness.
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Chord Symbol Alignment determines the general horizontal alignment of chord symbols 
(see “Handling Chord Symbols” on page 433) with an Align parameter set to def 
(default), in relation to their bar position.

Chord Symbol Accidental Scale changes the accidental size, in relation to the font size 
setting:  Positive values result in an increased size, negative values in a diminished size 
of chord symbol accidentals.

Clicking on Factory Defaults resets all parameters to their default settings. If you have a 
high resolution printer, you should try to use smaller line thickness settings (2, or 
maybe even 1). Smaller staves, in particular, look much better and more professional. 
The other parameter settings are more a matter of personal preference.

These changes are only visible at the highest zoom levels on the screen. To really judge 
the results, try some printouts with different settings.

Guitar Tablature
Guitar tablature is an alternative method of notating music for fretted string 
instruments, especially for guitar and electric bass, but also for other fretted 
instruments with four to six strings (or courses of strings).

In this system, the horizontal lines represent the strings of the instrument. Notes are 
always written on the line/string at which they are played. The numbers of the frets are 
shown instead of regular note heads. 

Logic automatically converts notes into tablature, if a Score Style containing a Clef 
parameter set to one of these Tuning Sets, is used. The exact characteristics of these 
Tuning Sets are determined in the Guitar Tablature window. 

To open this window, use:
• Layout > Guitar Tablature
• Key command Settings:  Guitar Tablature
• Double-click on the TAB clef, at the beginning of any staff that already uses tablature 

in the score.

Twelve different Tuning Sets can be defined. Each of them corresponds to one line in 
this window. The regular guitar and bass tunings are already included as defaults (first 
line and last five lines), as are some of the more common guitar tunings. 

The following parameters (from left to right) are available for every Tuning Set:

Name:  can be changed in the text entry field that opens with a double-click on the 
field.

Strings:  number of strings (four, five, or six).

Assign:  the method Logic uses for automatically assigning notes to strings. (see below)
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1 to 6:  the pitches that the “open” strings are tuned to.

Other common parameters:

Font, Size, and Face for the display of fret numbers.

Alignment of the numbers to the stem:  to the side, or centered (can be switched by 
clicking on this box).

Bass String:  the display of the lowest string:  may be the same as the other strings, or a 
bit thicker. (can be switched by clicking on this box)

1/1, 1/2 Notes:  if this option is activated, half and whole notes will be displayed with a 
circle around the fret number. As the note head is always a number, there would be no 
displayed difference between a half note and a quarter note, if this parameter wasn’t 
available. 

Assign
As most notes can be played at different positions (frets) on different strings, the Assign 
parameter plays an essential role in this system. In most cases, the MIDI channels of the 
individual notes determine the string assignment. (Remember:  the MIDI channel 
parameter of an individual note has no impact on MIDI playback. The playback channel 
is determined in the Instrument Parameter box (see “The Instrument Parameters” on 
page 102) in the Arrange window.) The following options are available for string 
assignment:

Pitch
Logic assigns each note to the string on which it is playable, at the lowest possible 
position. In order to influence the string assignment, there is a rule (in Pitch mode only) 
that a note’s fret position cannot be lower than its MIDI channel. This method is 
generally used when notes are recorded from a MIDI keyboard:

An A3 with MIDI channel 1 is displayed on the second fret of the G string. If you want 
the note to be displayed at a higher position (to correctly display the proper fingering 
of a passage), you need to set its channel to 3 or higher. This means that the fret 
position cannot be lower than 3 any more, so the note will be displayed at the D 
string’s seventh fret. If the channel is between 8 and 12, the A3 is assigned to the A 
string on the 12th fret, and to the low E string (17th fret) for channels 13 to 16. If you 
want to force even higher positions, you’ll need to use one of the other assignment 
modes.

Channel
In this mode, the number of the string (1 to 6, counted from the lowest string) simply 
corresponds to the MIDI channel. Channels 7 to 16 are also assigned to the highest 
string. 
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Inv. Chan
Like Channel, but counted from the highest string (1) to the lowest (6 and above). This 
way of numbering the strings is generally used in traditional guitar literature. 

As most Guitar-To-MIDI-Converters send notes on different MIDI channels, according to 
the played strings, the last two modes are suitable if you use such an instrument to 
record MIDI Regions. In this situation, the tablature notation is displayed exactly as the 
music was played during recording. 

Inv.Ch-1, Inv.Ch-2
These modes have been created for the purpose of recording and notating electric 
bass parts with Guitar-To-MIDI-Converters. “−2” is designed for four-string bass, “−1” for 
five-string bass (with an additional high B string). The principle is the same as Inv.Chan, 
but the number of the MIDI channel is reduced by 1 or 2, in order to convert the 
channels properly for bass string assignment.

The string assignment for a four-string bass will be 3 to 6, and 2 to 6 (counted from 
highest to lowest string in both cases) for a five-string bass, just as with guitar strings 
that sound one octave higher. Notes on channel 1 will be assigned to the highest 
string.

In all of these assign modes, notes below the lowest string are not displayed at all. A 
further point to note is that notes can generally only be assigned to strings on which 
they are actually playable. (F2 can only be played on the lowest string of a guitar, so the 
channel assignment is completely ignored in this case).

You can create a two-stave Score Style that displays the MIDI Region twice:  once using 
regular music notation, and once as tablature. The indicated split point can be ignored 
in this situation. A default style for this (named Guitar Mix) is in the Logic default song.

Some More Information Concerning Tablature Notation in Logic:
• You cannot insert clef changes in staves using tablature. If you want to change 

between tablature and regular notation in the same staff, you need to cut the MIDI 
Region, and assign the desired Score Styles (see “Basics” on page 380) to the resulting 
Regions.

• Guitar tablature relates to a regular treble clef. If you use the octave-transposing 
treble clef (Treble-8) for guitar notation (as done in most guitar music, and in the 
example), you need to set the tablature’s Transpose parameter to +12 in the Score 
Style window.
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MIDI Meaning
The settings in this window determine, if and to what extent, the insertion of the 
symbols listed here affect the MIDI playback of notes that these symbols are attached 
to. The window is opened from the Layout > MIDI Meaning menu.

Two parameters can be determined for each symbol listed here. These symbols change 
the MIDI output of all notes they are attached to:

Velocity
This value is added to, or subtracted from the original velocity value of the 
corresponding note.

Length
The original note length is shortened in accordance with the percentage chosen here. 
This only affects the playback of the note, not the score display. The note length 
change can be seen in the Event Parameter box or in the Event Editor window.

How It Works
The MIDI Meaning functions are most useful to users who insert notes with the mouse. 
This makes it possible to work as if writing music on paper. First, you write/insert the 
notes. They will all have the same velocity, and identical rhythmic note values will have 
exactly the same length. Accents and phrasing marks are then attached to some of the 
notes, which changes the velocity and (playback) length of these notes. This makes 
playback sound much more realistic and “alive”.

The default settings in this window (in new songs) are 0 for velocity, and 100% (no 
change) for length. If you don’t change these values, the symbols will remain purely 
graphic and will not affect MIDI playback. If you record your Regions in real time, it’s 
better to leave these settings at the defaults, as the notes probably already sound the 
way you want them to.

Important:  If you do use MIDI Meaning, you need to adjust the settings before you 
begin to insert accents and so on. This is because the settings have no influence on 
accents and phrasing marks that have already been inserted.

Once set, the velocity and length of notes will be changed as soon as you attach one of 
these symbols to a note. When you delete the symbol, note velocity and length are 
reset to their initial values.
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Color
Layout > Colors opens the color palette for the currently active song:

These color palettes are used by different coloring modes. Clicking on any color opens 
the standard color editing window, allowing this particular color to be changed.

Colors are saved with the song, and can be different in each song. They can be 
imported from any other song via Options > Import Settings > Score Settings.

There are three palettes, and some additional options in this window:
• Pitch Colors:  Each note of the octave is assigned a color, they are arranged like piano 

keys. Diatonic/Chromatic determines whether there are twelve or seven different 
colors.

• Velocity Colors:  These eight colors are applied in accordance with the MIDI velocity of 
notes, from left (minimum) to right (maximum).

• User Palette:  These colors can be freely edited and named, using the text entry boxes 
beside them. These names are displayed as color options in different color selection 
menus (Score Styles (see “Basics” on page 380), Note Attributes (see “Note Attributes” 
on page 398)).

• Note Color Options:  These options determine whether accidentals, dots, stems, and 
beams are displayed in color (according to their note associations), or in black. Rests 
refer to user rests, which are mainly used in polyphonic Score Styles.

Score Preferences
The Score Preference settings are global settings, which are saved when you quit Logic, 
and are effective for all song files. They can, however, be changed at any time, with an 
immediate effect on all open songs.

You can open the Score Preferences via:
• Local Score menu—Options > Preferences > Score Preferences…
• Global menu—Logic Menu > Preferences > Score Preferences…
• Key command Score Preferences
• Directly from one of the other pages in the Preferences window, via the pull-down 

menu.

Dashed Song Position Line
Determines if the Song Position Line in the Score Editor window is displayed as a solid 
line, or as a dashed line.
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Show Sequence Selection Colored
If this option is activated, the stave lines of the currently selected MIDI Region are 
displayed in color (blue), all other Regions are displayed with black lines. This can be 
useful when changing the display parameters of Regions, as the parameters in the 
Display Parameter box (see “The Display Parameter Box” on page 374) only refer to the 
currently selected MIDI Region/s. If it is not activated, all staves will be displayed in 
black, whether selected or not. 

Fast (Lower Resolution) Curves on Screen
This is mainly relevant for slower computers. The curves in slurs and score brackets are 
displayed at a lower resolution on the screen, which speeds up screen redraws. This 
setting does not affect the printout.

Display All Distance Values in Inches
This relates to the measurement units in the Song Settings and page rulers (Page Edit 
view only), which can be in inches or centimeters.

Use external Symbol Font (if Available)/Only for Printout
This option activates the use of the external fonts (see “Printout” on page 341) for 
display and printing of the whole score.

Open Floating Palettes
Default Setting for the shape of Part box Floating Palettes (see “Selecting and Inserting 
Part Box Objects” on page 348).

Double Click Note to Open…
This setting determines the editing window that will open when you double-click on a 
note head:  Note Attributes, Event List, Hyper Editor, or Matrix Editor.

Graphic Export Resolution, Graphic Export to…, PICT File Creator ID
Parameters concerning the PICT Export function with the Camera tool (see “Graphic 
Export” on page 342).

Auto Split Notes at… 
This parameter is only relevant if the chosen default Score Style (on the recording track) 
is polyphonic, and is using MIDI channels for Voice assignment. In this situation, newly 
recorded notes are automatically saved with the different MIDI channels used in the 
corresponding Score Style. They are allocated as per the split point set here.
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Text: Input and Display
Text Styles
All text elements in Logic refer to user-definable default settings called Text Styles. You 
can assign any of the predefined Text Styles to text inserted into the score. This saves 
you from setting all text attributes, such as font, size, style, and so on, every time you 
insert a new text object.

Text Styles
All Text Styles used in a song are listed in the Text Style window. This window allows 
you to edit existing Text Styles, or create new ones. You can open this window in the 
following ways:
• Menu Text > Text Styles…
• Double-click on the Text Style name in the Event Parameter box (only visible if either; 

text objects or no objects are selected)

The first eleven lines contain the System Text Styles, which exist in every song (but can 
be edited, according to personal preference). Below these (separated by the slightly 
thicker horizontal line), you will find the user-created Text Styles. Text Styles are saved 
with the song file, allowing them to be different for each song.

Each line shows the Name and Font (selectable via the pull-down menu) of the Text 
Style, followed by its Size and different columns for the style attributes (activated by a 
click in the corresponding field):  bold, underline, italic, outline, and circled. The circled 
attribute draws a circle around the text, which is stretched horizontally with longer 
text.

You can edit these settings for both the System and User Text Styles. Any text fonts 
installed on your system can be used.

The System Text Styles
Plain Text
The default setting for “regular” text

Page Numbers, Bar Numbers, Instrument Names
The Text Styles for automatic page and bar numbering, and display of instrument 
names. These functions are described in detail in the Numbers & Names section (see 
“Numbers & Names” on page 414).

These Styles can also be edited in the Layout > Numbers & Names window. Changes in 
one of the two windows automatically update the settings in the other window, and 
affect the whole song.

Tuplets
The Text Style for triplet and other tuplet numbers.
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Repeat Endings
The Text Style for anything written into the repeat ending boxes (usually just numbers, 
but text can also be entered).

Chord Root, Chord Extension
Used for the display of chord symbols. Root concerns the root and the (optional) extra 
bass note in chord symbols, and Extension is anything else. 

Multiple Rests
The Text Style for the number above multiple rests.

Tablature
Used for the display of fret numbers in guitar tablature (see “Guitar Tablature” on 
page 419).

Tempo Symbols
Used for the display of the numbers in tempo symbols (see “Tempo and Swing 
Symbols” on page 368), which can be inserted from the Part box.

Creating Additional Text Styles 
Select New > New Text Style:  a new line will appear below the bottom Text Style entry, 
allowing you to define the attributes of the new Text Style(s). The names of any new 
style can be edited in the text entry field, which opens when you click on the name of 
the Text Style.

Changing the Same Font in Several Text Styles Simultaneously
If you change a Text Style’s font (pull-down menu) while holding Option, the change 
will affect all Text Styles that use the same font. This is a quick method for changing 
Logic’s default Text Styles to preferred fonts, for example.

This method is also especially useful if you load a Logic song which was created on 
another computer, and uses text fonts that aren’t installed on your system (if this is the 
case, a warning message is displayed when you open the song). The names of 
unavailable fonts are displayed in parentheses in the Text Style window.

Font References
When you activate Options > Show Font References, any Text Styles which were created 
by directly editing a text object’s attributes in the Event Parameter box, or from the Text 
menu, are listed as Font References. Delete Unused Font References deletes any Font 
References that are no longer in use. Edits to Font References aren’t possible in the Text 
Style window, with the exception of changing the font. This display option is primarily 
used to replace missing fonts in Font References. 
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Music Fonts as Fonts for Text Styles
Musical Symbol Fonts do not contain letters. They only contain musical symbols. Text 
objects that use these fonts in Text Styles can be used for free positioning of musical 
symbols anywhere in the score. (Such as special percussion symbols).

Text Input

To insert text in the score, you need to get a Text object from the Part box, and drag it 
to the desired position with the mouse. During this procedure, the mouse cursor 
becomes the Text tool. You can also grab the Text tool from the Toolbox, and use it 
directly for text input. Each Text object (except text in the Header, directly at the page 
margins, or outside the margins) is saved as a Meta Event within a particular MIDI 
Region, at a certain bar position. This position can be seen in the Help Tag, as you insert 
the text object. Text events are also visible in the Event Editor, allowing you to change 
their position, but not the text itself. 

Following the insertion of the text object at the desired position (and releasing the 
mouse button), a flashing text cursor appears at that position. Now you can enter text 
with the computer keyboard. The basic functions for moving the cursor, deleting parts 
of the text and so on are as per most word processors.

As long as you are in text entry mode (indicated by the flashing text cursor), you can 
click on any position in the text to place the cursor there. You can also select parts of 
the text by dragging the mouse, and applying the usual cut/copy/paste commands. 
Press Return, or click anywhere outside the text, to leave text entry mode.

The newly inserted or edited text object is selected (the text flashes), and you can see 
its parameters in the Event Parameter box:
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Stave
Only relevant in multi-stave Score Styles. It determines the staff that the Text object is 
assigned to. The vert.pos parameter measures the vertical distance to the top line of the 
staff, which is indicated here. The hor.pos indicates the graphical horizontal deviation of 
the selected text object from its actual bar position (also in relation to the Align 
parameter). 

Lyric On
Defines the text object as a Lyric Event (song text). If a Lyric Event is placed at the same 
bar position as a note (above or below it), the horizontal distance to the previous and 
subsequent notes or rests is automatically expanded, providing enough space for the 
text. 

Style
The Text Style of the selected text object.

Align
Determines the horizontal alignment of the Text object. The first three settings relate to 
the bar position, the last three to the position on the page (each, left, centered, or 
right).

Size, Font
You can change the size and font of each individual Text object, independent of the 
initially chosen Text Style, which serves as the default setting. 

You can also change the font, size, style, and alignment settings of Text objects via the 
sub-menus in the Text menu, while the desired Text objects are selected.

Generally, you shouldn’t make these changes here, but rather create new Text Styles in 
the Text Style window, thereby making them available for other Text objects.

Simultaneous Text Input Into Several Staves
This works as per other objects (see “Simultaneous Input of Objects Into Several 
Regions” on page 346).

Example:  simultaneous insertion of the text “accelerando al fine” into all instruments.
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Editing Text
If a Text object is selected, its parameters can be edited in the Event Parameter box. If 
you want to edit the text itself, either click on it with the Text tool or double-click on it 
with the pointer tool. The flashing text cursor will reappear.

Deleting Text Objects
As with all other objects, selected Text objects (or selected text inside a Text object) can 
be deleted by pressing Backspace.

Copying Text Objects
Copying entire Text objects can be done with the usual methods:
• Copy/Paste, Multiple Paste and Paste at original Position
• Option-dragging, but this only works inside the same MIDI Region.

Global Text
Global Text objects appear in all Instrument Sets of a song (score, parts, and so on), 
although they are inserted just once. The position of Global Text does not relate to bar 
positions (unlike regular Text objects), but is defined as a graphic position on the page. 
Given this behavior, Global Text can only be inserted and seen in Page Edit view. The 
most obvious example of a Global Text object is a song name header line.

Input of Global Text
A Text object is automatically made “global” if inserted into one of the following areas 
on the page:
• In the Header space (which is set in Layout > Global Format)
• Outside, or directly on, any of the page margin lines

Following insertion of a Text object in one of these areas, and text entry, you will see an 
Event Parameter box that contains some additional parameters:

Pages
Defines the pages that text will be displayed on:

1 = first page, 2 = all pages except the first one, Odd = all pages with odd numbers, 
Even = all pages with even numbers, All =all pages.

Zone
The margin area that the text belongs to/is associated with:  Top, Header, Side, Footer. 

Align
You’ll find two additional alignment options in this pull-down menu:  for right and left 
alignment. You may select between alignment at the set page margin, or at the 
outermost possible position. Although alignments relating to bar positions are shown 
in the pull-down menu, they cannot be selected here.
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Style, Size
These work as per regular Text objects.

Positioning of Global Text
Following insertion into one of the margin areas, Global Text can be moved anywhere 
on the page with the mouse. The regular mouse cursor (the Pointer tool) only allows 
vertical movement of a Global Text object. Hold down Option to move it horizontally.

Automatic Text Objects

The Text group in the Part box contains four objects which represent names that are 
automatically displayed, if inserted:

SEQ = Sequence/Folder:  displays the name of the current Display Level. This can be a 
MIDI Region, a folder, or even the name of the song file (on the highest level). 

INSTR:  The name of the currently displayed Instrument Set (see “Instrument Sets and 
Score Display Levels” on page 401)

SONG:  The name of the song file

DATE:  The current date (at the time of printout)

These automatic Text objects can be inserted as both Global Text (in the margin areas), 
or as Text objects that are related to a bar position (in one of the staves/Regions). The 
appearance and exact positioning of these objects can be set in the Event Parameter 
box.

An Automatic Text Example
Insert the INSTR object above the top margin (centered, Pages set to 2). It will 
automatically be treated as a Global Text object. Now, create an Instrument Set (see 
“Instrument Sets and Score Display Levels” on page 401) named “Score” in the 
Instrument Set window. If you use this Instrument Set, a “Score” line will appear at the 
top of every page, except the first one. If you now extract parts for the individual 
instruments, each part will display the (track) instrument’s name at the top of every 
page, except the first one.
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Lyrics
There is a Part box object named LYRIC, which is designed for lyric entry. You should 
select the Text Style that you want to use for lyric entry prior to commencing lyric 
input. This is done in the Event Parameter box, with no object selected (indicated by 
“Default Inserts” in the title line of the box). Just click on any empty spot in the Score 
window, to deselect everything. 

Now drag the LYRIC object below the first note of the melody, or click at that position 
with the Text tool. Watch the Help Tag:  each LYRIC object must be at the same bar 
position as the note it belongs to (taking display quantization into account). Now, enter 
the text for the first note—and press Tab, not Return—which automatically moves the 
text cursor to the beginning of the next MIDI note. If a MIDI note is displayed as several 
tied (graphic) notes, press Shift-Tab to move the cursor to the next graphic note. This 
allows you to write several syllables below one longer note.

This method enables you to enter all lyrics in one process, although each syllable is 
saved as an independent LYRIC object.

Editing lyrics is just like editing regular text. The Event Parameter box displays the same 
parameters (with LYRIC is set to on).

Apart from the fast input mode (using Tab), the only difference between regular Text 
objects and Lyric objects is that the latter affect the distance between the notes they 
are assigned to. This provides enough space for the text to be displayed properly, 
without overlapping. If the text (or Text Style) is changed later on, the note distance will 
be recalculated accordingly.

Some Hints for Working With Lyrics
Setting all Words and Syllables to the Same Height
If you don’t enter the lyrics in one continuous process, as described, the Lyric objects 
probably won’t be set to the same vertical position. To quickly set all Lyric objects to 
the same height (vert.pos), select at least one Lyric object, then choose Edit > Select 
Similar Objects. This will highlight all Lyric objects. Now select the Align Object Positions 
Vertically key command. 

Note:  You do not want to use this method if there are multiple lines of lyrics for 
different verses. Doing so would set them all to the same height.

Several Verses Written below each other
There can be several Lyric objects assigned to the same note, enabling you to insert 
several verses for a song, one below the other. Start with the first verse and make sure 
the vertical distance to the notes is correct. Then start with the input of the second 
verse. As long as you stay in fast lyric input mode, all Lyric objects for the second verse 
will stay at the same height as the initial object—in this case, the first word of the 
second verse.
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Note:  It is important that Lyric objects are assigned to the right MIDI Region, if you’re 
working in a full score display (Remember:  selected staves are displayed with blue 
stave lines). It’s generally recommended that you insert lyrics in linear view, and single 
MIDI Region display mode—especially if inserting more than one verse. In linear view, 
it’s also easier to rubber band select several Lyric objects, to change all of their 
positions, for example.

Chord Symbols
Inserting Chord Symbols
Chord symbols (CHORD text object) are inserted into the score like regular Text objects, 
with the mouse from the Part box, or directly with the Text tool, while holding Option. 
A text cursor will appear. You first need to enter the root of the chord, and then any 
additional information.

Important:  Ensure that you insert chord symbols at the correct bar position. Watch the 
Help Tag as you insert the chord object.

A chord symbol can include a root note, a separate bass note, and two lines of 
extensions. Try to insert a simple chord symbol first. Type Eb7 and press Enter. The 
result will look like this:

Now double-click on the root Eb. The following edit window will open:

There are four entry fields for the different parts:  one for the root, one for an additional 
bass note and two for extensions, which are placed above each other. If you click on 
any of these options, an entry field opens, allowing you to edit the chord symbol or 
enter the desired additional information.

As you enter the text for the chord in the Score window, you can influence the way the 
inserted text is distributed to the different fields of the Chord Symbol Edit Box:
• First, enter the root, then the extensions, then—after typing a slash—the (optional) 

additional bass note.
• As soon as you enter a number, everything following it will be placed in the upper 

extension line. If you write “G7(b9/b13)”, the whole “7(b9/b13)” will be placed in the 
upper line, and the lower line remains blank.
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• If you write letters before a number (FMAJ7/9, for example), Logic places the letters 
in the lower line, and everything after the first number in the upper line. 

• You can influence this automatic placement by entering a comma in the 
text:  everything before the comma will be placed in the lower line, and everything 
after it, into the upper line. Only one comma can be used. If multiple commas are 
entered, only the first one is relevant, and the others are ignored. Blank spaces can be 
entered, to create additional horizontal space between the extension and the root. 

If you want to change a chord symbol, you can either double-click on the root, and edit 
the chord symbol in the resulting edit window, or double-click directly on one of the 
extensions. A text cursor will appear in the extension line, allowing you to edit the 
extension as per regular text.

The appearance of chord symbols can be edited in the Text Style window (see “Text 
Styles” on page 425), allowing you to choose different Text Styles for the root—Chord 
Root—and the extensions—Chord Extensions.

Handling Chord Symbols
Fast Input of Several Chord Symbols in One Process
If you want to insert several chord symbols into the same staff, there is a shortcut 
similar to the fast lyric input mode available. Following text entry of the first chord, 
press Tab, rather than Return. The text cursor automatically moves to the position of 
the next (displayed) note or rest. Enter the desired chord and repeat the process, or 
press Tab several times, to move to the target position for the next chord symbol.

Hint:  if you want to insert exactly one chord per bar into a very busy part, it’s much 
faster to create an empty MIDI Region, and enter the desired chords into it (the cursor 
moves to the next bar when you press Tab in empty Regions). Following chord entry, 
you can either merge the MIDI Region with the original MIDI Region in the Arrange 
window, or copy and paste all chords at once. 

Enharmonic Change of Chord Symbols
The roots of chord symbols can be enharmonically changed with the same commands 
available to notes (Attributes > Accidentals or key commands). An example:  “Gb7” 
becomes “F#7” by selecting Attributes > Accidentals > Enharmonic Shift:  #. Only 
additional bass notes need to be edited directly in the Chord Edit window.

Transposition of Chord Symbols
Chord symbols in transposing Score Styles are automatically transposed, just like notes. 
Further to this, if the Transpose parameter (for playback transposition) in the Region 
Parameter box (Arrange window) is changed, all chord symbols in the MIDI Region will 
be affected accordingly.
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German Chord Symbols: “H” Instead of “B”
If the German Chord Symbols option is activated in the Global Format dialog window, 
the note “B” in chord symbols is globally displayed with its German name “H”. The 
English “B flat” is written as “B”, according to its German name. This option is activated 
automatically, as soon as the letter “H” is used during chord symbol input.

Copying Chord Symbols
Chord symbols can be copied and pasted with the usual Copy/Paste, Multiple Paste, and 
Paste at original Position commands, or by Option-dragging them (if inside the same 
MIDI Region).

Precise Graphical Position of Chord Symbols
Horizontal Position: Bar Position, Align, Hor.Pos
Each chord symbol is stored as part of a MIDI Region at a certain bar position (there will 
often also be a note at that same bar position). This is the main parameter for 
horizontal placement in the staff. 

The Align parameter determines which part of the chord symbol is aligned to the bar 
position:  the left edge, center, or right edge of the letter representing the chord root. 
This is set via a pull-down menu in the Event Parameter box. The setting for newly 
inserted chord symbols is always def.: in this case, alignment is dependent on the 
global Chord Symbol Alignment setting in the Extended Layout Parameters window. 

This window contains the same four alignment options:  left, centered, right, and “| —”. 
The last option in this list should only be used when loading a song with chord 
symbols that have been inserted or modified in an older Logic version (2.6 or earlier—
the alignment parameter was unavailable in these versions). To achieve identical 
positions to the old version, set the global chord symbol alignment to “| —”. As this 
setting is solely included for backward compatibility, it should not be used in new 
songs.

In addition to bar position and alignment, you will also find the hor.pos parameter. It 
determines an additional graphical deviation of the chord symbol from the bar position

Be careful:  it’s easy to unintentionally change a chord symbol’s bar position with the 
Arrow tool. To avoid this, press Control during the procedure:  the cursor turns into the 
Layout tool, limiting changes to vert.pos and hor.pos, but not the bar position itself.

Vertical Position: Vert.Pos, Stave
The vert.pos parameter determines the vertical position or height of the chord symbol, 
above or below the staff. In Score Styles with more than one staff, the Stave parameter 
determines the staff that the vert.pos parameter refers to.

A hint:  to adjust a number of chord symbols to the same height above (or below) the 
staff, select them, and use the Align Object Positions Vertically key command.
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Rhythm Section Parts
To create typical rhythm section parts with chord symbols and Beat Slashes, select a 
Score Style with a Rest parameter set to “Slash”.
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16
16 The Transform Window
The Transform window is a very powerful non-real time 
processing tool. It enables very specific data event 
changes to one or multiple MIDI Regions, through the 
use of user-defined conditions.

This window allows you to select, say, all note events with a velocity that falls between 
80 and 86 to be adjusted to a fixed volume of 93. This can be done on one or a 
thousand MIDI Regions. The alternative of using another Logic editor to do this—note 
by note—is simply not feasible, or desirable, particularly on a thousand MIDI Regions!

Transform Window—Introduction

Usage
The Transform window can be used to alter existing events that match user-definable 
parameters.

The Transform window provides an extremely high degree of flexibility and power for 
complex edits and transformations of MIDI data.
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Opening the Transform Window
Select Windows > Open Transform (Command-4) to open a new Transform window.

Effective Range
The Transform window is only used to edit events. As with other editors in Logic, the 
operations are only performed on selected events. These might be:
• All selected events (in one of the editors),
• All events in selected Regions, or
• All events in selected folders.

You can use the link button in the top left corner to link the effective range with other 
windows.

All selected events on the same display level fall within the effective transform range, 
as do all events in the selected Region.

The title bar of the Transform window indicates the effective range; the song name and 
the name of the first selected MIDI Region, if applicable, are shown.

Purpose of the Transform Window
Conditions
This part of a transform function defines which events will be edited. If the Select and 
Operate or Select Only options are used, the transformer checks to see whether the 
individual parts of the events (Position, Status, Channel, and so on) fall within the 
effective range, as defined in the pull-down menus in the Select by Conditions panel.

Operations
The Operations section of the Transform window defines the edit operations that you 
wish to perform. These operations are defined via the pull-down menus in the 
Operations on selected Events panel.

Actions
The three main buttons at the top of the Transform window work as described below:

Select only
All events (in the effective range) that fulfil the Conditions will be selected, but not 
transformed. You can use this option to refine your selection, and ensure that your 
Conditions are set to only affect the events that you truly want to “transform”.

Operate only
All selected events are transformed, in accordance with the Operations settings 
(Conditions has no effect). This is useful if you want to edit events that you’ve already 
selected, manually.
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Select and Operate
This is a combination of both actions:  the events are selected in accordance with the 
Conditions, and are then transformed as per the Operations settings.

The title bar shows how many events have been selected and/or transformed after 
each action.

Use of Select only, followed by further selections in an editor, allows more refined (and/
or safer) transformations—activated with Operate only.

Display
The Hide unused Parameters checkbox allows you to remove all unused pull-down 
menus in the Conditions and Operations panels. This provides a better overview of the 
settings being used, and also protects the hidden menus from any accidental 
alterations.

Transformation
Mode
Basic operating modes are defined in the pull-down menu above the Conditions panel:

Apply Operations to selected Events
As described above, Operations are performed on selected events (default setting).

Apply Operations & Delete unselected Events
The selected events are edited, and all non-selected events are deleted. This ensures 
that the only events remaining after the transform operation are those that matched 
the Conditions.

If you set the Operations up correctly, you can use the Transform window as a 
programmable filter in this mode—where only events that match the Conditions 
survive.

Delete selected Events
The selected events are deleted.

In this mode, you can use the Transform window as a programmable erase function. All 
events that match the Condition are deleted, and all other events remain unchanged. 
The Operations setting is irrelevant in this mode.

Copy selected Events & Apply Operations
The selected events are retained in their original form, as well as being copied and 
edited.

You can use this mode for applications such as:
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Imagine you want to add a mod wheel controller event (#1) 10 ticks before each note, 
with a value that matches the note’s velocity. To do this, you set Status = Note in 
Conditions. In Operations, set the Position to Add and enter a value of 10 in the field 
below it. Set Status as Fix Control and Pitch (-1-) as Fix 1. The last of these operations 
means “the first data byte (-1-) receives the value of 1” (the first data byte defines the 
controller number for controller events, and mod wheel events happen to be #1). 

If we analyze these settings, we see that all note events will be selected for operation. A 
copy of each will be made, then moved 10 ticks earlier than the original, and converted 
to CC#1 (Mod Wheel)—with a value that corresponds to the velocity of the original 
note. This is because the second data byte (Vel) is left unaltered.

Event Parameters
Individual MIDI event parameters have their own columns in the Conditions and 
Operations panels:

Position
Time position of the event, referenced to the start of the MIDI Region (not of the song). 

Status
Type of event.

Channel 
Recorded MIDI channel of the event.

-1-/Pitch
First data byte (note or controller number).

-2-/Vel
Second data byte (velocity or controller value).

Length
Length of the note.

Subposition
Time position of the event, within a bar.

Conditions
The middle section of the window (Conditions) defines the conditions that determine 
which events are selected for edit operations. Each column represents a different MIDI 
event parameter.

The condition is considered to be fulfilled when an event matches the defined effective 
range of all event parameters. These ranges are determined in the pull-down menus 
found under each of the event parameter columns (except the Status column). The 
possible value conditions are listed below.
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The All setting in the top box means that all values fulfil the conditions, making all 
other boxes in the same column superfluous.

Conditions for the Status
You have a choice of just two settings here, All (means all event types fulfil the 
condition) and “=”. Clicking in the box below opens a pull-down menu, where you can 
select; note, poly pressure, control change, program change, channel pressure, or pitch 
bend.

Conditions for the values of Position, Cha, -1-/Pitch, -2-/Vel, Length, and 
Subposition
You can assign one of the following value conditions for each of the parameters 
(except the status):

“=”
The value in the event and the box below it must be equal, for the condition to be 
fulfilled.

Unequal
The value in the event and the box below it must be unequal, for the condition to be 
fulfilled.

Smaller 
The value in the event must be smaller than the value in the box below it, for the 
condition to be fulfilled.

Larger
The value in the event must be larger than the value in the box below it, for the 
condition to be fulfilled.

Inside
The value in the event must be within the value range of both boxes below it, for the 
condition to be fulfilled.

Outside
The value in the event must be outside the value range of both boxes below it, for the 
condition to be fulfilled.
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Exchanging Parameter Values
You can replace the value of each of the three event parameters:  Cha, -1-/Pitch and -2-/
Vel with the value of a different parameter from this group. Click on the lines between 
the Conditions and Operations fields to change the source for the parameter value. 
Note that the value is exchanged first, and then the operation is performed. 

Operations
The bottom part of the window (Operations) defines the changes to events that meet 
the Conditions, and offers separate columns for each MIDI event parameter.

The Thru setting in the top box means that the relevant event type passes through 
unaltered, making the other boxes in the same column superfluous.

Status Operations
Thru
The event type passes through unaltered.

Fix
The event type is altered. Clicking in the box below opens a pull-down menu, where 
you can choose between; note, poly pressure, control change, program change, 
channel pressure, or pitch bend.

Operations on the Values of Position, Cha, -1-/Pitch, -2-/Vel, Length, 
Subposition
For all parameters (except status), the top box determines the type of operation that is 
performed, using the values defined in the boxes below (referred to as the “set value” 
below). The following operations are identical for the channel and the first or second 
data byte, with the value ranges being automatically adjusted in the boxes below.

Fix
The parameter is fixed to the set value.

Add
The set value is added.

Sub
The set value is subtracted.
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Min
Parameter values lower than the set value are replaced by it. Larger parameter values 
remain unaltered.

Max
Parameter values that exceed the set value are replaced by it. Smaller parameter values 
remain unaltered.

Flip
The parameter values are reversed around a set point. Values above this amount are 
moved to the same distance below it and vice versa.

Mul
The parameter value is multiplied by the set value (4 decimal places).

Div
The parameter value is divided by the set value (4 decimal places).

Scale
The parameter value is multiplied by the top value, and the bottom value is then 
added. This is a combination of Mul and Add. Negative values can be used to generate 
an inversion of the plus/minus sign, and subtraction, rather than addition.

Range
Parameter values outside the set value range are replaced by the values of the (range) 
“limits” (combination of Min and Max).

Random
Random values are generated within the set limits.

+—Rand.
A random value between zero and the set value (positive or negative) is added.

Reverse
The parameter value is reversed within its value range (no value can be set here).

Quantize
The parameter value is quantized to a multiple of the set value.

Qua & Min
Like Quantize, but the quantization does not fall below the set value (a combination of 
the Quantize & Min functions, with the same set value).
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Exponent.
The parameter value is scaled exponentially. The extreme values (0 and 127) remain 
unaltered. The set value determines the shape of the curve. Positive values result in the 
exponential scaling of data (increasing input values remain lower for longer, and then 
rise quickly), and negative values result in the logarithmic scaling of data (decreasing 
input values remain higher for longer, and then drop off more quickly).

Crescendo
This only works if the Inside position condition is selected (crescendos need start and 
end points.). Crescendo creates a smooth alteration of the current parameters, between 
the set value boundaries.

Rel.Cres
This only works if the Inside position condition is selected. The effect is similar to that 
achieved by Crescendo, but the previous values of the parameters being altered are 
taken into account when the crescendo is created, preserving the relative feel of the 
original.

Use Map
The set Map will be used when this operation is selected.

Parameter Sets
Presets
The twelve items in the pull-down menu are write-protected presets. You can alter the 
presets temporarily, but any changes you make will be discarded when you leave the 
preset. Here is a list of the Presets:
• Crescendo
• Scale 14 bit PitchBd (Pitch Bend data will be scaled, keeping the 14 bit information 

intact)
• Double Speed (doubles the tempo by halving positions and lengths)
• Half Speed (halves the tempo by doubling positions and lengths)
• Humanize (adds a random value to the position, velocity, and length of notes)
• Reverse Position (reverses the positions of notes within a section)
• Reverse Pitch (inverts the pitch)
• Transpose (transposes the notes)
• Exponential Velocity (alters the scaling of the velocity curve)
• Velocity Limiter (limits the velocity)
• Fixed Note Length (creates constant note lengths)
• Maximum Note Length (limits the maximum note length)
• Minimum Note Length (limits the minimum note length)
• Quantize Note Length (quantizes the note length).
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Recalling Presets
Individual Transform sets can be selected directly via Functions > Transform submenu in 
the Event, Matrix, and Hyper Editor windows.
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17
17 Tempo
Logic provides several different tools and methods to 
create and edit tempo events.

This chapter discusses these tools, and covers the possible interactions between tempo 
events and MIDI and Audio Regions.

Display and Functions
Tempo Display
If your song has a tempo that stays the same throughout, you can set this constant 
tempo in the Transport window.

The current tempo is always displayed here, even if you’re using programmed tempo 
changes or external synchronization.

You can set the tempo display format on the Preferences > Display > Global preferences 
page.

Tempo Track
Tempo changes are controlled by tempo events, which are stored in a special Tempo 
track. This track can be displayed by choosing View > Global Track Components > Tempo. 
The Tempo track applies to the whole song. The tempo track also determines the 
relationship between incoming time code and the current song position.

Recording Tempo Changes
Open File > Song Settings > Recording and activate the Allow Tempo Change Recording 
checkbox. All tempo alterations made during recording are automatically stored as 
tempo events on the Tempo track. These events can be edited in one of the tempo 
editors.
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Adjusting the Tempo to Fit Regions
The Options > Tempo Adjust Tempo using Region Length and Locators command adjusts 
the MIDI tempo, making the length of the selected Audio Region exactly match the 
distance between the locators (Cycle area). If you want to use this function to adapt the 
MIDI tempo to match the tempo of a drum loop, make sure that the drum loop is 
cycling smoothly (use the Sample Editor for this), and that the length of the Region 
corresponds exactly to a specific musical length of the audio material. As an example, 
to ensure that the Region measures exactly two bars when played back, set a Cycle to 
match the musical length of the Region (two bars, in this case), and select Options > 
Tempo > Adjust Tempo using Region Length and Locators.

Tempo List Editor

You can open the Tempo List by clicking and holding on the Transport’s Sync button 
with the mouse. A pull-down menu will appear, allowing you to select Open Tempo List 
or you can simply select Options > Tempo > Tempo List Editor.

Note:  The layout, and way you use the Tempo List, are very similar to the Event List (see 
“Using the Event List” on page 297).

To create a tempo change in the Tempo List:
1 Set the song position to the required point.

2 Click the Create button.

3 A tempo event (of the current song tempo) appears. You can alter the tempo in the 
tempo column.

You can also use the Pencil tool to create a tempo change:
1 Click on the word “Tempo” in an existing tempo event with the pencil tool.

2 A new tempo event will appear, accompanied by an open position input box. Enter the 
required bar position and press Enter.

To delete tempo changes in the Tempo List:
m You can delete tempo events by clicking them with the eraser, or pressing Backspace. 

To copy a tempo change from a passage:
1 Set the locators to the passage containing the correct tempo change.

2 Choose Edit > Select Inside Locators.

3 Copy the tempo events to the Clipboard (Command-C).

4 Deselect all tempo events (by clicking the background).
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5 Paste the tempo events from the Clipboard (Command-V).

6 A position input box appears at the first tempo event, allowing you to alter the bar 
position. If the first tempo change is not at the start of the bar in the passage, be sure 
to alter the bar number, and leave the beat, sub beat and frame or tick values 
unaltered.

7 Press Enter. The copied tempo changes will be selected, and you can undo the 
operation if necessary.

Other Functions
The entries in the tempo list interact with and affect each other. You can also make 
several synchronization settings here. All other functions are identical to those in the 
Event List (see “Using the Event List” on page 297).
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18
18 Synchronization
Logic can be synchronized with external hardware and 
software via a number of different synchronization 
protocols.

This chapter discusses the synchronization of Logic—as both synchronization master 
and slave—in a number of different situations.

Functions
Switching on External Sync

Activation of the Transport Sync button synchronizes Logic to the chosen sync source. 

You can use the Sync button to turn off external sync at any time, without changing 
your selected sync source. This allows you to temporarily remove Logic from the sync 
master’s time axis. This could prove useful if you need to quickly edit a MIDI Region 
while the external sync source (tape machine, VTR, and so on) is still running, for 
example.

Recording With External Synchronization
When Record is pressed during external synchronization, Logic enters record mode, but 
does not start until it detects external time code.

Incoming MIDI Time Code Display
The flashing dot on the Transport window’s Sync button indicates that Logic is 
receiving error-free MIDI time code.

If the dot “sticks”, an error has occurred. Although Logic is capable of dealing with many 
MTC errors, you should nevertheless check the quality of your SMPTE signal, as well as 
any other potential error sources.
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MTC Interpretation
As the MIDI standard only supports four of the possible six time code formats (the 
30 fps and 29.97 fps formats cannot be differentiated), Logic needs to decide which 
format is “intended”, when it encounters incoming time code:

Incoming MTC format is interpreted as:
• 24 fps–24 fps
• 25 fps–25 fps
• 30 drop fps–29.97 drop fps
• 30 fps–30 fps

In other words, the much more commonly used 29.97 fps and 30 drop fps formats are 
used in place of the uncommon 30 fps, and the virtually-unheard-of 29.97 drop fps 
formats.

You can, however, manually set the format to whatever you like in the Song Settings > 
General > Frame Rate pull-down menu:  to convert material to 30 fps for black and 
white TV transmission in the NTSC format, for example.

Receiving MIDI Clock/SPP
Synchronization via MIDI Clock/SPP is the most accurate method to use—if Logic is 
being synchronized to a bar-referenced master.

MIDI Clock has a resolution of 24 PPQN (pulses per quarter note), while Logic has an 
internal resolution of 960 PPQN (some 40 times more accurate). For this reason, Logic 
needs to interpolate the 39 steps between two incoming clock pulses.

If you experience small variations in the timing between master and slave, you can 
tighten the sync (when in external sync mode) by entering the expected tempo 
changes from the master into Logic’s internal tempo list as well.

Even if you don’t take this step, synchronization should still be fairly tight, as long as 
you avoid large deviations, such as an internal setting of 200 bpm, with an external 
tempo of 40 bpm.

Continue Event
When a MIDI Continue Event is received, Logic doesn’t leap to the last valid position 
received via MIDI Clock. Rather, playback continues from the current song position. This 
allows you to manually change the song position while the sequencer is stopped, and 
then restart from the new position, with a MIDI Continue command.
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Synchronization Window
Overview
You can open this window from the Arrange window using File > Song Settings > 
Synchronization, or by click-holding the Sync button in the Transport window. 

At the top, there are tabs for selecting the various pages:  General, Audio, MIDI, Unitor.

General
This page of the synchronization window contains the major synchronization 
parameters for running Logic as a slave.

Audio
This page of the synchronization dialog window contains all parameters relevant to 
synchronizing Audio and MIDI.

MIDI
This page configures Logic to send timecode via MIDI, when the sequencer is running. 
This enables you to synchronize external devices as slaves to Logic, which acts as the 
master.

Unitor
This page is used to set the major synchronization parameters for the Unitor8.

General
Sync Mode
This parameter defines the master that Logic is synchronized to:

Internal
Logic’s internal timer. Logic is the master. External devices can be synchronized via MIDI 
Clock or MTC (the relevant settings are made on the MIDI page).

MTC
MIDI Time Code mode. Logic runs as a slave. MIDI Time Code can either arrive at a MIDI 
In port, or be generated by a MIDI interface that “translates” it from incoming SMPTE 
time code.

MIDI Clock
MIDI Clock and Song Position Pointer. Logic runs as a slave. Clock and SPP can be 
received at any MIDI input.
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Auto Enable external Sync
When this option is activated, Logic runs as the master (Internal sync mode), until it 
receives a synchronization signal—either in the form of MTC, Clock/SPP, or from the 
tempo interpreter.

Logic automatically locks to the first synchronization signal it receives. Please ensure 
that different synchronization signals don’t arrive simultaneously—there can only be 
one time code master.

Frame Rate
This is where you set the frame rate (in “fps”, frames per second). This frame rate applies 
to both transmitted and received time code.

Frame rate and typical applications
• 24:  Film
• 25:  Audio (Europe) and PAL Video
• (30 d):  Unusable (not realtime)
• 30:  Audio (USA) and NTSC Video (s/w)
• 29.97 d:  Audio (USA) and NTSC Video (color)
• 29.97:  Extremely rare (not realtime)

“d” stands for “drop frame”. In “drop frame” formats, certain frames are left out, following 
a regular pattern. To distinguish between them, formats without drop frame are 
sometimes referred to as “nd” or “non drop”.

Auto Detect Format of MTC
This checkbox, when active, analyzes the incoming time code and automatically sets 
the correct frame rate. You should generally leave this option switched on.

Please note that it is not possible to automatically distinguish between MTC frame rates 
of 29.97 and 30 because:
• the MTC standard does not allow a distinction, and
• a measured rate of 30 fps could also be 29.97 fps time code running too fast, and vice 

versa.

Logic automatically interprets frame rates of “approximately 30 fps” as either 29.97 df or 
30 nd, depending on whether or not the drop frame format is used. This interpretation 
will usually be correct, because only these two formats are actually used as a standard.

“Auto Detect” only switches to 29.97 df or 30 nd if one of the other conventional 
formats was previously set. If you want to synchronize Logic to one of these 
unconventional frame rates, you need to define the format manually. This setting will 
not be altered by “Auto Detect”.
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Validate MTC
This pull-down menu option allows you to specify how often Logic checks for incoming 
time code, in order to ensure synchronization. In general, you should leave this option 
set to always. There are some devices, however, that generate timecode pulses that 
may require a specific number of frames to be set, in order to maintain synchronization. 
The never, Jam Sync option basically sets Logic to “free-wheel” if synchronization is lost. 
In other words, Logic will run on its own internal clock (at the most recently received 
tempo) if the synchronization pulse is lost. This approach ensures that recording will 
continue, even if the incoming timing pulse fails. 

SMPTE Offset 
This is where you set the SMPTE offset for the song. As songs don’t always need to start 
precisely at bar 1, you can select any bar position to be played at the set SMPTE time.

The preset is 1/1/1/1 at 1:00:00:00. The SMPTE offset 1:00:00:00 is normally used, 
because it allows you to pre-roll an amount of time code.

Audio
MTC [fps]
This display shows the deviation between the incoming MTC, and its nominal frame 
rate.

If the deviation is too large, please make sure that you have set the right frame rate (on 
the General page of the synchronization window). If in doubt, set the frame rate to 
24 fps and switch on Auto detect format of MTC.

If the frame rate is correct, you can use this display to adjust the tape speed of the 
master machine to the nominal value (the same speed used when the time code was 
recorded). Adjust the varipitch control on the master machine, until the vertical yellow 
line is centered.

Sample Rate (Hz)
This display shows the deviation of the sample rate from its nominal value.

Bear in mind that some audio hardware will not allow any variation in the sample rate.

Deviation (ms)
This display shows the current phase deviation of the word clock from the time code 
master—in other words, the deviation between audio and MIDI.

Varying time code signals shown in this display indicate how Logic regulates the 
sample rate of the hardware, when in MTC continuous sync mode. Even large time code 
variations result in no deviation between audio and MIDI. Your audio hardware must be 
capable of continuously variable sample rates, for this to function.

Small deviations between audio and MIDI are unavoidable, because MIDI can (and 
should) follow the time code master directly.
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Audio Sync Mode
This is where you define how each individual piece of audio hardware should be 
synchronized to an external time code master.

Not all audio hardware can work in every sync mode described below. This is 
particularly dependent on whether or not the hardware’s sample rate can be 
controlled.

MTC Continuous 
Audio regions are started in sync, and the sample rate is continuously regulated in 
accordance with variations in the time code master signal. Even very long audio 
regions stay in sync in this mode.

MTC Trigger
Audio regions are started in sync, but are then played at a constant sample rate, 
regardless of any variations in the time code master signal. Logic always uses the set 
nominal sample rate (44.1, 48, 88.2, 96 kHz).

This mode is suitable when it is vital to retain the absolute pitch of a recording. If the 
speed of the time code master deviates from the nominal value, you may need to split 
long Regions into shorter sections.

External or Free
Logic has no influence on the sample rate. The audio hardware is responsible for 
ensuring that the position and sample rate of audio Regions match. This mode is only 
advisable if you are sure that the word clock and time code master are running in 
sync—by using an external SMPTE/wordclock synchronizer, for example.

MIDI
Transmit MIDI Clock
The checkboxes activate transmission of MIDI Clock. The pull-down menus determine 
the MIDI output ports for the MIDI Clock signal.

The two Destinations allow you to specify discrete MIDI ports.

Every time you start, “Song Position Pointer” (SPP) is also sent.

As not all devices can process SPP, the MIDI system realtime “Continue” message is also 
sent. The exception to this is when you start at position 1 1 1 1. In this situation, the 
realtime “Start” message is sent.

MIDI Clock can easily be sent with other normal MIDI events (notes, controllers). When 
using multiport MIDI interfaces (such as the Unitor8), better timing is achieved by 
sending MIDI Clock to All ports, rather than to several individual ports.
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If MIDI Clock is transmitted to all ports, the events are only sent once from the 
computer to the interface. If you address individual ports, one event needs to be sent 
for each port, placing a higher strain on the bandwidth of all ports.

Transmit MIDI Clock Delay
This parameter allows you to delay the transmitted time code. Negative values mean 
that the MIDI Clock signal is transmitted earlier. This enables you to compensate for any 
reaction delays in external MIDI Clock slaves.

Transmit MTC (MIDI Time Code)
The checkboxactivates transmission of MIDI Time Code. The pull-down menu 
determines the MIDI output port for the MTC signal.

It is not advisable to send MTC to all ports. MTC is very data-intensive, so use a MIDI 
port that isn’t being used for anything else.

Transmit MMC (MIDI Machine Control)
This is where you can switch on transmission of MIDI Machine Control (see “Sync 
Problems and Solutions” on page 460). These commands are then sent whenever you 
operate Logic’s transport functions (Start, Stop, Rewind, and so on).

MMC is normally used when Logic is running as a slave to an external master (such as 
an ADAT), and you want to control the external master’s transport functions from Logic. 
Logic therefore acts as MMC master, and MTC slave simultaneously.

If you want to use the external master’s transport controls, you don’t need to use MMC. 
In this situation, Logic will follow the MTC master as a slave.

You can also use MMC to place tracks on the MMC slave device into record-enabled 
mode.

Listen to MMC Input
Logic can be controlled by MMC (MIDI Machine Control) and so-called “Full Frame 
Messages” (Listen to MMC Input). Transmit MMC has been available in Logic for quite 
some time. 

Logic recognizes these commands when “listening” to MMC Input:
• Play
• Deferred Play
• Stop

Deferred Play is a special command for mechanically slow synchronization slaves such 
as reel-based tape recorders. Rather than having the machine play immediately, it is 
asked to reach the desired SMPTE position before playback is started. You’ll find no 
difference in Logic’s response to the play and deferred play commands, as Logic can 
locate as quickly as any hard disk recorder.
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Logic ignores these messages when incoming external MTC (MIDI Time Code) 
commands are detected.

Logic also obeys so-called “full frame messages”, and sets Logic’s song position line to a 
new location, without starting playback. Once again, incoming MTC data has higher 
priority, if conflicting information is received.

Some synchronizers send “Full Frame Messages” (instead of MTC) to locate the slave 
device (Logic in this case) to a new position, without implicitly starting playback. This is 
useful when in slow shuttle or single frame advance modes with video machines, 
because the slave device is perfectly located, without being in playback mode.

The MIDI Sync Preferences button launches the MIDI Synchronization preferences 
window (see “MIDI Preferences: Sync” on page 482).

Unitor
SMPTE Mode
Here, you can instruct the Unitor8 to write SMPTE. You must switch from Read to 
Generate, and set the frame rate and start-time in the “General” page. In Refresh mode, 
fresh time code is generated in sync with received time code. “Refresh” works with both 
VITC and LTC.

You should always use “Refresh” whenever you need to copy an LTC track, because you 
cannot directly copy LTC without a considerable loss of quality. When copying whole 
multitrack tapes, you should patch all tracks directly, but refresh the TC track via the 
Unitor8.

You should only use Refresh mode if you are copying time code.

SMPTE Type
This is where you define the SMPTE format that you want to use:

LTC:  Longitudinal Time Code is written to a tape track.

VITC:  Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a video 
tape.

Freewheel
You can set the freewheel time in frames for LTC and VITC. The freewheel parameter 
affects the SMPTE reader, and specifies how long the synchronizer continues 
transferring MTC to the sequencer, after time code ceases to be read.

Long freewheel times can maintain synchronization, even if there are drop outs in the 
time code, but they also increase Logic’s reaction time—after the time code master 
stops. In practice, you should set the value as large as necessary (for sustained 
operation), and as small as possible (for short waiting times).
Chapter 18    Synchronization



 

TV Format
Allows you to define the television format for time code burn-in:

PAL:  The video format used in Europe. If you are working with video in SECAM Norm, 
select PAL.

NTSC:  The video format used in the USA and Canada.

You don’t just need this setting when writing and reading VITC. If you’re working with 
LTC, and you want to generate a video picture a with burned-in SMPTE time, you also 
need to set the correct format here.

VITC Line 1, VITC Line 2
VITC is written into two lines of the video picture, which are normally invisible. The lines 
should not be adjacent, and are usually situated between 12 and 20.

If “Scan” is enabled, the VITC lines are automatically recognized. You should only enter 
the lines manually if there are problems with “Scan” mode.

Visible Time Code Display
The parameters allow you to set the position, size, and color of the time code counter 
window, which is burned-into the video picture.

Bar Ruler—Time Ruler
Positioning Bars to Frames
If you want a particular bar in the song to coincide with a specific SMPTE time, you 
need to alter the tempo of the preceding passage.

The following procedure will save you from having to do this by trial and error:
1 Open the Tempo List (see “Tempo List Editor” on page 448).

2 Create a tempo event at the desired bar position.

3 Set the desired time position for this tempo event in the SMPTE-Position column. The 
preceding tempo event is automatically adjusted to generate the correct bar and time 
position for the inserted tempo event.

4 You can then delete the tempo event you inserted, if you want to keep the same 
tempo for the following passage.
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Sync Problems and Solutions
Faulty Digital Synchronization
If Logic is synchronized to external wordclock (Audio Sync Mode:  External/free), you 
must ensure that a valid digital signal is always available. If you encounter error 
messages such as “Sample Rate xxx kHz recognized” it may be that the DAT recorder (or 
whatever clock source you have connected to your audio hardware’s digital input) does 
not transmit wordclock in stop or pause mode (or has switched itself off ).

Faulty Synchronization to an External Tape Machine
Create a new song, make a new recording and see if that does the trick. Why? If an old 
recording on tape was not properly synchronized to time code, you won’t be able to 
use it. One basic rule:  the playback situation must be identical to the recording 
situation.

If everything is working fine with the new recording, this means the present setup is 
okay. Next, check whether anything has changed in your global setup. Has the frame 
rate changed? Has the tape speed changed? If you have changed a 30 fps setting, try 
variations such as 30 drop or 29.97.

If MIDI and Audio Are Not Synchronized
Open the Synchronization > Audio page and select the MTC continuous or MTC Trigger/
ASD Audio Sync Mode. 

If your audio hardware doesn’t support either mode, you should cut extremely long 
Regions into shorter sections.

If MIDI and SMPTE Are Not Synchronized
Check all frame rate settings. The frame rate of all connected devices must be identical, 
including the time code on the tape machine, the synchronizer, and in Logic itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation, open the 
Tempo Editor, switch off the Detect option, and set the correct frame rate manually.
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19 Video
Logic supports the viewing of QuickTime video files in 
the Arrange Video track, making film and TV scoring 
quick and easy.

You can also view QuickTime video files in a separate window. This chapter covers the 
use of video files in Logic.

Synchronizing QuickTime Movies
QuickTime is a Macintosh standard for digitized, data-compressed films which can run 
in individual windows. If you want to play these films, Quicktime must be installed on 
your system.

You also need a fast hard disk, and above all a fast Mac, allowing the movie to be 
played smoothly. If you want to record a film like this yourself from a video recorder, 
you need specialized hardware, and relevant software (such as iMovie).

You can make QuickTime movies run in a Logic window, in sync with a song. Wherever 
you move the song position the film follows, and vice versa.

Opening a Movie
Select the global Options > Movies > Open Movie function to open a typical file selector 
box. You can then select a QuickTime movie from your hard disk or other storage 
device.

If you select Options > Movies > Open Movie as Float you can open a QuickTime movie 
in a float window. This ensures that the movie window will always stay on top.

Reopening a Movie
The Open Movie Again (as Float) command reopens a movie window with the same film 
clip. This is particularly useful if you want to open the video clip in a different Screenset.
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Working With Movies
In the QuickTime window, you can enter the SMPTE offset of the film in the Movie Start 
row. This is independent of the SMPTE offset for the song. Grabbing and dragging the 
position slider at the bottom of the video, or using the forward/rewind buttons to the 
right, moves the film to any position, and Logic will “chase” to the corresponding song 
position. All QuickTime transport functions interact with those of Logic.

Optimal Image Size
If you click once on the gray bar at the bottom of the video image, the QuickTime 
window will expand to fill the whole screen in such a way that the entire video image, 
whatever its shape, best fits your monitor. The window borders will also disappear (Best 
Size without Borders)

This proportional enlargement does mean that strangely-shaped images may not fill 
the entire monitor. There are two advantages to this:  the proportions of the image is 
retained, and a faster screen refresh rate can be obtained, because the graphics card is 
not overloaded with conversion calculations for altering the movie’s proportions.

Clicking on the gray bar at the bottom of the image restores it to its original format and 
size.

Options
Clicking and holding on the movie image opens the options menu. You can set various 
proportional image formats, from half-size to 8× size here.

The following image sizes are also selectable, allowing a non-proportional enlargement 
of the image if it is oddly-shaped for the monitor you’re using:

Pixel 512 × 384
Changes image size to NTSC Underscan format.

Pixel 640 × 480
Changes image size to PAL Underscan or NTSC Overscan format.

Pixel 768 × 576
Changes image size to PAL Overscan format.

Make Proportional
This selects the next-largest proportional setting.

Center
Choosing this option places the video image in the middle of your screen.

Best Size without Borders
This option is equivalent to the click on the gray bar at the bottom of the video screen.
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Synchronization Methods
The Continguous Sync option allows you to switch between the following sync 
methods:

When Continguous Sync is turned on, Logic controls the playback speed of the movie, 
keeping music and pictures in sync at all times. If the film has a soundtrack, the audio 
signal will be transposed slightly, if necessary, by means of sample rate conversion. This 
sync method is possibly more precise, but requires greater processing power.

Video to song adjust
Found under Preferences > Video, this global setting can be used to fine tune the 
starting point of a movie. 
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20 Song Settings and Preferences
The Song Settings and Preferences allow you to define 
many of Logic’s basic operating parameters. This section 
explains each of these menu items individually.

Unless otherwise indicated, the descriptions of the various options apply when the 
selection box next to the option is checked (in other words, when it’s active).

Song Settings and Preferences are accessible via the File > Song Settings and Logic > 
Preferences menu items. When either is selected, a Preferences or Song Settings 
window will be launched. 

Each window features a number of icons and tabbed panels. These are much like 
menus and sub-menus. To adjust a given Preference, simply select the desired icon, 
then the appropriate panel tab, and then activate/deactivate the preference, or make 
your selection from a pull-down menu. Just close the window once you’ve made your 
selections.

In some instances, you will find a button that links to the Song Settings window, while 
you are in the Preferences window (and vice-versa). Clicking on this button will launch 
the Song Settings window, and will automatically select the relevant panel. As an 
example, the Preferences > MIDI > Sync panel features a MIDI Sync Song Settings 
button. Clicking on this button will launch the Song Settings > Synchronization > MIDI 
panel.

Both the Song Settings and Preferences windows can be visible at the same time, 
making the set up of Logic’s operating parameters faster and clearer.

Some of these can also be reached directly from Logic’s local menus (in the Score 
window, for example), or from the Transport buttons, via pop-up menus.
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Saving of Song Settings and Preferences
The Song Settings are stored with the song file. If you want to start Logic with certain 
settings, simply make the desired settings in your Autoload song or a Template. 

The Preferences are saved whenever you quit Logic. There are several Preference files, 
which are stored separately in the $/User/Library/Preferences folder. Logic preference 
files all begin with “com.apple.Logic”.

Note:  All choices made in the Song Settings window are specific to the saved song. All 
items selected in the Preferences window globally affect all songs.

Song Settings
Song Settings, as mentioned, are saved independently with each song, which means 
that different songs can have different song settings. You can save all of your standard 
settings in the Autoload Song, which is the default song file that is automatically 
loaded when you boot Logic (unless you’ve started the program by double-clicking on 
a specific song file instead of the actual program icon, or have selected a Template). 
This way, you can start each Logic session with your preferred working setup.

Synchronization Settings
All Synchronization Song Settings are described in the Synchronization Chapter (see 
“Synchronization” on page 451).

Metronome Settings
File > Song Settings > Metronome or a long click on the Metronome button in the 
Transport Bar opens a settings dialog window for the Metronome. This window 
combines all settings for the MIDI Click Environment Object.

In addition, the Metronome dialog features a virtual metronome sound source called 
Klopfgeist (see the Klopfgeist section in the Plug-in Reference). It can be used either, in 
addition to, or in place of, the speaker and MIDI click source.

MIDI Click Settings
These settings include the MIDI port of the MIDI Metronome and allow you to 
separately set the Channel, Note, and Velocity for the Bar, Beat, and Division (format 
value) of the click.

Klopfgeist Parameters
The Klopfgeist checkbox activates/deactivates this virtual metronome.

The Tonality parameter changes the sound of the virtual metronome from a short click 
to a pitched percussion sound, similar to a Wood Block or Claves.

Volume adjusts the overall sound level of the virtual click sound. 
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Output (assignment):  Provided the audio hardware used by Logic offers more than two 
outputs, this field allows the routing of the Klopfgeist metronome sound to a different 
set of hardware outputs. 

Note:  Klopfgeist is a software instrument found in the Mono plug-in menu of Audio 
Instrument channels. Klopfgeist is inserted on Audio Instrument channel #64, by 
default. Logic will automatically create Audio Instrument channel #64 (with Klopfgeist 
inserted) when the Klopfgeist checkbox is activated. Theoretically, any other Logic or 
third-party instrument could be deployed as a metronome sound source—using Audio 
Instrument channel 64.

Klopfgeist can also be used as a simple and unique software instrument as well. The 
Klopfgeist Plug-in window offers a few additional sound parameters over those found 
in the Metronome window.

Other Settings

Metronome plays through built-in speakers
This sends the metronome click to the computer loudspeaker. 

Note:  The System Preferences > Sound pane must be set to Internal Speakers in order 
for the speaker click function to work.

Click while recording (e)
The metronome click is automatically switched on for recording. This is the same as 
activating the Metronome button in the Transport Bar during recording.

Only during count-in
When this option is active, the recording mode click will only be audible during the 
song count in, and is then switched off. 

Click while playing (p)
The metronome click is automatically switched on for playback. This is the same as 
activating the Metronome button in the Transport Bar during playback.

Polyphonic Clicks
The MIDI Metronome Environment Object sends notes, as defined for bars, beats, and 
divisions. As an example, two or three notes may be sent simultaneously at the 
beginning of each measure. If this option is unchecked, the metronome will only 
transmit one note at a time.
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Recording Settings
This page can be reached in various ways:  by key command (default:  Option-R), the 
File > Song Settings > Recording menu option, or from the Recording menu item, 
accessible by click-holding on the Metronome or Record buttons of the Transport.

The Recording Song Settings determine how Logic responds while in record mode. You 
can enable/disable some checkboxes via the computer keyboard, by using the keys 
indicated in brackets after the function name. Any key commands normally assigned to 
these keys will be temporarily deactivated while the Song Settings window is open.

General
Auto mute in cycle record
If recording in Cycle mode, this function creates a new Region for every cycle—
provided that there is data input during each “pass”. All Regions created in previous 
cycle passes are automatically muted. If the Auto create tracks in cycle record function 
(described next) is not active, all Regions are layered onto one track. Activation of this 
function deactivates both of the Merge functions.

Auto create tracks in cycle record
While recording in Cycle mode, this option creates a new track with each new cycle 
pass—provided that there is data input. The recorded Regions from earlier cycle passes 
are moved down to the track(s) below, with the “oldest” tracks ending up at the bottom 
of the list. Use of this option deactivates both Merge functions. This functionality is 
useful when attempting multiple takes of a solo, while cycling over a section of music. 
The recordings made during each cycle pass will appear on their own tracks, making it 
easy to sort through them, once you have finished recording.

Allow Tempo Change Recording
All tempo changes made while in record mode are recorded. For details on editing 
these “tempo recordings”, please see the Tempo section (see “Display and Functions” on 
page 447).

MIDI
Merge new recording with selected Region 
After each recording, all newly-recorded data is merged with all selected Regions on 
the recorded track, to form one Region. When Merge new recording… is activated, 
Merge only new Regions in cycle record is automatically activated as well.

Merge only new Regions in cycle record 
When recording in Cycle mode, this function merges all data recorded during 
subsequent cycles to the Region recorded during the first cycle. It can be used 
independently of Merge new recording with selected Regions.
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MIDI data reduction
Controller events are thinned out during recording, to reduce the data load on the MIDI 
bus during playback. This improves the timing of dense arrangements when using 
interfaces with only a few MIDI ports. The function actually reduces the duration of 
controller events, using an intelligent algorithm which retains the value at the end of a 
succession of controller messages.

Tuning Settings
A real-time tuning system is available for use with Logic’s software instruments. There 
are a number of parameter settings that are accessible via the File > Song Settings > 
Tuning panel.

We’ll discuss these options shortly, but before beginning, we’d like to cover some basics 
and background information.

About Alternate Tunings
The twelve tone scale that is currently used in Western music is a development that 
took centuries. Hidden in-between these twelve notes are a number of other 
microtones that represent different mathematical ways of expressing the frequency 
intervals between “tones”.

To explain, let’s take a look at the harmonic series, and the underlying harmonic theory. 
Imagine that you have a fundamental frequency of 100 Hz (100 vibrations per second), 
the first harmonic is double that, or 200 Hz. The second harmonic is found at 300 Hz, 
third at 400 Hz, and so on. Musically speaking, we know that when frequency doubles, 
pitch increases by exactly one octave. The second harmonic (300 Hz) is exactly one 
octave and a pure fifth higher than the fundamental frequency (100 Hz). 

From this, you would assume that tuning an instrument so that each fifth is “pure” 
would be the way to go, right? In doing so, you would expect a perfectly tuned scale, 
as you worked your way from C though to the C above or below. Close, but no cigar.

To simplify this example, we’ll start tuning at a frequency of 100 Hz and we’ll call it ‘C’ (a 
real ‘C’ would be closer to 130 Hz). The first fifth would be tuned by adjusting the pitch 
until a completely clear tone is produced, with no beats (beats are cyclic modulations 
in the tone). This will result in a ‘G’ at exactly 150 Hz. This is derived from this 
calculation:
• the fundamental (100 Hz) × 3 (=300 Hz for the second harmonic)
• divided by 2 (to drop it back into the same octave as your starting pitch).

This relationship is frequently expressed in terms of the ratio 3:2. 
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For the rest of the scale:
Tune the next fifth up:  150 × 3 = 450/2 = 225 (which is more than an octave above the 
starting pitch, so you need to drop it another octave to 112.5.

As you can see from the table above, there’s a problem! 

Although the laws of physics dictate that the octave above C (100 Hz) is C (at 200 Hz), 
the practical exercise of a (C to C) circle of perfectly tuned fifths results in a C at 
202.7287 Hz. 

This is not a mathematical error. If this was a real instrument, the results would be clear.

There is, as you can see, a choice. Either:
• each fifth is perfectly tuned, with octaves out of tune, or 
• perfectly tuned octaves with the final fifth (F to C) out of tune. 

It goes without saying that detuned octaves are more noticeable to the ears.

The Comma
The difference between a perfectly tuned octave and the octave resulting from a tuned 
circle of fifths is known as the “comma”. 

Over the centuries, numerous approaches have been taken to solve this mystery, 
resulting in a range of scales, and finally arriving at the concept of “equal temperament”. 

Other temperaments that have been devised throughout history maximize or 
emphasize different aspects of harmonic quality. Each compromises in some way or 
another. Some maximize pure thirds (Mean Tone) while others emphasize pure fifths, at 
the expense of the thirds (Kirnberger III, for example). 

Note Frequency (Hz) Notes

C 100 × 1.5/2

C# 106.7871 divide by 2 to stay in octave

D 112.5 divide by 2 to stay in octave

D# 120.1355 divide by 2 to stay in octave

E 126.5625 divide by 2 to stay in octave

F (E#) 135.1524

F# 142.3828 divide by 2 to stay in octave

G 150 (× 1.5) divided by two

G# 160.1807

A 168.75

A# 180.2032

B 189.8438

C 202.7287
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Every temperament has its own “character”, and a given piece of music may sound fine 
in one key, but awful in another. Transposing a piece to a new key can completely 
change its character. 

Careful attention must be paid to the selection of temperaments for authentic 
performances of historic keyboard music. The wrong choice could result in an 
unsatisfactory and historically inaccurate musical experience. 

About Equal Temperament
Equal temperament takes the tuning ‘error’ (the comma), and spreads it equally 
between each step of a chromatic scale. The result is actually a scale of equally mis-
tuned intervals, with no interval grossly out of tune, but none in perfect tune. Equal 
temperament has become the de-facto standard for two main reasons:  
• Convenience—Retuning an instrument to a specific temperament that is better 

suited to a particular piece of music is a hassle.
Many instruments are not capable of being alternately tuned (fretted string 
instruments, for example). 

• Portability—All Western musical pieces can be performed (adequately) on an 
instrument tuned to equal temperament. Obviously, some of the nuances may be 
missing for pieces that were originally performed in another temperament. On the 
flipside, pieces that depend on equal temperament may sound terrible by the 
placement of various mis-tuned intervals. 

Software Instrument Pitch
Tune
This parameter determines the global tuning of all software instruments. The default is 
concert pitch A=440 Hz. To adjust, simply grab the slider and move it to the left or 
right. Detuning is in cent (1/100th of a semitone) steps.

Scale
Activation of alternate tuning scales is achieved by clicking the appropriate radio 
button in the File > Song Settings > Tuning pane. The selected tuning scale will be saved 
when the song is saved, and reloaded the next time the song is opened.

Equal Tempered
This mode disables any tuning, and uses an equal tempered scale—just like earlier 
Logic versions.

Fixed Tuning
This option activates a number of fixed tuning Scales and Keys. The Type pull-down 
menu provides you with the most important historic tuning scales, amongst others.

The Root Key pull-down menu allows you to select a global key (C–B) for the chosen 
scale as an easy way to reference the chosen historic scale to any root note. 
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This mode tunes keys to different degrees of scaled tuning, and delivers a “key 
signature character”. When playing mostly white keys (in the Pure setting, and with C as 
the Root Key), C major will be the main focus, and tuning will be scaled to that chord. 
An A major chord that is played immediately after a C major (and is therefore subject to 
C major scaled tuning) will be affected somewhat by the scaled tuning effect, but will 
not sound completely tempered. If you normally play polyphonic music, this mode 
(when using the Pure setting) will sound most pleasing to your ears.

The Fixed Tuning scales are ideal for a number of Baroque and Mediaeval instruments 
and styles of music.

User
Each semitone can be detuned from equal temperament in semitone steps. To do so, 
just click-drag—vertically—on each semitone box until the desired value is reached. 
Alternately, you can double-click in each semitone box, and type in a value. Press Enter 
or click on another box to exit the text entry mode.

The Reset button will reset all of your tuning adjustments to their default values.

The Stretch Lower and Stretch Upper sliders can be used to stretch the tuning in the bass 
and treble, to simulate the “stretched tuning” of some instruments, for example 
acoustic pianos. 

Stretch Lower determines the deviation from the equal-tempered scale in the bass end 
of the sound. The higher the value, the further down the low notes are tuned. A setting 
of 0 results in an equal-tempered scale tuning. 

The Stretch Upper parameter does the same in the treble end of the sound. 

MIDI Settings
This page can be reached from the main menu File > Song Settings > MIDI option. These 
settings determine the behavior of the MIDI inputs and outputs. Simply click on the 
appropriate tab to access the parameters described in each section.

General: Miscellaneous
After loading Song, send:
Used Instrument MIDI settings
Sends the checked Instrument MIDI Settings  (see “Adjusting the Sound of a Track” on 
page 104) automatically after loading a song.

All fader values
This option causes all Environment fader values  (see “Special Functions” on page 183) 
to be automatically sent after a song is loaded.
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MIDI Remote
Global button for controlling Logic via MIDI Commands. Clicking on the Configure 
button will launch the Key Commands window  (see “To assign a function to a MIDI 
message:” on page 43).

General: MIDI Thru
SysEx with MIDI Thru function
Incoming SysEx messages are passed through the computer to the MIDI output(s), 
along with other MIDI data. This is particularly important when using hardware 
programmers, as only then will you be able to immediately monitor the changes to the 
synth you are editing. If you just want to record SysEx dumps, don’t select the 
checkbox. It rarely makes sense to divert dumps through the computer unless you 
want to record a dump, and simultaneously transmit it to a second device of the same 
type.

Instrument without MIDI Thru Function
The instrument selected here will not pass events through the computer, when the 
instrument is assigned to the selected Arrange track. Normally, you would set the “No 
Output” instrument here.

If your master keyboard does not have a “Local Off” setting, you can use this feature to 
avoid unwanted note doubling when recording:
• With multitimbral sound sources, assign the instrument (usually channel 1) which 

plays the part that is heard when playing with the computer turned off.
• With mono-timbral sound sources, assign the instrument which represents the sound 

generating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard 
whenever you are recording tracks for any other instrument.

It is possible to disable MIDI Thru for any MIDI track in the Arrange window selectively, 
by simply disabling the “R” button to the left of the track name.

General: Software Instruments
Use MIDI Controllers
This pull-down menu allows you determine the behavior of software instruments when 
addressed by MIDI Controller messages higher than CC #65.

Input Filter
The input filter switches are used to filter out certain event types at the sequencer 
input. When a switch is enabled (checked), it will filter the corresponding incoming 
events. You can filter the following event types:
• Note events.
• Program Change events.
• Pitch Bend events.
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• Control Changes (such as the modulation wheel of a MIDI keyboard).
• Aftertouch events (channel pressure).
• Polyphonic Aftertouch (polyphonic key pressure).
• System Exclusive data (such as patch dumps from synthesizers).

Chase
This MIDI Song Settings panel is used to alter the Chase Events  (see “Chase Events” on 
page 89) settings.

You can reach this page via the main menu File > Song Settings > Chase Events option.

You will see a number of checkboxes that determine the event type(s) that will be 
chased. If a checkbox is ticked, it indicates that chase events is activated for that event 
type.

Notes
This button only affects Note On and Note Off events in Regions played by instruments 
where the No Transpose box is not checked.

Sustained
Activation of this checkbox causes Logic to search (before the current playback start 
point) for any notes that should still be playing because of a sustain pedal message.

In ‘No Transpose’ Instruments
Activation of this checkbox ensures that all notes (including instruments with an active 
No Transpose parameter) are chased. If these are instruments for drum sounds or loops, 
as is typically the case, this box should not be checked.

Program Change
The most recent program change event (before the current playback start point) is 
sent.

Note:  Please keep in mind the time that your sound module may require to respond to 
an incoming program change event.

Pitch Bend
Pitch bend data is searched for.

Control Changes
If this switch is active, you can switch three groups of MIDI controllers (control change 
messages, such as modulation, volume, pan, and sustain) on and off individually:

0–15
Controller numbers 0 to 15 are chased. These include the following 
controllers:  modulation wheel, breath, foot, volume, pan, portamento time, balance, 
and expression, plus the MSB (most significant byte) for data entry and bank selection.
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64–71
“Switch” controllers 64 to 71 are chased. These include:  sustain, sostenuto, hold 2, soft 
pedal, and portamento.

All other
All other controller numbers are chased.

Aftertouch
(Channel) Aftertouch data is chased.

Polyphonic Aftertouch
Polyphonic Aftertouch data, generated by pressure sensors under the individual keys of 
the keyboard controller, is chased.

System Exclusive
The most recent SysEx message(s) in the Regions (before the current playback start 
point) are transmitted. If a Region contains pre-recorded SysEx fader data, the fader will 
be set to its correct state at the playback start point.

Note:  Chase events cannot always fully restore the correct state of SysEx data at the 
playback start point. To do so would involve not just searching for, but also analyzing 
all SysEx messages for the entire song, both before and after the playback start point. 
Given the non-standardized data structure of SysEx messages, this is completely 
impossible.

If even a couple of sound parameters have been recorded, each with separate SysEx 
faders of differing settings before the playback start point, there will be deviations in 
the sound. To circumvent this issue, try recording controller data for remote-control of 
the SysEx faders during playback. As chase events searches all controller numbers 
separately, any sound parameter SysEx settings (that have been substituted with 
controllers) will be correct at the playback start point. Another advantage to this 
method is that controller events can be edited graphically in the Hyper Editor, or by 
using Hyper Draw.

Chase separate channels in ‘All Channels’ instruments
This option affects multi instruments with the Channel parameter set to All. All defined 
event types in Regions that are started part-way through are chased separately for 
each MIDI sub-channel of the multi instrument.

Chase on Cycle Jump
Switches on the chase events function for cycle jumps (when a Cycle reaches its end 
point, and returns to the Cycle start point). Notes are only chased in a cycle jump when 
both the Notes checkbox and the Chase on Cycle Jump checkbox are activated.
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Send full MIDI Reset before Chasing
A full MIDI reset (for all ports and all MIDI channels) is sent before any event chasing 
begins.

Score Settings
All Score Song Settings are described in the Score Section  (see “Song Settings for Score 
Display” on page 410).

Preferences
The settings made in Logic’s Preferences panels are saved as a number of files in the $/
User/Library/Preferences folder. Keyboard shortcuts (key commands) are saved in a 
separate file in the same folder. Preference settings apply to all songs.

Note:  You can’t open the Preferences files directly. Any changes must be made in Logic.

Initializing the Preferences…
If you erase any of the Preference files, Logic will create new Preferences files the next 
time it is launched. All parameters will be reset to their default values. When you erase 
the Preferences files, you also lose all of your customized key commands. 

…and how to do it without losing your keyboard assignments 
If you’d like to initialize the Preferences, but don’t want to lose your customized key 
commands, select the Preferences > Initialize all except Commands menu item.

Global Preferences
Global Preferences: Song Handling
Hide Windows of inactive Songs
Only the windows of active songs are displayed. All other windows belonging to songs 
currently in memory are hidden. In this mode, you must use the main Windows menu 
to switch between songs.

When opening a song, ask to close current song(s)?
Whenever you load a new song before closing the old one, a dialog box will appear, 
and ask whether or not the current song should be closed. If this option is left 
unchecked, you will not be asked the question, and the current song will remain open.

Export MIDI File…’ saves single MIDI Regions as Format 0
If only one MIDI Region is selected when you make use of the File > Export MIDI File… 
function, the contents of the Region are saved in MIDI file format 0. This file format is 
guaranteed to be compatible with every MIDI file player.

Automatically open most recent song on startup
Activation of this option will automatically launch the song that you were working on 
when Logic was last closed.
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Auto Backup:
This pull-down menu switches on, and controls the automatic backup  (see “Saving 
Songs” on page 58) function. The menu options are self-explanatory.

Global Preferences: Editing
Right Mouse Button:
This pull-down menu determines the right mouse behavior. Options are:  
Is Assignable to a Tool, which allows any tool to be assigned to the right mouse button. 
The Opens Toolbox option does just that, when the right mouse button is clicked.

Limit Dragging to One Direction In: Matrix and Score
In the Matrix or Score Editors, you can only move notes in one direction (horizontally or 
vertically), per operation. This means that a note may be either transposed or moved in 
time, but not both at once. This prevents accidental alteration of one or the other 
parameter.

Limit Dragging to One Direction In: Arrange
This restricts the direction you can move Regions and folders in the Arrange window, in 
a similar way to, and for the same reasons, as the option above.

Double-clicking a MIDI Region opens:
This pull-down menu allows you to select which Editor opens when you double-click 
on a MIDI Region in the Arrange window. Options are the Score, Event, Matrix, and 
Hyper Editors.

Limit Multiple Undo Steps
Limits the number of Undo Steps (see “Undo” on page 32). Click on the arrows to 
increase or decrease the number of Undo steps.

Add ‘Last Edit Function’ to Region Name
After performing any edit operation (cutting, for example), the description of the edit 
operation is added to the name of the arrange Region (or resulting Regions).

Global Preferences: Cycle
Cycle Pre-Processing
In order to ensure a smooth cycle jump, the cycle jump is processed slightly before its 
actual position. This pull-down menu setting allows you to change the value of the pre-
processing time.
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Smooth Cycle Algorithm
This improves the timing of cycle jumps, making it easier to set the length of sample 
loops while in Cycle mode—although this is somewhat mitigated through the use of 
Apple Loops. If your computer has a very slow CPU, this setting reduces the processing 
performance for graphic operations. In general, you’ll want to keep this on, whenever 
possible, especially if you’re working in a style which involves frequent cycling of 
musical sections. If you find that your Cycled sections are not as smooth as you’d like 
them (and that your loops are actually perfect), you may wish to disable this parameter.

Global Preferences: Catch
Catch when sequencer starts
Every time you start the sequencer (start or pause), the Catch  (see “Relationships 
Between Windows” on page 28) function is automatically switched on, in all windows.

Catch when moving song position
Activation of this option ensures that whenever you move the SPL, the Catch function 
is automatically switched on.

Allow content Catch by position if Catch and Link are enabled
If the catch and content catch functions are active, the contents of the Region at the 
current song position are shown. If this option is inactive, the window view still follows 
the song position within the displayed Region, but does not update to show the 
contents of subsequent Regions as the SPL passes them in play or record mode.

Global Preferences: Caps Lock Keys
Enable Caps Lock Keys
A further Enable Caps Lock Keys option allows you to completely enable or disable the 
Caps Lock Keyboard functionality.

Space bar acts as Sustain Pedal
Should you wish to use the Space Bar key command (usually Start/Stop), rather than as 
the Sustain function for the Caps Lock Keyboard (when active), you can disable the 
Space bar acts as Sustain Pedal option.

Show window when active
After familiarizing yourself with the operation of the Caps Lock Keyboard for a while, 
you may wish to prevent the window from appearing when using it. To do so, disable 
the Show window when active option in the Preferences > Global > Caps Lock Keys 
menu.
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Audio Preferences
Audio Preferences: General
Create Overview after recording
To allow you to view new recordings of audio files in the Arrange window, Logic has to 
create an overview. Before it can do this, the whole audio file has to be read, which can 
be time-consuming, depending on the amount of data involved. If you want to 
continue working in the Arrange window without the waveform display, you can 
switch off the creation of the overview after the recording. If necessary, the menu 
option “Update File Information” in the Audio window will recognize that the overview 
is missing, and create it later.

Audio engine overload message
If switched off, the playback will simply stop in an overload situation instead of 
displaying an alert box.

Sample accurate automation
As the name implies Sample accurate automation is the most precise type of 
automation. However, it requires more overall system performance. Therefore Logic 
offers three options:
• Off:  needs less system performance and might be required for older songs (pre 

version 5 songs);
• Volume, Pan, Sends:  the most important parameters are automated with sample 

accuracy;
• Volume, Pan, Sends, Plug In Parameters:  all of these parameters are automated with 

sample accuracy. Please note:  not all Audio Unit plug-ins can be automated in this 
way.

Recording File Type
Lets you the determine the file type of recorded audio files. The options are:
• SDII = SoundDesigner II
• AIFF = Audio Interchange File Format (Default)
• WAVE = Most common Audio Format on Windows PCs

Crossfade Time
Determines a global crossfade time for all crossfade operations in the Arrange window.

Crossfade Curve
Determines a global crossfade curve type for all crossfade operations in the Arrange 
window.

Audio Preferences: Drivers
The Audio Driver preferences are covered in the Audio Driver chapter  (see “Audio 
Drivers” on page 271).
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Audio Preferences: Display
Display Color in Audio Window
If audio regions in the Arrange window are very brightly colored, it can sometimes be 
difficult to make out the waveform display in the Audio window. You can, therefore 
revert to a black and white display here.

New Style Audio Objects
This setting toggles the look of the Audio Objects between the old and new (since V 
3.0) style.

Open Plug-in window on insertion
With this setting on, the window of a plug-in or a virtual instrument is automatically 
opened after inserting it in the corresponding slot of an Audio Object.

Audio Preferences: Sample Editor
Warning before process function by key command
Before you carry out a destructive edit in the Sample Editor using a key command, a 
warning appears—giving you the opportunity to cancel it, before altering the data.

Dependent on the key commands and window combinations you are using, there is a 
danger of executing edit commands accidentally. To avert any disasters, Logic is preset 
so that an alert box appears before a destructive audio edit is carried out. If you feel 
confident that you won’t accidentally process a file, you can switch off the alert here.

Record “Normalize” in Undo History
Disable this parameter if you do not wish to create any undo files once the Normalize 
function is invoked. 

Note:  As normalization is generally the last step in sample editing, this parameter (if 
active) can destroy the undo history. As a safety feature, a warning will be shown if an 
undo history exists (and the switch is on), providing you with the opportunity to create 
an undo file.

Number of Undo Steps
This parameter limits the maximum number of recorded undo steps. Use the mouse as 
a slider to adjust the (number of ) step(s) value.

Store undo files in Song Folder
Activate this parameter if you would like the Undo History to be stored in a sub-folder 
alongside the song.

Note:  This is switched on by default if the song is part of a project (see “Projects” on 
page 51).

Global undo file path
All Undo History files are saved into a “global” location (a user-defined folder) if the 
Store undo files in Song Folder option is not switched on.
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Audio Preferences: MP3
Bit Rate (Mono/Stereo)
The bit rates are selectable between 8 kbps and 320 kbps, but default to 80 kbps mono, 
and 160 kbps stereo. These rates offer acceptable quality and good file compression. If 
you can afford the extra file size, we recommend selecting 96 kbps for mono and 
192 kbps for stereo streams for better audio quality. You can, of course, choose even 
higher rates, but the quality improvement in bit rates above 96/192 kbps is minimal.

Use Variable Bit Rate Encoding (VBR)
Variable Bit Rate encoding compresses simpler passages more heavily than more 
harmonically rich passages, generally resulting in better quality MP3s. Unfortunately, 
not all MP3 players can accurately decode VBR-encoded MP3s, which is why this option 
is off by default. If you determine that the listener/s of your MP3 can decode VBR-
encoded MP3s, you can switch this option on.

Quality
Keep this set to Highest whenever possible. Reducing the quality will speed up the 
conversion process, but at the expense of audio quality.

Use Best Encoding
Again, like the Quality parameter, if you uncheck this option, you will gain encoding 
speed at the price of audio quality. This should always be kept on unless conversion 
time is an issue.

Filter Frequencies Below 10 Hz
When this option is checked, frequencies below 10 Hz (which are usually not 
reproduced by speakers, and are not audible to human ears at any rate) will be 
removed, leaving slightly more data bandwidth for the frequencies which we can hear, 
resulting in an improvement in perceived quality. Only uncheck this if you’re 
experimenting with subsonic test tones, or exporting MP3s for whales…

Stereo Mode
You can select joint stereo or normal stereo mode. Depending on the original file, these 
settings may (or may not) offer any audible difference. Experiment with both settings 
to determine your preference.

Audio Preferences: Reset
Send Reset Messages to Audio Instruments:
Reset messages of the specified type (Control 64 off (Sustain), Control 1 (Modulation) to 
zero and Pitch Bend to center position) are sent to all active Audio Instrument channels 
for each of the checkboxes. This may be useful if you are encountering hung notes, or 
are finding that controller settings are incorrect when in Cycle mode or when returning 
to the beginning of a section or the Song start point.
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MIDI Preferences
This page handles Logic’s communication with your MIDI interface and other programs. 
All active CoreMIDI Drivers are automatically available in Logic. There is no need for 
further settings. 

MIDI Preferences: General
Use UME (Unified Virtual and Classic MIDI Engine)
The Unified Virtual and Classic MIDI Engine unifies the Classic MIDI Engine (used for 
hardware MIDI devices) with the use of Virtual MIDI Instruments (software instruments). 
This engine is switched on by default, which is the recommended setting. For 
compatibility reasons, it can still be switched off, and an alternate MIDI engine will be 
used. 

Note:  Not all Arrange features are available for software instrument use (the Loop 
parameter, for example) when this setting is switched off, so leave it on, unless you’re 
having problems.

External Stop ends Record Mode
If you are using external synchronization, and the time code stops during the 
recording, record mode is switched off. If there is no check in this box Logic stops, but 
remains in record mode (record + pause).

Always stop when opening song
With this setting on, a song will always be opened in Stop mode, even if it was saved in 
Play mode.

Reset All MIDI Drivers
The Reset All MIDI Drivers button resets all MIDI drivers. This may help should you 
experience MIDI communication problems.

MIDI Preferences: Sync
All MIDI Output: Delay:
This slider delays or advances the MIDI Output for all ports, allowing you to 
compensate for any timing differences between Audio and Audio Instrument tracks, 
and MIDI tracks. Simply drag the slider to the left or right to set the desired (positive or 
negative) millisecond value. Alternately, you can type the desired value into the ms 
field.

MIDI Clock: Allow Song Position Pointer while playing
Song Position Pointer data is not normally sent while the sequencer is in play mode 
(this is in accordance with the MIDI Standard). This option allows Logic to send SPP 
while the sequencer is running. The advantage is that external devices can also follow 
Logic in Cycle mode. If your external devices cannot process SPP, you should switch off 
this option.
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Note:  If your devices can follow MTC (MIDI Time Code), you should leave this option 
unchecked, and make use of Logic’s MTC functions.

MIDI Time Code (MTC): Pickup Delay
This parameter should generally be set to zero to ensure the quickest possible pickup 
time while Logic is in MTC sync mode. There are, however, some devices which seem to 
transmit imprecise MTC commands when first started. As a result, sync might not be 
perfectly reliable, and there could be an offset every time synchronization is 
established. In such situations, you can set a delay for MTC pickup, and Logic will ignore 
the initial MTC commands. A (frame) value of 25 to 30 corresponds to a delay of about 
a second, depending on the frame rate. Use this parameter when synchronized to hard 
disk recorders and other devices, if the sync doesn’t appear to be consistent.

MIDI Time Code (MTC): Transmit MTC Delay
This parameter allows you to delay the transmission of MIDI Time Code. Negative 
values result in MTC being transmitted earlier. This facility enables you to compensate 
for any reaction delays (to incoming MIDI Time Code) in external MTC slaves.

MIDI Sync Song Settings
Pressing this button will launch the MIDI Sync Song Settings window.

MIDI Preferences: Reset Messages
This page is only left for compatibility reasons with older MIDI hardware. Logic handles 
MIDI Reset Messages automatically and intelligently, so you should generally make sure 
that all options are switched off (this the default).
All selected checkboxes will send a reset message for the selected controller type to all 
MIDI outputs. This reset message will be sent on Cycle jumps and when playback 
begins, but the use of these options shouldn’t be necessary. 
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Display Preferences
These parameters alter the general appearance of Logic. Before we take a look at them, 
we’d like to cover a global setting. Namely changing the:

Interface Language
Logic features a Mac OS X compliant method to set the dialog language:

To set Logic’s interface language:
1 Select the Logic application in the Finder.

2 Press Command-I (to open the Information dialog).

3 Select/Flip open the “Languages” section.

4 Choose the preferred language, and uncheck all other languages.

Display Preferences: General
Windows: Anti-aliased text
Displays all Logic text strings in the Mac OS X Anti-aliased mode.

Windows: Large local window menus
The title and items of the local menus are displayed using the normal System font. If 
the is not checked, a smaller font is used instead.

Windows: Wide song position line
A thicker Song Position Line is used.

Windows: Show Help Tags
This enables help tags throughout Logic. As the mouse cursor hovers over parameters 
and tools, a small pop-up description (or value) of the item will momentarily appear 
onscreen.

Menus: Use hierarchical pull-down menus
Hierarchical pull-down menus are used in the Arrange window Track List and elsewhere 
in Logic.

Menus: Sort Instrument menu by layers
The instruments in the pull-down instrument selection menu are sorted by 
(Environment) layers.

Displays: Display Middle C as:
This pull-down menu option affects the description of notes in the editors. The bottom 
C on a five-octave keyboard (note # 36) is labeled C1, and middle C (#60 or c’) is labeled 
C3. According to this standard, the lowest MIDI note (# 0) is called C-2. This is the 
official standard, and is used by most manufacturers. Use of the C3 (Yamaha) option 
will set Logic to this “standard” mode.

Should you select the C4 (Roland) option, the bottom C on a five-octave keyboard is 
labeled C2, and middle C is labeled as C4. In this standard, the lowest MIDI note is C1.
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Display Preferences: Other
Environment: Allow ‘All Objects’ layer option
A layer, showing every Object in your Environment, is accessible from the Layer menu 
in the Environment. If this checkbox is not selected, the “All Objects” layer will not be 
available.

Matrix Background Colors: Background Type
These radio buttons allow you to select a Dark or Light Matrix editor background color. 
By default, a Light color scheme is selected.

Matrix Background Colors: Matrix Color Setup Panel
The Matrix Editor (see “Display” on page 324) features a grid that follows the pattern of 
the keyboard keys shown on the left hand side. The colors of the Matrix window grid, 
background, lines, and so on can be adjusted for both the “Light” and “Dark” 
Background views with the parameters in this recessed panel.
• White Keys:  Double-click on the color swatch to launch the Mac OS X Colors applet. 

Select or determine the desired color for the grid lines aligned with the white 
keyboard keys.

• Black Keys:  As above, for the black keyboard keys.
• C, D, E Key Brightness:  This slider allows you to intensify the brightness of these 

specific keys in all octaves, making transposition easier by providing a consistent 
reference point.

• Bar Lines/Dotted:  As with the White and Black Keys options, you can select a color for 
the bar lines. The Dotted checkbox will change the appearance of the solid bar line 
to a dotted line.

• Beat Lines/Dotted:  As above for beat lines.
• Division Lines/Dotted:  As above for division lines.
• Reset:  This button resets all user changes to default values.

Score Preferences
The Score Preferences are described in detail in the Score chapter (see “Score 
Preferences” on page 423).

Video Preferences
Adjustments: Video to Song
A global setting for fine tuning the start point of a movie.

Video Song Settings
This button launches the Video Song Settings window.
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Automation Preferences
The Automation preferences globally affect all Automation tracks.

Move Automation with Regions:
This pull-down menu allows you to select what happens to Track Automation data 
when you move Regions. You can choose between Never, Always, and Ask, which should 
be self-explanatory. Ask is the default setting.

Ramp Time:
The time required by a parameter to return to its previously recorded setting, is 
selected via this panel. Double-click on the value to enter a new number (in 
milliseconds).

‘Write’ Mode Changes To:
This pull-down menu option determines the mode that faders automatically change to 
once the recording of Track Automation data was completed. Options are:  Off, Read, 
Touch, Latch, and Write.

Touch/Latch/Write Erase:
The checkboxes in this section determine the types of Track Automation data that can 
be written in Touch, Latch, and Write Erase modes.

Automation Quick Access:
These parameters are discussed in detail in the Automation Quick Access section (see 
“Automation Quick Access” on page 232).

Control Surfaces Preferences
The Control Surface preferences are discussed in the Control Surfaces chapter (see 
“Control Surface Preferences” on page 495).
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21 Control Surface Support
Logic offers dedicated support for several surfaces plus 
the option to program unsupported devices. Control 
surfaces are hardware units that enable the operation of 
Logic using faders, rotary knobs, switches, and displays.

There are a number of simple control surfaces that feature conventional faders and no 
displays. More progressive units are equipped with motor faders, rotary encoders, LED 
rings, and programmable displays. The more feedback a control surface provides, the 
easier it is to use, as you don’t need to watch the computer screen in order to 
determine what mode the unit is currently in.

Although we recommend the Emagic Logic Control and Logic Control XT, other control 
surfaces are supported as well.

Logic supports many functions of modern control surfaces. Its modular concept and 
learning mode allows the addition of support for new control surfaces, or 
enhancements to existing support. The extensible control surface plug-in architecture 
allows the full use of all possibilities of a given controller, down to the finest details.

The following chapter describes functions applicable to all control surface models. 
Specific documentation for various models is available in individual PDF files.
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Installation
Control Surface Plug-ins
Dedicated control surface support is achieved through the use of special plug-in files. 
These files are automatically added when Logic is installed.

They are located in the Contents > MIDI Device Plug-ins sub-folder of the Logic 
application bundle (to view the bundle contents, Control or right-click on the Logic 
application icon, and choose Show Package Contents from the menu). Logic also checks 
for control surface plug-ins in the (optional) “/Library/Application Support/Logic/MIDI 
Device Plug-ins” and “~/Library/Application Support/Logic/MIDI Device Plug-ins” (the 
“~” denotes your user home directory) folders.

When new control surface plug-ins are released independently from a Logic update, 
please place them in the folders described above (or as advised in the documentation 
supplied with the plug-in).

The Setup Window
Some control surface units (Logic Control, for example) are automatically detected 
when Logic is launched. Units which are not detected automatically can be added via 
the Setup window. This is accessed via the Setup option in the Preferences > Control 
Surfaces menu.

Installation is very easy:  all you need to do is select the devices that you wish to use in 
Logic, in the following ways:

1 Select New > Install, and in the ensuing Install window, select the desired device from 
the list.

2 Press the Scan (or Add) button. The selected units will appear onscreen.

• Optionally, you can also click Scan all. This will search for all supported control 
surface unitson all MIDI ports. Please be aware that this may take a while.

• The Scan function, Setup window and Install window can all be accessed directly in 
the Preferences > Control Surfaces menu.

Rebuild Defaults
The Preferences > Control Surfaces > Rebuild Defaults option re initializes the support of 
all connected control surfaces.
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The Install Window
The Install window is used to automatically scan for devices, or to install them 
manually.

Selecting the Models
First, select the desired devices in the Install window before you scan or manually add 
them. You may select one or more models. If you select more than one model, Logic 
performs the desired operation for each model in turn. Logic displays the icon of the 
selected device beneath the buttons.
• To select just one model, select it by clicking on the name.
• To select more than one model, select them with Shift held down.

Scanning
Click the Scan button to start the process. You can also press Enter or double-click the 
device name. Logic will then analyze your MIDI system, and will automatically install 
the devices it finds, including the correct connection settings.

This option is preferable to manual installation, as Logic is able to gather the maximum 
amount of information about the devices.

Scan All
If you don’t want to select the models to be scanned manually, simply click this button. 
Logic will then scan for all supported models. This can take some time.

The Scan All function is also directly available via Preferences > Control Surfaces > Scan. 
This will automatically scan all MIDI ports for all supported control surfaces.

Manually Adding Devices
Some control surfaces don’t support automatic scanning. Such devices must be added 
manually to your setup. In this scenario, you will need to manually set the MIDI In and 
Out port parameters.

To manually add the selected devices to your system:
• click the Add button,
• or Option–double-click on one of them.

If a control surface of the selected type already exists in your setup, you will be asked 
whether or not you really want to add the new device. You will need to manually alter 
the MIDI In and Out port values in the device parameters to match those of the 
connected unit.

Done
Once you have completed the scanning or installation of the devices, click Done. The 
window will close.
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Setup Window Parameters

Device Parameters
Each control surface unit must be connected to an independent MIDI In and Out port. 
The automatic setup or Scan procedure should have automatically found, and set, the 
correct MIDI In/Out port settings for each unit.

In the event that the MIDI In or Out port identification is incorrect, you can manually 
select the appropriate one for the unit. To do so, click-hold on the MIDI Input and 
Output pull-down menus, and select the appropriate port(s) of your MIDI interface.

Some devices allow you to define a device ID (or global/basic channel). This can be set 
in this area. Module name, model name and firmware version are also displayed in the 
device parameters.

Special Parameters
Some control surfaces may allow the definition of “special” parameters. An example of 
this is fader touch sensitivity. Such parameters can be found in the Special Parameters 
area. A detailed description can be found in the documentation of the particular 
control surface plug-in. 

Display Parameters
Flip Mode
Many control surfaces offer both a fader and a rotary encoder for each channel strip. 
Flip Mode allows you to swap the encoder assignment with that of the fader for each 
channel. Alternately, you can assign both controls to the same parameter.

There are four “flip” or “swap” modes.
• Off—disables Flip Mode, making the fader act as a volume control.
• Duplicate—makes both the fader and encoder active for the currently selected 

encoder parameter.
• Swap—swaps the fader and encoder, making the fader a Pan control and the 

encoder a channel volume control, for example.
• Mute—disables the faders. This is useful for situations where recording is taking place 

in the same room as the control surface, and you wish to avoid the mechanical noise 
of the faders. Any existing automation data will still function as per normal.

Display Mode
If there is insufficient space available for the display of both the parameter name and 
value (on the control surface LCD), you can specify what is displayed here:
• Value—displays the parameter value
• Name—displays the parameter name

Clock Display
• Beats—the song position display shows Bars/Beats/(optional) Sub Division/Ticks
• SMPTE—As above, but in Hours/Minutes/Seconds/Frames
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Note:  The exact elements displayed, and thus their positions, depend on the selected 
SMPTE or bar/beat display option defined in Logic’s Preferences.

Track View Mode
This parameter determines which tracks or channels are displayed:
• Mixer—displays channels in their order of appearance in the Track Mixer window 

(while Global mode is disabled). Instruments/channels used by multiple tracks are 
merged into one channel.

• Global—displays all Objects of certain type(s)—MIDI or Bus channels, for example—
independently of their usage by tracks. They merely need to be defined as an 
Environment Object. The Object types to be displayed are defined by another 
parameter which is not shown in the parameter list. If a control surface supports 
switching to Global View, it also allows you to define which Objects to display.

• Arrange—displays channels in their order of appearance in the Track List of the 
Arrange window, including multiple tracks using the same instrument or channel. 
The Hide button status is taken into account, with tracks hidden in the Arrange 
window also being hidden on the control surface.

Mixer View Fader Bank
This parameter affects the Mixer and Arrange View mode by shifting channels by the 
defined amount. Imagine that your control surface has eight channel strips, and you 
were looking at audio tracks 1–8 in the Arrange window. These would appear as 
channels 1–8 on the control surface. Using the Mixer View Fader Bank parameter, you 
could offset this view by a defined number of channels, looking at audio tracks 3–11, 
for example.

Global View Fader Bank
The Global View Fader Bank parameter does the same thing as the Mixer View Fader 
Bank, but only applies if multiple Object types are enabled. When single Object types 
are enabled, there are separate fader bank parameters (these aren’t displayed in the 
parameter list).

Track/Channel Parameters
Track Parameters
Defines the current Track Assignment behavior for the encoders. Options are:
• Volume—adjusts channel volume.
• Pan—adjusts channel panorama.
• Mode—adjusts/selects channel mode (mono/stereo).
• Input—adjusts/selects channel input source.
• Output—adjusts/selects channel output (main outs/busses).
• Automation—adjusts/selects channel automation mode.
• Displayed parameter—adjusts the automation parameter displayed in the Arrange 

window. This is especially useful if you set the control surface to Arrange View mode, 
and your Arrange window shows multiple sub-tracks with various parameters.
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EQ Band
EQ Band allows you to select the current band in the EQ Multi Channel View. 

EQ Parameter
Related to the selected band, defined by the EQ Band parameter. This determines the 
current EQ Assignment behavior for the encoders in EQ Multi Channel View:
• Frequency—Determines the frequency of the selected band.
• Gain—Changes the gain of the selected EQ band. For the Low Cut and High Cut 

bands of the Channel EQ, this parameter controls the slope.
• Q—Changes the Q factor of the selected band.
• On/Off—Bypasses the selected EQ band.

EQ Parameter Page
Defines the first EQ parameter displayed in the EQ Channel Strip View. This parameter is 
required if the Control Surface Group displays fewer than 64 parameters 
simultaneously.

Send/Plug-in Parameters
Send Slot
Determines the currently selected Send slot. Normally, a value of 1 would be used, as 
this accesses the first (top) Send on each channel. A value of 2 accesses the second 
Send, and so on, up to the eighth Send. The Send slots are accessed by pressing the 
Up/Down buttons.

Send Parameter
Defines the currently displayed encoder Send parameter when in the Send Multi 
Channel view:
• Destination:  encoder is used to determine the Bus channel number for the Send slot.
• Level:  encoder is used to adjust the Send level.
• Position:  Sets Pre and Post fader modes.
• Mute:  Mutes/Unmutes the selected Send slot.

Send Parameter Page
Much like the EQ parameters, up to 32 parameters are available in Send Channel Strip 
View on a given channel (8 Send slots multiplied by the four parameters listed above). 
Send Parameter Page determines the current page for these parameters.

Split: no. of upper parameters
Control surfaces that support split mode allow the display of two separate parameter 
sections within one plug-in (or even different plug-ins). They are called Split Upper and 
Split Lower.

This parameter defines how many encoders belong to Split Upper, leaving the 
remaining encoders to Split Lower. A value of 0 means that Split Mode is off—all 
encoders then belong to the Split Upper area.
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Instrument Parameter Page
Determines the parameter index (counted from 1) which is assigned to the left-most 
encoder when editing a software instrument. The next Instrument parameter is 
assigned to encoder #2, and so on.

With Split Mode enabled, this applies to Split Upper.

Inst Parameter Page (Split Lower)
As with Instrument Parameter Page, but for Split Lower.

Insert Slot
Determines the current insert slot number for both selecting a plug-in (in plug-in 
Channel Strip View) and editing its parameters. A value of 1 accesses the first (top) plug-
in slot on each channel. A value of 2 accesses the second plug-in slot, and so on.

With Split Mode enabled, this applies to Split Upper.

Insert Slot (Split Lower)
As with Insert Slot, but for Split Lower.

Plug-in Parameter Page
As with Instrument Parameter Page, but for editing plug-ins. Having these parameters 
separate allows you to quickly switch between editing an instrument and a plug-in on 
a track, without the need to adjust the parameter page every time.

With Split Mode enabled, this applies to Split Upper.

Plug-in Parameter Page (Split Lower)
As with Plug-in Parameter Page, but for Split Lower.

Track
Specifies the currently displayed track for Channel Strip Views.

With Split Mode enabled, this applies to Split Upper.

Track (Split Lower)
As with Track, but for Split Lower.

Track Lock
When this parameter is set to “on”, selecting a track in Logic does not change the Track 
and Track (Split Lower) parameters. In other words, the control surface group continues 
to display the same track, independent from the currently selected track.

When Track Lock is disabled, the control surface group automatically switches to the 
selected track, whenever a track is selected.
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Other Parameters
Track Name Format
Changes the track name display to show the track name alone, or the track name, and 
it’s track number. As an example, a track named “Audio1” may actually be placed on 
track 12 in the Arrange window. When a value of #:Name is toggled, “Audio1” would be 
displayed as “12:Au1”. 

Parameter Page Shift Mode
Defines whether the parameter is shifted by an entire “page” or by one parameter.

Relative Change Mode
This determines the behavior of assignments with a relative value change mode (e.g. 
rotary encoders).
• Coarse:  the parameter can be adjusted in coarse steps.
• Full:  the parameter value is set to its minimum if delta < 0. If greater than 0, it is set 

to the maximum. This way, you can jump to the last or first track instead of the next 
or previous bank.

• Fine:  the value is incremented/decremented in fine steps—one tick/by one “unit”. In 
this mode, the adjustable resolution is ignored, and the highest possible resolution is 
used instead. As an example, using the Sample Delay parameter:  every encoder 
rotation tick in/decreases the value by 1 ms, no matter what the value of the 
resolution.

Coarse is the mode used by default.

Mix Group
When in Group Edit mode, this parameter defines the edited group.

Group Parameter Page
As with Instrument Parameter Page, but for the parameters of the edited group.
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Control Surface Preferences
The Control Surface preferences window is accessible via the Logic Menu > Preferences > 
Control Surfaces > Preferences menu.

General
Resolution of Relative Controls
This defines the default resolution of controls that change values in a relative manner. 
The default is 128 steps. 

As an example:  adjusting the Sample Delay (value range 0 to 4000 ms) in/decreases 
the value by 40 ms with every encoder rotation “tick”, if resolution is set to 100.

Maximum MIDI Band Width
This slider determines the maximum amount of MIDI bandwidth that can be used by 
your control surface. By default, this is set to 50%, which should be suitable for most 
situations. You can adjust the value if you find that your MIDI or Automation playback is 
being affected.

Touching fader selects track
Activation of this parameter will automatically select the track that corresponds to the 
selected fader. You require a device that features touch-sensitive faders for this 
functionality to work.

Jog resolution depends on horizontal zoom
If your control surface features a jog/shuttle wheel (or similar), the precision of any 
scrubbing is affected by the horizontal zoom level of Logic. To retain a consistent 
resolution, regardless of Logic window zoom levels, disable this checkbox.

Pickup Mode
Enable this option to activate Pickup Mode. Pickup Mode is used by Controller 
Assignments that use a scaled value mode and have either; no feedback or local 
feedback (when the user operates the control, feedback occurs locally due to the 
control’s mechanical nature). In Pickup Mode the current value must be reached 
(“picked up”) by the control before a value change can occur. This link is broken (Pickup 
Mode is non-functional) whenever the parameter changes its value by playing back 
existing automation data. In this mode, move the control towards the parameter’s 
current value (which is then “picked up”) if you want to change the parameter with the 
control. When the Pickup Mode option is disabled, adjusting a fader modifies the 
parameter immediately.
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Multiple Controls per Parameter
These parameters determine whether one, or multiple, encoders are used per 
parameter when editing effect plug-ins or software instruments. 

When multiple encoders are used per parameter, the encoders are subdivided into 
groups (for example 1/2, 3/4, 5/6, 7/8). The first encoder of each sub-division controls 
the parameter shown in the display. The remaining encoder(s) are inactive. 

Using more than one encoder per parameter shows fewer parameters at any given 
time, but you gain space on the LCD to cater for longer parameter names and values. 
The more control surfaces you have within a Control Surface Group, the more you 
benefit from this feature. 

The Multiple controls per parameter pull-down menu defines the maximum number of 
encoders which will be used for a single parameter.
• 1:  parameters are always displayed using one encoder per parameter, with the least 

space available for parameter name and value in the LCD.
• 2:  on each unit, encoders 1 and 2 are used for the first parameter, encoders 3 and 4 

for the second, and so on.
• 4:  on each unit, encoders 1 to 4 are used for the first parameter, encoders 5 to 8 for 

the second, and so on
• 8:  on each unit, encoders 1 to 8 are used for the first parameter, and so on.

The default setting is “2”.

Only when all Parameters fit in one Page
When this option is checked, the defined number of encoders are only used when 
there are sufficient encoders available to show all parameters without changing pages. 
As an example:
• You have a Logic Control and two Logic Control XTs, providing you with 24 encoders.
• A plug-in with 13 parameters will be shown with one encoder per parameter. Eleven 

encoders will remain unused.
• A plug-in with 11 parameters will be shown with two encoders per parameter. Two 

encoders will remain unused (and of course the inactive encoders of the above 
mentioned sub-divisions).

When the option is unchecked, multiple encoders are used for each parameter, which 
may require scrolling. This would not be the case if only one encoder was used for each 
parameter.

Show Value Units For:
Allows you to adjust whether parameter values will be appended by the measurement 
“unit”, where applicable—“Hz” or “%”, for example. You can set this option separately for 
Instrument/Plug-in parameters and Volume and other parameters. If you can do without 
the value units, the display is less cluttered.
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Controller Assignments
The Controller Assignments button launches the Controller Assignments Editor.

Setup
The Setup button launches the Control Surfaces Setup window.

Help Tags
Control Surfaces that have freely programmable displays which cover multiple controls 
in one row, can use Control Surfaces help tags. These help tags are similar to Logic’s 
help tags, showing additional information during operation. You can define the 
information that is displayed in the help tags pane of the Control Surfaces preferences.

While Editing Show Long Names For:
• Parameter Name—While editing a parameter, the upper LCD line displays the full 

parameter name, rather than an abbreviated form of it.
• Parameter Value—While editing a parameter, the lower LCD line displays the full 

parameter value. If the Show value unit for Parameter box (see below) is checked, it 
will be appended by the measurement unit, where applicable—“dB”, “Hz” or “%”.

Note:  The following options only have an effect if at least one of the two parameters 
above is active.

Display duration (s)
Use the mouse to adjust the time that parameter names and values remain on the LCD 
display, following selection/adjustments.

Allow multiple info
This determines the behavior when you edit multiple parameters simultaneously. When 
enabled:  the long name info remains in the display, until the most recently edited 
parameter’s display times out. This may cause overlapping text. When disabled:  the 
long name display is only shown for the most recently edited parameter. This can cause 
flicker.

Show info when selecting tracks
When this option is checked, and you select a track, you will see “Selected” in the upper 
row, and the selected track’s name in the lower row of the LCD. You can disable this 
feature, if you find it disconcerting.

Show info when editing volume
When this option is checked, and you edit a track’s volume, you will see “Volume” in the 
upper row and the new volume value in the lower row. You can disable this feature, if 
you find it disconcerting.
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Show Value Units For:
Allows you to adjust whether parameter values will be appended by the measurement 
“unit”, where applicable—“Hz” or “%”, for example. You can set this option separately for 
Instrument/Plug-in parameters and Volume and other parameters. If you can do without 
the value units, the display is less cluttered.

Note:  This parameter only applies while editing.

Customizing Control Surfaces
Logic allows you to program new assignments for unsupported control surfaces. This 
facility allows you to extend the use of faders, knobs, and switches, either directly or 
through the use of modifier commands. 

To assign a MIDI control to a parameter:
1 Click the destination parameter that you want to “teach” Logic.

2 Activate Learn by pressing Command-L (default), or via the Logic > Preferences > Control 
Surfaces > Learn Assignment for “xxx” menu option (the parameter name is appended to 
the menu item text).

3 The Controller Assignments window is opened, with the Learn Mode button enabled.

4 A help tag will indicate what needs to be done next (move control, for example).

5 After the first message has been received, you can assign another MIDI control by 
simply clicking the desired parameter and operating the desired MIDI control. This 
allows you to learn multiple assignments in one go.

Note:  If no MIDI messages are received, releasing the Command (modifier) key(s) leaves 
the Learn Mode button enabled, allowing you to immediately retry the generation of 
the intended control message. You will need to disable the Learn Mode button 
manually, once the procedure is completed. 

To abort the learn procedure:
m Either press Command-L a second time, or click the Learn Mode button. You can re-

enable the Learn Mode button to assign a message.

To delete a MIDI control assignment:
1 Click the destination parameter that you would like to delete.

2 Select Edit > Clear from the main menu bar. 

To assign a control surface button to a key command:
1 Select the desired key command in the Key Commands window.

2 Click the Learn New Assignment button.

3 Press a control surface button that sends a MIDI message.
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Note:  After about 5 ms, the Learn New Assignment button is automatically deactivated 
to prevent recording of a button release message. 

It is also possible to assign a key command to a button/key release message:
1 Press and hold the desired button/key before you enable the Learn New Assignment 

button. 

2 When you release the button/key, the selected key command is assigned to the button 
release message. 

To delete a key command assignment:
1 Select the desired key command in the Key Commands window.

2 Press the Backspace key. 

Shortcuts for Defining Multiple Assignments
If you would like to make multiple assignments for a number of consecutive 
parameters, Logic offers you a shortcut. You can assign the first parameter and the last 
parameter of a row to two controllers. Provided that the controller number distance is 
the same as the parameter distance, Logic will offer you, to assign the parameters in 
between to the corresponding controllers automatically. 

Example 1: assign faders 1 to 16 to volume of tracks 1 to 16
1 Learn volume track 1 for fader 1.

2 Learn volume track 16 for fader 16.

3 As the track “distance” (15) is the same as the controller number distance for the two 
most recently learned assignments, the following message appears:  “It seems you have 
just defined two assignments for the first and last of a consecutive row of parameters. 
Would you like to fill up in between?” Select OK to automatically fill the faders with 
corresponding Volume assignments for each track.

Note:  This feature also works for any other track parameter (Pan, Solo, Mute, and so on).

Example 2: assign knobs 1 to 16 to plug-in parameters 1 to 16
1 Learn parameter 1 for knob 1.

2 Learn parameter 16 for knob 16.

3 As the gap between parameter numbers (15) is the same as the gap between controller 
numbers for the two most recently learned assignments, the following message 
appears:  “It seems you have just defined two assignments for the first and last of a 
consecutive row of parameters. Would you like to fill up in between?” Select OK to 
automatically fill the knobs with corresponding Parameter assignments for each.

Note:  This feature also works for instrument parameters. Currently, this only works for 
knobs that send a single channel message, where the first data byte is the controller 
number and the second data byte is the value. Alternatively, the controller number can 
be encoded in the MIDI channel, with a fixed first data byte. 
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The Controller Assignments Window
The Controller Assignments window is opened via the Logic > Preferences > Control 
Surfaces > Controller Assignments menu item.

It allows you to edit all assignments of the Controller Assignments table. This table is a 
part of the Control Surfaces Preferences and is stored (along with all other control 
surface support settings) in the ~/Library/Preferences/com.apple.Logic.express.cs file.

The Controller Assignments window offers the following parameters:  
• Track (default):  This field can be used to specify the track parameter you would like 

to assign. You can choose between the option Selected (which is the default, if 
creating assignments on the selected track) or a fixed track number (if you want to 
set up your controls as a mixer surface). 

• Parameter:  Displays clear text of the addressed parameter.
• Input message:  Displays the incoming message data. 

Only the parameters of one assignment are visible. You can choose the desired 
assignment with the left/right arrows at the bottom of the window. If you activate the 
Follow option at the top of the Controller Assignments window, the window always 
selects the assignment that matches the most recently received incoming MIDI 
message.
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Glossary
amplifier  Device which controls the level of a signal.

amplitude  This term is used to describe the amount of a signal. If you have an audio 
signal, amplitude refers to the sound’s volume, measured in decibels (dB).

analog signal  A description of data that consists of a constantly varying voltage level, 
that represents audio information. Analog signals must be digitized, or captured, for 
use in Logic. Compare with digital.

Arrange window  The heart of Logic. The primary working window of the program 
where Audio and MIDI Regions are edited and moved to create a song arrangement.

attenuate  To lower an audio signal’s level.

audio file  Any digital recording of sound, stored on your hard drive. You can store 
audio files in the AIFF, WAV, and Sound Designer II formats.

Audio Instrument  Logic supports the use of software based instruments. Software 
instrument plug-ins are inserted into Audio Instrument Objects. Software instrument 
recording takes place on Audio Instrument tracks in the Arrange window. Playback of 
these tracks is routed via the Audio Instrument Object.

audio interface  Device needed to get sound into and out of your computer. An audio 
interface converts digital audio from your computer to analog waves that speakers can 
broadcast, or, in the other direction, an audio interface converts analog waves into 
digital audio your computer can work with.

Audio Mixer  An Environment layer that shows all Audio Objects of a song. The Audio 
Mixer is used for mixing multiple audio channels in real time. The Audio Mixer is also 
known as Environment Mixer.

Audio Object  Audio Objects are found in Logic’s Environment. They are the “building 
blocks” of the Audio Mixer. When expanded, Audio Objects look just like channel strips. 
Audio Objects tell Logic where to send audio signals. The following Audio Object types 
are available:  Audio Track Object, Input Object, Audio Instrument Object, Bus Object, 
Output Object, Master Object, Aux Object.
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Audio Region  Chosen area of an audio file which is registered in the Audio window for 
use in the song and, can be placed on audio tracks in the Arrange window, just like a 
MIDI Region can be placed on MIDI tracks. Audio Regions are aliases (or pointers) to 
portions of audio files. They can be as short as a single sample, or as long as the audio 
file itself. You can use all of Logic’s tools to edit Audio Regions. Editing is non 
destructive on the original audio file, as the Region is only an alias of the audio file. See 
also Region and MIDI Region.

audio track  A track in Logic’s Arrange window that is used for playback, recording, and 
editing of Audio Regions.

Audio Track Object  Audio Object in the Environment’s Audio layer. Used to playback 
audio tracks in Logic’s Arrange window. All data on the audio track is routed to the 
Audio Object, that was assigned in the Arrange window’s Track List menu.

Audio Units (AU)  Audio Units is the standard format for real-time plug-ins running on 
Mac OS X. It can be used for audio effects and software instruments. The Audio Unit 
format is part of the Mac OS X operating system. Once installed, Audio Unit plug-ins 
can be accessed by all programs simultaneously. Logic supports all Audio Unit format 
plug-ins.

Audio window  Logic window used for a number of audio file handling and conversion 
tasks.

Autoload Song  Song with your favorite settings and preferences. It loads automatically 
when you launch Logic, and serves as a starting point for your songs and projects. 

automation  Automation is the ability to record, edit, and play back the movements of 
all knobs, controls, and buttons, including volume faders and pan, EQ, and Aux send 
controls plus almost all effect and instrument plug-in parameters.

Aux Object  Audio Object in the Environment’s Audio layer. Aux Objects are similar to 
the Bus Objects, but are more flexible. Unlike Bus Objects Aux Objects also have Sends 
of their own, allowing you to form complex signal paths.

bar  In musical notation, a bar is a measure that contains a specified number of beats, 
and establishes the rhythmic structure of a musical piece.

bit depth  The number of bits a digital recording or digital device uses. The number of 
bits in each sample determines the theoretical maximum dynamic range of the audio 
data, regardless of sample rate. Also known as bit resolution, word length, or bit rate.

bit rate  See bit depth

bit resolution  See bit depth
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bounce  To process recorded or streamed MIDI and/or Audio Regions with any applied 
effects, such as delay or compression, combining them into one audio file. In Logic, you 
can choose between Realtime and Offline bouncing. Offline bouncing is faster, but 
doesn’t allow you to apply live automation or record real time audio input.

Bounce button  You can bounce the output of any Output Object to an audio file by 
clicking the Object’s Bounce button. See also bounce.

bus  The term bus is used to describe a send/return routing scheme for audio channels. 
In Logic, effects can be sent to/from Bus Objects for processing or submixing tasks.

Bus Object  Audio Object in the Environment’s Audio layer. Usually used to route the 
signal of an individual send bus to Output Objects. See also bus.

bypass  To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In 
Logic you can bypass a plug-in by either clicking its Bypass button in the plug-In 
window or by Option-clicking on the appropriate plug-in slot.

cable  In Logic the term cable is used to describe the virtual cables that represents the 
MIDI connection between two Environment Objects.

CD Audio  Short for Compact Disc—Audio; current standard for stereo music 
CDs:  44.1 kHz sampling rate and 16 bit depth.

channel strip  A channel strip is a virtual representation of a channel strip on a mixing 
console. Each channel strip contains a number of similar controls, such as a Mute 
button, Volume fader, Pan/Balance knob, Output selector and Bus and/or Insert slots.

checkbox  A small box. You click a checkbox to select or deselect an option.

Clipboard  The Clipboard is an invisible area of memory, into which you cut or copy 
selected objects, using the Edit menu. From there, you can paste these objects to 
different positions. Logic’s Clipboard spans all songs, allowing it to be used to exchange 
objects between songs.

controller  MIDI data type. As examples; sliders, pedals, or standard parameters like 
volume and panning. The type of command is encoded in the first data byte, the value 
in the second data byte.

Core Audio  Standardized audio driver system for all Macintosh computers running 
Mac OS X version 10.2 or higher. Core Audio is an integral part of Mac OS X, allowing 
access to all audio interfaces that are Core Audio compatible. Logic is compatible with 
any audio hardware that offers Core Audio drivers.

Core MIDI  Standardized MIDI driver system for all Macintosh computers running 
Mac OS X version 10.2 or higher. Core MIDI is an integral part of Mac OS X, allowing the 
connection of all MIDI devices that are Core MIDI compatible.
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DA converter or DAC  Short for digital/analog converter; a device that changes an 
analog signal into a digital signal.

DAW  Acronym for Digital Audio Workstation. A computer used for recording, mixing, 
and producing audio files.

dB  Abbreviation for decibels, a unit of measurement that describes the relationships of 
voltage levels, intensity, or power, particularly in audio systems.

default  The preset parameter value.

destructive  Destructive audio processing means that the actual data of an audio file is 
changed, as opposed to just editing peripheral or playback parameters.

dialog  A window containing a query or message. It must be cancelled or replied to 
before it will disappear and allow you to continue.

digital  A description of data that is stored or transmitted as a sequence of ones and 
zeros. Most commonly, refers to binary data represented using electronic or 
electromagnetic signals. All files used in Logic are digital. Also see analog for 
comparison.

disclosure triangle  A small triangle you click to show or hide details in the user 
interface.

distortion  The effect produced when the limit of what can be accurately reproduced 
in a digital signal is surpassed, resulting in a sharp, crackling sound. 

drag & drop  Grabbing objects with the mouse, moving them, and releasing the mouse 
button.

driver  Drivers are software programs that enable various pieces of hardware and 
software to be recognized by other programs in a computer, and also to have the 
appropriate data routed to them in a format they can understand. In Logic, you can use 
the Preferences > Audio > Drivers panel to select and configure your audio hardware 
drivers. If you do not have the proper driver installed, your computer may not 
recognize or work properly with a given piece of hardware.

DSP (digital signal processing)  In Logic, the mathematical processing of digital 
information to modify a signal. An example is the Insert slot of channel strips, which 
assigns DSP effects such as dynamic compression and delay to a channel’s signal.

dynamics  Refers to changes in volume or other aspects of a piece of music over time.
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dynamic range  The dynamic range of a sound system is the difference in level 
between the highest signal peak that can be reproduced by the system (or device in 
the system) and the amplitude of the highest spectral component of the noise floor. 
The dynamic range is the difference between the loudest and softest signals that the 
system can reproduce. It is measured in decibels (dB). See decibels.

editor  Window for editing MIDI or audio data. Logic offers the Hyper, Matrix, and Score 
editors for MIDI event data, and the Sample Editor for audio data.

effect  A type of software algorithm that lets you alter the sound of a track in a variety 
of ways. Logic includes a set of EQ, dynamics, time-based, modulation, and distortion 
effects in Logic’s native and Audio Unit plug-in formats.

Environment  The Environment is Logic’s brain:  it graphically reflects the relationships 
between hardware devices outside your computer and virtual devices within your 
computer. Beyond basic input and output handling, the Environment can be used to 
process MIDI data in real-time, and can even be used to create processing “machines”, 
such as virtual rhythm generators and step sequencers or complex synthesizer editors.

Environment layer  A place in the Environment, used to organize Objects and making 
usage easier. Objects of the same type (Audio Objects, for example) are generally 
placed on the same layer.

export  To create a version of a file, such as a Logic song, in a different format that can 
be distributed and used by other applications.

Freeze function  The Freeze function performs individual offline bounce processes for 
each “frozen” track, saving almost 100% of the CPU power used for software 
instruments and effect plug-ins. All plug-ins of a track (including software instrument 
plug-ins, if applicable, along with all related automation data) are rendered into a 
“Freeze file”. You can use the Freeze function on individual Audio or Audio Instrument 
tracks.

grab (an object)  Positioning the mouse cursor over an object, then pressing and 
holding the mouse button down.

hierarchical menu  Structured menus where choosing an individual entry opens a 
submenu.

importing  The process of bringing files of various types into a Logic project or song. 
Imported files can be created in another application, captured from another device, or 
brought in from another Logic project.

Input Object  Audio Object in the Environment’s Audio Layer. The Input Object 
represents the physical inputs of your audio interface and helps managing audio from 
your audio interface into Logic.
Glossary    505



506

 

Insert slot  A point on Logic’s Mixers where you can patch in (insert) an effect plug-in. 
All audio channel types in Logic’s Track and Audio Mixers offer effect insert slots.

interface  1) A hardware component such as a MIDI or audio device that allows Logic 
to “interface” (connect) with the outside world. You need an audio or MIDI interface to 
get sound/MIDI into and out of your computer. Also see audio interface. 2) A term that 
is used to describe Logic’s graphical elements that can be interacted with. An example 
would be the Arrange window, where graphical interface elements such as Regions are 
interacted with to create an arrangement, within the overall Arrange interface.

key command  Function which can be executed by pressing a specific key (or key 
combination) on your computer keyboard or MIDI controller.

latency  You may notice a delay between playing your keyboard and hearing the 
sound. This is a form of latency. A variety of factors contribute to latency including 
audio interface, audio, and MIDI drivers. One factor under you control, however, is the 
I/O buffer size, which is set in the Audio > Audio Hardware & Drivers preferences. 

local menu  Menu in a window that only contains functions that are relevant to that 
particular window.

Logic Setup Assistant  A utility that guides you through the process of setting up your 
Macintosh, audio, and MIDI hardware to work with Logic. The Logic Setup Assistant can 
be run at any time by choosing the Preferences > Start Logic Setup Assistant menu 
item.

main menu bar  The bar at the top of the computer screen, offering global functions 
such as opening, saving, exporting, or importing songs. It does not offer access to local 
functions. 

MIDI  Abbreviation for Musical Instrument Digital Interface. Standardized, 
asynchronous, serial, and event-oriented interface for electronic musical instruments. 
MIDI is an industry standard that allows devices such as synthesizers and computers to 
communicate with each other. It controls a musical note’s pitch, length, and volume, 
among other characteristics.

MIDI Region  Data container for MIDI events which is shown in the Arrange window as 
a named horizontal beam. In earlier Logic versions MIDI Regions were called sequences.

mixing  The process of shaping the overall sound of a song by adjusting the volume 
levels, pan positions, adding EQ, and other effects, and using automation to 
dynamically alter aspects of the song.

modifier key  Computer keyboard keys used in conjunction with alphabetical keys to 
change functionality. Modifier keys include; Control, Shift, Option, and Command.
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mono  Short for monophonic sound reproduction. The process of mixing audio 
channels into a single track, using equal amounts of the left and right audio channel 
signals. Compare with stereo.

MTC  See MIDI Time Code.

mute  Switch off an Audio Object or track’s audio output. You can mute a track by 
clicking the Track Mute button in the Track List. The output of an Audio Object is 
disabled by clicking the Mute button at the bottom of the channel strip.

Object  If capitalized, the term Object is used to refer to the graphical representation of 
all elements in Logic’s Environment. These elements can be used to create and process 
MIDI data in real-time, and can even be used to create processing “machines”, such as 
virtual rhythm generators or step sequencers. Examples for Objects are Instruments, 
Multi Instruments, Faders, Arpeggiators, and others. In the Environment’s Audio layer 
you also find Objects used to process audio data. These Objects are correspondingly 
named Audio Objects. Also see Audio Objects. 

option  1) Alternative function, often in the form of a checkbox, sometimes also 
available as a menu entry. 2) Modifier key, in Windows terminology this key is also 
known as Alt key.

Output Object  Audio Object in Logic’s Environment controlling the output level and 
pan/balance for each output on your audio interface. They are assigned to a specific 
hardware output in their Object Parameter box.

pan, pan position  The placement of mono audio signals in the stereo field, by setting 
different levels on both sides.

Parameter box  Field on the left side of Logic’s windows used to adjust the parameters 
of the selected Regions or Objects.

playback  Playing an Audio or MIDI Region or an entire arrangement, allowing you to 
hear it.

plug-in  Software application that enhances the functionality of the main program (in 
this case, Logic). Logic’s plug-ins are typically software instruments or effects.

Plug-in window  A window that launches when a plug-in is inserted, or the Insert/
Instrument slot is double-clicked. Allows you to interact with the plug-in parameters.

Preferences window  A window that is accessed via the Logic > Preferences menu. All 
Logic preferences can be set in this window.

project  In Logic, the top-level folder that holds all media associated with a song, 
including audio files, Sampler Instruments and samples, Video and Settings of various 
kinds.
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Region  Regions can be found in the tracks of the Arrange window:  They are 
rectangular beams that act as containers for audio or MIDI data. There are three 
different types of Regions:  Audio Regions, MIDI Regions, and Folder Regions. Also 
see:  Audio Region, MIDI Region and Folder.

routing  Generally refers to the way audio is sent through processing units. Also often 
used to describe specific input and output assignments.

sample  A digital recording of a sound at a particular instant in time.

sampler  Device used for sampling. In Logic, this generally refers to the EXSP24 
software-based sampler.

sample rate  When an analog audio signal is converted to a digital signal, this term 
refers to the number of times per second the audio file is sampled. Logic can record 
and edit audio at sample rates ranging from 44.1 kHz (44,100 times per second) up to 
192 kHz (192,000 times per second).

scroll bar and scroll box  Gray beam at the edge of a window. A movable box inside 
the beam is used to select the displayed song section in the window.

send  Abbreviation for auxiliary sends. An output on an audio device used for routing a 
controlled amount of the signal to another device. Sends are for example often used to 
send several signals to the same effect, which is rather advisable for computationally-
intensive effects such as reverb.

sequencer  A sequencer is a computer application that allows you to record both 
digital audio and MIDI data and blend the sounds together in a software mixing 
console. There are editing tools that let you control every aspect of the production, 
down to the finest details. Effect processors and software instruments are increasingly 
being added to these applications. Modern sequencers such as Logic now can fulfill 
many, if not all, functions that were only possible in the most expensive and well-
equipped recording studios a decade ago.

setting  1) A parameter value. 2) A set of plug-in parameter values that can be loaded, 
saved, copied, or pasted via the Settings menu. A plug-in setting is also known as 
preset. Also see preset and Settings menu. 

Settings menu  Accessible via the Arrow button found in the gray header at the top of 
all plug-in windows. Allows you to save, load, copy, and paste settings:  the parameter 
values of effects and software instruments.

shelving EQ  EQ type that allows reducing or increasing the frequency range above or 
below the specified frequency.

software instrument  Logic’s software counterpart to a real sound source or a sampler 
or synthesizer module.
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Solo tool  Click-holding on individual Regions or events with the Solo tool temporarily 
allows them to be heard in isolation. All other objects are muted.

song  Main Logic file, containing all MIDI events and parameter settings (including 
mixer automation data) plus information about the audio files to be played.

stereo  Short for stereophonic sound reproduction of two different audio channels. 
Compare with mono.

synthesizer  A device (hardware or software) that is used to generate sounds. The word 
is derived from early attempts with mechanical and electronic machines to emulate (or 
synthesize) the sounds of musical instruments, voices, birdsong, and so on. Logic 
features several software synthesizers, including; the ES1, ES2, EFM 1, ES E, ES P, and 
ES M.

toggle  To switch between two states such as on or off (applies to windows, parameter 
values and so on).

track  A horizontal row in the Arrange window that contains either Audio or MIDI 
Regions that can be played back over time. Each track has a specified destination that 
data is routed to. Logic allows hundreds of tracks to be used in a song.

Track List  Situated to the left of the Arrange window’s working area. Displays the 
Objects assigned to various tracks as well as the Track buttons. 

window class  Status of the window as a float window or a normal window. Float 
windows always “float” in the foreground and can not be hidden by normal windows. 
Also see float window.

word length  See bit depth.
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Index
A
AAC  208
Active MIDI Transmission  120
aftertouch  501
alias  124
amplifier  501
amplitude  501
analog  501
Anchor point  275
Apple Loops  62

adding to song  64
Apple Loops Utility  64

Tags pane  64
Transients pane  65

blue sound wave icon  63
green note icon  63
Loop Browser  62

Key pull-down menu  63
locating files  62
Search field  63

Arrange channel strip  100
resizing  101

Arrange window  91, 501
audio file

adding multiple simultaneously  134
opening  92
viewing

level meter  93
Track Freeze button  149
Track Mute button  97
Track Protect button  100
Track Solo button  98

attenuating  501
AU
audio

preference  479
audio file

adding all files in a folder  262
adding multiples  262
adding multiple simultaneously  134
AIFF  265
format conversion  265
removing all files in a folder  262

SDII  265
stereo  266
type  250
WAV  265

Audio Instrument  501
Audio Instrument Object

Object Parameter box  106
Audio Mixer  192, 501

connecting Audio Objects  193
opening as float window  192

Audio Object  192, 194, 501
adjusting multiple simultanously  194
Audio Instrument Object  213
Audio Track Object  502
Auxiliary Object  217
Aux Object  502
Balance control  200
Bus Object  216, 503
Channel Strip Settings menu  197
configuring as stereo  203
creating  192
deleting  192
Input  199
Input Object  212, 505
Insert  197
level meter  200
list of elements  196
Mute button  203
Output Object  215
Pan control  200
Record Enable button  204
selecting multiple  194
Send  198
signal routing  193
Solo button  202
soloing several Objects at once  202
Track Object  211

Audio Region  91
editing

end point  138
start point  138

audio synchronization  455
Audio Track Object  502
511
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Audio Unit.  See AU
Audio window  502
Auto Create Tracks in Cycle Record option  87
Autodrop function  88, 143

defining Autodrop area  88
Autoload Song  502
automation  502

settings  479
using a hardware MIDI fader  232

Auto Mute in Cycle Record option  87
Auto Track Zoom function  25
Auxiliary Object  217
Aux Object  502

B
backup file  59
Balance control  200
bank message

with channel  170
Bank Select parameter  104, 164
bar  502

position display  76
time signature change  78

barline  127
Bar Ruler  82, 91

display  82
bit depth  502
bit rate.  See bit depth
bit resolution.  See bit depth
bounce  503
Bounce button  503
Bounce function  204

adding audio file to iTunes library  205
Bounce window

AAC options  208
Burn options  210
global options  205
MP3 options  207
PCM options  206

Offline mode  206
Realtime mode  205
starting  204

burning
Red Book audio to blank CD  210

bus  503
Bus Object  216, 503
bypass  503

C
Camera tool  20
Caps Lock Keyboard  49

preference  50
Catch function  28

Enable Catch when Sequencer starts option  29

Channel EQ  196
thumbnail  196

channel strip  503
Channel Strip Only function  100
Channel Strip setting

copying  197
loading  197
menu  197
saving  197

Chase Events function  89
checkbox  14, 503
Chord  432
chord

automatic interpretation  78
Chord Mode key command  46
Clear function  33
Clear Overload Flag in Audio Channel Display key 
command  201
Clipboard  32, 503
clip detector  201
Contents Catch function  30
Contents Link function  29
controller  503
Controller Assignments window  500
control surface  487

assigning button to key command  498
assigning MIDI control to parameter  498
Controller Assignments window  500
customizing  498
defining multiple assignments  499
deleting MIDI assignment  498
help tag  497

Copy function  32
Core Audio  503
Core MIDI  503
Create new Instrument (key command)  101
Crescendo  359
crossfade

curve type  148
time  148

Crosshair tool  20
Cut function  32
Cycle function  84

defining Cycle area  85
by Regions  85
graphically in Bar Ruler  85
numerically  85

skipping Cycle  86
switching on  84

D
DAC  504
DA converter  504
DAW  504
dB
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DC Offset
removing  290

decibel.  See dB
Delete

Backspace key  108
eraser tool  108

deleting
event  35

De-Quantize function  36
Deselect Global Tracks function  241
destructive  504
dialog  504
digital  504
digital audio workstation.  See DAW
digital signal processing.  See DSP
Drag menu  108
driver  504
Drum

notation  396
drum

hi-hat mode  318
drum machine

sync  451
drum-mode device  170
DSP
dynamic range  505

E
Edit

notation  329
score  329

editing
cutting with Scissors tool  112
event  297

aftertouch  308
controller  297, 307
note  297
pitch bend  307
pressure  308
program change  306
SysEx  297, 309

fine resolution  111, 326
note  324, 325

length  326
pitch  324
position  324
velocity  324, 327

piano roll  323
sample-accurat  280
sample destructively  288

Edit menu
Clear function  33
Copy function  32
Cut function  32
Paste function  32

editor  35, 505
MIDI Out button  35
opening  35

Enable Catch when Sequencer starts option  29
Environment  505

Audio Mixer  192
Audio Object  192
button  182
cabling  160
exchanging between songs  189
fader with numerical display  182
importing

Environment layer  189
knob  182
layer  505
Mapped Instrument  170

Erase key command  48
Eraser  19
event

chasing  89
deleting  35
displaying in alphanumerical list  297
quantizing  35

Event Definition Parameter box  315
Event List  297

event
aftertouch  308
note  305
pressure  308
program change  306
SysEx  309

hiding/showing event types  299
listing Regions  304
showing/hiding event types  299

’Export MIDI File…’ save single Regions as File 
Format 0 option  61
external

sequencer  451
sync  451

F
Finger  19
FireWire

video playback  463
Folder  123

adding Region  124
creating  123
entering  123
exiting  124
transposing  117
unpacking  124

forwarding  80
Freeze function  148, 505

DSP card  148
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G
GarageBand  67

Channel Strip setting  67
Instruments  67
opening GarageBand song in Logic  67

Global track  239
Deselect Global Tracks function  241
displaying  240

key command  240
global event  240

copying  241
creating  240
deleting  241
selecting  241

reordering  240
Signature track  244
Tempo track  242
Transposition track  245
typ  239
Video track  247

Glue tool  20
Go into Folder or Region key command  23
Goto Position key command  84
Goto Selection Start/End key command  33
grid

overriding during editing operation  111, 326

H
headroom  201
help tag  20

displaying  484
Hide Windows of inactive song preference  57
hi-hat mode  318
Hyper Editor  311

Event Definition Parameter box  315

I
icon  94

assiging to Object  102
creating user-definable icon  94

importing
REX  68

importiong
ReCylce  68

In button  45
Input

selecting  199
Input Object  212, 505
input option  14

mouse  14
as slider  14
checkbox  14
in/decrementing  15
pull-down menu  14

numerical  15

arithmetical operation  15
ASCII symbol  15

text  16
numbered names  16

Insert  197
adjusting multiple simultanously  195

Instrument Object
assigning output  159
creating  101
hiding from Track List menu  103
Object Parameter box  102

Channel parameter  103
Delay parameter  105
icon  102
Key Limit parameter  105
Name  102
No Reset parameter  106
No Transpose option  105
Object type  102
Pan parameter  104
Port parameter  103
Program parameter  104
Style parameter  106
Transpose parameter  105
Vel Limit parameter  105
Velocity parameter  105
Volume parameter  104

interface  506
iTunes

adding audio file to library  205

K
Keyboard window  45

Chord mode  46
inserting single note  45

key command  36
assigning to control surface button  498
assigning to function  42
assigning to MIDI message  43
Clear Overload Flag in Audio Channel Display  201
copying to clipboard  39
Create new Instrument  101
deleting assignment  43
deleting MIDI assignment  43
Go into Folder or Region  23
importing  38
initializing  39
Key Commands window  37

Find field  40
Learn by Key Label button  40
Learn by Key Position button  40
Learn MIDI button  41
MIDI Remote option  39
Options menu  38
Show menu  39
Index    



Mute Track  97
Play from beginning  80
printing list of  39
Save as Zoom 1–3  25
saving  36
Select Next Track  95
Select Previous Track  95
Set rounded Locators by Objects key 
command  76
special keys  37
Toggle Loop  117
Turn Loops to Aliases  117
Undo  32

key signature  127

L
latency  506
Layout tool  19
legato

forcing  118
level meter

hiding/showing in Arrange window  201
Link function  29
Locator  76

Set Locators & Play key command  85
Set Locators by Objects key command  85
Set rounded Locators by Objects & Play key 
command  86
Set rounded Locators by Objects key 
command  85
setting by Object  76

Loop
repeating Region  138

Loop function  117
activating  117
ending loop  117
turning loops into aliases  117
turning loops into real copies  117, 136
using  136
using in folder  117

Lyric
notation  431
score  431

Lyric entry  367

M
Magnifying Glass  19, 25
Matrix Editor  323

Hyper Draw function  327
memory

reconfiguring  77
menu  26
Merge New Recording With Selected Region 
option  87
Merge only New Regions in Cycle Record option  87

Metronome
Metronome button  82

MIDI
delay  456
interface  476
monitoring  78
options  472

MIDI channel strip  221
GM/GS/XG functions  222

MIDI Clock  451, 456
MIDI data

changing  437
converting  437
double speed  444
half speed  444
note length  444
reverse  444
transpose  444
velocity  444

MIDI Machine Control  457, 460
MIDI monitor  78

automatic chord interpretation  78
Panic function  79

MIDI Out button  35
MIDI Region  91

altering length
rounded to whole bars  110

demixing
by note pitch  113

dividing  112
overlapping notes  112

merging  113
MIDI Thru Tool  20
MIDI Time Code  451, 457
mixing  191

with hardware  487
MMC  457, 460
modifier key  506
mono

Object  203
track to stereo bus  199

MP3
adding  263
importing  263
settings  481

MTC  451, 457
multi-timbral

synthesizer  166
multitrack tape

sync  451
mute  507
Mute tool  19
Mute Track key command  97
muting

all tracks  97
Region  114
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N
naming

Region  115
multiple  115

New dialog  51
Create Project Folder option  51

Next note will be flat key command  47
Next note will be sharp key command  47
Next three notes are triplets key command  48
Next two notes are a dotted group key 
command  48
normalizing

Region parameter  120
Notation

beaming  394
chord  432
clef  355
color  423
date  367
diatonic  351
display  339, 401
display box  374
display correction  377, 378
display syncopation  379
dots  380
drum  396
dynamic  356
edit  329, 371
fonts  341
grace note  354
groups  403
image file  342
input  339
insert symbol  348
jazz  358
key signature  361
legato off  379
lyric  431
mouse  344
name  367
note attributes  398
note head  357
notes  351
polyphonic voices  392
preferences  410, 423
print  341
recording  343
repeat/bar line  364
rest/bar repeat  365
slur/crescendi  359
split stave  390
stave setup  380
step input  343
sustain  355
symbols  348, 357, 368

tablature  419
tempo  368
text  425
text/chord symbols  367
ties  351
time signature  362
trill, tremolo  365
tuplets  352
voice separation  391
volume  347

Notation layout
full/part  407

note
automatic chord interpretation  78
editing  324, 325
keeping when cutting/dividing  112
length

editing  326
overlap handling when cutting/dividing  112
pitch  324
quantizing  36
shortening when cutting/dividing  112
splitting when cutting/dividing  112
stopping hanging notes  79
unquantizing  36
velocity

editing  327
No Transpose option  105, 118

O
Object

mono  203
Object Parameter box  193

Channel parameter  192, 193
Device parameter  193
Instrument  102
MIDI Channel parameter  194
showing/hiding  193

Output Object  215, 507
Bounce button  204

P
Pan control  200
Panic function  79
Parameter box  507
Parameters area

resizing  26
viewing  26

Paste function  32
Patch entry  306
Pause button  79
PCM  206
Pencil  19
Piano roll

volume  327
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piano roll editor  323
playback  507

Play from beginning key command  80
Play button  80
Plug-in window  507

opening as non-float window  197
placing on the Dock  197

Pointer  18
POW-r dithering  70
Preferences  465, 476

Audio  479
Display  480
Drivers  479
General  479
Sample Editor  285, 480
Universal Track Mode (UMT) option  203

Display
Wide Song Position Line option  83

Global
Caps Lock Keyboard  50
Editing  477
’Export MIDI File…’ save single Regions as File 
Format 0 option  61
Hide Windows of inactive song preference  57
Songs  476
When Opening a Song, ask to Close current 
song preference  56

initializing  476
without losing keyboard assignments  476

Project  55
saving  466

pressure  507
program change  104, 306

recording  104
project

Clean up function  54
Consolidate function  55
creating  51
handling ReCycle import  55
moving/copying project folder  54
preference  55
saving  53
settings  52

pull-down menu  14

Q
quantization

applying setting destructively  121
Quantize Tool  20
QuickTime  461

R
Recall Zoom 1–3 key command  25
Record button  79

recording  86
arming track  204
Autodrop function  88
changing MIDI track  86
in Autodrop mode  89
in Cycle and Autodrop mode  89
in Cycle and Replace mode  88
in Cycle mode  87
MIDI and audio simultaneously  142
Record Repeat key command  87
Record Toggle key command  87
Replace function  87
selecting a track  86
settings  468
with effects  212
with Skip Cycle function  88

ReCycle
Copy ReCycle Loop function  68
importing  68
Paste ReCycle Loop function  69

Redo
multiple Redo  32

Region
altering length  110

when Hyper Draw is enabled  110
copying  109

with enabled Hyper Draw  109
demixing by event channel  113
moving

with enabled Hyper Draw  109
moving into Folder  124
muting  114
naming  115

multiple  115
normalizing parameter  120
repeating  138
soloing  114

Region Parameter box
Loop function  117
Loop parameter  136
name  115

Regions
moving by one sample word  137
moving by single ticks  137
moving in steps of one division  137

removing
DC Offset  290

Repeat Regions function  136
repeat sign  127
Replace function  87
Rest key command  48
ReWire  214

settings
Bus  179
Cha  179
Dev  179
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Live mode  180
Playback mode  180

routing  508

S
sample

destructive editing  288
dipslaying as sample bits  280
displaying as sample bit  280
increasing level  295
looping  281
loop smoothing  284
moving  287
phase invert  289
pitch shift  292
processing  291
removing

noise  289
resizing  282
reverse  290
time stretch  292
view scale  278

sample-accurat
editing  280

sample-accurate
editing  284

Sample Editor  275
Anchor Point  275
opening  276
stereo file  276

sample rate  508
sample rate conversion  274, 296
Save as Zoom 1–3 key command  25
saving

as project  53
Scissors tool  19, 112
Score

beaming  394
chord  432
clef  355
color  423
date  367
diatonic  351
display  339, 401
display box  374
display correction  377, 378
display syncopation  379
dots  380
drum  396
dynamic  356
edit  329, 371
fonts  341
grace note  354
groups  403
image file  342

input  339
insert symbol  348
jazz  358
key signature  361
legato off  379
lyric  431
mouse  344
name  367
note attributes  398
note head  357
notes  351
polyphonic voices  392
preferences  410, 423
print  341
recording  343
repeat/bar line  364
rest/bar repeat  365
slur/crescendi  359
split stave  390
stave setup  380
step input  343
sustain  355
symbols  348, 357, 368
tablature  419
tempo  368
text  425
text/chord symbols  367
ties  351
time signature  362
trill, tremolo  365
tuplets  352
voice separation  391
volume  347

score
symbol  127

Score Editor
repeat sign  127

Score layout
full/part  407

Screenset  30
copying  31
locking  30
recalling  31
resetting  31
storing  30
switching  30

Scroll To Selection function  24
scrubbing  84
Search Zero Crossings option  284
Select first/last key command  33
selecting  33

all objects on a track  34
alphabetically  33
following objects  34
individual object  33
Regions/events within Locators  34
Index    



rubber band  34
several objects  34
toggling selection status  34

Selection Parameter box  282
Select next/previous Object key command  33
Select Next Track key command  95
Select previous/next track key command  86
Select Previous Track key command  95
Send  198

adjusting multiple Send level knobs 
simultanously  195
adjusting Send level/amount  198
bypassing  198
creating  198
normalizing Send level  198
post/pre fader  199
removing  198

Send slot
adjusting multiple simultaneously  195

Sequencer
sync  451

sequencer  508
external  451

Set Locators & Play key command  85
Set Locators by Objects key command  76, 85
Set rounded Locators by Objects & Play key 
command  86
Set rounded Locators by Objects key command  85
setting  508
settings

project  52
Shuttle  80

Shuttle Rewind/Forward (key command)  80
Signature track  244

creating time/key signatures  244
cutting bars  245
editing signatures  245

Sizer Tool  19
Slur  359
SMPTE  451

offset  455
position display  76
view offset  75, 76

Softsampler  213
Softsynth  213
software instrument  213

accessing multiple outputs  214
Software Instrument Pitch parameter  214, 471
Software sampler  213
Software synth  213

multiple outputs  214
Solo function  81
soloing

Region  114
Solo Lock function  81
Solo Tool  19

Solo tool  114
Song  51

settings  466
song

backup file  59
closing  59
end  79
importing song files via drag and drop  57
importing standard MIDI files via drag and 
drop  57
maximum length  79
opening  56
opening old songs  57
opening recent  57
reconfiguring memory  57
repairing song  57
reverting to saved version  59
saving  58
setting maximum length  79
Song Information window  58
start/end markers  83
switching between different songs open at same 
time  57

Song Position Line  83
Goto Position key command  84
positioning  83

numerically  84
Wide Song Position Line option  83

Song Settings  465
Metronome  466
MIDI

Chase  89
Recording  468

Auto Create Tracks in Cycle Record option  87
Auto Mute in Cycle Record option  87
Count-in  87
Merge New Recording With Selected Region 
option  87
Merge only New Region in Cycle Record 
option  87
Record Pre-roll  87

saving  466
Synchronization

Audio  455
General  453
MIDI  456
Unitor  458

Tuning  469
Software Instrument Pitch parameter  214

Song speed  447
change  448

Speed  447
change  448

SPL.  See Song Position Line
Staccato

force  118
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520
Standard MIDI file  60
bank select  60
format 0  60
format 1  60
loading  60
saving  61

Step backwards key command  48
Step forward key command  48
Step Input  44

In button  45
input via MIDI  49
Keyboard window  45
key commands  47
via computer keyboard  47

Stereo
create object  203

Stereo audio region
left channel playback  203
right channel playback  203

Stop button  80
Synchronization

Quicktime  463
synchronization  451

audio  455
general  453
locking Logic to external sync  451
receiving  451, 452
recording  451
tape machine  460
tips  460
Unitor  458
video  461
VITC  459

synthesizer  509
SysEx  475

T
tape machine

synchronization  460
tape sync  451
temperament

equal  471
template  56

saving  56
using  56

Tempo  447
change  448

Tempo Resolution menu  242
Tempo track  242

adjusting tempo events range  243
continous transition between two tempi  242
copying tempo change  243
deleting tempo change  242
inserting tempo change  242
moving tempo change  243

Tempo Resolution menu  242
Text Tool  19
Text tool  16
Time signature  127
time signature change  78

editing  78
erasing  78

Timing
fixing problems  119

toggle  509
Toggle Loop key command  117
tool

  17
Camera  20
Crosshair  20
effective range  17
Eraser  19
Finger  19
Glue tool  20
hide/show toolbox  17
Layout tool  19
Magnifying Glass  19
MIDI Thru Tool  20
Mute tool  19
opening Tool Box at mouse position  17
Pencil  19
Pointer  18
Quantize Tool  20
Scissors  19
selecting  17
selecting by Key Command  18
Sizer Tool  19
Solo Tool  19
Text Tool  19
two tools available at mouse pointer  16
Velocity tool  20
Voice Splitter  20

track  92
adjusting sound  104
arming  204
assigning Object  93
copying  95
creating  95
deleting  96
freezing  149
icon  94
muting  97
naming  96
protecting  99
selecting  95
selecting Instrument Object  99
soloing  98
sorting  95
types of  93

Track Button Slide Activation function  98
Track Freeze button  149
Index    



Track List  509
Track Mixer  218

Filter button  191, 219
Folder  220
Global view  219
MIDI channel strip  221
opening as float window  218
Track view  219
view  219

track number
hiding/showing in Arrange window  201

Track Protect button  100
Track Solo button  98
Transport

viewing  25
view Transport in other windows  75

transport
Transport window  73

Transport window  73
adjusting siize  75
altering display  75
closing  74
inputting data  74
Legend option  75
Locator

left  76
right  76

Metronome button  82
MIDI monitor  78

automatic chord interpretation  78
moving  74
opening  74
Panic function  79
Pause button  79
Play button  80
position display  76

bar  76
SMPTE  76

Position Slider option  75
Record button  79
Replace button  87
SMPTE View Offset option  75, 76
Solo button  81
Solo Lock button  81
song end  79
song title  79
Stop button  80

transposing
by octaves  118
preventing  118

Transposition track  245
adjusting scale range  247
handling transposition event  246

tuning
alternate  469
setting  469

U
Undo  32, 108

key command  32
multiple Undo  32

Unitor  458
Univeral Track Mode option  203
using mouse  13

as slider  14
clicking  13
clicking and holding  13
double-clicking  13
dragging  13
grabbing  13
in/decrementing  15
moving  13

V
velocity

editing  324
setting fixed value  118

Velocity tool  20
video

FireWire playback  463
thumbnail  463

Video track  247
VITC  459
Voice Splitter  20

W
When Opening a song, ask to Close current song 
preference  56
Wide Song Position Line option  83
window  21

activ  27
background  27
Catch function  28
closing  24
Contents Catch function  30
Contents Link function  29
float window  28
Link function  29
menu  26
moving up in display hierarchy  22
opening  21
Screenset  30
scrolling one page  24
selecting working area  23
setting size  21, 22
Stack Windows function  32
Tile Windows function  32
Tile Windows horizontally function  32
Toggle … Window key command  21
Transport window  73
viewing Parameters area  26
viewing Transport  25
Index    521



522
word length.  See bit depth

X
X/Y scroll element  23

Z
zero crossing

searching  284

zoom
Magnifying Glass  25

zooming
Auto Track Zoom function  25
Magnifying Glass  25
Recall Zoom 1–3 key command  25
reverting to previous setting  25
Save as Zoom 1–3 key command  25
saving zoom setting  25
Zoom slider  24
Index    


	Logic Express 7
	Reference Manual
	Contents
	Preface 9 Logic Reference
	9 What Is Logic?
	10 About This Manual

	Chapter 1 13 Using Logic
	13 Using the Mouse
	14 Input Options
	16 Tools and the Toolbox
	21 Window Functions
	32 Edit Operations
	33 Selection Techniques
	35 General Functions of the Editors
	36 Key Commands
	44 Step Input
	49 Caps Lock Keyboard
	51 Song Administration
	60 Standard MIDI Files
	62 Apple Loops
	67 GarageBand File Import
	68 ReCycle Import
	70 OPEN TL Import
	70 Bouncing and POW-r Dithering

	Chapter 2 73 Transport
	73 The Transport Window
	82 The Bar Ruler
	84 Cycle Mode
	86 Recording
	89 Chase Events

	Chapter 3 91 Arrange Window
	91 Overview
	92 Tracks
	100 Arrange Channel Strip
	101 MIDI Instruments
	107 MIDI Regions
	116 MIDI Region Playback Parameters
	120 Quantization
	122 Folders
	124 Aliases
	127 Time and Key Signature Editor
	128 Altering the Display
	132 Reset Functions

	Chapter 4 133 Audio in the Arrange Window
	133 Regions
	141 Audio Recording
	145 Functions
	148 Freeze

	Chapter 5 153 The Environment
	153 Environment—Introduction
	154 Basic Operation
	159 The MIDI Signal Path
	162 Environment Objects
	181 Faders
	189 Environment Exchange

	Chapter 6 191 Logic’s Mixing Facilities
	192 Audio Mixer
	194 Audio Objects in the Audio and Track Mixer
	211 Audio Object Types
	218 Track Mixer
	221 MIDI Channel Strips

	Chapter 7 225 Automation
	225 Automation—Introduction
	227 Track Based Automation
	232 Region Based Automation
	233 Hyper Draw
	236 Conversion of Automation Data

	Chapter 8 239 Global Tracks
	240 Display Options for Global Tracks
	240 How to Create, Move, Copy, and Delete Global Events
	242 Tempo Track
	244 Signature Track
	245 Transposition Track
	247 Video Track

	Chapter 9 249 Audio Window
	249 Audio Window—Introduction
	251 Layout
	253 Display
	256 Operation
	260 File Administration
	268 Further Options

	Chapter 10 271 Audio Drivers
	271 The Audio Hardware and Drivers Dialog
	274 Audio Engine
	274 Realtime Sample Rate Conversion

	Chapter 11 275 Sample Editor
	275 Sample Editor—Introduction
	277 Display
	280 The Sample Edit Window in Use
	288 Functions
	291 Digital Factory

	Chapter 12 297 Event List
	297 Using the Event List
	299 Display
	300 Operation
	302 Event List Structure
	305 Event Type Structure
	309 Tips for Numerical Input
	310 Event Float Window

	Chapter 13 311 Hyper Editor
	311 Hyper Editor—Introduction
	312 Hyper Sets
	313 Event Definitions
	319 Operation

	Chapter 14 323 Matrix Editor
	323 Matrix Editor—Introduction
	324 Display
	325 Editing Notes
	327 Hyper Draw in the Matrix Window

	Chapter 15 329 Score Editor
	329 Score Editor—Introduction
	331 Elements of the Score Edit Window
	332 Notation Concept
	336 General Appearance
	339 Input Methods in the Score Window
	339 Score Display Options—a Survey
	341 Printout
	342 Graphic Export
	343 Realtime MIDI Recording
	343 Step Input
	344 Mouse Input
	348 The Part Box
	369 Move, Copy, and Paste
	371 Editing or Deleting Notes and Symbols
	374 The Display Parameter Box
	380 Score Styles
	398 Note Attributes
	401 Instrument Sets and Score Display Levels
	410 Song Settings for Score Display
	423 Score Preferences
	425 Text: Input and Display
	432 Chord Symbols

	Chapter 16 437 The Transform Window
	437 Transform Window—Introduction
	439 Transformation
	444 Parameter Sets

	Chapter 17 447 Tempo
	447 Display and Functions
	448 Tempo List Editor

	Chapter 18 451 Synchronization
	451 Functions
	453 Synchronization Window
	459 Bar Ruler—Time Ruler
	460 Sync Problems and Solutions

	Chapter 19 461 Video
	461 Synchronizing QuickTime Movies

	Chapter 20 465 Song Settings and Preferences
	466 Song Settings
	476 Preferences

	Chapter 21 487 Control Surface Support
	488 Installation
	490 Setup Window Parameters
	495 Control Surface Preferences
	498 Customizing Control Surfaces
	500 The Controller Assignments Window

	Glossary 501
	Index 511

	Logic Reference
	What Is Logic?
	About This Manual
	Conventions of This Manual…


	Using Logic
	Using the Mouse
	Clicking
	Double-Clicking
	Grabbing or Clicking and Holding
	Moving or Dragging
	Mouse Wheel Events

	Input Options
	Mouse Input
	Checkboxes
	Pull-Down Menus
	Mouse as Slider
	Using the Mouse for In/Decrementing

	Numerical Input
	Arithmetical Operations
	ASCII Code
	Cancel Numerical Input

	Text Input
	Numbered Names


	Tools and the Toolbox
	Selecting Tools
	Opening the Toolbox at the Mouse Position
	Using Key Commands

	The Tools
	Help Tags

	Window Functions
	Working With Windows
	Opening Windows
	Setting Window Size
	Window Buttons
	Moving Up One Level in the Display Hierarchy
	Selecting the Working Area
	Closing Windows

	Zooming
	Storing and Recalling Zoom Settings
	Zooming in on One Section of the Screen
	Auto Track Zoom
	Reverting to the Previous Zoom Setting

	Window Elements
	Adjusting the Size of the Window Elements
	Concealing/Revealing the Transport Functions
	Concealing/Revealing the Parameters
	Concealing/Revealing the Local Menu Bar and Scroll Bars
	Resizing the Parameters Area

	Menu Handling
	Window Types
	Normal Windows
	Float Windows

	Relationships Between Windows
	Catch
	Link, Contents Link, and Contents Catch

	Screensets
	Storing Screensets
	Switching Screensets
	Protecting Screensets
	Copying Screensets
	Reverting to a Stored Screenset
	Recalling Screensets 1 to 9
	Sequencer Controlled Screenset Switching

	Window Management Functions

	Edit Operations
	Undo
	Multiple Undo and Redo

	The Clipboard
	Cut
	Copy
	Paste
	Clear


	Selection Techniques
	Goto Selection Start/End
	Selecting Individual Objects
	Selecting Alphabetically

	Selecting Several Objects
	Horizontal Selection
	“Rubber-Banding”
	Toggling the Selection Status
	Selecting Following Regions/Events
	Selecting Regions/Events Within the Locators (Vertical Selection)


	General Functions of the Editors
	Opening Editors
	Control Output via MIDI
	Deleting Events
	Event and Note Quantization
	Quantizing Events
	Note Quantization


	Key Commands
	Saving Key Commands
	Special Keys

	Key Commands Window
	Key Commands List
	Options Menu
	Switching MIDI Remote On/Off
	Show Menu
	Find Function
	Key Command Properties
	MIDI
	Assignments

	Assigning and Deleting Key Commands

	Step Input
	Input via Screen Keyboard
	Single Notes
	Proceeding
	Chords

	Input via the Computer Keyboard
	Pitch
	Octave Ranges
	Note Length and Velocity
	Rests, Correction, Moving Forward and Back
	Triplets, Dotted Note Groups
	Interaction with Other Key Commands

	Input via MIDI

	Caps Lock Keyboard
	Caps Lock Keyboard Preferences
	Additional Caps Lock Keyboard Info

	Song Administration
	Projects
	Creating a Project
	Saving as Project
	Copying or Moving the Project Folder
	Project Clean Up
	Consolidate Project Settings
	Project Preferences
	ReCycle Import Handling in Projects

	About Templates
	Loading a Song
	File > Open
	Direct Access to Your Current Songs
	Different Songs Open at the Same Time
	Song and MIDI File Import by Drag and Drop
	Opening Pre Version 7 Songs

	Special Functions
	Checking/Repairing Songs
	Song Information Window

	Saving Songs
	Export Song as Logic 4.8 Song
	Automatic Backup Files
	Reverting to the Saved Version

	Closing and Quitting
	Closing a Song
	Quitting the Program


	Standard MIDI Files
	Loading Standard MIDI Files
	Bank Select

	Saving Standard MIDI Files
	Preparing the Song
	Saving a Song as a Standard MIDI File


	Apple Loops
	The Loop Browser
	Apple Loops Utility
	Tags Pane
	Transients Pane
	Assets Drawer
	Playback and File Management Controls


	GarageBand File Import
	ReCycle Import
	Recognized ReCycle File Formats
	Importing ReCycle Files Into the Arrange Window
	Copying Audio Data Into the Clipboard
	Pasting ReCycle Loops Into the Arrange Window
	ReCycle File Import Overlap Function


	OPEN TL Import
	Bouncing and POW-r Dithering

	Transport
	The Transport Window
	The Transport Bar in Other Windows
	Altering the Display
	Position Display
	Locators
	Adjusting Locators to Fit Selected Regions

	Tempo/Free Memory
	Tempo
	Free Memory

	Time Signature and Division
	Time Signature Changes

	MIDI Monitor/Song End
	MIDI Monitor and Panic Function
	Song Title
	Song End

	Transport Buttons
	Record
	Pause
	Play
	Stop
	Rewind/Forward
	Shuttle—Winding Like a Reel-to-Reel Tape Recorder

	Mode Buttons
	Cycle, Autodrop, and Replace
	Solo and Solo Lock
	Sync
	Metronome


	The Bar Ruler
	Color and Display
	Start and End Markers

	Song Position Line
	Direct Placement
	Scrubbing


	Cycle Mode
	Defining the Cycle
	Skip Cycle
	Features of Skip Cycle Mode


	Recording
	Selecting a Track
	Changing MIDI Tracks

	Count-In
	Options
	Record Toggle—Record Repeat
	Record into Selected MIDI Region
	Replace Mode
	Destructive MIDI Recording

	Recording in Cycle Mode
	Cycle and Replace
	Recording With Skip Cycle

	Autodrop
	Defining the Autodrop Area
	Setting Autodrop Numerically
	Recording in Autodrop Mode
	Combining Cycle and Autodrop


	Chase Events

	Arrange Window
	Overview
	Opening the Arrange Window

	Tracks
	Overview
	Track Icons
	User-Definable Icons
	Icon Color

	Selecting a Track
	Changing Tracks While Retaining Your Selections

	Sorting Tracks
	Creating Tracks
	Copying a Track

	Deleting Tracks
	Deleting Unused Tracks

	Naming Tracks
	Name While Creating a Track
	Deleting Track Names

	Muting Tracks
	Muting When the Mute Buttons Are Hidden
	Muting All Tracks
	Mute Instrument

	Soloing Tracks
	Soloing When the Track Solo Buttons Are Hidden
	Soloing Multiple Tracks

	Track Button Slide Activation
	Selecting an Instrument
	Changing an Instrument Assignment Globally
	Selecting Track Instruments by Drag and Drop
	Special Types of Instruments

	Protecting Tracks

	Arrange Channel Strip
	Resizing the Arrange Channel Strip

	MIDI Instruments
	Creating a New Instrument
	The Instrument Parameters
	Name
	Object Type
	Selecting an Icon
	Hiding an Instrument
	MIDI Channel and Port Connection
	Adjusting the Sound of a Track
	Recording Program Changes, Volume, or Pan Controllers
	Further Parameters
	Additional Audio Instrument Object Parameters


	MIDI Regions
	Creating a MIDI Region
	Creating an Empty MIDI Region

	Deleting MIDI Regions
	Retrieving Deleted MIDI Regions

	Drag Menu
	Moving Regions
	Tying Regions by Length Change
	Tie Regions within Locators
	Editing the Start Position Numerically

	Copying Regions
	Making Multiple Copies of Regions

	Altering the Length of Regions
	Multiple Selection
	Adjusting the Region Startpoint
	Rounded to Whole Bars
	… to Adjust It to Fit Its Contents
	… to Adjust It to Fit Other Regions

	Using a Finer Grid
	Dividing MIDI Regions
	Multiple Divisions With the Scissors

	Merging MIDI Regions
	Demixing Regions
	Muting Regions
	Soloing Regions
	Naming a Region
	Multiple Naming

	Special Functions
	Inserting Events
	Deleting Duplicate Events


	MIDI Region Playback Parameters
	Displaying Region Parameters
	Opening and Closing
	Name
	Quantize
	Defaults and MIDI Thru
	Default Region Parameters
	Realtime Processing
	Editing Several Regions Simultaneously

	Loop
	Transpose
	Velocity, Dynamics, and Gate Time
	Velocity
	Dynamics
	Gate Time

	Delay
	Fixing/Neutralizing MIDI Region Parameters
	Merge/Normalize and MIDI Channels


	Quantization
	How It Works
	Which Events Can Be Quantized?
	Quantization
	Quantization Off
	Normal Quantization
	Triplet Quantization
	Mixed Quantization
	Odd Quantization

	Applying the Quantization Settings
	Pre-Quantization


	Folders
	Overview
	The “Folder” as a Track Instrument

	Working With Folders
	Creating Folders
	Changing Display Levels
	Moving Regions Into Folders
	Folder Editing: Just Like Regions

	Unpacking Folders
	Unpacking Individual Regions
	Unpacking Folders


	Aliases
	Creating an Alias
	Playback Parameters

	Alias and Real Regions
	Search Functions for an Original or Alias
	“Orphan” Aliases
	Turning the Alias Into a Real Region
	Editing the Events in an Alias
	Merging Two or More Regions


	Time and Key Signature Editor
	Functions
	Copying Time and Key Signatures
	Moving and Deleting List Entries
	Changing Time and Key Signatures in the List Editor


	Altering the Display
	Display Options for the Track List
	Track Numbers/Level Meters
	Mute Button
	Track Solo Button
	Record Enable Button
	Track Protect Button
	Track Freeze Button
	Track Instrument Channel
	Instrument Icon
	Instrument Icon (Large)
	Track Instrument Color
	Instrument Name
	Track Name

	Instrument Name and Track Name
	Horizontal Layout
	Instrument and Track Name Stacked on Each Other
	Sorting the Tracks
	Selecting a Track Instrument
	Opening the Environment Window for an Instrument
	Editing Instrument Names
	Editing Track Names

	Region Display
	Contents Visible in MIDI Regions
	Region Colors
	Altering the Background of the Arrange
	Show/Hide Channel Strip Only


	Reset Functions
	For Hanging Notes—Panic Function
	Unwanted Modulation—Controller Reset
	If Some Sounds Are Suddenly Too Quiet—Volume Reset
	If You Suddenly Hear the Wrong Sounds—Send Instrument Settings


	Audio in the Arrange Window
	Regions
	Creating Regions
	Drag and Drop Into the Arrange Window
	Multiple File Dragging
	Inserting Audio Files Using the Pencil Tool
	Inserting Apple Loops

	Editing Regions
	Dividing Regions
	Region Display
	Resolution
	On Zero Crossings

	Erasing Regions
	Erasing Recordings

	Copying Regions
	Creating New Regions
	Using an Existing Region More Than Once
	Making Cloned Regions Independent
	Making Multiple Copies of Regions

	Moving Audio Regions
	Moving Regions Back to Record Position

	Changing Start and End Points
	Adjusting the Grid to Zero Crossings

	Region Parameter Box
	Name
	Loop
	Delay

	The Region Anchor
	MIDI and Audio Regions Compared

	Audio Recording
	Creating Audio Tracks
	Arming Tracks
	First Method:
	Second Method:
	“Disarming” All Tracks

	Standard Recording With Count-in
	Record and Pause Mode

	Punch-In Recording
	Pre-Programmed Drop-Record
	Audio Cycle Recording
	After Recording, Please Note…
	Stereo Recordings

	Functions
	Automatic Tempo Matching
	Digital Mixdown
	No Mixdown Situation
	“Mixdown” of Regions in a Track
	Genuine Mixdown With Clipscan

	Audio Crossfades in Digital Mixdown

	Freeze
	Concept
	When to Freeze a Track
	How to Freeze a Track
	Working With Frozen Tracks
	Freeze Files
	Refresh Freeze Files



	The Environment
	Environment—Introduction
	Layers
	Opening the Environment Window

	Basic Operation
	Layers
	Switching Between Layers
	Creating Layers
	Naming Layers
	Deleting Layers
	Special Layers
	Hiding/Showing Parameters
	Hiding/Showing the Cables
	Protecting Cabling and Object Positions
	Background
	List Display

	Objects
	Creating Objects
	Deleting Objects
	Adjusting the Size of Objects
	Moving Objects
	Aligning Objects …
	Moving Objects Between Layers
	Replacing Objects
	Assigning an Object to the Selected Track

	Special Selection Commands
	Selecting All Used Instruments
	Selecting All Unused Instruments
	Selecting Cable Destination Objects
	Toggling Your Selection


	The MIDI Signal Path
	Direct Output Assignment
	Breaking the Direct Output Assignment

	Cabling
	Cabling Between Layers
	Deleting Cables
	Cable Color

	Multiple Cabling
	Multiple Inputs
	Multiple Outputs
	Special Outputs
	Cabling Serially


	Environment Objects
	Object Parameters
	Opening/Closing the Object Parameter Box
	Common Parameters
	Name
	Object Type
	Icon/Display Filter for the Instrument List
	Color

	Standard Instrument
	Multi Instrument
	Multi-Instrument Parameter Box
	Activating and Selecting Sub-Channels
	The Sub-Channel Parameter Box
	Cabling

	Multi Instrument Window
	Name and Short Name
	Program Names
	Banks

	Defining Custom Bank Selects
	Mapped Instrument
	Object Parameter Box

	GM Mixer Object
	Cha/Port
	Legend
	Bank

	Keyboard Object
	Monitor Object
	Channel Splitter Object
	Arpeggiator Object
	Arpeggiator Parameters

	Delay Line Object
	Delay Line Parameters

	Physical Input/Sequencer Input Objects
	Physical Input Object
	Sequencer Input Object

	MIDI Metronome Click
	Internal Objects
	Using Internal Objects
	Apple QuickTime

	Internal—ReWire
	Starting/Stopping the ReWire Connection
	Settings
	Reason Settings
	ReWire Behavior

	MIDI Outs
	Faders
	Audio Objects

	Faders
	Faders—Overview
	Fader Operation
	Special Functions
	Grouping Faders
	Sending Fader Values
	Resetting Fader Values

	Recording and Playback of Fader Movements
	Recording Fader Movements
	Playing Back Fader Movements

	Fader Styles
	Vertical/Mute
	Numerical
	Buttons
	Text

	Fader Functions:��MIDI Events
	Fader Functions:��Range, Val as
	Range
	Val as

	Fader Functions:��Filter
	Feedback


	Environment Exchange

	Logic’s Mixing Facilities
	Audio Mixer
	Setting Up Your Audio Mixer
	Connections

	Object Parameter Box
	Device
	Channel
	MIDI Channel


	Audio Objects in the Audio and Track Mixer
	Multiple Selection of Audio Objects
	Elements of the Audio Object
	Channel EQ
	Inserts
	Channel Strip Settings Menu

	Sends
	Post and Pre Fader Aux Sends
	Stereo Sends
	Double-Click on Send

	In/Output
	Input Selection
	Output Routing

	Pan/Balance
	Level
	Peak Hold
	Clip Detector
	Pre Fader Metering
	Adjusting the Level

	Solo/Mute
	Solo
	Mute Button

	Stereo Objects
	Creating Stereo Objects

	Track Arming
	Bounce
	Global Options in the Bounce Dialog Window
	PCM Options in the Bounce Dialog Window
	MP3 Options in the Bounce Dialog Window
	AAC Format Options
	AAC Sound Settings
	MPEG-4 Audio Compressor Window
	Burn Options


	Audio Object Types
	Track Object
	Monitoring With Effect Plug-ins

	Input Object
	Pre-Processing of Input Signals

	Audio Instrument Object
	Accessing Multiple Outputs
	Software Instrument Pitch

	ReWire
	Output Objects
	Bus Objects
	Auxiliary Object
	Aux Objects and Software Instruments With Multiple Outputs


	Track Mixer
	Display Modes
	Track Filter
	Track Filter Switching Techniques

	View Options
	Folders and the Track Mixer
	General Tips for Using the Track Mixer
	Send All Mixer Data
	Track Selection When Playing or Recording


	MIDI Channel Strips
	Operation
	Saving the Mixer Settings
	Extended GM, GS, and XG Functions
	Reset Button

	Controls
	Bank
	Program
	Volume
	Mute
	Pan
	Other Controllers



	Automation
	Automation—Introduction
	Track Based Automation
	Region Based Automation

	Track Based Automation
	Display
	Zooming of Individual Tracks
	Choosing the Parameter to be Displayed
	Context Sensitive Display
	Viewing Multiple Parameters

	Automation Modes
	Off
	Read
	Touch
	Latch
	Write
	MIDI
	Switching Automation Modes for All Channels Simultaneously

	Writing Track Automation Data
	Behavior in Stop Mode

	Deleting Track Automation Data
	Editing of Track Automation Data in an Event List
	Track Automation Folder

	Automation Quick Access
	Setting Up Automation Quick Access


	Region Based Automation
	Recording of MIDI Automation Data
	Drawing MIDI Automation Data
	Editing MIDI Automation Data

	Hyper Draw
	Hyper Draw for Tracks
	Hyper Draw for Regions
	Hyper Draw Functions
	Arrow Tool
	Pen Tool
	Eraser Tool
	Value Display in Hyper Draw

	Activating Region Hyper Draw
	Event Type
	MIDI Channel
	Hyper Draw—Note Velocity
	Deactivating Hyper Draw


	Conversion of Automation Data
	Converting Automation Data
	Moving from Region Data to Track Automation
	Moving from Track Automation to Region Data


	Global Tracks
	Display Options for Global Tracks
	How to Create, Move, Copy, and Delete Global Events
	Creating Global Events
	Selecting and Moving Global Events
	Copying Global Events
	Deleting Global Events

	Tempo Track
	Insertion of Tempo Changes
	Deleting Tempo Changes
	Continuous Transition Between Different Tempi
	Moving and Copying Tempo Changes
	More About the Tempo Track

	Signature Track
	Handling Signature Changes
	Cutting Bars

	Transposition Track
	Handling Events in the Transposition Track

	Video Track

	Audio Window
	Audio Window—Introduction
	Opening the Audio Window

	Layout
	Overview
	Zoom Functions
	The Mode Buttons
	Link
	Monitoring
	Region Cycle
	Selecting the Audio Output for Monitoring


	Display
	The Audio List
	Hiding and Showing Regions
	Displaying the Lengths of the Regions
	Displaying Information About Audio Files

	Sorting Audio Files and Regions
	Sorting Audio Files
	Sorting Regions

	The Waveform Display Outside the Region
	Overview Calculation
	Automatic Overview Calculation
	Starting Overview Calculation Manually
	Controlling the Overview Calculation


	Operation
	Selection Techniques
	Audio Files
	Audio Files and Regions

	Edit Commands
	Cut
	Copy
	Paste
	Clear
	Undo

	Regions
	Creating a Region
	Deleting a Region
	Altering the Boundaries of a Region
	Moving the Anchor
	Snapping to Zero Crossings
	Making Fine Adjustments
	Protecting the Region Parameters

	Renaming Audio Files and Regions

	File Administration
	Record File
	Defining the Record Path
	When You Choose the Path Remember …
	When You Enter the Recording Time Remember…

	Adding Audio Files
	Audio File Selector
	Drag & Drop Using Audio Files
	Removing Audio Files
	MP3 Import

	Deleting Audio Files
	Further File Functions
	Saving a Region as an Individual Audio File
	Making Backups
	Copying Audio Files
	Moving Audio Files

	File Conversion and Exchange
	Audio File Format Conversion
	Exchanging Audio Files Between Mac and PC

	Split and Interleaved Stereo Formats
	Special Features of “Split” Stereo Files
	Converting Different Split Stereo Formats
	Manual Stereo Conversion
	Convert to AIFF Stereo

	Other Functions Involving Audio Files
	Reassigning Audio Files (Update File Information)
	What to Do if Logic Cannot Find an Audio File


	Further Options
	Setting the Sample Rate
	Varipitch/Varispeed Synchronization


	Audio Drivers
	The Audio Hardware and Drivers Dialog
	Core Audio
	Enable
	Driver
	I/O Buffer Size
	Recording Delay
	Max. Number of Audiotracks
	Universal Track Mode
	Larger Disc Buffer
	24 Bit Recording
	Software Monitoring
	Process Buffer Range
	ReWire Behavior


	Audio Engine
	Realtime Sample Rate Conversion

	Sample Editor
	Sample Editor—Introduction
	Opening the Sample Edit Window
	Elements of the Sample Edit Window

	Display
	Waveform Overview
	Functions in the Overview

	Window Functions
	Catch Mode
	Link Mode

	The Detailed Waveform Display
	Display Scale
	X and Y Axis Scales
	Absolute and Relative Time
	Display Waveform as Sample Bits


	The Sample Edit Window in Use
	Monitoring Sample Playback
	Monitoring Sample Playback
	Playback From the Overview
	Playing the Current Selection
	Playback From a Certain Position
	Checking the Position of the Anchor
	Cycle Playback Mode
	Playing Regions

	GoTo Commands
	Making Selections
	Selecting the Whole Audio File
	Manual Selection
	To Change the Boundaries of a Selection
	Moving a Selection
	The Selection Parameter Box

	The Relationship Between Selections and Regions
	Selecting the Region
	Turning a Selection Into a Region
	Creating New Regions
	Editing Regions in the Sample Editor
	Protecting the Anchor Point

	Search Zero Crossings
	Editing Commands
	Cut
	Copy
	Paste
	Clear
	Undo

	Sample Editor Undo Preferences
	Backup Copies
	Automatic Backups
	Manual Backups

	Update Arrange Position

	Functions
	Normalize
	Change Gain
	Fade In/Out
	Fade In
	Fade Out

	Silence
	Invert/Reverse
	Invert
	Reverse

	Trim
	Remove DC Offset
	Search Peak/Silence
	Search Peak
	Search Silence

	Adjust Tempo…

	Digital Factory
	Operation
	Options

	Time and Pitch Machine
	Opening the Time and Pitch Machine
	Parameters
	Free Transposition
	Classic (Correlated) Transposition
	Audio Algorithms
	Using the Graphic Display

	Time Machine—Technical Background
	The Technology of the Time Machine

	Audio Energizer
	Opening the Audio Energizer
	Parameters

	Sample Rate Converter
	Opening the Sample Rate Converter
	Parameters



	Event List
	Using the Event List
	Opening the Event List
	Structure

	Display
	Operation
	Scrolling
	Selection
	Selection Techniques
	Special Selection Functions

	Event Editing
	Adding Events
	Duplicating Events
	Pasting from the Clipboard
	Moving Events

	Altering Values
	Altering the Values of Several Events
	Numerical Value Input


	Event List Structure
	… on the Event Level
	Position
	Status
	Cha
	Num, Val
	Length/Info

	… on Arrange Level
	Position
	Name
	Track
	Length


	Event Type Structure
	Note Events
	Mapped Instrument Notes

	Program Change Events
	Val
	Num

	Pitchbend Events
	Num
	Val
	Length/Info

	Control Change Events
	Num
	Val

	Aftertouch Events
	Num
	Val

	Poly Pressure Events
	Num
	Val

	SysEx Events
	SysEx Data in Hex Format


	Tips for Numerical Input
	Event Float Window

	Hyper Editor
	Hyper Editor—Introduction
	Usage
	Opening the Hyper Editor
	Structure

	Hyper Sets
	Selecting a Hyper Set
	Creating a Hyper Set
	Create GM Drum Set
	Naming the Hyper Set
	Clearing a Hyper Set

	Event Definitions
	Selecting the Event Definition
	Creating Event Definitions
	Creating an Event Definition
	Automatically Creating Event Definitions
	Creating Several Event Definitions Automatically
	Deleting an Event Definition
	Sorting Event Definitions

	Copy/Convert Event Definitions
	Hyper Sets: Copying Event Definitions
	Converting Event Definitions

	Event Definition Parameter Box
	Name of the Event Definition
	Display and Editing Grid
	Beam Width
	Beam Display
	Delay
	Length of Notes to Be Added
	Event Status
	MIDI Channel
	First Data Byte

	Making Different Definitions Simultaneously
	Hi Hat Mode

	Operation
	Grid
	Selection Techniques
	Moving and Copying Events

	Altering Event Values
	Altering Several Events
	Setting Up a Manual Series
	Setting Up a Linear Series
	Linear Series in Sections

	Adding Individual Events
	Fix Value



	Matrix Editor
	Matrix Editor—Introduction
	Opening the Matrix Editor

	Display
	Pitch/Note Names
	Position
	Velocity
	Chord Recognition

	Editing Notes
	Selection Techniques
	Quick Opening of Event or Score Editor
	Creating Notes
	Duplicating Notes

	Deleting Notes
	Moving Notes
	Setting a Finer Grid

	Copying Notes
	Altering Length
	Note Start Edit
	Altering the Lengths of Several Notes Simultaneously
	Making Notes the Same Length
	What Tools to Use

	Altering Velocity
	Altering the Velocity of Several Notes


	Hyper Draw in the Matrix Window

	Score Editor
	Score Editor—Introduction
	Opening the Score Edit Window

	Elements of the Score Edit Window
	Along the Left-Hand Side:
	Along the Top Margin:
	The Main Working Area:
	Positioning the SPL Directly in the Score

	Notation Concept
	Basics
	Staff Display…
	…in Relation to the Position and Length of MIDI Regions in the Arrange Window

	Aliases in the Score Display
	Alias Editing

	Basic Elements for Score Display
	Instrument Sets
	Score Styles
	Text Styles
	Display Parameter box
	Song Settings
	Note Attributes


	General Appearance
	View Menu
	Colors
	Page Edit
	Print View
	Explode Folders
	Explode Polyphony
	Scroll in Play
	Part Box
	Toolbox
	SMPTE Time Ruler
	Parameters
	Instrument Names
	Page Rulers
	White Background
	Hyper Draw

	Other Options
	Adjusting the Borders Between the Different Areas
	Parameter Boxes
	The Main Working Area


	Input Methods in the Score Window
	Score Display Options—a Survey
	Printout
	Using External Symbol Fonts for Display and Printout of Notes and Symbols

	Graphic Export
	PICT Export Using the Camera Tool

	Realtime MIDI Recording
	Step Input
	Mouse Input
	Input
	MIDI Channel and Velocity of Inserted Objects
	Insert Quantization
	Simultaneous Input of Objects Into Several Regions
	Exact Graphic Position of Symbols
	Hyper Draw in the Score Edit Window

	The Part Box
	Selecting and Inserting Part Box Objects
	Using Floating Palettes

	Object Selection by Key Commands
	Display Size of Inserted Objects
	Notes
	Allowing Diatonic Input Only

	Ties
	Changing the Way Notes With Ties Are Displayed

	N-Tuplets
	Definition of Previously Recorded Notes As N-Tuplets
	N-Tuplet Input With the Mouse
	Changing or Deleting Existing Tuplets
	Fast Input of Several Identical N-Tuplets
	Editing Automatically Displayed Triplets
	“Artificial” N-Tuplets to Bypass Display Quantization

	Grace Notes, Independent Notes
	Creating Independent Notes:

	Sustain Pedal Symbols
	Clefs
	Octave Settings

	Dynamic Symbols
	Note Heads
	Invisible Note Heads

	Symbols Attached to Notes
	MIDI Meaning
	Quick Assignment With Key Commands
	Inserting Independent Symbols

	Jazz Symbols
	Slurs, Crescendi
	Input
	Fast Slur and Crescendo Input With Key Commands
	Altering the Shape
	Changing the Position
	Change of Length
	Particular Attributes of Certain Symbols
	Precise Positioning

	Key Signatures
	Deleting a Key Signature Change
	Moving and Copying Key Signature Changes

	Time Signatures
	Compound Time Signatures
	Invisible Time Signatures
	Editing Time Signatures

	Repeat Signs and Bar Lines
	Moving, Deleting
	Invisible Bar Lines
	1st and 2nd Endings

	Trills, Tremolo, and so on
	Rests, Bar Repeat Signs
	Automatic Rest Display
	Manually Inserted Rests
	Multi Bar Rests
	Bar Repeat Signs

	Text Objects, Chord Symbols
	D.S., D.C., Segno, Coda Signs
	Tempo and Swing Symbols

	Move, Copy, and Paste
	Moving/Copying With the Mouse
	Positioning Grid
	Moving and Copying Several Objects at Once

	Via the Clipboard
	Paste Multiple
	Automatic Insert Quantization
	Paste at Original Position/Paste Multiple at Original Position

	Repeat Objects

	Editing or Deleting Notes and Symbols
	Editing With Tools
	Velocity Tool
	Quantize Tool
	Layout Tool
	Sizing Tool

	Changes in the Event Parameter Box
	Notes
	Symbols
	Additional Parameters for Text Objects

	Changing Several Selected Objects Simultaneously
	Relative Change (Preserving Differences)
	Absolute Change (All Values Set Equal)

	Deleting Objects in the Score Editor

	The Display Parameter Box
	Settings
	Different Settings Within the Same Staff
	Default Settings for New Sequences
	Simultaneously Changing the Settings of Several Sequences

	Rhythmic Interpretation of Sequences
	Name and Style
	Title Line: Name of the Sequence
	Style

	Qua—Display Quantization
	Automatic Display of Triplets
	Default Setting
	Swing Notation

	Interpretation
	Syncopation
	No Overlap
	Max. Dots

	Score Styles
	Basics
	The Concept of Score Styles
	Assigning Score Styles

	Predefined Styles
	Working With Score Styles
	Assigning Score Styles to Sequences
	Automatic Score Style Assignment for New Sequences

	The Score Style Window
	Link Button
	Toolbox
	Name Box/Style Selector
	Parameter Groups
	List View

	Handling Score Styles
	Copying Score Styles Between Songs
	Deleting Score Styles
	Creating New Score Styles

	Editing Single Staff Score Styles
	Name
	Space
	Size
	Clef
	Trans
	Key
	Rest
	Stem
	Tie
	Tupl
	Beam
	Color

	Editing Two-Stave Score Styles
	Number of Staves
	Brackets and Bar Line Connections

	Voice Separation Method
	Voice Assignment When Using Mouse Input

	Editing Single-Staff Polyphonic Styles
	Input and Recording of Polyphonic Voices
	Via MIDI
	Mouse Input

	Single-Staff Score Style With Optional Polyphony
	Multi-Stave Polyphonic Score Styles
	Cross Staff Beaming
	Required Settings
	The Procedure in Detail
	Stem Direction
	Rest Display

	Copying Voices or Staves
	Copying Voices or Staves Into Other Score Styles
	Deleting Voices in a Score Style

	Drum Notation With Mapped Score Styles
	The Basics of Drum Notation With Logic
	Different Drum Maps Within the Same Song
	Mapped Score Styles
	Creating and Editing Your Own Mapped Score Styles
	Using Mapped Score Styles for Non-Mapped Instruments


	Note Attributes
	Reset Note Attributes
	List of All Note Attributes

	Instrument Sets and Score Display Levels
	Display Levels
	Explode Folders
	Changing Between Single Sequence and Full Score Display
	Special Cases Concerning Score Display

	Instrument Sets
	The Instrument Set Window
	Instrument
	Full Name
	Short Name
	Brackets and Bar Lines
	Name of Instrument Set
	Scaling, Format

	Importing Instrument Sets From Other Songs
	Additional Information on Instrument Sets
	Relationship to Display Levels
	New Instrument Sets for Selected Instruments
	Automatic Display of Selected Instruments when Opening the Score Window
	Different Instruments Using the Same Sound

	Full Score and Part Layout
	Part Extraction (“Instrument Filter”)
	Scaling Parameter for Instrument Sets
	Separate Layout Options for Parts and Score

	Line Breaks
	Restriction to Local Movement
	Combining Max.Bars/Line and Line Breaks

	Local Margins
	Deleting All Line Breaks and Local Margins


	Song Settings for Score Display
	Importing All Score Settings
	Global Format
	Top/Bottom/Left/Right Margin
	Add Bracket Space
	Alternating Margins
	Header Space
	Line Distance
	Max. Bars/Line
	Constant/Proportional Spacing: Note Distance
	Slash Spacing: Spacing of Beat Slashes
	Default Pedal Position
	Beaming Slant Factor/Min. Slant/Max. Slant
	“Open” Single Staves
	Justify Last Staff
	Hide Muted Sequences/Tracks
	Show Alias
	Allow Alias Editing
	Alternate Repeat Symbols
	Chord Symbol Language

	Numbers & Names
	Page Numbers
	Bar Numbers
	Instrument Names

	Clefs & Signatures
	For Clefs:
	For Key Signatures:
	For Time Signatures/Barlines
	Octave Symbols

	Extended Layout Parameters
	Guitar Tablature
	Assign
	Some More Information Concerning Tablature Notation in Logic:

	MIDI Meaning
	How It Works

	Color

	Score Preferences
	Dashed Song Position Line
	Show Sequence Selection Colored
	Fast (Lower Resolution) Curves on Screen
	Display All Distance Values in Inches
	Use external Symbol Font (if Available)/Only for Printout
	Open Floating Palettes
	Double Click Note to Open…
	Graphic Export Resolution, Graphic Export to…, PICT File Creator ID
	Auto Split Notes at…

	Text: Input and Display
	Text Styles
	Text Styles
	The System Text Styles
	Creating Additional Text Styles
	Changing the Same Font in Several Text Styles Simultaneously
	Font References
	Music Fonts as Fonts for Text Styles

	Text Input
	Simultaneous Text Input Into Several Staves

	Editing Text
	Deleting Text Objects
	Copying Text Objects

	Global Text
	Input of Global Text
	Positioning of Global Text

	Automatic Text Objects
	An Automatic Text Example

	Lyrics
	Some Hints for Working With Lyrics


	Chord Symbols
	Inserting Chord Symbols
	Handling Chord Symbols
	Fast Input of Several Chord Symbols in One Process
	Enharmonic Change of Chord Symbols
	Transposition of Chord Symbols
	German Chord Symbols: “H” Instead of “B”
	Copying Chord Symbols
	Precise Graphical Position of Chord Symbols
	Rhythm Section Parts



	The Transform Window
	Transform Window—Introduction
	Usage
	Opening the Transform Window
	Effective Range
	Purpose of the Transform Window
	Actions
	Display


	Transformation
	Mode
	Apply Operations to selected Events
	Apply Operations & Delete unselected Events
	Delete selected Events
	Copy selected Events & Apply Operations

	Event Parameters
	Position
	Status
	Channel
	-1-/Pitch
	-2-/Vel
	Length
	Subposition

	Conditions
	Conditions for the Status
	Conditions for the values of Position, Cha, -1-/Pitch, -2-/Vel, Length, and Subposition
	Exchanging Parameter Values

	Operations
	Status Operations
	Operations on the Values of Position, Cha, -1-/Pitch, -2-/Vel, Length, Subposition


	Parameter Sets
	Presets
	Recalling Presets


	Tempo
	Display and Functions
	Tempo Display
	Tempo Track
	Recording Tempo Changes
	Adjusting the Tempo to Fit Regions

	Tempo List Editor
	Other Functions


	Synchronization
	Functions
	Switching on External Sync
	Recording With External Synchronization
	Incoming MIDI Time Code Display
	MTC Interpretation
	Receiving MIDI Clock/SPP

	Synchronization Window
	Overview
	General
	Audio
	MIDI
	Unitor

	General
	Sync Mode
	Auto Enable external Sync
	Frame Rate
	Auto Detect Format of MTC
	Validate MTC
	SMPTE Offset

	Audio
	MTC [fps]
	Sample Rate (Hz)
	Deviation (ms)
	Audio Sync Mode

	MIDI
	Transmit MIDI Clock
	Transmit MIDI Clock Delay
	Transmit MTC (MIDI Time Code)
	Transmit MMC (MIDI Machine Control)
	Listen to MMC Input

	Unitor
	SMPTE Mode
	SMPTE Type
	Freewheel
	TV Format
	VITC Line 1, VITC Line 2
	Visible Time Code Display


	Bar Ruler—Time Ruler
	Positioning Bars to Frames

	Sync Problems and Solutions
	Faulty Digital Synchronization
	Faulty Synchronization to an External Tape Machine
	If MIDI and Audio Are Not Synchronized
	If MIDI and SMPTE Are Not Synchronized


	Video
	Synchronizing QuickTime Movies
	Opening a Movie
	Working With Movies
	Optimal Image Size
	Options
	Synchronization Methods
	Video to song adjust


	Song Settings and Preferences
	Saving of Song Settings and Preferences
	Song Settings
	Synchronization Settings
	Metronome Settings
	MIDI Click Settings
	Klopfgeist Parameters
	Other Settings

	Recording Settings
	General
	MIDI

	Tuning Settings
	About Alternate Tunings
	The Comma
	About Equal Temperament
	Software Instrument Pitch

	MIDI Settings
	General: Miscellaneous
	General: MIDI Thru
	General: Software Instruments
	Input Filter
	Chase

	Score Settings

	Preferences
	Initializing the Preferences…
	Global Preferences
	Global Preferences: Song Handling
	Global Preferences: Editing
	Global Preferences: Cycle
	Global Preferences: Catch
	Global Preferences: Caps Lock Keys

	Audio Preferences
	Audio Preferences: General
	Audio Preferences: Drivers
	Audio Preferences: Display
	Audio Preferences: Sample Editor
	Audio Preferences: MP3
	Audio Preferences: Reset

	MIDI Preferences
	MIDI Preferences: General
	MIDI Preferences: Sync
	MIDI Preferences: Reset Messages

	Display Preferences
	Interface Language
	Display Preferences: General
	Displays: Display Middle C as:
	Display Preferences: Other

	Score Preferences
	Video Preferences
	Video Song Settings

	Automation Preferences
	Control Surfaces Preferences


	Control Surface Support
	Installation
	Control Surface Plug-ins
	The Setup Window
	Rebuild Defaults

	The Install Window
	Selecting the Models
	Manually Adding Devices
	Done


	Setup Window Parameters
	Device Parameters
	Special Parameters
	Display Parameters
	Track/Channel Parameters
	Send/Plug-in Parameters
	Other Parameters


	Control Surface Preferences
	General
	Help Tags

	Customizing Control Surfaces
	Shortcuts for Defining Multiple Assignments

	The Controller Assignments Window

	Glossary
	Index

